Contenu | Rechercher | Menus

Annonce

DVD, clés USB et t-shirts Ubuntu-fr disponibles sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 29/09/2021, à 16:49

Kitetkat06

[RESOLU] Le Bluethooth ne s'active plus

Bonjour

Après avoir fait quelques recherches, je pose ma question ici en espérant être sur la bonne section.

Je ne parviens plus à avoir ma souris en Bluethooth et je ne sais pour quelle raison.
L'activation ne fais aucun effet...
Si vous avez une piste à me suggérer.

PS: Ubuntu 20.04

Merci

Kitetkat06

Dernière modification par Kitetkat06 (Le 29/09/2021, à 17:45)

Hors ligne

#2 Le 29/09/2021, à 16:51

xubu1957

Re : [RESOLU] Le Bluethooth ne s'active plus

Bonjour,


Il faut fournir, en te servant du Retour utilisable de commande :

uname -a; lspci -nnk | grep -iA3 net; lsusb; dmesg | grep -i bluetooth; dmesg | grep -i firmware; lsmod | grep bluetooth
dpkg -l | grep blue
rfkill list all

et avec un terminal dont au préalable la fenêtre est élargie, afin de ne pas tronquer les lignes :

sudo service bluetooth status

Méthode détaillée :

cqfd93 a écrit :

Bonjour,

Entrer des commandes dans un terminal et donner le résultat - Voilà la marche à suivre :

  1. Ouvre le terminal avec ctrl-alt-t

  2. Sélectionne la commande voulue avec un triple clic (ça sélectionne toute la ligne, même la fin si on ne la voit pas)

  3. Colle-la dans le terminal avec un clic molette, valide avec Entrée

  4. Sélectionne et copie tout ce que te dit le terminal depuis la commande jusqu'à la dernière ligne incluse

  5. Clique sur le <> de l'éditeur de message

    1530289742.png

  6. Colle là où se trouve le curseur (entre le ] et le [)

  7. Refais toutes les étapes depuis la 2 pour les autres commandes.


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 20.04 LTS - Lenovo T410 -18.04.1 LTS Toshiba Satellite A300  Membre de Linux-Azur

Hors ligne

#3 Le 29/09/2021, à 17:01

Kitetkat06

Re : [RESOLU] Le Bluethooth ne s'active plus

Merci pour la réponse.
"uname -a; lspci -nnk | grep -iA3 net; lsusb; dmesg | grep -i bluetooth; dmesg | grep -i firmware; lsmod | grep bluetooth"

Linux edxpeditiondx-Aspire-A517-51G 5.11.0-37-generic #41~20.04.2-Ubuntu SMP Fri Sep 24 09:06:38 UTC 2021 x86_64 x86_64 x86_64 GNU/Linux
02:00.1 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [10ec:8168] (rev 12)
	Subsystem: Acer Incorporated [ALI] RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller [1025:121e]
	Kernel driver in use: r8169
	Kernel modules: r8169
03:00.0 Network controller [0280]: Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter [168c:0042] (rev 31)
	Subsystem: Lite-On Communications Inc Qualcomm Atheros QCA9377 802.11ac Wireless Network Adapter [11ad:08a6]
	Kernel driver in use: ath10k_pci
	Kernel modules: ath10k_pci
04:00.0 Non-Volatile memory controller [0108]: Sandisk Corp Device [15b7:5009] (rev 01)
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 007: ID 0408:a060 Quanta Computer, Inc. HD Webcam
Bus 001 Device 038: ID 3151:1002 YICHIP Wireless Device
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
[  444.934095] Bluetooth: Core ver 2.22
[  444.934130] Bluetooth: HCI device and connection manager initialized
[  444.934133] Bluetooth: HCI socket layer initialized
[  444.934135] Bluetooth: L2CAP socket layer initialized
[  444.934138] Bluetooth: SCO socket layer initialized
[    0.103321] Spectre V2 : Enabling Restricted Speculation for firmware calls
[    0.156423] ACPI: [Firmware Bug]: BIOS _OSI(Linux) query ignored
[    6.607283] i915 0000:00:02.0: [drm] Finished loading DMC firmware i915/kbl_dmc_ver1_04.bin (v1.4)
[    6.927531] ath10k_pci 0000:03:00.0: firmware ver WLAN.TF.2.1-00021-QCARMSWP-1 api 6 features wowlan,ignore-otp crc32 42e41877
[    7.738562] [Firmware Bug]: ACPI(PXSX) defines _DOD but not _DOS
bluetooth             638976  0
ecdh_generic           16384  1 bluetooth
dpkg -l | grep blue
ii  bluez                                      5.53-0ubuntu3.3                       amd64        Bluetooth tools and daemons
ii  bluez-cups                                 5.53-0ubuntu3.3                       amd64        Bluetooth printer driver for CUPS
ii  bluez-obexd                                5.53-0ubuntu3.3                       amd64        bluez obex daemon
ii  gir1.2-gnomebluetooth-1.0:amd64            3.34.3-0ubuntu1                       amd64        Introspection data for GnomeBluetooth
ii  gnome-bluetooth                            3.34.3-0ubuntu1                       amd64        GNOME Bluetooth tools
ii  libbluetooth3:amd64                        5.53-0ubuntu3.3                       amd64        Library to use the BlueZ Linux Bluetooth stack
ii  libgnome-bluetooth13:amd64                 3.34.3-0ubuntu1                       amd64        GNOME Bluetooth tools - support library
ii  pulseaudio-module-bluetooth                1:13.99.1-1ubuntu3.11                 amd64        Bluetooth module for PulseAudio sound server

Voici le status sur le Bluetooth

bluetooth.service - Bluetooth service
     Loaded: loaded (/lib/systemd/system/bluetooth.service; enabled; vendor pre>
     Active: inactive (dead)
       Docs: man:bluetoothd(8)

Je l'active mais rien ne se passe...

rfkill list all
0: acer-wireless: Wireless LAN
	Soft blocked: no
	Hard blocked: no
1: acer-bluetooth: Bluetooth
	Soft blocked: no
	Hard blocked: no
2: phy0: Wireless LAN
	Soft blocked: no
	Hard blocked: no

https://www.expedition-dx.fr/Capture%20 … -04-52.png


Modération : merci d'utiliser des images de petite taille (300x300) ou des miniatures pointant sur ces images.

Dernière modification par cqfd93 (Le 29/09/2021, à 17:27)

Hors ligne

#4 Le 29/09/2021, à 17:06

xubu1957

Re : [RESOLU] Le Bluethooth ne s'active plus

Deux retours sur quatre, c'est pas assez ! tongue

_ _ _

> [Tuto] Pas de Bluetooth ? Quelques solutions

Dernière modification par xubu1957 (Le 29/09/2021, à 17:15)


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 20.04 LTS - Lenovo T410 -18.04.1 LTS Toshiba Satellite A300  Membre de Linux-Azur

Hors ligne

#5 Le 29/09/2021, à 17:15

Kitetkat06

Re : [RESOLU] Le Bluethooth ne s'active plus

actualise tout y est cette fois

Hors ligne

#6 Le 29/09/2021, à 17:16

xubu1957

Re : [RESOLU] Le Bluethooth ne s'active plus

Tente :

sudo /etc/init.d/bluetooth restart

Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 20.04 LTS - Lenovo T410 -18.04.1 LTS Toshiba Satellite A300  Membre de Linux-Azur

Hors ligne

#7 Le 29/09/2021, à 17:22

Kitetkat06

Re : [RESOLU] Le Bluethooth ne s'active plus

Aucune réaction

Juste  pour infos il y a eu une mise à jour (du noyau ???)

Hors ligne

#8 Le 29/09/2021, à 17:26

xubu1957

Re : [RESOLU] Le Bluethooth ne s'active plus

Essaye :

sudo modprobe -r usbhid

> Logitech M185 Wireless Mouse - Suspend Woes

_ _ _

Mises à jour des noyaux > ubuntuupdates.org


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 20.04 LTS - Lenovo T410 -18.04.1 LTS Toshiba Satellite A300  Membre de Linux-Azur

Hors ligne

#9 Le 29/09/2021, à 17:28

Kitetkat06

Re : [RESOLU] Le Bluethooth ne s'active plus

Ce n'est pas une Logitech mais une belle chinoiserie, qui fonctionne bien mais cela ne vient pas de cela.

Hors ligne

#10 Le 29/09/2021, à 17:42

Kitetkat06

Re : [RESOLU] Le Bluethooth ne s'active plus

Re

Bon après un nouveau démarrage c'est revenu.

Merci pour ton aide.

Je comprend pas le soucis mais c'est de nouveau ok
Je viens de refaire une mise à jour et ensuite éteint et redémarrer

Merci

Kitetkat06

Dernière modification par Kitetkat06 (Le 29/09/2021, à 17:43)

Hors ligne

#11 Le 29/09/2021, à 18:13

xubu1957

Re : [RESOLU] Le Bluethooth ne s'active plus

Montre aussi d'éventuels paquets cassés :

dpkg -l | grep -v ^ii

Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 20.04 LTS - Lenovo T410 -18.04.1 LTS Toshiba Satellite A300  Membre de Linux-Azur

Hors ligne

#12 Le 30/09/2021, à 11:09

Kitetkat06

Re : [RESOLU] Le Bluethooth ne s'active plus

Salut

Résultat de cette commande

dpkg -l | grep -v ^ii
Souhait=inconnU/Installé/suppRimé/Purgé/H=à garder
| État=Non/Installé/fichier-Config/dépaqUeté/échec-conFig/H=semi-installé/W=attend-traitement-déclenchements
|/ Err?=(aucune)/besoin Réinstallation (État,Err: majuscule=mauvais)
||/ Nom                                        Version                               Architecture Description
+++-==========================================-=====================================-============-======================================================================================================
rc  fonts-wqy-zenhei                           0.9.45-7ubuntu1                       all          "WenQuanYi Zen Hei" A Hei-Ti Style (sans-serif) Chinese font
rc  libreoffice-base-core                      1:6.4.7-0ubuntu0.20.04.1              amd64        office productivity suite -- shared library
rc  libreoffice-calc                           1:6.4.7-0ubuntu0.20.04.1              amd64        office productivity suite -- spreadsheet
rc  libreoffice-draw                           1:6.4.7-0ubuntu0.20.04.1              amd64        office productivity suite -- drawing
rc  libreoffice-impress                        1:6.4.7-0ubuntu0.20.04.1              amd64        office productivity suite -- presentation
rc  libreoffice-writer                         1:6.4.7-0ubuntu0.20.04.1              amd64        office productivity suite -- word processor
rc  linux-image-5.8.0-43-generic               5.8.0-43.49~20.04.1                   amd64        Signed kernel image generic
rc  linux-modules-5.8.0-43-generic             5.8.0-43.49~20.04.1                   amd64        Linux kernel extra modules for version 5.8.0 on 64 bit x86 SMP
rc  linux-modules-extra-5.8.0-43-generic       5.8.0-43.49~20.04.1                   amd64        Linux kernel extra modules for version 5.8.0 on 64 bit x86 SMP
rc  tomatoes                                   1.55-9build1                          amd64        I Have No Tomatoes - tomato smashing game
rc  vim-gtk3                                   2:8.1.2269-1ubuntu5.3                 amd64        Vi IMproved - enhanced vi editor - with GTK3 GUI
rc  vim-gui-common                             2:8.1.2269-1ubuntu5.3                 all          Vi IMproved - Common GUI files
rc  vim-runtime                                2:8.1.2269-1ubuntu5.3                 all          Vi IMproved - Runtime files

Hors ligne

#13 Le 30/09/2021, à 11:11

xubu1957

Re : [RESOLU] Le Bluethooth ne s'active plus

Bonjour,

Pour nettoyer :

Le 11/02/2017, moko138 a écrit :

Pour supprimer tous ces fichiers de configuration devenus sans objets et marqués "rc", et uniquement ces fichiers, exécute :

dpkg -l | awk '/^rc/{print $2}' | xargs -r sudo dpkg -P

Pour info, les précisions de nany, pour la commande de nettoyage et une possibilité d'automatisation.


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 20.04 LTS - Lenovo T410 -18.04.1 LTS Toshiba Satellite A300  Membre de Linux-Azur

Hors ligne

#14 Le 30/09/2021, à 11:38

Kitetkat06

Re : [RESOLU] Le Bluethooth ne s'active plus

Merci xubu1957

Voilà c'est fait ...

Hors ligne

#15 Le 30/09/2021, à 11:45

xubu1957

Re : [RESOLU] Le Bluethooth ne s'active plus

Et au cas où :

Donne ce retour, pour les permissions :

moko138 a écrit :

Merci de montrer :

echo -e "\n\tNombre d'éléments de /home/moi ne m'appartenant pas :"; find ~ \( ! -user $USER -o ! -group $USER \) | wc -l

Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 20.04 LTS - Lenovo T410 -18.04.1 LTS Toshiba Satellite A300  Membre de Linux-Azur

Hors ligne

#16 Le 30/09/2021, à 11:50

Kitetkat06

Re : [RESOLU] Le Bluethooth ne s'active plus

Résultat...

Nombre d'éléments de /home/moi ne m'appartenant pas :
204

Et cela veut dire quoi ?

Hors ligne

#17 Le 30/09/2021, à 11:58

xubu1957

Re : [RESOLU] Le Bluethooth ne s'active plus

Pour corriger :

sudo find ~ -xdev \( ! -user $USER -o ! -group $USER \) -exec chown -ch $USER:$USER "{}" \;

Pour les permissions, tu as dans ce message > les explications de moko138, et :

Le 16/11/2021, nany a écrit :

JAMAIS de sudo gedit, malheureux !

gedit admin:///lib/udev/rules.d/60-iscan.rules

J’ai édité mon message précédent (...) pour mettre un lien vers une page de la doc.
_ _ _

D’une manière générale, il ne faut pas lancer d’applications graphiques avec sudo sous peine de changements possibles de la propriété de certains fichiers dans le home.
Il faut utiliser pkexec (policykit §4) ou, avec gedit par exemple, le chemin canonique comme dans la page que j’ai mise en lien dans mon précédent message.

   _ _ _

Diverses évolutions de la commande réparatrice :

Le 01/12/2020, moko138 a écrit :

Vérification faite, la commande en #66 est opérationnelle.

/!\  À reporter dans vos mémos, à la place du sudo chown -R $USER:$USER /home/$USER habituel :

Exécuter depuis la session normale (pas en root ni en session live) :

find ~ -xdev -iname \**\* -exec bash -c 'sudo chown -c $USER:$USER "{}"' \;

commande à copier-coller telle quelle.

Correction de la commande corrigée :

Le 27/06/2021 à 6:41, nany a écrit :

Bonjour,

moko138 a écrit :
find ~ -xdev -iname \**\* -exec bash -c 'sudo chown -c $USER:$USER "{}"' \;
find ~ -xdev -name "*" -exec sudo chown -ch $USER:$USER "{}" \;

> /viewtopic.php?pid=22467873#p22467873

_ _ _

La commande informative après amélioration du 13/11/2021 :

echo -e "\nNombre d'éléments de /home/moi ne m'appartenant pas : $(sudo find ~ \( ! -user $USER -o ! -group $USER \) | wc -l)"

Dernière modification par xubu1957 (Le 30/11/2021, à 11:23)


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 20.04 LTS - Lenovo T410 -18.04.1 LTS Toshiba Satellite A300  Membre de Linux-Azur

Hors ligne