Contenu | Rechercher | Menus

Annonce

DVD, clés USB et t-shirts Ubuntu-fr disponibles sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 12/05/2021, à 11:23

Balilaï

Paramétrage de TLP-UI

Bonjour à tous,

J’essaie désespérément de paramétrer TLP-UI sur les deux portables de la maison dans l'espoir d'économiser les batteries dans la durée.
Le mien : un MSI sous Ubuntu Mate 21.4

System:
  Kernel: 5.11.0-17-generic x86_64 bits: 64 compiler: gcc v: 10.2.1 
  Desktop: MATE 1.24.2 Distro: Ubuntu 21.04 (Hirsute Hippo) 
Machine:
  Type: Laptop System: Micro-Star product: Bravo 17 A4DDR v: REV:1.0 
  serial: <filter> 
  Mobo: Micro-Star model: MS-17FK v: REV:1.0 serial: <filter> 
  UEFI: American Megatrends v: E17FKAMS.116 date: 07/10/2020 
Battery:
  ID-1: BAT1 charge: 41.0 Wh condition: 52.8/51.3 Wh (103%) 
  model: MSI Corp. MS-17FK status: Unknown 
  Device-1: hidpp_battery_0 model: Logitech Wireless Mouse M280/320/275 
  charge: 55% (should be ignored) status: Discharging 
CPU:
  Info: 6-Core model: AMD Ryzen 5 4600H with Radeon Graphics bits: 64 
  type: MT MCP arch: Zen 2 rev: 1 L2 cache: 3 MiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm 
  bogomips: 71868 
  Speed: 1397 MHz min/max: 1400/3000 MHz boost: enabled Core speeds (MHz): 
  1: 1397 2: 1397 3: 1397 4: 1397 5: 1397 6: 1397 7: 1397 8: 1397 9: 1397 
  10: 1397 11: 1397 12: 1397 
Graphics:
  Device-1: AMD Navi 14 [Radeon RX 5500/5500M / Pro 5500M] 
  vendor: Micro-Star MSI driver: amdgpu v: kernel bus ID: 03:00.0 
  Device-2: AMD Renoir vendor: Micro-Star MSI driver: amdgpu v: kernel 
  bus ID: 07:00.0 
  Device-3: Acer HD Webcam type: USB driver: uvcvideo bus ID: 1-4:3 
  Display: x11 server: X.Org 1.20.11 driver: loaded: amdgpu,ati 
  unloaded: fbdev,modesetting,radeon,vesa resolution: 1920x1080~144Hz 
  OpenGL: renderer: AMD RENOIR (DRM 3.40.0 5.11.0-17-generic LLVM 11.0.1) 
  v: 4.6 Mesa 21.0.1 direct render: Yes 
Audio:
  Device-1: AMD Navi 10 HDMI Audio vendor: Micro-Star MSI 
  driver: snd_hda_intel v: kernel bus ID: 03:00.1 
  Device-2: AMD Raven/Raven2/FireFlight/Renoir Audio Processor 
  vendor: Micro-Star MSI driver: N/A bus ID: 07:00.5 
  Device-3: AMD Family 17h HD Audio vendor: Micro-Star MSI 
  driver: snd_hda_intel v: kernel bus ID: 07:00.6 
  Sound Server: ALSA v: k5.11.0-17-generic 
Network:
  Device-1: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel bus ID: 04:00.0 
  IF: wlp4s0 state: up mac: <filter> 
  Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Micro-Star MSI driver: r8169 v: kernel port: f000 bus ID: 05:00.0 
  IF: enp5s0 state: down mac: <filter> 
Bluetooth:
  Device-1: Intel AX200 Bluetooth type: USB driver: btusb v: 0.8 
  bus ID: 3-3:2 
  Report: ID: hci0 state: up running pscan iscan bt-v: 3.0 lmp-v: 5.2 
  address: <filter> 
Drives:
  Local Storage: total: 476.94 GiB used: 59.88 GiB (12.6%) 
  ID-1: /dev/nvme0n1 vendor: Kingston model: RBUSNS8154P3512GJ5 
  size: 476.94 GiB temp: 33.9 C 
Partition:
  ID-1: / size: 72.83 GiB used: 12.35 GiB (17.0%) fs: ext4 
  dev: /dev/nvme0n1p7 
  ID-2: /boot/efi size: 96 MiB used: 38.1 MiB (39.7%) fs: vfat 
  dev: /dev/nvme0n1p1 
  ID-3: /home size: 78.18 GiB used: 47.49 GiB (60.7%) fs: ext4 
  dev: /dev/nvme0n1p8 
Swap:
  ID-1: swap-1 type: file size: 2 GiB used: 0 KiB (0.0%) file: /swapfile 
Sensors:
  System Temperatures: cpu: 41.4 C mobo: N/A 
  Fan Speeds (RPM): N/A 
  GPU: device: amdgpu temp: 42.0 C fan: 65535 device: amdgpu temp: 34.0 C 
Info:
  Processes: 403 Uptime: 33m Memory: 15.09 GiB used: 2.19 GiB (14.5%) 
  Init: systemd runlevel: 5 Compilers: gcc: 10.3.0 Packages: 2554 
  Shell: Bash v: 5.1.4 inxi: 3.3.01 

celui de ma fille: un Asus sous Linux Mint 20.1

System:
  Kernel: 5.4.0-72-generic x86_64 bits: 64 compiler: gcc v: 9.3.0 
  Desktop: Cinnamon 4.8.6 Distro: Linux Mint 20.1 Ulyssa 
  base: Ubuntu 20.04 focal 
Machine:
  Type: Laptop System: ASUSTeK product: X705UAP v: 1.0 serial: <filter> 
  Mobo: ASUSTeK model: X705UAP v: 1.0 serial: <filter> 
  UEFI: American Megatrends v: X705UAP.302 date: 09/18/2017 
Battery:
  ID-1: BAT0 charge: 26.3 Wh condition: 36.8/42.1 Wh (88%) 
  model: ASUSTeK ASUS Battery status: Discharging 
CPU:
  Topology: Dual Core model: Intel Pentium 4405U bits: 64 type: MT MCP 
  arch: Skylake rev: 3 L2 cache: 2048 KiB 
  flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 16799 
  Speed: 700 MHz min/max: 400/2100 MHz Core speeds (MHz): 1: 700 2: 700 
  3: 700 4: 700 
Graphics:
  Device-1: Intel HD Graphics 510 vendor: ASUSTeK driver: i915 v: kernel 
  bus ID: 00:02.0 
  Display: x11 server: X.Org 1.20.9 driver: modesetting unloaded: fbdev,vesa 
  resolution: 1600x900~60Hz 
  OpenGL: renderer: Mesa Intel HD Graphics 510 (SKL GT1) v: 4.6 Mesa 20.2.6 
  direct render: Yes 
Audio:
  Device-1: Intel Sunrise Point-LP HD Audio vendor: ASUSTeK 
  driver: snd_hda_intel v: kernel bus ID: 00:1f.3 
  Sound Server: ALSA v: k5.4.0-72-generic 
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: ASUSTeK driver: r8169 v: kernel port: e000 bus ID: 02:00.0 
  IF: enp2s0 state: down mac: <filter> 
  Device-2: Qualcomm Atheros QCA9565 / AR9565 Wireless Network Adapter 
  vendor: AzureWave driver: ath9k v: kernel port: e000 bus ID: 03:00.0 
  IF: wlp3s0 state: up mac: <filter> 
Drives:
  Local Storage: total: 931.51 GiB used: 327.80 GiB (35.2%) 
  ID-1: /dev/sda vendor: Seagate model: ST1000LM035-1RK172 size: 931.51 GiB 
Partition:
  ID-1: / size: 136.51 GiB used: 10.41 GiB (7.6%) fs: ext4 dev: /dev/sda3 
  ID-2: /home size: 773.68 GiB used: 317.35 GiB (41.0%) fs: ext4 
  dev: /dev/sda5 
  ID-3: swap-1 size: 3.73 GiB used: 780 KiB (0.0%) fs: swap dev: /dev/sda4 
Sensors:
  System Temperatures: cpu: 34.0 C mobo: N/A 
  Fan Speeds (RPM): cpu: 2000 
Info:
  Processes: 202 Uptime: 53m Memory: 3.73 GiB used: 1.01 GiB (27.1%) 
  Init: systemd runlevel: 5 Compilers: gcc: 9.3.0 Shell: bash v: 5.0.17 
  inxi: 3.0.38 

Pour le moment c'est la configuration de la charge des batteries qui m'interresse mais je dois louper quelque chose car la gestion des batteries n'est prise en charge sur aucun des deux ordis.
Je l'ai bien mis en route :

francois@francois-Bravo-17-A4DDR:~$ sudo tlp start
[sudo] Mot de passe de francois : 
TLP started in AC mode (auto).
francois@francois-Bravo-17-A4DDR:~$ 

La confirmation :

francois@francois-Bravo-17-A4DDR:~$ sudo tlp-stat -s
--- TLP 1.3.1 --------------------------------------------

+++ System Info
System         = Micro-Star International Co., Ltd. REV:1.0 Bravo 17 A4DDR
BIOS           = E17FKAMS.116
Release        = Ubuntu 21.04
Kernel         = 5.11.0-17-generic #18-Ubuntu SMP Thu May 6 20:10:11 UTC 2021 x86_64
/proc/cmdline  = BOOT_IMAGE=/boot/vmlinuz-5.11.0-17-generic root=UUID=bcee8f6a-00aa-46af-8d73-047e2fe92dc5 ro quiet splash vt.handoff=7
Init system    = systemd v247 (247.3-3ubuntu3)
Boot mode      = UEFI

+++ TLP Status
State          = enabled
RDW state      = enabled
Last run       = 10:01:28,    248 sec(s) ago
Mode           = AC
Power source   = AC

francois@francois-Bravo-17-A4DDR:~$ 

je suis une bille en ligne de commende sauf quand c'est du copié/collé , donc je préfère le graphique.
Voilà grosso modo ce que je voudrais :

mini_210512121114326863.png

le MSI est en Dual boot et j'ai un logiciel équivalent sous Windows qui semble prendre le pas sur TLP-UI mais qui n'est pas paramétrable ou si peu (recharge 80%, décharge jusqu'à 60%). C'est un moindre mal mais comme je compte me séparer de Windows assez rapidement, le problème se posera.
par contre, là où je ne comprends plus, c'est sur l'Asus où les paramétrages ne sont absolument pas pris en compte ( recharge jusqu'à 100% et dès qu'il manque 1%)
Je bidouille depuis plusieurs jours, je ne trouve pas de notice de paramétrage claire ou en français, TLP-UI est en anglais et propose plein de langues sauf le français (voilà ce que c'est d'être un pays en voie de dé-développement !)
Bref, je galère !

Qu'ai je loupé ?

Merci pour votre aide

smile

Dernière modification par Balilaï (Le 12/05/2021, à 11:30)


Ubuntu Mate 21.4 dual boot W10 / Bravo 17 A4DDR / AMD Ryzen 5 4600H with Radeon Graphics / Radeon RX 5500M, 4080 MB / 16 GB

https://www.flickr.com/photos/balilai/albums

Hors ligne

#2 Le 12/05/2021, à 15:42

michel_04

Re : Paramétrage de TLP-UI

Bonjour.


Tu as regardé l'aide pour la configuration de TLP (pas UI) : "Settings".
En anglais, mais assez explicite.


A+


:D
Comment Poser Les Questions De Manière Intelligente - Trouver de l'aide grâce au Groupe des Parrains Linux - Le Pacte des Gnous - l'Almanet doLys de nam1962 et ses amis
PCs sous Debian Stable & Debian Sid.

En ligne

#3 Le 12/05/2021, à 15:53

Balilaï

Re : Paramétrage de TLP-UI

michel_04 a écrit :

Bonjour.


Tu as regardé l'aide pour la configuration de TLP (pas UI) : "Settings".
En anglais, mais assez explicite.


A+


Oui j'ai déjà regardé avec le traducteur.
Mais je n'ai rien trouvé qui ne colle pas.
mais bon, je suis une bille !


Ubuntu Mate 21.4 dual boot W10 / Bravo 17 A4DDR / AMD Ryzen 5 4600H with Radeon Graphics / Radeon RX 5500M, 4080 MB / 16 GB

https://www.flickr.com/photos/balilai/albums

Hors ligne

#4 Le 12/05/2021, à 16:00

Balilaï

Re : Paramétrage de TLP-UI

Ils expliquent que la configuration par défaut fonctionne assez bien or la gestion des batteries n'est pas active sur les deux ordinateurs avec la configuration par défaut.
si je modifie cette config batterie, il ne se passe rien non plus.

Dernière modification par Balilaï (Le 12/05/2021, à 16:37)


Ubuntu Mate 21.4 dual boot W10 / Bravo 17 A4DDR / AMD Ryzen 5 4600H with Radeon Graphics / Radeon RX 5500M, 4080 MB / 16 GB

https://www.flickr.com/photos/balilai/albums

Hors ligne

#5 Le 13/05/2021, à 10:18

Balilaï

Re : Paramétrage de TLP-UI

Bon, apparemment ça n'inspire pas grand monde, personne ne l'utilise ?
sinon connaissez vous un autre logiciel qui pourrait gérer les batteries des portables et qui serait plus simple d'utilisation ?

smile


Ubuntu Mate 21.4 dual boot W10 / Bravo 17 A4DDR / AMD Ryzen 5 4600H with Radeon Graphics / Radeon RX 5500M, 4080 MB / 16 GB

https://www.flickr.com/photos/balilai/albums

Hors ligne

#6 Le 31/05/2021, à 12:56

R136a1

Re : Paramétrage de TLP-UI

Salut
Je peux pas t'aider avec TLP, je l'utilise pas.
Je peux par contre t'indiquer un lien expliquant comment bloquer le niveau de charge de la batterie de l'Asus s'il supporte cette fonction (s'il est pas trop ancien, ça doit le faire).
Regarde ce tuto, en anglais mais très simple : https://www.linuxuprising.com/2021/02/h … t.html?m=1
J'ai paramétré ça sur 3 portable Asus. Avec le gestionnaire d'énergie, perso ça me suffit.
Désolé pour TLP.
A+


Asus UX333FA: Debian 11 Mate

Hors ligne

#7 Le 31/05/2021, à 14:52

inbox

Re : Paramétrage de TLP-UI

Salut,

La section de gestion de la batterie de tlp-ui indique clairement que cette partie ne fonctionne (ou n'est prévue pour fonctionner) qu'avec un Thinkpad. En début de sujet, tu indiques avoir un MSI.

A+


Un problème résolu ? Indiquez le en modifiant le titre du sujet.
Linux user 449594

En ligne

#8 Le 31/05/2021, à 15:05

R136a1

Re : Paramétrage de TLP-UI

inbox a écrit :

En début de sujet, tu indiques avoir un MSI.

MSI et Asus, d'où le lien vers linuxuprising. wink

Dernière modification par R136a1 (Le 31/05/2021, à 15:14)


Asus UX333FA: Debian 11 Mate

Hors ligne

#9 Le 31/05/2021, à 18:45

Balilaï

Re : Paramétrage de TLP-UI

R136a1 a écrit :
inbox a écrit :

En début de sujet, tu indiques avoir un MSI.

MSI et Asus, d'où le lien vers linuxuprising. wink

Mince, je me suis tellement concentré sur les différents réglages que je n'a pas pas vu ça !!!!


Ubuntu Mate 21.4 dual boot W10 / Bravo 17 A4DDR / AMD Ryzen 5 4600H with Radeon Graphics / Radeon RX 5500M, 4080 MB / 16 GB

https://www.flickr.com/photos/balilai/albums

Hors ligne

#10 Le 31/05/2021, à 18:46

Balilaï

Re : Paramétrage de TLP-UI

R136a1 a écrit :

Salut
Je peux pas t'aider avec TLP, je l'utilise pas.
Je peux par contre t'indiquer un lien expliquant comment bloquer le niveau de charge de la batterie de l'Asus s'il supporte cette fonction (s'il est pas trop ancien, ça doit le faire).
Regarde ce tuto, en anglais mais très simple : https://www.linuxuprising.com/2021/02/h … t.html?m=1
J'ai paramétré ça sur 3 portable Asus. Avec le gestionnaire d'énergie, perso ça me suffit.
Désolé pour TLP.
A+

Super, merci, je vais regarder cela de plus prêt !

smile


Ubuntu Mate 21.4 dual boot W10 / Bravo 17 A4DDR / AMD Ryzen 5 4600H with Radeon Graphics / Radeon RX 5500M, 4080 MB / 16 GB

https://www.flickr.com/photos/balilai/albums

Hors ligne

#11 Le 06/06/2021, à 10:00

Balilaï

Re : Paramétrage de TLP-UI

Balilaï a écrit :
R136a1 a écrit :

Salut
Je peux pas t'aider avec TLP, je l'utilise pas.
Je peux par contre t'indiquer un lien expliquant comment bloquer le niveau de charge de la batterie de l'Asus s'il supporte cette fonction (s'il est pas trop ancien, ça doit le faire).
Regarde ce tuto, en anglais mais très simple : https://www.linuxuprising.com/2021/02/h … t.html?m=1
J'ai paramétré ça sur 3 portable Asus. Avec le gestionnaire d'énergie, perso ça me suffit.
Désolé pour TLP.
A+

Super, merci, je vais regarder cela de plus prêt !

smile



Je patauge !


Ubuntu Mate 21.4 dual boot W10 / Bravo 17 A4DDR / AMD Ryzen 5 4600H with Radeon Graphics / Radeon RX 5500M, 4080 MB / 16 GB

https://www.flickr.com/photos/balilai/albums

Hors ligne

#12 Le 30/09/2021, à 16:54

Balilaï

Re : Paramétrage de TLP-UI

Bonjour à tous !

Je ré ouvre ce post pour communiquer une info :

Sur le PC Asus de ma fille (Linux Mint), j'avais installé TLPUI pour pouvoir maîtriser la charge de la batterie que je voulais limiter à 80%.
Après moult tentatives infructueuses (forcément puisque le limiteur de charge ne fonctionne qu'avec un Thinkpad), j'avais laissé tombé en oubliant de désinstaller TLPUI et en laissant les paramétrages.

Il y a environ 10 jours, j'ai fait la mise à jour vers Mint 20.2 et depuis, le limiteur de charge fonctionne et se paramètre bien avec TLPUI, à + ou - 1%.
Evolution chez Linux Mint ou chez TLPUI, nouveau noyau ? je n'en ai pas la moindre idée.
Sur mon PC (Ubuntu Mate 21.4), je ne peux vérifier puisqu'il est en dual boot Windows/Ubuntu et que c'est le limiteur de charge MSI qui semble prendre le pas.

Voilà, c'est juste une info et si d'autres veulent creuser, on peut peut être le faire ici et je serai tout ouie !

smile


Ubuntu Mate 21.4 dual boot W10 / Bravo 17 A4DDR / AMD Ryzen 5 4600H with Radeon Graphics / Radeon RX 5500M, 4080 MB / 16 GB

https://www.flickr.com/photos/balilai/albums

Hors ligne

#13 Le 09/10/2021, à 12:29

Balilaï

Re : Paramétrage de TLP-UI

Bon ...

Il y a eu cette semaine une mise à jour et depuis ça ne fonctionne plus !  roll
Pas eu encore le temps de me pencher sur le probleme.


Ubuntu Mate 21.4 dual boot W10 / Bravo 17 A4DDR / AMD Ryzen 5 4600H with Radeon Graphics / Radeon RX 5500M, 4080 MB / 16 GB

https://www.flickr.com/photos/balilai/albums

Hors ligne

#14 Le 01/12/2021, à 00:19

R136a1

Re : Paramétrage de TLP-UI

Balilaï a écrit :

Il y a environ 10 jours, j'ai fait la mise à jour vers Mint 20.2 et depuis, le limiteur de charge fonctionne et se paramètre bien avec TLPUI, à + ou - 1%.
Evolution chez Linux Mint ou chez TLPUI, nouveau noyau ?
smile

Evolution de TLP (TLP-UI est une interface graphique à TLP). Depuis la version 1.4 de TLP, la prise en charge de la limite de charge de la batterie se fait aussi, en plus des thinkpad, pour les Asus, huawei MateBooks, LG gram, lenovo non Thinkpad et Samsung.
Sinon, tu pataugeais pourquoi dans le lien que je t'avais donné?
Désolé pour le retard...

Dernière modification par R136a1 (Le 01/12/2021, à 00:23)


Asus UX333FA: Debian 11 Mate

Hors ligne