Contenu | Rechercher | Menus

Annonce

DVD, clés USB et t-shirts Ubuntu-fr disponibles sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 27/10/2021, à 13:55

Pchev

Xubuntu installé mais ne se lance pas en automatique - résolu

Bonjour,
J'ai installé XUBUNTU 21.04 sur un portable HP Elite 840 G2, après avoir testé sans installation, via une clé USB bootable
J'ai écrasé le DD et le windows précédemment installé .

Par contre , je n'arrive pas à lancer automatiquement  XUbuntu au démarrage du PC, le systeme de démarrage tourne en rond (logo HP, ecran noir , logo HP)
SI je passe par le menu du bios manuellement , en utilisant le menu suivant :a EFI / Ubuntu/ grub ... cela démarre normalement .

J'ai exécute Boot repair, sans succes ( pas de lancement de ubuntu en auto an demarrage du PC)

Ci après le lien pour le boot info à la suite :  https://paste.ubuntu.com/p/kDRdKBN6KZ/



Merci de votre aide, débutant avec Linux , je suis un peu perdu

Dernière modification par Pchev (Le 28/10/2021, à 15:51)

Hors ligne

#2 Le 27/10/2021, à 13:58

xubu1957

Re : Xubuntu installé mais ne se lance pas en automatique - résolu

Bonjour,

Collage du Boot-repair, pour les spécialistes :

boot-repair-4ppa130                                              [20211027_1236]

============================= Boot Repair Summary ==============================



Default settings: ______________________________________________________________

The default repair of the Boot-Repair utility would reinstall the grub-efi-amd64-signed of
sda2,
using the following options:        sda1/boot/efi,
Additional repair would be performed: unhide-bootmenu-10s  use-standard-efi-file  restore-efi-backups  

Final advice in case of suggested repair: ______________________________________


Please do not forget to make your UEFI firmware boot on the L'OS actuellement utilisé - Ubuntu 20.04.3 LTS CurrentSession entry (sda1/efi/****/shim****.efi (**** will be updated in the final message) file) !

User settings: _________________________________________________________________

/usr/share/boot-sav/bs-cmd_terminal.sh: ligne 177: avertissement : substitution de commande: octet nul ignoré en entrée
(debug) reinstall grub2 place-in-MBR no-BIOSboot (sda2)

Repair blocked: ________________________________________________________________
GPT détecté. Veuillez créer une partition BIOS-Boot (>1MB, système de fichiers non formaté, drapeau bios_grub). Cela peut être réalisé via des outils tels que Gparted. Puis réessayez.
Alternativement, vous pouvez réessayer après avoir activé l'option [Partition /boot/efi séparée :].
The settings chosen by the user will reinstall the grub-efi-amd64-signed of
sda2,
using the following options:        sda1/boot/efi,
Additional repair will be performed: unhide-bootmenu-10s  use-standard-efi-file  restore-efi-backups


/boot/efi added in sda2/fstab
rm /boot/efi/efi/Boot/bootx64.efi
mv /boot/efi/efi/Boot/bkpbootx64.efi /boot/efi/efi/Boot/bootx64.efi
sda2/boot/efi not empty

================= Reinstall the grub-efi-amd64-signed of sda2 ==================

grub-install --version
grub-install (GRUB) 2.04-1ubuntu26.13

efibootmgr -v from chroot before grub install
BootCurrent: 0000
Timeout: 0 seconds
BootOrder: 0000,0001
Boot0000* Notebook Hard Drive	BBS(HD,,0x0).......................................................................
Boot0001* Notebook Ethernet	BBS(128,,0x0)........................E..............................................
Boot0002* Notebook Ethernet	BBS(128,,0x0)........................E..............................................
Boot0003* Notebook Ethernet	BBS(128,,0x0)........................E..............................................
Boot0004* ubuntu	HD(1,GPT,5f6a8582-31e8-4cd3-8971-a141241bf81b,0x800,0x100000)/File(EFIubuntushimx64.efi)
Boot0005* ubuntu	HD(1,GPT,5f6a8582-31e8-4cd3-8971-a141241bf81b,0x800,0x100000)/File(EFIubuntushimx64.efi)
Boot0006* ubuntu	HD(1,GPT,5f6a8582-31e8-4cd3-8971-a141241bf81b,0x800,0x100000)/File(EFIubuntushimx64.efi)
Boot0007* ubuntu	HD(1,GPT,5f6a8582-31e8-4cd3-8971-a141241bf81b,0x800,0x100000)/File(EFIubuntushimx64.efi)

uname -r
5.11.0-38-generic

grub-install --efi-directory=/boot/efi --target=x86_64-efi --uefi-secure-boot
Installing for x86_64-efi platform.
Installation finished. No error reported.
df /dev/sda1
mv /boot/efi/EFI/Boot/bootx64.efi /boot/efi/EFI/Boot/bkpbootx64.efi
cp /boot/efi/EFI/ubuntu/shimx64.efi /boot/efi/EFI/Boot/bootx64.efi

grub-install --efi-directory=/boot/efi --target=x86_64-efi --uefi-secure-boot
Installing for x86_64-efi platform.
Installation finished. No error reported.

efibootmgr -v from chroot after grub install
BootCurrent: 0000
Timeout: 0 seconds
BootOrder: 0004,0000,0001
Boot0000* Notebook Hard Drive	BBS(HD,,0x0).......................................................................
Boot0001* Notebook Ethernet	BBS(128,,0x0)........................E..............................................
Boot0002* Notebook Ethernet	BBS(128,,0x0)........................E..............................................
Boot0003* Notebook Ethernet	BBS(128,,0x0)........................E..............................................
Boot0004* ubuntu	HD(1,GPT,5f6a8582-31e8-4cd3-8971-a141241bf81b,0x800,0x100000)/File(EFIubuntushimx64.efi)

update-grub
Sourcing file `/etc/default/grub'
Sourcing file `/etc/default/grub.d/init-select.cfg'
Generating grub configuration file ...
Found linux image: /boot/vmlinuz-5.11.0-38-generic
Found initrd image: /boot/initrd.img-5.11.0-38-generic
Found linux image: /boot/vmlinuz-5.11.0-27-generic
Found initrd image: /boot/initrd.img-5.11.0-27-generic
Adding boot menu entry for UEFI Firmware Settings

Unhide GRUB boot menu in sda2/boot/grub/grub.cfg

Le démarrage de l'ordinateur a été correctement réparé.

Vous pouvez maintenant redémarrer votre ordinateur.

N'oubliez pas de faire démarrer votre firmware UEFI sur l'entrée L'OS actuellement utilisé - Ubuntu 20.04.3 LTS CurrentSession (fichier sda1/EFI/ubuntu/shimx64.efi) !

et :

============================ Boot Info After Repair ============================

 => No boot loader is installed in the MBR of /dev/sda.

sda1: __________________________________________________________________________

    File system:       vfat
    Boot sector type:  FAT32
    Boot sector info:  No errors found in the Boot Parameter Block.
    Operating System:  
    Boot files:        /efi/BOOT/bkpbootx64.efi /efi/BOOT/bootx64.efi 
                       /efi/BOOT/fbx64.efi /efi/BOOT/grubx64.efi 
                       /efi/BOOT/mmx64.efi /efi/ubuntu/grubx64.efi 
                       /efi/ubuntu/mmx64.efi /efi/ubuntu/shimx64.efi 
                       /efi/ubuntu/grub.cfg

sda2: __________________________________________________________________________

    File system:       ext4
    Boot sector type:  -
    Boot sector info: 
    Operating System:  Ubuntu 20.04.3 LTS
    Boot files:        /boot/grub/grub.cfg /etc/fstab /etc/default/grub


================================ 1 OS detected =================================

OS#1:   L'OS actuellement utilisé - Ubuntu 20.04.3 LTS CurrentSession on sda2

============================ Architecture/Host Info ============================

CPU architecture: 64-bit
BOOT_IMAGE of the installed session in use:
/boot/vmlinuz-5.11.0-38-generic root=UUID=1f366589-7ee2-4562-bfe0-d0413b225c0d ro quiet splash vt.handoff=7


===================================== UEFI =====================================

BIOS is EFI-compatible, and is setup in EFI-mode for this installed-session.
SecureBoot disabled.

efibootmgr -v
BootCurrent: 0000
Timeout: 0 seconds
BootOrder: 0000,0001
Boot0000* Notebook Hard Drive	BBS(HD,,0x0).......................................................................
Boot0001* Notebook Ethernet	BBS(128,,0x0)........................E..............................................
Boot0002* Notebook Ethernet	BBS(128,,0x0)........................E..............................................
Boot0003* Notebook Ethernet	BBS(128,,0x0)........................E..............................................
Boot0004* ubuntu	HD(1,GPT,5f6a8582-31e8-4cd3-8971-a141241bf81b,0x800,0x100000)/File(\EFI\ubuntu\shimx64.efi)
Boot0005* ubuntu	HD(1,GPT,5f6a8582-31e8-4cd3-8971-a141241bf81b,0x800,0x100000)/File(\EFI\ubuntu\shimx64.efi)
Boot0006* ubuntu	HD(1,GPT,5f6a8582-31e8-4cd3-8971-a141241bf81b,0x800,0x100000)/File(\EFI\ubuntu\shimx64.efi)
Boot0007* ubuntu	HD(1,GPT,5f6a8582-31e8-4cd3-8971-a141241bf81b,0x800,0x100000)/File(\EFI\ubuntu\shimx64.efi)

728124f6ec8e22fbdbe7034812c81b95   sda1/BOOT/bkpbootx64.efi
728124f6ec8e22fbdbe7034812c81b95   sda1/BOOT/bootx64.efi
85fa9d77b929ec4231aba29476574eb6   sda1/BOOT/fbx64.efi
fa1bf1a7f90a852abe0bdbd089b7f1b0   sda1/BOOT/grubx64.efi
469e608783843a701d172242f016c79c   sda1/BOOT/mmx64.efi
fa1bf1a7f90a852abe0bdbd089b7f1b0   sda1/ubuntu/grubx64.efi
469e608783843a701d172242f016c79c   sda1/ubuntu/mmx64.efi
728124f6ec8e22fbdbe7034812c81b95   sda1/ubuntu/shimx64.efi


============================= Drive/Partition Info =============================

Disks info: ____________________________________________________________________

sda	: is-GPT,	no-BIOSboot,	has---ESP, 	not-usb,	not-mmc, has-os,	2048 sectors * 512 bytes

Partitions info (1/3): _________________________________________________________

sda2	: is-os,	64, apt-get,	signed grub-pc grub-efi ,	grub2,	grub-install,	grubenv-ok,	update-grub,	farbios
sda1	: no-os,	32, nopakmgr,	no-docgrub,	nogrub,	nogrubinstall,	no-grubenv,	noupdategrub,	not-far

Partitions info (2/3): _________________________________________________________

sda2	: isnotESP,	fstab-has-goodEFI,	no-nt,	no-winload,	no-recov-nor-hid,	no-bmgr,	notwinboot
sda1	: is---ESP,	part-has-no-fstab,	no-nt,	no-winload,	no-recov-nor-hid,	no-bmgr,	notwinboot

Partitions info (3/3): _________________________________________________________

sda2	: not-sepboot,	with-boot,	fstab-without-boot,	not-sep-usr,	with--usr,	fstab-without-usr,	std-grub.d,	sda
sda1	: not-sepboot,	no-boot,	part-has-no-fstab,	not-sep-usr,	no---usr,	part-has-no-fstab,	std-grub.d,	sda

fdisk -l (filtered): ___________________________________________________________

Disk sda: 447.13 GiB, 480103981056 bytes, 937703088 sectors
Disk identifier: 931457F0-17BF-463D-AC78-E7EFF542F2EB
        Start       End   Sectors   Size Type
sda1     2048   1050623   1048576   512M EFI System
sda2  1050624 937701375 936650752 446.6G Linux filesystem

parted -lm (filtered): _________________________________________________________

sda:480GB:scsi:512:512:gpt:ATA SSDG2-480G:;
1:1049kB:538MB:537MB:fat32:EFI System Partition:boot, esp;
2:538MB:480GB:480GB:ext4::;

blkid (filtered): ______________________________________________________________

NAME   FSTYPE   UUID                                 PARTUUID                             LABEL PARTLABEL
sda                                                                                             
├─sda1 vfat     DFD1-0E87                            5f6a8582-31e8-4cd3-8971-a141241bf81b       EFI System Partition
└─sda2 ext4     1f366589-7ee2-4562-bfe0-d0413b225c0d b934c7ed-85ae-45e6-ae50-948f2c841d80       

df (filtered): _________________________________________________________________

       Avail Use% Mounted on
sda2     399G   4% /

Mount options: __________________________________________________________________

sda2   rw,relatime,errors=remount-ro

===================== sda1/efi/ubuntu/grub.cfg (filtered) ======================

search.fs_uuid 1f366589-7ee2-4562-bfe0-d0413b225c0d root hd0,gpt2 
set prefix=($root)'/boot/grub'
configfile $prefix/grub.cfg

====================== sda2/boot/grub/grub.cfg (filtered) ======================

Ubuntu   1f366589-7ee2-4562-bfe0-d0413b225c0d
Ubuntu, with Linux 5.11.0-38-generic   1f366589-7ee2-4562-bfe0-d0413b225c0d
Ubuntu, with Linux 5.11.0-27-generic   1f366589-7ee2-4562-bfe0-d0413b225c0d
### END /etc/grub.d/30_os-prober ###
UEFI Firmware Settings   uefi-firmware
### END /etc/grub.d/30_uefi-firmware ###

========================== sda2/etc/fstab (filtered) ===========================

# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sda2 during installation
UUID=1f366589-7ee2-4562-bfe0-d0413b225c0d /               ext4    errors=remount-ro 0       1
# /boot/efi was on /dev/sda1 during installation
/swapfile                                 none            swap    sw              0       0
UUID=DFD1-0E87  /boot/efi       vfat    defaults      0       1

======================= sda2/etc/default/grub (filtered) =======================

GRUB_DEFAULT=0
GRUB_TIMEOUT_STYLE=hidden
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

==================== sda2: Location of files loaded by Grub ====================

           GiB - GB             File                                 Fragment(s)
 272,647396088 = 292,752912384  boot/grub/grub.cfg                             1
 261,783855438 = 281,088274432  boot/vmlinuz                                   1
   4,752593994 = 5,103058944    boot/vmlinuz-5.11.0-27-generic                 2
 261,783855438 = 281,088274432  boot/vmlinuz-5.11.0-38-generic                 1
   4,752593994 = 5,103058944    boot/vmlinuz.old                               2
 263,159755707 = 282,565636096  boot/initrd.img                                3
 263,093334198 = 282,494316544  boot/initrd.img-5.11.0-27-generic              1
 263,159755707 = 282,565636096  boot/initrd.img-5.11.0-38-generic              3
 263,093334198 = 282,494316544  boot/initrd.img.old                            1

===================== sda2: ls -l /etc/grub.d/ (filtered) ======================

-rwxr-xr-x 1 root root 18151 août  12 11:18 10_linux
-rwxr-xr-x 1 root root 42359 août  12 11:18 10_linux_zfs
-rwxr-xr-x 1 root root 12894 août  12 11:18 20_linux_xen
-rwxr-xr-x 1 root root 12059 août  12 11:18 30_os-prober
-rwxr-xr-x 1 root root  1424 août  12 11:18 30_uefi-firmware
-rwxr-xr-x 1 root root   214 août  12 11:18 40_custom
-rwxr-xr-x 1 root root   216 août  12 11:18 41_custom

Dernière modification par xubu1957 (Le 27/10/2021, à 14:02)


Conseils pour les nouveaux demandeurs et pas qu'eux
Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.                   Membre de Linux-Azur

Hors ligne

#3 Le 27/10/2021, à 14:01

Qid

Re : Xubuntu installé mais ne se lance pas en automatique - résolu

Pchev a écrit :

SI je passe par le menu du bios manuellement , en utilisant le menu suivant :a EFI / Ubuntu/ grub ... cela démarre normalement .

Donc il faut changer la séquence de boot de l'uefi ! Question de logique... Et ça aurait certainement été confirmé par le retour de l'une des commandes qu'utilise bootinfo mais je ne peux pas lire le rapport...

édit : cette partie me confirme ce que je disais :

efibootmgr -v
BootCurrent: 0000
Timeout: 0 seconds
BootOrder: 0000,0001
Boot0000* Notebook Hard Drive	BBS(HD,,0x0).......................................................................
Boot0001* Notebook Ethernet	BBS(128,,0x0)........................E..............................................
Boot0002* Notebook Ethernet	BBS(128,,0x0)........................E..............................................
Boot0003* Notebook Ethernet	BBS(128,,0x0)........................E..............................................
Boot0004* ubuntu	HD(1,GPT,5f6a8582-31e8-4cd3-8971-a141241bf81b,0x800,0x100000)/File(\EFI\ubuntu\shimx64.efi)
Boot0005* ubuntu	HD(1,GPT,5f6a8582-31e8-4cd3-8971-a141241bf81b,0x800,0x100000)/File(\EFI\ubuntu\shimx64.efi)
Boot0006* ubuntu	HD(1,GPT,5f6a8582-31e8-4cd3-8971-a141241bf81b,0x800,0x100000)/File(\EFI\ubuntu\shimx64.efi)
Boot0007* ubuntu	HD(1,GPT,5f6a8582-31e8-4cd3-8971-a141241bf81b,0x800,0x100000)/File(\EFI\ubuntu\shimx64.efi)

Dernière modification par Qid (Le 27/10/2021, à 14:06)


"GNU/Linux c'est que du bon mais M$ Windows ce n'est pas si mal"
Référent technique d'un Groupe d'Utilisateur du Libre
plus d'info sur mon profil

Hors ligne

#4 Le 27/10/2021, à 15:22

geole

Re : Xubuntu installé mais ne se lance pas en automatique - résolu

Bonjour.
d'après la documentation de ubuntu:

https://doc.ubuntu-fr.org/liste_portables_hp#la_serie_elitebook a écrit :

- En fait, grâce au 'Customized Boot' du BIOS HP (touche F10), il est possible de lancer grub au boot sans changer aucun fichier de configuration et de choisir le système, ce qui est pratique en cas de double-boot. Il suffit d'activer le 'custom boot' et d'ajouter le chemin \EFI\ubuntu\shimx64.efi (attention, le clavier passe en QWERTY sous le BIOS) dans 'Define Customized Boot Option' puis de déplacer l'item 'Customized Boot' en tête de liste de 'UEFI Boot Order' (NB: le boot mode étant 'UEFI Hybrid' et le secure boot étant Off). Ceci a été vérifié sur une installation d'ubuntu 18.04 à côté de W10 Pro mais devrait fonctionner aussi avec la 20.04

Mais si c'est trop difficile, comme windows a été viré, il suffit de refabriquer la structure de boot de windows et d'y transférer les fichiers de boot de ubuntu.
Nota. Boot-repair fait le transfert des fichiers de boot de ubuntu uniquement dans les fichiers de boot standards. Il ne souhaite pas écraser ceux de windows.

mv /boot/efi/EFI/Boot/bootx64.efi /boot/efi/EFI/Boot/bkpbootx64.efi
cp /boot/efi/EFI/ubuntu/shimx64.efi /boot/efi/EFI/Boot/bootx64.efi

Dernière modification par geole (Le 27/10/2021, à 15:30)

Hors ligne

#5 Le 27/10/2021, à 22:12

Pchev

Re : Xubuntu installé mais ne se lance pas en automatique - résolu

Bonsoir,
J'ai essayé la première opération , mais sans succès . Dommage car cela me paraissait logique .

Pour la seconde, je ne suis pas un pro des commandes ; avec un copier coller dans la console cela m'a mis "permission refusé" ; j'ai mis sudo devant, la commande est passée (est ce la bonne manière de faire ?) , la seconde idem ( commet vérifier que le résultat est bon ?) . J'ai refait un boot repair, et toujours le même pb au démarrage .

Au cas ou cela serait utile, le dernier rapport boot info
https://paste.ubuntu.com/p/Zc7CSjpdWM/

Hors ligne

#6 Le 27/10/2021, à 22:33

xubu1957

Re : Xubuntu installé mais ne se lance pas en automatique - résolu

Deuxième mouture :

boot-repair-4ppa130                                              [20211027_2156]

============================= Boot Repair Summary ==============================



/usr/share/boot-sav/bs-cmd_terminal.sh: ligne 177: avertissement : substitution de commande: octet nul ignoré en entrée

Recommended repair: ____________________________________________________________

The default repair of the Boot-Repair utility will reinstall the grub-efi-amd64-signed of
sda2,
using the following options:        sda1/boot/efi,
Additional repair will be performed: unhide-bootmenu-10s  use-standard-efi-file  restore-efi-backups


/boot/efi added in sda2/fstab
rm /boot/efi/efi/Boot/bootx64.efi
mv /boot/efi/efi/Boot/bkpbootx64.efi /boot/efi/efi/Boot/bootx64.efi
sda2/boot/efi not empty

================= Reinstall the grub-efi-amd64-signed of sda2 ==================

grub-install --version
grub-install (GRUB) 2.04-1ubuntu26.13

efibootmgr -v from chroot before grub install
BootCurrent: 0000
Timeout: 0 seconds
BootOrder: 0000
Boot0000* Notebook Hard Drive	BBS(HD,,0x0).......................................................................
Boot0001* Notebook Ethernet	BBS(128,,0x0)........................E..............................................
Boot0002* Notebook Ethernet	BBS(128,,0x0)........................E..............................................
Boot0003* Notebook Ethernet	BBS(128,,0x0)........................E..............................................
Boot0004* ubuntu	HD(1,GPT,5f6a8582-31e8-4cd3-8971-a141241bf81b,0x800,0x100000)/File(EFIubuntushimx64.efi)
Boot0005* ubuntu	HD(1,GPT,5f6a8582-31e8-4cd3-8971-a141241bf81b,0x800,0x100000)/File(EFIubuntushimx64.efi)
Boot0006* ubuntu	HD(1,GPT,5f6a8582-31e8-4cd3-8971-a141241bf81b,0x800,0x100000)/File(EFIubuntushimx64.efi)
Boot0007* ubuntu	HD(1,GPT,5f6a8582-31e8-4cd3-8971-a141241bf81b,0x800,0x100000)/File(EFIubuntushimx64.efi)
Boot0008* ubuntu	HD(1,GPT,5f6a8582-31e8-4cd3-8971-a141241bf81b,0x800,0x100000)/File(EFIubuntushimx64.efi)

uname -r
5.11.0-38-generic

grub-install --efi-directory=/boot/efi --target=x86_64-efi --uefi-secure-boot
Installing for x86_64-efi platform.
Installation finished. No error reported.
df /dev/sda1
mv /boot/efi/EFI/Boot/bootx64.efi /boot/efi/EFI/Boot/bkpbootx64.efi
cp /boot/efi/EFI/ubuntu/shimx64.efi /boot/efi/EFI/Boot/bootx64.efi

grub-install --efi-directory=/boot/efi --target=x86_64-efi --uefi-secure-boot
Installing for x86_64-efi platform.
Installation finished. No error reported.

efibootmgr -v from chroot after grub install
BootCurrent: 0000
Timeout: 0 seconds
BootOrder: 0004,0000
Boot0000* Notebook Hard Drive	BBS(HD,,0x0).......................................................................
Boot0001* Notebook Ethernet	BBS(128,,0x0)........................E..............................................
Boot0002* Notebook Ethernet	BBS(128,,0x0)........................E..............................................
Boot0003* Notebook Ethernet	BBS(128,,0x0)........................E..............................................
Boot0004* ubuntu	HD(1,GPT,5f6a8582-31e8-4cd3-8971-a141241bf81b,0x800,0x100000)/File(EFIubuntushimx64.efi)

update-grub
Sourcing file `/etc/default/grub'
Sourcing file `/etc/default/grub.d/init-select.cfg'
Generating grub configuration file ...
Found linux image: /boot/vmlinuz-5.11.0-38-generic
Found initrd image: /boot/initrd.img-5.11.0-38-generic
Found linux image: /boot/vmlinuz-5.11.0-27-generic
Found initrd image: /boot/initrd.img-5.11.0-27-generic
Adding boot menu entry for UEFI Firmware Settings

Unhide GRUB boot menu in sda2/boot/grub/grub.cfg

Le démarrage de l'ordinateur a été correctement réparé.

Vous pouvez maintenant redémarrer votre ordinateur.

N'oubliez pas de faire démarrer votre firmware UEFI sur l'entrée L'OS actuellement utilisé - Ubuntu 20.04.3 LTS CurrentSession (fichier sda1/EFI/ubuntu/shimx64.efi) !

============================ Boot Info After Repair ============================

 => No boot loader is installed in the MBR of /dev/sda.

sda1: __________________________________________________________________________

    File system:       vfat
    Boot sector type:  FAT32
    Boot sector info:  No errors found in the Boot Parameter Block.
    Operating System:  
    Boot files:        /efi/BOOT/bkpbootx64.efi /efi/BOOT/bootx64.efi 
                       /efi/BOOT/fbx64.efi /efi/BOOT/grubx64.efi 
                       /efi/BOOT/mmx64.efi /efi/ubuntu/grubx64.efi 
                       /efi/ubuntu/mmx64.efi /efi/ubuntu/shimx64.efi 
                       /efi/ubuntu/grub.cfg

sda2: __________________________________________________________________________

    File system:       ext4
    Boot sector type:  -
    Boot sector info: 
    Operating System:  Ubuntu 20.04.3 LTS
    Boot files:        /boot/grub/grub.cfg /etc/fstab /etc/default/grub


================================ 1 OS detected =================================

OS#1:   L'OS actuellement utilisé - Ubuntu 20.04.3 LTS CurrentSession on sda2

============================ Architecture/Host Info ============================

CPU architecture: 64-bit
BOOT_IMAGE of the installed session in use:
/boot/vmlinuz-5.11.0-38-generic root=UUID=1f366589-7ee2-4562-bfe0-d0413b225c0d ro quiet splash vt.handoff=7


===================================== UEFI =====================================

BIOS is EFI-compatible, and is setup in EFI-mode for this installed-session.
SecureBoot disabled.

efibootmgr -v
BootCurrent: 0000
Timeout: 0 seconds
BootOrder: 0000
Boot0000* Notebook Hard Drive	BBS(HD,,0x0).......................................................................
Boot0001* Notebook Ethernet	BBS(128,,0x0)........................E..............................................
Boot0002* Notebook Ethernet	BBS(128,,0x0)........................E..............................................
Boot0003* Notebook Ethernet	BBS(128,,0x0)........................E..............................................
Boot0004* ubuntu	HD(1,GPT,5f6a8582-31e8-4cd3-8971-a141241bf81b,0x800,0x100000)/File(\EFI\ubuntu\shimx64.efi)
Boot0005* ubuntu	HD(1,GPT,5f6a8582-31e8-4cd3-8971-a141241bf81b,0x800,0x100000)/File(\EFI\ubuntu\shimx64.efi)
Boot0006* ubuntu	HD(1,GPT,5f6a8582-31e8-4cd3-8971-a141241bf81b,0x800,0x100000)/File(\EFI\ubuntu\shimx64.efi)
Boot0007* ubuntu	HD(1,GPT,5f6a8582-31e8-4cd3-8971-a141241bf81b,0x800,0x100000)/File(\EFI\ubuntu\shimx64.efi)
Boot0008* ubuntu	HD(1,GPT,5f6a8582-31e8-4cd3-8971-a141241bf81b,0x800,0x100000)/File(\EFI\ubuntu\shimx64.efi)

728124f6ec8e22fbdbe7034812c81b95   sda1/BOOT/bkpbootx64.efi
728124f6ec8e22fbdbe7034812c81b95   sda1/BOOT/bootx64.efi
85fa9d77b929ec4231aba29476574eb6   sda1/BOOT/fbx64.efi
fa1bf1a7f90a852abe0bdbd089b7f1b0   sda1/BOOT/grubx64.efi
469e608783843a701d172242f016c79c   sda1/BOOT/mmx64.efi
fa1bf1a7f90a852abe0bdbd089b7f1b0   sda1/ubuntu/grubx64.efi
469e608783843a701d172242f016c79c   sda1/ubuntu/mmx64.efi
728124f6ec8e22fbdbe7034812c81b95   sda1/ubuntu/shimx64.efi


============================= Drive/Partition Info =============================

Disks info: ____________________________________________________________________

sda	: is-GPT,	no-BIOSboot,	has---ESP, 	not-usb,	not-mmc, has-os,	2048 sectors * 512 bytes

Partitions info (1/3): _________________________________________________________

sda2	: is-os,	64, apt-get,	signed grub-pc grub-efi ,	grub2,	grub-install,	grubenv-ok,	update-grub,	farbios
sda1	: no-os,	32, nopakmgr,	no-docgrub,	nogrub,	nogrubinstall,	no-grubenv,	noupdategrub,	not-far

Partitions info (2/3): _________________________________________________________

sda2	: isnotESP,	fstab-has-goodEFI,	no-nt,	no-winload,	no-recov-nor-hid,	no-bmgr,	notwinboot
sda1	: is---ESP,	part-has-no-fstab,	no-nt,	no-winload,	no-recov-nor-hid,	no-bmgr,	notwinboot

Partitions info (3/3): _________________________________________________________

sda2	: not-sepboot,	with-boot,	fstab-without-boot,	not-sep-usr,	with--usr,	fstab-without-usr,	std-grub.d,	sda
sda1	: not-sepboot,	no-boot,	part-has-no-fstab,	not-sep-usr,	no---usr,	part-has-no-fstab,	std-grub.d,	sda

fdisk -l (filtered): ___________________________________________________________

Disk sda: 447.13 GiB, 480103981056 bytes, 937703088 sectors
Disk identifier: 931457F0-17BF-463D-AC78-E7EFF542F2EB
        Start       End   Sectors   Size Type
sda1     2048   1050623   1048576   512M EFI System
sda2  1050624 937701375 936650752 446.6G Linux filesystem

parted -lm (filtered): _________________________________________________________

sda:480GB:scsi:512:512:gpt:ATA SSDG2-480G:;
1:1049kB:538MB:537MB:fat32:EFI System Partition:boot, esp;
2:538MB:480GB:480GB:ext4::;

blkid (filtered): ______________________________________________________________

NAME   FSTYPE   UUID                                 PARTUUID                             LABEL PARTLABEL
sda                                                                                             
├─sda1 vfat     DFD1-0E87                            5f6a8582-31e8-4cd3-8971-a141241bf81b       EFI System Partition
└─sda2 ext4     1f366589-7ee2-4562-bfe0-d0413b225c0d b934c7ed-85ae-45e6-ae50-948f2c841d80       

df (filtered): _________________________________________________________________

       Avail Use% Mounted on
sda2   397.4G   4% /

Mount options: __________________________________________________________________

sda2   rw,relatime,errors=remount-ro

===================== sda1/efi/ubuntu/grub.cfg (filtered) ======================

search.fs_uuid 1f366589-7ee2-4562-bfe0-d0413b225c0d root hd0,gpt2 
set prefix=($root)'/boot/grub'
configfile $prefix/grub.cfg

====================== sda2/boot/grub/grub.cfg (filtered) ======================

Ubuntu   1f366589-7ee2-4562-bfe0-d0413b225c0d
Ubuntu, with Linux 5.11.0-38-generic   1f366589-7ee2-4562-bfe0-d0413b225c0d
Ubuntu, with Linux 5.11.0-27-generic   1f366589-7ee2-4562-bfe0-d0413b225c0d
### END /etc/grub.d/30_os-prober ###
UEFI Firmware Settings   uefi-firmware
### END /etc/grub.d/30_uefi-firmware ###

========================== sda2/etc/fstab (filtered) ===========================

# <file system> <mount point>   <type>  <options>       <dump>  <pass>
# / was on /dev/sda2 during installation
UUID=1f366589-7ee2-4562-bfe0-d0413b225c0d /               ext4    errors=remount-ro 0       1
# /boot/efi was on /dev/sda1 during installation
/swapfile                                 none            swap    sw              0       0
UUID=DFD1-0E87  /boot/efi       vfat    defaults      0       1

======================= sda2/etc/default/grub (filtered) =======================

GRUB_DEFAULT=0
GRUB_TIMEOUT_STYLE=hidden
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

==================== sda2: Location of files loaded by Grub ====================

           GiB - GB             File                                 Fragment(s)
 274,644706726 = 294,897508352  boot/grub/grub.cfg                             1
 261,783855438 = 281,088274432  boot/vmlinuz                                   1
   4,752593994 = 5,103058944    boot/vmlinuz-5.11.0-27-generic                 2
 261,783855438 = 281,088274432  boot/vmlinuz-5.11.0-38-generic                 1
   4,752593994 = 5,103058944    boot/vmlinuz.old                               2
 263,159755707 = 282,565636096  boot/initrd.img                                3
 263,093334198 = 282,494316544  boot/initrd.img-5.11.0-27-generic              1
 263,159755707 = 282,565636096  boot/initrd.img-5.11.0-38-generic              3
 263,093334198 = 282,494316544  boot/initrd.img.old                            1

===================== sda2: ls -l /etc/grub.d/ (filtered) ======================

-rwxr-xr-x 1 root root 18151 août  12 11:18 10_linux
-rwxr-xr-x 1 root root 42359 août  12 11:18 10_linux_zfs
-rwxr-xr-x 1 root root 12894 août  12 11:18 20_linux_xen
-rwxr-xr-x 1 root root 12059 août  12 11:18 30_os-prober
-rwxr-xr-x 1 root root  1424 août  12 11:18 30_uefi-firmware
-rwxr-xr-x 1 root root   214 août  12 11:18 40_custom
-rwxr-xr-x 1 root root   216 août  12 11:18 41_custom

Conseils pour les nouveaux demandeurs et pas qu'eux
Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.                   Membre de Linux-Azur

Hors ligne

#7 Le 27/10/2021, à 23:12

ikewdu

Re : Xubuntu installé mais ne se lance pas en automatique - résolu

Salut,

Tu devrais tester un démarrage en tapotant F9 au démarrage pour voir si ton Ubuntu se lance. Et ce serait bien que tu précises les points de suspension ici : 

je passe par le menu du bios manuellement , en utilisant le menu suivant :a EFI / Ubuntu/ grub ...

Car sur ce sujet : https://forum.ubuntu-fr.org/viewtopic.php?id=2067148 , malbo propose d'utiliser grubx64.efi au lieu de shimx64.efi, ce qui donnerait si on l'applique à ton cas :

sudo cp /boot/efi/EFI/ubuntu/grubx64.efi /boot/efi/EFI/boot/bootx64.efi

Sinon, si ça ne fonctionne pas, tu peux aussi tenter :

sudo cp /boot/efi/EFI/ubuntu/shimx64.efi /boot/efi/EFI/Microsoft/boot/bootmgfw.efi

puis

sudo cp /boot/efi/EFI/ubuntu/grubx64.efi /boot/efi/EFI/Microsoft/boot/bootmgfw.efi

On ne sait jamais, le PC sera peut-être plus conciliant au démarrage avec cela.

Dernière modification par ikewdu (Le 27/10/2021, à 23:40)

Hors ligne

#8 Le 28/10/2021, à 13:37

geole

Re : Xubuntu installé mais ne se lance pas en automatique - résolu

Bonjour
extrait de ton boot-info . Le fichier de boot original semble détruit

728124f6ec8e22fbdbe7034812c81b95   sda1/BOOT/bkpbootx64.efi
728124f6ec8e22fbdbe7034812c81b95   sda1/BOOT/bootx64.efi
728124f6ec8e22fbdbe7034812c81b95   sda1/ubuntu/shimx64.efi

Si tu es amené à faire les deux dernières commandes, il faut d'abord recréer la structure de boot de windows

sudo mkdir -pv  /boot/efi/EFI/Microsoft/boot

puis seulement la seconde

Dernière modification par geole (Le 28/10/2021, à 13:43)

Hors ligne

#9 Le 28/10/2021, à 14:49

inbox

Re : Xubuntu installé mais ne se lance pas en automatique - résolu

Salut,

Je pense que la base du problème se trouve décrite ici :

Boot info a écrit :

Repair blocked: ________________________________________________________________
GPT détecté. Veuillez créer une partition BIOS-Boot (>1MB, système de fichiers non formaté, drapeau bios_grub). Cela peut être réalisé via des outils tels que Gparted. Puis réessayez.

A+


Un problème résolu ? Indiquez le en modifiant le titre du sujet.
Linux user 449594

Hors ligne

#10 Le 28/10/2021, à 15:46

Pchev

Re : Xubuntu installé mais ne se lance pas en automatique - résolu

Bonjour,
La modification de hier 23h12 fonctionne (remplacer shimm par grub)
Merci de votre aide

Hors ligne