Contenu | Rechercher | Menus

Annonce

DVD, clés USB et t-shirts Ubuntu-fr disponibles sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 15/11/2021, à 14:29

nepeta

Installation paquets problématique

Bonjour,

J'ai voulu installer evince via synaptic, j'ai eu un message " 'Could not apply changes ! Fix broken packages first"

J'ai trouvé How to Fix Broken Packages in Ubuntu mais la commande m'a retourné çà :

sudo apt update --fix-missing
Hit:1 http://fr.archive.ubuntu.com/ubuntu impish InRelease
Hit:2 http://fr.archive.ubuntu.com/ubuntu impish-updates InRelease
Get:3 http://security.ubuntu.com/ubuntu impish-security InRelease [103 kB]
Fetched 103 kB in 1s (143 kB/s)                           
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
All packages are up to date.

Dans synaptic le paquet libevince-dev est marqué d'un ' ! rouge'.
Je suppose que c'est lui le cassé.
J'ai donc essayé de l'installer, mais...

sudo apt-get install libevince-dev
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libcairo2-dev : Depends: libcairo2 (= 1.16.0-5ubuntu1) but 1.16.0-5ubuntu2 is to be installed
                 Depends: libcairo-gobject2 (= 1.16.0-5ubuntu1) but 1.16.0-5ubuntu2 is to be installed
                 Depends: libcairo-script-interpreter2 (= 1.16.0-5ubuntu1) but 1.16.0-5ubuntu2 is to be installed
                 Depends: libfontconfig1-dev (>= 2.2.95)
                 Depends: libpixman-1-dev (>= 0.22.0) but it is not going to be installed
                 Depends: libxcb-render0-dev (>= 1.6) but it is not going to be installed
                 Depends: libxcb-shm0-dev but it is not going to be installed
 libdatrie-dev : Depends: libdatrie1 (= 0.2.13-1ubuntu2) but 0.2.13-1ubuntu3 is to be installed
 libfreetype-dev : Depends: libfreetype6 (= 2.10.4+dfsg-1build1) but 2.10.4+dfsg-1build2 is to be installed
 libgtk-3-dev : Depends: libfontconfig1-dev
                Depends: libgdk-pixbuf-2.0-dev (>= 2.40.0) but it is not installable or
                         libgdk-pixbuf2.0-dev (>= 2.40.0) but it is not installable
 libharfbuzz-dev : Depends: libharfbuzz0b (= 2.7.4-1ubuntu1) but 2.7.4-1ubuntu2 is to be installed
                   Depends: libharfbuzz-icu0 (= 2.7.4-1ubuntu1) but 2.7.4-1ubuntu2 is to be installed
                   Depends: gir1.2-harfbuzz-0.0 (= 2.7.4-1ubuntu1) but 2.7.4-1ubuntu2 is to be installed
                   Depends: libgraphite2-dev but it is not going to be installed
 libpango1.0-dev : Depends: libfontconfig1-dev (>= 2.11.91)
 libpcre3-dev : Depends: libpcre3 (= 2:8.39-13build3) but 2:8.39-13build4 is to be installed
 libxcomposite-dev : Depends: libxcomposite1 (= 1:0.4.5-1) but 1:0.4.5-1build1 is to be installed
 libxcursor-dev : Depends: libxcursor1 (= 1:1.2.0-2build2) but 1:1.2.0-2build3 is to be installed
 libxdamage-dev : Depends: libxdamage1 (= 1:1.1.5-2) but 1:1.1.5-2build1 is to be installed
 libxext-dev : Depends: libxext6 (= 2:1.3.4-0ubuntu3) but 2:1.3.4-0ubuntu4 is to be installed
 libxfixes-dev : Depends: libxfixes3 (= 1:5.0.3-2build1) but 1:5.0.3-2build2 is to be installed
 libxft-dev : Depends: libfontconfig1-dev
 libxi-dev : Depends: libxi6 (= 2:1.7.10-1build2) but 2:1.7.10-1build3 is to be installed
 libxinerama-dev : Depends: libxinerama1 (= 2:1.1.4-2build2) but 2:1.1.4-2build3 is to be installed
 libxkbcommon-dev : Depends: libxkbcommon0 (= 1.3.0-1) but 1.3.0-1build1 is to be installed
 libxrandr-dev : Depends: libxrandr2 (= 2:1.5.2-0ubuntu1) but 2:1.5.2-0ubuntu2 is to be installed
 libxrender-dev : Depends: libxrender1 (= 1:0.9.10-1build2) but 1:0.9.10-1build3 is to be installed
 libxtst-dev : Depends: libxtst6 (= 2:1.2.3-1build2) but 2:1.2.3-1build3 is to be installed
E: Unable to correct problems, you have held broken packages.

Je ne comprend pas tout = je ne comprends rien.

Merci de votre aide.

Hors ligne

#2 Le 15/11/2021, à 14:35

xubu1957

Re : Installation paquets problématique

Bonjour,

La Doc evince

Que retourne :

sudo apt install evince

?


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 20.04 LTS - Lenovo T410 -18.04.1 LTS Toshiba Satellite A300  Membre de Linux-Azur

Hors ligne

#3 Le 15/11/2021, à 14:44

nepeta

Re : Installation paquets problématique

sudo apt install evince
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
evince is already the newest version (40.4-2).
evince set to manually installed.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

Hors ligne

#4 Le 15/11/2021, à 15:18

xubu1957

Re : Installation paquets problématique

En lançant en commande :

evince

ressort-il un message d'erreur ?


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 20.04 LTS - Lenovo T410 -18.04.1 LTS Toshiba Satellite A300  Membre de Linux-Azur

Hors ligne

#5 Le 15/11/2021, à 15:48

iznobe

Re : Installation paquets problématique

Bonjour , que donne le rretour complet de cette commande :

sudo dpkg --configure -a

retour utilisable de commande
MSI Z490A-pro , i7 10700 , 32 GB RAM . avec Ubuntu , LM et W$10

Hors ligne

#6 Le 15/11/2021, à 17:14

nepeta

Re : Installation paquets problématique

@xubu1957  Document viewer s'ouvre normalement.

@iznobe Il ne se passe rien,juste un retour à la ligne.

Hors ligne

#7 Le 15/11/2021, à 17:29

iznobe

Re : Installation paquets problématique

as tu fait un upgrade vers ubuntu impish ( 21.10 ) ou est ce une nouvelle installation ?

d' apres cette page : https://packages.ubuntu.com/impish/evince , le paquet libevince-dev , ne fait pas partie des dependances , il serait logiquement juste necessaire de le supprimer .

mais je ne suis pas sur a 100 % du truc tongue vaut mieux attendre l' avis d ' un expert .

En attendant @xubu1957 , pourrais tu donner la commande pour voir les paquets cassés stp ?

Dernière modification par iznobe (Le 15/11/2021, à 17:33)


retour utilisable de commande
MSI Z490A-pro , i7 10700 , 32 GB RAM . avec Ubuntu , LM et W$10

Hors ligne

#8 Le 15/11/2021, à 17:33

nepeta

Re : Installation paquets problématique

Je suis sous ubuntu impish.

Hors ligne

#9 Le 15/11/2021, à 17:34

iznobe

Re : Installation paquets problématique

nepeta a écrit :

Je suis sous ubuntu impish.

oui je sais bien big_smile , la question c ' est : est ce une nouvelle install ou une mise a jour ?

Dernière modification par iznobe (Le 15/11/2021, à 17:34)


retour utilisable de commande
MSI Z490A-pro , i7 10700 , 32 GB RAM . avec Ubuntu , LM et W$10

Hors ligne

#10 Le 15/11/2021, à 17:35

nepeta

Re : Installation paquets problématique

Mise à jour.

Hors ligne

#11 Le 15/11/2021, à 17:36

iznobe

Re : Installation paquets problématique

xubu1957 a écrit :

Bonjour,

Montre aussi d'éventuels paquets cassés :

dpkg -l | grep -v ^ii

retour utilisable de commande
MSI Z490A-pro , i7 10700 , 32 GB RAM . avec Ubuntu , LM et W$10

Hors ligne

#12 Le 15/11/2021, à 17:47

nepeta

Re : Installation paquets problématique

roll

dpkg -l | grep -v ^ii
Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Conf-files/Unpacked/halF-conf/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Reinst-required (Status,Err: uppercase=bad)
||/ Name                                          Version                                           Architecture Description
+++-=============================================-=================================================-============-===============================================================================

Hors ligne

#13 Le 15/11/2021, à 18:07

iznobe

Re : Installation paquets problématique

que donne

sudo apt remove -s libevince-dev

retour utilisable de commande
MSI Z490A-pro , i7 10700 , 32 GB RAM . avec Ubuntu , LM et W$10

Hors ligne

#14 Le 15/11/2021, à 18:12

nepeta

Re : Installation paquets problématique

sudo apt remove -s libevince-dev
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
Package 'libevince-dev' is not installed, so not removed
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

Hors ligne

#15 Le 15/11/2021, à 18:17

ylag

Re : Installation paquets problématique

Bonjour,

Vu au #1 :

The following packages have unmet dependencies:
libcairo2-dev : Depends: libcairo2 (= 1.16.0-5ubuntu1) but 1.16.0-5ubuntu2 is to be installed
                 Depends: libcairo-gobject2 (= 1.16.0-5ubuntu1) but 1.16.0-5ubuntu2 is to be installed
                 Depends: libcairo-script-interpreter2 (= 1.16.0-5ubuntu1) but 1.16.0-5ubuntu2 is to be installed

La version 1.16.0-5ubuntu2 de ces paquets proviendrait des dépôts de la  future 22.04 LTS Jammy Jellyfish :
https://launchpad.net/ubuntu/+source/cairo
...faudrait peut-être voir le contenu complet des sources ?

A+

Dernière modification par ylag (Le 15/11/2021, à 18:47)

Hors ligne

#16 Le 15/11/2021, à 18:44

iznobe

Re : Installation paquets problématique

suite au commentaire @ylag , que donne donc :

cat /etc/apt/sources.list
ls -l /etc/apt/sources.list.d

Dernière modification par iznobe (Le 15/11/2021, à 18:46)


retour utilisable de commande
MSI Z490A-pro , i7 10700 , 32 GB RAM . avec Ubuntu , LM et W$10

Hors ligne

#17 Le 15/11/2021, à 20:45

nepeta

Re : Installation paquets problématique

cat /etc/apt/sources.list
# deb cdrom:[Ubuntu 20.04 LTS _Focal Fossa_ - Release amd64 (20200423)]/ xubu/dists/focal/multiverse/binary-amd64/

# deb cdrom:[Ubuntu 20.04 LTS _Focal Fossa_ - Release amd64 (20200423)]/ xubu/dists/focal/multiverse/binary-i386/
# deb cdrom:[Ubuntu 20.04 LTS _Focal Fossa_ - Release amd64 (20200423)]/ xubu/dists/focal/restricted/binary-i386/
# deb cdrom:[Ubuntu 20.04 LTS _Focal Fossa_ - Release amd64 (20200423)]/ xubu/dists/focal/universe/binary-i386/
# deb cdrom:[Ubuntu 20.04 LTS _Focal Fossa_ - Release amd64 (20200423)]/ubun/ focal main restricted
# deb cdrom:[Ubuntu 20.04 LTS _Focal Fossa_ - Release amd64 (20200423)]/xubu/ focal main restricted universe

# See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
# newer versions of the distribution.
deb http://fr.archive.ubuntu.com/ubuntu/ impish main restricted
# deb-src http://fr.archive.ubuntu.com/ubuntu/ focal main restricted

## Major bug fix updates produced after the final release of the
## distribution.
deb http://fr.archive.ubuntu.com/ubuntu/ impish-updates main restricted
# deb-src http://fr.archive.ubuntu.com/ubuntu/ focal-updates main restricted

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team. Also, please note that software in universe WILL NOT receive any
## review or updates from the Ubuntu security team.
deb http://fr.archive.ubuntu.com/ubuntu/ impish universe
# deb-src http://fr.archive.ubuntu.com/ubuntu/ focal universe
deb http://fr.archive.ubuntu.com/ubuntu/ impish-updates universe
# deb-src http://fr.archive.ubuntu.com/ubuntu/ focal-updates universe

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu 
## team, and may not be under a free licence. Please satisfy yourself as to 
## your rights to use the software. Also, please note that software in 
## multiverse WILL NOT receive any review or updates from the Ubuntu
## security team.
deb http://fr.archive.ubuntu.com/ubuntu/ impish multiverse
# deb-src http://fr.archive.ubuntu.com/ubuntu/ focal multiverse
deb http://fr.archive.ubuntu.com/ubuntu/ impish-updates multiverse
# deb-src http://fr.archive.ubuntu.com/ubuntu/ focal-updates multiverse

## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.
# deb-src http://fr.archive.ubuntu.com/ubuntu/ focal-backports main restricted universe multiverse

## Uncomment the following two lines to add software from Canonical's
## 'partner' repository.
## This software is not part of Ubuntu, but is offered by Canonical and the
## respective vendors as a service to Ubuntu users.
# deb http://archive.canonical.com/ubuntu focal partner
# deb-src http://archive.canonical.com/ubuntu focal partner

deb http://security.ubuntu.com/ubuntu impish-security main restricted
# deb-src http://security.ubuntu.com/ubuntu focal-security main restricted
deb http://security.ubuntu.com/ubuntu impish-security universe
# deb-src http://security.ubuntu.com/ubuntu focal-security universe
deb http://security.ubuntu.com/ubuntu impish-security multiverse
# deb-src http://security.ubuntu.com/ubuntu focal-security multiverse
# This system was installed using small removable media
# (e.g. netinst, live or single CD). The matching "deb cdrom"
# entries were disabled at the end of the installation process.
# For information about how to configure apt package sources,
ls -l /etc/apt/sources.list.d
total 36
-rw-r--r-- 1 root root 157 nov.  11 11:26 archive_uri-https_dl_winehq_org_wine-builds_ubuntu_-hirsute.list
-rw-r--r-- 1 root root 124 oct.  15 10:06 archive_uri-https_dl_winehq_org_wine-builds_ubuntu_-hirsute.list.distUpgrade
-rw-r--r-- 1 root root 157 nov.  11 11:26 archive_uri-https_dl_winehq_org_wine-builds_ubuntu_-hirsute.list.save
-rw-r--r-- 1 root root  80 nov.  11 11:26 leap.list
-rw-r--r-- 1 root root  80 oct.  15 10:06 leap.list.distUpgrade
-rw-r--r-- 1 root root  80 nov.  11 11:26 leap.list.save
-rw-r--r-- 1 root root 187 nov.  11 11:26 openshot_developers-ubuntu-ppa-hirsute.list
-rw-r--r-- 1 root root 154 oct.  15 10:06 openshot_developers-ubuntu-ppa-hirsute.list.distUpgrade
-rw-r--r-- 1 root root 187 nov.  11 11:26 openshot_developers-ubuntu-ppa-hirsute.list.save

Hors ligne

#18 Le 15/11/2021, à 21:11

iznobe

Re : Installation paquets problématique

de ce que je vois rien a signaler qui ne va pas dans le fichier /etc/apt/sources.list .

Peux tu donner les retour de :

cat /etc/apt/sources.list.d/archive_uri-https_dl_winehq_org_wine-builds_ubuntu_-hirsute.list
cat /etc/apt/sources.list.d/leap.list
cat /etc/apt/sources.list.d/openshot_developers-ubuntu-ppa-hirsute.list

Petite question annexe : tu as demarré avec ubuntu focal fossa , puis mise a jour vers hirsute , puis mise a jour vers impish , c ' est bien ca ?

Dernière modification par iznobe (Le 15/11/2021, à 21:14)


retour utilisable de commande
MSI Z490A-pro , i7 10700 , 32 GB RAM . avec Ubuntu , LM et W$10

Hors ligne

#19 Le 15/11/2021, à 21:53

ylag

Re : Installation paquets problématique

Bonsoir,

Ajoute ceci aux commandes du #18, pour avoir une liste d'éventuels paquets «orphelins» absents de tes dépôts activés :

apt list ?obsolete

A+

Hors ligne

#20 Le 16/11/2021, à 08:35

nepeta

Re : Installation paquets problématique

cat /etc/apt/sources.list.d/archive_uri-https_dl_winehq_org_wine-builds_ubuntu_-hirsute.list
# deb https://dl.winehq.org/wine-builds/ubuntu/ impish main # disabled on upgrade to impish
# deb-src https://dl.winehq.org/wine-builds/ubuntu/ hirsute main
cat /etc/apt/sources.list.d/leap.list
# deb https://deb.leap.se/client release buster # disabled on upgrade to groovy
cat /etc/apt/sources.list.d/openshot_developers-ubuntu-ppa-hirsute.list
# deb http://ppa.launchpad.net/openshot.developers/ppa/ubuntu/ impish main # disabled on upgrade to impish
# deb-src http://ppa.launchpad.net/openshot.developers/ppa/ubuntu/ hirsute main
apt list ?obsolete
Listing... Done
gir1.2-unity-5.0/now 7.1.4+19.04.20190319-2 amd64 [installed,local]
libldap-2.4-2/now 2.4.57+dfsg-2ubuntu1 amd64 [installed,local]
libldap-2.4-2/now 2.4.57+dfsg-2ubuntu1 i386 [installed,local]
libopenshot-audio8/now 0.2.1+dfsg2+139+202108251943~ubuntu21.04.1 amd64 [installed,local]
libopenshot20/now 0.2.6+dfsg2+1045+202108252003+daily~ubuntu21.04.1 amd64 [installed,local]
libvkd3d-shader1/now 1.2~hirsute-1 amd64 [installed,local]
libvkd3d-shader1/now 1.2~hirsute-1 i386 [installed,local]
linux-headers-5.13.0-22-generic/now 5.13.0-22.22 amd64 [installed,local]
linux-headers-5.13.0-22/now 5.13.0-22.22 all [installed,local]
linux-image-5.13.0-22-generic/now 5.13.0-22.22 amd64 [installed,local]
linux-modules-5.13.0-22-generic/now 5.13.0-22.22 amd64 [installed,local]
linux-modules-extra-5.13.0-22-generic/now 5.13.0-22.22 amd64 [installed,local]
pyflakes/now 2.1.1-2 all [installed,local]
python-pyflakes/now 2.1.1-2 all [installed,local]
riseup-vpn/now 0.19.11 amd64 [installed,local]
vkd3d-compiler/now 1.2~hirsute-1 amd64 [installed,local]
wine-stable-amd64/now 6.0.1~hirsute-1 amd64 [installed,local]
wine-stable-i386/now 6.0.1~hirsute-1 i386 [installed,local]
winehq-stable/now 6.0.1~hirsute-1 amd64 [installed,local]

Hors ligne

#21 Le 16/11/2021, à 09:21

FrancisFDZ

Re : Installation paquets problématique

Bonjour,
Les paquets obsolètes ne devraient-ils pas être effacés par

sudo apt autoremove --purge

??


-- On peut avoir des raisons de se plaindre et n'avoir pas raison de se plaindre --
[Victor Hugo]

Hors ligne

#22 Le 16/11/2021, à 09:48

nepeta

Re : Installation paquets problématique

C'est ce que je croyais, mais...

 sudo apt autoremove --purge
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

et ensuite :

apt list ?obsolete
Listing... Done
gir1.2-unity-5.0/now 7.1.4+19.04.20190319-2 amd64 [installed,local]
libldap-2.4-2/now 2.4.57+dfsg-2ubuntu1 amd64 [installed,local]
libldap-2.4-2/now 2.4.57+dfsg-2ubuntu1 i386 [installed,local]
libopenshot-audio8/now 0.2.1+dfsg2+139+202108251943~ubuntu21.04.1 amd64 [installed,local]
libopenshot20/now 0.2.6+dfsg2+1045+202108252003+daily~ubuntu21.04.1 amd64 [installed,local]
libvkd3d-shader1/now 1.2~hirsute-1 amd64 [installed,local]
libvkd3d-shader1/now 1.2~hirsute-1 i386 [installed,local]
linux-headers-5.13.0-22-generic/now 5.13.0-22.22 amd64 [installed,local]
linux-headers-5.13.0-22/now 5.13.0-22.22 all [installed,local]
linux-image-5.13.0-22-generic/now 5.13.0-22.22 amd64 [installed,local]
linux-modules-5.13.0-22-generic/now 5.13.0-22.22 amd64 [installed,local]
linux-modules-extra-5.13.0-22-generic/now 5.13.0-22.22 amd64 [installed,local]
master-pdf-editor/now 5.8.20 amd64 [installed,local]
pyflakes/now 2.1.1-2 all [installed,local]
python-pyflakes/now 2.1.1-2 all [installed,local]
riseup-vpn/now 0.19.11 amd64 [installed,local]
vkd3d-compiler/now 1.2~hirsute-1 amd64 [installed,local]
wine-stable-amd64/now 6.0.1~hirsute-1 amd64 [installed,local]
wine-stable-i386/now 6.0.1~hirsute-1 i386 [installed,local]
winehq-stable/now 6.0.1~hirsute-1 amd64 [installed,local]

Est-ce que je peux supprimer mannuellement les paquets obsolètes un à un  / sans risque ?

Dernière modification par nepeta (Le 16/11/2021, à 12:54)

Hors ligne

#23 Le 16/11/2021, à 13:31

iznobe

Re : Installation paquets problématique

Bonjour je n' ai pas l' impression que cette commande liste des paquets obsolete dans le sens ou on l ' entend .

Chez moi par exemple :

iznobe@iznobe-PC:~$ apt list ?obsolete
En train de lister... Fait
brscan-skey/now 0.3.1-2 amd64  [installé, local]
brscan4/now 0.4.10-1 amd64  [installé, local]
mfcj480dwcupswrapper/now 1.0.0-0 i386  [installé, local]
mfcj480dwlpr/now 1.0.0-0 i386  [installé, local]
realvnc-vnc-viewer/now 6.20.529.42646 amd64  [installé, local]
iznobe@iznobe-PC:~$

ca ressemble plus a des paquets que j ' ai installé manuellement , et qui me sont toujours necessaire !

Maintenant si tu n' as plus besoin de wine et des autres logiciels listés que tu as installé manuellement , bien sur que tu peux les supprimer , attention a etre bien certain que tu ne ten sers plus , sinon il faut supprimer et installer une version pour impish a la place .

Vu que ce sont des paquets installés manuellement , il est tout a fait possible de tous les supprimer sans aucun soucis pour le systeme en lui-meme , c ' est certainement un de ceux là qui font bloquer le reste .
Si apres il s' avere que tu as besoin d ' un logiciel , tu pourras tout a fait le reinstaller en prenant bien une version pour impish .
une fois l ' ensemble supprimer , il faudrait faire :
EDIT ajout du nettoyage du cache d ' apt , des fois que ...

sudo apt clean && sudo apt autoclean
sudo apt update
sudo apt autoremove
sudo apt install -f
sudo apt full-upgrade

et voir ce que ca dit .

cela dit , si les paquets listés par ylag sont bien des paquets de jamy , on aura toujours un probleme a regler , mais cela depasse mes competences a la vu des fichiers sources.list ...

REMARQUE : upgrader de version en version est souvent pas trop evident , mais faire 3 voire 4 upgrade de versions est tres deconseillé car amene beaucoup de problemes , surtout avec des logiciels installés a la " mano " , qui , eux ne sont pas mis a jour .
il faut preferer l ' installation avec des depots quand  c' est possible bien sur .
vu sur ca :

cat /etc/apt/sources.list.d/leap.list
# deb https://deb.leap.se/client release buster # disabled on upgrade to groovy

Sinon une installation toute fraiche de temps en temps , c ' est pas plus mal big_smile

EDIT 2 : chez moi ubuntu budgie impish :

iznobe@iznobe-PC:~$ uname -a
Linux iznobe-PC 5.13.0-21-generic #21-Ubuntu SMP Tue Oct 19 08:59:28 UTC 2021 x86_64 x86_64 x86_64 GNU/Linux
iznobe@iznobe-PC:~$

alors que dans ton dernier retour :

linux-headers-5.13.0-22-generic/now 5.13.0-22.22 amd64 [installed,local]
linux-headers-5.13.0-22/now 5.13.0-22.22 all [installed,local]
linux-image-5.13.0-22-generic/now 5.13.0-22.22 amd64 [installed,local]
linux-modules-5.13.0-22-generic/now 5.13.0-22.22 amd64 [installed,local]
linux-modules-extra-5.13.0-22-generic/now 5.13.0-22.22 amd64 [installed,local]

Dernière modification par iznobe (Le 16/11/2021, à 14:20)


retour utilisable de commande
MSI Z490A-pro , i7 10700 , 32 GB RAM . avec Ubuntu , LM et W$10

Hors ligne

#24 Le 16/11/2021, à 14:16

nepeta

Re : Installation paquets problématique

Exactement. " ca ressemble plus a des paquets que j ' ai installé manuellement , et qui me sont toujours necessaire !"

sudo apt clean && sudo apt autoclean
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
sudo apt update
Get:1 http://security.ubuntu.com/ubuntu impish-security InRelease [110 kB]     
Get:2 http://security.ubuntu.com/ubuntu impish-security/main amd64 DEP-11 Metadata [6436 B]
Get:3 http://security.ubuntu.com/ubuntu impish-security/universe amd64 DEP-11 Metadata [2312 B]
Hit:4 http://fr.archive.ubuntu.com/ubuntu impish InRelease                     
Get:5 http://fr.archive.ubuntu.com/ubuntu impish-updates InRelease [110 kB]  
Get:6 http://fr.archive.ubuntu.com/ubuntu impish-updates/main amd64 DEP-11 Metadata [18,8 kB]
Get:7 http://fr.archive.ubuntu.com/ubuntu impish-updates/universe amd64 DEP-11 Metadata [4196 B]
Get:8 http://fr.archive.ubuntu.com/ubuntu impish-updates/universe DEP-11 48x48 Icons [4706 B]
Fetched 257 kB in 2s (149 kB/s)                                           
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
All packages are up to date.
sudo apt autoremove
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
sudo apt install -f
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
sudo apt full-upgrade
Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
Calculating upgrade... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

Hors ligne

#25 Le 16/11/2021, à 14:23

iznobe

Re : Installation paquets problématique

Ces commandes sont a passées apres avoir supprimé les logiciels " obsoletes " qui a priori ne sont plus a jour , et qu ' il faut mettre a jour manuellement puisque installé manuellement . Mais je ne pense pas que le probleme viennent effectivement de là .

bizzare que apt propose des package de jamy , vu qu ' on en voit aucune trace dans tes sources , et honnetement j ' ai pas le niveau pour investiguer plus , desolé .

Je laisse donc la main a des aidants plus experimentés .

Dernière modification par iznobe (Le 16/11/2021, à 14:23)


retour utilisable de commande
MSI Z490A-pro , i7 10700 , 32 GB RAM . avec Ubuntu , LM et W$10

Hors ligne