Contenu | Rechercher | Menus

Annonce

DVD, clés USB et t-shirts Ubuntu-fr disponibles sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#26 Le 15/10/2021, à 16:20

NicoApi73

Re : [RÉSOLU] RTL8852AE - Aucun adaptateur wi-fi trouvé

Pas de problème, ça veut dire que tu n'as pas besoin d'être sur la branche des noyaux qui évolue. Tu peux donc être sur une série 5.4. On verra ça plus tard.

Donne dans un premier temps le retour de la commande suivante :

dmesg | grep rtw
dmesg | grep 8852

Hors ligne

#27 Le 15/10/2021, à 18:36

baptziak

Re : [RÉSOLU] RTL8852AE - Aucun adaptateur wi-fi trouvé

alors pour la première ca ne revoit rien, et la seconde :

[    0.818342] pci 0000:02:00.0: [10ec:8852] type 00 class 0x028000
[    3.372016] Bluetooth: hci0: RTL: examining hci_ver=0b hci_rev=000a lmp_ver=0b lmp_subver=8852
[    3.373996] Bluetooth: hci0: RTL: loading rtl_bt/rtl8852au_fw.bin
[    3.374698] Bluetooth: hci0: RTL: loading rtl_bt/rtl8852au_config.bin

Hors ligne

#28 Le 15/10/2021, à 22:52

NicoApi73

Re : [RÉSOLU] RTL8852AE - Aucun adaptateur wi-fi trouvé

Quel est le retour de

bootctl

Hors ligne

#29 Le 15/10/2021, à 23:08

NicoApi73

Re : [RÉSOLU] RTL8852AE - Aucun adaptateur wi-fi trouvé

On va installer un noyau 5.4 :

sudo apt install linux-headers-5.4.0-88 linux-headers-5.4.0-88-generic linux-image-5.4.0-88-generic linux-modules-5.4.0-88-generic linux-modules-extra-5.4.0-88-generic

Tu rebootes quand grub apparaît, tu choisis options Ubuntu (ou quelque chose équivalent), et tu lances le noyau 5.4.0-88 (sans recovery, ni autre chose)

Une fois booté, tu vérifies le noyau que tu utilises avec la commande :

uname -r

Le retour doit être

nicolas@nicolas-M32CD4-K:~$ uname -r
5.4.0-88-generic
nicolas@nicolas-M32CD4-K:~$ 

ensuite, tu fais :

cd ~/rtw89
make clean
make
sudo make install
sudo modprobe rtw89pci
sudo modprobe rtw89core
sudo lshw -class network
lsmod | sort

Hors ligne

#30 Le 20/10/2021, à 20:30

baptziak

Re : [RÉSOLU] RTL8852AE - Aucun adaptateur wi-fi trouvé

Bonsoir !!!
Désolé d'une réponse si tardive, j'ai une semaine très chargée.

Du coup j'ai tout comme indiqué, sauf jusqu'a

sudo modprobe rtw89pci

qui me renvoit

operation not permitted

(de même pour la ligne du dessous)

Hors ligne

#31 Le 20/10/2021, à 20:40

baptziak

Re : [RÉSOLU] RTL8852AE - Aucun adaptateur wi-fi trouvé

+à notifier :

le partage de connexion filaire avec mon téléphone ne fonctionne pas sur le noyau 5.4 (va savoir pourquoi)

je commence vraiment à me demander s'il y a juste pas un problème avec ma carte réseau & ubuntu

Hors ligne

#32 Le 20/10/2021, à 21:01

ylag

Re : [RÉSOLU] RTL8852AE - Aucun adaptateur wi-fi trouvé

Bonsoir,

baptziak a écrit :

Bonsoir !!!
Désolé d'une réponse si tardive, j'ai une semaine très chargée.

Du coup j'ai tout comme indiqué, sauf jusqu'a

sudo modprobe rtw89pci

qui me renvoit

operation not permitted

(de même pour la ligne du dessous)

Sauf erreur de ma part, ce serait pas causé par la présence du « secure-boot », qu'il faudrait désactiver pour permettre le chargement du module ?

A+

Hors ligne

#33 Le 21/10/2021, à 05:37

NicoApi73

Re : [RÉSOLU] RTL8852AE - Aucun adaptateur wi-fi trouvé

Bonjour

Je plussoie la question d'ylag

NicoApi73 a écrit :

Quel est le retour de

bootctl

smile

Dernière modification par NicoApi73 (Le 21/10/2021, à 05:37)

Hors ligne

#34 Le 21/10/2021, à 10:37

baptziak

Re : [RÉSOLU] RTL8852AE - Aucun adaptateur wi-fi trouvé

incroyable, je suis actuellement connecté au wifi. (c'était le secure-boot...)

1) Plusieurs question, dois-je continuer à taper les lignes de commandes là je m'étais arrêté à cause de celui-ci ?

2) depuis que le secure boot est desactivé le chargement de l'environnement linux se fait en 4:3 ce qui fait que la résolution de l'écran est dégueulasse et que après avoir regardé, je ne peux pas en séléctionner d'autre dans les paramètres

Hors ligne

#35 Le 21/10/2021, à 10:40

baptziak

Re : [RÉSOLU] RTL8852AE - Aucun adaptateur wi-fi trouvé

aussi, voici le retour de

bootctl

-->

Failed to read "/boot/efi/EFI/systemd": Permission non accordée
Failed to open "/boot/efi/loader/loader.conf": Permission non accordée
System:
     Firmware: n/a (n/a)
  Secure Boot: enabled
   Setup Mode: user

Current Boot Loader:
      Product: n/a
     Features: ✗ Boot counting
               ✗ Menu timeout control
               ✗ One-shot menu timeout control
               ✗ Default entry control
               ✗ One-shot entry control
               ✗ Support for XBOOTLDR partition
               ✗ Support for passing random seed to OS
               ✗ Boot loader sets ESP partition information
          ESP: n/a
         File: └─n/a

Random Seed:
 Passed to OS: no
 System Token: not set
       Exists: no

Available Boot Loaders on ESP:
          ESP: /boot/efi (/dev/disk/by-partuuid/e6c7cd4b-c88f-4e25-8feb-5593c91>

Boot Loaders Listed in EFI Variables:
        Title: ubuntu
           ID: 0x0003
       Status: active, boot-order
    Partition: /dev/disk/by-partuuid/e6c7cd4b-c88f-4e25-8feb-5593c91c4e40
         File: └─/EFI/ubuntu/shimx64.efi

        Title: Windows Boot Manager
           ID: 0x0000
       Status: active, boot-order
    Partition: /dev/disk/by-partuuid/e6c7cd4b-c88f-4e25-8feb-5593c91c4e40
         File: └─/EFI/Microsoft/Boot/bootmgfw.efi

Boot Loader Entries:
        $BOOT: /boot/efi (/dev/disk/by-partuuid/e6c7cd4b-c88f-4e25-8feb-5593c91>

 ESCOC





artuuid/e6c7cd4b-c88f-4e25-8feb-5593c91c4e40)





7cd4b-c88f-4e25-8feb-5593c91c4e40





7cd4b-c88f-4e25-8feb-5593c91c4e40
tmgfw.efi


artuuid/e6c7cd4b-c88f-4e25-8feb-5593c91c4e40)

 ESCOD
 Passed to OS: no
 System Token: not set
       Exists: no

Available Boot Loaders on ESP:
          ESP: /boot/efi (/dev/disk/by-partuuid/e6c7cd4b-c88f-4e25-8feb-5593c91>

Boot Loaders Listed in EFI Variables:
        Title: ubuntu
           ID: 0x0003
       Status: active, boot-order
    Partition: /dev/disk/by-partuuid/e6c7cd4b-c88f-4e25-8feb-5593c91c4e40
         File: └─/EFI/ubuntu/shimx64.efi

        Title: Windows Boot Manager
           ID: 0x0000
       Status: active, boot-order
    Partition: /dev/disk/by-partuuid/e6c7cd4b-c88f-4e25-8feb-5593c91c4e40
         File: └─/EFI/Microsoft/Boot/bootmgfw.efi

Boot Loader Entries:
        $BOOT: /boot/efi (/dev/disk/by-partuuid/e6c7cd4b-c88f-4e25-8feb-5593c91>

Hors ligne

#36 Le 21/10/2021, à 11:03

xubu1957

Re : [RÉSOLU] RTL8852AE - Aucun adaptateur wi-fi trouvé

Bonjour,

baptziak a écrit :

2) depuis que le secure boot est desactivé le chargement de l'environnement linux se fait en 4:3 ce qui fait que la résolution de l'écran est dégueulasse et que après avoir regardé, je ne peux pas en séléctionner d'autre dans les paramètres

Montre :

lspci -vnn | grep -A12 '\''[030[02]\]' | grep -Ei "vga|3d|display|kernel"
ubuntu-drivers devices
xrandr

et :

dpkg -l | grep nvidia
dpkg -l | grep -v ^ii

Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 20.04 LTS - Lenovo T410 -18.04.1 LTS Toshiba Satellite A300  Membre de Linux-Azur

Hors ligne

#37 Le 21/10/2021, à 11:19

baptziak

Re : [RÉSOLU] RTL8852AE - Aucun adaptateur wi-fi trouvé

1ere ligne :

 04:00.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] Device [1002:164c] (rev c2) (prog-if 00 [VGA controller]) 

2eme :

ne renvoit rien

3eme :

xrandr: Failed to get size of gamma for output default
Screen 0: minimum 1024 x 768, current 1024 x 768, maximum 1024 x 768
default connected primary 1024x768+0+0 0mm x 0mm
   1024x768      76.00* 

4eme :

ne renvoit rien

5eme :

Souhait=inconnU/Installé/suppRimé/Purgé/H=à garder
| État=Non/Installé/fichier-Config/dépaqUeté/échec-conFig/H=semi-installé/W=attend-traitement-déclenchements
|/ Err?=(aucune)/besoin Réinstallation (État,Err: majuscule=mauvais)
||/ Nom                                        Version                               Architecture Description
+++-==========================================-=====================================-============-======================================================================================================

Hors ligne

#38 Le 21/10/2021, à 11:25

xubu1957

Re : [RÉSOLU] RTL8852AE - Aucun adaptateur wi-fi trouvé

Dans > linux-hardware.org, je trouve :

 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] Device [1002:164c] (rev c3) (prog-if 00 [VGA controller])
	DeviceName:  Onboard IGD
	Subsystem: Hewlett-Packard Company Device [103c:887a]
	Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx+
	Status: Cap+ 66MHz- UDF- FastB2B- ParErr- DEVSEL=fast >TAbort+ <TAbort- <MAbort- >SERR- <PERR- INTx-
	Latency: 0, Cache Line Size: 64 bytes
	Interrupt: pin A routed to IRQ 45
	IOMMU group: 4
	Region 0: Memory at d0000000 (64-bit, prefetchable) [size=256M]
	Region 2: Memory at e0000000 (64-bit, prefetchable) [size=2M]
	Region 4: I/O ports at e000 [size=256]
	Region 5: Memory at fcd00000 (32-bit, non-prefetchable) [size=512K]
	Capabilities: <access denied>
	Kernel driver in use: amdgpu

Et pour un pilote amdgpu, je ne suis pas de taille pour répondre.


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 20.04 LTS - Lenovo T410 -18.04.1 LTS Toshiba Satellite A300  Membre de Linux-Azur

Hors ligne

#39 Le 21/10/2021, à 12:04

NicoApi73

Re : [RÉSOLU] RTL8852AE - Aucun adaptateur wi-fi trouvé

baptziak a écrit :
[...]
System:
     Firmware: n/a (n/a)
  Secure Boot: enabled
   Setup Mode: user

Il est toujours actif... Désactive le dans le BIOS

Hors ligne

#40 Le 21/10/2021, à 14:46

baptziak

Re : [RÉSOLU] RTL8852AE - Aucun adaptateur wi-fi trouvé

YESSAIIII LETS GOOOOO

en fait je désactivais le secure boot via le terminal ubuntu mais visiblement ça le faisait à moitié.

MERCI BEAUCOUP

Hors ligne

#41 Le 21/11/2021, à 18:56

guiyou65

Re : [RÉSOLU] RTL8852AE - Aucun adaptateur wi-fi trouvé

Merci NicoAPI73 !!!
And thanks to L Finger too !!!

Hors ligne