Contenu | Rechercher | Menus

Annonce

DVD, clés USB et t-shirts Ubuntu-fr disponibles sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 24/11/2021, à 10:11

Lionel90

[Résolu] Avertissements lors de mise à jour

Bonjour

J'ai installé Unbuntu sur un PC portable, pas ultra neuf; pour lui redonner un petit coup de "jeune" en matière de bureautique et ça marche très bien.

A l'occasion d'une mise à jour j'en ai profité pour faire le ménage avec autoremove, la commande a retiré un certain nombre de paquets Nvidia.
Au démarrage suivant, l'ordinateur ne démarrait plus correctement, et je me retrouvait avec un simple écran noir et

/dev/sda5 clean

le démarrage n'allait pas plus loin.

Il semble que le pilote Nvidia (pas le propriétaire je ne l'ai pas installé) soit en cause.
J'ai trouvé comme solution de le désinstaller

apt-get purge nvidia*

Puis re installation via mise à jour, tout refonctionne

Seulement, depuis, j'ai plein de messages d'avertissement lorsque je veux faire une mise à jour:

Tous les paquets sont à jour. 
W: La cible Packages (main/binary-amd64/Packages) est spécifiée plusieurs fois dans /etc/apt/sources.list.d/skype-stable.list:1 et /etc/apt/sources.list.d/skypeforlinux.list:1
W: La cible Packages (main/binary-all/Packages) est spécifiée plusieurs fois dans /etc/apt/sources.list.d/skype-stable.list:1 et /etc/apt/sources.list.d/skypeforlinux.list:1
W: La cible Translations (main/i18n/Translation-fr_FR) est spécifiée plusieurs fois dans /etc/apt/sources.list.d/skype-stable.list:1 et /etc/apt/sources.list.d/skypeforlinux.list:1
W: La cible Translations (main/i18n/Translation-fr) est spécifiée plusieurs fois dans /etc/apt/sources.list.d/skype-stable.list:1 et /etc/apt/sources.list.d/skypeforlinux.list:1
W: La cible Translations (main/i18n/Translation-en) est spécifiée plusieurs fois dans /etc/apt/sources.list.d/skype-stable.list:1 et /etc/apt/sources.list.d/skypeforlinux.list:1
W: La cible DEP-11 (main/dep11/Components-amd64.yml) est spécifiée plusieurs fois dans /etc/apt/sources.list.d/skype-stable.list:1 et /etc/apt/sources.list.d/skypeforlinux.list:1
W: La cible DEP-11 (main/dep11/Components-all.yml) est spécifiée plusieurs fois dans /etc/apt/sources.list.d/skype-stable.list:1 et /etc/apt/sources.list.d/skypeforlinux.list:1
W: La cible DEP-11-icons-small (main/dep11/icons-48x48.tar) est spécifiée plusieurs fois dans /etc/apt/sources.list.d/skype-stable.list:1 et /etc/apt/sources.list.d/skypeforlinux.list:1
W: La cible DEP-11-icons (main/dep11/icons-64x64.tar) est spécifiée plusieurs fois dans /etc/apt/sources.list.d/skype-stable.list:1 et /etc/apt/sources.list.d/skypeforlinux.list:1
W: La cible DEP-11-icons-hidpi (main/dep11/icons-64x64@2.tar) est spécifiée plusieurs fois dans /etc/apt/sources.list.d/skype-stable.list:1 et /etc/apt/sources.list.d/skypeforlinux.list:1
W: La cible CNF (main/cnf/Commands-amd64) est spécifiée plusieurs fois dans /etc/apt/sources.list.d/skype-stable.list:1 et /etc/apt/sources.list.d/skypeforlinux.list:1
W: La cible CNF (main/cnf/Commands-all) est spécifiée plusieurs fois dans /etc/apt/sources.list.d/skype-stable.list:1 et /etc/apt/sources.list.d/skypeforlinux.list:1
W: La cible Packages (main/binary-amd64/Packages) est spécifiée plusieurs fois dans /etc/apt/sources.list.d/skype-stable.list:1 et /etc/apt/sources.list.d/skypeforlinux.list:1
W: La cible Packages (main/binary-all/Packages) est spécifiée plusieurs fois dans /etc/apt/sources.list.d/skype-stable.list:1 et /etc/apt/sources.list.d/skypeforlinux.list:1
W: La cible Translations (main/i18n/Translation-fr_FR) est spécifiée plusieurs fois dans /etc/apt/sources.list.d/skype-stable.list:1 et /etc/apt/sources.list.d/skypeforlinux.list:1
W: La cible Translations (main/i18n/Translation-fr) est spécifiée plusieurs fois dans /etc/apt/sources.list.d/skype-stable.list:1 et /etc/apt/sources.list.d/skypeforlinux.list:1
W: La cible Translations (main/i18n/Translation-en) est spécifiée plusieurs fois dans /etc/apt/sources.list.d/skype-stable.list:1 et /etc/apt/sources.list.d/skypeforlinux.list:1
W: La cible DEP-11 (main/dep11/Components-amd64.yml) est spécifiée plusieurs fois dans /etc/apt/sources.list.d/skype-stable.list:1 et /etc/apt/sources.list.d/skypeforlinux.list:1
W: La cible DEP-11 (main/dep11/Components-all.yml) est spécifiée plusieurs fois dans /etc/apt/sources.list.d/skype-stable.list:1 et /etc/apt/sources.list.d/skypeforlinux.list:1
W: La cible DEP-11-icons-small (main/dep11/icons-48x48.tar) est spécifiée plusieurs fois dans /etc/apt/sources.list.d/skype-stable.list:1 et /etc/apt/sources.list.d/skypeforlinux.list:1
W: La cible DEP-11-icons (main/dep11/icons-64x64.tar) est spécifiée plusieurs fois dans /etc/apt/sources.list.d/skype-stable.list:1 et /etc/apt/sources.list.d/skypeforlinux.list:1
W: La cible DEP-11-icons-hidpi (main/dep11/icons-64x64@2.tar) est spécifiée plusieurs fois dans /etc/apt/sources.list.d/skype-stable.list:1 et /etc/apt/sources.list.d/skypeforlinux.list:1
W: La cible CNF (main/cnf/Commands-amd64) est spécifiée plusieurs fois dans /etc/apt/sources.list.d/skype-stable.list:1 et /etc/apt/sources.list.d/skypeforlinux.list:1
W: La cible CNF (main/cnf/Commands-all) est spécifiée plusieurs fois dans /etc/apt/sources.list.d/skype-stable.list:1 et /etc/apt/sources.list.d/skypeforlinux.list:1

Que faire pour solutionner ce problème de doublons ?

Dernière modification par Lionel90 (Le 25/11/2021, à 20:33)

Hors ligne

#2 Le 24/11/2021, à 10:13

xubu1957

Re : [Résolu] Avertissements lors de mise à jour

Bonjour,

Montre le sources.list :

find /etc/apt -type f -name '*.list*' -exec bash -c 'echo -e "\n\t$1\n"; [[ $1 = *".list" ]] && cat -n "$1"' _ '{}' \;

Montre aussi d'éventuels paquets cassés :

dpkg -l | grep -v ^ii

Dernière modification par xubu1957 (Le 24/11/2021, à 10:13)


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 20.04 LTS - Lenovo T410 -18.04.1 LTS Toshiba Satellite A300  Membre de Linux-Azur

Hors ligne

#3 Le 24/11/2021, à 10:30

nany

Re : [Résolu] Avertissements lors de mise à jour

Bonjour,



Donne aussi les retours de :

cd /etc/apt/sources.list.d && sudo rm -v skype-stable* ; cd && sudo apt clean && sudo apt update
dpkg -l | grep "nvidia"
ubuntu-drivers devices

Hors ligne

#4 Le 25/11/2021, à 08:55

Lionel90

Re : [Résolu] Avertissements lors de mise à jour

Alors en procédant dans l'ordre:

find /etc/apt -type f -name '*.list*' -exec bash -c 'echo -e "\n\t$1\n"; [[ $1 = *".list" ]] && cat -n "$1"' _ '{}' \;
[sudo] Mot de passe de xxxxxx : 

	/etc/apt/sources.list.save


	/etc/apt/sources.list.d/skypeforlinux.list

     1	deb [arch=amd64] https://repo.skype.com/deb stable main

	/etc/apt/sources.list.d/skype-stable.list

     1	deb [arch=amd64] https://repo.skype.com/deb stable main

	/etc/apt/sources.list.d/google-chrome.list
dpkg -l | grep -v ^ii
Souhait=inconnU/Installé/suppRimé/Purgé/H=à garder
| État=Non/Installé/fichier-Config/dépaqUeté/échec-conFig/H=semi-installé/W=attend-traitement-déclenchements
|/ Err?=(aucune)/besoin Réinstallation (État,Err: majuscule=mauvais)
||/ Nom                                        Version                               Architecture Description
+++-==========================================-=====================================-============-======================================================================================================
cd /etc/apt/sources.list.d && sudo rm -v skype-stable* ; cd && sudo apt clean && sudo apt update
'skype-stable.list' supprimé
Atteint :1 http://fr.archive.ubuntu.com/ubuntu focal InRelease
Atteint :2 http://archive.canonical.com/ubuntu focal InRelease                                                                               
Atteint :3 http://fr.archive.ubuntu.com/ubuntu focal-updates InRelease                                                                       
Atteint :4 http://fr.archive.ubuntu.com/ubuntu focal-backports InRelease                                                                     
Atteint :5 https://dl.google.com/linux/chrome/deb stable InRelease                                                                           
Atteint :6 https://repo.skype.com/deb stable InRelease                                                                         
Atteint :7 http://security.ubuntu.com/ubuntu focal-security InRelease 
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
1 paquet peut être mis à jour. Exécutez « apt list --upgradable » pour le voir.
dpkg -l | grep "nvidia"
ii  libnvidia-cfg1-390:amd64                   390.144-0ubuntu0.20.04.1              amd64        NVIDIA binary OpenGL/GLX configuration library
ii  libnvidia-common-390                       390.144-0ubuntu0.20.04.1              all          Shared files used by the NVIDIA libraries
ii  libnvidia-compute-390:amd64                390.144-0ubuntu0.20.04.1              amd64        NVIDIA libcompute package
ii  libnvidia-compute-390:i386                 390.144-0ubuntu0.20.04.1              i386         NVIDIA libcompute package
ii  libnvidia-decode-390:amd64                 390.144-0ubuntu0.20.04.1              amd64        NVIDIA Video Decoding runtime libraries
ii  libnvidia-decode-390:i386                  390.144-0ubuntu0.20.04.1              i386         NVIDIA Video Decoding runtime libraries
ii  libnvidia-encode-390:amd64                 390.144-0ubuntu0.20.04.1              amd64        NVENC Video Encoding runtime library
ii  libnvidia-encode-390:i386                  390.144-0ubuntu0.20.04.1              i386         NVENC Video Encoding runtime library
ii  libnvidia-fbc1-390:amd64                   390.144-0ubuntu0.20.04.1              amd64        NVIDIA OpenGL-based Framebuffer Capture runtime library
ii  libnvidia-fbc1-390:i386                    390.144-0ubuntu0.20.04.1              i386         NVIDIA OpenGL-based Framebuffer Capture runtime library
ii  libnvidia-gl-390:amd64                     390.144-0ubuntu0.20.04.1              amd64        NVIDIA OpenGL/GLX/EGL/GLES GLVND libraries and Vulkan ICD
ii  libnvidia-gl-390:i386                      390.144-0ubuntu0.20.04.1              i386         NVIDIA OpenGL/GLX/EGL/GLES GLVND libraries and Vulkan ICD
ii  libnvidia-ifr1-390:amd64                   390.144-0ubuntu0.20.04.1              amd64        NVIDIA OpenGL-based Inband Frame Readback runtime library
ii  libnvidia-ifr1-390:i386                    390.144-0ubuntu0.20.04.1              i386         NVIDIA OpenGL-based Inband Frame Readback runtime library
ii  linux-objects-nvidia-390-5.11.0-27-generic 5.11.0-27.29~20.04.1                  amd64        Linux kernel nvidia modules for version 5.11.0-27 (objects)
ii  linux-objects-nvidia-390-5.11.0-40-generic 5.11.0-40.44~20.04.2+1                amd64        Linux kernel nvidia modules for version 5.11.0-40 (objects)
ii  linux-signatures-nvidia-5.11.0-27-generic  5.11.0-27.29~20.04.1                  amd64        Linux kernel signatures for nvidia modules for version 5.11.0-27-generic
ii  linux-signatures-nvidia-5.11.0-40-generic  5.11.0-40.44~20.04.2+1                amd64        Linux kernel signatures for nvidia modules for version 5.11.0-40-generic
ii  nvidia-compute-utils-390                   390.144-0ubuntu0.20.04.1              amd64        NVIDIA compute utilities
ii  nvidia-dkms-390                            390.144-0ubuntu0.20.04.1              amd64        NVIDIA DKMS package
ii  nvidia-driver-390                          390.144-0ubuntu0.20.04.1              amd64        NVIDIA driver metapackage
ii  nvidia-kernel-common-390                   390.144-0ubuntu0.20.04.1              amd64        Shared files used with the kernel module
ii  nvidia-kernel-source-390                   390.144-0ubuntu0.20.04.1              amd64        NVIDIA kernel source package
ii  nvidia-prime                               0.8.16~0.20.04.1                      all          Tools to enable NVIDIA's Prime
ii  nvidia-settings                            470.57.01-0ubuntu0.20.04.2            amd64        Tool for configuring the NVIDIA graphics driver
ii  nvidia-utils-390                           390.144-0ubuntu0.20.04.1              amd64        NVIDIA driver support binaries
ii  screen-resolution-extra                    0.18build1                            all          Extension for the nvidia-settings control panel
ii  xserver-xorg-video-nvidia-390              390.144-0ubuntu0.20.04.1              amd64        NVIDIA binary Xorg driver
ubuntu-drivers devices
WARNING:root:_pkg_get_support nvidia-driver-390: package has invalid Support Legacyheader, cannot determine support level
== /sys/devices/pci0000:00/0000:00:01.0/0000:01:00.0 ==
modalias : pci:v000010DEd00000DF4sv00001025sd00000512bc03sc00i00
vendor   : NVIDIA Corporation
model    : GF108M [GeForce GT 540M]
driver   : nvidia-340 - distro non-free
driver   : nvidia-driver-390 - distro non-free recommended
driver   : xserver-xorg-video-nouveau - distro free builtin

Dernière modification par Lionel90 (Le 25/11/2021, à 08:55)

Hors ligne

#5 Le 25/11/2021, à 09:16

Qid

Re : [Résolu] Avertissements lors de mise à jour

Lionel90 a écrit :

Que faire pour solutionner ce problème de doublons ?

Bah...
Supprimer soit "/etc/apt/sources.list.d/skypeforlinux.list" soit "/etc/apt/sources.list.d/skype-stable.list" qui pointent strictement au même endroit...


"GNU/Linux c'est que du bon mais M$ Windows ce n'est pas si mal"
Référent technique d'un Groupe d'Utilisateur du Libre
plus d'info sur mon profil

Hors ligne

#6 Le 25/11/2021, à 10:49

nany

Re : [Résolu] Avertissements lors de mise à jour

Qid a écrit :
Lionel90 a écrit :

Que faire pour solutionner ce problème de doublons ?

Bah...
Supprimer soit "/etc/apt/sources.list.d/skypeforlinux.list" soit "/etc/apt/sources.list.d/skype-stable.list" qui pointent strictement au même endroit...

Ça y est c’est fait grâce à la première commande que j’ai donnée.

Lionel90 a écrit :
'skype-stable.list' supprimé

Hors ligne

#7 Le 25/11/2021, à 11:46

Qid

Re : [Résolu] Avertissements lors de mise à jour

nany a écrit :
Qid a écrit :
Lionel90 a écrit :

Que faire pour solutionner ce problème de doublons ?

Bah...
Supprimer soit "/etc/apt/sources.list.d/skypeforlinux.list" soit "/etc/apt/sources.list.d/skype-stable.list" qui pointent strictement au même endroit...

Ça y est c’est fait grâce à la première commande que j’ai donnée.

Lionel90 a écrit :
'skype-stable.list' supprimé

Ok... Je n'aurai donc pas dû intervenir... J'avais pas regardé dans le détail ta proposition de commande


"GNU/Linux c'est que du bon mais M$ Windows ce n'est pas si mal"
Référent technique d'un Groupe d'Utilisateur du Libre
plus d'info sur mon profil

Hors ligne

#8 Le 25/11/2021, à 20:32

Lionel90

Re : [Résolu] Avertissements lors de mise à jour

Merci pour l'aide.

Hors ligne