Contenu | Rechercher | Menus

Annonce

DVD, clés USB et t-shirts Ubuntu-fr disponibles sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#26 Le 25/04/2022, à 14:40

jplemoine

Re : os-prober désactivé pour Ubuntu 22.04

Perso, je suis en EFI (et donc en GPT ?) : donc que des partitions "primaires" avec un partition au départ en vfat pour le /boot/efi.


Membre de l'ALDIL (Association Lyonnaise pour le Développement de l'Informatique Libre)
- En pro, après 20 ans de développement, administrateur Linux / Unix depuis Avril 2019.
- En privé, sous Ubuntu-Xubuntu depuis 2009.

En vacances du forum jusqu’à nouvel ordre

Hors ligne

#27 Le 25/04/2022, à 20:04

Coeur Noir

Re : os-prober désactivé pour Ubuntu 22.04

Bybeu a écrit :

J'ai pris l'option "Installer à côté" (…)

Moi aussi ma question c'est pour savoir si je peux cramer tout ce foutoir car dès Precise quand j'ai acheté ce PC j'ai viré toutes les partitions daubiques de Dell (diags/reco..) pour me faire un truc simple et propre avec rien que deux partitions primaires sur BIOS/MBR. Un truc simple et sans FS de merde comme le FAT.

La prochaine fois essaie avec « autre chose » où tu désigneras manuellement dans quelle partition tu veux installer la racine / du système, ça devrait mieux se passer.

Les modes ( semi ) automatiques d'installation ne se comportent bien que « derrière » des bios UEFI. En mode legacy ou vieux bios, ça cafouille, il vaudra mieux la méthode manuelle « autre chose ».

Le partitionnement GPT est un vrai progrès par rapport au mbr/dos, plus sûr et plus simple à l'usage. Et inévitable sur des supports > 2,2To.


DébuterDocBien rédigerRetour commandeInsérer image | illustrations & captures d'écran <>

Hors ligne

#28 Le 25/04/2022, à 20:28

Bybeu

Re : os-prober désactivé pour Ubuntu 22.04

Ouais pour >2To, y'a pas le choix... mais foutre un bout de FAT32 au cœur de mon système roll
En attendant, je re DL l'iso de Jammy et je me fais une VM pour voir comment c'est foutu sur un disque dédié mono OS.
J'ai brûlé sda4 & 5 et bougé sda3 tout au bout du disque avant le swap, puis update-grub. En attendant de virer sda3 et de reflaguer sda1 comme boot...

sudo fdisk -x /dev/sda
[sudo] Mot de passe de moi : 
Disque /dev/sda : 238,47 GiB, 256060514304 octets, 500118192 secteurs
Disk model: LITEONIT LMT-256
Unités : secteur de 1 × 512 = 512 octets
Taille de secteur (logique / physique) : 512 octets / 512 octets
taille d'E/S (minimale / optimale) : 512 octets / 512 octets
Type d'étiquette de disque : dos
Identifiant de disque: 0x000122ab

Périphérique Amorçage     Début       Fin  Secteurs Id Type Début-C/T/S   Fin-C/T/S Attr.
/dev/sda1                  2048 234188799 234186752 83 Linu     0/32/33  1023/254/2
/dev/sda4             234188800 467322879 233134080 83 Linu 1023/254/63 1023/254/63 (recréée pour mon essai de VM, plus assez de place dans sda1) 
/dev/sda3    *        467322880 468373503   1050624 ef EFI  1023/254/63 1023/254/63    80
/dev/sda2             468373504 500117503  31744000 82 part 1023/254/63 1023/254/63 



Les entrées de la table de partitions ne sont pas dans l'ordre du disque.
moi@lap

Dernière modification par Bybeu (Le 25/04/2022, à 20:34)

Hors ligne

#29 Le 25/04/2022, à 21:53

Bybeu

Re : os-prober désactivé pour Ubuntu 22.04

Je viens d'essayer en choisissant "Autre chose" sur une VM virtualbox (CM non-EFI) : tout le disque en ext4 pour sda1 et le boot loader dans sda. En outrepassant 2 avertissements sur l'absence de partition EFI, on installe (minimum sans mises à jour pour aller vite)... et hop ça boote quand-même. Pire, vue de gparted /dev/sda1 n'est même pas marquée 'boot' !
Pour torturer un peu, j'ai activé le drapeau 'boot' : la gparted rajoute automatiquement le drapeau 'esp'
update-grub à tout hasard... et reboot OK malgré ça :-)

Je vais tenter de supprimer sda3 sur mon PC maintenant. J'ai fait une copie iso de sda3 avec gnome-disks quand-même

[EDIT...le lendemain]
(PS, le pc ne permet de ne connecter qu'un seul disque... donc tournevis, mais avantage, on est dispensé d'y regarder à trois fois pour ne pas faire d'erreur sur les sdX).
Ça y est c'est fait, quelle suée smile, mais voilà le résultat final

sudo fdisk -x /dev/sda
[sudo] Mot de passe de moi : 
Disque /dev/sda : 238,47 GiB, 256060514304 octets, 500118192 secteurs
Disk model: LITEONIT LMT-256
Unités : secteur de 1 × 512 = 512 octets
Taille de secteur (logique / physique) : 512 octets / 512 octets
taille d'E/S (minimale / optimale) : 512 octets / 512 octets
Type d'étiquette de disque : dos
Identifiant de disque: 0x000122ab

Périphérique Amorçage     Début       Fin  Secteurs Id Type                                Début-C/T/S   Fin-C/T/S Attr.
/dev/sda1    *             2048 468373503 468371456 83 Linux                                   0/32/33  1023/254/2    80
/dev/sda2             468373504 500117503  31744000 82 partition d'échange Linux / Solaris 1023/254/63 1023/254/63 
moi@lap:~$

Mais avant, comme c'était un peu risqué, j'ai regardé comment ça se présentait sur un disque physique de remplacement (je m'étais commandé un ~petit~ mSATA 128Go d'occase pour tester en vrai). L'install par défaut sur ce dernier, disque entier avec l'assistant tout automatique avait créé 3 partitions après le tout premier Mo. Un vrai plaisir pour jouer : depuis la live j'ai supprimé sda1 (1Mo) et sda2 (~500Mo) et agrandi sda3 à tout le disque avec gparted. Évidement ça bootait plus.
Depuis la live, ouvrir sda3 avec nautilus pour la monter, et en terminal :

sudo grub-install --boot-directory=/media/ubuntu/UUID-de-sda3/boot  --force /dev/sda

Ne pas oublier de passer en commentaire (ou supprimer) la déclaration de sda2 dans fstab, sinon ça coince.
Reboot OK smile
Comme il restait une seule partition en sda3 c'était crasseux :

sudo fdisk /dev/sda
x
f
r
w
q

Et voilà, comme disent les anglais.

Fort de cette expérience j'étais chaud pour le faire en plus-vrai sur mon mSATA 256Go habituel. Évidement ça a foiré : après suppression de sda3 (la partition ESP dans ce cas) et la manip update-grub façon ~ci-dessus~...

BIOS a écrit :

~MISSING OPERATING SYSTEM~

  une courte nuit de sommeil la dessus, re-essais avec

#jamais eu besoin de ou essayé --force ci-dessous (c'était mon vrai disque quoi !)
sudo grub-install --boot-directory=/media/ubuntu/UUID-de-sda1/boot  /dev/sda   #exactement comme le coup précédent
echo$?
0
=>Boot [b]KO[/b] :(

sudo grub-install --boot-directory=/media/ubuntu/UUID-de-sda1/boot  --efi-directory=/media/ubuntu/UUID-de-sda1/boot /dev/sda
erreur style ~2 disques spécifiés~

sudo grub-install --boot-directory=/media/ubuntu/UUID-de-sda1/boot --disk-module=biosdisk  /dev/sda
erreur style ~2 disques spécifiés~

Creuse-gratte-cherche... idée, vérif : pas de drapeau boot sur sda1, ce voleur d'installeur me l'avait confisqué.
Rajouté (tiens, esp n'est pas lié ici)
Boot OK smile smile smile

Dernière modification par Bybeu (Le 26/04/2022, à 14:44)

Hors ligne