Contenu | Rechercher | Menus

Annonce

DVD, clés USB et t-shirts Ubuntu-fr disponibles sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 18/08/2022, à 14:30

BernieLou

[Resolu] Montage ressource windows sur ubuntu 20.04

Bonjour,
J'ai un souci que je ne comprends pas :
Dans un terminal.
Lorsque je monte ma ressource windows de cette façon :
sudo mount -t cifs -o username=utilisateur_windows,rw,iocharset=utf8,file_mode=0777,dir_mode=0777 //adressIP_PC_Windows/repertoireSource /media/partage
On me demande mon mot de passe Windows et la ressource se monte sans souci.

J'ai créer un fichier .smbcredentials dans root comprenant
username=utilisateur_windows
password=password_utilisateur_windows

Ensuite dans fstab j'ai écrit la ligne suivante :
//adressesIP_PC_Windows/repertoireSource /media/partage cifs _netdev,rw,username=utilisateur_windows,credentials=/root/.smbcredentials, iocharset=utf8,uid=1000,sec=ntlmv2,file_mode=0777,dir_mode=0777,vers=2.0

Si je tape ensuite : sudo mount -a j'ai la réponse :
mount error(13): permission denied

après redémarrage de ubuntu si je veux monter et accéder à ma ressource j'ai :
mount: /media/partage: opération permitted for root only

si dans la même session je retape dans un terminal :
sudo mount -t cifs -o username=utilisateur_windows,rw,iocharset=utf8,file_mode=0777,dir_mode=0777 //adressIP_PC_Windows/repertoireSource /media/partage
la ressouce se monte sans souci après que j'ai taper mon password_windows.

Si quelqu'un peut m'expliquer....
Pour info :
1 - j'ai exactement la même ligne dans fstab pour monter une autre ressource qui se trouve sur un NAS (avec username=nom_user_NAS et .smbcredentials avec les références NAS)) et celle-ci se monte à chaque fois sans souci.
2 - c'est encore pire si dans fstab je mets mon username_ubuntu avec mes reférences ubuntu dans un .smbcrédentials
3 - que je mette enfin de ligne vers=2.0 ou vers=1.0 ou rien du tout le souci reste le même.

Voilà, je sais c'est long mais franchement je sèche. D'habitude je trouve mes réponses sur ce forum mais là.... RIEN !

Dernière modification par BernieLou (Le 18/08/2022, à 22:14)

Hors ligne

#2 Le 18/08/2022, à 14:36

xubu1957

Re : [Resolu] Montage ressource windows sur ubuntu 20.04

Bonjour,

Pour éviter de nous esquinter les yeux, peux tu te servir du Retour utilisable de commande ?

Pour ajouter toi-même les balises code à ton précédent message #1 :

  • Cliquer sur  le lien « Modifier » en bas à droite du message

  • Sélectionner le texte

  • Cliquer sur le <> de l'éditeur de message

1642675956.jpg

sudo mount -t cifs -o username=utilisateur_windows,rw,iocharset=utf8,file_mode=0777,dir_mode=0777 //adressIP_PC_Windows/repertoireSource /media/partage

J'ai créer un fichier .smbcredentials dans root comprenant

username=utilisateur_windows
password=password_utilisateur_windows

Ensuite dans fstab j'ai écrit la ligne suivante :

//adressesIP_PC_Windows/repertoireSource /media/partage cifs _netdev,rw,username=utilisateur_windows,credentials=/root/.smbcredentials, iocharset=utf8,uid=1000,sec=ntlmv2,file_mode=0777,dir_mode=0777,vers=2.0

Si je tape ensuite :

sudo mount -a

j'ai la réponse :

mount error(13): permission denied

après redémarrage de ubuntu si je veux monter et accéder à ma ressource j'ai :

mount: /media/partage: opération permitted for root only

si dans la même session je retape dans un terminal :

sudo mount -t cifs -o username=utilisateur_windows,rw,iocharset=utf8,file_mode=0777,dir_mode=0777 //adressIP_PC_Windows/repertoireSource /media/partage

Voir règles du forum > balises BB code

Balise CODE :

C'est la balise à utiliser pour donner de longs messages d'erreurs, des contenus de fichiers de configuration, des commandes à taper, etc … Elle permet des messages plus "compacts", et est moins ambiguë que d'autres polices sur certains caractères.

Dernière modification par xubu1957 (Le 18/08/2022, à 15:23)


Conseils pour les nouveaux demandeurs et pas qu'eux
Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.                   Membre de Linux-Azur

En ligne

#3 Le 18/08/2022, à 14:43

iznobe

Re : [Resolu] Montage ressource windows sur ubuntu 20.04

Bonjour ,

Ensuite dans fstab j'ai écrit la ligne suivante :

//adressesIP_PC_Windows/repertoireSource /media/partage cifs _netdev,rw,username=utilisateur_windows,credentials=/root/.smbcredentials, iocharset=utf8,uid=1000,sec=ntlmv2,file_mode=0777,dir_mode=0777,vers=2.0

ceci est un non sens , tu as du mal comprendre un épisode dans la doc , il y a une confusion quelquepart .
une ligne de ce type est dedié au partage de dossier via samba sur un serveur . elle ne peut donc commencer par :

//adressesIP

Si tu desires monter un partage distant , c' est tout bon a part : username=utilisateur_windows .
vu que tu montes le partage windows sur le client ( ubuntu ) , le montage doit etre lié a un utilisateur d' ubuntu .

Autre remarque les espaces dans les nom de fichiers ne sont pas tolerés :

adressesIP_PC_Windows/repertoireSource 

il y a , dans la doc , me semble t il moyen de contourner ce soucis , dans une des pages : " /040 " de mémoire , mais je ne le conseille pas , c ' est toujours source de probleme .
les caracteres speciaux et accentués il vaut mieux eviter .

et mes pauvres yeux en ont pris un coup ...
essaie de mettre les vrais valeurs si tu peux , ca serait plus simple pour visualiser ce qui ne va pas , hors mis l' utilisateur bien sur .

Dernière modification par iznobe (Le 18/08/2022, à 14:58)


retour utilisable de commande
MSI Z490A-pro , i7 10700 , 32 GB RAM .

Hors ligne

#4 Le 18/08/2022, à 15:36

BernieLou

Re : [Resolu] Montage ressource windows sur ubuntu 20.04

@iznobe

Oups, désolé pour tes yeux....
Désolé aussi pour la confusion dans mon vocabulaire : effectivement j'essaie de monter des dossiers partagés sur windows

à force de tester mille et un trucs, j'ai trouvé la (une ?) solution à mon problème. En fait je montais mon dossier partagé sur windows en utilisant le même .smbcredentials que celui que j'utilisais pour mon NAS. Il semble qu'il faille un .smbcredentials différent lorsque les username et password ne sont pas les mêmes.
j'ai déplacé mes fichiers .smbcredentials dans /home/user/
En revanche cela ne fonctionne que si je mets mon ID_Windows si je mets uniquement mon ID_Ubuntu ça ne marche pas. uid=1000 faisant réference à mon ID_ubuntu
donc..... Roulement de tambour..... Voilà les lignes de mon fstab concernant ces partages

............
192.168.1.XXX/partage01 /media/partage01 cifs _netdev,rw,username=mon_ID_Windows,credentials=/home/user/.smbcredentials01, iocharset=utf8,uid=1000,sec=ntlmv2,file_mode=0777,dir_mode=0777,vers=2.0
192.168.1.YYY/partage02 /media/partage02 cifs _netdev,rw,username=mon_ID_Windows,credentials=/home/user/.smbcredentials02, iocharset=utf8,uid=1000,sec=ntlmv2,file_mode=0777,dir_mode=0777,vers=2.0
...........

Et depuis mon partage windows se monte sans soucis à chaque redémarrage.
Si je reviens j'espère que voudras bien excuser par avance mes lacunes concernant le vocabulaire ou l'usage du forum.
Je ne devrais pas le dire mais je n'utilise Linux que depuis 3 ans et j'en ai 73 donc pas les mêmes réflexes qu'un jeune geek.

En tout cas merci de t'être penché sur mon problème.
Cdlt
Bernard

Dernière modification par BernieLou (Le 18/08/2022, à 15:53)

Hors ligne

#5 Le 18/08/2022, à 21:04

iznobe

Re : [Resolu] Montage ressource windows sur ubuntu 20.04

j ' avoue que ma dernière configuration pour monter un partage sur serveur windows remonte a .... pas mal d' années en fait , au moins 7 ou 8 , lorsque je m' étais penché sur la question pour les photos familiale que ma femme se regale de mitrailler et de ne pas trier roll


C ' est vrai que le langage informatique est souvent difficile a maîtriser quand on ne creuse pas la question , mais c' est important de bien se comprendre pour aider une autre personne a résoudre un soucis , du coup on est souvent obligé d' être a cheval sur les termes employés si on veut d' une part bien renseigné la personne , et d' autre part eviter de perdre du temps ( dans les 2 camps ) et rester efficace .

Il semble qu'il faille un .smbcredentials différent lorsque les username et password ne sont pas les mêmes.

j ' ai pas tout compris ce que tu veux dire par là .
tu indiquais 2 noms d' utilisateur et 2 mots de passes dans le meme fichier ?

Sur 22.04 , il y a eu quelques changements , mais je ne sais pas en quoi ca consiste exactement sauf une option qu ' on ne peut plus utiliser a priori : windows_name .

En tout cas , je suis content que tu ai trouvé la solution a ton probleme wink
il faudrait donc editer ton 1er message de cette discussion afin d' ajouter [ resolu ] au titre ( pour faciliter la recherche pour d' autres personne ) .

Merci et au plaisir .

Dernière modification par iznobe (Le 18/08/2022, à 23:24)


retour utilisable de commande
MSI Z490A-pro , i7 10700 , 32 GB RAM .

Hors ligne