Contenu | Rechercher | Menus

Annonce

DVD, clés USB et t-shirts Ubuntu-fr disponibles sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 19/08/2022, à 14:58

bonuscad

[RESOLU]commande ubuntu-drivers : le retour est vide !

Bonjour,
J'ai fait l'upgrade de la distribution proposée (20.04LTS -> 22.04LTS)
Cela c'est relativement bien passé, mais une chose m'intrigue au niveau de l'affichage (celui-ci cependant fonctionne).
Dans "Logiciels et mises à jour" dans l'onglet "Pilotes additionnels" la fenêtre est vide "Aucun pilote additionnel disponible"

Pour info au démarrage j'ai 2 lignes qui s'affiche rapidement (pas de pause possible) je retranscrit les messages (fautes de recopie possible)

/dev/sdb1: clean,351209/14655400 files, 5092910/50607360 blocks
[    4.679106] mtd device must be supplied (device name is empty)

Je vous donne quelques retours de commandes

bruno@Precision-T1500:~$ lspci -vnn | grep -A 12 '\[030[02]\]' | grep -Ei "vga|3d|display|kernel"
01:00.0 VGA compatible controller [0300]: NVIDIA Corporation G96CGL [Quadro FX 580] [10de:0659] (rev a1) (prog-if 00 [VGA controller])
	Kernel driver in use: nouveau
	Kernel modules: nvidiafb, nouveau
bruno@Precision-T1500:~$ 
bruno@Precision-T1500:~$ sudo lshw -enable pci -class display
  *-display                 
       description: VGA compatible controller
       produit: G96CGL [Quadro FX 580]
       fabricant: NVIDIA Corporation
       identifiant matériel: 0
       information bus: pci@0000:01:00.0
       nom logique: /dev/fb0
       version: a1
       bits: 64 bits
       horloge: 33MHz
       fonctionnalités: pm msi pciexpress vga_controller bus_master cap_list rom fb
       configuration : depth=32 driver=nouveau latency=0 resolution=1920,1080
       ressources : irq:32 mémoire:fa000000-faffffff mémoire:c0000000-dfffffff mémoire:f8000000-f9ffffff portE/S:dc00(taille=128) mémoire:c0000-dffff
bruno@Precision-T1500:~$ 
bruno@Precision-T1500:~$ xrandr
Screen 0: minimum 320 x 200, current 1920 x 1080, maximum 8192 x 8192
DVI-I-1 connected 1920x1080+0+0 (normal left inverted right x axis y axis) 531mm x 299mm
   1920x1080     60.00*+  59.96    59.93  
   1920x1200     59.95  
   1600x1200     65.00    60.00  
   1680x1050     59.95    59.88  
   1600x1024     60.17  
   1400x1050     59.98  
   1600x900      59.95    59.82  
   1280x1024     60.02  
   1440x900      59.89    59.90  
   1400x900      59.96    59.88  
   1280x960      60.00  
   1368x768      59.88    59.85  
   1360x768      59.80    59.96  
   1280x800      59.81    59.91  
   1152x864      60.00  
   1280x720      59.86    59.74  
   1024x768      60.00  
   896x672       60.01  
   1024x576      59.95    59.96    59.90    59.82  
   960x600       59.93    60.00  
   960x540       59.96    59.99    59.63    59.82  
   800x600       65.00    60.00    60.32    56.25  
   840x525       60.01    59.88  
   864x486       59.92    59.57  
   800x512       60.17  
   700x525       59.98  
   800x450       59.95    59.82  
   640x512       60.02  
   720x450       59.89  
   700x450       59.96    59.88  
   640x480       60.00    66.67    59.94  
   684x384       59.88    59.85  
   680x384       59.80    59.96  
   640x400       59.88    59.98  
   576x432       60.06  
   640x360       59.86    59.83  
   512x384       60.00  
   512x288       60.00    59.92  
   480x270       59.63    59.82  
   400x300       60.32    56.34  
   432x243       59.92    59.57  
   320x240       60.05  
DP-1 disconnected (normal left inverted right x axis y axis)
DP-2 disconnected (normal left inverted right x axis y axis)
bruno@Precision-T1500:~$ 
bruno@Precision-T1500:~$ grep "drivers" /var/log/Xorg.0.log
[    16.350] (WW) Hotplugging is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.
[    16.511] (II) Loading /usr/lib/xorg/modules/drivers/modesetting_drv.so
[    16.512] (II) Loading /usr/lib/xorg/modules/drivers/fbdev_drv.so
[    16.513] (II) Loading /usr/lib/xorg/modules/drivers/vesa_drv.so
bruno@Precision-T1500:~$ 

Et bizarrement aucun retour de:

bruno@Precision-T1500:~$ ubuntu-drivers devices
bruno@Precision-T1500:~$ 

Seule cette commande renvoie quelque chose

bruno@Precision-T1500:~$ ubuntu-drivers debug
=== log messages from detection ===
DEBUG:root:Loading custom detection plugin /usr/share/ubuntu-drivers-common/detect/arm-gles.py
DEBUG:root:plugin /usr/share/ubuntu-drivers-common/detect/arm-gles.py return value: None
DEBUG:root:Loading custom detection plugin /usr/share/ubuntu-drivers-common/detect/sl-modem.py
DEBUG:root:plugin /usr/share/ubuntu-drivers-common/detect/sl-modem.py return value: None
=== modaliases in the system ===
platform:dcdbas
platform:eisa
platform:microcode
platform:Fixed MDIO bus
acpi:PNP0C0C:
platform:coretemp
platform:dell_smm_hwmon
input:b0011v0001p0001eAB41-e0,1,4,11,14,k71,72,73,74,75,76,77,79,7A,7B,7C,7D,7E,7F,80,8C,8D,8E,8F,94,98,9B,9C,9D,9E,9F,A2,A3,A4,A5,A6,AC,AD,B7,B8,B9,BF,CD,D4,D7,D9,E0,E1,E2,E3,EC,F0,ram4,l0,1,2,sfw
platform:pcspkr
platform:vboxdrv
pci:v00008086d00003B22sv00001028sd00000427bc01sc06i01
pci:v000014E4d00001692sv00001028sd00000427bc02sc00i00
pci:v00008086d0000D155sv00000028sd00000027bc08sc80i00
pci:v00008086d00003B08sv00001028sd00000427bc06sc01i00
platform:gpio_ich
acpi:PNP0800:
acpi:PNP0103:
acpi:PNP0C04:
platform:iTCO_wdt
pci:v00008086d0000D150sv00000028sd00000027bc08sc80i00
pci:v00008086d00003B64sv00001028sd00000427bc07sc80i00
mei::6733a4db-0476-4e7b-b3af-bcfc29bee7a7:04:
mei::a12ff5ca-facb-4cb4-a958-19a23b2e6881:01:
mei::d2ea63bc-5f04-4997-9454-8cadf4e3ef8a:01:
mei::05b79a6f-4628-4d7f-899d-a91514cb32ab:01:
mei::bb875e12-cb58-4d14-ae93-8566183c66c7:01:
mei::9b27fd6d-ef72-4967-bcc2-471a32679620:01:
mei::42b3ce2f-bd9f-485a-96ae-26406230b1ff:01:
mei::309dcde8-ccb1-4062-8f78-600115a34327:01:
mei::55213584-9a29-4916-badf-0fb7ed682aeb:01:
mei::fbf6fcf1-96cf-4e2e-a6a6-1bab8cbe36b1:01:
mei::f908627d-13bf-4a04-b91f-a64e9245323d:01:
mei::12f80028-b4b7-4b2d-aca8-46e0ff65814c:01:
pci:v00008086d00003B56sv00001028sd00000427bc04sc03i00
hdaudio:v10EC0662r00100101a01
input:b0000v0000p0000e0000-e0,5,kramlsfw6,
input:b0000v0000p0000e0000-e0,5,kramlsfw4,
input:b0000v0000p0000e0000-e0,5,kramlsfw2,
input:b0000v0000p0000e0000-e0,5,kramlsfwD,
pci:v00008086d0000D158sv00000028sd00000027bc08sc80i00
pci:v00008086d0000244Esv00001028sd00000427bc06sc04i01
pci:v00001186d00004300sv00001186sd00004300bc02sc00i00
pci:v00001102d00007003sv00001102sd00000040bc09sc80i00
pci:v00001102d00004001sv00001102sd00000010bc0Csc00i10
pci:v00001102d00000004sv00001102sd00002006bc04sc01i00
pci:v00008086d00003B30sv00001028sd00000427bc0Csc05i00
pci:v00008086d0000D131sv00001028sd00000427bc06sc00i00
pci:v00008086d0000D156sv00000028sd00000027bc08sc80i00
pci:v000010DEd00000659sv000010DEsd0000063Abc03sc00i00
i2c:adt7473
pci:v00008086d0000D151sv00000028sd00000027bc08sc80i00
usb:v062Ap4102d0103dc00dsc00dp00ic03isc01ip02in00
hid:b0003g0001v0000062Ap00004102
input:b0003v062Ap4102e0110-e0,3,kra28,mlsfw
input:b0003v062Ap4102e0110-e0,1,2,4,k110,111,112,113,114,r0,1,6,8,B,C,am4,lsfw
input:b0003v062Ap4102e0110-e0,1,2,3,4,k71,72,73,74,77,78,80,82,83,85,86,87,88,89,8A,8B,8C,8E,90,96,98,9B,9C,9E,9F,A1,A3,A4,A5,A6,A7,A8,A9,AB,AC,AD,AE,B0,B1,B2,B5,B6,CC,CE,CF,D0,D1,D2,D4,D8,D9,DB,DF,E0,E1,E4,E5,E6,E7,E8,E9,EA,EB,F0,F1,F4,100,161,162,166,16A,16E,172,174,176,177,178,179,17A,17B,17C,17D,17F,180,182,183,185,188,189,18C,18D,18E,18F,190,191,192,193,195,197,198,199,19A,19C,1A0,1A1,1A2,1A3,1A4,1A5,1A6,1A7,1A8,1A9,1AA,1AB,1AC,1AD,1AE,1AF,1B0,1B1,1B7,1BA,240,241,242,243,244,245,246,247,248,249,24A,250,251,260,261,262,263,264,265,r6,C,a20,m4,lsfw
usb:v8087p0020d0000dc09dsc00dp01ic09isc00ip00in00
usb:v1D6Bp0002d0515dc09dsc00dp00ic09isc00ip00in00
usb:v046Dp08C1d0005dc00dsc00dp01icFFisc01ip00in00
input:b0003v046Dp08C1e0005-e0,1,kD4,ramlsfw
usb:v046Dp08C1d0005dc00dsc00dp01ic01isc02ip00in03
usb:v046Dp08C1d0005dc00dsc00dp01icFFisc02ip00in01
usb:v046Dp08C1d0005dc00dsc00dp01ic01isc01ip00in02
pci:v00008086d0000D157sv00000028sd00000027bc08sc80i00
cpu:type:x86,ven0000fam0006mod001E:feature:,0000,0001,0002,0003,0004,0005,0006,0007,0008,0009,000B,000C,000D,000E,000F,0010,0011,0013,0015,0016,0017,0018,0019,001A,001C,001D,001F,002B,0034,003B,003D,0068,006B,006C,006D,006F,0070,0072,0074,0075,0076,0078,0079,007C,0080,0082,0083,0084,0085,0086,0087,0088,0089,008D,008E,008F,0093,0094,0097,00C0,00EB,00ED,00F0,00F1,00F3,00F5,00F6,00F9,00FA,00FB,00FD,00FF,0100,0101,0102,0103,0104,0165,016C,01C0,01C1,025A,025B,025C,025F
dmi:bvnDellInc.:bvr2.2.0:bd07/06/2010:br8.15:svnDellInc.:pnPrecisionT1500:pvr00:rvnDellInc.:rn0XC7MM:rvrA01:cvnDellInc.:ct3:cvr:sku0:
pci:v00008086d00002CA2sv00008086sd00008086bc06sc00i00
pci:v00008086d00002CA0sv00008086sd00008086bc06sc00i00
pci:v00008086d00002CABsv00008086sd00008086bc06sc00i00
pci:v00008086d00002C91sv00008086sd00008086bc06sc00i00
pci:v00008086d00002C9Csv00008086sd00008086bc06sc00i00
pci:v00008086d00002CA9sv00008086sd00008086bc06sc00i00
pci:v00008086d00002C51sv00008086sd00008086bc06sc00i00
pci:v00008086d00002C98sv00008086sd00008086bc06sc00i00
pci:v00008086d00002CA3sv00008086sd00008086bc06sc00i00
pci:v00008086d00002CA1sv00008086sd00008086bc06sc00i00
pci:v00008086d00002CAAsv00008086sd00008086bc06sc00i00
pci:v00008086d00002C90sv00008086sd00008086bc06sc00i00
pci:v00008086d00002C81sv00008086sd00008086bc06sc00i00
pci:v00008086d00002CA8sv00008086sd00008086bc06sc00i00
pci:v00008086d00002C99sv00008086sd00008086bc06sc00i00
acpi:LNXSYSTM:
acpi:LNXCPU:
acpi:LNXSYBUS:
acpi:PNP0C0F:
acpi:PNP0C01:
input:b0019v0000p0001e0000-e0,1,k74,ramlsfw
acpi:PNP0A08:PNP0A03:
acpi:PNP0B00:
acpi:PNP0C02:
acpi:PNP0303:PNP030B:
acpi:PNP0200:
acpi:PNP0100:
acpi:PNP0501:
acpi:PNP0000:
=== matching driver packages ===
bruno@Precision-T1500:~$ 

Pourquoi aucun pilote NVIDIA ne m'est proposée, alors que sous la 20.04LTS j'avais bien un pilote...?
Normal, pas normal?

Dernière modification par bonuscad (Le 19/08/2022, à 15:56)

Hors ligne

#2 Le 19/08/2022, à 15:08

ylag

Re : [RESOLU]commande ubuntu-drivers : le retour est vide !

Bonjour,

bonuscad a écrit :

Pourquoi aucun pilote NVIDIA ne m'est proposée, alors que sous la 20.04LTS j'avais bien un pilote...?

C'est un cas d'obsolescence programmée, ton ancien GPU doit utiliser le pilote NVIDIA 340, qui n'est plus dans les dépôts de la 22.04 ; c'est la raison pour laquelle la commande ubuntu-drivers ne donne aucun résultat pour ta carte sur la 22.04

Il faut se contenter du pilote libre «nouveau», ou bien peut-être essayer le pilote de série 340 proposé par ce PPA : nvidia-legacy

Note que je ne sais pas si c'est vraiment fonctionnel, d'autres que moi pourront te conseiller sur ce point.

A+

Dernière modification par ylag (Le 19/08/2022, à 15:10)

Hors ligne

#3 Le 19/08/2022, à 15:15

philon

Re : [RESOLU]commande ubuntu-drivers : le retour est vide !

Bonjour
et avec ceci

sudo apt install nvidia-settings

Hors ligne

#4 Le 19/08/2022, à 15:17

ylag

Re : [RESOLU]commande ubuntu-drivers : le retour est vide !

@jefvans :

Bonjour,

Installer nvidia-settings ne servira à rien s'il n'y a pas de pilote NVIDIA disponible.

A+

Dernière modification par ylag (Le 19/08/2022, à 15:17)

Hors ligne

#5 Le 19/08/2022, à 15:55

bonuscad

Re : [RESOLU]commande ubuntu-drivers : le retour est vide !

ylag a écrit :

Bonjour,

bonuscad a écrit :

Pourquoi aucun pilote NVIDIA ne m'est proposée, alors que sous la 20.04LTS j'avais bien un pilote...?

C'est un cas d'obsolescence programmée, ton ancien GPU doit utiliser le pilote NVIDIA 340, qui n'est plus dans les dépôts de la 22.04 ; c'est la raison pour laquelle la commande ubuntu-drivers ne donne aucun résultat pour ta carte sur la 22.04

Il faut se contenter du pilote libre «nouveau», ou bien peut-être essayer le pilote de série 340 proposé par ce PPA : nvidia-legacy

Note que je ne sais pas si c'est vraiment fonctionnel, d'autres que moi pourront te conseiller sur ce point.

A+

Merci de ta réponse.
J'ai essayé ton lien et effectivement il me propose le pilote 340.
Bien que cela fonctionne, la résolution est plus basse et mon écran n'est plus détecté et j'ai des erreurs qui se sont rajoutées au démarrage (que je n'ai pas relevés) en plus du précédent que j'avais mis au début de mon premier post.

Je suis donc revenu à l'état initial avec le pilote libre, je vais me contenté de ça, vu que ça fonctionne bien...

Hors ligne