Contenu | Rechercher | Menus

Annonce

DVD, clés USB et t-shirts Ubuntu-fr disponibles sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 18/09/2022, à 16:07

captain-plant

[RESOLU] Problèmes connecter un serveur sur VM avec la machine hôte

Bonjour smile,

Je fais en ce moment le cours : OpenClassroom -> Partie 1 : Montez un serveur de fichiers sous linux -> Chapitre 3 : Créez votre environnement de travail

Dans ce cours, il est question d'installer avec VirtualBox 2 VMs et de les configurer pour communiquer entre-elles :
- Une servira de client graphique
- Une servira de serveur

A la différence du cours, sachant que j'ai un ordi peu puissant, je n'ai pas installé de VM client mais uniquement la VM serveur avec ubuntu-server-22.04 ce qui n'a pas été simple déjà (et merci à l'aide sur ce forum) et ma machine hôte qui fait office de client est sur Lubuntu 22.04.

J'ai suivi et adapté les configurations du cours mais sachant que je ne fais pas exactement la même chose et que je découvre tout ça j'ai du mal à comprendre ce qui ne va pas. Voici les configurations des deux machines :

--------------------------------------------------------- Config machine hôte - Lubuntu 22.04 -------------------------------------------------------

A la base j'ai :

~$ ip a
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: enp4s0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc fq_codel state DOWN group default qlen 1000
    link/ether 00:13:77:3a:27:27 brd ff:ff:ff:ff:ff:ff
3: wlp3s0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc mq state DOWN group default qlen 1000
    link/ether 00:1b:77:2a:d3:dd brd ff:ff:ff:ff:ff:ff
~$ cat /etc/netplan/01-network-manager-all.yaml 
# Let NetworkManager manage all devices on this system
network:
  version: 2
  renderer: NetworkManager
~$

J'ai édité le seul fichier qu'il y avait par défaut dans `/etc/netplan` pour ajouter l'adresse IPv4 `192.168.29.2` à l'interface `enp4s0`  :

~$ cat /etc/netplan/01-network-manager-all.yaml 
# Let NetworkManager manage all devices on this system
network:
  version: 2
  renderer: NetworkManager
  ethernets:
    enp4s0:
      dhcp4: no
      dhcp6: no 
      addresses: [192.168.29.2/24] 
~$ 

Mais les modifications ne sont pas prise en compte même en faisant `sudo netplan apply` ou en redémarrant car j'ai toujours :

~$ ip a show dev enp4s0
2: enp4s0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc fq_codel state DOWN group default qlen 1000
    link/ether 00:13:77:3a:27:27 brd ff:ff:ff:ff:ff:ff
~$ 

Pour ajouter l'adresse IPv4 `192.168.29.2` sur l'interface `enp4s0` je fais avec la commande `ip`, mais ce n'est pas persistant :

~$ sudo ip addr add 192.168.29.2/24 dev enp4s0
~$ ip a show dev enp4s0
2: enp4s0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc fq_codel state DOWN group default qlen 1000
    link/ether 00:13:77:3a:27:27 brd ff:ff:ff:ff:ff:ff
    inet 192.168.29.2/24 scope global enp4s0
       valid_lft forever preferred_lft forever
~$ 

----------------------------------------------------------- Config VM - Ubuntu-server 22.04 -------------------------------------------------

A la base j'ai :

yann@serveur-vm:~$ ip a
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
 link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
 inet 127.0.0.1/8 scope host lo
 valid_lft forever preferred_lft forever
 inet6 ::1/128 scope host 
 valid_lft forever preferred_lft forever
2: enp0s3: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UP group default qlen 1000
 link/ether 08:00:27:4a:09:d3 brd ff:ff:ff:ff:ff:ff
 inet 10.0.2.15/24 metric 100 brd 10.0.2.255 scope global dynamic enp0s3
 valid_lft 84289sec preferred_lft 84289sec
 inet6 fe80::a00:27ff:fe4a:9d3/64 scope link 
 valid_lft forever preferred_lft forever
yann@serveur-vm:~$

J'ai ajouté une deuxième interface virtuelle avec un mode d'accès `Réseau interne` dans la configuration de la VM de virtualbox.

J'ai une nouvelle interface `enp0s8` en plus :

yann@serveur-vm:~$ ip a show dev enp0s8
3: enp0s8: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UP group default qlen 1000
 link/ether 08:00:27:19:37:30 brd ff:ff:ff:ff:ff:ff
 inet6 fe80::a00:27ff:fe19:3730/64 scope link 
 valid_lft forever preferred_lft forever
yann@serveur-vm:~$

Maintenant, je veux attribuer de façon persistante l'adresse IPv4 `192.168.29.1` à l'interface `enp0s8`. Pour cela, j'ai créé le fichier `/etc/netplan/60-lan-static.yaml` et j'ai mis dedans :

network:
 version: 2
 renderer: networkd
 ethernets:
   enp0s8:
     dhcp4: no
     dhcp6: no
     addresses: [192.168.29.1/24] 

Cela a bien marché car j'ai maintenant de façon permanente :

yann@serveur-vm:~$ ip a show dev enp0s8
3: enp0s8: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UP group default qlen 1000
 link/ether 08:00:27:19:37:30 brd ff:ff:ff:ff:ff:ff
 inet 192.168.29.1/24 brd 192.168.29.255 scope global enp0s8
    valid_lft forever preferred_lft forever
 inet6 fe80::a00:27ff:fe19:3730/64 scope link 
    valid_lft forever preferred_lft forever

---------------------------------------------------------- Les problèmes ----------------------------------------------------------

- Je n'arrive pas à faire persister l'adresse IPv4 sur l'interface `enp4s0` de mon ordi "Lubuntu 22.04" avec les configurations de netplan (alors que cela marche bien sur la vm serveur)
- Et surtout, je n'arrive pas à ping les machines entre-elles.

J'espère avoir été clair. Quelqu'un aurait une idée ? Merci par avance smile

Dernière modification par captain-plant (Hier à 00:12)

Hors ligne

#2 Le 20/09/2022, à 11:15

men-go

Re : [RESOLU] Problèmes connecter un serveur sur VM avec la machine hôte

Bonjour,

Je ne connais pas et n'ai jamais utilisé netplan  mais personnellement j'ai installé un LAN avec le réseau réel et plusieurs sous-réseaux virtuels (2 routeurs VM Debian bullseye sans interface graphique pour passer de l'un à l'autre).

Tous mes systèmes sont des UBUNTU 22.04.1 (pour la petite histoire) et ont des adresses IP STATIQUES autrement dit je n'utilise pas le DHCP. Les adresses IP statiques doivent être définies manuellement, éventuellement définies aussi dans /etc/hosts et sont répertoriées par le système dans /etc/NetworkManager/system-connections.

Autres points pour communiquer dans ce LAN, j'utilise NFS pour être totalement dans l'esprit Linux et mes serveurs de données sont de "simples" systèmes UBUNTU (on a plus de facilités avec l'interface graphique) qui partagent (via NFS) plusieurs disques ou répertoires. Enfin dans les paramètres réseau de VirtualBox le Moded'accès réseau est l'Accès par pont.

Hors ligne

#3 Le 20/09/2022, à 12:15

captain-plant

Re : [RESOLU] Problèmes connecter un serveur sur VM avec la machine hôte

Bonjour,

Merci pour ta réponse smile. De ce que j'ai compris, pour la configuration des interfaces réseaux, le répertoire /etc/netplan/ a remplacé le répertoire /etc/network/ depuis Ubuntu 17. Et netplan utilise le format yaml.

J'en déduis que c'est bizarre que tu n'aies pas utilisé netplan si tu utilises Ubuntu 22.04, mais mes connaissances sont très limitées alors ^^

Pour la VM serveur, j'ai éteint la machine, puis dans “configuration” -> “réseau” --> J'ai ajouté une deuxième interface réseau en mode “Réseau interne” --> C'est ce qu'utilise le prof dans le cours mais vu que lui utilise deux VM entre-elles et moi une VM + mon hôte, peut-être je devrais changer ?

Les IP statiques je les ai normalement définies manuellement dans /etc/netplan. Cela semble avoir marché sur la VM serveur mais pas sur mon hôte Lubuntu et je ne sais pas pourquoi, donc je la mets en dynamique à chaque démarrage sur l'hôte. Mais de toute façon je n'arrive pas à ping le serveur, ni dans l'autre sens

Je n'ai pas précisé mais pour résoudre les noms de domaine j'ai mis dans /etc/hosts les IP avec les noms, ce qui semble fonctionner car quand je ping le nom alors l'IP s'affiche et j'ai vérifié mille fois que je ne me suis pas mélangé les pinceaux

NFS je ne connais pas encore, mais c'est au programme dans la suite du cours apparemment, faudrait déjà que j'arrive à communiquer entre le serveur et le client

Hors ligne

#4 Le 20/09/2022, à 12:47

men-go

Re : [RESOLU] Problèmes connecter un serveur sur VM avec la machine hôte

Re,

On peut très facilement communiquer entre une machine rélle (l'hôte) et une VM.

Pour cela il faut absolument rester dans le même réseau c'est à dire par exemple si ta box a une adresse IP 192.168.1.1, tu peux pour ton hôte mettre 192.168.1.2 et ta VM 192.168.1.3. Dans ce cas chaque machine n'a qu'une seule interface réseau (avec au moins deux cartes réseau il faut faire de l'IP forwarding pour passer d'un réseau à un autre, ce que font les routeurs). Il FAUT aussi définir dans VirtualBox le Moded'accès réseau:  l'Accès par pont (par défaut VB fait de la NAT pour comuniquer avec un VM et là c'est un autre problème).

Du point de vue géographique et réseau, les machines réelles peuvent se trouver n'importe où et si certaines sont des hôtes potentiels, les VM peuvent se trouver sur n'importe quel hôte. L'important est de ne surtout pas avoir des doublons dans les adresses IP (et ni bein entendu dans les MAC address, puisque chaque adresse IP correspond à une adresse MAC.

Hors ligne

#5 Le 20/09/2022, à 15:58

captain-plant

Re : [RESOLU] Problèmes connecter un serveur sur VM avec la machine hôte

Très facilement à condition de savoir comment faire et de s'y connaître, ça fait 2 semaines que j'y suis lol
Merci pour l'aide big_smile

Je ne savais pas tout ça, j'ai simplement suivi le cours où le prof faisait sans trop d'explications ceci, que j'ai adapté à mon cas :
- VM serveur : `192.168.29.1` pour l'interface `enp0s8`
- Hôte Client : `192.168.29.2` pour l'interface `enp4s0`

L'adresse IP de ma box est : `192.168.1.254`
--> D'après ce que tu dis j'en déduis que ce que j'ai fait n'est pas bon et j'ai fait cela du coup :
- VM serveur : `192.168.1.3` pour l'interface `enp0s8`
- Hôte Client : `192.168.1.2` pour l'interface `enp4s0`

J'ai modifié dans la configuration de la VM du serveur, pour l'adaptateur 2 (enp0s8) le Mode d'accès réseau était `réseau interne` pour mettre : `Accès par pont` et on me demande de choisir un nom. J'ai le choix entre `enp4s0` et `wlp3s0`. J'ai choisi `enp4s0`.

Après ces modifications je n'arrive toujours pas à connecter l'hôte et la VM. Quand je ping l'une ou l'autre j'ai `destination host unreachable`

Je ne sais pas si je suis dans le cas où chaque machine n'a qu'une seule interface réseau OU si j'ai au moins deux cartes réseau et qu'il faut faire de l'IP forwarding pour passer d'un réseau à un autre (ce que font les routeurs). Et je ne sais pas comment faire de l'IP forwarding.

Dernière modification par captain-plant (Le 20/09/2022, à 16:02)

Hors ligne

#6 Le 20/09/2022, à 19:07

men-go

Re : [RESOLU] Problèmes connecter un serveur sur VM avec la machine hôte

Re,

Ma box a comme adresse IP 192.168.1.1, mon serveur de données est le système hôte sous Ubuntu 22.04.1 auquel j'ai donné l'adresse IP 192.168.1.3 via simplement Paramètres/Réseau. Un de  mes clients est une VM toujours sous Ubuntu 22.02.1, son adresse IP est 192.168.1.16 que je lui ai attribuée de la mếme façon que le système hôte. Dans ces deux cas je n'ai pas eu à manipuler la notion d'interface puisque le Network Manager s'en charge.

En fait mon serveur de données consiste simplement à démarrer en premier puisque quasiment tous mes systèmes partage des volumes. J'ai fait une procèdure qui fait que les clients se connectent automatiquement au serveur(s) mais sur n'importe quel système je peux me connecter manuellement à tous les autres.

Si on reste dans le même réseau (dans notre cas, l'adresse de sous-réseau est 192.168.1) il n'y a pas lieu de faire de l'IP forwarding. Pour le comprendre j'ai parlé de routeur. Mon premiers routeur est une VM qui a 3 interfaces (donc l'équivalent de 3 cartes réseau). La première a comme adresse IP 192.168.1.254 donc avec la même adresse de sous-réseau que le réseau réel. Ce routeur VM se trouve dans le serveur de données (mais il pourrait être sur n'importe quel hôte). La seconde carte du routeur a comme adresse IP 192.168.0.254, adresse de sous-réseau 192.168.0 donc différente de 192.168.1. La troisième carte a comme adresse IP 172.16.0.254, adresse de sous-réseau 172.16.0. Pour passer d'un réseau à un autre sur ce routeur il faut juste à chaque boot émettre la commande:

sudo echo 1>/proc/sys/net/ipv4/ip_forward.

Ce routeur étant un système Debian (qui n'a pas de Network Manager) il a fallu que je change les paramètres dans /etc/network/interfaces

Dans VB quelque soit les machines, chaque adaptateur a Accès par pont  et dans Nom: il n'y en a qu'un seul donc pas à modifier

Je ne connais pas non plus Lubuntu mais est-ce que le Network Manager y existe ? (Cf /etc/NetworkManager)

Hors ligne

#7 Le 20/09/2022, à 19:27

captain-plant

Re : [RESOLU] Problèmes connecter un serveur sur VM avec la machine hôte

De ce que je comprends, je crois que mon cas est assez simple car je reste dans le même réseau il me semble. Donc pas d'IP forwarding à mettre en place je crois...

Oui Network Manager existe :

~$ ls /etc/NetworkManager/
conf.d  dispatcher.d  dnsmasq.d  dnsmasq-shared.d  NetworkManager.conf  system-connections
~$ ls

Dernière modification par captain-plant (Le 21/09/2022, à 10:53)

Hors ligne

#8 Le 22/09/2022, à 11:30

men-go

Re : [RESOLU] Problèmes connecter un serveur sur VM avec la machine hôte

Bonjour,

Je suis entrain de simuler ton environnement et donc je viens d'installer Lubuntu pour l'instant dans une VM. Comme le bureau ne ressemble pas tellement à celui dont j'ai l'habitude je commence à me faire les dents en créant une adresse IP statique (192.168.1.2) et pour l'instant ça fonctionne.

Pour ce faire j'ai été dans Préférences/Advanced Network Configuration/…/IPv4 Setting et j'ai créé une connexion avec Method Manual.
Est-ce que tu as fait ce type d'opération lorsque tu as modifié tes adresses IP:

- VM serveur : `192.168.1.3` pour l'interface `enp0s8`
- Hôte Client : `192.168.1.2` pour l'interface `enp4s0`

dont je ne vois pas pourquoi tu parles d'interface puisque je n'ai pas eu à m'en occuper ?

La suite va consister à transférer ce nouveau système sur un disque réel et installer le serveur sur la VM.

Hors ligne

#9 Le 22/09/2022, à 12:40

captain-plant

Re : [RESOLU] Problèmes connecter un serveur sur VM avec la machine hôte

Bonjour,

C'est super gentil de faire ça ! Merci smile
Perso j'ai tout fait dans le terminal en ligne de commande et avec VIM. Je ne suis jamais passé par "Préférences/Advanced Network Configuration/" (je ne sais pas comment m'en servir d'ailleurs) et je ne connais pas "Method Manual".

En tout cas j'ai essayé de faire comme tu dis :

- VM Ubuntu serveur : `192.168.1.3` pour l'interface `enp0s8`
- Hôte Client Lubuntu : `192.168.1.2` pour l'interface `enp4s0`

Voici ce que j'ai fait : je reprends ce que j'ai mis au tout début avec les modifications que tu m'as déjà fait faire et quelques explications en plus :

------------------------ Config machine hôte client - Lubuntu 22.04 -----------------------------

A la base sur Lubuntu j'ai l'interface `enp4s0` qui existe, mais il n'y a pas d'adresse IPv4 attribuée et le fichier `/etc/netplan/01-network-manager-all.yaml` est presque vide :

~$ ip a
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: enp4s0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc fq_codel state DOWN group default qlen 1000
    link/ether 00:13:77:3a:27:27 brd ff:ff:ff:ff:ff:ff
3: wlp3s0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc mq state DOWN group default qlen 1000
    link/ether 00:1b:77:2a:d3:dd brd ff:ff:ff:ff:ff:ff
~$ cat /etc/netplan/01-network-manager-all.yaml 
# Let NetworkManager manage all devices on this system
network:
  version: 2
  renderer: NetworkManager
~$

Donc j'ai édité le seul fichier qu'il y avait par défaut dans `/etc/netplan` pour ajouter l'adresse IPv4 `192.168.1.2` à l'interface `enp4s0` et voilà le résultat

~$ cat /etc/netplan/01-network-manager-all.yaml 
# Let NetworkManager manage all devices on this system
network:
  version: 2
  renderer: NetworkManager
  ethernets:
    enp4s0:
      dhcp4: no
      dhcp6: no 
      addresses: [192.168.1.2/24] 
~$ 

Normalement, pour appliquer les modifications il faut :
- Soit faire  `sudo netplan apply`
- Soit redémarrer la machine

Mais ici cela ne marche pas, l'adresse IP que j'ai ajouté n'est pas prise en compte :

~$ ip a show dev enp4s0
2: enp4s0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc fq_codel state DOWN group default qlen 1000
    link/ether 00:13:77:3a:27:27 brd ff:ff:ff:ff:ff:ff
~$ 

La seule manière que j'ai trouvé, c'est d'ajouter l'adresse IPv4 `192.168.1.2` sur l'interface `enp4s0` avec la commande `ip` de manière dynamique, donc pas persistant, mais ça marche :

~$ sudo ip addr add 192.168.1.2/24 dev enp4s0
~$ ip a show dev enp4s0
2: enp4s0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc fq_codel state DOWN group default qlen 1000
    link/ether 00:13:77:3a:27:27 brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.2/24 scope global enp4s0
       valid_lft forever preferred_lft forever
~$ 

--------------------------- Config VM serveur - Ubuntu-server 22.04 -------------------------------

A la base je n'ai pas l'interface `enp0s8` :

yann@serveur-vm:~$ ip a
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
 link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
 inet 127.0.0.1/8 scope host lo
 valid_lft forever preferred_lft forever
 inet6 ::1/128 scope host 
 valid_lft forever preferred_lft forever
2: enp0s3: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UP group default qlen 1000
 link/ether 08:00:27:4a:09:d3 brd ff:ff:ff:ff:ff:ff
 inet 10.0.2.15/24 metric 100 brd 10.0.2.255 scope global dynamic enp0s3
 valid_lft 84289sec preferred_lft 84289sec
 inet6 fe80::a00:27ff:fe4a:9d3/64 scope link 
 valid_lft forever preferred_lft forever
yann@serveur-vm:~$

J'ai donc ajouté, en éteignant la VM et en allant dans les configurations, une deuxième interface virtuelle avec un mode d'accès `Accès par pont` (comme tu me l'as dit et non plus `réseau interne`).

Ainsi, j'ai une nouvelle interface `enp0s8` en plus mais qui n'a pas d'adresse IPv4 encore :

yann@serveur-vm:~$ ip a show dev enp0s8
3: enp0s8: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UP group default qlen 1000
 link/ether 08:00:27:19:37:30 brd ff:ff:ff:ff:ff:ff
 inet6 fe80::a00:27ff:fe19:3730/64 scope link 
 valid_lft forever preferred_lft forever
yann@serveur-vm:~$

Maintenant, j'ai attribué de façon persistante/statique l'adresse IPv4 `192.168.1.3` à l'interface `enp0s8`. Pour cela, j'ai créé le fichier `/etc/netplan/60-lan-static.yaml` et j'ai mis dedans :

network:
 version: 2
 renderer: networkd
 ethernets:
   enp0s8:
     dhcp4: no
     dhcp6: no
     addresses: [192.168.1.3/24] 

Cela a bien marché car j'ai maintenant de façon permanente :

yann@serveur-vm:~$ ip a show dev enp0s8
3: enp0s8: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UP group default qlen 1000
 link/ether 08:00:27:19:37:30 brd ff:ff:ff:ff:ff:ff
 inet 192.168.1.3/24 brd 192.168.29.255 scope global enp0s8
    valid_lft forever preferred_lft forever
 inet6 fe80::a00:27ff:fe19:3730/64 scope link 
    valid_lft forever preferred_lft forever

-----------------------------------------------------------------

- Dans le cas de la VM Ubuntu-serveur, l'adresse IPv4 a été correctement attribué de façon persistante
- Dans le cas de l'hôte client Lubuntu, je dois attribuer l'adresse IPv4 de façon dynamique car je n'arrive pas à la faire persister alors que j'ai suivi le même processus que pour la VM serveur

De ce que tu me dis, il faudrait que je passe par l'outil graphique `Préférences/Advanced Network Configuration/` pour attribuer une adresse IPv4 statique à l'interface `enp4s0` sur l'hôte client Lubuntu ? Je ne sais pas comment on fait...
Quand je vais dans  `Préférences` puis je clique sur `Advanced Network Configuration`  j'arrive sur la fenêtre `Network Connections`, j'imagine que je clique sur le `+` et là je choisis `Bridge` ? Et après je sais pas

J'espère avoir été plus clair smile

Dernière modification par captain-plant (Le 22/09/2022, à 12:48)

Hors ligne

#10 Le 22/09/2022, à 17:01

men-go

Re : [RESOLU] Problèmes connecter un serveur sur VM avec la machine hôte

Re,

Si tu listes avec sudo /etc/NetworkManager/system-connections je suis sûr que ce répertoire est vide. L'adresse IP de ta connexion a été attribuée automatiquement par Network Manager via le dispositif DHCP. De ce fait, il n'est pas certain qu'on retrouve la même adresse IP au prochain boot. Il faut créer une connexion avec une adresse IP STATIQUE qui veut dire qui ne bouge pas. C'est ce que je propose avec “Advanced Network Configuration”.

- Dans le panneau Network Connections on clique sur + (Add a new connection)
- Dans Choose a Connection Type, normalement il y a Ethernet, donc on clique sur [Create…]
- Dans la fenêtre Editing avec un nom de connexion proposé, on peut changer ce nom dans la rubrique Connection Name. Les autres rubriques peuvent rester inchangées. Cliquer sur l'onglet {IPv4 settings}
- Dans Method choisir Manual (au lieu de DHCP)
- Dans le petit tableau Adresses, cliquer sur [Add]
- Remplir la position proposée sous Adress par la nouvelle adresse IP du système, ex: 192.168.1.2
- Tabuler pour sauter, le nombre 24 est proposé pour Netmask, c'est le bon, tabuler pour sauter
- Remplir avec l'adresse IP de la box sous Getway
- Aller à DNS servers et y remettre l'adresse IP de la box
- Cliquer sur [Save]

Rebooter. Normalement si tous les paramètres sont justes le système prendra en compte cette nouvelle adresse. Si ce n'est pas le cas autant que je me souvienne tu repartiras avec l'ancienne.

Normalement dans la Box elle-même on peut définir des plages d'adresses IP statiques. Par exemple comme ma box a comme adresse 192.168.1.1, j'ai défini une plage de 192.168.1.2-30 pour les adresses statiques, les autres sont prises par DHCP. Ceci évite qu'un système avec une adresse statique soit perturbé un autre déjà booté auquel DHCP aura donné la même adresse.

Hors ligne

#11 Le 22/09/2022, à 19:39

captain-plant

Re : [RESOLU] Problèmes connecter un serveur sur VM avec la machine hôte

Alors le répertoire dans l'hôte Lubuntu dont tu parles n'est pas vide :

~$ sudo ls /etc/NetworkManager/system-connections
Bbox-06B0F2B2.nmconnection         OUIFI.nmconnection            _SNCF_WIFI_INOUI.nmconnection
La-Maison-du-Bonheur.nmconnection  SFR_3F68_2.4GHZ.nmconnection  wifile253.nmconnection
~$

Merci pour les étapes, je les ai suivi scrupuleusement, mais après redémarrage, comment voir si le système a bien pris en compte la nouvelle adresse ?

Car si je fais `ip a` je ne vois pas la nouvelle adresse (192.168.1.2)

~$ ip a
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: enp4s0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc fq_codel state DOWN group default qlen 1000
    link/ether 00:13:77:3a:27:27 brd ff:ff:ff:ff:ff:ff
3: wlp3s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP group default qlen 1000
    link/ether 00:1b:77:2a:d3:dd brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.38/24 brd 192.168.1.255 scope global dynamic noprefixroute wlp3s0
       valid_lft 86334sec preferred_lft 86334sec
    inet6 2001:861:3a80:e8a0:e070:532e:65c3:5403/64 scope global temporary dynamic 
       valid_lft 86337sec preferred_lft 14337sec
    inet6 2001:861:3a80:e8a0:15d8:4ff4:9938:441e/64 scope global dynamic mngtmpaddr noprefixroute 
       valid_lft 86337sec preferred_lft 14337sec
    inet6 fe80::e640:80bd:345:3a1e/64 scope link noprefixroute 
       valid_lft forever preferred_lft forever
~$ 

En revanche, dans le panneau Network Connection, je vois dans la rubrique Ethernet deux réseaux (j'avais pas du tout fait attention si `netplan-enp4s0` était présent avant) :
- `netplan-enp4s0` ---> Qui correspond au fichier que j'ai modifié (`/etc/netplan/01-network-manager-all.yaml `)
- `Ethernet Connection 1` ---> Qui correspond aux étapes que tu m'as fait faire
==> Ces deux réseaux ont la même adresse du coup : `192.168.1.2`

C'est bizarre que dans `ip a` je ne vois rien non ?

Dernière modification par captain-plant (Le 22/09/2022, à 19:40)

Hors ligne

#12 Le 22/09/2022, à 22:16

men-go

Re : [RESOLU] Problèmes connecter un serveur sur VM avec la machine hôte

Re,

Autant pour moi, je vois que tu as 3 connexions installées et c'est la connexion wifi qui fonctionne.

J'ai donné l'exemple d'une connexion filaire puisque je me suis basé sur une VM. Mais tu as aussi un connexion Wifi (wlp3s0) qui a les mêmes paramétrages que la connexion filaire (ce qui est normal). Or à un instant T seule l'une ou l'autre est en fonction et dans ton cas c'est la wifi. Personnellement toutes mes machines même les portables fonctionnent avec une connexion filaire (plus rapide et plus sécurisée) et la connexion wifi a aussi une adresse IP statique.

Il y a juste à vérifier quel est le type de connexion (DHCP ou non) avec le mode d'emploi que je t'ai donné en sachant que le fait d'éditer une connexion n'est pas forcément la changer. Avec “Advanced Network Configuration” on peut éditer, créer, supprimer une connexion. J'ai créé une connexion DHCP qui évidemment lorsque je la lance a une adresse IP dynamique. Sur ma VM je peux activer l'une ou l'autre avec l'icône représentant une prise RJ45 en bas à droite de l'écran. Si tu es dans l'obligation de créer une connexion wifi, dans Choose a Connection Type il faut mettre Wi-Fi au lieu d'Ethernet. Tu dois certainement avoir une icône à part à côté de celle RJ45 pour lancer la connexion wifi.

Hors ligne

#13 Le 22/09/2022, à 23:17

captain-plant

Re : [RESOLU] Problèmes connecter un serveur sur VM avec la machine hôte

Oui `wlp3s0` correspond à mon interface wifi qui est activé avec laquelle je me connecte à internet.

"Mais tu as aussi un connexion Wifi (wlp3s0) qui a les mêmes paramétrages que la connexion filaire (ce qui est normal)"
==> Je ne comprends pas où tu vois que la connexion wifi a les mêmes paramétrages que la connexion filaire ? De ce que je vois `enp4s0` n'a pas les mêmes paramètres que `wlp3s0` :

2: enp4s0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc fq_codel state DOWN group default qlen 1000
    link/ether 00:13:77:3a:27:27 brd ff:ff:ff:ff:ff:ff
3: wlp3s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP group default qlen 1000
    link/ether 00:1b:77:2a:d3:dd brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.38/24 brd 192.168.1.255 scope global dynamic noprefixroute wlp3s0
       valid_lft 86334sec preferred_lft 86334sec
    inet6 2001:861:3a80:e8a0:e070:532e:65c3:5403/64 scope global temporary dynamic 
       valid_lft 86337sec preferred_lft 14337sec
    inet6 2001:861:3a80:e8a0:15d8:4ff4:9938:441e/64 scope global dynamic mngtmpaddr noprefixroute 
       valid_lft 86337sec preferred_lft 14337sec
    inet6 fe80::e640:80bd:345:3a1e/64 scope link noprefixroute 
       valid_lft forever preferred_lft forever

"Il y a juste à vérifier quel est le type de connexion (DHCP ou non) ..."
==> Le type de connexion de quoi ? de quelle interface ?

"Si tu es dans l'obligation de créer une connexion wifi, dans Choose a Connection Type il faut mettre Wi-Fi au lieu d'Ethernet."
==> Je ne comprends pas pourquoi je serais obligé de créer une connexion wifi ? Et pourquoi aurais-je besoin d'une connexion wifi ? Je veux seulement faire communiquer ma VM avec son hôte.

En fait je ne comprends même pas pourquoi la box serait importante alors que je communique en local sur la même machine. On devrait pouvoir communiquer entre une VM et son hôte sans aucune connexion internet non ? Puisque tout se passe sur le même ordinateur

Hors ligne

#14 Le 23/09/2022, à 00:32

MicP

Re : [RESOLU] Problèmes connecter un serveur sur VM avec la machine hôte

…On devrait pouvoir communiquer entre une VM et son hôte sans aucune connexion internet non ? …

Oui, dans ton cas, c'est ce que tu voudrais pouvoir faire, et tout est possible,
mais en général, quand on créé des machine virtuelles, c'est justement pour pouvoir faire des tests qu'on ne voudrait pas prendre le risque de faire subir à sa machine hôte,
donc, on créé une machine virtuelle qui sera le plus isolée possible de la machine hôte.

Je n'utilise pas netplan, et je n'utilise pas VirtualBox, (j'utilise debian et Qemu/Kvm pour mes machines virtuelles)
mais pour les machines virtuelles, le principe est le même : chaque machine virtuelle a une (ou plusieurs) cartes réseau virtuelle(s) qui est par défaut connectée à un switch qui est lui aussi virtuel et qui peut même faire office de serveur DHCP virtuel pour les machines virtuelles,
et c'est ce switch virtuel qui accédera au réseau externe de la machine hôte puis à la box en utilisant un bridge qui sera automatiquement connecté au périphérique réseau actif de la machine hôte,

C'est ce qui fait que, quel que soit le périphérique réseau (WiFi ou par câble ou autre) qui permet à la machine hôte d'accéder au web,
les machines virtuelles n'auront rien à changer dans la configuration de leur carte réseau virtuelle.

Il te faut donc te renseigner d'abord sur la façon dont le réseau est géré pour ta machine virtuelle : Comprendre les différents types de réseaux VirtualBox

Dernière modification par MicP (Le 23/09/2022, à 00:34)


Retour utilisable de commande
2.d  Le prompt final : permet de s'assurer que la commande est allée à son terme, permet de s'assurer que le retour de commande a été copié/collé dans son intégralité et fournit dans certains cas d'autres informations très importantes.
voir le message #42

Hors ligne

#15 Le 23/09/2022, à 10:15

men-go

Re : [RESOLU] Problèmes connecter un serveur sur VM avec la machine hôte

Bonjour,

Je vais essayer d'être un peu plus clair.

Pour commencer, gérer un réseau Internet est beaucoup plus difficile que manipuler des fichiers sur un arbre de répertoires. En deuxième lieu, il faut voir le réseau (internet ou intranet) comme un ensemble unique. Troisièmement que les communications passent par câbles ou par ondes (wifi) on est toujours sur le réseau. Il faut voir le réseau comme un système hydraulique comme un fleuve avec ses affluents sachant que pour passer d'un système à un autre un utilise des écluses (routeurs).

Ta connexion wifi fait partie du réseau à même titre qu'un réseau de câbles. Il faut faire abstraction de l'électronique qui permet de passer de l'un à l'autre.

Une machine virtuelle est comme son nom l'indique est virtuelle, mais ceci ne l'empêche pas de réagir comme si elle était réelle. C'est tellement vrai que si tu as eu la curiosité du visualiser la totalité des données d'une interface dans la rubrique réseau de VirtualBox, dans "Avancé"  il y a un paramètre à cocher qui s'appelle "Câble branché". Or que je sache il n'y a aucun câble entre une VM et son hôte. 

Alors question: comment faire communiquer une VM "branchée au réseau par câble" avec un ordinateur branché au réseau par wifi ?

==> Je ne comprends pas où tu vois que la connexion wifi a les mêmes paramétrages que la connexion filaire ? De ce que je vois `enp4s0` n'a pas les mêmes paramètres que `wlp3s0`
Je voulais dire que sur un ordinateur portable qui peut communiquer par câble ou par wifi, à un instant T on utilise l'un ou (exclusif) l'autre et que le paramétrage des connexions sont identiques (en principe)

==> Le type de connexion de quoi ? de quelle interface ?
Si ta connexion wifi est de type DHCP comment un autre machine peut l'atteindre si l'adresse IP change ?

==> Je ne comprends pas pourquoi je serais obligé de créer une connexion wifi ? Et pourquoi aurais-je besoin d'une connexion wifi ? Je veux seulement faire communiquer ma VM avec son hôte.
Peut-être qu'avec une connexion wifi avec une adresse IP statique ça risque de marcher !!!!

Malheureusement si toutes ces notions te sont étrangères je ne vois pas comment je peux résoudre ton problème à distance.

Hors ligne

#16 Le 23/09/2022, à 14:47

men-go

Re : [RESOLU] Problèmes connecter un serveur sur VM avec la machine hôte

Re,

Je viens d'installer Ubuntu 22.04 server sur une deuxième VM. Effectivement le processus d'installation crée le fichier, «/etc/netplan/00-installer-config.yaml» qui contient:

# This is the network config written by 'subiquity'
network:
  ethernets:
    enp0s3:
      dhcp4: true
  version: 2

J'ai remplacé ce texte par celui emprunté/modifié dans la doc netplan trouvée dans ubuntu.fr:

# This is the network config written by 'subiquity'
network:
    ethernets:
        enp0s3:
            addresses: [192.168.1.23/24]
            gateway4: 192.168.1.1
            nameservers:
                addresses: [8.8.8.8, 8.8.4.4]
            dhcp4: false
            dhcp6: false
    version: 2

Les 3 machines (l'hôte, la VM Lubuntu et la VM serveur) communiquent, c'est à dire que je peux pinguer indifféremment chaque machine vers les deux autres. Ex:

cyclope@TLUBU:~$ ip a     # Il s'agit de la VM Lubuntu
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: enp0s3: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UP group default qlen 1000
    link/ether 08:00:27:4c:f1:dc brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.2/24 brd 192.168.1.255 scope global noprefixroute enp0s3
       valid_lft forever preferred_lft forever
    inet6 fe80::18f3:1ae4:bab:597c/64 scope link noprefixroute 
       valid_lft forever preferred_lft forever

cyclope@TLUBU:~$ ping 192.168.1.23
PING 192.168.1.23 (192.168.1.23) 56(84) bytes of data.
64 bytes from 192.168.1.23: icmp_seq=1 ttl=64 time=0.268 ms
64 bytes from 192.168.1.23: icmp_seq=2 ttl=64 time=0.231 ms
64 bytes from 192.168.1.23: icmp_seq=3 ttl=64 time=0.331 ms
64 bytes from 192.168.1.23: icmp_seq=4 ttl=64 time=0.237 ms
64 bytes from 192.168.1.23: icmp_seq=5 ttl=64 time=0.197 ms
^C
--- 192.168.1.23 ping statistics ---
5 packets transmitted, 5 received, 0% packet loss, time 5377ms
rtt min/avg/max/mdev = 0.197/0.252/0.331/0.045 ms
cyclope@TLUBU:~$ ping 192.168.1.3
PING 192.168.1.3 (192.168.1.3) 56(84) bytes of data.
64 bytes from 192.168.1.3: icmp_seq=1 ttl=64 time=0.305 ms
64 bytes from 192.168.1.3: icmp_seq=2 ttl=64 time=0.150 ms
64 bytes from 192.168.1.3: icmp_seq=3 ttl=64 time=0.149 ms
^C
--- 192.168.1.3 ping statistics ---
3 packets transmitted, 3 received, 0% packet loss, time 4239ms
rtt min/avg/max/mdev = 0.149/0.201/0.305/0.073 ms
cyclope@TLUBU:~$ 
cyclope@MIMAS:~$ ping 192.168.1.2   # L'hôte (192.168.1.3)
PING 192.168.1.2 (192.168.1.2) 56(84) bytes of data.
64 bytes from 192.168.1.2: icmp_seq=1 ttl=64 time=0.256 ms
64 bytes from 192.168.1.2: icmp_seq=2 ttl=64 time=0.209 ms
64 bytes from 192.168.1.2: icmp_seq=3 ttl=64 time=0.160 ms
^C
--- 192.168.1.2 ping statistics ---
3 packets transmitted, 3 received, 0% packet loss, time 2053ms
rtt min/avg/max/mdev = 0.160/0.208/0.256/0.039 ms

cyclope@MIMAS:~$ ping 192.168.1.23
PING 192.168.1.23 (192.168.1.23) 56(84) bytes of data.
64 bytes from 192.168.1.23: icmp_seq=1 ttl=64 time=0.210 ms
64 bytes from 192.168.1.23: icmp_seq=2 ttl=64 time=0.152 ms
64 bytes from 192.168.1.23: icmp_seq=3 ttl=64 time=0.149 ms
64 bytes from 192.168.1.23: icmp_seq=4 ttl=64 time=0.149 ms
64 bytes from 192.168.1.23: icmp_seq=5 ttl=64 time=0.137 ms
64 bytes from 192.168.1.23: icmp_seq=6 ttl=64 time=0.126 ms
^C
--- 192.168.1.23 ping statistics ---
6 packets transmitted, 6 received, 0% packet loss, time 5130ms
rtt min/avg/max/mdev = 0.126/0.153/0.210/0.026 ms

Tu m'excuseras de ne pas de donner l'exemple du serveur. Donc il n'y a pas de raison que si je transfère VM Lubuntu sur une machine réelle ça puisse changer quoi que ce soit.

Hors ligne

#17 Le 23/09/2022, à 19:42

captain-plant

Re : [RESOLU] Problèmes connecter un serveur sur VM avec la machine hôte

Effectivement mon manque de connaissance est un frein pour bénéficier de votre aide correctement. J'ai mis du temps à répondre car je devais m'informer plus sur tout ça et puis ensuite relire tous vos messages. Je vous remercie tout les deux pour votre aide et votre patience. J'ai bien regardé la vidéo très instructive de MicP et d'autres... je crois avoir un peu mieux compris tout ça.

Les explications de men-go me semblent plus claires, quand tu disais que c'était soit le wifi soit le filaire et pas les deux, en effet, j'avais fait l'erreur dans les paramètres de la VM en choisissant "Accès par pont" de choisir la carte `enp0s4` et au lieu de la carte `wlp3s0` qui est la carte avec laquelle je suis connectée à internet. En faisant ce changement j'ai pu ping les machines entre-elles. Du coup, je ne passe pas par `enp0s4` et je n'ai pas besoin de modifier le fichier `/etc/netplan/01-network-manager-all.yaml` sur l'hôte Lubuntu car comme l'a dit men-go je passe par la carte wifi.

Par contre, je n'ai pas défini manuellement d'adresses IP STATIQUES dans `/etc/NetworkManager/system-connections`. L'IP de la carte wifi `wlp3s0` semble statique car elle ne change pas après redémarrage mais quand je regarde dans Network Connections et que je regarde dans les paramètres de mon réseau / de ma box, je vois que dans l'onglet "IPv4 Settings" la "Method" est `Automatic(DHCP)`. Il faut que je change cela ? Ou que je crée une autre connection wifi ?

Donc côté hôte client j'ai toujours ça :

~$ ip a
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: enp4s0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc fq_codel state DOWN group default qlen 1000
    link/ether 00:13:77:3a:27:27 brd ff:ff:ff:ff:ff:ff
3: wlp3s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP group default qlen 1000
    link/ether 00:1b:77:2a:d3:dd brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.38/24 brd 192.168.1.255 scope global dynamic noprefixroute wlp3s0
       valid_lft 86334sec preferred_lft 86334sec
    inet6 2001:861:3a80:e8a0:e070:532e:65c3:5403/64 scope global temporary dynamic 
       valid_lft 86337sec preferred_lft 14337sec
    inet6 2001:861:3a80:e8a0:15d8:4ff4:9938:441e/64 scope global dynamic mngtmpaddr noprefixroute 
       valid_lft 86337sec preferred_lft 14337sec
    inet6 fe80::e640:80bd:345:3a1e/64 scope link noprefixroute 
       valid_lft forever preferred_lft forever
~$

Du côté VM serveur, j'ai deux adaptateurs réseau, un qui est en "NAT" et un autre que j'ai rajouté en suivant le cours et en adaptant avec les conseils de men-go pour le mettre en "Accès par pont". Donc j'ai deux interfaces `enp0s3` qui correspont au NAT et `enp0s8` qui correspont à l'"Accès pas pont".
je n'ai jamais touché au fichier `/etc/netplan/00-installer-config.yaml` car dans le cours que j'ai suivi, on créé un autre fichier que l'on appelle arbitrairement `/etc/netplan/60-lan-static.yaml` et dans lequel il y a :

network:
 version: 2
 renderer: networkd
 ethernets:
   enp0s8:
     dhcp4: no
     dhcp6: no
     addresses: [192.168.1.3/24] 

Et j'ai :

yann@serveur-vm:~$ ip a
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
 link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
 inet 127.0.0.1/8 scope host lo
   valid_lft forever preferred_lft forever
 inet6 ::1/128 scope host 
   valid_lft forever preferred_lft forever
2: enp0s3: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UP group default qlen 1000
 link/ether 08:00:27:4a:09:d3 brd ff:ff:ff:ff:ff:ff
 inet 10.0.2.15/24 metric 100 brd 10.0.2.255 scope global dynamic enp0s3
   valid_lft 84289sec preferred_lft 84289sec
 inet6 fe80::a00:27ff:fe4a:9d3/64 scope link 
   valid_lft forever preferred_lft forever
3: enp0s8: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UP group default qlen 1000
 link/ether 08:00:27:19:37:30 brd ff:ff:ff:ff:ff:ff
 inet 192.168.1.3/24 brd 192.168.29.255 scope global enp0s8
   valid_lft forever preferred_lft forever
 inet6 2001:861:3a80:e8a0:a00:27ff:fe19:3730/64 scope global dynamic mngtmpaddr noprefixroute 
   valid_lft 86138sec preferred_lft 14138sec
 inet6 fe80::a00:27ff:fe19:3730/64 scope link 
   valid_lft forever preferred_lft forever

Maintenant depuis
- la VM-serveur je peux faire : `ping 192.168.1.38` et ça marche
- l'hôte client je peux faire : `ping 192.168.1.3` et ça marche

Il faut que je relise le dernier message de men-go mais je dois partir, je le verrai demain big_smile

Dernière modification par captain-plant (Le 23/09/2022, à 19:43)

Hors ligne

#18 Le 24/09/2022, à 12:07

men-go

Re : [RESOLU] Problèmes connecter un serveur sur VM avec la machine hôte

Re,

Le DHCP c'est bien s'il n'existe pratiquement qu'un seul système dans le réseau auquel cas les paramètres réseau peuvent être ignorés. À partir du moment où il y a au moins deux machines et qu'on leur demande de communiquer vraiment et pas seulement par ping (CàD partager par exemple des données) l'utilisation du DHCP n'est plus possible, en tout pour NFS il faut des adresses IP statiques. Que dire des réseaux d'entreprise qui peuvent héberger plusieurs dizaines de milliers d'utilisateurs ? Il faut bien reconnaître chacun d'entre eux. C'est pourquoi je t'ai proposé de créer un connexion wifi avec une adresse IP statique sur le Client.

Sur ton serveur je remarque qu'il y a deux adresses IP: 10.0.2.15 et 192.168.1.3. Il y en a une de trop. Dans VB tu as dû définir et activer deux interfaces dont la première utilise la NAT (défaut de VB). Il faut soit la désactiver soit désactiver la 2ème et reparamétrer la première pour avoir des paramètres comme ceux de mon dernier post (# Il s'agit de la VM Lubuntu)

Maintenant que tu as le couple Serveur-Client pour la suite je suppose que tu devras faire connaître au Client des données (donc répertoires ou disques) du Serveur. Je connais deux solutions le réseau samba (l'équivalent du réseau Windows) et NFS. La différence, avec NFS on accède aux données éloignées de la même façon et avec les mêmes attributs que si c'était un système de fichiers ext[2|3|4]. Mais peut-être que ceci est une autre histoire.

Hors ligne

#19 Le 24/09/2022, à 16:08

captain-plant

Re : [RESOLU] Problèmes connecter un serveur sur VM avec la machine hôte

Alors effectivement sur la VM serveur j'ai deux cartes :

- Adapter 1 : Mode d'accès réseau = `NAT` - carte = `enp0s3` - IPv4 = `10.0.2.15`
- Adapter 2 : Mode d'accès réseau = `Accès par pont` - carte = `enp0s8` - IPv4 = `192.168.1.3`

Mais c'est intentionnel, c'est dans le cours, le prof laisse la carte `NAT` qui est de base lors de l'installation et en crée une autre (sauf qu'il travaille entre 2 VM et il choisit un Mode d'accès réseau = `Réseau interne`...). Donc j'ai fait pareil, ça pose problème tu crois ? Parce que j'arrive à ping sans soucis dans les deux sens et l'adresse IP de `enp0s8` est statique smile
-----
Ok donc tu dis "il faut que je crée une connexion wifi avec une adresse IP statique sur le Client" mais j'ai déjà un réseau wifi qui correspond à ma box auquel je suis connecté. Je devrais pas plutôt modifier cette connexion pour lui mettre une IP statique ?
Si je crée une autre connexion wifi et que je m'y connecte, je n'aurais plus internet non ? car cette connexion ne sera pas sur la box
-----
C'est la même histoire, dans le cours après on voit Samba et NFS, je prie fort de pas me prendre trop de murs avec mon setup. Je viens de réaliser que je vais probablement avoir des soucis avec la VM qui a un disque virtuel et l'hôte qui a un disque physique pour faire communiquer tout ça ensemble... aie aie aie. lol

Dernière modification par captain-plant (Le 24/09/2022, à 16:17)

Hors ligne

#20 Le 24/09/2022, à 19:14

men-go

Re : [RESOLU] Problèmes connecter un serveur sur VM avec la machine hôte

Re,

Je ne sais pas si tu as remarqué mais une connexion réseau, ça s'ajoute, ça se démarre, ça s'arrête et ça se supprime. Donc si tu en ajoutes une tu ne casse rien. Tu vas te retrouver avec 2 connexions wifi que tu peux arrêter et démarrer à ta guise et justement dans un premier temps il faut garder la connexion DHCP qu'il faudra prendre comme exemple puisque au moment de la création d'une connexion wifi il faudra donner le SSID de ta box et la passphrase pour le cryptage des données qui vont sur le réseau.

Si tu arrives à créer cette connexion (avec une adresse IP statique) et que tu la lances, si tu n'as plus d'internet je te donne le droit de m'engu… (est-ce que tu penses vraiment que mon serveur de données dont j'ai parlé et qui a une adresse IP statique ne va pas sur internet ?).

Pour ta carte NAT ça ne pose pas de problème, mais tu la supprimeras  quand tu te rendra compte qu'elle ne te servira à rien.

Hors ligne

#21 Hier à 00:11

captain-plant

Re : [RESOLU] Problèmes connecter un serveur sur VM avec la machine hôte

Certes, je pose des questions qui peuvent sembler bizarre parce que je découvre tout ça, j'ai beaucoup de notions que je ne maîtrise pas. Je pensais depuis le début qu'il fallait une interface réseau pour le wifi et une autre pour la connection à la VM, et donc avec l'interface du `wlp3s0` je me connectais soit au wifi sur internet soit je me connectais à la VM... En le disant ça semble bizarre maintenant...

En tout cas, c'est bon j'ai créé la connexion wifi avec l'IP statique et je peux aller sur internet et faire des pings entre les machines cool

Un grand merci pour l'aide et j'ai appris pleins de choses big_smile

Dernière modification par captain-plant (Hier à 00:14)

Hors ligne