Contenu | Rechercher | Menus

Annonce

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 08/03/2023, à 22:38

duralex69

[RÉSOLU] Accès à phpMyAdmin impossible après mise à niveau

Bonjour,

Je viens de faire une mise à niveau 20.10 > 22.04.2 LTS.
Pendant, l'installation j'ai eu un message concernant MySQL qui disait 'invoke-rc.d<service>start'.

La mise à niveau s'est bien déroulée sauf que je n'arrive plus à me connecter à phpMyAdmin car j'atterris sur une page avec le message :
"La connexion a échoué

Une erreur est survenue pendant une connexion à 127.0.0.1.
Le site est peut-être temporairement indisponible ou surchargé. Réessayez plus tard ;
Si vous n’arrivez à naviguer sur aucun site, vérifiez la connexion au réseau de votre ordinateur ;
Si votre ordinateur ou votre réseau est protégé par un pare-feu ou un proxy, assurez-vous que Firefox est autorisé à accéder au Web."

Quelqu'un peut-il m'aider pour récupérer cet accès ?

Merci par avance de vos réponses et conseils.

Salutations,

Alex

Dernière modification par duralex69 (Le 15/03/2023, à 14:16)


Ubuntu 22.04.2 LTS

Hors ligne

#2 Le 08/03/2023, à 23:01

xubu1957

Re : [RÉSOLU] Accès à phpMyAdmin impossible après mise à niveau

Bonjour,

Donne les retour des :

sudo apt update

et d'éventuels paquets cassés :

dpkg -l | grep -v ^ii

en te servant du Retour utilisable de commande.


Conseils pour les nouveaux demandeurs et pas qu'eux
Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.                   Membre de Linux-Azur

Hors ligne

#3 Le 08/03/2023, à 23:10

duralex69

Re : [RÉSOLU] Accès à phpMyAdmin impossible après mise à niveau

Merci.

Voici les retours :

Pour sudo apt update

Atteint :1 http://fr.archive.ubuntu.com/ubuntu jammy InRelease
Atteint :2 http://fr.archive.ubuntu.com/ubuntu jammy-updates InRelease
Réception de :3 http://fr.archive.ubuntu.com/ubuntu jammy-backports InRelease [107 kB]
Réception de :4 http://security.ubuntu.com/ubuntu jammy-security InRelease [110 kB]
217 ko réceptionnés en 1s (249 ko/s)
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances... Fait
Lecture des informations d'état... Fait      
Tous les paquets sont à jour.

Pour dpkg -l | grep -v ^ii

Souhait=inconnU/Installé/suppRimé/Purgé/H=à garder
| État=Non/Installé/fichier-Config/dépaqUeté/échec-conFig/H=semi-installé/W=attend-traitement-déclenchements
|/ Err?=(aucune)/besoin Réinstallation (État,Err: majuscule=mauvais)
||/ Nom                                        Version                                 Architecture Description
+++-==========================================-=======================================-============-================================================================================
rc  ca-certificates-java                       20190909ubuntu1.1                       all          Common CA certificates (JKS keystore)
rc  chrome-gnome-shell                         10.1-5                                  all          GNOME Shell extensions integration for web browsers
rc  crda                                       4.14+git20191112.9856751-1              amd64        wireless Central Regulatory Domain Agent
rc  ffmpeg                                     7:4.3.1-4ubuntu1                        amd64        Tools for transcoding, streaming and playing of multimedia files
rc  fuse                                       2.9.9-3                                 amd64        Filesystem in Userspace
rc  ibverbs-providers:amd64                    39.0-1                                  amd64        User space provider drivers for libibverbs
rc  libapache2-mod-php7.4                      8.1.2-1ubuntu2.11                       amd64        Transitional package
rc  libkf5attica5:amd64                        5.92.0-0ubuntu1                         amd64        Qt library that implements the Open Collaboration Services API
rc  linux-image-5.8.0-25-generic               5.8.0-25.26                             amd64        Signed kernel image generic
rc  linux-image-5.8.0-33-generic               5.8.0-33.36                             amd64        Signed kernel image generic
rc  linux-image-5.8.0-34-generic               5.8.0-34.37                             amd64        Signed kernel image generic
rc  linux-image-5.8.0-36-generic               5.8.0-36.40                             amd64        Signed kernel image generic
rc  linux-image-5.8.0-38-generic               5.8.0-38.43                             amd64        Signed kernel image generic
rc  linux-image-5.8.0-40-generic               5.8.0-40.45                             amd64        Signed kernel image generic
rc  linux-image-5.8.0-41-generic               5.8.0-41.46                             amd64        Signed kernel image generic
rc  linux-image-5.8.0-43-generic               5.8.0-43.49                             amd64        Signed kernel image generic
rc  linux-image-5.8.0-44-generic               5.8.0-44.50                             amd64        Signed kernel image generic
rc  linux-image-5.8.0-45-generic               5.8.0-45.51                             amd64        Signed kernel image generic
rc  linux-image-5.8.0-48-generic               5.8.0-48.54                             amd64        Signed kernel image generic
rc  linux-image-5.8.0-49-generic               5.8.0-49.55                             amd64        Signed kernel image generic
rc  linux-image-5.8.0-50-generic               5.8.0-50.56                             amd64        Signed kernel image generic
rc  linux-image-5.8.0-53-generic               5.8.0-53.60                             amd64        Signed kernel image generic
rc  linux-image-5.8.0-55-generic               5.8.0-55.62                             amd64        Signed kernel image generic
rc  linux-image-5.8.0-59-generic               5.8.0-59.66                             amd64        Signed kernel image generic
rc  linux-image-5.8.0-63-generic               5.8.0-63.71                             amd64        Signed kernel image generic
rc  linux-modules-5.8.0-25-generic             5.8.0-25.26                             amd64        Linux kernel extra modules for version 5.8.0 on 64 bit x86 SMP
rc  linux-modules-5.8.0-33-generic             5.8.0-33.36                             amd64        Linux kernel extra modules for version 5.8.0 on 64 bit x86 SMP
rc  linux-modules-5.8.0-34-generic             5.8.0-34.37                             amd64        Linux kernel extra modules for version 5.8.0 on 64 bit x86 SMP
rc  linux-modules-5.8.0-36-generic             5.8.0-36.40                             amd64        Linux kernel extra modules for version 5.8.0 on 64 bit x86 SMP
rc  linux-modules-5.8.0-38-generic             5.8.0-38.43                             amd64        Linux kernel extra modules for version 5.8.0 on 64 bit x86 SMP
rc  linux-modules-5.8.0-40-generic             5.8.0-40.45                             amd64        Linux kernel extra modules for version 5.8.0 on 64 bit x86 SMP
rc  linux-modules-5.8.0-41-generic             5.8.0-41.46                             amd64        Linux kernel extra modules for version 5.8.0 on 64 bit x86 SMP
rc  linux-modules-5.8.0-43-generic             5.8.0-43.49                             amd64        Linux kernel extra modules for version 5.8.0 on 64 bit x86 SMP
rc  linux-modules-5.8.0-44-generic             5.8.0-44.50                             amd64        Linux kernel extra modules for version 5.8.0 on 64 bit x86 SMP
rc  linux-modules-5.8.0-45-generic             5.8.0-45.51                             amd64        Linux kernel extra modules for version 5.8.0 on 64 bit x86 SMP
rc  linux-modules-5.8.0-48-generic             5.8.0-48.54                             amd64        Linux kernel extra modules for version 5.8.0 on 64 bit x86 SMP
rc  linux-modules-5.8.0-49-generic             5.8.0-49.55                             amd64        Linux kernel extra modules for version 5.8.0 on 64 bit x86 SMP
rc  linux-modules-5.8.0-50-generic             5.8.0-50.56                             amd64        Linux kernel extra modules for version 5.8.0 on 64 bit x86 SMP
rc  linux-modules-5.8.0-53-generic             5.8.0-53.60                             amd64        Linux kernel extra modules for version 5.8.0 on 64 bit x86 SMP
rc  linux-modules-5.8.0-55-generic             5.8.0-55.62                             amd64        Linux kernel extra modules for version 5.8.0 on 64 bit x86 SMP
rc  linux-modules-5.8.0-59-generic             5.8.0-59.66                             amd64        Linux kernel extra modules for version 5.8.0 on 64 bit x86 SMP
rc  linux-modules-5.8.0-63-generic             5.8.0-63.71                             amd64        Linux kernel extra modules for version 5.8.0 on 64 bit x86 SMP
rc  linux-modules-extra-5.8.0-25-generic       5.8.0-25.26                             amd64        Linux kernel extra modules for version 5.8.0 on 64 bit x86 SMP
rc  linux-modules-extra-5.8.0-33-generic       5.8.0-33.36                             amd64        Linux kernel extra modules for version 5.8.0 on 64 bit x86 SMP
rc  linux-modules-extra-5.8.0-34-generic       5.8.0-34.37                             amd64        Linux kernel extra modules for version 5.8.0 on 64 bit x86 SMP
rc  linux-modules-extra-5.8.0-36-generic       5.8.0-36.40                             amd64        Linux kernel extra modules for version 5.8.0 on 64 bit x86 SMP
rc  linux-modules-extra-5.8.0-38-generic       5.8.0-38.43                             amd64        Linux kernel extra modules for version 5.8.0 on 64 bit x86 SMP
rc  linux-modules-extra-5.8.0-40-generic       5.8.0-40.45                             amd64        Linux kernel extra modules for version 5.8.0 on 64 bit x86 SMP
rc  linux-modules-extra-5.8.0-41-generic       5.8.0-41.46                             amd64        Linux kernel extra modules for version 5.8.0 on 64 bit x86 SMP
rc  linux-modules-extra-5.8.0-43-generic       5.8.0-43.49                             amd64        Linux kernel extra modules for version 5.8.0 on 64 bit x86 SMP
rc  linux-modules-extra-5.8.0-44-generic       5.8.0-44.50                             amd64        Linux kernel extra modules for version 5.8.0 on 64 bit x86 SMP
rc  linux-modules-extra-5.8.0-45-generic       5.8.0-45.51                             amd64        Linux kernel extra modules for version 5.8.0 on 64 bit x86 SMP
rc  linux-modules-extra-5.8.0-48-generic       5.8.0-48.54                             amd64        Linux kernel extra modules for version 5.8.0 on 64 bit x86 SMP
rc  linux-modules-extra-5.8.0-49-generic       5.8.0-49.55                             amd64        Linux kernel extra modules for version 5.8.0 on 64 bit x86 SMP
rc  linux-modules-extra-5.8.0-50-generic       5.8.0-50.56                             amd64        Linux kernel extra modules for version 5.8.0 on 64 bit x86 SMP
rc  linux-modules-extra-5.8.0-53-generic       5.8.0-53.60                             amd64        Linux kernel extra modules for version 5.8.0 on 64 bit x86 SMP
rc  linux-modules-extra-5.8.0-55-generic       5.8.0-55.62                             amd64        Linux kernel extra modules for version 5.8.0 on 64 bit x86 SMP
rc  linux-modules-extra-5.8.0-59-generic       5.8.0-59.66                             amd64        Linux kernel extra modules for version 5.8.0 on 64 bit x86 SMP
rc  linux-modules-extra-5.8.0-63-generic       5.8.0-63.71                             amd64        Linux kernel extra modules for version 5.8.0 on 64 bit x86 SMP
rc  ltrace                                     0.7.3-6.1ubuntu6                        amd64        Tracks runtime library calls in dynamically linked programs
rc  mpv                                        0.32.0-2ubuntu2                         amd64        video player based on MPlayer/mplayer2
rc  openjdk-11-jre-headless:amd64              11.0.18+10-0ubuntu1~22.04               amd64        OpenJDK Java runtime, using Hotspot JIT (headless)
rc  php7.4-bz2                                 7.4.9-1ubuntu1.2                        amd64        bzip2 module for PHP
rc  php7.4-cli                                 7.4.9-1ubuntu1.2                        amd64        command-line interpreter for the PHP scripting language
rc  php7.4-common                              7.4.9-1ubuntu1.2                        amd64        documentation, examples and common module for PHP
rc  php7.4-curl                                7.4.9-1ubuntu1.2                        amd64        CURL module for PHP
rc  php7.4-gd                                  7.4.9-1ubuntu1.2                        amd64        GD module for PHP
rc  php7.4-intl                                7.4.9-1ubuntu1.2                        amd64        Internationalisation module for PHP
rc  php7.4-json                                7.4.9-1ubuntu1.2                        amd64        JSON module for PHP
rc  php7.4-mbstring                            7.4.9-1ubuntu1.2                        amd64        MBSTRING module for PHP
rc  php7.4-mysql                               7.4.9-1ubuntu1.2                        amd64        MySQL module for PHP
rc  php7.4-opcache                             7.4.9-1ubuntu1.2                        amd64        Zend OpCache module for PHP
rc  php7.4-readline                            7.4.9-1ubuntu1.2                        amd64        readline module for PHP
rc  php7.4-xml                                 7.4.9-1ubuntu1.2                        amd64        DOM, SimpleXML, XML, and XSL module for PHP
rc  php7.4-zip                                 7.4.9-1ubuntu1.2                        amd64        Zip module for PHP
rc  pkg-config                                 0.29.2-1ubuntu3                         amd64        manage compile and link flags for libraries
rc  python3.8-minimal                          3.8.10-0ubuntu1~20.10.1                 amd64        Minimal subset of the Python language (version 3.8)
rc  realmd                                     0.17.0-1ubuntu2                         amd64        DBus service for configuring kerberos and other online identities
rc  sssd-dbus                                  2.6.3-1ubuntu3.2                        amd64        System Security Services Daemon -- D-Bus responder
rc  xul-ext-ubufox                             3.4-0ubuntu1.17.10.1                    all          Ubuntu modifications for Firefox
rc  youtube-dl                                 2020.09.14-1                            all          downloader of videos from YouTube and other sites

Ubuntu 22.04.2 LTS

Hors ligne

#4 Le 08/03/2023, à 23:14

xubu1957

Re : [RÉSOLU] Accès à phpMyAdmin impossible après mise à niveau

Pour nettoyer partiellement :

Le 22/07/2020, nany a écrit :
dpkg -l | awk '/^rc/ && !/sql/{print $2}' | xargs -r sudo dpkg -P

Pour info, les précisions de nany, pour la commande de nettoyage.

Fournis les noyaux présents :

echo; dpkg -l | awk '!/^rc/ && / linux-(c|g|h|i|lo|m|si|t)/{print $1,$2,$3,$4 | "sort -k3V | column -t"}' ; echo -e "\nNoyau courant : $(uname -mr)"

Conseils pour les nouveaux demandeurs et pas qu'eux
Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.                   Membre de Linux-Azur

Hors ligne

#5 Le 08/03/2023, à 23:42

duralex69

Re : [RÉSOLU] Accès à phpMyAdmin impossible après mise à niveau

Voici la liste des noyaux :

ii  linux-headers-5.15.0-67                5.15.0-67.74           all
ii  linux-headers-5.15.0-67-generic        5.15.0-67.74           amd64
ii  linux-image-5.15.0-67-generic          5.15.0-67.74           amd64
ii  linux-modules-5.15.0-67-generic        5.15.0-67.74           amd64
ii  linux-modules-extra-5.15.0-67-generic  5.15.0-67.74           amd64
ii  linux-generic                          5.15.0.67.65           amd64
ii  linux-generic-hwe-20.04                5.15.0.67.65           amd64
ii  linux-headers-generic                  5.15.0.67.65           amd64
ii  linux-image-generic                    5.15.0.67.65           amd64
ii  linux-hwe-5.19-headers-5.19.0-35       5.19.0-35.36~22.04.1   all
ii  linux-headers-5.19.0-35-generic        5.19.0-35.36~22.04.1   amd64
ii  linux-image-5.19.0-35-generic          5.19.0-35.36~22.04.1   amd64
ii  linux-modules-5.19.0-35-generic        5.19.0-35.36~22.04.1   amd64
ii  linux-modules-extra-5.19.0-35-generic  5.19.0-35.36~22.04.1   amd64
ii  linux-generic-hwe-22.04                5.19.0.35.36~22.04.10  amd64
ii  linux-headers-generic-hwe-22.04        5.19.0.35.36~22.04.10  amd64
ii  linux-image-generic-hwe-22.04          5.19.0.35.36~22.04.10  amd64

Noyau courant : 5.19.0-35-generic x86_64

Ubuntu 22.04.2 LTS

Hors ligne

#6 Le 08/03/2023, à 23:49

xubu1957

Re : [RÉSOLU] Accès à phpMyAdmin impossible après mise à niveau

invoke-rc.d mysql start

donne une réponse ?

pompé dans message erreur lors mise a jour vers ubuntu studio


Conseils pour les nouveaux demandeurs et pas qu'eux
Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.                   Membre de Linux-Azur

Hors ligne

#7 Le 09/03/2023, à 13:40

bruno

Re : [RÉSOLU] Accès à phpMyAdmin impossible après mise à niveau

Bonjour,

S'il y  un problème avec le serveur MySQL il faut donner les retours complets de :

systemctl status mysql
journactl -xeu mysql
cat /var/log/mysql/error.log

pour voir l'état du service et les logs d'erreur ;

apt list ~n^mysql ~n^mariadb --installed

pour voir les paquets installés.

#8 Le 09/03/2023, à 20:02

duralex69

Re : [RÉSOLU] Accès à phpMyAdmin impossible après mise à niveau

Bonsoir,

@xubu1957

invoke-rc.d mysql start

ne donne rien.

Je vais essayer ce que me dit bruno...

Merci.


Ubuntu 22.04.2 LTS

Hors ligne

#9 Le 09/03/2023, à 20:05

duralex69

Re : [RÉSOLU] Accès à phpMyAdmin impossible après mise à niveau

Évolution par rapport à hier soir.
Lorsque je vais sur la page http://127.0.0.1/phpmyadmin/ je n'ai plus le message d'hier mais j'atterris sur une page blanche.

Si ça vous évoque...


Ubuntu 22.04.2 LTS

Hors ligne

#10 Le 09/03/2023, à 20:08

duralex69

Re : [RÉSOLU] Accès à phpMyAdmin impossible après mise à niveau

Tandis que la page http://127.0.0.1 m'amène sur une page "Apache2 Ubuntu Default Page" avec le message "It works!"


Ubuntu 22.04.2 LTS

Hors ligne

#11 Le 09/03/2023, à 20:29

arverne73

Re : [RÉSOLU] Accès à phpMyAdmin impossible après mise à niveau

Bonjour,
Au risque de faire erreur : à une époque, on pouvait se connecter à phpmyadmin avec le nom d'utilisateur habituel.
Comme indiqué dans la page de documentation ici, désormais, il faut créer un utilisateur spécifique pour Phpmyadmin. Je ne sais pas si c'était le cas dans ta version sous 21.10.
Dans la console MySQL, la commande:

SELECT user, host, plugin, authentication_string FROM mysql.user;

permet en tout cas de voir les utilisateurs enregistrés.


J-Paul - Utilisateur Ubuntu depuis 2006
Lunar 24.04 - AMD FX et carte graphique AMD Radeon HD 6850

Hors ligne

#12 Le 09/03/2023, à 21:42

duralex69

Re : [RÉSOLU] Accès à phpMyAdmin impossible après mise à niveau

@bruno

Voici le retour de

systemctl status mysql

:

● mysql.service - MySQL Community Server
     Loaded: loaded (/lib/systemd/system/mysql.service; enabled; vendor preset:>
     Active: active (running) since Thu 2023-03-09 18:54:45 CET; 7min ago
   Main PID: 1158 (mysqld)
     Status: "Server is operational"
      Tasks: 38 (limit: 4006)
     Memory: 328.9M
        CPU: 5.390s
     CGroup: /system.slice/mysql.service
             └─1158 /usr/sbin/mysqld

mars 09 18:54:41 ubuntu-NL40-50GU systemd[1]: Starting MySQL Community Server...
mars 09 18:54:45 ubuntu-NL40-50GU systemd[1]: Started MySQL Community Server.

Celui de

journactl -xeu mysql

:

La commande « journactl » n'a pas été trouvée, voulez-vous dire :
  commande « journalctl » du deb systemd (249.11-0ubuntu3.7)
Essayez : sudo apt install <nom du deb>

Celui de

cat /var/log/mysql/error.log

:

2023-03-03T17:40:23.936164Z 0 [System] [MY-010116] [Server] /usr/sbin/mysqld (mysqld 8.0.25-0ubuntu0.20.10.1) starting as process 1117
2023-03-03T17:40:23.982736Z 1 [System] [MY-013576] [InnoDB] InnoDB initialization has started.
2023-03-03T17:40:25.100806Z 1 [System] [MY-013577] [InnoDB] InnoDB initialization has ended.
2023-03-03T17:40:25.533578Z 0 [System] [MY-011323] [Server] X Plugin ready for connections. Bind-address: '127.0.0.1' port: 33060, socket: /var/run/mysqld/mysqlx.sock
2023-03-03T17:40:25.715308Z 0 [Warning] [MY-010068] [Server] CA certificate ca.pem is self signed.
2023-03-03T17:40:25.715590Z 0 [System] [MY-013602] [Server] Channel mysql_main configured to support TLS. Encrypted connections are now supported for this channel.
2023-03-03T17:40:25.771700Z 0 [System] [MY-010931] [Server] /usr/sbin/mysqld: ready for connections. Version: '8.0.25-0ubuntu0.20.10.1'  socket: '/var/run/mysqld/mysqld.sock'  port: 3306  (Ubuntu).
2023-03-03T17:59:03.873105Z 0 [System] [MY-013172] [Server] Received SHUTDOWN from user <via user signal>. Shutting down mysqld (Version: 8.0.25-0ubuntu0.20.10.1).
2023-03-03T17:59:05.283302Z 0 [System] [MY-010910] [Server] /usr/sbin/mysqld: Shutdown complete (mysqld 8.0.25-0ubuntu0.20.10.1)  (Ubuntu).
2023-03-04T13:44:03.457455Z 0 [System] [MY-010116] [Server] /usr/sbin/mysqld (mysqld 8.0.25-0ubuntu0.20.10.1) starting as process 1111
2023-03-04T13:44:03.495133Z 1 [System] [MY-013576] [InnoDB] InnoDB initialization has started.
2023-03-04T13:44:04.560114Z 1 [System] [MY-013577] [InnoDB] InnoDB initialization has ended.
2023-03-04T13:44:05.033764Z 0 [System] [MY-011323] [Server] X Plugin ready for connections. Bind-address: '127.0.0.1' port: 33060, socket: /var/run/mysqld/mysqlx.sock
2023-03-04T13:44:05.180104Z 0 [Warning] [MY-010068] [Server] CA certificate ca.pem is self signed.
2023-03-04T13:44:05.180356Z 0 [System] [MY-013602] [Server] Channel mysql_main configured to support TLS. Encrypted connections are now supported for this channel.
2023-03-04T13:44:05.245438Z 0 [System] [MY-010931] [Server] /usr/sbin/mysqld: ready for connections. Version: '8.0.25-0ubuntu0.20.10.1'  socket: '/var/run/mysqld/mysqld.sock'  port: 3306  (Ubuntu).
2023-03-04T17:13:38.852136Z 0 [System] [MY-013172] [Server] Received SHUTDOWN from user <via user signal>. Shutting down mysqld (Version: 8.0.25-0ubuntu0.20.10.1).
2023-03-04T17:13:40.864086Z 0 [System] [MY-010910] [Server] /usr/sbin/mysqld: Shutdown complete (mysqld 8.0.25-0ubuntu0.20.10.1)  (Ubuntu).
2023-03-05T14:38:55.808389Z 0 [System] [MY-010116] [Server] /usr/sbin/mysqld (mysqld 8.0.25-0ubuntu0.20.10.1) starting as process 1107
2023-03-05T14:38:55.878475Z 1 [System] [MY-013576] [InnoDB] InnoDB initialization has started.
2023-03-05T14:38:56.930442Z 1 [System] [MY-013577] [InnoDB] InnoDB initialization has ended.
2023-03-05T14:38:57.363520Z 0 [System] [MY-011323] [Server] X Plugin ready for connections. Bind-address: '127.0.0.1' port: 33060, socket: /var/run/mysqld/mysqlx.sock
2023-03-05T14:38:57.504242Z 0 [Warning] [MY-010068] [Server] CA certificate ca.pem is self signed.
2023-03-05T14:38:57.504519Z 0 [System] [MY-013602] [Server] Channel mysql_main configured to support TLS. Encrypted connections are now supported for this channel.
2023-03-05T14:38:57.574714Z 0 [System] [MY-010931] [Server] /usr/sbin/mysqld: ready for connections. Version: '8.0.25-0ubuntu0.20.10.1'  socket: '/var/run/mysqld/mysqld.sock'  port: 3306  (Ubuntu).
2023-03-05T21:04:21.754758Z 0 [System] [MY-013172] [Server] Received SHUTDOWN from user <via user signal>. Shutting down mysqld (Version: 8.0.25-0ubuntu0.20.10.1).
2023-03-05T21:04:24.079473Z 0 [System] [MY-010910] [Server] /usr/sbin/mysqld: Shutdown complete (mysqld 8.0.25-0ubuntu0.20.10.1)  (Ubuntu).
2023-03-06T21:23:20.552592Z 0 [System] [MY-010116] [Server] /usr/sbin/mysqld (mysqld 8.0.25-0ubuntu0.20.10.1) starting as process 1114
2023-03-06T21:23:20.609158Z 1 [System] [MY-013576] [InnoDB] InnoDB initialization has started.
2023-03-06T21:23:21.669268Z 1 [System] [MY-013577] [InnoDB] InnoDB initialization has ended.
2023-03-06T21:23:22.089004Z 0 [System] [MY-011323] [Server] X Plugin ready for connections. Bind-address: '127.0.0.1' port: 33060, socket: /var/run/mysqld/mysqlx.sock
2023-03-06T21:23:22.257109Z 0 [Warning] [MY-010068] [Server] CA certificate ca.pem is self signed.
2023-03-06T21:23:22.257414Z 0 [System] [MY-013602] [Server] Channel mysql_main configured to support TLS. Encrypted connections are now supported for this channel.
2023-03-06T21:23:22.313481Z 0 [System] [MY-010931] [Server] /usr/sbin/mysqld: ready for connections. Version: '8.0.25-0ubuntu0.20.10.1'  socket: '/var/run/mysqld/mysqld.sock'  port: 3306  (Ubuntu).
2023-03-06T21:55:07.006218Z 0 [System] [MY-013172] [Server] Received SHUTDOWN from user <via user signal>. Shutting down mysqld (Version: 8.0.25-0ubuntu0.20.10.1).
2023-03-06T21:55:09.077802Z 0 [System] [MY-010910] [Server] /usr/sbin/mysqld: Shutdown complete (mysqld 8.0.25-0ubuntu0.20.10.1)  (Ubuntu).
2023-03-08T12:49:16.676610Z 0 [System] [MY-010116] [Server] /usr/sbin/mysqld (mysqld 8.0.25-0ubuntu0.20.10.1) starting as process 1120
2023-03-08T12:49:16.749664Z 1 [System] [MY-013576] [InnoDB] InnoDB initialization has started.
2023-03-08T12:49:17.740813Z 1 [System] [MY-013577] [InnoDB] InnoDB initialization has ended.
2023-03-08T12:49:18.166345Z 0 [System] [MY-011323] [Server] X Plugin ready for connections. Bind-address: '127.0.0.1' port: 33060, socket: /var/run/mysqld/mysqlx.sock
2023-03-08T12:49:18.317582Z 0 [Warning] [MY-010068] [Server] CA certificate ca.pem is self signed.
2023-03-08T12:49:18.317831Z 0 [System] [MY-013602] [Server] Channel mysql_main configured to support TLS. Encrypted connections are now supported for this channel.
2023-03-08T12:49:18.375625Z 0 [System] [MY-010931] [Server] /usr/sbin/mysqld: ready for connections. Version: '8.0.25-0ubuntu0.20.10.1'  socket: '/var/run/mysqld/mysqld.sock'  port: 3306  (Ubuntu).
2023-03-08T19:03:04.415756Z 0 [System] [MY-013172] [Server] Received SHUTDOWN from user <via user signal>. Shutting down mysqld (Version: 8.0.25-0ubuntu0.20.10.1).
2023-03-08T19:03:05.933722Z 0 [System] [MY-010910] [Server] /usr/sbin/mysqld: Shutdown complete (mysqld 8.0.25-0ubuntu0.20.10.1)  (Ubuntu).
2023-03-08T19:35:29.423107Z 0 [System] [MY-010116] [Server] /usr/sbin/mysqld (mysqld 8.0.32-0ubuntu0.22.04.2) starting as process 96112
2023-03-08T19:35:29.465282Z 1 [System] [MY-013576] [InnoDB] InnoDB initialization has started.
2023-03-08T19:35:30.272875Z 1 [System] [MY-013577] [InnoDB] InnoDB initialization has ended.
2023-03-08T19:35:33.279088Z 4 [System] [MY-013381] [Server] Server upgrade from '80025' to '80032' started.
2023-03-08T19:35:39.327821Z 4 [System] [MY-013381] [Server] Server upgrade from '80025' to '80032' completed.
2023-03-08T19:35:39.445573Z 0 [Warning] [MY-010068] [Server] CA certificate ca.pem is self signed.
2023-03-08T19:35:39.445635Z 0 [System] [MY-013602] [Server] Channel mysql_main configured to support TLS. Encrypted connections are now supported for this channel.
2023-03-08T19:35:39.452643Z 0 [Warning] [MY-011810] [Server] Insecure configuration for --pid-file: Location '/tmp' in the path is accessible to all OS users. Consider choosing a different directory.
2023-03-08T19:35:39.482563Z 0 [System] [MY-011323] [Server] X Plugin ready for connections. Socket: /var/run/mysqld/mysqlx.sock
2023-03-08T19:35:39.482656Z 0 [System] [MY-010931] [Server] /usr/sbin/mysqld: ready for connections. Version: '8.0.32-0ubuntu0.22.04.2'  socket: '/tmp/tmp.9Qn085M1Bw/mysqld.sock'  port: 0  (Ubuntu).
2023-03-08T19:35:39.557089Z 0 [System] [MY-013172] [Server] Received SHUTDOWN from user <via user signal>. Shutting down mysqld (Version: 8.0.32-0ubuntu0.22.04.2).
2023-03-08T19:35:42.500361Z 0 [System] [MY-010910] [Server] /usr/sbin/mysqld: Shutdown complete (mysqld 8.0.32-0ubuntu0.22.04.2)  (Ubuntu).
2023-03-08T19:35:43.213301Z 0 [System] [MY-010116] [Server] /usr/sbin/mysqld (mysqld 8.0.32-0ubuntu0.22.04.2) starting as process 96565
2023-03-08T19:35:43.262894Z 1 [System] [MY-013576] [InnoDB] InnoDB initialization has started.
2023-03-08T19:35:43.709698Z 1 [System] [MY-013577] [InnoDB] InnoDB initialization has ended.
2023-03-08T19:35:43.966580Z 0 [Warning] [MY-010068] [Server] CA certificate ca.pem is self signed.
2023-03-08T19:35:43.966651Z 0 [System] [MY-013602] [Server] Channel mysql_main configured to support TLS. Encrypted connections are now supported for this channel.
2023-03-08T19:35:43.973664Z 0 [Warning] [MY-011810] [Server] Insecure configuration for --pid-file: Location '/tmp' in the path is accessible to all OS users. Consider choosing a different directory.
2023-03-08T19:35:44.002497Z 7 [System] [MY-013172] [Server] Received SHUTDOWN from user boot. Shutting down mysqld (Version: 8.0.32-0ubuntu0.22.04.2).
2023-03-08T19:35:44.009121Z 0 [System] [MY-011323] [Server] X Plugin ready for connections. Bind-address: '127.0.0.1' port: 33060, socket: /var/run/mysqld/mysqlx.sock
2023-03-08T19:35:46.148385Z 0 [System] [MY-010910] [Server] /usr/sbin/mysqld: Shutdown complete (mysqld 8.0.32-0ubuntu0.22.04.2)  (Ubuntu).
2023-03-08T19:35:47.836959Z 0 [System] [MY-010116] [Server] /usr/sbin/mysqld (mysqld 8.0.32-0ubuntu0.22.04.2) starting as process 96666
2023-03-08T19:35:47.888311Z 1 [System] [MY-013576] [InnoDB] InnoDB initialization has started.
2023-03-08T19:35:48.219587Z 1 [System] [MY-013577] [InnoDB] InnoDB initialization has ended.
2023-03-08T19:35:48.474969Z 0 [Warning] [MY-010068] [Server] CA certificate ca.pem is self signed.
2023-03-08T19:35:48.475050Z 0 [System] [MY-013602] [Server] Channel mysql_main configured to support TLS. Encrypted connections are now supported for this channel.
2023-03-08T19:35:48.512616Z 0 [System] [MY-011323] [Server] X Plugin ready for connections. Bind-address: '127.0.0.1' port: 33060, socket: /var/run/mysqld/mysqlx.sock
2023-03-08T19:35:48.512712Z 0 [System] [MY-010931] [Server] /usr/sbin/mysqld: ready for connections. Version: '8.0.32-0ubuntu0.22.04.2'  socket: '/var/run/mysqld/mysqld.sock'  port: 3306  (Ubuntu).
2023-03-08T19:51:19.618007Z 0 [System] [MY-013172] [Server] Received SHUTDOWN from user <via user signal>. Shutting down mysqld (Version: 8.0.32-0ubuntu0.22.04.2).
2023-03-08T19:51:21.149207Z 0 [System] [MY-010910] [Server] /usr/sbin/mysqld: Shutdown complete (mysqld 8.0.32-0ubuntu0.22.04.2)  (Ubuntu).
2023-03-08T19:52:17.784144Z 0 [System] [MY-010116] [Server] /usr/sbin/mysqld (mysqld 8.0.32-0ubuntu0.22.04.2) starting as process 1142
2023-03-08T19:52:17.846542Z 1 [System] [MY-013576] [InnoDB] InnoDB initialization has started.
2023-03-08T19:52:18.991899Z 1 [System] [MY-013577] [InnoDB] InnoDB initialization has ended.
2023-03-08T19:52:19.802704Z 0 [Warning] [MY-010068] [Server] CA certificate ca.pem is self signed.
2023-03-08T19:52:19.802800Z 0 [System] [MY-013602] [Server] Channel mysql_main configured to support TLS. Encrypted connections are now supported for this channel.
2023-03-08T19:52:19.926795Z 0 [System] [MY-011323] [Server] X Plugin ready for connections. Bind-address: '127.0.0.1' port: 33060, socket: /var/run/mysqld/mysqlx.sock
2023-03-08T19:52:19.927103Z 0 [System] [MY-010931] [Server] /usr/sbin/mysqld: ready for connections. Version: '8.0.32-0ubuntu0.22.04.2'  socket: '/var/run/mysqld/mysqld.sock'  port: 3306  (Ubuntu).
2023-03-08T21:44:22.200368Z 0 [System] [MY-013172] [Server] Received SHUTDOWN from user <via user signal>. Shutting down mysqld (Version: 8.0.32-0ubuntu0.22.04.2).
2023-03-08T21:44:24.865984Z 0 [System] [MY-010910] [Server] /usr/sbin/mysqld: Shutdown complete (mysqld 8.0.32-0ubuntu0.22.04.2)  (Ubuntu).
2023-03-09T17:46:03.479561Z 0 [System] [MY-010116] [Server] /usr/sbin/mysqld (mysqld 8.0.32-0ubuntu0.22.04.2) starting as process 1158
2023-03-09T17:46:03.541498Z 1 [System] [MY-013576] [InnoDB] InnoDB initialization has started.
2023-03-09T17:46:04.736417Z 1 [System] [MY-013577] [InnoDB] InnoDB initialization has ended.
2023-03-09T17:46:05.487293Z 0 [Warning] [MY-010068] [Server] CA certificate ca.pem is self signed.
2023-03-09T17:46:05.487373Z 0 [System] [MY-013602] [Server] Channel mysql_main configured to support TLS. Encrypted connections are now supported for this channel.
2023-03-09T17:46:05.654747Z 0 [System] [MY-011323] [Server] X Plugin ready for connections. Bind-address: '127.0.0.1' port: 33060, socket: /var/run/mysqld/mysqlx.sock
2023-03-09T17:46:05.655040Z 0 [System] [MY-010931] [Server] /usr/sbin/mysqld: ready for connections. Version: '8.0.32-0ubuntu0.22.04.2'  socket: '/var/run/mysqld/mysqld.sock'  port: 3306  (Ubuntu).
2023-03-09T17:50:18.792408Z 0 [System] [MY-013172] [Server] Received SHUTDOWN from user <via user signal>. Shutting down mysqld (Version: 8.0.32-0ubuntu0.22.04.2).
2023-03-09T17:50:20.630593Z 0 [System] [MY-010910] [Server] /usr/sbin/mysqld: Shutdown complete (mysqld 8.0.32-0ubuntu0.22.04.2)  (Ubuntu).
2023-03-09T17:54:43.291886Z 0 [System] [MY-010116] [Server] /usr/sbin/mysqld (mysqld 8.0.32-0ubuntu0.22.04.2) starting as process 1158
2023-03-09T17:54:43.339069Z 1 [System] [MY-013576] [InnoDB] InnoDB initialization has started.
2023-03-09T17:54:44.539918Z 1 [System] [MY-013577] [InnoDB] InnoDB initialization has ended.
2023-03-09T17:54:45.265951Z 0 [Warning] [MY-010068] [Server] CA certificate ca.pem is self signed.
2023-03-09T17:54:45.266031Z 0 [System] [MY-013602] [Server] Channel mysql_main configured to support TLS. Encrypted connections are now supported for this channel.
2023-03-09T17:54:45.379938Z 0 [System] [MY-011323] [Server] X Plugin ready for connections. Bind-address: '127.0.0.1' port: 33060, socket: /var/run/mysqld/mysqlx.sock
2023-03-09T17:54:45.380079Z 0 [System] [MY-010931] [Server] /usr/sbin/mysqld: ready for connections. Version: '8.0.32-0ubuntu0.22.04.2'  socket: '/var/run/mysqld/mysqld.sock'  port: 3306  (Ubuntu).

Et

apt list ~n^mysql ~n^mariadb --installed

:

En train de lister... Fait
mysql-client-8.0/jammy-updates,jammy-security,now 8.0.32-0ubuntu0.22.04.2 amd64  [installé, automatique]
mysql-client-core-8.0/jammy-updates,jammy-security,now 8.0.32-0ubuntu0.22.04.2 amd64  [installé, automatique]
mysql-common/jammy,jammy,now 5.8+1.0.8 all  [installé, automatique]
mysql-server-8.0/jammy-updates,jammy-security,now 8.0.32-0ubuntu0.22.04.2 amd64  [installé, automatique]
mysql-server-core-8.0/jammy-updates,jammy-security,now 8.0.32-0ubuntu0.22.04.2 amd64  [installé, automatique]
mysql-server/jammy-updates,jammy-updates,jammy-security,jammy-security,now 8.0.32-0ubuntu0.22.04.2 all  [installé]

Ubuntu 22.04.2 LTS

Hors ligne

#13 Le 09/03/2023, à 23:09

jplemoine

Re : [RÉSOLU] Accès à phpMyAdmin impossible après mise à niveau

duralex69 a écrit :

Celui de

journactl -xeu mysql

:

La commande « journactl » n'a pas été trouvée, voulez-vous dire :
  commande « journalctl » du deb systemd (249.11-0ubuntu3.7)
Essayez : sudo apt install <nom du deb>

C'est

journalctl -xeu mysql

erreur du sachant que je n'avais pas vu non plus.


Membre de l'ALDIL (Association Lyonnaise pour le Développement de l'Informatique Libre)
- En pro, après 20 ans de développement, administrateur Linux / Unix depuis Avril 2019.
- En privé, sous Ubuntu-Xubuntu depuis 2009.

Hors ligne

#14 Le 10/03/2023, à 07:46

bruno

Re : [RÉSOLU] Accès à phpMyAdmin impossible après mise à niveau

Désolé pour la faute de frappe.
Le serveur MySQL fonctionne. Il faut donc appliquer ce qu'a indiqué @arverne73 au message #11

#15 Le 10/03/2023, à 14:14

arverne73

Re : [RÉSOLU] Accès à phpMyAdmin impossible après mise à niveau

Ma remarque au #11 n'a de sens que si l'on peut avoir la page de connexion à Phpmyadmin à l'adresse localhost/phpmyadmin
Si ce n'est pas le cas, je tâcherais de désinstaller complètement phpmyadmin et le réinstaller en suivant bien la procédure indiqué dans la documentation du site Ubuntu-fr
Pour la désinstallation, configuration comprise, la commande

sudo apt remove --purge phpmyadmin

J-Paul - Utilisateur Ubuntu depuis 2006
Lunar 24.04 - AMD FX et carte graphique AMD Radeon HD 6850

Hors ligne

#16 Le 10/03/2023, à 22:32

duralex69

Re : [RÉSOLU] Accès à phpMyAdmin impossible après mise à niveau

Merci.

Bon, sinon voici le retour de la commande mysql :

mysql> SELECT user, host, plugin, authentication_string FROM mysql.user;
+------------------+-----------+-----------------------+------------------------------------------------------------------------+
| user             | host      | plugin                | authentication_string                                                  |
+------------------+-----------+-----------------------+------------------------------------------------------------------------+
| duralex69        | %         | caching_sha2_password | $A$005$%(a2;\"6	OhjVzQUch59NOgPaodNyPMW8mM5.rqGykRmtI0IK429jib1 |
t#J4tCO7dFI/Ta/nCLAoJl3KmEj4kXyQ29xrBV6SvlNfogB3 |word | $A$005${q
| mysql.infoschema | localhost | caching_sha2_password | $A$005$THISISACOMBINATIONOFINVALIDSALTANDPASSWORDTHATMUSTNEVERBRBEUSED |
| mysql.session    | localhost | caching_sha2_password | $A$005$THISISACOMBINATIONOFINVALIDSALTANDPASSWORDTHATMUSTNEVERBRBEUSED |
| mysql.sys        | localhost | caching_sha2_password | $A$005$THISISACOMBINATIONOFINVALIDSALTANDPASSWORDTHATMUSTNEVERBRBEUSED |
| phpmyadmin       | localhost | caching_sha2_password | $A$005$2yVs%%3t/g4`5/6P.SlQu0VDyTYB6UdUo0rKeZr3GCUZuoNlxkiUJk1B |
| root             | localhost | auth_socket           |                                                                        |
+------------------+-----------+-----------------------+------------------------------------------------------------------------+
7 rows in set (0,06 sec)

Je ne sais pas si ça aide.

Je vais réinstaller phpmyadmin.


Ubuntu 22.04.2 LTS

Hors ligne

#17 Le 11/03/2023, à 09:25

bruno

Re : [RÉSOLU] Accès à phpMyAdmin impossible après mise à niveau

La connexion à phpmyadmin devrait fonctionner avec l'utilisateur duralex69 et son mot de passe MySQL.

Tu dis que tu obtiens une page blanche en allant sur http:/localhost/phpmyadmin. Il faut regarder les logs après avoir tenté de visiter cette page. Si tu n'as pas modifié leur emplacement c'est dans /var/log/apache2/error.log.

#18 Le 14/03/2023, à 22:52

duralex69

Re : [RÉSOLU] Accès à phpMyAdmin impossible après mise à niveau

Merci bruno.

J'ai trouvé le fichier de log qui dit ceci :

[Thu Mar 02 19:37:00.340271 2023] [mpm_prefork:notice] [pid 1066] AH00163: Apache/2.4.46 (Ubuntu) configured -- resuming normal operations
[Thu Mar 02 19:37:00.340374 2023] [core:notice] [pid 1066] AH00094: Command line: '/usr/sbin/apache2'
[Thu Mar 02 22:12:54.981661 2023] [mpm_prefork:notice] [pid 1066] AH00169: caught SIGTERM, shutting down
[Fri Mar 03 18:40:23.429246 2023] [mpm_prefork:notice] [pid 1065] AH00163: Apache/2.4.46 (Ubuntu) configured -- resuming normal operations
[Fri Mar 03 18:40:23.429896 2023] [core:notice] [pid 1065] AH00094: Command line: '/usr/sbin/apache2'
[Fri Mar 03 18:59:04.564770 2023] [mpm_prefork:notice] [pid 1065] AH00169: caught SIGTERM, shutting down
[Sat Mar 04 14:44:03.022961 2023] [mpm_prefork:notice] [pid 1077] AH00163: Apache/2.4.46 (Ubuntu) configured -- resuming normal operations
[Sat Mar 04 14:44:03.025039 2023] [core:notice] [pid 1077] AH00094: Command line: '/usr/sbin/apache2'
[Sat Mar 04 18:13:39.598874 2023] [mpm_prefork:notice] [pid 1077] AH00169: caught SIGTERM, shutting down
[Sun Mar 05 15:38:55.341552 2023] [mpm_prefork:notice] [pid 1077] AH00163: Apache/2.4.46 (Ubuntu) configured -- resuming normal operations
[Sun Mar 05 15:38:55.341949 2023] [core:notice] [pid 1077] AH00094: Command line: '/usr/sbin/apache2'
[Sun Mar 05 22:04:23.918556 2023] [mpm_prefork:notice] [pid 1077] AH00169: caught SIGTERM, shutting down
[Mon Mar 06 22:23:20.147465 2023] [mpm_prefork:notice] [pid 1086] AH00163: Apache/2.4.46 (Ubuntu) configured -- resuming normal operations
[Mon Mar 06 22:23:20.155872 2023] [core:notice] [pid 1086] AH00094: Command line: '/usr/sbin/apache2'
[Mon Mar 06 22:55:09.099466 2023] [mpm_prefork:notice] [pid 1086] AH00169: caught SIGTERM, shutting down
[Wed Mar 08 13:49:16.146018 2023] [mpm_prefork:notice] [pid 1078] AH00163: Apache/2.4.46 (Ubuntu) configured -- resuming normal operations
[Wed Mar 08 13:49:16.151272 2023] [core:notice] [pid 1078] AH00094: Command line: '/usr/sbin/apache2'
[Wed Mar 08 20:03:08.667646 2023] [mpm_prefork:notice] [pid 1078] AH00169: caught SIGTERM, shutting down
[Wed Mar 08 20:03:08.966656 2023] [mpm_prefork:notice] [pid 18106] AH00163: Apache/2.4.46 (Ubuntu) configured -- resuming normal operations
[Wed Mar 08 20:03:08.966742 2023] [core:notice] [pid 18106] AH00094: Command line: '/usr/sbin/apache2'
[Wed Mar 08 20:37:31.385601 2023] [mpm_prefork:notice] [pid 18106] AH00169: caught SIGTERM, shutting down
[Thu Mar 09 18:46:02.795865 2023] [mpm_prefork:notice] [pid 1109] AH00163: Apache/2.4.52 (Ubuntu) configured -- resuming normal operations
[Thu Mar 09 18:46:02.800235 2023] [core:notice] [pid 1109] AH00094: Command line: '/usr/sbin/apache2'
[Thu Mar 09 18:48:03.818872 2023] [mpm_prefork:notice] [pid 1109] AH00170: caught SIGWINCH, shutting down gracefully
[Thu Mar 09 18:48:03.896180 2023] [mpm_prefork:notice] [pid 5892] AH00163: Apache/2.4.52 (Ubuntu) configured -- resuming normal operations
[Thu Mar 09 18:48:03.896368 2023] [core:notice] [pid 5892] AH00094: Command line: '/usr/sbin/apache2'
[Thu Mar 09 18:50:18.927516 2023] [mpm_prefork:notice] [pid 5892] AH00170: caught SIGWINCH, shutting down gracefully
[Thu Mar 09 18:54:42.631418 2023] [mpm_prefork:notice] [pid 1144] AH00163: Apache/2.4.52 (Ubuntu) configured -- resuming normal operations
[Thu Mar 09 18:54:42.633641 2023] [core:notice] [pid 1144] AH00094: Command line: '/usr/sbin/apache2'
[Thu Mar 09 21:34:03.576082 2023] [mpm_prefork:notice] [pid 1144] AH00170: caught SIGWINCH, shutting down gracefully
[Fri Mar 10 21:19:41.923092 2023] [mpm_prefork:notice] [pid 1143] AH00163: Apache/2.4.52 (Ubuntu) configured -- resuming normal operations
[Fri Mar 10 21:19:41.924075 2023] [core:notice] [pid 1143] AH00094: Command line: '/usr/sbin/apache2'
[Fri Mar 10 22:32:30.404398 2023] [mpm_prefork:notice] [pid 1143] AH00170: caught SIGWINCH, shutting down gracefully
[Sun Mar 12 11:44:22.701923 2023] [mpm_prefork:notice] [pid 1115] AH00163: Apache/2.4.52 (Ubuntu) configured -- resuming normal operations
[Sun Mar 12 11:44:22.705240 2023] [core:notice] [pid 1115] AH00094: Command line: '/usr/sbin/apache2'
[Sun Mar 12 21:37:10.640986 2023] [mpm_prefork:notice] [pid 1115] AH00170: caught SIGWINCH, shutting down gracefully
[Mon Mar 13 14:34:26.045505 2023] [mpm_prefork:notice] [pid 1138] AH00163: Apache/2.4.52 (Ubuntu) configured -- resuming normal operations
[Mon Mar 13 14:34:26.046942 2023] [core:notice] [pid 1138] AH00094: Command line: '/usr/sbin/apache2'
[Mon Mar 13 17:45:04.044346 2023] [mpm_prefork:notice] [pid 1138] AH00170: caught SIGWINCH, shutting down gracefully
[Tue Mar 14 21:24:56.755188 2023] [mpm_prefork:notice] [pid 1151] AH00163: Apache/2.4.52 (Ubuntu) configured -- resuming normal operations
[Tue Mar 14 21:24:56.757050 2023] [core:notice] [pid 1151] AH00094: Command line: '/usr/sbin/apache2'
[Tue Mar 14 21:27:49.452715 2023] [mpm_prefork:notice] [pid 1151] AH00170: caught SIGWINCH, shutting down gracefully
[Tue Mar 14 21:28:41.002325 2023] [mpm_prefork:notice] [pid 1136] AH00163: Apache/2.4.52 (Ubuntu) configured -- resuming normal operations
[Tue Mar 14 21:28:41.006036 2023] [core:notice] [pid 1136] AH00094: Command line: '/usr/sbin/apache2'

Cela vous parle ? Merci.

Alex


Ubuntu 22.04.2 LTS

Hors ligne

#19 Le 15/03/2023, à 13:17

bruno

Re : [RÉSOLU] Accès à phpMyAdmin impossible après mise à niveau

Rien dans les logs d'erreur c'est étrange.

En #3 on voyait beaucoup de résidus de paquets, notamment des traces de PHP 7.4 As-tu fais le ménagé ? Comme ceci :

sudo apt purge ?config-files

suivi d'une mise à jour complète :

sudo apt update
sudo apt full-upgrade

Si cela ne fonctionne toujours pas il faudra nous donner les retours de ;

a2query -m

pour voir les modules Apache utilisés

apt list php* libapache2-mod-php* --installed

pour voir les paquets PHP installés.

#20 Le 15/03/2023, à 13:33

duralex69

Re : [RÉSOLU] Accès à phpMyAdmin impossible après mise à niveau

Bonjour,

Pas de changement après ménage dans les paquets.

Le retour de

a2query -m
deflate (enabled by maintainer script)
setenvif (enabled by maintainer script)
reqtimeout (enabled by maintainer script)
authz_core (enabled by maintainer script)
status (enabled by maintainer script)
filter (enabled by maintainer script)
negotiation (enabled by maintainer script)
dir (enabled by maintainer script)
authz_user (enabled by maintainer script)
alias (enabled by maintainer script)
authn_core (enabled by maintainer script)
authn_file (enabled by maintainer script)
mime (enabled by maintainer script)
access_compat (enabled by maintainer script)
mpm_prefork (enabled by maintainer script)
autoindex (enabled by maintainer script)
php7.4 (enabled by maintainer script)
env (enabled by maintainer script)
auth_basic (enabled by maintainer script)
authz_host (enabled by maintainer script)

Et celui de

apt list php* libapache2-mod-php* --installed
En train de lister... Fait
libapache2-mod-php8.1/jammy-updates,jammy-security,now 8.1.2-1ubuntu2.11 amd64  [installé, automatique]
libapache2-mod-php/jammy,jammy,now 2:8.1+92ubuntu1 all  [installé]
php-bz2/jammy,jammy,now 2:8.1+92ubuntu1 all  [installé, automatique]
php-common/jammy,jammy,now 2:92ubuntu1 all  [installé, automatique]
php-curl/jammy,jammy,now 2:8.1+92ubuntu1 all  [installé]
php-gd/jammy,jammy,now 2:8.1+92ubuntu1 all  [installé]
php-google-recaptcha/jammy,jammy,now 1.2.4-3 all  [installé, automatique]
php-intl/jammy,jammy,now 2:8.1+92ubuntu1 all  [installé]
php-json/jammy,jammy,now 2:8.1+92ubuntu1 all  [installé]
php-mariadb-mysql-kbs/jammy,jammy,now 1.2.12-1 all  [installé, automatique]
php-mbstring/jammy,jammy,now 2:8.1+92ubuntu1 all  [installé]
php-mysql/jammy,jammy,now 2:8.1+92ubuntu1 all  [installé]
php-nikic-fast-route/jammy,jammy,now 1.3.0-3 all  [installé, automatique]
php-phpmyadmin-motranslator/jammy,jammy,now 5.2.0-1build1 all  [installé, automatique]
php-phpmyadmin-shapefile/jammy,jammy,now 2.1-5 all  [installé, automatique]
php-phpmyadmin-sql-parser/jammy,jammy,now 5.4.1-2 all  [installé, automatique]
php-phpseclib/jammy,jammy,now 2.0.36-1 all  [installé, automatique]
php-psr-cache/jammy,jammy,now 3.0.0-1 all  [installé, automatique]
php-psr-container/jammy,jammy,now 2.0.2-1 all  [installé, automatique]
php-psr-log/jammy,jammy,now 3.0.0-1 all  [installé, automatique]
php-symfony-cache-contracts/jammy,jammy,now 2.4.0-1ubuntu2 all  [installé, automatique]
php-symfony-cache/jammy,jammy,now 5.4.4+dfsg-1ubuntu8 all  [installé, automatique]
php-symfony-config/jammy,jammy,now 5.4.4+dfsg-1ubuntu8 all  [installé, automatique]
php-symfony-dependency-injection/jammy,jammy,now 5.4.4+dfsg-1ubuntu8 all  [installé, automatique]
php-symfony-deprecation-contracts/jammy,jammy,now 2.4.0-1ubuntu2 all  [installé, automatique]
php-symfony-expression-language/jammy,jammy,now 5.4.4+dfsg-1ubuntu8 all  [installé, automatique]
php-symfony-filesystem/jammy,jammy,now 5.4.4+dfsg-1ubuntu8 all  [installé, automatique]
php-symfony-polyfill-php80/jammy,jammy,now 1.24.0-1ubuntu2 all  [installé, automatique]
php-symfony-polyfill-php81/jammy,jammy,now 1.24.0-1ubuntu2 all  [installé, automatique]
php-symfony-service-contracts/jammy,jammy,now 2.4.0-1ubuntu2 all  [installé, automatique]
php-symfony-var-exporter/jammy,jammy,now 5.4.4+dfsg-1ubuntu8 all  [installé, automatique]
php-tcpdf/jammy,jammy,now 6.4.4+dfsg1-1 all  [installé, automatique]
php-twig-i18n-extension/jammy,jammy,now 3.0.0-2 all  [installé, automatique]
php-twig/jammy,jammy,now 3.3.8-2ubuntu4 all  [installé, automatique]
php-xml/jammy,jammy,now 2:8.1+92ubuntu1 all  [installé]
php-zip/jammy,jammy,now 2:8.1+92ubuntu1 all  [installé]
php8.1-bz2/jammy-updates,jammy-security,now 8.1.2-1ubuntu2.11 amd64  [installé, automatique]
php8.1-cli/jammy-updates,jammy-security,now 8.1.2-1ubuntu2.11 amd64  [installé, automatique]
php8.1-common/jammy-updates,jammy-security,now 8.1.2-1ubuntu2.11 amd64  [installé, automatique]
php8.1-curl/jammy-updates,jammy-security,now 8.1.2-1ubuntu2.11 amd64  [installé, automatique]
php8.1-gd/jammy-updates,jammy-security,now 8.1.2-1ubuntu2.11 amd64  [installé, automatique]
php8.1-intl/jammy-updates,jammy-security,now 8.1.2-1ubuntu2.11 amd64  [installé, automatique]
php8.1-mbstring/jammy-updates,jammy-security,now 8.1.2-1ubuntu2.11 amd64  [installé, automatique]
php8.1-mysql/jammy-updates,jammy-security,now 8.1.2-1ubuntu2.11 amd64  [installé, automatique]
php8.1-opcache/jammy-updates,jammy-security,now 8.1.2-1ubuntu2.11 amd64  [installé, automatique]
php8.1-readline/jammy-updates,jammy-security,now 8.1.2-1ubuntu2.11 amd64  [installé, automatique]
php8.1-xml/jammy-updates,jammy-security,now 8.1.2-1ubuntu2.11 amd64  [installé, automatique]
php8.1-zip/jammy-updates,jammy-security,now 8.1.2-1ubuntu2.11 amd64  [installé, automatique]
php8.1/jammy-updates,jammy-updates,jammy-security,jammy-security,now 8.1.2-1ubuntu2.11 all  [installé, automatique]
php/jammy,jammy,now 2:8.1+92ubuntu1 all  [installé]
phpmyadmin/jammy,jammy,now 4:5.1.1+dfsg1-5ubuntu1 all  [installé]

Encore merci de l'aide apportée !

Alex


Ubuntu 22.04.2 LTS

Hors ligne

#21 Le 15/03/2023, à 13:38

bruno

Re : [RÉSOLU] Accès à phpMyAdmin impossible après mise à niveau

Tu utilises toujours le module Apache pour PHP 7.4, donc aucun script PHP ne devait fonctionner. Je ne comprends pas pourquoi Apache ne t'a pas renvoyé d'erreurs…
Fait ceci:

sudo a2dismod php7.4
sudo a2enmod php8.1
sudo systemctl restart apache2

#22 Le 15/03/2023, à 14:09

duralex69

Re : [RÉSOLU] Accès à phpMyAdmin impossible après mise à niveau

sudo a2dismod php7.4
removing dangling symlink /etc/apache2/mods-enabled/php7.4.load
removing dangling symlink /etc/apache2/mods-enabled/php7.4.conf
sudo a2enmod php8.1
Considering dependency mpm_prefork for php8.1:
Considering conflict mpm_event for mpm_prefork:
Considering conflict mpm_worker for mpm_prefork:
Module mpm_prefork already enabled
Considering conflict php5 for php8.1:
Enabling module php8.1.
To activate the new configuration, you need to run:
  systemctl restart apache2
sudo systemctl restart apache2

Pas de retour particulier.


Ubuntu 22.04.2 LTS

Hors ligne

#23 Le 15/03/2023, à 14:10

bruno

Re : [RÉSOLU] Accès à phpMyAdmin impossible après mise à niveau

Si ce n'est que maintenant les scripts PHP doivent fonctionner et a priori phpmyadmin aussi.

#24 Le 15/03/2023, à 14:18

duralex69

Re : [RÉSOLU] Accès à phpMyAdmin impossible après mise à niveau

Alors là, chapeau !!! smile
MERCI beaucoup, l'accès se fait maintenant sans problème.

Alex


Ubuntu 22.04.2 LTS

Hors ligne