Contenu | Rechercher | Menus

Annonce

DVD, clés USB et t-shirts Ubuntu-fr disponibles sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 23/05/2006, à 19:14

yanightmare

[Résolu !] Installation imprimante

Bonjour. Je suis sous Dapper. Impossible d'installer mon imprimante... Pourtant sous Breezy je pouvais hmm

Je vais dans systeme > Administration > Impression .

Je mets "installer une nouvelle imprimante". Je choisis imprimante locale, mais impossible de choisir USB il n'y est pas. Et quand je mets ok partout en sélectionnant mon imprimante elle ne marche pas...

hmm

Dernière modification par yanightmare (Le 29/05/2006, à 21:19)

Hors ligne

#2 Le 23/05/2006, à 22:37

yanightmare

Re : [Résolu !] Installation imprimante

Personne peut m'aider ? hmm

Hors ligne

#3 Le 24/05/2006, à 13:33

yanightmare

Re : [Résolu !] Installation imprimante

http://www.image-dream.com/membre/up/du … pture4.png

Impossible de changer le port en bas. Et meme quand je peux le changer j'ai le choix entre :

hp no_device_found
Parallel port #1 (Canon)
Parallel port #1 (Epson)
LPT #1

Je suis branché en USB... Je coche quoi ??? hmm neutral

Dernière modification par yanightmare (Le 24/05/2006, à 13:34)

Hors ligne

#4 Le 24/05/2006, à 14:11

yanightmare

Re : [Résolu !] Installation imprimante

Bon bah en attendant qu'on me réponde je vais me voir un film moi big_smile...

Puisque je peux rien faire d'autre ... (j'aimerais imprimer un tas de commande que je dois faire sans X, [donc j'dois imprimer pour m'y retrouver] pour ensuite avoir l'accélération graphique sur mon ATI... tout un programme... tongue)

Hors ligne

#5 Le 24/05/2006, à 19:07

bertrand0

Re : [Résolu !] Installation imprimante

Il arrive qu'il faille redémarrer le serveur cups après avoir branché l'imprimante sur le port usb.
(dans un terminal, taper "sudo /etc/init.d/cupsys restart")
Normalement, tu devrais alors voir apparaître un port usb dans la liste quand tu fais ajouter l'imprimante.


Ceux qui écrivent comme ils parlent, quoiqu'ils parlent très bien, écrivent mal.
                                                            Buffon, Discours sur le style

Hors ligne

#6 Le 24/05/2006, à 19:40

yanightmare

Re : [Résolu !] Installation imprimante

bertrand0 a écrit :

Il arrive qu'il faille redémarrer le serveur cups après avoir branché l'imprimante sur le port usb.
(dans un terminal, taper "sudo /etc/init.d/cupsys restart")
Normalement, tu devrais alors voir apparaître un port usb dans la liste quand tu fais ajouter l'imprimante.

Nan toujours pas d'imprimante détectée et je n'ai toujours pas USB dans les ports hmm

Hors ligne

#7 Le 26/05/2006, à 19:02

yanightmare

Re : [Résolu !] Installation imprimante

Personne ne peut m'aider ? Bouhouhou... Pourquoi moi ? Sachant que je dois installer mon accélération graphique et que je dois m'imprimer mes tabs ! Bouhou... Déja j'aurai du le mettre dans "Dapper : Unstable". Si un modo charitable passe par là wink

Dernière modification par yanightmare (Le 26/05/2006, à 20:37)

Hors ligne

#8 Le 26/05/2006, à 22:41

kaillou38

Re : [Résolu !] Installation imprimante

ton usb est bien pris en charge deja? quand tu branches une clé usb, tu peux la monter?

Hors ligne

#9 Le 26/05/2006, à 22:52

yanightmare

Re : [Résolu !] Installation imprimante

Bah j'ai pas de clé usb... Et j'ai rien de branché en USB à part mon imprimante. hmm

Mais j'ai fait un lsusb et apparament elle est reconnue :

yanightmare@ubuntu:~$ lsusb
Bus 004 Device 001: ID 0000:0000
Bus 002 Device 001: ID 0000:0000
Bus 001 Device 002: ID 04b8:0808 Seiko Epson Corp.
Bus 001 Device 001: ID 0000:0000
Bus 003 Device 001: ID 0000:0000

hmm

Hors ligne

#10 Le 26/05/2006, à 23:08

ZiOns

Re : [Résolu !] Installation imprimante

Salut

tu as vérifié que dans le menu paramètres globaux  détecter les imprimantes LAN était bien coché ?

Hors ligne

#11 Le 26/05/2006, à 23:24

yanightmare

Re : [Résolu !] Installation imprimante

Oui il est coché neutral...

Hors ligne

#12 Le 26/05/2006, à 23:47

ZiOns

Re : [Résolu !] Installation imprimante

Question sans doute stupide mais quand tu coches utiliser une imprimante détectée il ne te met rien ?

Au fait c'est quoi le modèle de ton imprimante ?

Hors ligne

#13 Le 26/05/2006, à 23:50

yanightmare

Re : [Résolu !] Installation imprimante

J'ai une Epson CX5400.

Et quand je coche utiliser une imprimante détectée y a rien donc je peux pas avancer... hmm

Hors ligne

#14 Le 28/05/2006, à 15:41

yanightmare

Re : [Résolu !] Installation imprimante

En plus je suis vraiment dans le caca parce que ma mere a besoin d'imprimer plein de documents pour son boulot...

Personne a mon probleme ??? Vous pensez que c'est du à l'Epson CX5400 ??? Pourquoi sous Breezy ça marchait et pas sous Dapper ??? hmm

Je viens de regarder, elle est dans mon gestionnaire de périphériques. en USB... hmm

Dernière modification par yanightmare (Le 28/05/2006, à 19:21)

Hors ligne

#15 Le 28/05/2006, à 20:19

yanightmare

Re : [Résolu !] Installation imprimante

Je suis à la limite de craquer nerveusement...

J'ai trouvé ce tuto.

Ca peut marcher ??? hmm

Le probleme c'est qu'ici ils mettent ça :

You have to remove the following from the drivers/usb/scanner.c file in the kernel source:

if (dev->config[0].bNumInterfaces != 1) {
    info("probe_scanner: Only one device interface is supported.");
    return NULL;
}

Or je trouve pas le dossier cité... drivers/usb/scanner.c roll

Edit : je précise que j'ai pas trouvé de driver pour Stylus CX5400. Est-ce que celui pour 5200 peut marcher ??? hmm

Dernière modification par yanightmare (Le 28/05/2006, à 20:21)

Hors ligne

#16 Le 29/05/2006, à 19:19

bertrand0

Re : [Résolu !] Installation imprimante

yanightmare a écrit :

Le probleme c'est qu'ici ils mettent ça :

Non, ça c'est pour les noyaux inférieurs à 2.4 or dapper a un noyau 2.6, donc aucun problème de ce côté; de plus c'était uniquement pour faire marcher le scanner intégré, pas l'imprimante par elle-même.

Le premier site que tu donnes a l'air bien, tu as essayé ?


Ceux qui écrivent comme ils parlent, quoiqu'ils parlent très bien, écrivent mal.
                                                            Buffon, Discours sur le style

Hors ligne

#17 Le 29/05/2006, à 19:29

yanightmare

Re : [Résolu !] Installation imprimante

Ce que j'ai donné est tiré du premier site en fait... Dans le "3. Récupérer le driver de votre imprimante". ils disent :

Pour récupérer le driver de votre imprimante, consultez la Page de recherche de drivers

Alors j'y vais puis je vais sur Epson Stylus CX5200 (puisqu'il n'y a pas de page concernant la 5400 hmm) et je tombe sur :

http://www.linuxprinting.org/show_print … lus_CX5200

Puis :

You have to remove the following from the drivers/usb/scanner.c file in the kernel source:

hmm

Hors ligne

#18 Le 29/05/2006, à 20:27

bertrand0

Re : [Résolu !] Installation imprimante

Oui, je l'ai lu; ma remarque reste valable en ce qui concerne la partie scanner, il ne faut rien toucher, le noyau est suffisamment récent.
Par ailleurs, tu n'as pas besoin de télécharger le pilote, la dapper contient déjà le pilote pour la CX5400.

Je n'ai pas d'imprimante à portée de main pour tester, mais je peux te donner dans les grandes lignes une procédure à suivre, si personne de plus au courant ne se présente:
1- Tu branches ton imprimante
2- Tu tapes dans un terminal: ls /dev/usb*
Normalement tu devrais voir /dev/usb0
3- Tu cliques sur le menu Système/Administration/Impression
4- Tu fais ajouter une imprimante, et dans le port tu sélectionnes lpt1, puis tu cliques sur avancer
5- Fabricant Epson, Modèle Stylus CX5400, puis avancer, puis appliquer
6- dans un terminal, tu tapes
sudo gedit /etc/cups/printers.conf
7- à la place de la ligne "DeviceURI parallel:/dev/lp0"
tu mets "DeviceURI usb:/dev/usb0"
et tu sauvegardes
8- dans le terminal, tu tapes
sudo /etc/init.d/cupsys restart
afin de relancer le démon d'impression.

Avec un peu de chance, ça devrais fonctionner ainsi...

EDIT: Si à l'étape 2, tu n'as rien, tu peux lancer Système/Administration/Gestionnaire de périphériques. Tu cherches alors ton imprimante dans la liste des périphériques, et une fois que tu l'as trouvée, tu cliques dessus, puis sur l'onglet avancé. Là il ne reste plus qu'à trouver une entrée marquée "device" ou "device_file" et noter le chemin indiqué en valeur, et le mettre à la place de /dev/usb0 dans les commandes.

Dernière modification par bertrand0 (Le 29/05/2006, à 20:32)


Ceux qui écrivent comme ils parlent, quoiqu'ils parlent très bien, écrivent mal.
                                                            Buffon, Discours sur le style

Hors ligne

#19 Le 29/05/2006, à 21:19

yanightmare

Re : [Résolu !] Installation imprimante

Yeeeeeeeessss !!! J'ai même pas eu besoin de faire la 4 ! Je sais pas à quel miracle c'est du (mise à jour que j'ai faite il y a quelques minutes ? ls /dev/usb* ?), mais quand j'ai voulu rajouter une nouvelle imprimante, la mienne était reconnue en USB !!!

Yeahhhh ça marche nickel !!! Merci mille fois ! Merci merci merci merci merci smile

Tu (ou la mise à jour) me sauves ! big_smile

Merci encore cool

Hors ligne

#20 Le 29/05/2006, à 22:25

yanightmare

Re : [Résolu !] Installation imprimante

En fait peut-être pas si résolu... roll

Il a imprimé avec succès une belle page de test. Mais impossible d'imprimer sur le net ou sur openoffice.org. Pourtant je choisis bien Stylus CX5400... hmm

Hors ligne