Contenu | Rechercher | Menus

Annonce

DVD, clés USB et t-shirts Ubuntu-fr disponibles sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#51 Le 07/06/2006, à 19:32

bertrand0

Re : [résolu] Radeon 9200 : dessin incomplet avec fgl_glxgears

clown a écrit :

Pour ma part je n'ai fait que ça:
Télécharger la librairie : http://www.ground-impact.com/libGL.so.1.2
Puis la copier là: /usr/lib/ (à la place de l'ancienne)

Pour plus d'info: http://ubuntuforums.org/showthread.php?t=185033

Oui, je suis d'accord. Pour ceux qui ont une carte ATI supérieure aux 9000/9200/9250 la manip que tu donnes est suffisante, mais pour ces trois modèles, le pilote ne marchait déjà pas même avant la récente mise à jour d'ATI. Le récent problème n'a fait qu'en rajouter une couche... C'est spécifiquement pour ces trois cartes que s'applique la procédure que j'ai décrite.


Ceux qui écrivent comme ils parlent, quoiqu'ils parlent très bien, écrivent mal.
                                                            Buffon, Discours sur le style

Hors ligne

#52 Le 07/06/2006, à 23:25

Bluetr@in

Re : [résolu] Radeon 9200 : dessin incomplet avec fgl_glxgears

bertrand0 a écrit :

@Bluetrain #47
Effectivement, ces commandes ne servent que si on veux relancer aussi sec le serveur graphique à la fin sans avoir à redémarrer la machine. (Je suis bizarre, je préfère taper 3 commandes de plus qu'attendre 1 minute le reboot de la machine...)
Pour le prepare, tu as raison aussi, je ne l'ai pas mis parce que j'ai installé le paquet linux-headers-2.6.15-686, donc j'ai toujours les derniers en-têtes d'installés.

Tu as tout à fait raison mais vois tu, en étant débutant (comme presque moi), en suivant ton tuto je me retrouve brutalement devant un écran genre très barbare sans ton tuto sous les yeux et ça, c'est un vrai moment de solitude.

bertrand0 a écrit :

@Bluetrain #48
Fais attention avec les mises à jour, qui ont peut-être effacés la libGL que tu avais installé. Je n'utilise qu'aptitude donc je n'ai mis que les commandes le concernant pour bloquer les mises à jour.

Non le problème est tout autre. En fait et je l'ai compris sur un autre thread, j'ai renommé la librairie libGL.so.1.2 en libGL.so.1.2.backup et cela a entraîner la mise à jour du lien avec libGL.so.1. Résultat, l'appel à libGL.so.1 pointait sur libGL.so.1.2.backup et non sur libGL.so.1.2 . Il convient en fait de supprimer le lien existant puis de le rétablir à nouveau après avoir écraser libGL.so.1.2 ce qui donne

sudo rm /usr/lib/libGL.so.1
sudo ln -s /usr/lib/libGL.so.1.2 /usr/lib/libGL.so.1

Pour le reste, concernant les commentaires, tu as raison des commentaires de bout de ligne était passé en tant qu'argument. Conclusion, on place les commentaires avant et après les commandes. Par contre ke module GLCORE, je ne sais pas à quoi il sert et je n'ai pas encore creusé.

Pour reprendre ton tuto et concernant les cartes ATI 9000/9200/9250 il conviendrait de faire (après avoir imprimé le présent tuto pour ne pas se sentir désespérément seul(e) devant son écran pour les newbies ...) :

0- je télécharge les deux versions 8.14.13 et 8.24.8 dans mon répertoire home (les deux fichiers .run)
1- je suis passé sur le terminal virtuel 1 (en tapant ctrl+alt+F1)
2- je me logge
3- ensuite j'ai tapé les commandes suivantes:
sudo /etc/init.d/gdm stop
sudo rmmod fglrx
sudo rmmod radeon
sudo rmmod drm
sudo aptitude purge xorg-driver-fglrx fglrx-control fglrx-kernel-source
(là je réponds oui à chaque question)
mkdir ~/fglrx-8.24.8
cd ~/fglrx-8.24.8
X_VERSION=x680 fakeroot sh ~/ati-driver-installer-8.24.8-x86.run
(là je dis que je veux un paquet de distribution pour ubuntu/dapper, puis j'attend qu'il ait fini)
sudo dpkg -i xorg-driver-fglrx_8.24.8-1_i386.deb
sudo dpkg -i fglrx-control_8.24.8-1_i386.deb
sudo dpkg -i fglrx-kernel-source_8.24.8-1_i386.deb
sudo aptitude hold fglrx-control xorg-driver-fglrx fglrx-kernel-source
sudo aptitude install module-assistant
sudo module-assitant prepare
sudo module-assistant build fglrx-kernel
sudo module-assistant install fglrx-kernel
sudo depmod -ae
sudo dpkg-reconfigure xserver-xorg
(là je sélectionne le serveur fglrx, je fais l'autodétection de l'écran, du clavier et ainsi de suite en laissant tout par défaut (fr, xorg, pc105), je refuse d'écrire les sync dans la config, j'autorise l'écriture des sections par défaut, je sélectionne les modes 1280x800,1024x768,800x600 et 24bits pour la couleur)
sudo aticonfig --initial
mkdir ~/fglrx-8.14.13
sh ~/ati-driver-installer-8.14.13.run --extract ~/fglrx-8.14.13
sudo rm /usr/lib/libGL.so.1
sudo cp ~/fglrx-8.14.13/x680/usr/X11R6/lib/libGL.so.1.2 /usr/lib
sudo ln -s /usr/lib/libGL.so.1.2 libGL.so.1
sudo ldconfig
sudo /etc/init.d/gdm start; exit

Au cas ou on est pris d'envie (comme moi !) de faire une sauvegarde de libGL.so.1.2 en libGL.so.1.2.backup, il convient de mettre à jour le lien avec libGL.so.1 en faisant :

1. sudo rm /usr/lib/libGL.so.1
2. sudo ln -s /usr/lib/libGL.so.1.2 libGL.so.1

On reboot, et tout est normalement rentré dans l'ordre.

Encore merci Bertrand0 ...

Bluetr@in

Dernière modification par Bluetr@in (Le 07/06/2006, à 23:32)


Prendre son temps certes mais un jour il faut se lancer ...

Hors ligne

#53 Le 09/06/2006, à 09:54

bertrand0

Re : [résolu] Radeon 9200 : dessin incomplet avec fgl_glxgears

Oui, d'accord, à une exception: c'est en fait la commande ldconfig qui se charge de créer les liens symboliques comme celui que tu crées à la main. Or cette commande est lancée une fois de temps en temps par le système (je ne sais pas trop sur quels critères, mais je suppose à chaque installation d'une nouvelle bibliothèque...), ce qui veux dire que tes liens seront systématiquement recréés même si tu ne le fais pas. Ca veux dire aussi que la sauvegarde de libGL ne doit JAMAIS se trouver dans le path des bibliothèques (c'est pour cela que le paquet fglrx dévie la bibliothèque mesa dans /usr/lib/fglrx et ne se contente pas de la renommer.)

EDIT: Conclusion, ta sauvegarde libgl.baskup, je te conseille de la mettre dans /usr/lib/fglrx , où se trouve déjà libgl.xlibmesa

EDIT: Correction, avec les paquets de ATI, la bilbliothèque mesa est déviée vers /usr/share/fglrx/diversions.

Dernière modification par bertrand0 (Le 09/06/2006, à 10:04)


Ceux qui écrivent comme ils parlent, quoiqu'ils parlent très bien, écrivent mal.
                                                            Buffon, Discours sur le style

Hors ligne

#54 Le 09/06/2006, à 20:33

klub

Re : [résolu] Radeon 9200 : dessin incomplet avec fgl_glxgears

Bonjour,
j'ai aussi la chance d'avoir une radeon 9250... Ce post va peut etre paraitre un peu long par rapport à la question, mais je ne comprends plus rien.

Je suis le tutoriel à la lettre de bertrand0. Premier point:

sudo rmmod radeon
ERROR: Module radeon does not exist in /proc/modules
sudo rmmod drm
ERROR: Module drm does not exist in /proc/modules

Bon, tant pis, je continue (j'avais vu que ces lignes étaient facultatives si on redémarrait). Arrive la création de paquets, chose entièrement nouvelle pour moi (je précise que je tourne avec un Duron, et que mon header est bien le k7).
Je lance donc la ligne X_VERSION=x680 ...
je choisis "Generate Distribution Specific Driver Package"
Instalation Path = /home/ed/fglrx-8.24.8
Please choose the option to install: ben y a pas d'option disponible
Je choisis Ubuntu Package
Instalation complete!

Maintenant, si je fais la ligne suivante: sudo dpkg -i xorg-driver-fglrx_8.24.8-1_i386.deb

dpkg : erreur de traitement de xorg-driver-fglrx_8.24.8-1_i386.deb (--install): ne peut pas accéder à l'archive: Aucun fichier ou repertoire de ce type
Des erreurs ont été rencontrés pendant l'exécution:
xorg-driver-fglrx_8.24.8-1_i386.deb

Si je parcours le repertoire fglrx-8.24.8 précédemment créé, il me parait bien vide:
/usr/share/fglrx/fglrx-install.log et /usr/share/fglrx/fglrx-uninstall.sh
De plus, le log est vide... Le problème doit venir de la, mais je ne comprend pas pourquoi.

Hors ligne

#55 Le 09/06/2006, à 20:43

bertrand0

Re : [résolu] Radeon 9200 : dessin incomplet avec fgl_glxgears

Regarde dans /tmp si les fichiers .deb ne s'y trouvent pas, par hasard.
Sinon, pour trouver où le programme a été planquer les fichiers, tape:
find / -name xorg-driver-fglrx_8.24.8-1_i386.deb

EDIT: Essaie de taper "sudo aptitude install build-essential"
puis de recommencer l'étape de génération des paquets.

Dernière modification par bertrand0 (Le 09/06/2006, à 20:45)


Ceux qui écrivent comme ils parlent, quoiqu'ils parlent très bien, écrivent mal.
                                                            Buffon, Discours sur le style

Hors ligne

#56 Le 09/06/2006, à 20:54

klub

Re : [résolu] Radeon 9200 : dessin incomplet avec fgl_glxgears

Et bien ni l'un ni l'autre... find ne trouve rien, et tmp n'a rien qui y ressemble.
Le .run, au départ, detecte une architecture i686.
Sinon, les fichiers temporaires sont stocké dans fglrx-install, repertoire supprimé à la fin de l'installation.

EDIT: L'installation de ces paquets ne change rien. Je réinstalle le dernier driver, et j'essaie de bosser direct sous gdm.

Dernière modification par klub (Le 09/06/2006, à 21:11)

Hors ligne

#57 Le 09/06/2006, à 21:28

bertrand0

Re : [résolu] Radeon 9200 : dessin incomplet avec fgl_glxgears

L'essentiel est de générer ces paquets d'une façon ou d'une autre... On peut très bien les créer au préalable dans l'interface graphique.

EDIT: J'ai donné cette procédure à titre d'exemple pour mon cas; voici le lien dans le wiki pour la génération des paquets, qui traite plus en détail les cas particuliers pour la génération des paquets ati. Utilise donc cette procédure pour générer ton paquet en remplacement de tout ce que j'ai tapé jusqu'à la ligne avec aticonfig. (Bien sûr quand il est dit 8.25.18 dans le wiki, pour nous c'est 8.24.8)

EDIT: le X_VERSION=x680 est bel et bien indispensable, même s'il n'est pas dans le wiki, qui parlait du pilote 8.25.18.
Il ne faut pas non plus taper la ligne avec le "module-assistant update du wiki", et la ligne avec "module-assistant a-i" doit être remplacée par "module-assistant build" comme ce que j'avais écrit. (Problème de mise à jour sinon.)

Dernière modification par bertrand0 (Le 09/06/2006, à 21:51)


Ceux qui écrivent comme ils parlent, quoiqu'ils parlent très bien, écrivent mal.
                                                            Buffon, Discours sur le style

Hors ligne

#58 Le 09/06/2006, à 23:12

yanightmare

Re : [résolu] Radeon 9200 : dessin incomplet avec fgl_glxgears

Au fait au passage. Vu qu'il faut pas mettre à jour fglrx, est-ce qu'il y aurait moyen de les enlever de la liste de mise à jour ? hmm

Hors ligne

#59 Le 10/06/2006, à 03:27

Tye

Re : [résolu] Radeon 9200 : dessin incomplet avec fgl_glxgears

heu j'ai effectuer le tuto (page 2) mais je rencontre un probleme pour l'installation de fglrx-kernel avec module-assistant
voici l'erreur:

Échec de l'installation des sources de fglrx-kernel-source.
 Paquet ignoré. Vous devez peut-être ajouter quelque chose à sources.list, comme les archives « contrib » et « non-free ».

je sais pas trop quoi ajouter a mon source.list :s

Hors ligne

#60 Le 10/06/2006, à 12:46

bertrand0

Re : [résolu] Radeon 9200 : dessin incomplet avec fgl_glxgears

Bon, j'ai fait un résumé corrigé de ce que j'ai mis dans les posts précédents avec quelques explications... Ça évite d'avoir à relire la totalité des posts pour s'en sortir.
Donc les étapes:
0- je télécharges les deux versions 8.14.13 et 8.24.8 dans mon répertoire home (les deux fichiers .run)
1- je suis passé sur le terminal virtuel 1 (en tapant ctrl+alt+F1)
2- je me logge
3- ensuite j'ai tapé les commandes suivantes:
D'abord, arrêt du serveur graphique et déchargement des modules graphiques. L'arrêt du serveur est obligatoire si vous ne voulez pas que le système plante à la ligne dpkg-reconfigure un peu plus loin. Si vous utilisez un fichier xorg.conf déjà tout fait, ça n'est pas nécessaire d'arrêter le serveur. Par ailleurs, les rmmod renverront des erreurs si les modules n'étaient pas présent, ces erreurs peuvent être ignorées. Enfin, la dernière ligne sert à supprimer d'éventuels paquets fglrx déjà installés, s'il n'y en a pas, aptitude le dit et on peut continuer.

sudo /etc/init.d/gdm stop
      (Arrêt du serveur graphique)
sudo rmmod fglrx
      (Déchargement ancien module si existant, facultatif)
sudo rmmod radeon
      (Déchargement module pilote libre, si présent, facultatif)
sudo rmmod drm
      (Déchargement module pilote libre, si présent, facultatif)
sudo aptitude purge xorg-driver-fglrx fglrx-control fglrx-kernel-source
      (Suppression des anciens paquets fglrx; je réponds oui aux demandes de confirmation d'aptitude)

Toute la partie qui suit sert à générer les paquets pour la version 8.24.8 du pilote propriétaire ATI. Si vous préférez faire autrement, aucun problème, le tout est de terminer en ayant installé les paquets xorg-driver-fglrx et fglrx-kernel-source. Si le répertoire fglrx-8.24.8 existe déjà, supprimez le ou choisissez en un autre.

export CC=gcc-4.0
sudo aptitude install gcc-4.0 module-assistant build-essential fakeroot dh-make debconf libstdc++5 gcc-4.0-base module-assistant
      (Préparation des outils pour la compilation des paquets, ça sort direct du wiki pour la version 8.25.18)
mkdir ~/fglrx-8.24.8
cd ~/fglrx-8.24.8
      (Création du répertoire de travail pour générer les paquets 8.24.8)
X_VERSION=x680 fakeroot sh ~/ati-driver-installer-8.24.8-x86.run --buildpkg Ubuntu/dapper
      (Génération automatique des paquets 8.24.8 de ATI pour xorg)
sudo dpkg -i xorg-driver-fglrx_8.24.8-1_i386.deb
sudo dpkg -i fglrx-control_8.24.8-1_i386.deb
sudo dpkg -i fglrx-kernel-source_8.24.8-1_i386.deb
      (Installation des 3 paquets qui nous intéressent)

A partir de là, se pose le problème que apt-get veut systématiquement mettre à jour les paquets qu'on vient d'installer avec ceux du dépôts officiels qui ne marchent pas pour nous. Donc je vous propose d'éditer le fichier /etc/apt/preferences avec votre éditeur préféré (le fichier n'existe peut-être pas encore, ce n'est pas un problème, on le crée), par exemple:

sudo vi /etc/apt/preferences

et d'y taper ce qui suit (rappel, une fois dans vi, on appuie sur "i" pour passer en insertion, on écrit son truc, puis on appuie sur echap, et enfin on tape ":wq" pour quitter et enregistrer ou ":q!" pour quitter et annuler les changements). En fait, ça vous pouvez le faire au tout début, avant d'arrêter l'interface graphique, si vous voulez, ça ne pose pas de problème. Le jour où vous voudrez revenir aux pilotes du dépôt, il suffira de supprimer le fichier preferences.

Package: xorg-driver-fglrx
Pin: version 8.24.8-1
Pin-Priority: 1001

Package: fglrx-kernel-source
Pin: version 8.24.8-1
Pin-Priority: 1001

Package: fglrx-control
Pin: version 8.24.8-1
Pin-Priority: 1001

Maintenant, il faut compiler le module noyau du pilote 8.24.8.
Si vous avez mis à jour le fichier preferences comme indiqué, il suffit maintenant de taper:

sudo module-assistant auto-install fglrx-kernel
      (Compilation et installation du module noyau)
sudo depmod -ae
      (Mise à jour de la base de données des modules, facultatif si on reboote)

Sinon, il faut plutôt taper ces commandes:

sudo module-assistant prepare fglrx-kernel
      (Téléchargement des en-têtes du noyau)
sudo module-assistant build fglrx-kernel
      (Compilation)
sudo module-assistant install fglrx-kernel
      (Installation)
sudo depmod -ae

Maintenant, il faut configurer le serveur X nouvellement installé. Si vous avez déjà un fichier xorg.conf qui marchait avec une ancienne version de fglrx, vous le mettre dans /etc/X11. Sinon je propose les deux lignes suivantes:

sudo dpkg-reconfigure xserver-xorg
      (Sert à générer un fichier xorg.conf générique)
      (là je sélectionne le serveur fglrx, je fais l'autodétection de l'écran, du clavier et ainsi de suite 
      en laissant tout par défaut (fr, xorg, pc105), je refuse d'écrire les sync dans la config, j'autorise
      l'écriture des sections par défaut, je sélectionne les modes 1280x800,1024x768,800x600 et 
      24bits pour la couleur)
sudo aticonfig --initial
      (Sert à appliquer les options spécifiques du pilote ATI)

L'étape suivante est d'extraire la version qui marche avec les 9000/9200/9250 du pilote openGL d'ATI, à savoir la version 8.14.13. Si le répertoire fglrx-8.14.13 existe déjà, on le supprime ou on en choisit un autre... Il n'est pas nécessaire de sauvegarder le fichier libGL.so.1.2: si vous vous plantez, il suffit de retaper "sudo dpkg -i ~/fglrx-8.24.8/xorg-driver-fglrx_8.24.8-1_i386.deb" pour récupérer la version perdue.

mkdir ~/fglrx-8.14.13
      (Création du répertoire de travail)
sh ~/ati-driver-installer-8.14.13.run --extract ~/fglrx-8.14.13
      (Extraction du contenu de l'archive ATI du pilote 8.14.13)
sudo cp ~/fglrx-8.14.13/x680/usr/X11R6/lib/libGL.so.1.2 /usr/lib
      (Copie de la version 8.14.13 par dessus la version 8.24.8)
sudo ldconfig
      (Mise à jour de la base de données des bibliothèques)

La dernière étape consiste à mettre à jour certains chemins d'accès pour que la bibliothèque puisse trouver les modules dri dont elle a besoin:

cd /usr/X11R6/lib
sudo mkdir modules
      (Création d'un répertoire manquant; s'il existe déjà, il y a un message d'erreur qui peut être ignoré)
cd modules
sudo ln -s /usr/lib/dri
      (Création du lien symbolique vers le bon répertoire dri)

La dernière commande sert à redémarrer l'interface graphique, mais vous pouvez faire un "sudo reboot" à la place si vous n'avez pas confiance.

sudo /etc/init.d/gdm start; exit

Voilà, c'est un peu long, mais je pense que ça couvre tout ce qui a été dit auparavant. Je rappelle encore que c'est explicitement pour les radeon 9000/9200/9250. Pour les autres le problème est moins profond et il y a d'autres solutions plus simple.
En espérant qu'ATI se décidera à se souvenir un jour de l'existence de ces chipsets...

Dernière modification par bertrand0 (Le 10/06/2006, à 12:54)


Ceux qui écrivent comme ils parlent, quoiqu'ils parlent très bien, écrivent mal.
                                                            Buffon, Discours sur le style

Hors ligne

#61 Le 10/06/2006, à 13:07

bertrand0

Re : [résolu] Radeon 9200 : dessin incomplet avec fgl_glxgears

@Tye Est-ce que tu pourrais réessayer avec ce que je viens de mettre, et me dire si ça ne marche toujours pas, et les éventuels changements que tu as fait par rapport à ce que j'ai marqué.
Si tu as déjà essayé ce que j'avais marqué au tout début, n'oublie pas de taper les commandes suivantes pour démarrer sur un espace vierge:

sudo rm -rf ~/fglrx-8.24.8 ~/fglrx-8.14.13
     (Effacement des deux répertoires de travail, 
     ATTENTION, surtout ne pas mettre d'espace entre le ~ et le / ce serait catastrophique !)

@yanightmare pour ta question j'ai mis une façon de faire dans le post précédent.

Dernière modification par bertrand0 (Le 10/06/2006, à 13:08)


Ceux qui écrivent comme ils parlent, quoiqu'ils parlent très bien, écrivent mal.
                                                            Buffon, Discours sur le style

Hors ligne

#62 Le 10/06/2006, à 14:18

Tye

Re : [résolu] Radeon 9200 : dessin incomplet avec fgl_glxgears

voila le problemes

tye@ubuntu:~$ sudo module-assistant prepare fglrx-kernel
Getting source for kernel version: 2.6.15-23-686
En-têtes du noyau disponibles dans /usr/src/linux

Fait.

et si je fais l' "auto-install il me sort la meme erreur que précedemment :s
snif ..

Hors ligne

#63 Le 10/06/2006, à 14:57

bertrand0

Re : [résolu] Radeon 9200 : dessin incomplet avec fgl_glxgears

Bon, je dois avouer que je ne comprend pas bien ce qui cloche. Essaye de supprimer les répertoires /usr/src/modass et /usr/src/modules avant de faire l'étape des module-assistant.

sudo rm -rf /usr/src/modass /usr/src/modules

Si ça ne marche toujours pas, je te propose une solution alternative. Je suppose ici que tu as bien installé le fichier fglrx-kernel-source à l'aide de la commande dpkg comme indiqué dans le post #60 !

sudo aptitude update
sudo aptitude install linux-headers-$(uname -r)
cd /usr/src
sudo rm -rf /usr/src/modules
sudo tar -xjf fglrx.tar.bz2
cd /usr/src/linux-headers-$(uname -r)
sudo make-kpkg modules_image
sudo dpkg -i /usr/src/fglrx-kernel-$(uname -r)_8.24.8-1+10.00.Custom_i386.deb

et à partir de là, tu reprends au "sudo depmod -ae"

Dernière modification par bertrand0 (Le 10/06/2006, à 14:58)


Ceux qui écrivent comme ils parlent, quoiqu'ils parlent très bien, écrivent mal.
                                                            Buffon, Discours sur le style

Hors ligne

#64 Le 11/06/2006, à 18:55

Tye

Re : [résolu] Radeon 9200 : dessin incomplet avec fgl_glxgears

j'ai un soucis a cette ligne:
"sudo make-kpkg modules_image"
il connait pas la commande
et pensant qu'il y avait une erreur de frappe j'ai meme testé celle ci:
"sudo make-dpkg modules_image"

mais non toujours pas :s

Hors ligne

#65 Le 11/06/2006, à 19:04

yanightmare

Re : [résolu] Radeon 9200 : dessin incomplet avec fgl_glxgears

Au fait merci bertrand pour les mises à jour wink smile

Hors ligne

#66 Le 11/06/2006, à 19:19

Tye

Re : [résolu] Radeon 9200 : dessin incomplet avec fgl_glxgears

haaaaaaaa c'est bon j'ai réussi a faire marcher la commande "make-dpkg" en installant "kernel-package"..
et maintenant tout marche..
j'ai bien un cube avec des engrenages qui tournent quand je tape "fgl_glxgears"
et j'ai pres de 1800 fps avec "fglxgears" !!
merci, merci beaucooup Bertrant0 big_smile:D:D

parcontre juste un truc qui me chagrine,  lorsque je veux minimiser une fenetre , l'animation qui fait que la fenetre devient deplus en plus petite jusqu'en dans la barre de taches et enfait un réctangle noir très moche... et je n'avais pas ca avant :s Es ce que ca aurait un rappot avec la manip effectuée ??

Hors ligne

#67 Le 12/06/2006, à 18:14

tuxico

Re : [résolu] Radeon 9200 : dessin incomplet avec fgl_glxgears

bonjour à tous,

voila mon problème :

J'ai suivi tous les tutos sur les drivers ati que j'ai pu trouver sur le net...rien à faire .
Celui posté sur ce forum ne retourne aucun message d'erreur mais mon xorg n'a tjs pas d'accélration 3D et est toujours basé sur la lib mesa -_-

quand je fais modprobe -v fglrx
j'obtiens :
insmod /lib/modules/2.6.15/misc/fglrx.ko
FATAL: Error inserting fglrx (/lib/modules/2.6.15/misc/fglrx.ko): Invalid module format


wtf? roll j'ai cherché mais pas trouvé la solution .

Malgré tous les paquest installés, le fglrxinfo me donne :
3t3rnity:/home/tuxico# fglrxinfo
display: :0.0  screen: 0
OpenGL vendor string: Mesa project: www.mesa3d.org
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.2 (1.5 Mesa 6.4.1)

donc toujours Mesa...:s

Il faut savoir qu'avant tout allait bien avec le DRI, depuis un dist-upgrade je n'ai plus d'accélération, plus moyen de changer cette lib mesa à la *** et donc j'essaye tant bien que mal apparamment d'installer ces fichus drivers qui commencent à m'agacer...
quand je lance par exemple Enemy-territory (jeu online) :

...loading libGL.so.1: Initializing OpenGL display
...setting mode 4: 800 600
Using XFree86-VidModeExtension Version 2.2
XF86DGA Mouse (Version 2.0) initialized
XFree86-VidModeExtension Activated at 800x600
Using 8/8/8 Color bits, 16 depth, 0 stencil display.
GL_RENDERER: Mesa GLX Indirect


***********************************************************
You are using software Mesa (no hardware acceleration)!
Driver DLL used: libGL.so.1
If this is intentional, add
       "+set r_allowSoftwareGL 1"
to the command line when starting the game.
***********************************************************
...WARNING: could not set the given mode (4)
Initializing OpenGL display
...setting mode 3: 640 480
Using XFree86-VidModeExtension Version 2.2
XF86DGA Mouse (Version 2.0) initialized
XFree86-VidModeExtension Activated at 640x480
Received signal 11, exiting...

un grand merci d'avance hmm

#68 Le 12/06/2006, à 19:35

bertrand0

Re : [résolu] Radeon 9200 : dessin incomplet avec fgl_glxgears

tuxico a écrit :

quand je fais modprobe -v fglrx
j'obtiens :
insmod /lib/modules/2.6.15/misc/fglrx.ko
FATAL: Error inserting fglrx (/lib/modules/2.6.15/misc/fglrx.ko): Invalid module format

Apparemment tu utilises un noyau personnalisé plutôt que le noyau précompilé de ubuntu. Je mettrais ma main à couper que le problème est lié à ça. Quand tu as compilé le module fglrx, es-tu certain d'avoir utilisé *exactement* les mêmes en-têtes que ceux du noyau que tu as compilé ? Etant donné que tu n'as pas donné de nom personnalisé à ton noyau (genre 2.6.15-perso plutôt que 2.6.15), il peut y avoir confusion entre ton noyau, et les en-têtes par défaut...
Si tu ne vois pas de quoi je parle, je te conseille de mettre à jour ton système et d'installer puis booter sur un des noyaux précompilés.


Ceux qui écrivent comme ils parlent, quoiqu'ils parlent très bien, écrivent mal.
                                                            Buffon, Discours sur le style

Hors ligne

#69 Le 12/06/2006, à 19:56

Tuxico

Re : [résolu] Radeon 9200 : dessin incomplet avec fgl_glxgears

je suis obligé de booter sur mon kernel "perso" car j'utilise ndiswrapper pour ma connection et j'ai besoin de certains autres modules qui ne sont pas pris par défault, de plus je préfère toujours recompiler par moi-même, cela marchait très bien jusqu'au dernier dist-upgrade ou plus d'accélération (précision je n'utilisais pas les drivers ati! rien que le dri et ca suffisait, ici ca ne marche même pas...)
Je ne vois pas la différence entre le fait que mon noyau soit nommé 2.6.15 et 2;6.15-perso ce n'est qu'un nom wink
en tout cas merci de l'attention que vous portez à mon problème smile

#70 Le 12/06/2006, à 19:57

Tuxico

Re : [résolu] Radeon 9200 : dessin incomplet avec fgl_glxgears

Tuxico a écrit :

je suis obligé de booter sur mon kernel "perso" car j'utilise ndiswrapper pour ma connection et j'ai besoin de certains autres modules qui ne sont pas pris par défault, de plus je préfère toujours recompiler par moi-même, cela marchait très bien jusqu'au dernier dist-upgrade ou plus d'accélération (précision je n'utilisais pas les drivers ati! rien que le dri et ca suffisait, ici ca ne marche même pas...)
Je ne vois pas la différence entre le fait que mon noyau soit nommé 2.6.15 et 2;6.15-perso ce n'est qu'un nom wink
en tout cas merci de l'attention que vous portez à mon problème smile

Edit: oups j'avais mal lu, non mon noyau s'appelle bien 2.6.15 smile

#71 Le 13/06/2006, à 17:51

bertrand0

Re : [résolu] Radeon 9200 : dessin incomplet avec fgl_glxgears

Tuxico a écrit :

Je ne vois pas la différence entre le fait que mon noyau soit nommé 2.6.15 et 2;6.15-perso ce n'est qu'un nom wink

Voilà un exemple: je compile mon premier noyau avec mes paramètres perso --> ça me donne un paquet linux-image-2.6.15; je suis prévoyant, j'ai aussi préparé le paquet linux-headers-2.6.15 pour les en-têtes, et je l'ai installé. Là-dessus, je décide de recompiler un nouveau noyau avec des paramètres complètement optimisés ... mais comme je suis pressé, je ne crée que le nouveau paquet linux-image-2.6.15. Là-dessus, tout fonctionne nickel. Viens le moment où je veux compiler un module pour mon noyau. J'utilise module-assistant, impec tout se compile sans problème. Mais il y a un os le module ne veux pas se charger... c'est en fait parce que module-assistant a utilisé les en-têtes fournies par le vieux paquet linux-headers-2.6.15, celui de la premièle compilation. Comme les noms de noyaux et les versions sont tous identiques, il n'y a pas de moyen évident pour le programme de déterminer que ce sont les mauvais en-têtes. En donnant des noms différents à chaque fois, le problème ne se posait pas.

Tout ça pour dire qu'il faut t'assurer que module-assistant a bien utilisé soit le répertoire d'en-tête adéquat, soit le répertoire source dans lequel tu as fait ta compilation (et sans l'avoir réutilisé entre temps...). D'après le message d'erreur, il est à peu près certain que ton problème est de cet ordre.

EDIT: Il faut aussi t'assurer que tu as utilisé le même compilateur pour ton noyau et pour le module, à savoir gcc-4.0. Si tu fais l'un avec gcc-3.4 et l'autre avec gcc-4.0, il est possible que ça pose ce genre de problèmes.

Dernière modification par bertrand0 (Le 13/06/2006, à 17:54)


Ceux qui écrivent comme ils parlent, quoiqu'ils parlent très bien, écrivent mal.
                                                            Buffon, Discours sur le style

Hors ligne

#72 Le 13/06/2006, à 19:50

Tuxico

Re : [résolu] Radeon 9200 : dessin incomplet avec fgl_glxgears

ok merci en fait j'ai réussi à réinitiliser l'acc. 3d avec le module dri j'ai 1800fps sur glxgears et bon ca me suffit...Les drivers propriétaires d'ati ne sont pas satisfaisant je trouve...mal codés et vraiment pas optimisés (enfin c'est ati quoi...) . Maintenant, le problème de l'impossibilité de charger le module venait du fait que le module avait été compilé avec une version de gcc antérieure comme vous l'avez signalé...je trouve d'ailleurs cela assez mal "foutu" mais bon ...;) car j'ai du recompiler mon kernel avec la version courante de gcc pour permettre l'ajouts de modules compilés avec cette même version...bref, perte de temps wink

voila wink

#73 Le 13/06/2006, à 21:19

bertrand0

Re : [résolu] Radeon 9200 : dessin incomplet avec fgl_glxgears

Oui, entièrement d'accord contre ati. Pour les perfs, il n'y a pas que ça, moi avec radeon je tourne entre 2000 et 2200 selon les réglages, tandis qu'avec le pilote ati je suis à 1900, dans glxgears. Cependant, un certains nombre de primitives non utilisées par glxgears sont plus rapides avec fglrx; par exemple quelques veilles d'écrans opengl, surtout celles utilisant des textures, tournent beaucoup mieux avec fglrx. D'ailleurs, avec le pilote radeon, il faut penser à bidouiller un peu avec driconf pour avoir les meilleures perfs (notamment le s3tc est à activer si on veux que ce soit comparable avec fglrx). Si tu veux un exemple concret, UFO:Aftermath via cedega est injouable sur le pilote radeon (trop saccadé), mais tourne nickel sur fglrx.

Dernière modification par bertrand0 (Le 13/06/2006, à 21:19)


Ceux qui écrivent comme ils parlent, quoiqu'ils parlent très bien, écrivent mal.
                                                            Buffon, Discours sur le style

Hors ligne

#74 Le 17/06/2006, à 12:07

*Serval

Re : [résolu] Radeon 9200 : dessin incomplet avec fgl_glxgears

bertrand0 a écrit :

Bon, j'ai fait un résumé corrigé de ce que j'ai mis dans les posts précédents avec quelques explications... Ça évite d'avoir à relire la totalité des posts pour s'en sortir.
Donc les étapes:
0- je télécharges les deux versions 8.14.13 et 8.24.8 dans mon répertoire home (les deux fichiers .run)

Hum je cale déjà ici tongue

Comment faire pour télécharger des 2 versions ?


Merci d'avance smile

Hors ligne

#75 Le 18/06/2006, à 03:49

sboudbliff

Re : [résolu] Radeon 9200 : dessin incomplet avec fgl_glxgears

Salut,
j'ai une radeon 9250 et je viens de suivre à la lettre le tuto de bertrand0.
L'acceleration graphique fonctionne mais c'est très saccadé (120FPS en moyenne),.comme le vidéo "plein ecran" .
???

Hors ligne