Contenu | Rechercher | Menus

Annonce

Ubuntu-fr vend de superbes t-shirts et de belles clés USB 32Go
Rendez-vous sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 06/08/2010, à 08:43

ognio2009

[Résolu] Bit rate wifi à 54 M, mais pour une session...

Bonjour,

En partant de la documentation Ubuntu, j'ai bien réussi à fixer le bit rate wifi à 54 M mais seulement pour une session en cours: il faut recommencer à chaque fois. Certes, ce n est pas compliqué à refaire chaque fois avec un copier coller, mais je ne comprends pas quel type d'écriture il faut faire pour le conserver en permanence:
Je ne vois pas ce que veut dire : /etc/rc.local (avant la ligne exit 0)  et surtout à quoi ça corresponds dans mon système et comment y aller.
Beaucoup de questions pour un truc simple !

Merci si quelqu'un connait cette procédure de façon pratique.

François

Dernière modification par ognio2009 (Le 12/08/2010, à 12:42)


AntiX 16.1 - tout seul sur le disque dur  - Laptop Toshiba Satellite A 100 - 310 2006
Ubuntu 18.04 LTS, tout seul sur le disque dur - HP Compaq 6005 - 155 G0 32 bits Intel core 2CPU 1.66 Ghz
Ipad MINI -IOS12

Hors ligne

#2 Le 06/08/2010, à 08:58

fabux

Re : [Résolu] Bit rate wifi à 54 M, mais pour une session...

Salut,

si tu nous disais quel tuto ou procédure tu fais, on pourrait peut-être t'aider un peu plus wink

Hors ligne

#3 Le 06/08/2010, à 16:38

ognio2009

Re : [Résolu] Bit rate wifi à 54 M, mais pour une session...

ok désolé pour la brièveté :

Je suis parti de la documentation WIFI sur le site Ubuntu, je suis allé au chapitre : "Connexion lente à cause d'un Bit Rate mal configuré".
J'ai fait iwconfig pour vérifier la situation de ma connexion qui est à 1 Mb/s, puis sur le terminal  j'ai recopié la commande proposée pour la faire établir à 54 Mb/s: ça  a marché mais ça ne dure que le temps d'une session, il faut recommencer à chaque ouverture de session.

Il y a donc une autre procédure proposée pour l'établir à 54 Mb/s en permanence qui est présentée dans le même chapitre:

"pour que ca reste permanent : ajoutez dans /etc/rc.local (avant la ligne exit 0) :

ifconfig wlan0 up
iwconfig wlan0 rate 54M

Voilà où je suis bloqué : je ne trouve pas le fichier /etc/rc.local dans lequel  écrire ces deux lignes de commande et la ligne exit 0.

Merci d'avance

François


AntiX 16.1 - tout seul sur le disque dur  - Laptop Toshiba Satellite A 100 - 310 2006
Ubuntu 18.04 LTS, tout seul sur le disque dur - HP Compaq 6005 - 155 G0 32 bits Intel core 2CPU 1.66 Ghz
Ipad MINI -IOS12

Hors ligne

#4 Le 06/08/2010, à 17:04

Nexus6

Re : [Résolu] Bit rate wifi à 54 M, mais pour une session...

Salut! big_smile

La documentation Ubuntu wifi est foireuse (même obsolète sur certaines fiches...) j'ai testé des dizaines d'adaptateur wifi et je n'ai jamais eu besoin de forcer le Rate à 54M, la Rate s'adapte automatiquement avec la qualité du signal (link) entre vous et l'AP!
(ou alors c'est très spécifique à certain adaptateur wifi...)

De plus utilisez la commande watch pour voir fluctuer cette Rate :
# watch -d -n 3 "iwconfig wlan0"

Pour le fichier /etc/rc.local si il n'existe pas (j'ai des doutes), créez-le :

# vi /etc/rc.local
--
#!/bin/sh -e
#
# rc.local
#
# This script is executed at the end of each multiuser runlevel.
# Make sure that the script will "exit 0" on success or any other
# value on error.
#
# In order to enable or disable this script just change the execution
# bits.
#
# By default this script does nothing.

# config wireless
bash /etc/init.d/wireless_up.sh

exit 0
--

Mon bash wireless_up.sh configure mes adaptateurs wifi (j'en ai plusieurs qui tournent en même temps)

iwconfig wlan0 rts 250 frag 2352 txpower 30dBm rate auto retry 10
iwconfig wlan6 rts 250 frag 2352 txpower 30dBm rate auto retry 10
iw reg set US

ifconfig wlan0 down
macchanger -m 00:19:5B:_______ wlan0
ifconfig wlan0 up

[etc...]

/Nexus6

--
!

Dernière modification par Nexus6 (Le 06/08/2010, à 17:11)

Hors ligne

#5 Le 06/08/2010, à 17:21

fabux

Re : [Résolu] Bit rate wifi à 54 M, mais pour une session...

pour voir le contenu du fichier (s'il n'existe pas il te le dira)

cat /etc/rc.local

Hors ligne

#6 Le 06/08/2010, à 18:19

ognio2009

Re : [Résolu] Bit rate wifi à 54 M, mais pour une session...

Merci à tous les deux :

@Nexus6

Cela va sans dire mais c est mieux en le disant : cette commande s 'exécute sur le terminal évidemment ?

j ai donc copié collé sur le terminal : # watch -d -n 3 "iwconfig wlan0" et cela ne donne rien, juste la répétition
de mon adresse.
Je n ai pas dit  que le fichier "etc/local " n existait pas, simplement je ne sais pas dans quel menu de l'ordi il se trouve !

( je n ai qu' un an de Linux après 15 ans de Windows, donc chaque mot ou formule nouvelle est très sensible.....! )

@fabux

c est sur le terminal aussi sans doute pour le fichier "etc/rc.local" ?


AntiX 16.1 - tout seul sur le disque dur  - Laptop Toshiba Satellite A 100 - 310 2006
Ubuntu 18.04 LTS, tout seul sur le disque dur - HP Compaq 6005 - 155 G0 32 bits Intel core 2CPU 1.66 Ghz
Ipad MINI -IOS12

Hors ligne

#7 Le 06/08/2010, à 19:56

Nexus6

Re : [Résolu] Bit rate wifi à 54 M, mais pour une session...

Salut! smile

Pas de problème!

Quand je vous mets un '#' et une commande à la suite, c'est pour vous indiquer qu'il s'agit d'une commande à lancer dans une console.

(sans le '#' devant)

watch -d -n 3 "iwconfig wlan0"

Au besoin on installe 'watch'

apt-get install watch

(perso je préfère aptitude pour gérer les packages debian... # apt-get install aptitude)

Quand vous voyez un  '#' dans un fichier, c'est un commentaire, la ligne ne sera pas interprété par bash dans '/etc/rc.local' par exemple (tous les caractères '/' sont important dans un chemin Unix).

/Nexus6

--
# watch -d -n 3 "iw dev wlan0 station dump; iwconfig wlan0;iw dev wlan6 station dump; iwconfig wlan6;iw dev mon0 station dump; iwconfig mon0;cat /proc/net/wireless"

watchg.png

Dernière modification par Nexus6 (Le 06/08/2010, à 20:51)

Hors ligne

#8 Le 06/08/2010, à 23:36

toutafai

Re : [Résolu] Bit rate wifi à 54 M, mais pour une session...

HS : j'adore la belle couleur de police verte de la console, ca me rappelle le bon vieux pet CBM2001

pour les curieux (ca vaut le détour) : http://en.wikipedia.org/wiki/Commodore_PET


Tombé dans l'informatique étant petit, j'en ai fait mon métier. Utilisateur d'Ubuntu depuis novembre 2006, actuellement sous 20.04 x64 (Que d'évolution
depuis Dapper Drake ! Ça rajeunit pas ^^^).

Hors ligne

#9 Le 09/08/2010, à 16:08

ognio2009

Re : [Résolu] Bit rate wifi à 54 M, mais pour une session...

@Nexus6
Ok - j ai bien affiché le compteur de watch : j'ai 32 % de link quality .

Pour trouver et gérer   /etc/rc.local, quel est le chemin  à suivre ?

François


AntiX 16.1 - tout seul sur le disque dur  - Laptop Toshiba Satellite A 100 - 310 2006
Ubuntu 18.04 LTS, tout seul sur le disque dur - HP Compaq 6005 - 155 G0 32 bits Intel core 2CPU 1.66 Ghz
Ipad MINI -IOS12

Hors ligne

#10 Le 10/08/2010, à 09:09

fabux

Re : [Résolu] Bit rate wifi à 54 M, mais pour une session...

/etc/local : c'est le fichier "local" qui se trouve dans le dossier "etc" lui même dans le dossier "/" (appeler aussi "Système de fichiers" dans les raccourcis nautilus). Tu peux y accéder (sans modification possible) via le gestionnaire de fichier.
Tu peux également le voir et nous le donner si tu fais

cat /etc/rc.local

Hors ligne

#11 Le 12/08/2010, à 10:08

ognio2009

Re : [Résolu] Bit rate wifi à 54 M, mais pour une session...

@fabux : ok j ai trouvé /etc/rc.local dans " / navigateur de fichiers ". Le fichier rc.local se présente comme un document de traitement de texte et est en lecture seule lorsqu'on l'affiche (gedit).

Copie ci dessous : on me propose soit de le lancer dans un terminal ou l'afficher ou le lancer .......

#!/bin/sh -e
#
# rc.local
#
# This script is executed at the end of each multiuser runlevel.
# Make sure that the script will "exit 0" on success or any other
# value on error.
#
# In order to enable or disable this script just change the execution
# bits.
#
# By default this script does nothing.

exit 0

François


AntiX 16.1 - tout seul sur le disque dur  - Laptop Toshiba Satellite A 100 - 310 2006
Ubuntu 18.04 LTS, tout seul sur le disque dur - HP Compaq 6005 - 155 G0 32 bits Intel core 2CPU 1.66 Ghz
Ipad MINI -IOS12

Hors ligne

#12 Le 12/08/2010, à 10:23

fabux

Re : [Résolu] Bit rate wifi à 54 M, mais pour une session...

En attendant Nexus6 qui proposera peut-être mieux, ouvre ton fichier avec les droits root

gksudo gedit /etc/rc.local

et ajoutes tes lignes:

ifconfig wlan0 up
iwconfig wlan0 rate 54M

entre la ligne "#By default..." et le exit 0. enregistres, quitte gedit et reboot .

Hors ligne

#13 Le 12/08/2010, à 10:56

agil

Re : [Résolu] Bit rate wifi à 54 M, mais pour une session...

fabux a écrit :

ouvre ton fichier avec les droits root

=
dans un terminal tu colle la commande suivante:

gksudo gedit /etc/rc.local

ca ouvre le fichier voulu dans Gedit (un editeur de fichier) avec les droits administrateur .

Fabux a écrit :

et ajoutes tes lignes:

ifconfig wlan0 up
iwconfig wlan0 rate 54M

entre la ligne "#By default..." et le exit 0. enregistres, quitte gedit et reboot .

copier coller est ton ami


Intel Core i5 650, Asus FORMULA ATI HD 5750 1Go, 4 Go DDR3, Ubuntu 10.04 Lucid Lynx 64 bits
Packard Bell EasyNote Intel Core i5 4096 Mo, ATI Mobility™ Radeon™ HD5650 Oneiric Ocelot 64 bits

Hors ligne

#14 Le 12/08/2010, à 11:26

fabux

Re : [Résolu] Bit rate wifi à 54 M, mais pour une session...

bah c'est ce que j'ai dis lol
Mais tu as raison de préciser et j'ajoute:
gksudo = exécuter une application graphique avec les droit root (cf doc sudo)

gedit = éditeur de texte dans l'environnement gnome. kate est le pendant pour KDE, nano étant pour le terminal.

/etc/rc.local= chemin du fichier à ouvrir. /etc est le dossier des fichiers de configurations (cf doc arborescence) . rc.local étant quant à lui le fichier qui contient les scripts d'exécution post démarrage.

/etc/rc.local étant un fichier qui touche au système et non inclus dans le /home, il faut les droits root pour pouvoir le modifier, d'où le gksudo (ou sudo si on utilise nano par exemple)

Hors ligne

#15 Le 12/08/2010, à 11:55

agil

Re : [Résolu] Bit rate wifi à 54 M, mais pour une session...

hello Fabux
c'est son

Pour trouver et gérer   /etc/rc.local, quel est le chemin  à suivre?

qui m'a poussé a "vulgariser" tes consignes (j'ai failli blaguer sur c:\ , "bloc-notes" [mais j'ai pas pu eviter "administrateur"^^])
ton lien est parfait (tout ton post d'ailleurs):

(cf doc arborescence)

je l'avais pas trouvé

Dernière modification par agil (Le 12/08/2010, à 11:57)


Intel Core i5 650, Asus FORMULA ATI HD 5750 1Go, 4 Go DDR3, Ubuntu 10.04 Lucid Lynx 64 bits
Packard Bell EasyNote Intel Core i5 4096 Mo, ATI Mobility™ Radeon™ HD5650 Oneiric Ocelot 64 bits

Hors ligne

#16 Le 12/08/2010, à 12:13

fabux

Re : [Résolu] Bit rate wifi à 54 M, mais pour une session...

J'avais bien compris ta juste intervention, d'où la mienne qui apporte des pointages vers la doc toujours plus clair wink

Hors ligne

#17 Le 12/08/2010, à 12:25

ognio2009

Re : [Résolu] Bit rate wifi à 54 M, mais pour une session...

@fabux
@agil
@Nexus6

Ok merci à tous : l'opération bit rate 54M fonctionne en permanence grâce à votre apport et votre suivi.

Je crois avoir bien compris tous les enchainements pour y parvenir ( l'an dernier, j'avais réussi à installer la connexion wifi sur Ubuntu ) et j'ai mis tout ça en notes.
ça progresse !

Bonne journée à tous,

François


AntiX 16.1 - tout seul sur le disque dur  - Laptop Toshiba Satellite A 100 - 310 2006
Ubuntu 18.04 LTS, tout seul sur le disque dur - HP Compaq 6005 - 155 G0 32 bits Intel core 2CPU 1.66 Ghz
Ipad MINI -IOS12

Hors ligne