Contenu | Rechercher | Menus

Annonce

DVD, clés USB et t-shirts Ubuntu-fr disponibles sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 27/12/2010, à 13:07

pdm

[résolu en partie] Console Mobigo de Vtech : j'y suis presque ou pas ?

Alors voilà, le père Noël, pas vraiment cool, a offert à mon fiston une console de jeux Mobigo de Vtech. Jusque là pas de souci, sauf quand au bout de quelques heures de jeu acharné, une douce voix dit à mon fils:

" tu as gagné une récompense ! demande à un adulte de brancher ta console sur internet pour récupérer ton cadeau".

Et là, voilà le pdm se plongeant dans la doc pour voir que, bien sûr, il faut télécharger un programme, que, bien sûr, il y a une version Win et une version OSX et que bien sûr, si tu as autre chose tu te mets la console... et attention en la mettant, c'est pas de la petite console et y'a de l'anti-dérapant (d'ailleurs je dérape).

Je télécharge le programme et, ne me sentant pas d'humeur aventurière je vais sur mon Windows XP pro virtualisé (VirtualBox version proprio avec prise en charge de l'USB), j'installe, je branche la console, je la monte en USB et là... tout se bloque. Plus rien ne bouge sous Windows. Je débranche, tout revient. Je rebranche, tout se bloque.

Bon, je mets le stetson, je prends mon fouet et part à l'aventure : installation sous Wine ! ça marche. Il faut Flash 10 ? installation sous Wine : ça marche encore.

Je branche la console et... ben rien évidemment.

J'ai l'impression d'être pas loin de la vérité, voici les messages du kernel au moment du branchement, si certains d'entre vous parlent le kernel couramment, ça m'aiderait pas mal, même pour me dire qu'il n'y a rien à faire :

Dec 26 21:20:41 Bureau kernel: [ 2744.723780] usb 1-1.5: new full speed USB device using ehci_hcd and address 4
Dec 26 21:20:41 Bureau kernel: [ 2744.851833] scsi10 : usb-storage 1-1.5:1.0
Dec 26 21:20:42 Bureau kernel: [ 2745.868323] scsi 10:0:0:0: Direct-Access     VTECH    USB-MSDC DISK A  1.00 PQ: 0 ANSI: 0
Dec 26 21:20:42 Bureau kernel: [ 2745.869294] sd 10:0:0:0: Attached scsi generic sg6 type 0
Dec 26 21:20:42 Bureau kernel: [ 2745.871462] sd 10:0:0:0: [sdf] 16561 512-byte logical blocks: (8.47 MB/8.08 MiB)
Dec 26 21:20:42 Bureau kernel: [ 2745.872196] sd 10:0:0:0: [sdf] Write Protect is off
Dec 26 21:20:42 Bureau kernel: [ 2745.875928]  sdf: sdf1
Dec 26 21:20:42 Bureau kernel: [ 2745.968508] sdf: p1 size 16560 extends beyond EOD, enabling native capacity
Dec 26 21:20:42 Bureau kernel: [ 2745.971552]  sdf: sdf1
Dec 26 21:20:42 Bureau kernel: [ 2745.976839] sdf: p1 size 16560 extends beyond EOD, truncated
Dec 26 21:20:42 Bureau kernel: [ 2745.979774] sd 10:0:0:0: [sdf] Attached SCSI removable disk
Dec 26 21:21:07 Bureau kernel: [ 2770.610067] NVRM: os_raise_smp_barrier(), invalid context!
Dec 26 21:21:07 Bureau kernel: [ 2770.626369] NVRM: os_raise_smp_barrier(), invalid context!
Dec 26 21:21:14 Bureau kernel: [ 2777.061844] usb 1-1.5: reset full speed USB device using ehci_hcd and address 4
Dec 26 21:21:21 Bureau kernel: [ 2784.092822] NVRM: os_raise_smp_barrier(), invalid context!
Dec 26 21:21:21 Bureau kernel: [ 2784.110170] NVRM: os_raise_smp_barrier(), invalid context!
Dec 26 21:21:41 Bureau kernel: [ 2804.567178] NVRM: os_raise_smp_barrier(), invalid context!
Dec 26 21:21:41 Bureau kernel: [ 2804.583478] NVRM: os_raise_smp_barrier(), invalid context!
Dec 26 21:21:45 Bureau kernel: [ 2808.035744] usb 1-1.5: reset full speed USB device using ehci_hcd and address 4

Et ça continue comme ça pendant des lustres.

Du coup j'ai du réactiver une partition Windows au fin fond d'un portable pour que mon fils ait sa récompense et n'aille pas appeler le numéro vert "enfants victimes d'un père manchot".

Mais bon sang, devoir garder un windows rien que pour ça, ça me gonfle terriblement, vous savez !

Merci donc de votre aide et bonnes fêtes de fin d'année,

pdm

Dernière modification par pdm (Le 31/12/2010, à 10:02)

Hors ligne

#2 Le 30/12/2010, à 02:01

thiebaud2001

Re : [résolu en partie] Console Mobigo de Vtech : j'y suis presque ou pas ?

Bonjour,

Mon fils ayant eu le même cadeau, je me suis lancé comme vous dans l'aventure du Windows virtuel pour connecter la mobigo.
Ma version de virtualbox était la 3.2 et j'ai eu comme vous un problème de freeze de Windows au moment du montage de la mobigo en usb.
Pour résoudre le problème, il faut installer la version 4.0 de virtualbox et installer les extensions associés.
Pour moi cela à fonctionner, Windows ne freeze plus et le logiciel a reconnu la Mobigo

Cdlt


Google Nexus 4 - Ubuntu touch daily build (--channel=devel-proposed)
PC personnel - Ubuntu 14.04

Hors ligne

#3 Le 30/12/2010, à 09:47

pdm

Re : [résolu en partie] Console Mobigo de Vtech : j'y suis presque ou pas ?

Salut et merci pour cette info, je vais essayer ça dès ce soir.

Par contre pour installer la version 4.0 tu as désinstallé la précédente avant ou juste fait une install par dessus ?

Merci encore wink

Hors ligne

#4 Le 30/12/2010, à 20:22

pdm

Re : [résolu en partie] Console Mobigo de Vtech : j'y suis presque ou pas ?

Eh bien non ça ne marche pas. J'ai bien suivi la doc pour activer l'USB et ça ne bloque plus mais le logiciel Vtech tourne en permanence et ne se débloque que si j'éteins la console.

Il faut encore que je creuse. j'ai remarqué que mon fichier

/etc/udev/rules.d/10-vboxdrv.rules

a plutôt l'apparence que la doc lui donne sous 10.04 et non sous 10.10. Tu peux vérifier de ton côté quel contenu a ce fichier ?

Merci

Hors ligne

#5 Le 31/12/2010, à 10:01

pdm

Re : [résolu en partie] Console Mobigo de Vtech : j'y suis presque ou pas ?

Bon, ça marche neutral:|:|

Je suis allé sur mon windows natif pour remettre un jeu que mon fils avait viré en arrachant la cartouche (puisque je lui avais dit qu'il ne fallait surtout pas le faire sinon son petit jeu serait effacé... il a bien fallu qu'il vérifie mad). ça a mouliné pas mal avant de fonctionner.

Du coup, par acquis de conscience je suis retourné sur mon XP virtualisé et après un assez long moulinage, ça a fonctionné !

Merci donc à toi pour le conseil de mise à jour.

Je conseille à mon tour à quiconque passera ici en recherche de solution de bien suivre la partie de la doc concernant l'USB, notamment la création du filtre (à faire en branchant la console allumée pour qu'elle soit reconnue) ainsi que la modification du fichier

/etc/udev/rules.d/10-vboxdrv.rules

Après, un peu de patience et ça devrait fonctionner.

ça ne résoud pas mon souhait initial de le faire fonctionner sous Wine mais c'est déjà ça. A voir comme ça, il semblerait que sous Windows la console soit montée comme un lecteur de disque (qu'un plugin empêche d'apparaître dans le poste de travail) et le logiciel, simple façade en flash (beurk) fait la synchronisation du contenu de la mémoire de la console avec notre disque dur du PC, plus le stockage des scores et autres babioles du genre.

Bref, il y aurait largement moyen de faire une interface web multiplateforme pour des opés si simple. Mais Vtech a tout fait pour fermer le truc, c'est dommage.

Hors ligne

#6 Le 11/01/2011, à 19:30

zeroman

Re : [résolu en partie] Console Mobigo de Vtech : j'y suis presque ou pas ?

Bonjour

Le père Noël a aussi apporté une console mobigo chez moi. Et impossible de faire fonctionner leur programme avec wine, ni sous Mandriva, ni sous Ubuntu.
Obligé d'aller me connecter chez des voisins. En plus en cas de changement de piles les jeux additionnels sont effacés...
Alors si quelqu'un trouve la solution je suis preneur !

Codialement

laurent


Ma liste de lecture sur grooveshark.com est : bobox

Hors ligne

#7 Le 17/01/2011, à 19:08

zeroman

Re : [résolu en partie] Console Mobigo de Vtech : j'y suis presque ou pas ?

Bonjour

J'ai contacté Vtech et voici la réponse :
"Nous sommes désolés, actuellement Explor@Park n'est pas compatible avec
Linux.
Il se peut qu'à terme une solution soit trouvée pour remédier à ce
problème."

Peut être qu'un message de toute les personnes ayant le problème pourrait les faire accélérer ?

Email : vtech_conseil@vtech.com

Cordialement


Ma liste de lecture sur grooveshark.com est : bobox

Hors ligne

#8 Le 29/12/2011, à 14:58

loubrix

Re : [résolu en partie] Console Mobigo de Vtech : j'y suis presque ou pas ?

Je me joins à ce post, car ma fille à également eu une Mobigo à Noël, et le pire, c'est que le c... qui l'a achetée, c'est moi (mea culpa, mais à ma décharge, la boite ne mentionnait pas la nécessité de Windows ou Mac).
j'ai aussi envoyé un mail chez Vtech, en précisant bien le vide légal dans lequel ils se mettent en ne précisant pas de système d'exploitation requis sur la boite, et en insistant sur le fait que je ne me voie pas reprendre la console à ma fille (au cas où ils me proposeraient un remboursement): pas de réponse pour le moment...
d'un point de vue technique, j'ai quelques pistes mais j'en dirai plus plus tard, quand j'aurai un peu avancé...


Asus X50VL - Ubuntu 12.04 AMD64
HP G62 - Ubuntu 12.10 AMD64
Fujitsu-Siemens Amilo EL - Lubuntu 12.04 i686
Manjaro, une rolling pour débutants

Hors ligne

#9 Le 31/12/2011, à 12:35

ArnaudK

Re : [résolu en partie] Console Mobigo de Vtech : j'y suis presque ou pas ?

Je viens d'envoyer un email également. Peut être que l'on pourrait contacter l'équipe de Wine pour remédier à cela ?

Hors ligne

#10 Le 31/12/2011, à 15:15

Grünt

Re : [résolu en partie] Console Mobigo de Vtech : j'y suis presque ou pas ?

Heu.. vous ne prévenez jamais vos proches du fait que faut faire gaffe avant d'offrir des objets hi-techs, parce que Linux toussa?

neutral


Red flashing lights. I bet they mean something.

Hors ligne

#11 Le 31/12/2011, à 15:27

loubrix

Re : [résolu en partie] Console Mobigo de Vtech : j'y suis presque ou pas ?

ǤƦƯƝƬ');DROP TABLE users; a écrit :

Heu.. vous ne prévenez jamais vos proches du fait que faut faire gaffe avant d'offrir des objets hi-techs, parce que Linux toussa?

neutral

c'était pas marqué sur la boîte qu'il fallait Windows ou Mac, donc même en se méfiant on se fait avoir...

pour en revenir à la bebête, quand on la branche, on a une partition sdc1, mais il semble que le système de fichiers pose problème; extrait des logs:

Dec 31 14:03:33 phobos kernel: [13558.065457] scsi5 : usb-storage 2-2:1.0
Dec 31 14:03:34 phobos kernel: [13559.072198] scsi 5:0:0:0: Direct-Access     VTECH    USB-MSDC DISK A  1.00 PQ: 0 ANSI: 0
Dec 31 14:03:34 phobos kernel: [13559.072345] scsi: killing requests for dead queue
Dec 31 14:03:34 phobos kernel: [13559.076645] scsi: killing requests for dead queue
Dec 31 14:03:34 phobos kernel: [13559.076873] scsi: killing requests for dead queue
Dec 31 14:03:34 phobos kernel: [13559.080661] scsi: killing requests for dead queue
Dec 31 14:03:34 phobos kernel: [13559.080877] scsi: killing requests for dead queue
Dec 31 14:03:34 phobos kernel: [13559.084626] scsi: killing requests for dead queue
Dec 31 14:03:34 phobos kernel: [13559.084838] scsi: killing requests for dead queue
Dec 31 14:03:34 phobos kernel: [13559.100339] scsi: killing requests for dead queue
Dec 31 14:03:34 phobos kernel: [13559.102306] sd 5:0:0:0: Attached scsi generic sg3 type 0
Dec 31 14:03:34 phobos kernel: [13559.173196] sd 5:0:0:0: [sdc] 16561 512-byte logical blocks: (8.47 MB/8.08 MiB)
Dec 31 14:03:34 phobos kernel: [13559.180179] sd 5:0:0:0: [sdc] Write Protect is off
Dec 31 14:03:34 phobos kernel: [13559.180189] sd 5:0:0:0: [sdc] Mode Sense: 03 00 00 00
Dec 31 14:03:34 phobos kernel: [13559.187185] sd 5:0:0:0: [sdc] No Caching mode page present
Dec 31 14:03:34 phobos kernel: [13559.187195] sd 5:0:0:0: [sdc] Assuming drive cache: write through
Dec 31 14:03:34 phobos kernel: [13559.290166] sd 5:0:0:0: [sdc] No Caching mode page present
Dec 31 14:03:34 phobos kernel: [13559.290177] sd 5:0:0:0: [sdc] Assuming drive cache: write through
Dec 31 14:03:34 phobos kernel: [13559.380190]  sdc: sdc1
Dec 31 14:03:34 phobos kernel: [13559.380200] sdc: p1 size 16560 extends beyond EOD, enabling native capacity
Dec 31 14:03:34 phobos kernel: [13559.405187] sd 5:0:0:0: [sdc] No Caching mode page present
Dec 31 14:03:34 phobos kernel: [13559.405198] sd 5:0:0:0: [sdc] Assuming drive cache: write through
Dec 31 14:03:34 phobos kernel: [13559.490195]  sdc: sdc1
Dec 31 14:03:34 phobos kernel: [13559.490203] sdc: p1 size 16560 extends beyond EOD, truncated
Dec 31 14:03:34 phobos kernel: [13559.581175] sd 5:0:0:0: [sdc] No Caching mode page present
Dec 31 14:03:34 phobos kernel: [13559.581184] sd 5:0:0:0: [sdc] Assuming drive cache: write through
Dec 31 14:03:34 phobos kernel: [13559.581190] sd 5:0:0:0: [sdc] Attached SCSI removable disk
Dec 31 14:04:05 phobos kernel: [13590.032145] usb 2-2: reset full speed USB device number 2 using ohci_hcd
Dec 31 14:04:36 phobos kernel: [13621.008119] usb 2-2: reset full speed USB device number 2 using ohci_hcd
Dec 31 14:05:07 phobos kernel: [13651.984049] usb 2-2: reset full speed USB device number 2 using ohci_hcd
Dec 31 14:05:38 phobos kernel: [13683.088047] usb 2-2: reset full speed USB device number 2 using ohci_hcd
Dec 31 14:06:09 phobos kernel: [13714.064044] usb 2-2: reset full speed USB device number 2 using ohci_hcd
Dec 31 14:06:40 phobos kernel: [13745.040084] usb 2-2: reset full speed USB device number 2 using ohci_hcd
Dec 31 14:06:40 phobos kernel: [13745.332183] sd 5:0:0:0: [sdc] Unhandled error code
Dec 31 14:06:40 phobos kernel: [13745.332191] sd 5:0:0:0: [sdc]  Result: hostbyte=DID_OK driverbyte=DRIVER_OK
Dec 31 14:06:40 phobos kernel: [13745.332197] sd 5:0:0:0: [sdc] CDB: Read(10): 28 00 00 00 40 b0 00 00 01 00
Dec 31 14:06:40 phobos kernel: [13745.332211] end_request: I/O error, dev sdc, sector 16560
Dec 31 14:06:40 phobos kernel: [13745.332219] quiet_error: 21 callbacks suppressed
Dec 31 14:06:40 phobos kernel: [13745.332223] Buffer I/O error on device sdc, logical block 16560
Dec 31 14:07:11 phobos kernel: [13776.016049] usb 2-2: reset full speed USB device number 2 using ohci_hcd
Dec 31 14:07:42 phobos kernel: [13806.992116] usb 2-2: reset full speed USB device number 2 using ohci_hcd
Dec 31 14:08:13 phobos kernel: [13838.096046] usb 2-2: reset full speed USB device number 2 using ohci_hcd
Dec 31 14:08:44 phobos kernel: [13869.072045] usb 2-2: reset full speed USB device number 2 using ohci_hcd
Dec 31 14:09:15 phobos kernel: [13900.048087] usb 2-2: reset full speed USB device number 2 using ohci_hcd
Dec 31 14:09:35 phobos kernel: [13920.392103] INFO: task udisks-daemon:1837 blocked for more than 120 seconds.
Dec 31 14:09:35 phobos kernel: [13920.392109] "echo 0 > /proc/sys/kernel/hung_task_timeout_secs" disables this message.
Dec 31 14:09:35 phobos kernel: [13920.392113] udisks-daemon   D 0000000000000000     0  1837   1836 0x00000000
Dec 31 14:09:35 phobos kernel: [13920.392121]  ffff88006c3d5928 0000000000000082 ffff88006c3d5918 ffffffff8104f536
Dec 31 14:09:35 phobos kernel: [13920.392128]  ffff88006c3d5fd8 ffff88006c3d5fd8 ffff88006c3d5fd8 0000000000012a40
Dec 31 14:09:35 phobos kernel: [13920.392134]  ffff880013114560 ffff8800696c8000 ffff880013114560 7fffffffffffffff
Dec 31 14:09:35 phobos kernel: [13920.392140] Call Trace:
Dec 31 14:09:35 phobos kernel: [13920.392155]  [<ffffffff8104f536>] ? check_preempt_wakeup+0x196/0x260
Dec 31 14:09:35 phobos kernel: [13920.392163]  [<ffffffff815e940f>] schedule+0x3f/0x60
Dec 31 14:09:35 phobos kernel: [13920.392168]  [<ffffffff815e9a55>] schedule_timeout+0x2a5/0x320
Dec 31 14:09:35 phobos kernel: [13920.392174]  [<ffffffff8104a3b6>] ? ttwu_do_activate.constprop.174+0x66/0x70
Dec 31 14:09:35 phobos kernel: [13920.392181]  [<ffffffff810329b9>] ? default_spin_lock_flags+0x9/0x10
Dec 31 14:09:35 phobos kernel: [13920.392186]  [<ffffffff815e924f>] wait_for_common+0xdf/0x180
Dec 31 14:09:35 phobos kernel: [13920.392192]  [<ffffffff81057340>] ? try_to_wake_up+0x200/0x200
Dec 31 14:09:35 phobos kernel: [13920.392197]  [<ffffffff815e93cd>] wait_for_completion+0x1d/0x20
Dec 31 14:09:35 phobos kernel: [13920.392202]  [<ffffffff8107d14e>] flush_work+0x2e/0x40
Dec 31 14:09:35 phobos kernel: [13920.392208]  [<ffffffff81079450>] ? do_work_for_cpu+0x30/0x30
Dec 31 14:09:35 phobos kernel: [13920.392213]  [<ffffffff8107d1ab>] flush_delayed_work+0x4b/0x60
Dec 31 14:09:35 phobos kernel: [13920.392219]  [<ffffffff812da264>] disk_clear_events+0x84/0x130
Dec 31 14:09:35 phobos kernel: [13920.392225]  [<ffffffff8119c997>] check_disk_change+0x37/0x80
Dec 31 14:09:35 phobos kernel: [13920.392231]  [<ffffffff81403a8d>] sd_open+0xad/0x1e0
Dec 31 14:09:35 phobos kernel: [13920.392236]  [<ffffffff8119e0fb>] __blkdev_get+0x2eb/0x420
Dec 31 14:09:35 phobos kernel: [13920.392242]  [<ffffffff8117ab90>] ? __pollwait+0xf0/0xf0
Dec 31 14:09:35 phobos kernel: [13920.392246]  [<ffffffff8119e28e>] blkdev_get+0x5e/0x1e0
Dec 31 14:09:35 phobos kernel: [13920.392250]  [<ffffffff8119e470>] blkdev_open+0x60/0x90
Dec 31 14:09:35 phobos kernel: [13920.392257]  [<ffffffff81165cb4>] __dentry_open+0x144/0x320
Dec 31 14:09:35 phobos kernel: [13920.392261]  [<ffffffff8119e410>] ? blkdev_get+0x1e0/0x1e0
Dec 31 14:09:35 phobos kernel: [13920.392267]  [<ffffffff811673fd>] nameidata_to_filp+0xad/0xb0
Dec 31 14:09:35 phobos kernel: [13920.392273]  [<ffffffff81175540>] do_last+0x3a0/0x730
Dec 31 14:09:35 phobos kernel: [13920.392277]  [<ffffffff8117744a>] path_openat+0xca/0x3f0
Dec 31 14:09:35 phobos kernel: [13920.392282]  [<ffffffff81177872>] do_filp_open+0x42/0xa0
Dec 31 14:09:35 phobos kernel: [13920.392288]  [<ffffffff812f57b1>] ? strncpy_from_user+0x31/0x40
Dec 31 14:09:35 phobos kernel: [13920.392293]  [<ffffffff81172bfa>] ? do_getname+0x10a/0x180
Dec 31 14:09:35 phobos kernel: [13920.392300]  [<ffffffff815eb2ee>] ? _raw_spin_lock+0xe/0x20
Dec 31 14:09:35 phobos kernel: [13920.392305]  [<ffffffff81184c27>] ? alloc_fd+0xf7/0x150
Dec 31 14:09:35 phobos kernel: [13920.392310]  [<ffffffff811674ed>] do_sys_open+0xed/0x220
Dec 31 14:09:35 phobos kernel: [13920.392315]  [<ffffffff81167640>] sys_open+0x20/0x30
Dec 31 14:09:35 phobos kernel: [13920.392322]  [<ffffffff815f36c2>] system_call_fastpath+0x16/0x1b
Dec 31 14:09:46 phobos kernel: [13931.024082] usb 2-2: reset full speed USB device number 2 using ohci_hcd
Dec 31 14:09:46 phobos kernel: [13931.283246] sd 5:0:0:0: [sdc] Unhandled error code
Dec 31 14:09:46 phobos kernel: [13931.283256] sd 5:0:0:0: [sdc]  Result: hostbyte=DID_OK driverbyte=DRIVER_OK
Dec 31 14:09:46 phobos kernel: [13931.283268] sd 5:0:0:0: [sdc] CDB: Read(10): 28 00 00 00 40 b0 00 00 01 00
Dec 31 14:09:46 phobos kernel: [13931.283292] end_request: I/O error, dev sdc, sector 16560
Dec 31 14:09:46 phobos kernel: [13931.283306] Buffer I/O error on device sdc1, logical block 16552
Dec 31 14:14:20 phobos kernel: [14205.008166] usb 2-2: reset full speed USB device number 2 using ohci_hcd
Dec 31 14:14:51 phobos kernel: [14236.056071] usb 2-2: reset full speed USB device number 2 using ohci_hcd
Dec 31 14:15:22 phobos kernel: [14267.024084] usb 2-2: reset full speed USB device number 2 using ohci_hcd
Dec 31 14:15:53 phobos kernel: [14298.004078] usb 2-2: reset full speed USB device number 2 using ohci_hcd
Dec 31 14:16:24 phobos kernel: [14329.040075] usb 2-2: reset full speed USB device number 2 using ohci_hcd
Dec 31 14:16:55 phobos kernel: [14360.080075] usb 2-2: reset full speed USB device number 2 using ohci_hcd
Dec 31 14:16:55 phobos kernel: [14360.339175] sd 5:0:0:0: [sdc] Unhandled error code
Dec 31 14:16:55 phobos kernel: [14360.339185] sd 5:0:0:0: [sdc]  Result: hostbyte=DID_OK driverbyte=DRIVER_OK
Dec 31 14:16:55 phobos kernel: [14360.339193] sd 5:0:0:0: [sdc] CDB: Read(10): 28 00 00 00 40 b0 00 00 01 00
Dec 31 14:16:55 phobos kernel: [14360.339209] end_request: I/O error, dev sdc, sector 16560
Dec 31 14:16:55 phobos kernel: [14360.339223] Buffer I/O error on device sdc1, logical block 16552
Dec 31 14:17:03 phobos kernel: [14368.248725] usb 2-2: USB disconnect, device number 2
Dec 31 14:17:03 phobos kernel: [14368.249406] sd 5:0:0:0: [sdc] Unhandled error code
Dec 31 14:17:03 phobos kernel: [14368.249411] sd 5:0:0:0: [sdc]  Result: hostbyte=DID_NO_CONNECT driverbyte=DRIVER_OK
Dec 31 14:17:03 phobos kernel: [14368.249417] sd 5:0:0:0: [sdc] CDB: Read(10): 28 00 00 00 40 b0 00 00 01 00
Dec 31 14:17:03 phobos kernel: [14368.249432] end_request: I/O error, dev sdc, sector 16560
Dec 31 14:17:03 phobos kernel: [14368.249441] Buffer I/O error on device sdc1, logical block 16552

un "sudo fdisk -l " se bloque, Gparted veut même pas démarrer...
bien sûr mes essais pour la monter avec Udisks ou avec Mount se soldent par des échecs...
je continue mes recherches...

PS: pour les mails, est-ce que ça aurait pas plus de poids si on faisait un mail groupé; quelqu'un aurait des contacts sur d'autres forums (Fedora, Mint, Arch, Debian,...etc), pour trouver d'autres co-signataires ?


Asus X50VL - Ubuntu 12.04 AMD64
HP G62 - Ubuntu 12.10 AMD64
Fujitsu-Siemens Amilo EL - Lubuntu 12.04 i686
Manjaro, une rolling pour débutants

Hors ligne

#12 Le 31/12/2011, à 15:38

ArnaudK

Re : [résolu en partie] Console Mobigo de Vtech : j'y suis presque ou pas ?

J'ai a peu près les mêmes messages d'erreur sous OpenSuSE. Je me demande qui parmi les mainteneur du noyau s'intéresserait à supporter ce genre d'appareil.

Hors ligne

#13 Le 31/12/2011, à 16:08

Grünt

Re : [résolu en partie] Console Mobigo de Vtech : j'y suis presque ou pas ?

Et un

dd if=/dev/sdc of=image_console.raw

Ça donne quoi?
Ça pourra intéresser pas mal de dev d'avoir une copie du disque de la console sans devoir l'acheter eux-mêmes big_smile


Red flashing lights. I bet they mean something.

Hors ligne

#14 Le 01/01/2012, à 12:11

loubrix

Re : [résolu en partie] Console Mobigo de Vtech : j'y suis presque ou pas ?

ça donne ça:

david@phobos:~$ sudo dd if=/dev/sdc of=image_mobigo.raw
[sudo] password for david: 
dd: lecture de «/dev/sdc»: Erreur d'entrée/sortie
16560+0 enregistrements lus
16560+0 enregistrements écrits
8478720 octets (8,5 MB) copiés, 663,995 s, 12,8 kB/s

ce qui me donne un "image_mobigo.raw" de 8,5 Mo, malgré l'erreur d'entrée/sortie...
au passage, on l'a pas encore précisé, mais la marque semble être connue dans les usb-ids (retour de lsusb):

Bus 002 Device 002: ID 0f88:2d3f VTech Holdings, Ltd 

j'en fait quoi de cette image ? je pensais l'ouvrir avec un éditeur hexa pour voir si les entêtes allaient m'en dire plus...

edit: avec hexedit, j'ai trouvé ça:

00001000   EB 3E 90 4D  53 57 49 4E  34 2E 31 00  02 01 08 00  .>.MSWIN4.1.....
00001010   02 00 02 B0  40 F8 40 00  3F 00 FF 00  08 00 00 00  ....@.@.?.......
00001020   00 00 00 00  00 00 29 E9  7B 37 36 4E  4F 20 4E 41  ......).{76NO NA
00001030   4D 45 20 20  20 20 46 41  54 31 36 20  20 20 00 00  ME    FAT16   ..

donc ça serait du fat16, reste à savoir pourquoi on peut pas la monter...

Dernière modification par loubrix (Le 01/01/2012, à 12:35)


Asus X50VL - Ubuntu 12.04 AMD64
HP G62 - Ubuntu 12.10 AMD64
Fujitsu-Siemens Amilo EL - Lubuntu 12.04 i686
Manjaro, une rolling pour débutants

Hors ligne

#15 Le 01/01/2012, à 14:27

Grünt

Re : [résolu en partie] Console Mobigo de Vtech : j'y suis presque ou pas ?

Ça donne quoi en essayant de monter ce fichier?

mkdir /tmp/test
sudo mount image_mobigo.raw /tmp/test -t vfat -o loop
sudo dmesg

Si ça ne te dérange pas j'aimerais bien jeter un oeil à l'image raw wink


Red flashing lights. I bet they mean something.

Hors ligne

#16 Le 01/01/2012, à 15:47

loubrix

Re : [résolu en partie] Console Mobigo de Vtech : j'y suis presque ou pas ?

j'ai déjà essayé avec "sudo mount -o loop -t vfat image_mobigo.raw montage/" mais ça voulait pas (avec -t msdos non plus); je suis pas chez moi là mais ça me répondait en gros que le système de fichier était incorrect.
quand je rentre je te mettrais l'image sur un partage de fichiers (à moins que tu aies un FTP à toi)...
en tout cas merci de me filer un coup de main, et bonne année à toi wink

edit: voilà, je l'ai mis ici:
http://sendbox.fr/pro/f9aghu08jtfe/imag … o.raw.html

Dernière modification par loubrix (Le 02/01/2012, à 11:39)


Asus X50VL - Ubuntu 12.04 AMD64
HP G62 - Ubuntu 12.10 AMD64
Fujitsu-Siemens Amilo EL - Lubuntu 12.04 i686
Manjaro, une rolling pour débutants

Hors ligne

#17 Le 02/01/2012, à 13:01

loubrix

Re : [résolu en partie] Console Mobigo de Vtech : j'y suis presque ou pas ?

j'ai ré-essayé de monter la console comme une partition:

david@phobos:~$ sudo mount -t vfat /dev/sdc1 /home/david/montage/
[sudo] password for david: 
david@phobos:~$

ça a mouliné pendant 3 bonnes minutes, le terminal ne me rendait pas la main, CPU à fond, mais au final, ça s'est monté:

david@phobos:~$ mount
/dev/sda1 on / type ext4 (rw,errors=remount-ro,commit=0)
proc on /proc type proc (rw,noexec,nosuid,nodev)
sysfs on /sys type sysfs (rw,noexec,nosuid,nodev)
fusectl on /sys/fs/fuse/connections type fusectl (rw)
none on /sys/kernel/debug type debugfs (rw)
none on /sys/kernel/security type securityfs (rw)
udev on /dev type devtmpfs (rw,mode=0755)
devpts on /dev/pts type devpts (rw,noexec,nosuid,gid=5,mode=0620)
tmpfs on /run type tmpfs (rw,noexec,nosuid,size=10%,mode=0755)
none on /run/lock type tmpfs (rw,noexec,nosuid,nodev,size=5242880)
none on /run/shm type tmpfs (rw,nosuid,nodev)
/dev/sda2 on /home type ext4 (rw,commit=0)
binfmt_misc on /proc/sys/fs/binfmt_misc type binfmt_misc (rw,noexec,nosuid,nodev)
gvfs-fuse-daemon on /home/david/.gvfs type fuse.gvfs-fuse-daemon (rw,nosuid,nodev,user=david)
/dev/sdc1 on /home/david/montage type vfat (rw)

évidemment, la partition est vide:

david@phobos:~$ df -h
Sys. de fichiers            Taille  Uti. Disp. Uti% Monté sur
/dev/sda1              12G  5,2G  5,4G  49% /
udev                  994M  4,0K  994M   1% /dev
tmpfs                 402M  976K  401M   1% /run
none                  5,0M     0  5,0M   0% /run/lock
none                 1005M  180K 1004M   1% /run/shm
/dev/sda2             217G  157G   49G  77% /home
/dev/sdc1             8,0M  8,0M     0 100% /home/david/montage

il faudrait que je me procure un de leurs jeux, pour essayer de le mettre dessus, ce qui ramène au problème de l'explor@park sans Windows...
autre chose, j'ai trouvé un bug sur launchpad à propos d'un problème d'accès à la Kidizoom de Vtech (c'est un APN pour les gosses), se pourrait-il que le problème soit identique (lenteur du montage toussa...):
https://bugs.launchpad.net/ubuntu/+sour … bug/500398

@Grunt: j'ai peur qu'il y ait eu quelque chose qui s'est mal passé quand j'ai fait l'image raw, sinon, j'aurais pu la monter...

Dernière modification par loubrix (Le 02/01/2012, à 13:04)


Asus X50VL - Ubuntu 12.04 AMD64
HP G62 - Ubuntu 12.10 AMD64
Fujitsu-Siemens Amilo EL - Lubuntu 12.04 i686
Manjaro, une rolling pour débutants

Hors ligne

#18 Le 02/01/2012, à 13:42

Grünt

Re : [résolu en partie] Console Mobigo de Vtech : j'y suis presque ou pas ?

/dev/sdc1             8,0M  8,0M     0 100% /home/david/montage

C'est pas vide ça, c'est plein.


Red flashing lights. I bet they mean something.

Hors ligne

#19 Le 02/01/2012, à 14:28

loubrix

Re : [résolu en partie] Console Mobigo de Vtech : j'y suis presque ou pas ?

exact (je me suis encore fait avoir par le décalage des colonnes tongue ); malgré tout, une fois monté, rien n'apparait avec Nautilus, et un ls ne renvoie rien non-plus.
je pense qu'on est victime d'un certain nombre d'erreur d'interprètation, car df dit que la partition est pleine, alors qu'il est logique de supposer qu'elle est vide, puisque je n'ai encore téléchargé aucun jeu...
je pencherais aussi pour une erreur de taille: la doc dit qu'on peut mettre 3 jeux dedans (ce qui ferait environ 2,5 Mo par jeu), mais quel jeu moderne tiendrait dans moins de 3 Mo ( surtout que la console est tactile, en couleurs, avec une bonne résolution, des dialogues audio et de la musique), ou alors les jeux téléchargeables sont du style Morpion, Tetris...
tu as eu l'image ?


Asus X50VL - Ubuntu 12.04 AMD64
HP G62 - Ubuntu 12.10 AMD64
Fujitsu-Siemens Amilo EL - Lubuntu 12.04 i686
Manjaro, une rolling pour débutants

Hors ligne

#20 Le 02/01/2012, à 16:20

Grünt

Re : [résolu en partie] Console Mobigo de Vtech : j'y suis presque ou pas ?

Ouais, bien reçu le fichier..

Faudra gérer avec l'offset du à la table de partition. Je regarde ça ce soir, mais les choses se présentent bien:

$ file image_mobigo.raw 
image_mobigo.raw: x86 boot sector; partition 1: ID=0x4, starthead 0, startsector 8, 16560 sectors, extended partition table (last)\011, code offset 0x0
$ fdisk -l image_mobigo.raw 

Disk image_mobigo.raw: 8 MB, 8478720 bytes
8 heads, 55 sectors/track, 37 cylinders, total 16560 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x00000000

           Device Boot      Start         End      Blocks   Id  System
image_mobigo.raw1               8       16567        8280    4  FAT16 <32M           

Edit: à tout hasard, tu peux me refaire un disc dump (dd) en ajoutant "conv=noerror"?

Dernière modification par ǤƦƯƝƬ');DROP TABLE users; (Le 02/01/2012, à 16:20)


Red flashing lights. I bet they mean something.

Hors ligne

#21 Le 02/01/2012, à 23:13

loubrix

Re : [résolu en partie] Console Mobigo de Vtech : j'y suis presque ou pas ?

le problème c'est qu'avec "conv=noerror", ça se répète à l'infini, enfin pour le moment ça fait 25 fois et ça tourne depuis 1h30; comme il y a à chaque fois la même erreur d'E/S, ça recommence plus lentement à chaque fois, et le fichier final fait toujours la même taille (à l'octet près); en revanche un diff me dit que les deux images sont différentes.
je le laisse continuer où je l'arrête ?

edit: ça a fini par s'arrêter, au bout de 2 h...
http://sendbox.fr/pro/xls8x5lfaogg/imag … r.raw.html

Dernière modification par loubrix (Le 03/01/2012, à 10:10)


Asus X50VL - Ubuntu 12.04 AMD64
HP G62 - Ubuntu 12.10 AMD64
Fujitsu-Siemens Amilo EL - Lubuntu 12.04 i686
Manjaro, une rolling pour débutants

Hors ligne

#22 Le 08/01/2012, à 15:14

loubrix

Re : [résolu en partie] Console Mobigo de Vtech : j'y suis presque ou pas ?

J'ai fini par installer un Windows XP sur une partition de mon ordi; existe-t'il un moyen de voir ce que fait le soft Explor@park, pour faire un truc sous Ubuntu qui soit compatible (vu qu'il y a beaucoup de Flash, je pensais à une extension pour Firefox)?

au fait, sous Windows, la Mobigo est reconnue comme un simple stockage de masse, donc je me dis que sous Ubuntu une simple règle Udev suffirait...

Dernière modification par loubrix (Le 08/01/2012, à 15:16)


Asus X50VL - Ubuntu 12.04 AMD64
HP G62 - Ubuntu 12.10 AMD64
Fujitsu-Siemens Amilo EL - Lubuntu 12.04 i686
Manjaro, une rolling pour débutants

Hors ligne

#23 Le 08/01/2012, à 15:55

Grünt

Re : [résolu en partie] Console Mobigo de Vtech : j'y suis presque ou pas ?

Désolé, je t'avais oublié. Je DL ton fichier rapidement et je lance des tests.

Pour voir ce que fait le logiciel, l'idéal serait de regarder au niveau du port USB je pense. Il doit bien manipuler un système de fichier quelconque.. wink


Red flashing lights. I bet they mean something.

Hors ligne

#24 Le 08/01/2012, à 16:42

loubrix

Re : [résolu en partie] Console Mobigo de Vtech : j'y suis presque ou pas ?

c'est ce que je comptais faire, et aussi espionner les paquets réseaux pour voir comment ça se passe au niveau des paquets récupéré sur leur serveur...
d'après les fichiers configuration en XML du soft, j'ai les adresses des serveurs, et c'est du http au niveau du protocole; le client semble se connecter exactement comme un navigateur avec un user-agent particulier; je vais essayer avec Arora (parce que le user-agent est simple à changer sur ce navigateur).
dès que j'ai 5 minutes, je jette un oeil dans les logs de Windows, pour voir comment c'est géré niveau USB (en tout cas, le soft n'a installé aucun pilote).
ce serait bien aussi si je pouvais trouvé quelqu'un avec un Mac pour tester l'autre version du logiciel...


Asus X50VL - Ubuntu 12.04 AMD64
HP G62 - Ubuntu 12.10 AMD64
Fujitsu-Siemens Amilo EL - Lubuntu 12.04 i686
Manjaro, une rolling pour débutants

Hors ligne

#25 Le 10/01/2012, à 12:56

Grünt

Re : [résolu en partie] Console Mobigo de Vtech : j'y suis presque ou pas ?

Faut la monter avec l'option "offset=4096" pour zapper le début.

Par contre la console est vide, c'est normal?


Red flashing lights. I bet they mean something.

Hors ligne