Contenu | Rechercher | Menus

Annonce

DVD, clés USB et t-shirts Ubuntu-fr disponibles sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 10/09/2005, à 21:43

random.hero

Accéleration 3d - VIA

Bonjour,

Je viens vers vous car je n'arrive pas à installer la prise en charge 3D sur mon ordinateur. Après recherches en différents endroits, je me permets de poster ceci.

Il s'agit d'un ordinateur portable, et pour ce qui est de la carte graphique, je vous poste le résultat de la commande

lspci -v | less
0000:00:00.0 Host bridge: VIA Technologies, Inc. P/KN266 Host Bridge
        Subsystem: Unknown device 1631:e004
        Flags: bus master, 66MHz, medium devsel, latency 8
        Memory at a0000000 (32-bit, prefetchable) [size=64M]
        Capabilities: [a0] AGP version 2.0
        Capabilities: [c0] Power Management version 2

0000:01:00.0 VGA compatible controller: S3 Inc. VT8375 [ProSavage8 KM266/KL266]
(prog-if 00 [VGA])
        Subsystem: Unknown device 1631:e004
        Flags: bus master, 66MHz, medium devsel, latency 64, IRQ 255
        Memory at e0000000 (32-bit, non-prefetchable) [size=512K]
        Memory at 90000000 (32-bit, prefetchable) [size=128M]
        Expansion ROM at 000c0000 [disabled] [size=64K]
        Capabilities: [dc] Power Management version 2
        Capabilities: [80] AGP version 2.0

J'espère en avoir fourni assez.

Les symptômes sont assez énervants, le simple fait de réduire une fenêtre ou créer un rectangle de sélection me cause des ralentissements conséquents.

Merci d'avance pour vos conseils,

random.hero

Dernière modification par random.hero (Le 12/09/2005, à 20:26)

Hors ligne

#2 Le 12/09/2005, à 10:12

dylhoxic

Re : Accéleration 3d - VIA

Voilà peut être un début de solution, dans ton fichier xorg.conf :

Section "Device"
        Identifier      "S3 Inc. VT8375 [ProSavage8 KM266/KL266]"
        Driver          "savage"
        Option          "UseBIOS"            "False"
EndSection


Kubuntu++

Hors ligne

#3 Le 12/09/2005, à 10:25

emilio_do_brasil

Re : Accéleration 3d - VIA

salut,

encore une victime de ces maudites cartes graphiques VIA, va voir le topic suivant et tout devrai marcher wink

http://forum.ubuntu-fr.org/viewtopic.php?id=8294


mon site: http://butterpig.net63.net (webdesign/ilustration/object/recyclage)

ma boutique: http://butterpig.spreadshirt.net

Hors ligne

#4 Le 12/09/2005, à 20:13

random.hero

Re : Accéleration 3d - VIA

Bonsoir,

Merci de vos réponses wink

Pour ce qui est du topic que tu m'as conseillé, emilio_do_brasil, j'avais au préalable effectué l'opération, mais sans succès.

La modification de xorg.conf semble avoir été bénéfique, mais je ne sais pas si je profite réellement de l'accelération 3D, cependant on dirait que l'affichage est plus instantané...

Si vous avez des suggestions...

Merci pour tout!

Dernière modification par random.hero (Le 12/09/2005, à 20:16)

Hors ligne

#5 Le 12/09/2005, à 20:18

tuxik

Re : Accéleration 3d - VIA

essaye de tapper fgl_glxgears. Si je dis pas de betise tu devrais avoir une belle petite fenetre avec un cube qui tourne dedans si tout marche bien.

Hors ligne

#6 Le 12/09/2005, à 20:20

random.hero

Re : Accéleration 3d - VIA

Visiblement, ce n'est pas ça...

bash: fgl_glxgears: command not found

Merci quand même...

edit : glxgears seul :

arno@ubuntu:~$ glxgears
369 frames in 7.0 seconds = 52.714 FPS
114 frames in 7.0 seconds = 16.286 FPS

C'est bien? ou non...? :s

Dernière modification par random.hero (Le 12/09/2005, à 20:26)

Hors ligne

#7 Le 12/09/2005, à 20:39

dylhoxic

Re : Accéleration 3d - VIA

ca me semble pas terrible du tout lol :

avec mon 800Mhz et geforce 2 j'obtiens ca :

4838 frames in 5.0 seconds = 967.600 FPS
5642 frames in 5.0 seconds = 1128.400 FPS

tu as le dri activé ? et que donne 'glxinfo' ? on peut voir ton 'xorg.conf' ?


Kubuntu++

Hors ligne

#8 Le 12/09/2005, à 20:49

random.hero

Re : Accéleration 3d - VIA

ca me semble pas terrible du tout lol

Ho!


Voilà le résultat de glxinfo :

name of display: :0.0
display: :0  screen: 0
direct rendering: No
server glx vendor string: SGI
server glx version string: 1.2
server glx extensions:
    GLX_ARB_multisample, GLX_EXT_visual_info, GLX_EXT_visual_rating,
    GLX_EXT_import_context, GLX_OML_swap_method, GLX_SGI_make_current_read,
    GLX_SGIS_multisample, GLX_SGIX_fbconfig
client glx vendor string: SGI
client glx version string: 1.4
client glx extensions:
    GLX_ARB_get_proc_address, GLX_ARB_multisample, GLX_EXT_import_context,
    GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_MESA_allocate_memory,
    GLX_MESA_swap_control, GLX_MESA_swap_frame_usage, GLX_OML_swap_method,
    GLX_OML_sync_control, GLX_SGI_make_current_read, GLX_SGI_swap_control,
    GLX_SGI_video_sync, GLX_SGIS_multisample, GLX_SGIX_fbconfig,
    GLX_SGIX_pbuffer, GLX_SGIX_visual_select_group
GLX extensions:
    GLX_ARB_get_proc_address, GLX_ARB_multisample, GLX_EXT_import_context,
    GLX_EXT_visual_info, GLX_EXT_visual_rating, GLX_OML_swap_method,
    GLX_SGI_make_current_read, GLX_SGIS_multisample, GLX_SGIX_fbconfig,
    GLX_SGIX_visual_select_group
OpenGL vendor string: Mesa project: www.mesa3d.org
OpenGL renderer string: Mesa GLX Indirect
OpenGL version string: 1.2 (1.5 Mesa 6.2.1)
OpenGL extensions:
    GL_ARB_depth_texture, GL_ARB_imaging, GL_ARB_multitexture,
    GL_ARB_point_parameters, GL_ARB_point_sprite, GL_ARB_shadow,
    GL_ARB_shadow_ambient, GL_ARB_texture_border_clamp,
    GL_ARB_texture_cube_map, GL_ARB_texture_env_add,
    GL_ARB_texture_env_combine, GL_ARB_texture_env_crossbar,
    GL_ARB_texture_env_dot3, GL_ARB_texture_mirrored_repeat,
    GL_ARB_transpose_matrix, GL_ARB_window_pos, GL_EXT_abgr, GL_EXT_bgra,
    GL_EXT_blend_color, GL_EXT_blend_func_separate, GL_EXT_blend_logic_op,
    GL_EXT_blend_minmax, GL_EXT_blend_subtract, GL_EXT_clip_volume_hint,
    GL_EXT_copy_texture, GL_EXT_draw_range_elements, GL_EXT_fog_coord,
    GL_EXT_multi_draw_arrays, GL_EXT_packed_pixels, GL_EXT_point_parameters,
    GL_EXT_polygon_offset, GL_EXT_rescale_normal, GL_EXT_secondary_color,
    GL_EXT_separate_specular_color, GL_EXT_shadow_funcs,
    GL_EXT_stencil_two_side, GL_EXT_stencil_wrap, GL_EXT_subtexture,
    GL_EXT_texture, GL_EXT_texture3D, GL_EXT_texture_edge_clamp,
    GL_EXT_texture_env_add, GL_EXT_texture_env_combine,
    GL_EXT_texture_env_dot3, GL_EXT_texture_lod_bias, GL_EXT_texture_object,
    GL_EXT_texture_rectangle, GL_EXT_vertex_array, GL_APPLE_packed_pixels,
    GL_ATI_texture_env_combine3, GL_ATI_texture_mirror_once,
    GL_ATIX_texture_env_combine3, GL_IBM_texture_mirrored_repeat,
    GL_INGR_blend_func_separate, GL_MESA_pack_invert, GL_MESA_ycbcr_texture,
    GL_NV_blend_square, GL_NV_point_sprite, GL_NV_texgen_reflection,
    GL_NV_texture_rectangle, GL_SGIS_generate_mipmap,
    GL_SGIS_texture_border_clamp, GL_SGIS_texture_edge_clamp,
    GL_SGIS_texture_lod, GL_SGIX_depth_texture, GL_SGIX_shadow,
    GL_SGIX_shadow_ambient, GL_SUN_multi_draw_arrays
glu version: 1.3
glu extensions:
    GLU_EXT_nurbs_tessellator, GLU_EXT_object_space_tess

   visual  x  bf lv rg d st colorbuffer ax dp st accumbuffer  ms  cav
 id dep cl sp sz l  ci b ro  r  g  b  a bf th cl  r  g  b  a ns b eat
----------------------------------------------------------------------
0x23 24 tc  0 24  0 r  y  .  8  8  8  0  0 16  0  0  0  0  0  0 0 None
0x24 24 tc  0 24  0 r  y  .  8  8  8  0  0 16  8 16 16 16  0  0 0 None
0x25 24 tc  0 32  0 r  y  .  8  8  8  8  0 16  8 16 16 16 16  0 0 None
0x26 24 tc  0 32  0 r  .  .  8  8  8  8  0 16  8 16 16 16 16  0 0 None
0x27 24 dc  0 24  0 r  y  .  8  8  8  0  0 16  0  0  0  0  0  0 0 None
0x28 24 dc  0 24  0 r  y  .  8  8  8  0  0 16  8 16 16 16  0  0 0 None
0x29 24 dc  0 32  0 r  y  .  8  8  8  8  0 16  8 16 16 16 16  0 0 None
0x2a 24 dc  0 32  0 r  .  .  8  8  8  8  0 16  8 16 16 16 16  0 0 None

Et voici mon xorg.conf :

# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the /etc/X11/xorg.conf manual page.
# (Type "man /etc/X11/xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following commands:
#
#   cp /etc/X11/xorg.conf /etc/X11/xorg.conf.custom
#   sudo sh -c 'md5sum /etc/X11/xorg.conf >/var/lib/xfree86/xorg.conf.md5sum'
#   sudo dpkg-reconfigure xserver-xorg

Section "Files"
	FontPath	"unix/:7100"			# local font server
	# if the local font server has problems, we can fall back on these
	FontPath	"/usr/lib/X11/fonts/misc"
	FontPath	"/usr/lib/X11/fonts/cyrillic"
	FontPath	"/usr/lib/X11/fonts/100dpi/:unscaled"
	FontPath	"/usr/lib/X11/fonts/75dpi/:unscaled"
	FontPath	"/usr/lib/X11/fonts/Type1"
	FontPath	"/usr/lib/X11/fonts/CID"
	FontPath	"/usr/lib/X11/fonts/100dpi"
	FontPath	"/usr/lib/X11/fonts/75dpi"
        # paths to defoma fonts
	FontPath	"/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
	FontPath	"/var/lib/defoma/x-ttcidfont-conf.d/dirs/CID"
EndSection

Section "Module"
	Load	"bitmap"
	Load	"dbe"
	Load	"ddc"
	Load	"dri"
	Load	"extmod"
	Load	"freetype"
	Load	"glx"
	Load	"int10"
	Load	"record"
	Load	"type1"
	Load	"vbe"
EndSection

Section "InputDevice"
	Identifier	"Generic Keyboard"
	Driver		"keyboard"
	Option		"CoreKeyboard"
	Option		"XkbRules"	"xorg"
	Option		"XkbModel"	"pc105"
	Option		"XkbLayout"	"fr-latin9"
EndSection

Section "InputDevice"
	Identifier	"Configured Mouse"
	Driver		"mouse"
	Option		"CorePointer"
	Option		"Device"		"/dev/input/mice"
	Option		"Protocol"		"ImPS/2"
	Option		"Emulate3Buttons"	"true"
	Option		"ZAxisMapping"		"4 5"
EndSection
Section "InputDevice"
        Identifier      "Synaptics Touchpad"
        Driver          "synaptics"
        Option          "SendCoreEvents"        "true"
        Option          "Device"                "/dev/psaux"
        Option          "Protocol"              "auto-dev"
        Option		"HorizScrollDelta"	"0"
EndSection

Section "Device"
        Identifier      "S3 Inc. VT8375 [ProSavage8 KM266/KL266]"
        Driver          "savage"
        Option          "UseBIOS"            "False"
EndSection

Section "Monitor"
	Identifier	"Écran générique"
	Option		"DPMS"
	HorizSync	28-49
	VertRefresh	43-72
EndSection

Section "Screen"
	Identifier	"Default Screen"
	Device		"S3 Inc. VT8375 [ProSavage8 KM266/KL266]"
	Monitor		"Écran générique"
	DefaultDepth	24
	SubSection "Display"
		Depth		1
		Modes		"1024x768" "800x600"
	EndSubSection
	SubSection "Display"
		Depth		4
		Modes		"1024x768" "800x600"
	EndSubSection
	SubSection "Display"
		Depth		8
		Modes		"1024x768" "800x600"
	EndSubSection
	SubSection "Display"
		Depth		15
		Modes		"1024x768" "800x600"
	EndSubSection
	SubSection "Display"
		Depth		16
		Modes		"1024x768" "800x600"
	EndSubSection
	SubSection "Display"
		Depth		24
		Modes		"1024x768" "800x600"
	EndSubSection
EndSection

Section "ServerLayout"
	Identifier	"Default Layout"
	Screen		"Default Screen"
	InputDevice	"Generic Keyboard"
	InputDevice	"Configured Mouse"
	InputDevice	"Synaptics Touchpad"
EndSection

Section "DRI"
	Mode	0666
EndSection

Voilà...

merci quand même du temps que vous me consacrez...

Hors ligne

#9 Le 13/09/2005, à 00:22

dylhoxic

Re : Accéleration 3d - VIA

'direct rendering: No' indique que l'acceleration 3d n'est pas prise en compte par ta carte graphique, tout est fait en software d'ou les scores sous glxgears...

D'après ce lien : http://dri.freedesktop.org/wiki/S3Savage l'acceleration 3d pour ta carte ne semble pas encore au point mais il y a des liens qui te permettront peut-être d'installer tout ça 'en mettant les mains dans le camboui'...

Bon courage !


Kubuntu++

Hors ligne

#10 Le 13/09/2005, à 13:52

random.hero

Re : Accéleration 3d - VIA

en mettant les mains dans le camboui

C'est là où j'aurais sans doute le plus besoin de la communauté...

Je devrais me diriger vers quoi? recherches? forums?

Hors ligne

#11 Le 13/09/2005, à 16:12

random.hero

Re : Accéleration 3d - VIA

Visiblement, ma carte serait supportée par ubuntu, si j'en croit cette page... mais par contre, je ne comprends pas ce qu'il faut faire pour ajouter le support 3D...

https://wiki.ubuntu.com//HardwareSupportComponentsVideoCards

Hors ligne

#12 Le 14/09/2005, à 18:15

dylhoxic

Re : Accéleration 3d - VIA

Je fais quelques recherches mais j'ai rien trouvé de bien concluant... Je suis désolé de pas pouvoir t'aider plus que ça...

Bon courage !


Kubuntu++

Hors ligne