Contenu | Rechercher | Menus

Annonce

DVD, clés USB et t-shirts Ubuntu-fr disponibles sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 20/08/2005, à 14:15

oToKaR

[Résolu] - grosse galere nvidia

salut tout le monde!
bon voici mon probleme: je possede une nvidia 6200 et apparament je n'ai ni la sortie tv ni la 3D qui fonctionent. J'ai suivi scrupuleusement le wiki qui disait d'installer nvidia-glx et nvidia settings. resultat je ne voyais quasi plus rien sur mon ecran avec des couleurs desaturees,l'horreur.

donc j'aimerai qu'on m'explique ce qui s'est passe et aussi quels drivers dois-je choisir sur le site nvidia car yen a plusieurs..
merci


« Être libre, ce n'est pas seulement se débarrasser de ses chaînes... c'est vivre d'une façon qui respecte et renforce la liberté des autres. » "Nelson Mandela"

Hors ligne

#2 Le 21/08/2005, à 13:12

oToKaR

Re : [Résolu] - grosse galere nvidia

alors personne pour m'aider svp ?? sad


« Être libre, ce n'est pas seulement se débarrasser de ses chaînes... c'est vivre d'une façon qui respecte et renforce la liberté des autres. » "Nelson Mandela"

Hors ligne

#3 Le 21/08/2005, à 14:10

Kiraa

Re : [Résolu] - grosse galere nvidia

installez les paquets

nvidia-glx, nvidia-kernel-common

Hors ligne

#4 Le 21/08/2005, à 16:06

oToKaR

Re : [Résolu] - grosse galere nvidia

Kiraa a écrit :

installez les paquets

nvidia-glx, nvidia-kernel-common

c'est bien ce que j'ai fais mais tout est illisible.. la seule installation du driver est celle faite lors de l'installation de base


« Être libre, ce n'est pas seulement se débarrasser de ses chaînes... c'est vivre d'une façon qui respecte et renforce la liberté des autres. » "Nelson Mandela"

Hors ligne

#5 Le 21/08/2005, à 16:09

Ju.

Re : [Résolu] - grosse galere nvidia

Je ne comprends pas trop tu as installé les drivers via synaptic (nvidia-kernel-common) ou en utilisant les drivers du site nvidia.com directement ?

oToKaR a écrit :

la seule installation du driver est celle faite lors de l'installation de base

oToKaR a écrit :

quels drivers dois-je choisir sur le site nvidia car yen a plusieurs..

Autre chose as tu bien executé la commande

sudo nvidia-glx-config enable

?


Have Fun !

Conduite à tenir face aux trolls

Hors ligne

#6 Le 21/08/2005, à 16:34

oToKaR

Re : [Résolu] - grosse galere nvidia

Ju a écrit :

Je ne comprends pas trop tu as installé les drivers via synaptic (nvidia-kernel-common) ou en utilisant les drivers du site nvidia.com directement ?

oToKaR a écrit :

la seule installation du driver est celle faite lors de l'installation de base

oToKaR a écrit :

quels drivers dois-je choisir sur le site nvidia car yen a plusieurs..

Autre chose as tu bien executé la commande

sudo nvidia-glx-config enable

?

salut ju
ben oui l'installation des drivers à ete faite via synaptic d'apres le wiki j'ai aussi installe nvidia-glx puis nvidia-setting.
ensuite j'ai execute la commande: sudo nvidia-glx-config enable. alors effectivement le logo nvidia apparait mais l'affichage est degueu et quasiment illisible sad


« Être libre, ce n'est pas seulement se débarrasser de ses chaînes... c'est vivre d'une façon qui respecte et renforce la liberté des autres. » "Nelson Mandela"

Hors ligne

#7 Le 21/08/2005, à 16:37

Ju.

Re : [Résolu] - grosse galere nvidia

Ah ok, plus d'infos seraient utiles : le résultat de

 lspci | grep nVidia

ainsi que ton fichier /etc/X11/xorg.conf


Have Fun !

Conduite à tenir face aux trolls

Hors ligne

#8 Le 21/08/2005, à 16:46

oToKaR

Re : [Résolu] - grosse galere nvidia

Ju a écrit :

Ah ok, plus d'infos seraient utiles : le résultat de

 lspci | grep nVidia

ainsi que ton fichier /etc/X11/xorg.conf

voici le resultat ju
now je n'ai pas fais cette manip(sudo nvidia-glx-config enable) sinon je verrai plus rien helas!!

resultats

lspci | grep nVidia
0000:01:00.0 VGA compatible controller: nVidia Corporation: Unknown device 0221 (rev a1)


# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the /etc/X11/xorg.conf manual page.
# (Type "man /etc/X11/xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following commands:
#
#   cp /etc/X11/xorg.conf /etc/X11/xorg.conf.custom
#   sudo sh -c 'md5sum /etc/X11/xorg.conf >/var/lib/xfree86/xorg.conf.md5sum'
#   sudo dpkg-reconfigure xserver-xorg

Section "Files"
    FontPath    "unix/:7100"            # local font server
    # if the local font server has problems, we can fall back on these
    FontPath    "/usr/lib/X11/fonts/misc"
    FontPath    "/usr/lib/X11/fonts/cyrillic"
    FontPath    "/usr/lib/X11/fonts/100dpi/:unscaled"
    FontPath    "/usr/lib/X11/fonts/75dpi/:unscaled"
    FontPath    "/usr/lib/X11/fonts/Type1"
    FontPath    "/usr/lib/X11/fonts/CID"
    FontPath    "/usr/lib/X11/fonts/100dpi"
    FontPath    "/usr/lib/X11/fonts/75dpi"
        # paths to defoma fonts
    FontPath    "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
    FontPath    "/var/lib/defoma/x-ttcidfont-conf.d/dirs/CID"
EndSection

Section "Module"
    Load    "bitmap"
    Load    "dbe"
    Load    "ddc"
    Load    "dri"
    Load    "extmod"
    Load    "freetype"
    Load    "glx"
    Load    "int10"
    Load    "record"
    Load    "type1"
    Load    "vbe"
EndSection

Section "InputDevice"
    Identifier    "Generic Keyboard"
    Driver        "keyboard"
    Option        "CoreKeyboard"
    Option        "XkbRules"    "xorg"
    Option        "XkbModel"    "pc105"
    Option        "XkbLayout"    "fr-latin9"
EndSection

Section "InputDevice"
    Identifier    "Configured Mouse"
    Driver        "mouse"
    Option        "CorePointer"
    Option        "Device"        "/dev/input/mice"
    Option        "Protocol"        "ImPS/2"
    Option        "Emulate3Buttons"    "true"
    Option        "ZAxisMapping"        "4 5"
EndSection

Section "Device"
    Identifier    "NVIDIA Corporation NV40? [Unknown nVidia Card]"
    Driver        "nv"
    BusID        "PCI:1:0:0"
EndSection

Section "Monitor"
    Identifier    "901B"
    Option        "DPMS"
EndSection

Section "Screen"
    Identifier    "Default Screen"
    Device        "NVIDIA Corporation NV40? [Unknown nVidia Card]"
    Monitor        "901B"
    DefaultDepth    24
    SubSection "Display"
        Depth        1
        Modes        "1600x1200" "1280x1024" "1024x768" "832x624" "800x600" "720x400" "640x480"
    EndSubSection
    SubSection "Display"
        Depth        4
        Modes        "1600x1200" "1280x1024" "1024x768" "832x624" "800x600" "720x400" "640x480"
    EndSubSection
    SubSection "Display"
        Depth        8
        Modes        "1600x1200" "1280x1024" "1024x768" "832x624" "800x600" "720x400" "640x480"
    EndSubSection
    SubSection "Display"
        Depth        15
        Modes        "1600x1200" "1280x1024" "1024x768" "832x624" "800x600" "720x400" "640x480"
    EndSubSection
    SubSection "Display"
        Depth        16
        Modes        "1600x1200" "1280x1024" "1024x768" "832x624" "800x600" "720x400" "640x480"
    EndSubSection
    SubSection "Display"
        Depth        24
        Modes        "1600x1200" "1280x1024" "1024x768" "832x624" "800x600" "720x400" "640x480"
    EndSubSection
EndSection

Section "ServerLayout"
    Identifier    "Default Layout"
    Screen        "Default Screen"
    InputDevice    "Generic Keyboard"
    InputDevice    "Configured Mouse"
EndSection

Section "DRI"
    Mode    0666
EndSection


« Être libre, ce n'est pas seulement se débarrasser de ses chaînes... c'est vivre d'une façon qui respecte et renforce la liberté des autres. » "Nelson Mandela"

Hors ligne

#9 Le 22/08/2005, à 00:33

Ju.

Re : [Résolu] - grosse galere nvidia

Aie...

Ta carte ne semble pas reconnue !

Tente malgré tout de remplacer nv par nvidia dans xorg.conf
(assure toi au préalable que le module nvidia est bien chargé : i doit apparaitre dans un lsmod, sinon sudo modprobe nvidia)


Have Fun !

Conduite à tenir face aux trolls

Hors ligne

#10 Le 22/08/2005, à 00:58

Yaen

Re : [Résolu] - grosse galere nvidia

salut à tous et à Otokar

sur le post http://forum.ubuntu-fr.org/viewtopic.php?id=10459 j'ai posté une soluce qui marche dans mon cas.

de plus tu peux aussi rentrer les Verticalsync et Horizontalsync de ton écran pour une bonne gestion de l'affichage.


Je joue à HL2, CSS, Stalker... avec mon pingouin d'amour.

Hors ligne

#11 Le 23/08/2005, à 10:19

oToKaR

Re : [Résolu] - grosse galere nvidia

salut yaen
ben en fait ce doit etre un soucis avec ma carte car la 3D fonctionne mais l'affichage est degueu voir illisible(comme si cela manquait de luminosite et de contraste). malgre les reglages,rien à faire donc vais me remettre avec mon ati 9600 car ça me gave à force..
en tous cas merci à toi et sans oublier "ju" wink

j'espere que tout se passera bien avec la config de mon ati lol

voilà je ne met pas resolu pour le post (sauf si un dodo me le demande,of course)car le probleme persiste...


« Être libre, ce n'est pas seulement se débarrasser de ses chaînes... c'est vivre d'une façon qui respecte et renforce la liberté des autres. » "Nelson Mandela"

Hors ligne

#12 Le 23/08/2005, à 11:16

michel2652

Re : [Résolu] - grosse galere nvidia

Bonjour,

J'ai moi aussi chercher sur le forum pour avoir les bons drivers et reglages nVidia.
Je pense que : http://wiki.ubuntu-fr.org/materiel/optimisation_nvidia (et le lien qu'il contient sur une bonne installation du driver) peut-t-etre utile

A+

Dernière modification par michel2652 (Le 23/08/2005, à 13:44)

#13 Le 24/08/2005, à 11:33

oToKaR

Re : [Résolu] - grosse galere nvidia

michel2652 a écrit :

Bonjour,

J'ai moi aussi chercher sur le forum pour avoir les bons drivers et reglages nVidia.
Je pense que : http://wiki.ubuntu-fr.org/materiel/optimisation_nvidia (et le lien qu'il contient sur une bonne installation du driver) peut-t-etre utile

A+

merci michel je l'avais deja vu mais le fait que tu me rappelles ce wiki m'a permis de m'apercevoir d' un truc celui-ci:  "Dans le répertoire /proc/driver/nvidia se trouve toute une série d’informations utiles aux optimisations. Si ce répertoire n’existe pas sur votre système, c’est que le pilote NVidia n’est pas installé ou pas chargé."

et effectivement je n'ai pas ce dossier, grrrr suis trop con,loll
encore merci de ce rappel wink


« Être libre, ce n'est pas seulement se débarrasser de ses chaînes... c'est vivre d'une façon qui respecte et renforce la liberté des autres. » "Nelson Mandela"

Hors ligne

#14 Le 24/08/2005, à 11:42

michel2652

Re : [Résolu] - grosse galere nvidia

OK !

Si tu arrives à régler ton problème, penses à mettre résolu dans le titre de ton post

A+

#15 Le 07/09/2005, à 20:30

rufus_corp

Re : [Résolu] - grosse galere nvidia

Salut,
j'ai exactement le même problème que toi avec ma nvidia 6200.
dès que je met dans mon xorg.conf le paramètre

driver = nvidia

au lieu de

driver = nv

( en passant c'est juste l'effet de la commande nvidia-glx-enable )

je vois quasiment plus rien et j'ai des couleurs toute bizarres!!!

t'as resolu le problème?

apparament c'est un problème avec le driver version 1.0.7174. J'aimerais bien essayer avec une plus vieille version du driver mais je sais pas trop comment faire pour trouver ça sur un dépot?
faut-il compiler?
et comment désinstaller le driver version 1.0.7174 proprement?


Monde de merde...

Hors ligne

#16 Le 07/09/2005, à 23:15

Yaen

Re : [Résolu] - grosse galere nvidia

rufus_corp, as-tu installé les drivers nvidia ? dans synaptic recherche nvidia. ou :

sudo apt-get install nvidia-glx glx-settings

parce que sans ces paquets l'affichage est effectivement disgracieux smile


Je joue à HL2, CSS, Stalker... avec mon pingouin d'amour.

Hors ligne

#17 Le 09/09/2005, à 19:37

rufus_corp

Re : [Résolu] - grosse galere nvidia

Oui j'avais bien installé les bon paquets glx qui se trouve sur les dépots .
En fait j'ai réglé le problème en installant le drivers version 7676 téléchargé sur le site de nvidia.
Le script d'installation NVIDIA-Linux-x86-1.0-7676-pkg1.run désinstalle la version du driver précedent tout proprement puis réinstalle un nouveau.
Attention de bien arreter le serveur X, de disposer des sources du kernel de la version : les paquets linux-source-2.6.10-4-i386 et linux- kernel-headers avant de lancer le script.

autre chose j'ai eu un gros plantage du server graphique en tentant d'installer kdm. Je l'ai réglé en réinstallant le driver.


Monde de merde...

Hors ligne

#18 Le 09/09/2005, à 21:24

Yaen

Re : [Résolu] - grosse galere nvidia

sad pas cool ces histoires de drivers tout de même...
y'aurait-il des cartes graphiques wingraphic ? lol


Je joue à HL2, CSS, Stalker... avec mon pingouin d'amour.

Hors ligne

#19 Le 10/09/2005, à 07:48

oToKaR

Re : [Résolu] - grosse galere nvidia

ben comme vous l'avez remarqué,j'ai laissé le sujet s'enrichir de questions et reponses alors que j'aurai pu le mettre RESOLU. oui effectivement grace à nos modos preferes,mon soucis est regle. mon ati fonctionne nickel avec la prise en charge 3D,j'ai donc arrete de me servir de ma nvidia car excecpte les galeres d'affichage que j'avais,j'avais un autre soucis avec cette carte qui a disparu instantannement avec la mise en place de mon ati: "des problemes d'affichage de curseur lors de l'ecriture..."

ps: en tous cas on s'aperçois que les solutions et autres envies de resoudre les problemes techniques ne manquent pas et ça c'est important pour l'evolution de ubuntu


« Être libre, ce n'est pas seulement se débarrasser de ses chaînes... c'est vivre d'une façon qui respecte et renforce la liberté des autres. » "Nelson Mandela"

Hors ligne

#20 Le 16/09/2005, à 00:52

rufus_corp

Re : [Résolu] - grosse galere nvidia

Bon...
C'est bien malgrès moi mais l'histoire n'est pas terminé..
Je résume en gros parce que le problème vaux le coup d'oeil. y'a pas de doute possible sur mon diagnostic, j'ai fait le test dans tout le sens 50 fois pour savoir quand ça plantais. ( à vrai dire j'ai suspecté plein d'autre chose avant, voir mon post plus haut.)

Je réinstalle le Driver Nvidia version 7979.
je lance gdm avec

/etc/init.d/gdm start

: jusqu'a la tout marche nickel. C'est à dire que quand je tape glxgears dans un terminal, j'ai les petites roues qui s'affiche. Quant à glxinfo, j'ai plein mais alors plein d'info. Bref ça marche quoi!!!

Je fait un redémarrage: Le serveur X se lance bien. seulement maintenant quand je fait un glxgear, ou un glxinfo j'ai un superbe

"erreur de segmentation"

.

Ok ... la je fait un redémarrage et pan! plus de serveur X !!!
Le Xorg.0.log s'arrête à

(II) Initializing built-in extension XEVIE
(II) Initializing extension GLX

et après plus rien ( normalement j'ai :
(**) Generic Keyboard: Core Keyboard
(**) Option "Protocol" "standard"
(**) Generic Keyboard: Protocol: standard

... et encore plein de truc.) . c'est donc l'initialisation de GLX qui plante apparament.

La preuve quand je met

 driver="nv"

dans xorg.conf, le serveur X se lance bien

Vraiement étonnant. Le truc c'est que j'ai pas trouver autre chose que de réinstaller le driver pour que ça remarche nickel... jusqu'a 1 redemarrage complet et 1 redemarrage de gdm ...

Voila. en tout cas si personne ne trouve une solution à mon problème, le cas est assez interressant. dommage que c'est une machine que j'installe pour un pote que je dois lui filer dans 3 jours. Je sens que je vais lui filer sans la 3D. Domage, il aura un argument pour tourner sous windaube.


Monde de merde...

Hors ligne