Contenu | Rechercher | Menus

Annonce

Ubuntu-fr vend de superbes t-shirts et de belles clés USB 32Go
Rendez-vous sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 05/09/2012, à 09:26

juliech

[RESOLU] Installation Ubuntu OK, Pas de démarrage possible ( Legacy)

Bonjour,
Suite à de nombreuses déconvenues avec l'UEFI, j'ai décidé de tout effacer sur mon disque dur et d'installer uniquement un linux, pensant ainsi m'affranchir de l'UEFI en l'installant en mode Legacy.

L'installation s'est très bien passée, j'ai pensé à créer une partition non formatée en début de disque avec un drapeau bios-grub qui au moment de l'installation a été choisie comme réservée pour le secteur d'amorçage.

Jusque là tout va bien.

A la fin de l'installation, le pc reboot. Mais là pas de reboot possible.
J'ai effectivement vérifié dans le bios : en mode legacy je n'ai des options de boot que pour mes médias (clés usb, lecteurs dvd).
Il n'y avait que le mode UEFI qui avait des options de boot sur les hard drives.

Quelqu'un aurait-il une idée pour que mon grub apparaisse dans ces options de boot en legacy? Un boot-repair via le live cd?

Merci

Dernière modification par juliech (Le 05/09/2012, à 17:57)

Hors ligne

#2 Le 05/09/2012, à 09:49

malbo

Re : [RESOLU] Installation Ubuntu OK, Pas de démarrage possible ( Legacy)

Pour les lecteurs : le PC de juliech contient un "PowerEdge RAID Controller" : http://forum.ubuntu-fr.org/viewtopic.ph … #p10631881
Sa machine est un dell precision T3600 : http://forum.ubuntu-fr.org/viewtopic.ph … #p10563761
Dont les spec sont visibles dans ce pdf : http://i.dell.com/sites/doccontent/shar … -Sheet.pdf

Dernière modification par malbo (Le 05/09/2012, à 12:53)

Hors ligne

#3 Le 05/09/2012, à 13:40

YannUbuntu

Re : [RESOLU] Installation Ubuntu OK, Pas de démarrage possible ( Legacy)

Bonjour
Pouvez-vous nous indiquer votre URL BootInfo svp?
http://doc.ubuntu-fr.org/tutoriel/boot-info


à consulter/améliorer: Guide du Débutant, Logiciels, Ecole, Travail, Maison

Hors ligne

#4 Le 05/09/2012, à 13:46

malbo

Re : [RESOLU] Installation Ubuntu OK, Pas de démarrage possible ( Legacy)

@YannUbuntu
Merci d'intervenir. As-tu vu qu'il a deux disques durs virtuels (son post #17 dans le lien) : http://forum.ubuntu-fr.org/viewtopic.ph … #p10631201
le dernier Boot-Info envoyé par juliech où on peut voir ces deux disques durs virtuels : http://paste.ubuntu.com/1183739/

Dernière modification par malbo (Le 05/09/2012, à 13:47)

Hors ligne

#5 Le 05/09/2012, à 14:16

YannUbuntu

Re : [RESOLU] Installation Ubuntu OK, Pas de démarrage possible ( Legacy)

Merci Malbo pour les liens.
Ca ressemble à un fake raid (raid BIOS), donc normalement il n'y a rien à activer.

Par contre il y avait un gros soucis détecté par parted:

Error: The backup GPT table is corrupt, but the primary appears OK, so that will
be used.
Model: DELL PERC H310 (scsi)
Disk /dev/sda: 1971GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt

Number  Start   End     Size    File system  Name  Flags
1      1049kB  1971GB  1971GB  ext4



                                                                          
Error: The backup GPT table is corrupt, but the primary appears OK, so that will
be used.
Model: DELL PERC H310 (scsi)
Disk /dev/sdb: 1029GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt

Number  Start   End     Size    File system     Name                          Flags
1      1049kB  106MB   105MB   fat32           EFI system partition
2      106MB   240MB   134MB                   Microsoft reserved partition  msftres
3      240MB   157GB   157GB   ntfs            Basic data partition
4      157GB   157GB   210MB   fat16                                         boot
5      157GB   189GB   31.5GB  linux-swap(v1)
6      189GB   294GB   105GB   ext4
7      294GB   451GB   157GB   ext4
8      451GB   1029GB  578GB   ext4

Et le soucis de boot était peut-etre dû au fait que la partition EFI était trop loin (157Go).

@Juliech: comme vous avez tout réinstallé, merci de nous indiquer votre BootInfo actuel. http://doc.ubuntu-fr.org/tutoriel/boot-info

Dernière modification par YannUbuntu (Le 05/09/2012, à 14:17)


à consulter/améliorer: Guide du Débutant, Logiciels, Ecole, Travail, Maison

Hors ligne

#6 Le 05/09/2012, à 14:28

juliech

Re : [RESOLU] Installation Ubuntu OK, Pas de démarrage possible ( Legacy)

Merci pour vos réponses.
J'avais bien prévu de vous mettre mon bootInfo mais malheureusement je n'ai pas réussi à le créer. Lorsque je lance l'appli boot-repair de mon liveCD, il est à la recherche d'un operating system et ne semble pas en trouver puisque ça tourne en continu sans s'arrêter.
Voyant cela je me dis que si même Ubuntu n'est pas capable de le trouver, mon bios ne le trouvera pas non plus.

Il semblerait également que la config de mon bios ne me permette pas de booter en mode legacy sur un hard drive. En effet en mode UEFI je peux lui ajouter manuellement des options de boot, en mode legacy je ne peux absolument rien ajouter ni supprimer manuellement.
Donc sans une détection automatique de mon grub par le bios, il semble que ma machine n'accepte aucun os en mode legacy. Est-ce possible?

Hors ligne

#7 Le 05/09/2012, à 14:33

YannUbuntu

Re : [RESOLU] Installation Ubuntu OK, Pas de démarrage possible ( Legacy)

juliech a écrit :

Lorsque je lance l'appli boot-repair de mon liveCD, il est à la recherche d'un operating system et ne semble pas en trouver puisque ça tourne en continu sans s'arrêter.

Même si vous répondez "Non" à la question "Voulez-vous mettre à jour le logiciel?"

Depuis un liveCD, ouvrez un terminal et indiquez-nous le retour de :

sudo parted -l
juliech a écrit :

Il semblerait également que la config de mon bios ne me permette pas de booter en mode legacy sur un hard drive.

Ca m'étonnerait fortement. Pouvez-vous nous montrer des photos de votre BIOS? (à uploder sur http://pix.toile-libre.org/ )


à consulter/améliorer: Guide du Débutant, Logiciels, Ecole, Travail, Maison

Hors ligne

#8 Le 05/09/2012, à 15:51

juliech

Re : [RESOLU] Installation Ubuntu OK, Pas de démarrage possible ( Legacy)

Alors pour répondre à vos questions :
1. Oui même en répondant non à la mise à jour boot repair mouline dans le vide en me disant : "detection des systèmes. Veuillez patienter quelques secondes"

2.Voici le résultat de la commande sudo parted -l :

Model: DELL PERC H310 (scsi)
Disk /dev/sda: 1971GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt

Number  Start   End     Size    File system  Name  Flags
 1      1049kB  11,5MB  10,5MB                     bios_grub
 2      11,5MB  1971GB  1971GB  ext4


Model: DELL PERC H310 (scsi)
Disk /dev/sdb: 1029GB
Sector size (logical/physical): 512B/512B
Partition Table: gpt

Number  Start   End     Size    File system     Name  Flags
 1      1049kB  157GB   157GB   ext4
 2      157GB   189GB   31,5GB  linux-swap(v1)
 3      189GB   294GB   105GB   ext4
 4      294GB   1029GB  735GB   ext4

3. photos du bios à suivre...

Merci

Hors ligne

#9 Le 05/09/2012, à 16:04

juliech

Re : [RESOLU] Installation Ubuntu OK, Pas de démarrage possible ( Legacy)

Voici donc les images du bios :
Lorsque l'option Legacy est cochée :
1346853684.jpg
on voit bien que les boutons add et delete ne sont pas accessibles

Lorsque l'option UEFI est cochée:
1346853743.jpg
Il ne reste plus que le windows boot manager (certainement un reliquat de l'ancienne installation) mais il n'envoie vers rien.

Merci de votre aide.
Julie

Hors ligne

#10 Le 05/09/2012, à 16:06

YannUbuntu

Re : [RESOLU] Installation Ubuntu OK, Pas de démarrage possible ( Legacy)

1. quelle version de Boot-Repair utilisez-vous?

boot-repair -v

2. Bonne nouvelle: l'erreur de partitionnement a disparu.

3. Pour l'instant restez sur le mode Legacy svp.

Que retourne la commande:

sudo os-prober

Qu'y a-t-il sur chacune de vos partitions?

Dernière modification par YannUbuntu (Le 05/09/2012, à 16:15)


à consulter/améliorer: Guide du Débutant, Logiciels, Ecole, Travail, Maison

Hors ligne

#11 Le 05/09/2012, à 16:17

juliech

Re : [RESOLU] Installation Ubuntu OK, Pas de démarrage possible ( Legacy)

Heu l'erreur de partitionnement c'était GPT Table corrupted?
Parce que si c'est ça, je l'ai en fait effacée étant donnée que depuis le début que j'ai cet ordinateur, à chaque fois que j'ai utilisé GParted il m'envoyait ce genre de message. mais comme ça fonctionnait quand même en faisant ok, je me suis dit que ce n'étzait peut être qu'un warning.
Donc cette erreur apparait toujours en fait.

Par contre autre bonne nouvelle : pour vous donner la version de boot-repair j'ai du relancer mon live cd et là je ne sais pas pourquoi mais boot-repair a fonctionné, voici donc le boot info :

http://paste.ubuntu.com/1187306

Hors ligne

#12 Le 05/09/2012, à 16:30

YannUbuntu

Re : [RESOLU] Installation Ubuntu OK, Pas de démarrage possible ( Legacy)

Voici ce que je ferais à votre place:
1) Si vous avez des documents sur votre disque, sauvegardez-les sur disque externe (ou DVDs..)
2) Via Gparted, réduire sdb1 de façon à obtenir 1Go d'espace libre juste devant (en début de disque)
3) Via Gparted, réduire sdb1 de façon à ce que sa taille ne dépasse pas 90Go. (donc la réduire par la fin)
4) Via Gparted: dans l'espace libre de 1Go en début de disque, créer une autre partition BIOS-boot (1Mo, pas de système de fichier, drapeau bios_grub)
5) lancer Boot-Repair, cliquer sur le bouton "Réparation recommandée".
6) Nous indiquer la nouvelle URL qui apparaitra
7) Redémarrer (en mode Legacy) et nous indiquer ce que vous observez

Dernière modification par YannUbuntu (Le 05/09/2012, à 16:30)


à consulter/améliorer: Guide du Débutant, Logiciels, Ecole, Travail, Maison

Hors ligne

#13 Le 05/09/2012, à 16:34

juliech

Re : [RESOLU] Installation Ubuntu OK, Pas de démarrage possible ( Legacy)

il n'y a pas d'erreur? c'est bien 1Go avant sdb1 et sdb1 (qui est ma partition racine) mesure 90Go.
Et le drapeau bios-grub du coup je l'enlève de la partition sda1?
merci

Hors ligne

#14 Le 05/09/2012, à 17:37

YannUbuntu

Re : [RESOLU] Installation Ubuntu OK, Pas de démarrage possible ( Legacy)

Pas d'erreur, c'est bien 1Go=  1Mo pour BIOS-boot, + 999Mo libres au cas où tu aurais besoin d'une partition /boot.

Non, n'enlève pas le drapeau sur sda1.


à consulter/améliorer: Guide du Débutant, Logiciels, Ecole, Travail, Maison

Hors ligne

#15 Le 05/09/2012, à 17:56

juliech

Re : [RESOLU] Installation Ubuntu OK, Pas de démarrage possible ( Legacy)

Voici la nouvelle url pour le bootinfo :
http://paste.ubuntu.com/1187435

ET oh miracle : le pc boot sur un grub ET cerise sur le gateau quand on sélectionne linux, il se lance!!!

Merci merci merci beaucoup.
Un jour peut-être pourrais-je utiliser le dual boot sur cette machine en uefi, mais pour le moment un linux qui tourne c'est exceptionnel.
Merci encore, je modifie le post pour le mettre résolu.

Hors ligne

#16 Le 05/09/2012, à 18:48

YannUbuntu

Re : [RESOLU] Installation Ubuntu OK, Pas de démarrage possible ( Legacy)

Parfait smile
Si tu veux bien, on va faire un petit test:
1) renommer le fichier sda1/core.img en core-old.img
2) Redémarrer le PC. Est-ce que le menu GRUB apparait et est toujours fonctionnel ?
3) en cas de soucis, restaurer core-old.img en core.img

Dernière modification par YannUbuntu (Le 05/09/2012, à 18:50)


à consulter/améliorer: Guide du Débutant, Logiciels, Ecole, Travail, Maison

Hors ligne

#17 Le 06/09/2012, à 08:57

juliech

Re : [RESOLU] Installation Ubuntu OK, Pas de démarrage possible ( Legacy)

Oui je veux bien mais :
1 comment je trouve ce fichier? puisqu'il n'est pas dans mon file system
2 si le grub ne fonctionne plus, comment je ferai pour booter sur mon linux et rechanger le fichier?

Merci

Hors ligne

#18 Le 06/09/2012, à 09:43

YannUbuntu

Re : [RESOLU] Installation Ubuntu OK, Pas de démarrage possible ( Legacy)

1. Ouvrir un terminal (Ctrl+Alt+T), et saisir la commande suivante:

sudo mount /dev/sda1 /mnt                     # Monte la partition sda1 dans le dossier /mnt
ls /mnt                                     #Affiche le contenu du dossier /mnt (devrait afficher core.img)
sudo mv /mnt/core.img /mnt/core-old.img     #Renomme core.img en core-old.img
ls /mnt                                     #Affiche le contenu du dossier /mnt (devrait afficher core-old.img)

2. Si le GRUB ne fonctionne plus, démarrer sur un CD Ubuntu, choisir "Essayer Ubuntu", ouvrir un terminal et restaurer le nom initial:

sudo mount /dev/sda1 /mnt                    # Monte la partition sda1 dans le dossier /mnt
ls /mnt                                        #Affiche le contenu du dossier /mnt (devrait afficher core-old.img)
sudo mv /mnt/core-old.img /mnt/core.img    #Renomme core-old.img en core.img

Dernière modification par YannUbuntu (Le 06/09/2012, à 09:45)


à consulter/améliorer: Guide du Débutant, Logiciels, Ecole, Travail, Maison

Hors ligne

#19 Le 06/09/2012, à 10:04

juliech

Re : [RESOLU] Installation Ubuntu OK, Pas de démarrage possible ( Legacy)

Wah! on ne peut pas plus clair, merci.
j'ai déjà un souci à la première commande. mount demande de préciser le type de sytème de fichier. Or sda1 n'est pas formaté donc il n'a pas de type. Il y a une autre solution? ou un utilitaire tout fait qui monte les volumes?

Hors ligne

#20 Le 06/09/2012, à 10:13

YannUbuntu

Re : [RESOLU] Installation Ubuntu OK, Pas de démarrage possible ( Legacy)

Je ne sais pas, donc mieux vaut laisser tomber ce test. Merci quand même d'avoir essayé. Et surtout... bonne continuation parmi nous ! smile


à consulter/améliorer: Guide du Débutant, Logiciels, Ecole, Travail, Maison

Hors ligne

#21 Le 06/09/2012, à 10:16

juliech

Re : [RESOLU] Installation Ubuntu OK, Pas de démarrage possible ( Legacy)

Merci encore d'y avoir passé du temps.

Hors ligne