Contenu | Rechercher | Menus

Annonce

La nouvelle clé USB Ubuntu-fr est en prévente
Rendez-vous sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 15/05/2014, à 15:00

Duanra

[Résolu] Bloqué dans nomodeset

Bonjour à tous,

J'ai récemment installé Xubuntu 14.04 sur un PC relativement vieux, équipé d'une AMD/ATI RS300 Radeon 9100 IGP.
Déjà à l'installation j'ai eu des problèmes avec la carte graphique (écran noir), ce qui m'a fait utiliser le "crlt+alt+F1", puis arrêter et redémarrer lightdm à la main pour pouvoir démarrer une session avec le live CD et installer.
Maintenant que le système est installé, mon problème n'a bien entendu pas disparu de lui-même. J'ai cherché sur les forums français et anglais et j'ai trouvé la solution du nomodeset, soit éditer le /etc/default/grub et modifier

"quiet splash"

pour

"quiet splash nomodeset"

En théorie, ceci permet d'afficher un écran splash certes baveux mais fonctionnel, et ensuite d'après la solution trouvée sur google quand X démarre, tout revient dans l'ordre.
Avec nomodeset je peux me loguer et travailler normalement, SAUF QUE ma résolution reste en 1024x768, et qu'elle est au final moche et baveuse. Comme ça fait assez mal aux yeux, j'ai supprimé nomodeset du grub et je suis revenu à ma bonne vieille méthode de lancer un terminal au démarrage pour stopper et redémarrer lightdm à la main. Une fois que c'est fait, tout fonctionne à merveille. 

Est-ce que quelqu'un saurait comment palier le problème et faire en sorte que le nomodeset ne soit pas permanent mais juste temporaire pour le login ?

Merci d'avance : )

Dernière modification par Duanra (Le 16/05/2014, à 12:30)

Hors ligne

#2 Le 15/05/2014, à 15:23

Cyralien

Re : [Résolu] Bloqué dans nomodeset

J'ai peux-être une méthode, quelle est la définition que tu souhaites avoir ?

Hors ligne

#3 Le 15/05/2014, à 16:05

Duanra

Re : [Résolu] Bloqué dans nomodeset

Je voudrais du 1360x768. Dis-moi, ça peut peut-être m'aider...

Hors ligne

#4 Le 15/05/2014, à 17:25

Cyralien

Re : [Résolu] Bloqué dans nomodeset

Désolé je ne pourrais pas t'aider, il existe des paramètres à passer au noyau par grub pour forcer la définition, mais pas pour du 1360x768.

Sinon il faut utilisé une modeline voir ici et si ça ne fonctionne pas alors passer par le xorg.conf ( pas sûr que le xorg.conf soit d'actualité sur la 14.04 )

Hors ligne

#5 Le 15/05/2014, à 17:34

alca94

Re : [Résolu] Bloqué dans nomodeset

Je voudrais du 1360x768. Dis-moi, ça peut peut-être m'aider...

c'est pas plutôt 1366 x 768


POUR METTRE LES RETOURS DU "TERMINAL"  voir les explications sur ce post
https://forum.ubuntu-fr.org/viewtopic.p … #p17345641

Hors ligne

#6 Le 15/05/2014, à 17:42

ADOS

Re : [Résolu] Bloqué dans nomodeset

Bonjour,

Apparemment, avec une petite recherche sur le forum, on trouve ceci :
http://forum.ubuntu-fr.org/viewtopic.php?id=1511111
http://forum.ubuntu-fr.org/viewtopic.php?id=1273791

Ça devrait résoudre quelques soucis. wink

Hors ligne

#7 Le 16/05/2014, à 12:27

Duanra

Re : [Résolu] Bloqué dans nomodeset

C'est résolu !!
Non sans mal mais tout est ok maintenant.

J'ai utilisé "nosplash", puisque mes problèmes arrivaient toujours à cet endroit-là et ça fonctionne bien. Pour une raison que j'ignore toujours après avoir fait la modif du fichier grub et l'update, j'ai redémarré la machine et surprise, je ne pouvais lancer de session utilisateur !!!! Un petit "sudo chown" sur le fichier de l'utilisateur et le problème était joué. Je ne pense pas que ça ait quelque chose à voir avec le nosplash, mais bon les voies de l'informatique sont impénétrables...

Pour ceux que ça pourrait aider, voici un petit récapitulatif utile:

Après l'écran noir consécutif au démarrage (râté : ) ) d'Ubuntu, appuyer sur "crlt+alt+F1". Un terminal se lance, rentrer la commande

sudo nano /etc/default/grub

puis le mot de passe. Aller à la ligne

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

et la modifier pour

GRUB_CMDLINE_LINUX_DEFAULT="nosplash"

Enregister en appuyant sur "crlt+o" puis sur "entrée". Appuyer ensuite sur "crlt+x" et écrire

sudo update-grub

Lorsque l'opération est terminée, rentrer

sudo reboot

Voilà, avec ça le démarrage est certes moins joli, mais au moins tout fonctionne correctement !

Merci à tous de m'avoir aidé : )

Dernière modification par Duanra (Le 16/05/2014, à 12:29)

Hors ligne

#8 Le 26/07/2014, à 14:10

siddhartha

Re : [Résolu] Bloqué dans nomodeset

salut

je pensais avoir trouvé une solution pour mon pb qui est tres proche... mais ca marche pas du tout !

j'ai ouvert un post à cette adresse , si qq'un a une idée, une solution!

merci
stephane

Dernière modification par siddhartha (Le 26/07/2014, à 14:12)


consultant internet / webmaster
www.stephane-desrousseaux.fr

Hors ligne