Contenu | Rechercher | Menus

Annonce

L'équipe des administrateurs et modérateurs du forum vous invite à prendre connaissance des nouvelles règles.
En cas de besoin, vous pouvez intervenir dans cette discussion.

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 20/09/2018, à 11:16

pseudofab

[Résolu]Comment installer ipython pour python3.6 sur la 16.04?

Bonjour,
Je souhaite installer ipython pour python3.6
J'ai installé ipython , ipython3 (sudo apt install ipython , sudo apt install ipython3) mais les versions ne correspondent pas à python3.6 . De plus , les caractères dans le terminal sont peu lisibles car trop petit....

J'ai aussi essayé d'installé ipython via pip comme expliqué par la notice https://doc.ubuntu-fr.org/python
Mais la 3 eme commande ne passe pas :

~ jt'écoute :sudo pip3 install jupyter
[sudo] Mot de passe de fabien : 
Traceback (most recent call last):
  File "/usr/bin/pip3", line 9, in <module>
    from pip import main
ImportError: cannot import name 'main'
~ jt'écoute :

Bref, comment installer ipython pour python3.6 ?
Merci

[Résolu] Solution en #20

Dernière modification par pseudofab (Le 28/09/2018, à 22:59)


# Là pour le plaisir de découvrir . En souvenir de l'ado dont les yeux brillaient d'émerveillement devant l'écran d'un Amstrad 6128 ...

# Débutant en tout ...  je me régale !

Hors ligne

#2 Le 20/09/2018, à 12:08

pseudofab

Re : [Résolu]Comment installer ipython pour python3.6 sur la 16.04?

J'ai oublié de préciser que je suis sous Ubuntu mate 16.04 LTS...


# Là pour le plaisir de découvrir . En souvenir de l'ado dont les yeux brillaient d'émerveillement devant l'écran d'un Amstrad 6128 ...

# Débutant en tout ...  je me régale !

Hors ligne

#3 Le 20/09/2018, à 12:50

pseudofab

Re : [Résolu]Comment installer ipython pour python3.6 sur la 16.04?

Bon , pour ce qui est de la petitesse des caractères , le problème est liée au lancement par l'interface graphique . Affichage normal avec un lancement depuis le terminal .
Reste , le soucis d'avoir un ipython pour python3.6 . (ipython3 correspond à la version 3.5.2 de python)


# Là pour le plaisir de découvrir . En souvenir de l'ado dont les yeux brillaient d'émerveillement devant l'écran d'un Amstrad 6128 ...

# Débutant en tout ...  je me régale !

Hors ligne

#4 Le 23/09/2018, à 07:44

pseudofab

Re : [Résolu]Comment installer ipython pour python3.6 sur la 16.04?

Bonjour,
Up... toujours avec la même question roll
Quelle version de ipython compatible python3.6?
Merci


# Là pour le plaisir de découvrir . En souvenir de l'ado dont les yeux brillaient d'émerveillement devant l'écran d'un Amstrad 6128 ...

# Débutant en tout ...  je me régale !

Hors ligne

#5 Le 23/09/2018, à 07:59

melixgaro

Re : [Résolu]Comment installer ipython pour python3.6 sur la 16.04?

salut,

ipython3 démarre ipython en version 3.x, que ce soit 3.5 ou 3.6 ne change pas grand chose. Je ne peux pas le vérifier facilement mais je pense qu'ubuntu 16.04 te bloque en version 3.5. Ne t'embête pas avec ça plus longtemps et amuse-toi avec ipython3/python3.5.


Linux depuis ~2007. Xubuntu seulement.

Hors ligne

#6 Le 23/09/2018, à 08:10

pseudofab

Re : [Résolu]Comment installer ipython pour python3.6 sur la 16.04?

salut,
merci de ta réponse.
L'ennui c'est que le support des cours que je suis , utilise la version 3.6 . (utilisation des  f-strings ...)

Dernière modification par pseudofab (Le 23/09/2018, à 08:11)


# Là pour le plaisir de découvrir . En souvenir de l'ado dont les yeux brillaient d'émerveillement devant l'écran d'un Amstrad 6128 ...

# Débutant en tout ...  je me régale !

Hors ligne

#7 Le 23/09/2018, à 11:11

melixgaro

Re : [Résolu]Comment installer ipython pour python3.6 sur la 16.04?

ah oui, effectivement tu utilises une nouveauté de 3.6
je crois que tu peux installer fstring localement avec pip

pip3 install --no-deps --user fstring

et après depuis ipython3 tu exécutes

import fstring

Linux depuis ~2007. Xubuntu seulement.

Hors ligne

#8 Le 23/09/2018, à 12:38

pseudofab

Re : [Résolu]Comment installer ipython pour python3.6 sur la 16.04?

Toujours pas de fstring ...
Voici ce que me répond la 1ere commande:

jt'écoute :pip3 install --no-deps --user fstring
Collecting fstring
  Downloading https://files.pythonhosted.org/packages/19/ad/1cd17d79ad3b435e5ca11865525c4afcb4858101b730fc93b181915f820b/fstring-1.7.4.tar.gz
Building wheels for collected packages: fstring
  Running setup.py bdist_wheel for fstring ... done
  Stored in directory: /home/fabien/.cache/pip/wheels/0a/dd/0e/6190e97da30be7c8f0d6bce509a3456435c53bb325e9ea22c7
Successfully built fstring
Installing collected packages: fstring
Successfully installed fstring-1.7.4
~ jt'écoute:

Cependant pour la 2eme commande je ne comprend pas : une croix s'affiche ( il semble qu'elle permet une selection d'une zone d'écran ) . Après un clic , la croix disparaît et le prompt revient ...


# Là pour le plaisir de découvrir . En souvenir de l'ado dont les yeux brillaient d'émerveillement devant l'écran d'un Amstrad 6128 ...

# Débutant en tout ...  je me régale !

Hors ligne

#9 Le 23/09/2018, à 12:45

pseudofab

Re : [Résolu]Comment installer ipython pour python3.6 sur la 16.04?

Il doit y avoir une erreur d'écriture ... La commande import appartient à ImageMagick ... D'où la croix qui s'affiche.


# Là pour le plaisir de découvrir . En souvenir de l'ado dont les yeux brillaient d'émerveillement devant l'écran d'un Amstrad 6128 ...

# Débutant en tout ...  je me régale !

Hors ligne

#10 Le 23/09/2018, à 12:53

pseudofab

Re : [Résolu]Comment installer ipython pour python3.6 sur la 16.04?

Désolé , j'ai mal suivi tes directives...
J'ai lancé import depuis le terminal
Voici ce que ça donne :

~ jt'écoute :ipython3
Python 3.5.2 (default, Nov 23 2017, 16:37:01) 
Type "copyright", "credits" or "license" for more information.

IPython 2.4.1 -- An enhanced Interactive Python.
?         -> Introduction and overview of IPython's features.
%quickref -> Quick reference.
help      -> Python's own help system.
object?   -> Details about 'object', use 'object??' for extra details.

In [1]: import fstring
---------------------------------------------------------------------------
ImportError                               Traceback (most recent call last)
<ipython-input-1-875d19ae8aff> in <module>()
----> 1 import fstring

/home/fabien/.local/lib/python3.5/site-packages/fstring/__init__.py in <module>()
      1 """PEP 498 Python 2.7 Back-port."""
----> 2 from .fstring import fstring

/home/fabien/.local/lib/python3.5/site-packages/fstring/fstring.py in <module>()
      5 
      6 from six import text_type
----> 7 from astroid.decorators import cachedproperty
      8 
      9 # pylint: disable=invalid-name,missing-docstring

ImportError: No module named 'astroid'

Dernière modification par pseudofab (Le 23/09/2018, à 12:55)


# Là pour le plaisir de découvrir . En souvenir de l'ado dont les yeux brillaient d'émerveillement devant l'écran d'un Amstrad 6128 ...

# Débutant en tout ...  je me régale !

Hors ligne

#11 Le 23/09/2018, à 13:31

melixgaro

Re : [Résolu]Comment installer ipython pour python3.6 sur la 16.04?

oui y a des dépendances pour fstring, attends…


Linux depuis ~2007. Xubuntu seulement.

Hors ligne

#12 Le 23/09/2018, à 13:38

melixgaro

Re : [Résolu]Comment installer ipython pour python3.6 sur la 16.04?

pip3 install --user astroid

Avec cette commande, ça devrait installer ce qu'il manque. Pour info, pip3 (pip pour python2.7) permet d'installer des modules python, ceux que l'on trouve dans ce catalogue. Si un module python est installable via apt, il faut privilégier cette façon. Si ça n'est pas le cas, pip3 est très pratique. Avec l'option --user, l'installation se fait pour l'utilisateur courant. Tu trouveras les fichiers installés dans

~/.local/lib/python3.6/site-packages/

Linux depuis ~2007. Xubuntu seulement.

Hors ligne

#13 Le 23/09/2018, à 16:19

pseudofab

Re : [Résolu]Comment installer ipython pour python3.6 sur la 16.04?

Toujours pas ...

~ jt'écoute :pip3 install --user astroid
Collecting astroid
  Downloading https://files.pythonhosted.org/packages/19/92/6f6d3591c429dbdb31c18d8476ba1af08d5973d7cc09f66346109e9de7fb/astroid-2.0.4-py3-none-any.whl (172kB)
    100% |████████████████████████████████| 174kB 741kB/s 
Collecting typed-ast; python_version < "3.7" and implementation_name == "cpython" (from astroid)
  Downloading https://files.pythonhosted.org/packages/5b/4e/79e873aa89b8038ca6474c00afe96f9468973b604e7f737cb82697a680c0/typed_ast-1.1.0-cp35-cp35m-manylinux1_x86_64.whl (724kB)
    100% |████████████████████████████████| 727kB 897kB/s 
Collecting wrapt (from astroid)
  Downloading https://files.pythonhosted.org/packages/a0/47/66897906448185fcb77fc3c2b1bc20ed0ecca81a0f2f88eda3fc5a34fc3d/wrapt-1.10.11.tar.gz
Collecting lazy-object-proxy (from astroid)
  Downloading https://files.pythonhosted.org/packages/10/88/d7b8274edf912be71d73a1e5de7988f62b63d9e88e591da2e6f921ab69e6/lazy_object_proxy-1.3.1-cp35-cp35m-manylinux1_x86_64.whl (55kB)
    100% |████████████████████████████████| 61kB 1.1MB/s 
Requirement already satisfied: six in /usr/lib/python3/dist-packages (from astroid) (1.10.0)
Building wheels for collected packages: wrapt
  Running setup.py bdist_wheel for wrapt ... done
  Stored in directory: /home/fabien/.cache/pip/wheels/48/5d/04/22361a593e70d23b1f7746d932802efe1f0e523376a74f321e
Successfully built wrapt
Installing collected packages: typed-ast, wrapt, lazy-object-proxy, astroid
Successfully installed astroid-2.0.4 lazy-object-proxy-1.3.1 typed-ast-1.1.0 wrapt-1.10.11
~ jt'écoute :

Essai de fstring dans ipython3:

~ jt'écoute :ipython3
Python 3.5.2 (default, Nov 23 2017, 16:37:01) 
Type "copyright", "credits" or "license" for more information.

IPython 2.4.1 -- An enhanced Interactive Python.
?         -> Introduction and overview of IPython's features.
%quickref -> Quick reference.
help      -> Python's own help system.
object?   -> Details about 'object', use 'object??' for extra details.

In [1]: age=10

In [2]: f"Jaan a {age} ans"
  File "<ipython-input-2-63c0dca4d229>", line 1
    f"Jaan a {age} ans"
                      ^
SyntaxError: invalid syntax

Et le répertoire ~/.local/lib/python3.6/site-packages/ n'existe pas :

~ jt'écoute :cd ~/.local/lib/python3.6/site-packages/
bash: cd: /home/fabien/.local/lib/python3.6/site-packages/: Aucun fichier ou dossier de ce type
~ jt'écoute :

....

Dernière modification par pseudofab (Le 23/09/2018, à 16:21)


# Là pour le plaisir de découvrir . En souvenir de l'ado dont les yeux brillaient d'émerveillement devant l'écran d'un Amstrad 6128 ...

# Débutant en tout ...  je me régale !

Hors ligne

#14 Le 23/09/2018, à 16:40

melixgaro

Re : [Résolu]Comment installer ipython pour python3.6 sur la 16.04?

pardon pour l'erreur dans le chemin, chez toi, ça doit être

ls -lh ~/.local/lib/python3.5/site-packages/

encore une fois, une fois ipython3 démarré, il faut commencer par

from fstring import fstring as f

ça permet d'activer dans ipython3.5 une fonction fstring, pour émuler les fstring qui ne sont livrés qu'en python 3.6

Voir ici. Tu noteras dans l'exemple donné sur cette page que la syntaxe est différente, il faudra faire

x = 5
f("{x}")   # f est ici une fonction

au lieu de

x = 5
f"{x}"

De toute façon, cette histoire n'est pas bloquante pour ton apprentissage de python.


Linux depuis ~2007. Xubuntu seulement.

Hors ligne

#15 Le 23/09/2018, à 16:44

melixgaro

Re : [Résolu]Comment installer ipython pour python3.6 sur la 16.04?

python est un composant trop essentiel pour ton système pour s'amuser à forcer une version. En tout cas, je n'ai pas l'expérience pour te guider dans cette aventure. Tant que tu seras en 16.04 et sauf si tu t'aventures à installer une autre version de python manuellement, tu seras bloqué en 3.5 (je pense).


Linux depuis ~2007. Xubuntu seulement.

Hors ligne

#16 Le 23/09/2018, à 17:07

pseudofab

Re : [Résolu]Comment installer ipython pour python3.6 sur la 16.04?

Je te remercie pour le temps que tu m'as accordé wink .
Tu as raison cette histoire n'est pas bloquante pour mon apprentissage .
Sinon , c'est parce que j'utilise la 16.04 que ipython3 n'est pas à jour ? Si c'est le cas , il est peut être temps que je pense à migrer vers la 18.04..


# Là pour le plaisir de découvrir . En souvenir de l'ado dont les yeux brillaient d'émerveillement devant l'écran d'un Amstrad 6128 ...

# Débutant en tout ...  je me régale !

Hors ligne

#17 Le 23/09/2018, à 17:23

melixgaro

Re : [Résolu]Comment installer ipython pour python3.6 sur la 16.04?

Je pense que oui, 16.04 te bloquera en 3.5. Si tu as du temps pour faire une migration tranquillement, pourquoi pas. N'oublie pas que : 1/ une mise-à-niveau peut foirer, 2/ il vaut mieux faire une installation propre de zéro, 3/ dans tous les cas, il faut en profiter pour mettre à jour ses sauvegardes, 4/ dans tous les cas, il faut commencer par tester la nouvelle version d'ubuntu via une session live (clé usb démarrable). Si tu n'as pas l'habitude et que ta 16.04 te satisfait, garde-la encore (les màj de sécurité sont assurées jusqu'en 2021 ; par contre, certains logiciels prendront du retard avec le temps, comme python).

Si la seule grosse différence entre 3.5 et 3.6 est cette histoire de fstring (d'ailleurs, merci, grâce à toi, j'ai découvert les fstring), je ne pense pas que ça vaille le coup de se tracasser. Tu as suffisamment à faire. D'ailleurs, pour écrire du code partageable, je dirais qu'il est trop tôt pour utiliser les fstring. Pense à tous ces utilisateurs en ubuntu 12.04 et 16.04 qui ont une version python inférieure à 3.6… Certains codent encore en python2…


Linux depuis ~2007. Xubuntu seulement.

Hors ligne

#18 Le 23/09/2018, à 19:00

pseudofab

Re : [Résolu]Comment installer ipython pour python3.6 sur la 16.04?

Je ne vais pas tenter la migration prochainement . D'ailleurs peut être qu'à terme j'essaierai une debian ...
Sinon je viens de lire une autre alternative de remplacement pour fstring  :

In [2]: age = 10
"Jean a {} ans".format(age)
Out[2]: 'Jean a 10 ans'

Bonne soirée, Fabien


# Là pour le plaisir de découvrir . En souvenir de l'ado dont les yeux brillaient d'émerveillement devant l'écran d'un Amstrad 6128 ...

# Débutant en tout ...  je me régale !

Hors ligne

#19 Le 23/09/2018, à 19:10

melixgaro

Re : [Résolu]Comment installer ipython pour python3.6 sur la 16.04?

encore désolé de t'avoir fait faire des manips pour rien.

En fait, la notation .format remplace la notation % (qui est clairement déconseillée maintenant). La notation f est une nouvelle façon de faire.
Tu peux spécifier le formater le texte dans {}. Par exemple,

"Jean a {:05d} ans".format(age)

imprimera un nombre entier (le 'd') avec cinq chiffres (le '05') en mettant autant de 0 que nécessaire en amont du nombre.

"Jean a {:s} ans".format(age)

échouera car age contient un entier et, avec la ligne ci-dessus, tu prétends que c'est un string. Voir .


Linux depuis ~2007. Xubuntu seulement.

Hors ligne

#20 Le 23/09/2018, à 19:40

metalux

Re : [Résolu]Comment installer ipython pour python3.6 sur la 16.04?

Bonsoir pseudofab,
J'ai pas tout lu mais as-tu réussi à installer ipython en version 3.6?
Si non je viens de le faire sur ubuntu-mate en suivant cette page: http://ubuntuhandbook.org/index.php/201 … 16-04-lts/

A chaque fois que tu veux utiliser ipython, passe cette commande:
sudo update-alternatives --config python3
et choisi la 3.6. Repasse en 3.5 après sinon tu auras des erreurs entre autre avec update-manager.
Le plus simple, un alias dans .bash_aliases pour basculer rapidement d'une version à l'autre:

alias mooc="sudo update-alternatives --config python3"

Hors ligne

#21 Le 23/09/2018, à 19:42

melixgaro

Re : [Résolu]Comment installer ipython pour python3.6 sur la 16.04?

oui, d'où ma mise en garde


Linux depuis ~2007. Xubuntu seulement.

Hors ligne

#22 Le 23/09/2018, à 21:09

pseudofab

Re : [Résolu]Comment installer ipython pour python3.6 sur la 16.04?

Super ça marche bien ainsi . smile:)
J'édite le titre du post et mon 1er message pour plus de clarté .
Merci metalux  ,
Merci melixgaro


# Là pour le plaisir de découvrir . En souvenir de l'ado dont les yeux brillaient d'émerveillement devant l'écran d'un Amstrad 6128 ...

# Débutant en tout ...  je me régale !

Hors ligne

#23 Le 28/09/2018, à 08:53

pseudofab

Re : [Résolu]Comment installer ipython pour python3.6 sur la 16.04?

Bonjour,
Avec cette solution je note cependant un souci avec l'importation d'une bibliothèque que je ne rencontre pas avec ipython3.5 ...

~ jt'écoute :ipython3
Python 3.6.5 (default, May  3 2018, 10:08:28) 
Type "copyright", "credits" or "license" for more information.

IPython 2.4.1 -- An enhanced Interactive Python.
?         -> Introduction and overview of IPython's features.
%quickref -> Quick reference.
help      -> Python's own help system.
object?   -> Details about 'object', use 'object??' for extra details.


In [1]: import numpy as np
---------------------------------------------------------------------------
ImportError                               Traceback (most recent call last)
<ipython-input-2-4ee716103900> in <module>()
----> 1 import numpy as np

/usr/lib/python3/dist-packages/numpy/__init__.py in <module>()
    178         return loader(*packages, **options)
    179 
--> 180     from . import add_newdocs
    181     __all__ = ['add_newdocs',
    182                'ModuleDeprecationWarning',

/usr/lib/python3/dist-packages/numpy/add_newdocs.py in <module>()
     11 from __future__ import division, absolute_import, print_function
     12 
---> 13 from numpy.lib import add_newdoc
     14 
     15 ###############################################################################

/usr/lib/python3/dist-packages/numpy/lib/__init__.py in <module>()
      6 from numpy.version import version as __version__
      7 
----> 8 from .type_check import *
      9 from .index_tricks import *
     10 from .function_base import *

/usr/lib/python3/dist-packages/numpy/lib/type_check.py in <module>()
      9            'common_type']
     10 
---> 11 import numpy.core.numeric as _nx
     12 from numpy.core.numeric import asarray, asanyarray, array, isnan, \
     13                 obj2sctype, zeros

/usr/lib/python3/dist-packages/numpy/core/__init__.py in <module>()
     12         os.environ[envkey] = '1'
     13         env_added.append(envkey)
---> 14 from . import multiarray
     15 for envkey in env_added:
     16     del os.environ[envkey]

ImportError: cannot import name 'multiarray'

Dernière modification par pseudofab (Le 28/09/2018, à 08:55)


# Là pour le plaisir de découvrir . En souvenir de l'ado dont les yeux brillaient d'émerveillement devant l'écran d'un Amstrad 6128 ...

# Débutant en tout ...  je me régale !

Hors ligne

#24 Le 28/09/2018, à 12:28

metalux

Re : [Résolu]Comment installer ipython pour python3.6 sur la 16.04?

Bonjour pseudofab,
Il faut passer par virtualenv pour isoler ton python 3.6 de ton environnement:

sudo update-alternatives --config python3

choisir python 3.6
Installer virtualenv et pip

sudo apt install virtualenv
sudo apt install python3-pip

Puis créer le répertoire de virtualenv et se rendre dedans:

virtualenv ~/mooc
cd ~/mooc/bin

Et enfin activer l'isolement et installer numpy dedans:

source activate
pip3 install numpy
ipython3
import numpy as np

Pour sortir de l'environnement d'isolement quand tu as finis, il faut utiliser la commande suivante:

deactivate

Et ne pas oublier de repasser sur python 3.5

sudo update-alternatives --config python3

Par la suite, tu auras juste à faire le choix de la version 3.6 puis:

cd ~/mooc/bin
source activate

et pour quitter

deactivate

Si tu veux supprimer un dossier d'isolement, il suffit de supprimer le dossier correspondant simplement avec rm -R ou en graphique après la commande deactivate. Cependant, conserve le au moins durant la durée du Mooc.

Dernière modification par metalux (Le 28/09/2018, à 12:33)

Hors ligne

#25 Le 28/09/2018, à 16:23

pseudofab

Re : [Résolu]Comment installer ipython pour python3.6 sur la 16.04?

Bonjour metalux,
merci pour ton soutient ,
encore des erreurs qui apparaissent  :

~/mooc/bin jt'écoute :pip3 install numpy
Traceback (most recent call last):
  File "/home/fabien/.local/bin/pip3", line 7, in <module>
    from pip._internal import main
ModuleNotFoundError: No module named 'pip._internal'
Error in sys.excepthook:
Traceback (most recent call last):
  File "/usr/lib/python3/dist-packages/apport_python_hook.py", line 63, in apport_excepthook
    from apport.fileutils import likely_packaged, get_recent_crashes
  File "/usr/lib/python3/dist-packages/apport/__init__.py", line 5, in <module>
    from apport.report import Report
  File "/usr/lib/python3/dist-packages/apport/report.py", line 30, in <module>
    import apport.fileutils
  File "/usr/lib/python3/dist-packages/apport/fileutils.py", line 23, in <module>
    from apport.packaging_impl import impl as packaging
  File "/usr/lib/python3/dist-packages/apport/packaging_impl.py", line 23, in <module>
    import apt
  File "/usr/lib/python3/dist-packages/apt/__init__.py", line 23, in <module>
    import apt_pkg
ModuleNotFoundError: No module named 'apt_pkg'

Original exception was:
Traceback (most recent call last):
  File "/home/fabien/.local/bin/pip3", line 7, in <module>
    from pip._internal import main
ModuleNotFoundError: No module named 'pip._internal'
(mooc) ~/mooc/bin jt'écoute :

j'ai essayé par la suite en vain pip3 install pip._internal puisque la 1ere erreur dit ModuleNotFoundError: No module named 'pip._internal'

~/mooc/bin jt'écoute :pip3 install pip._internal
Traceback (most recent call last):
  File "/home/fabien/.local/bin/pip3", line 7, in <module>
    from pip._internal import main
ModuleNotFoundError: No module named 'pip._internal'
Error in sys.excepthook:
Traceback (most recent call last):
  File "/usr/lib/python3/dist-packages/apport_python_hook.py", line 63, in apport_excepthook
    from apport.fileutils import likely_packaged, get_recent_crashes
  File "/usr/lib/python3/dist-packages/apport/__init__.py", line 5, in <module>
    from apport.report import Report
  File "/usr/lib/python3/dist-packages/apport/report.py", line 30, in <module>
    import apport.fileutils
  File "/usr/lib/python3/dist-packages/apport/fileutils.py", line 23, in <module>
    from apport.packaging_impl import impl as packaging
  File "/usr/lib/python3/dist-packages/apport/packaging_impl.py", line 23, in <module>
    import apt
  File "/usr/lib/python3/dist-packages/apt/__init__.py", line 23, in <module>
    import apt_pkg
ModuleNotFoundError: No module named 'apt_pkg'

Original exception was:
Traceback (most recent call last):
  File "/home/fabien/.local/bin/pip3", line 7, in <module>
    from pip._internal import main
ModuleNotFoundError: No module named 'pip._internal'
(mooc) ~/mooc/bin jt'écoute :

# Là pour le plaisir de découvrir . En souvenir de l'ado dont les yeux brillaient d'émerveillement devant l'écran d'un Amstrad 6128 ...

# Débutant en tout ...  je me régale !

Hors ligne