Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

#1 Le 29/12/2005, à 12:34

gizz

Lm-sensors et reglages de la vitesse des ventilateur

Bien donc comme j'avai le probleme , je n'arrivai pas a afficher mes temperature et regler mes ventilos je cree ce post en esperant que ca aide quelqu'un smile

je traduit le HOW TO du forum de la version officielle  (http://ubuntuforums.org/showthread.php? … ht=sensors et je rajoute le reglage des ventilos

Comment Installer et Configurer lm-sensors
========================

1. Installer lm-sensors par apt-get ou Synaptic.

sudo apt-get install lm-sensors

2. Lancer le script mkdev.sh comme decrit ci-dessous:

a. Copier le code ci-dessous et l'enregitrer sous un fichier nommé mkdev.sh (mettez le ou vous voulez).

#!/bin/bash

# Here you can set several defaults.

# The number of devices to create (max: 256)
NUMBER=32

# The owner and group of the devices
OUSER=root
OGROUP=root
# The mode of the devices
MODE=600

# This script doesn't need to be run if devfs is used
if [ -r /proc/mounts ] ; then
if grep -q "/dev devfs" /proc/mounts ; then
echo "You do not need to run this script as your system uses devfs."
exit;
fi
fi

i=0;

while [ $i -lt $NUMBER ] ; do
echo /dev/i2c-$i
mknod -m $MODE /dev/i2c-$i c 89 $i || exit
chown "$OUSER:$OGROUP" /dev/i2c-$i || exit
i=$[$i + 1]
done
#end of file

b. Rendre le fichier executable:

chmod 755 mkdev.sh

c. Lancer mkdev.sh depuis le repertoire courrant

sudo ./mkdev.sh

3. Maintenant lancez sensors-detect et repondez oui a toutes les questions .(il est possible que vous deviez charger quelques modules auparavant). Perso j'ai utiliser le ISA bus plutot que le SMBus ca c'est a vous de faire le choix!. A la fin de la detection, une liste de modules qui ont besoin d'etre chargés seront affichés. vous aurez besoin de noter ou imprimer la liste.

Note: a la fin de la detection il demande d'ecrire dans les fichiers etc/modules et un autre j'avai mis oui mais j'ai modifié opar apres comme ecri ci-dessous

Ci-dessous un exemple de resultat de sensors-detect:
#************************************************* *****************************

sudo sensors-detect

To make the sensors modules behave correctly, add these lines to
/etc/modules:

#----cut here----
# I2C adapter drivers
i2c-viapro
i2c-isa
# I2C chip drivers
eeprom
it87
#----cut here----

Then, run /etc/init.d/module-init-tools

To make the sensors modules behave correctly, add these lines to
/etc/modprobe.d/local and run update-modules:

#----cut here----
# I2C module options
alias char-major-89 i2c-dev
#----cut here----
#************************************************* *******************************


4. Dans cet exemple, nous ajoutons les modules dans l'ordre inverse dans "/etc/modules".

#************************************************* ***********************
# /etc/modules: kernel modules to load at boot time.
#
# This file should contain the names of kernel modules that are
# to be loaded at boot time, one per line. Comments begin with
# a "#", and everything on the line after them are ignored.

psmouse
mousedev
ide-cd
ide-disk
ide-generic
lp

#For lm-sensors, i2c modules
it87
i2c-viapro
i2c-isa

#end of file!
#************************************************* ****************

Note: Si vous remarquez il manque eeprom mais moi je l'ai ajoute qquand meme et ca n'a pas posé probleme

4. J'ai remarqué qu'il n'y avait pas de "/etc/modprobe.d/local" et que "alias char-major-89 i2c-dev" etait deja listé dans "/etc/modprobe.d/aliases". Donc je n'ai rien fait.

Note: euh la j'ai pas verifié chez moi mais je n'ai rien fait non plus


5.Maintenant chargez les modules manuellement en utilisant modprobe et mettez a jour les dependances.

sudo modprobe i2c-sensor
sudo modprobe i2c-viapro
sudo modprobe i2c-isa
sudo modprobe it87

sudo depmod -a <may not be needed!>
sudo update-modules <may not be needed!>

6. Maintenant testez la sortie de sensors en utilisant la commande "sensors".

sensors

************************************************** *****************
it87-isa-0290
Adapter: ISA adapter
VCore 1: +1.57 V (min = +1.42 V, max = +1.57 V) ALARM
VCore 2: +2.66 V (min = +2.40 V, max = +2.61 V) ALARM
+3.3V: +6.59 V (min = +3.14 V, max = +3.46 V) ALARM
+5V: +5.11 V (min = +4.76 V, max = +5.24 V)
+12V: +11.78 V (min = +11.39 V, max = +12.61 V)
-12V: -19.14 V (min = -12.63 V, max = -11.41 V) ALARM
-5V: +0.77 V (min = -5.26 V, max = -4.77 V) ALARM
Stdby: +5.00 V (min = +4.76 V, max = +5.24 V)
VBat: +3.12 V
fan1: 3668 RPM (min = 0 RPM, div =
fan2: 0 RPM (min = 664 RPM, div = ALARM
fan3: 0 RPM (min = 2657 RPM, div = 2) ALARM
M/B Temp: +39°C (low = +15°C, high = +40°C) sensor = thermistor
CPU Temp: +36°C (low = +15°C, high = +45°C) sensor = thermistor
Temp3: +96°C (low = +15°C, high = +45°C) sensor = diode
************************************************** ********************

7. Rebootez Ubuntu et les sondes devraient etre detectées correctement mainteant durant le boot !

8. La sortie de "sensors" peut etre configurer en editant le fichier "/etc/sensors.conf" file. Pour plus de details consultez le man avec "man sensors.conf.

Note: pas plus d'explication la dessus car je n'ai pas encore configuré mais ce fichier liste tous les tweak pour tous les chip je pense donc qu'il faut modifier seulement le chip concerné.

Maintenant pour ce qui est du reglage des ventilateur:

Dans une console lancez:

sudo pwmconfig

Au debut tapper faites entrée, il va tester vos differents ventilos en les arretants chacun 5 secondes donc faites gaffe a laisser un peu le cpu refroidir avant de lancer ca

Ensuite il vous propose des tests de vitesses

Apres vous avez un petit menu avec vos differents ventilo

Select fan output to configure, or other action:
1) 0-0290/pwm2         3) Change INTERVAL     5) Save and quit
2) 0-0290/pwm1         4) Just quit           6) Show configuration

Tappez le chiffre du ventilo que vous voulez regler
Puis il vous demande dans l'orde:
la temperature la plus basse (la ou le ventilo sera eteint)
la temperature la plus haute acceptée (la ou le ventilo sera a fond)
la vitesse minimum du ventilo acceptée (entre 0 et255)

Quand c'est terminé sauver la config en mettant le chiffre 5

Lancez fancontrol pour voir le changement:

sudo fancontrol

la suite dessous

Dernière modification par gizz (Le 29/12/2005, à 14:00)

Hors ligne

#2 Le 29/12/2005, à 13:56

gizz

Re : Lm-sensors et reglages de la vitesse des ventilateur

Fancontrol au demarrage traduit et synthetisé de http://ubuntuforums.org/showthread.php?t=42737

Bon c'etait ardu mais j'ai trouvé lol

On cree un fichier en ouvrant gedit en root:

sudo gedit

on colle ca dedant

#!/bin/sh
#
# Fancontrol start script.
#

set -e

# Defaults
DAEMON=/usr/sbin/fancontrol
PIDFILE=/var/run/fancontrol-pid
PATH=/sbin:/bin:/usr/sbin:/usr/bin

test -f $DAEMON || exit 0

. /lib/lsb/init-functions


case "$1" in
	start)
		log_begin_msg "Starting fancontrol daemon..."
		start-stop-daemon --start -o -q -m -b -p $PIDFILE -x $DAEMON
		log_end_msg $?
		;;
	stop)
		log_begin_msg "Stopping fancontrol daemon..."
		start-stop-daemon --stop -o -q -p $PIDFILE
		log_end_msg $?
		;;
	force-reload|restart)
		sh $0 stop
		sh $0 start
		;;
	*)
		log_success_msg "Usage: /etc/init.d/fancontrol {start|stop|restart|force-reload}"
		log_success_msg "  start - starts system-wide fancontrol service"
		log_success_msg "  stop  - stops system-wide fancontrol service"
		log_success_msg "  restart, force-reload - starts a new system-wide fancontrol service"
		exit 1
		;;
esac

exit 0

On l'enregistre dans /etc/init.d avec comme nom fancontrol

On le rend executable:

sudo chmod 0755 /etc/init.d/fancontrol

On fait un lien symbolique vers rcS.d par exemple

sudo ln -s /etc/init.d/fancontrol /etc/rcS.d/S99fancontrol

Et on reboot

En tout cas pour moi ca a marché tongue

Dernière modification par gizz (Le 29/12/2005, à 14:02)

Hors ligne

#3 Le 29/01/2006, à 18:04

guix

Re : Lm-sensors et reglages de la vitesse des ventilateur

La méthode fonctionne pour moi aussi.....

Mais dans /etc/fancontrol j'ai renseigné comme T°

min 32
max 45

le ventilateur fonctionne mais la T° CPU est à 40 en permanence hmm

en tapant la commande sensors, la vitesse de mon ventilo est tjs à 0

qq'un a-t-il une idée ?

#4 Le 25/02/2006, à 12:15

thbkrshw

Re : Lm-sensors et reglages de la vitesse des ventilateur

Merci gizz, pour ton tuto, tout marche parfaitement chez moi.
Juste une petite précision : au lieu de créer des liens symboliques pour mettre fancontrol au démarrage, il aurait mieux fallu utiliser cette ligne de commande :

update-rc.d fancontrol defaults

Jabber : thbkrshw@jabber.fr

Hors ligne

#5 Le 25/02/2006, à 15:18

ToY

Re : Lm-sensors et reglages de la vitesse des ventilateur

Moi je n'arrive jamais à avoir des sensors à par eeprom mais c'est ma mémoire vive...
Est-ce que c'est que mes sondes ne sont pas supportée ? Car sous windows j'avais bien des températures...

Merci !

Hors ligne

#6 Le 26/02/2006, à 22:44

skateinmars

Re : Lm-sensors et reglages de la vitesse des ventilateur

ToY a écrit :

Moi je n'arrive jamais à avoir des sensors à par eeprom mais c'est ma mémoire vive...
Est-ce que c'est que mes sondes ne sont pas supportée ? Car sous windows j'avais bien des températures...

Merci !

Essaye avec sensors-detect

Hors ligne

#7 Le 16/06/2006, à 17:43

patgrisly

Re : Lm-sensors et reglages de la vitesse des ventilateur

Salut,
Je crois que j'ai un solide problème de droits!
J'ai créé le script et lors du chmod ça donne ça

 sudo chmod 755 mkdev.sh
chmod: ne peut accéder `mkdev.sh': Aucun fichier ou répertoire de ce type

Je précise que j'ai mis le script dans home et que c'est la que j'ai lancé le terminal.

(hors sujet,enfin peut-etre !)après avoir fait une réinstallation d'ubuntu suite a  des soucis de partitions , j'ai a chaque démarrage une erreur de (blocs)
il me demande de faire e2fsk  .... <device> mais l'appli ne se lance pas.
Cela pourrait il être en rapport?
[edit] probleme de chroot reglé.:)

Dernière modification par patgrisly (Le 16/06/2006, à 23:13)


Seeks le moteur de recherche open source très efficace . Faites vous plaisir essayez le ou installez-le!
On en parle ici     http://forum.ubuntu-fr.org/viewtopic.php?id=384501&p=1

Hors ligne

#8 Le 28/06/2006, à 22:59

guga

Re : Lm-sensors et reglages de la vitesse des ventilateur

Bonjour smile

J'aimerais moi aussi pouvoir utiliser sensors detect (je soupconne un probleme de surchauffe responsble de l'apparition de traits bleus verts sur mon écran de temps en temps, problème recontré par plusieurs utilisateur d'ordis asus vraisemblablement mais jamais résolu à ma connaissance) mais j'ai un probleme :

l'execution du script mkdev ne fournit aucune sortie valide:

guga@ubuntu:~$ sudo sensors-detect
# sensors-detect revision 1.393 (2005/08/30 18:51:18)

This program will help you determine which I2C/SMBus modules you need to
load to use lm_sensors most effectively. You need to have i2c and
lm_sensors installed before running this program.
Also, you need to be `root', or at least have access to the /dev/i2c-*
files, for most things.
If you have patched your kernel and have some drivers built in, you can
safely answer NO if asked to load some modules. In this case, things may
seem a bit confusing, but they will still work.

It is generally safe and recommended to accept the default answers to all
questions, unless you know what you're doing.

 We can start with probing for (PCI) I2C or SMBus adapters.
 You do not need any special privileges for this.
 Do you want to probe now? (YES/no): YES
Probing for PCI bus adapters...
Sorry, no PCI bus adapters found.

We will now try to load each adapter module in turn.
If you have undetectable or unsupported adapters, you can have them
scanned by manually loading the modules before running this script.

 To continue, we need module `i2c-dev' to be loaded.
 If it is built-in into your kernel, you can safely skip this.
 i2c-dev is not loaded. Do you want to load it now? (YES/no): YES
 Module loaded succesfully.

 We are now going to do the adapter probings. Some adapters may hang halfway
 through; we can't really help that. Also, some chips will be double detected;
 we choose the one with the highest confidence value in that case.
 If you found that the adapter hung after probing a certain address, you can
 specify that address to remain unprobed. That often
 includes address 0x69 (clock chip).

Some chips are also accessible through the ISA bus. ISA probes are
typically a bit more dangerous, as we have to write to I/O ports to do
this. This is usually safe though.

Do you want to scan the ISA bus? (YES/no): YES
Probing for `National Semiconductor LM78'
  Trying address 0x0290... Failed!
Probing for `National Semiconductor LM78-J'
  Trying address 0x0290... Failed!
Probing for `National Semiconductor LM79'
  Trying address 0x0290... Failed!
Probing for `Winbond W83781D'
  Trying address 0x0290... Failed!
Probing for `Winbond W83782D'
  Trying address 0x0290... Failed!
Probing for `Winbond W83627HF'
  Trying address 0x0290... Failed!
Probing for `Winbond W83627EHF'
  Trying address 0x0290... Failed!
Probing for `Winbond W83697HF'
  Trying address 0x0290... Failed!
Probing for `Silicon Integrated Systems SIS5595'
  Trying general detect... Failed!
Probing for `VIA Technologies VT82C686 Integrated Sensors'
  Trying general detect... Failed!
Probing for `VIA Technologies VT8231 Integrated Sensors'
  Trying general detect... Failed!
Probing for `ITE IT8712F'
  Trying address 0x0290... Failed!
Probing for `ITE IT8705F / SiS 950'
  Trying address 0x0290... Failed!
Probing for `IPMI BMC KCS'
  Trying address 0x0ca0... Failed!
Probing for `IPMI BMC SMIC'
  Trying address 0x0ca8... Failed!

Some Super I/O chips may also contain sensors. Super I/O probes are
typically a bit more dangerous, as we have to write to I/O ports to do
this. This is usually safe though.

Do you want to scan for Super I/O sensors? (YES/no): YES
Probing for `ITE 8702F Super IO Sensors'
  Failed! (skipping family)
Probing for `Nat. Semi. PC87351 Super IO Fan Sensors'
  Failed! (skipping family)
Probing for `SMSC 47B27x Super IO Fan Sensors'
  Failed! (skipping family)
Probing for `VT1211 Super IO Sensors'
  Failed! (skipping family)
Probing for `Winbond W83627EHF/EHG Super IO Sensors'
  Failed! (skipping family)

Do you want to scan for secondary Super I/O sensors? (YES/no): YES
Probing for `ITE 8702F Super IO Sensors'
  Failed! (skipping family)
Probing for `Nat. Semi. PC87351 Super IO Fan Sensors'
  Failed! (skipping family)
Probing for `SMSC 47B27x Super IO Fan Sensors'
  Failed! (skipping family)
Probing for `VT1211 Super IO Sensors'
  Failed! (skipping family)
Probing for `Winbond W83627EHF/EHG Super IO Sensors'
  Failed! (skipping family)

 Sorry, no chips were detected.
 Either your sensors are not supported, or they are
 connected to an I2C bus adapter that we do not support.
 See doc/FAQ, doc/lm_sensors-FAQ.html, or
 http://www2.lm-sensors.nu/~lm78/cvs/lm_sensors2/doc/lm_sensors-FAQ.html
 (FAQ #4.24.3) for further information.
 If you find out what chips are on your board, see
 http://secure.netroedge.com/~lm78/newdrivers.html for driver status.

Mon ordi est un asus a6ja Q017H et une ati x1600

Que dois-je faire?

Merci par avance.


Halte au sketch! Réveillons-nous!
http://cluaran.free.fr/dette.html

Hors ligne

#9 Le 29/06/2006, à 00:40

patgrisly

Re : Lm-sensors et reglages de la vitesse des ventilateur

salut,
Il me semble que pour terminer l'install de i2c et sensors detect ,il faille rebooter,sinon
Je ne peux que te conseiller de suivre les 2 liens donnés par le système.
http://www2.lm-sensors.nu/~lm78/cvs/lm_ … s-FAQ.html
http://secure.netroedge.com/~lm78/newdrivers.html
J'y ai jeté un coup d'oeil ,la connaissance de l'anglais est nécessaire   :rolleyes
Cela dit ,avant ce tuto ,je lançais sensors detects sans rien faire d'autres et ça fonctionnais,a essayer peut-être.

Dernière modification par patgrisly (Le 29/06/2006, à 00:42)


Seeks le moteur de recherche open source très efficace . Faites vous plaisir essayez le ou installez-le!
On en parle ici     http://forum.ubuntu-fr.org/viewtopic.php?id=384501&p=1

Hors ligne

#10 Le 04/07/2006, à 09:49

guga

Re : Lm-sensors et reglages de la vitesse des ventilateur

Merci pour les infos...
J'ai en fait porté mon ordi au sav car un controle de température avec asus NB Probe m'a permis de constater que la température du proc montait allègrement à 70 °C alors que je ne faisais rien dessus. J'en ai déduit que les ventilos ne se lancaient pas....mais ce n'est pas facile à vérifier. On verra l'avis des experts asus.

Je donnerai des nouvelles dans .... longtemps smile


Halte au sketch! Réveillons-nous!
http://cluaran.free.fr/dette.html

Hors ligne

#11 Le 19/07/2006, à 23:59

NEOAKIRA

Re : Lm-sensors et reglages de la vitesse des ventilateur

J'ai suivi le tuto et j'ai un probleme:

neoakira@neoakira-desktop:~$ sudo modprobe i2c-sensor
FATAL: Module i2c_sensor not found.

Hors ligne

#12 Le 24/07/2006, à 01:08

hctim_53

Re : Lm-sensors et reglages de la vitesse des ventilateur

J'ai exactement le meme problème que NEOAKIRA et je ne sais pas comment faire....
tous les autres modules passent bien pourtant...
si qqu a une piste de recherche à me conseiller...

merci

#13 Le 04/08/2006, à 14:39

hctim_53

Re : Lm-sensors et reglages de la vitesse des ventilateur

up up wink

#14 Le 13/10/2006, à 19:41

hokkos

Re : Lm-sensors et reglages de la vitesse des ventilateur

Merci Beaucoup tu est mon sauveur, ca marche trés bien, tout est bcp plus silencieux maintenant big_smile .
Ca fait partie des 4 problemes que je cherchais a résourdre depuis des mois, ca fait plaisir de plus entendre le réacteur d'avion (p4 inside).

Hors ligne

#15 Le 02/12/2006, à 19:12

kiraff

Re : Lm-sensors et reglages de la vitesse des ventilateur

Mon ordi fait vraiment beaucoup trop de bruit, alors j'ai voulu mieux contrôler les ventilos
J'ai suivi tes indications, y a 3 ventilos dont là vitesse devrait pouvoir être affichée:

fan1
CPUfan
fan3

J'ai quatre prise sur la carte mère: 2 ventilo boitier inutilisées et apparemment on peut pas contrôler la vitesse (j'ai essayé une fois sous win avec un ventilo 3 broches)
une poure le processeur et une pour la carte mère

J'ai que le ventilo du chips reconnu (sous win je pouvais aussi régler le proc) comme "fan1"
autrement pour les températures: cpu, c bon, une autre ça doit être le DD et une troisième qui est toujours entre 17 et 19 °C, je sais pas à quoi ça correspond et ça me parait un peu bizarre.

Pour ma config, j'ai une carte msi avec un chips nforce3 et un athlon 64, le cool'n'quiet est activé dans le bios, ça marche pour la fréquence, mais par contre j'ai l'impression que le ventilo reste toujours à la même vitesse....

j'aimerais bien savoir à combien est mon ventilo pour le processeur et pouvoir le contrôler.....

Hors ligne

#16 Le 09/02/2007, à 18:54

Aguillem

Re : Lm-sensors et reglages de la vitesse des ventilateur

Tout comme neokira ci-dessus :

NEOAKIRA a écrit :

J'ai suivi le tuto et j'ai un probleme:

neoakira@neoakira-desktop:~$ sudo modprobe i2c-sensor
FATAL: Module i2c_sensor not found.

Le module i2c-sensor n'est pas trouvé lors de la commande précédente. J'ai essayé de me renseigner pour savoir comment je pourrais récupérer ce module, mais je n'ai rien trouvé... sad
Quelqu'un aurait-il une idée ?

#17 Le 11/02/2007, à 13:33

Aguillem

Re : Lm-sensors et reglages de la vitesse des ventilateur

Un petit up pour trouver de l'aide wink

#18 Le 17/02/2007, à 00:26

[Djoode]

Re : Lm-sensors et reglages de la vitesse des ventilateur

+1 pour le "Module i2c_sensor not found"

Mais j'ai tout de même continué,
$ sensors à l'air d'afficher des valeurs correctes;
Et au moment de faire :
$ sudo modprobe i2c-sensor
Ca me met ce message :
$ /usr/sbin/pwmconfig: There are no pwm-capable sensor modules installed

Si on pouvait nous aider smile j'en peux plus de mes ventillo qui tournent à 5000 RPM!

#19 Le 17/02/2007, à 12:57

Lonestar

Re : Lm-sensors et reglages de la vitesse des ventilateur

hello j'ai le même soucis après avoir suivi plein de tutou même en anglais...... please!! HELP!!

#20 Le 03/03/2007, à 16:22

SuperGuest

Re : Lm-sensors et reglages de la vitesse des ventilateur

FATAL: Module i2c_sensor not found.

Il suffit de recompiler le kernel en ajoutant les modules I2C necessaire je pense. (Character devices --> I2C support)

Quant à moi, j'aimerais connaître la température minimum et maximum que vous avez configuré.
Merci d'avance. wink

#21 Le 17/04/2007, à 22:33

Le Mouton Vert

Re : Lm-sensors et reglages de la vitesse des ventilateur

FATAL: Module i2c_sensor not found

+1 pour ce souci.
Je précise que je suis toujours dans ma quête pour résoudre ce problème là: http://forum.ubuntu-fr.org/viewtopic.php?id=110979

J'ai voulu connaître mes températures et hop... je débarque ici.

Tout ça pour dire: est-ce que quelqu'un est sûr qu'Il suffit de recompiler le kernel en ajoutant les modules I2C pour résoudre le problème?

Parce que ça me parait un peu ardu comme tâche, pour un débutant comme moi, et je ne voudrais pas me risquer à ça pour rien...

Merci d'avance,

LMV

Hors ligne

#22 Le 17/04/2007, à 23:26

Le Mouton Vert

Re : Lm-sensors et reglages de la vitesse des ventilateur

A priori, ce n'est pas utile pour les noyaux récents

Une piste, je cherche encore...
http://www.lm-sensors.org/wiki/Kernel2.6

Pour info, je suis sous kernel 2.6.17.

LMV

Dernière modification par Le Mouton Vert (Le 18/04/2007, à 00:19)

Hors ligne

#23 Le 18/04/2007, à 00:17

Le Mouton Vert

Re : Lm-sensors et reglages de la vitesse des ventilateur

Bien... je cale...

J'ai téléchargé ici (http://www.lm-sensors.org/wiki/iwizard/ManualInstall)l'archive de la version 2.10.3 de lm-sensors, qui semblait convenir à mon noyau.

Malheureusement, je n'ai pas réussi à la compiler (c'était une première pour moi).

Notez que pour cela, en plus de libsysfs et libsysfs-dev, il faut aussi avoir les paquets bison et flex installés (c'est peut-être évident pour les habitués mais bon... je ne les avais pas!).

Je bute maintenant sur l'erreur suivante:

...
collect2: ld returned 1 exit status
make: *** [prog/sensors/sensors] Erreur 1
$

SI ça vous parle, n'hésitez pas! Je n'ai plus la force de tordre Google pour comprendre (apprendre) encore...

Je ne sais pas si c'est bien raisonnable de laisser tout ça en plan mais il faut vraiment que j'aille dormir...

LMV

Hors ligne

#24 Le 01/05/2007, à 21:30

Qclinuxnw

Re : Lm-sensors et reglages de la vitesse des ventilateur

Bonjour à tous!

Moi aussi je cherche une solution au i2c-sensor not found. Quelqu'un peut-il confirmer s'il faut effectivement recompiler le noyau? Tout ces posts sont bien utiles, mais pour ma part, je n'y arrive toujours pas.

Faites signe s'il y a des développements, je fais de même!

Bye


Si j'avais SU, je ne serais pas venu

Ubuntu user #6994

Hors ligne

#25 Le 04/05/2007, à 18:55

nain-nain

Re : Lm-sensors et reglages de la vitesse des ventilateur

+1 même problème sad


Mon brique à brac: mes lego, notre sono et le modélisme auto
Si un bug voulait dire je t'aime, je t'offrirais Windows.

Hors ligne

Haut de page ↑