Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites". Attention, le forum rencontre actuellement quelques difficultés. En cas d'erreur 502, il ne faut pas re-valider l'envoi d'un message ou l'ouverture d'une discussion, au risque de créer un doublon.

La section divers se réorganise ! De nouvelles sous-sections à venir. (plus d'infos + donner son avis)

#1 Le 21/11/2008, à 22:45

ZavezPasVu

[Résolu] Installation EPSON Stylus NX400

Bonjour,

J'ai beaucoup galérer pour installer l'imprimante multifonction Epson Stylus SX400 sur Intrepid 64. Alors voici la démarche qui m'a permis de faire fonctionner l'imprimante et le scanner. Suivant les régions du monde cette multifonction porte aussi les références NX400 ou TX400.
L'idéal serait de passer par les pilotes Avasys mais je n'ai pas réussi à compiler les sources ni à les installer dans un chroot32.
Au final la solution est assez simple. Elle se base essentiellement sur deux articles du wiki de la documentation française Ubuntu : imprimante_epson_multifonctions et Scanner Epson

Imprimante
L'imprimante est bien reconnue comme une SX400 ; le pilote proposé est un modèle Epson Stylus Scan 2500. Mais impossible d'imprimer la page de test avec ce modèle. Choisir un modèle DX permet de régler le problème (j'ai choisi : DX4800 avec le pilote Epson Stylus DX4800 Foomatic/gutenprint-ijs-simplified.5.2 qui parait simple cependant le choix Epson Stylus DX8400 - CUPS+Gutenprint v5.2.0-rc1 autorise des réglages plus fins - réglage individuel de la densité de chaque couleur - et permet aussi de commander le nettoyage des têtes d'impression depuis l'ordinateur).

Scanner
Installer libsane-extras dans les dépôts universe (je suis allé chercher la dernière version disponible pour Ubuntu64 mais je pense que la version des dépôts conviendrait).
Scanner allumé, taper lsusb dans une console  pour vérifier le code de référence du scanner. J'obtiens en particulier "code fabricant":"code matériel" du scanner :

Bus 008 Device 002: ID 04b8:084a Seiko Epson Corp.

Pour indiquer à sane (et xsane) d'utiliser le pilote epkowa, créer dans le répertoire /etc/sane.d un fichier epkowa.conf

gksudo gedit /etc/sane.d/epkowa.conf

et créer la ligne

usb 0x04b8 0x084a

Si le fichier existe déjà il faut modifier la ligne commençant par usb. Attention les valeurs sont en hexa d'où le 0x devant chaque identifiant.

A ce stade un : 

scanimage -L

ne me permettait pas de trouver le scanner alors qu'il est trouvé avec :

sudo scanimage -L

Il faut changer les permissions de l'interface usb pour ce scanner. On ajoute une règle :

gksudo gedit /etc/udev/rules.d/50-libsane-extras.rules

en ajoutant entre les lignes LABEL="libsane_extras_rules_begin" et LABEL="libsane_extras_rules_end" :

# EPSON Stylus SX400 | EPSON Stylus SX400
SYSFS{idVendor}=="04b8", SYSFS{idProduct}=="084a", MODE="0666", GROUP="scanner", ENV{libsane_matched}="yes"

pour valider la nouvelle règle sans redémarrer la session faire :

sudo /etc/init.d/udev restart

Voilà, l'imprimante et le scanner devrait être fonctionnels.:D

Dernière modification par ZavezPasVu (Le 22/11/2008, à 11:20)

Hors ligne

#2 Le 22/12/2008, à 19:18

Calimo

Re : [Résolu] Installation EPSON Stylus NX400

Hello,
Merci pour le tuto très intéressant.;)
Je rencontre le même type de problèmes avec un scanner Epson Perfection 2580 Photo.

J'ai donc installé libsane-extras. Puis

> lsusb
(...)
Bus 002 Device 007: ID 04b8:0121 Seiko Epson Corp. Perfection 2480 Photo

j'ai créé /etc/sane.d/epkowa.conf avec la ligne "usb 0x04b8 0x0121".

xavier@ubuntu:~$ scanimage -L
No scanners were identified. If you were expecting something different,
check that the scanner is plugged in, turned on and detected by the
sane-find-scanner tool (if appropriate). Please read the documentation
which came with this software (README, FAQ, manpages).
xavier@ubuntu:~$ sudo scanimage -L
device `snapscan:libusb:002:007' is a EPSON EPSON Scanner flatbed scanner

Dans 50-libsane-extras.rules j'ai trouvé la ligne concernant le 2580

# EPSON Perfection 2580 PHOTO
SYSFS{idVendor}=="04b8", SYSFS{idProduct}=="0121", MODE="0664", GROUP="scanner", ENV{libsane_matched}="yes"

Et j'ai remplacé 0664 par 0666 :

SYSFS{idVendor}=="04b8", SYSFS{idProduct}=="0121", MODE="0666", GROUP="scanner", ENV{libsane_matched}="yes"
xavier@ubuntu:~$ sudo /etc/init.d/udev restart
 * Loading additional hardware drivers...                                [ OK ] 
xavier@ubuntu:~$ scanimage -L
device `snapscan:libusb:002:007' is a EPSON EPSON Scanner flatbed scanner

Ça a l'air bon... je lance donc xsane et là j'obtiens une fenêtre d'erreur de xsane : "Erreur d'ouverture du périphérique `snapscan:libusb:002:007': Argument invalide.
Dans la console j'ai ça :

xavier@ubuntu:~$ xsane
[snapscan] Cannot open firmware file /usr/share/sane/snapscan/your-firmwarefile.bin.
[snapscan] Edit the firmware file entry in snapscan.conf.

J'ai rajouté usb 0x04b8 0x0121 dans /etc/sane.d/snapscan.conf mais ça ne change rien... j'ai aussi commenté la ligne snapscan dans dll.conf, mais il ne trouve plus aucun scanner...

Je sens que je ne suis pas très loin... quel est le problème et que faire ? Pourquoi cherche-t-il a utiliser snapscan et pas epkowa ? J'ai pourtant bien ajouté la ligne epkowa en bas de dll.conf...

Merci ! smile
Xavier

Hors ligne

#3 Le 22/12/2008, à 19:47

Calimo

Re : [Résolu] Installation EPSON Stylus NX400

J'ai résolu mon problème !!
Sur le site d'Avasys (http://www.avasys.jp/lx-bin2/linux_e/scan/DL1.do) on peut télécharger un rpm pour i386 (iscan-plugin-gt-f500-1.0.0-1.c2.i386.rpm).
Dedans (gestionnaire d'archives), on trouve un fichier esfw41.bin. Comme c'est le firmware, ça ne pose pas de soucis, il dépend du scanner lui-même, donc fonctionne tout aussi bien sur amd64 !
Je l'ai copié dans /usr/share/sane/snapscan/esfw41.bin (après avoir créé le dossier snapscan), fait un chmod +r dessus, et mis à jour le fichier snapscan.conf (tout en haut, la ligne commençant par "firmware" et donnant le chemin complet de ce fichier). Et ça a l'air de marcher smile

Bonne chance à tous !
Xavier

Édition: précisions.

Dernière modification par Calimo (Le 22/12/2008, à 21:03)

Hors ligne

#4 Le 23/12/2008, à 21:32

Calimo

Re : [Résolu] Installation EPSON Stylus NX400

J'arrête de "squatter" ce sujet, car je me rend compte que le 2580 Photo est en fait totalement différent (utilisation de snapscan au lieu d'epkowa, pas besoin de libsane-extras et téléchargement du firmware à la place). Au final, seule la modification de 50-libsane-extras.rules est commune aux deux (ce n'est pas rien et je n'aurais jamais trouvé tout seul). J'ai donc résumé tout ça sur mon blog : http://xavablog.romandie.com/post/14066/140467 J'espère que ça pourra aussi servir !

PS : je voulais mettre à jour le wiki, mais ma modification contient des mots bloqués...
PPS : en fait il y a tout sur le wiki - juste dans l'anarchie la plus complète sad

Hors ligne

#5 Le 02/01/2009, à 10:58

jd.gonon

Re : [Résolu] Installation EPSON Stylus NX400

Salut ZavezPasVu

Pour ce noël, j'ai eu une imprimante EPSON SX400. J'ai utilisé tes conseils pour l'installer sous ubuntu : donc j'ai pris le pilote d'une EPSON DX4800.

Et ça n'a pas marché pour moi : l'impression d'un fichier contenant les couleurs BLEU et VERT ne fonctionnait pas avec ce pilote (du gris/marron est imprimé à la place du BLEU et VERT). L'impression du ROUGE et du JAUNE ne pose pas de souci.

Et l'impression depuis win Vista de ce même fichier contenant du BLEU + VERT + ROUGE + JAUNE ne pose aucun problème...

Voir mon précédent post : http://forum.ubuntu-fr.org/viewtopic.php?id=282749

Avec le bon pilote pour EPSON SX400, tout est OK

Merci quand même pour ton tuto.
JD

Dernière modification par jd.gonon (Le 04/01/2009, à 17:58)


Config : PC portable HP Pavilion dv9600
Ubuntu 10.10

Hors ligne

#6 Le 03/01/2009, à 10:07

ZavezPasVu

Re : [Résolu] Installation EPSON Stylus NX400

Merci pour l'information. Je n'avais pas constaté de problème quand j'ai testé l'imprimante avec les paramètres que j'ai indiqué. Maintenant je ne peux pas faire de test car elle est chez mes parents.
Par contre j'ai cherché un pilote EPSON SX400 via "nouvelle imprimante" dans la fenêtre de configuration de l'imprimante (obtenu par le menu Système/Administration/Impression) et je ne l'ai pas vu. Je ne l'ai pas davantage trouvée via l'interface de CUPS (http://localhost:631/) ce qui est... cohérent !
Peux-tu préciser le nom exact du pilote que tu utilises ?

Hors ligne

#7 Le 04/01/2009, à 18:09

jd.gonon

Re : [Résolu] Installation EPSON Stylus NX400

Pour le pilote utilisé, je pense que j'ai le pilote nécessaire à l'epson stylus SX400 suite à l'installation de ceci : pipslite_1.3.0-2_i386.deb , téléchargé sur AVASYS (http://www.avasys.jp/lx-bin2/linux_e/spc/DL1.do où tu sélectionnes le modèle Epson, ta distrib).

Par contre depuis que j'ai sélectionné ce pilote, la marge du haut des documents n'est jamais imprimée (voir ce post http://forum.ubuntu-fr.org/viewtopic.php?id=283231)
Je ne sais pas comment résoudre ce problème ....


Config : PC portable HP Pavilion dv9600
Ubuntu 10.10

Hors ligne

#8 Le 28/04/2009, à 10:54

compte supprimé

Re : [Résolu] Installation EPSON Stylus NX400

Bravo!!! ZavezPasVu

Presque un jour que j'essayer de faire aller mon scanner et grâce à toi ça fonctionne!!

petit génie...

Haut de page ↑