Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".

#1 Le 10/02/2009, à 17:42

Lyrical

[Réglé] Problème avec Teeworlds

Bonjour,


J'ai vu le jeu du mois qui était Teeworlds et je me suis empressé de l'essayer.

Je l'installe donc :

sudo apt-get install teeworlds

Yes! Installation parfaite!

Pourtant, je vais dans applications>jeux, je lance Teeworlds et là... bah rien! lol! Je réésaye plein de fois et rien du tout...

Vous pouvez essayer et me dire si ça marche? Ou quelqun a déjà eu ce problème? Car ça m'a l'air d'être un super jeu :
tee_join.png

Donc, je répète, pour l'installer par terminal :

sudo apt-get install teeworlds


Merci wink

Dernière modification par Lyrical (Le 11/02/2009, à 23:20)

Hors ligne

#2 Le 10/02/2009, à 18:04

mum1989

Re : [Réglé] Problème avec Teeworlds

tape
teeworlds
dans un terminal et poste ce que ça affiche


Aujourd’hui, le standard est Windows, l’exception MacOS.
Demain, le standard sera GNU/Linux, les exceptions MacOS et Windows.

Hors ligne

#3 Le 10/02/2009, à 18:06

Lyrical

Re : [Réglé] Problème avec Teeworlds

mum1989 a écrit :

tape
teeworlds
dans un terminal et poste ce que ça affiche

Pas de soucis :

[4991a601][engine]: running on unix-linux-ia32
[4991a601][engine]: arch is little endian
[4991a601][binds]: bound f1 (258) = toggle_local_console
[4991a601][binds]: bound f2 (259) = toggle_remote_console
[4991a601][binds]: bound tab (293) = +scoreboard
[4991a601][binds]: bound f10 (267) = screenshot
[4991a601][binds]: bound a (65) = +left
[4991a601][binds]: bound d (68) = +right
[4991a601][binds]: bound space (32) = +jump
[4991a601][binds]: bound mouse1 (384) = +fire
[4991a601][binds]: bound mouse2 (385) = +hook
[4991a601][binds]: bound lshift (287) = +emote
[4991a601][binds]: bound 1 (49) = +weapon1
[4991a601][binds]: bound 2 (50) = +weapon2
[4991a601][binds]: bound 3 (51) = +weapon3
[4991a601][binds]: bound 4 (52) = +weapon4
[4991a601][binds]: bound 5 (53) = +weapon5
[4991a601][binds]: bound mousewheelup (383) = +prevweapon
[4991a601][binds]: bound mousewheeldown (382) = +nextweapon
[4991a601][binds]: bound t (84) = chat all
[4991a601][binds]: bound y (89) = chat team
[4991a601][console]: executing '/home/lyrical/.teeworlds/settings.cfg'
[4991a601][binds]: bound space (32) = +jump
[4991a601][binds]: bound 1 (49) = +weapon1
[4991a601][binds]: bound 2 (50) = +weapon2
[4991a601][binds]: bound 3 (51) = +weapon3
[4991a601][binds]: bound 4 (52) = +weapon4
[4991a601][binds]: bound 5 (53) = +weapon5
[4991a601][binds]: bound a (65) = +left
[4991a601][binds]: bound d (68) = +right
[4991a601][binds]: bound t (84) = chat all
[4991a601][binds]: bound y (89) = chat team
[4991a601][binds]: bound f1 (258) = toggle_local_console
[4991a601][binds]: bound f2 (259) = toggle_remote_console
[4991a601][binds]: bound f10 (267) = screenshot
[4991a601][binds]: bound lshift (287) = +emote
[4991a601][binds]: bound tab (293) = +scoreboard
[4991a601][binds]: bound mousewheeldown (382) = +nextweapon
[4991a601][binds]: bound mousewheelup (383) = +prevweapon
[4991a601][binds]: bound mouse1 (384) = +fire
[4991a601][binds]: bound mouse2 (385) = +hook
[4991a601][console]: failed to open '/home/lyrical/.teeworlds/autoexec.cfg'
[4991a601][game]: failed to create gl context
Erreur de segmentation

Merci

Dernière modification par Lyrical (Le 10/02/2009, à 18:07)

Hors ligne

#4 Le 10/02/2009, à 18:09

mum1989

Re : [Réglé] Problème avec Teeworlds

ok essaye de faire toujours dans un terminal
sudo chmod 777 /home/lyrical/.teeworlds/autoexec.cfg

(je pense que tu as un probleme de droit d'ecriture sur le fichier de config autoexec.cfg

et relance le jeux pour tester

Dernière modification par mum1989 (Le 10/02/2009, à 18:10)


Aujourd’hui, le standard est Windows, l’exception MacOS.
Demain, le standard sera GNU/Linux, les exceptions MacOS et Windows.

Hors ligne

#5 Le 10/02/2009, à 18:16

Lyrical

Re : [Réglé] Problème avec Teeworlds

Merci! Mais...

chmod: ne peut accéder `/home/lyrical/.teeworlds/autoexec.cfg': Aucun fichier ou dossier de ce type

^^

Hors ligne

#6 Le 10/02/2009, à 18:18

mum1989

Re : [Réglé] Problème avec Teeworlds

essaye plutot
sudo chmod 777 "/home/lyrical/.teeworlds/autoexec.cfg"

(ou sinon
fait
cd /home/lyrical/.teeworlds/

puis
sudo chmod 777 autoexec.cfg


Aujourd’hui, le standard est Windows, l’exception MacOS.
Demain, le standard sera GNU/Linux, les exceptions MacOS et Windows.

Hors ligne

#7 Le 10/02/2009, à 18:28

Lyrical

Re : [Réglé] Problème avec Teeworlds

Voilà :

lyrical@ubuntu:~$ cd /home/lyrical/.teeworlds/
lyrical@ubuntu:~/.teeworlds$ sudo chmod 777 autoexec.cfg
chmod: ne peut accéder `autoexec.cfg': Aucun fichier ou dossier de ce type
lyrical@ubuntu:~/.teeworlds$

Donc, le dossier existe bien... Mais c'est la commande sudo chmod 777 autoexec.cfg qui bug...

Hors ligne

#8 Le 10/02/2009, à 18:31

mum1989

Re : [Réglé] Problème avec Teeworlds

non je pense que c'est plutot que soit le fichier n'existe pas, soit c'est un fichier caché
ouvre l'explorateur de fichier aussi pour regarder dans /home/lyrical/.teeworlds/ si tu as ce fichier autoexec.cfg
(fait CTRL+H pour afficher les dossiers et les fichiers cachés)


?
bizarre
fait ls pour voir tous les fichiers

(ps: toujours dans le répertoire /home/lyrical/.teeworlds/)

Dernière modification par mum1989 (Le 10/02/2009, à 18:33)


Aujourd’hui, le standard est Windows, l’exception MacOS.
Demain, le standard sera GNU/Linux, les exceptions MacOS et Windows.

Hors ligne

#9 Le 10/02/2009, à 18:37

Lyrical

Re : [Réglé] Problème avec Teeworlds

Non je ne l'ai pas...
J'ai le dossier .teeworlds mais pas autoexec.cfg

Hors ligne

#10 Le 10/02/2009, à 18:46

mum1989

Re : [Réglé] Problème avec Teeworlds

laisse beton cela ne vient pas de la
j'ai aussi ce message d'erreur sous mon archlinux

failed to open '/home/lyrical/.teeworlds/autoexec.cfg'

mais le jeux démarre   !!!
donc tu dois avoir un probleme de pilote graphique ou d'accéleration graphique
ou un probleme de dépandance de jeux

tente quand même un sudo chmod 777  "/home/lyrical/.teeworlds/"


as tu l'accélération graphique d'activée
pour vérifier tape cette commande :

glxinfo | grep "direct rendering"

quel est ta carte graphique amd , intel nvidia ?
c'est ubuntu 8.04 ou 8.10?

Dernière modification par mum1989 (Le 10/02/2009, à 18:47)


Aujourd’hui, le standard est Windows, l’exception MacOS.
Demain, le standard sera GNU/Linux, les exceptions MacOS et Windows.

Hors ligne

#11 Le 10/02/2009, à 18:53

mum1989

Re : [Réglé] Problème avec Teeworlds

sinon autre methode
comme dit abelthorne :
http://forum.kubuntu-fr.org/viewtopic.php?id=223390

Pas besoin de l'installer, copie juste le dossier où tu veux et lance le jeu via le lanceur en question. Si vraiment tu voulais que le jeu soit installé au niveau système (l'intérêt principal étant qu'il soit alors utilisable par tous les utilisateurs, ce qui devient caduque si tu es seul à utiliser ton PC), le plus simple serait de récupérer un paquet DEB, par exemple sur GetDeb (le paquet est pour Gutsy mais il devrait s'installer sous Hardy sans problème).

Donc, vérifie les droits sur le dossier .teeworlds et son contenu.

Sinon, je crois me souvenir que Teeworlds a quelques problèmes s'il n'est pas lancé depuis son dossier. En le lançant depuis le terminal, pas de souci, mais depuis Nautilus ça peut poser problème. Dans ce cas-là, le plus simple est de créer un simple lanceur :
- Crée un fichier texte dans le dossier de TeeWorlds
- Copie ce qui suit dedans :
#!/bin/bash
cd /home/tonnom/chemin/vers/tw
./teeworlds
(en remplaçant /home/tonnom/chemin/vers/tw par le chemin correct qui contient les fichiers du jeu)
- Enregistre le fichier, par exemple sous le nom start_teeworlds
- Rends-le exécutable (depuis les propriétés du fichier)
Tu n'as plus qu'à lancer ce fichier au lieu du teeworlds original. Si tu veux créer un lanceur sur le bureau ou dans le menu, fais-le sur ce fichier.

Aujourd’hui, le standard est Windows, l’exception MacOS.
Demain, le standard sera GNU/Linux, les exceptions MacOS et Windows.

Hors ligne

#12 Le 10/02/2009, à 18:57

Lyrical

Re : [Réglé] Problème avec Teeworlds

mum1989 a écrit :

tente quand même un sudo chmod 777  "/home/lyrical/.teeworlds/"

Voilà, c'est fait, le jeu se lance pas... ^^



mum1989 a écrit :

as tu l'accélération graphique d'activée
pour vérifier tape cette commande :

glxinfo | grep "direct rendering"
lyrical@ubuntu:~$ glxinfo | grep "direct rendering"
direct rendering: No (If you want to find out why, try setting LIBGL_DEBUG=verbose)

Non, comment dois-je activer l'accélération graphique?



mum1989 a écrit :

quel est ta carte graphique amd , intel nvidia ?
c'est ubuntu 8.04 ou 8.10?

00:00.0 Host bridge: Intel Corporation 82945G/GZ/P/PL Memory Controller Hub (rev 02)
00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 01)
00:1c.0 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 1 (rev 01)
00:1d.0 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #1 (rev 01)
00:1d.1 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #2 (rev 01)
00:1d.2 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #3 (rev 01)
00:1d.3 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #4 (rev 01)
00:1d.7 USB Controller: Intel Corporation 82801G (ICH7 Family) USB2 EHCI Controller (rev 01)
00:1e.0 PCI bridge: Intel Corporation 82801 PCI Bridge (rev e1)
00:1f.0 ISA bridge: Intel Corporation 82801GB/GR (ICH7 Family) LPC Interface Bridge (rev 01)
00:1f.2 IDE interface: Intel Corporation 82801GB/GR/GH (ICH7 Family) SATA IDE Controller (rev 01)
00:1f.3 SMBus: Intel Corporation 82801G (ICH7 Family) SMBus Controller (rev 01)
01:00.0 VGA compatible controller: ATI Technologies Inc RV535 [Radeon X1650 Series] (rev 9e)
01:00.1 Display controller: ATI Technologies Inc RV535 [Radeon X1650 Series] (rev 9e)
02:05.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL-8110SC/8169SC Gigabit Ethernet (rev 10)

J'ai une Radeon X1650 Series. Elle n'est pas operationelle, j'en parle ICI
Sinon, j'ai Ubunru (Gnome) 8.10 Intrepid Ibex.



Merci

Hors ligne

#13 Le 10/02/2009, à 19:00

mum1989

Re : [Réglé] Problème avec Teeworlds

 glxinfo | grep "direct rendering"
direct rendering: No

be dans ce cas la aucun jeux démarera ou presque

J'ai une Radeon X1650 Series. Elle n'est pas operationelle, j'en parle ICI
Sinon, j'ai Ubuntu (Gnome) 8.10 Intrepid Ibex.

be cela vient de la, pas d'acceleration graphique ; donc le jeux démarre pas

il faut que ta carte graphique soit "opérationnelle" comme tu dis pour démarer le jeux

Dernière modification par mum1989 (Le 10/02/2009, à 19:03)


Aujourd’hui, le standard est Windows, l’exception MacOS.
Demain, le standard sera GNU/Linux, les exceptions MacOS et Windows.

Hors ligne

#14 Le 10/02/2009, à 19:04

Lyrical

Re : [Réglé] Problème avec Teeworlds

Ok, merci...

J'essaye donc de régler mon problème de carte graphique et je refais signe si tout marche bien wink



Merci encore!

Hors ligne

#15 Le 10/02/2009, à 20:21

Lyrical

Re : [Réglé] Problème avec Teeworlds

lyrical@ubuntu:~$ glxinfo | grep "direct rendering"
direct rendering: Yes

Héhé la classe!


Mais de temps en temps l'écran se fige et le jeu bug... Quelles combinaisons de touche y a t-il pour :
1) Revenir au bureau?
2) Relancer gnome?


Merci

Hors ligne

#16 Le 10/02/2009, à 20:51

mum1989

Re : [Réglé] Problème avec Teeworlds

Mais de temps en temps l'écran se fige et le jeu bug
bizarre
teste avec un autre jeux linux
par exemple
racer
ou urban terror
laquelle version de teeworld as tu ?

Quelles combinaisons de touche y a t-il pour :
1) Revenir au bureau?
2) Relancer gnome?

sinon tu peut killer teewolrd
donc tu fait
CTRL+ALT+F2 (de F1 à F7)
tu rentre ton login
tu fait

[b]sudo killall -TERM teeworlds[/b]

et tu fait
CTRL+ALT+F7 pour revenir a l'interface graphique (gnome)
(si je me trompe pas F7)


tu as ubuntu 8.04 ou 8.10 ?

Dernière modification par mum1989 (Le 10/02/2009, à 20:55)


Aujourd’hui, le standard est Windows, l’exception MacOS.
Demain, le standard sera GNU/Linux, les exceptions MacOS et Windows.

Hors ligne

#17 Le 10/02/2009, à 21:02

Lyrical

Re : [Réglé] Problème avec Teeworlds

J'ai Ubuntu (Gnome) 8.10 Intrepid Ibex.
Merci mais si je reviens à l'interface graphique, je reviens à celle du jeu, pas au bureau... ^^

Hors ligne

#18 Le 10/02/2009, à 21:18

mum1989

Re : [Réglé] Problème avec Teeworlds

ok

Merci mais si je reviens à l'interface graphique, je reviens à celle du jeu, pas au bureau...

be non si tu as killé  avant le processus teeworlds (terminé le processus)
tu reviendra au bureau (si ça fonctionne)

au pire tu fait CTRL+ALT+BACKSPACE(la touche au-dessus entree)
ça redemarrera l'interface graphique gnome carement
et faudra te reloguer


Aujourd’hui, le standard est Windows, l’exception MacOS.
Demain, le standard sera GNU/Linux, les exceptions MacOS et Windows.

Hors ligne

#19 Le 11/02/2009, à 02:39

Lyrical

Re : [Réglé] Problème avec Teeworlds

Ok, merci beaucoup!

Bon, plusieurs jeux ne fonctionnent pas sur Ubuntu (chez moi), alors que la carte video fonctionne bien...

Exemple avec FlightGear, il se lance mais reste en dessous dans la barre de taches...

Hors ligne

#20 Le 11/02/2009, à 10:28

mum1989

Re : [Réglé] Problème avec Teeworlds

Exemple avec FlightGear, il se lance mais reste en dessous dans la barre de taches...

???
a très bizarre encore une fois
tu n'aurais pas compiz d'activé ?
désactive le si tu l'a d'activé

Dernière modification par mum1989 (Le 11/02/2009, à 10:29)


Aujourd’hui, le standard est Windows, l’exception MacOS.
Demain, le standard sera GNU/Linux, les exceptions MacOS et Windows.

Hors ligne

#21 Le 11/02/2009, à 16:12

Lyrical

Re : [Réglé] Problème avec Teeworlds

Oui j'ai compiz...
Comment le desactiver?

Hors ligne

#22 Le 11/02/2009, à 21:45

mum1989

Re : [Réglé] Problème avec Teeworlds

c'est ça le problème
pour le désactiver
tu vas dans système--------->préférences--------->apparences------------->effets visuels
tu cliques sur "Aucun"(fournit un environnement de travail simple sans  aucun effet., donc sans compiz)

(pour le réactiver plus tard coche  Extra


ou aussi tu peux installer fusion-icon pour le désactiver/activer facilement compiz


plus d'aide sur compiz et fusion-icon ici :
http://doc.ubuntu-fr.org/compiz_fusion


Aujourd’hui, le standard est Windows, l’exception MacOS.
Demain, le standard sera GNU/Linux, les exceptions MacOS et Windows.

Hors ligne

#23 Le 11/02/2009, à 22:13

Lyrical

Re : [Réglé] Problème avec Teeworlds

Ok merci, je vais tester et je te dis plus tard si ça marche...

Hors ligne

#24 Le 11/02/2009, à 22:17

Lyrical

Re : [Réglé] Problème avec Teeworlds

Shiiiiiiiiiiiiiiiiiiiiiiiiiiiiiiiiiiiiiiiiiiiiiiiiiiiiiiiiiiit!!!
Nikel!!!! Même les films marchent bien!!!!!!!

Merci milles et milles fois!!!!!!!!!!
Vive Ubuntu!!!

Je te jure, si ça ne tenait qu'à moi, je désinstallerais Windows... Le blem' c'est que l'I-Pod n'est pas reconnu à 100%... sad


Bon, pour te remercier, une petite vanne : "Que fait une blonde avec l'oreille contre une maison?"
Bah elle écoute de la "house" tongue

La blague est Open-Source, tu peux modifier "blonde" par ce que tu veux wink

Dernière modification par Lyrical (Le 11/02/2009, à 22:21)

Hors ligne

#25 Le 12/02/2009, à 00:29

mum1989

Re : [Réglé] Problème avec Teeworlds

Je te jure, si ça ne tenait qu'à moi, je désinstallerais Windows...

c'est ce que j'ai fait sur mon vieux pc fixe
il n'a que linux maintenant et pour toujours



Le blem' c'est que l'I-Pod n'est pas reconnu à 100%...

a quelle idée d'acheter un appareil avec un systeme propriétaire, (non je déconne)

quels sont tes soucis rencontrés ?
tu as essayé avec rhythmbox ?
(un lecteur censé supporter l'ipod)  :
http://doc.ubuntu-fr.org/rhythmbox

ou,  as tu  lu l'aide sur l'ipod d'ubuntu ? ici :
http://doc.ubuntu-fr.org/ipod#mode_d_emploi

Dernière modification par mum1989 (Le 12/02/2009, à 00:30)


Aujourd’hui, le standard est Windows, l’exception MacOS.
Demain, le standard sera GNU/Linux, les exceptions MacOS et Windows.

Hors ligne

Haut de page ↑