Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails) *** mise à jour 12/10/2014 ***

#1 Le 19/11/2009, à 19:38

Gamuti

[Résolu] Plantage de PRBOOM sous Ubuntu 9.10

Salut à tous.

J'ai fait la mise à jour de Ubuntu 9.04 vers 9.10. Mais depuis, Prboom ne fonctionne plus.
Il semblerait que cela soit dû à un problème de rendu 3D, alors que prboom fonctionnait sous ubuntu 9.04...

J'ai tenté de désinstaller proprement prboom et freedoom puis de le réinstaller (via synaptics) mais le problème persiste.

Prboom se lance correctement, affichage et navigation dans le menu sans problème, mais prboom se ferme au bout de quelques secondes (environ 10 secondes).

J'ai même tenté de désactivé l'openGl mais le problème persiste (donc, le problème n'est pas là).

Qui peut m'aider ?

Gamuti

Dernière modification par Gamuti (Le 29/11/2009, à 21:05)

Hors ligne

#2 Le 22/11/2009, à 12:24

Lancelin

Re : [Résolu] Plantage de PRBOOM sous Ubuntu 9.10

Salut !

Le problème est dans la version installée par le Koala...
Tu vas sur le site des paquets Ubuntu, Jaunty (9.04), Jeux, prboom et tu télécharges l'ancienne version que tu installes.
Il faudra bien évidemment bloquer la version dans Synaptic (Paquet --> cocher la case Bloquer la version).
Chez moi la musique ne fonctionne pas. Mais c'est peut-être dû aux nombreux tripatouillages...

#3 Le 24/11/2009, à 09:32

Gamuti

Re : [Résolu] Plantage de PRBOOM sous Ubuntu 9.10

Tiens, Comment vas-tu ? ça fait un bail !

En fait, j'avais même installé manuellement prboom depuis les sources disponibles sur sourceforge. Mais ce n'est pas mieux.

Je m'en vais utiliser ta méthode pour l'installation avec synaptics avec blocage de version.

Hors ligne

#4 Le 24/11/2009, à 18:01

Gamuti

Re : [Résolu] Plantage de PRBOOM sous Ubuntu 9.10

J'ai tenté d'installer prboom en utilisant ta méthode (blocage de version dans synaptics) mais impossible de forcer une version.
Qu'à cela ne tienne ! j'ai donc compilé la version 2.4.7 depuis les sources mais ça plante toujours au bout d'une petite dizaine de secondes de fonctionnement.

Voici ce que me renvoi la ligne de commande :

prboom v2.4.7 (http://prboom.sourceforge.net/)
laurent@laurent:/media/media/soft/prboom-2.4.7/src$ '/media/media/soft/prboom-2.4.7/src/prboom' -iwad '/media/media/soft/armadosia/armadosia/DOOM2.WAD' -vidmode gl

prboom v2.4.7 (http://prboom.sourceforge.net/)
M_LoadDefaults: Load system defaults.
 default file: /home/laurent/.prboom/prboom.cfg
 found /media/media/soft/armadosia/armadosia/DOOM2.WAD
IWAD found: /media/media/soft/armadosia/armadosia/DOOM2.WAD
PrBoom (built Nov 24 2009), playing: DOOM 2: Hell on Earth
PrBoom is released under the GNU General Public license v2.0.
You are welcome to redistribute it under certain conditions.
It comes with ABSOLUTELY NO WARRANTY. See the file COPYING for details.
V_Init: allocate screens.
 found /usr/local/share/games/doom/prboom.wad
D_InitNetGame: Checking for network game.
W_Init: Init WADfiles.
 adding /media/media/soft/armadosia/armadosia/DOOM2.WAD
 adding /usr/local/share/games/doom/prboom.wad
W_InitCache

M_Init: Init miscellaneous info.
R_Init: Init DOOM refresh daemon - 
R_LoadTrigTables: Endianness...ok.
R_InitData: Textures Flats Sprites 
R_Init: R_InitPlanes R_InitLightTables R_InitSkyMap R_InitTranslationsTables R_InitPatches 
P_Init: Init Playloop state.
I_Init: Setting up machine state.
I_InitSound:  configured audio device with 1024 samples/slice
I_InitSound: sound module ready
S_Init: Setting up sound.
S_Init: default sfx volume 8
HU_Init: Setting up heads up display.
I_InitGraphics: 1440x900
I_UpdateVideoMode: 1440x900 (fullscreen)
V_InitMode: using OpenGL video mode
I_SetRes: Using resolution 1440x900
I_UpdateVideoMode: 0x80000002, own buffer, direct access
SDL OpenGL PixelFormat:
    SDL_GL_RED_SIZE: 8
    SDL_GL_GREEN_SIZE: 8
    SDL_GL_BLUE_SIZE: 8
    SDL_GL_STENCIL_SIZE: 0
    SDL_GL_ACCUM_RED_SIZE: 16
    SDL_GL_ACCUM_GREEN_SIZE: 16
    SDL_GL_ACCUM_BLUE_SIZE: 16
    SDL_GL_ACCUM_ALPHA_SIZE: 16
    SDL_GL_DOUBLEBUFFER: 1
    SDL_GL_BUFFER_SIZE: 32
    SDL_GL_DEPTH_SIZE: 24
GL_VENDOR: NVIDIA Corporation
GL_RENDERER: GeForce FX 5200/AGP/SSE2
GL_VERSION: 2.1.2 NVIDIA 173.14.20
GL_EXTENSIONS:
	GL_ARB_depth_texture
	GL_ARB_fragment_program
	GL_ARB_fragment_program_shadow
	GL_ARB_fragment_shader
	GL_ARB_half_float_pixel
	GL_ARB_imaging
	GL_ARB_multisample
	GL_ARB_multitexture
	GL_ARB_occlusion_query
	GL_ARB_pixel_buffer_object
	GL_ARB_point_parameters
	GL_ARB_point_sprite
	GL_ARB_shadow
	GL_ARB_shader_objects
	GL_ARB_shading_language_100
	GL_ARB_texture_border_clamp
	GL_ARB_texture_compression
	GL_ARB_texture_cube_map
	GL_ARB_texture_env_add
	GL_ARB_texture_env_combine
	GL_ARB_texture_env_dot3
	GL_ARB_texture_mirrored_repeat
	GL_ARB_texture_rectangle
	GL_ARB_transpose_matrix
	GL_ARB_vertex_buffer_object
	GL_ARB_vertex_program
	GL_ARB_vertex_shader
	GL_ARB_window_pos
	GL_S3_s3tc
	GL_EXT_texture_env_add
	GL_EXT_abgr
	GL_EXT_bgra
	GL_EXT_blend_color
	GL_EXT_blend_func_separate
	GL_EXT_blend_minmax
	GL_EXT_blend_subtract
	GL_EXT_compiled_vertex_array
	GL_EXT_Cg_shader
	GL_EXT_draw_range_elements
	GL_EXT_fog_coord
	GL_EXT_framebuffer_blit
	GL_EXT_framebuffer_multisample
	GL_EXT_framebuffer_object
	GL_EXT_gpu_program_parameters
	GL_EXT_multi_draw_arrays
	GL_EXT_packed_depth_stencil
	GL_EXT_packed_pixels
	GL_EXT_paletted_texture
	GL_EXT_pixel_buffer_object
	GL_EXT_point_parameters
	GL_EXT_rescale_normal
	GL_EXT_secondary_color
	GL_EXT_separate_specular_color
	GL_EXT_shadow_funcs
	GL_EXT_shared_texture_palette
	GL_EXT_stencil_two_side
	GL_EXT_stencil_wrap
	GL_EXT_texture3D
	GL_EXT_texture_compression_s3tc
	GL_EXT_texture_cube_map
	GL_EXT_texture_edge_clamp
	GL_EXT_texture_env_combine
	GL_EXT_texture_env_dot3
	GL_EXT_texture_filter_anisotropic
	GL_EXT_texture_lod
	GL_EXT_texture_lod_bias
	GL_EXT_texture_object
	GL_EXT_texture_sRGB
	GL_EXT_timer_query
	GL_EXT_vertex_array
	GL_IBM_rasterpos_clip
	GL_IBM_texture_mirrored_repeat
	GL_KTX_buffer_region
	GL_NV_blend_square
	GL_NV_copy_depth_to_color
	GL_NV_depth_clamp
	GL_NV_fence
	GL_NV_float_buffer
	GL_NV_fog_distance
	GL_NV_fragment_program
	GL_NV_fragment_program_option
	GL_NV_framebuffer_multisample_coverage
	GL_NV_half_float
	GL_NV_light_max_exponent
	GL_NV_multisample_filter_hint
	GL_NV_occlusion_query
	GL_NV_packed_depth_stencil
	GL_NV_pixel_data_range
	GL_NV_point_sprite
	GL_NV_primitive_restart
	GL_NV_register_combiners
	GL_NV_register_combiners2
	GL_NV_texgen_reflection
	GL_NV_texture_compression_vtc
	GL_NV_texture_env_combine4
	GL_NV_texture_expand_normal
	GL_NV_texture_rectangle
	GL_NV_texture_shader
	GL_NV_texture_shader2
	GL_NV_texture_shader3
	GL_NV_vertex_array_range
	GL_NV_vertex_array_range2
	GL_NV_vertex_program
	GL_NV_vertex_program1_1
	GL_NV_vertex_program2
	GL_NV_vertex_program2_option
	GL_SGIS_generate_mipmap
	GL_SGIS_texture_lod
	GL_SGIX_depth_texture
	GL_SGIX_shadow
	GL_SUN_slice_accum
GL_MAX_TEXTURE_SIZE=4096
Using GL_LINEAR for normal textures.
Using GL_LINEAR_MIPMAP_LINEAR for mipmap textures.
Using texture format GL_RGB5_A1.
ST_Init: Init status bar.
P_GetNodesVersion: using normal BSP nodes
I_SignalHandler: Exiting on signal: signal 8
I_ShutdownMusic: removing /tmp/prboom-music-swXDdv
I_ShutdownSound: 
laurent@laurent:/media/media/soft/prboom-2.4.7/src$

On pourra noter la présence de la ligne :

I_SignalHandler: Exiting on signal: signal 8

Ce qui correspondrait à un code d'erreur. Seulement voilà, je n'ai rien trouvé concernant les codes de retour de prboom dans la documentation.

Je suppose aussi que le problème serait lié à une dépendance mais j'ai bien vérifié que tous les paquets sont biens installés.

Une idée ?

Dernière modification par Gamuti (Le 24/11/2009, à 18:06)

Hors ligne

#5 Le 25/11/2009, à 11:28

Lancelin

Re : [Résolu] Plantage de PRBOOM sous Ubuntu 9.10

Salut !

Si moi je vais bien (pour l'instant du moins...) Prboom semble être au plus mal !
Mais ce n'est pas ma méthode que tu as utilisé. Tout du moins ce n'est pas l'impression que j'ai à te lire. Je la détaille donc ci-dessous (pour Ubuntu 9.10 - 32 bits) :
- désinstaller prboom avec Synaptic ou par sudo apt-get remove prboom au choix
- récupérer le fichier prboom de Jaunty (9.04) sur le site des paquets Ubuntu
- l'installer avec l'Installateur de paquets GDebi
- bloquer la version dans Synaptic (Paquet --> cocher la case Bloquer la version)
Et chez moi ça fonctionne. Sauf la musique. Mais bon l'essentiel c'est quand même d'avoir les explosions et les cris de douleurs, non ?
Quant à forcer la version, j'ai vu que ça existe mais je n'ai jamais essayé. Je préfère la méthode, peut-être barbare, de l'installation du .deb qui va bien.

Bon courage !

Dernière modification par Lancelin (Le 25/11/2009, à 11:30)

#6 Le 29/11/2009, à 21:04

Gamuti

Re : [Résolu] Plantage de PRBOOM sous Ubuntu 9.10

Ouai ! super ! ça marche ta méthode.
Effectivement, je ne possédais pas le lien pour Jaunty.

De mon côté, j'ai la musique et le bruitage.

Pour ton problème de musique, peut-être que timidity n'est pas installé ou bien que l'option musique n'est pas activée dans le prboom.cfg
Regarde ici : http://forum.ubuntu-fr.org/viewtopic.ph … 8#p2664368
Bon amusement et merci encore.

Dernière modification par Gamuti (Le 29/11/2009, à 21:25)

Hors ligne

#7 Le 30/11/2009, à 11:19

Lancelin

Re : [Résolu] Plantage de PRBOOM sous Ubuntu 9.10

music_card       -1
C'est bon !
Faut que j'ajoute ça dans ma doc perso...

Par hasard, connais-tu une astuce permettant de mettre en OpenGL dans prboom.cfg ?

@+

Dernière modification par Lancelin (Le 30/11/2009, à 11:41)

#8 Le 30/11/2009, à 15:46

Gamuti

Re : [Résolu] Plantage de PRBOOM sous Ubuntu 9.10

Pour activer par défaut l'openGl, il faut modifier le même fichier prboom.cfg comme suit :
- dans la section

# Video settings

- il faut remplacer

videomode                 "8"

- par

videomode                 "gl"

Normalement, tu n'as pas besoin de modifier le prboom.cfg, il faut simplement activer l'openGl depuis le menu paramètres de prboom

Dernière modification par Gamuti (Le 30/11/2009, à 15:47)

Hors ligne

#9 Le 30/11/2009, à 17:52

Lancelin

Re : [Résolu] Plantage de PRBOOM sous Ubuntu 9.10

Sur l'ancienne version c'était 0 ou 1. Je n'aurais jamais pensé à mettre "gl" à la place de "8"...
Quant à la possibilité de changement dans les options de prboom, j'ignorais totalement.
Bon, il faut encore que je mette ma doc à jour...
Merci à toi !

#10 Le 01/12/2009, à 20:22

Gamuti

Re : [Résolu] Plantage de PRBOOM sous Ubuntu 9.10

Il vous en prie.
Mais tu peux aussi mettre "OpenGl" à la place de "gl". Ça marche tout aussi bien.

Hors ligne

#11 Le 01/12/2009, à 22:04

Lancelin

Re : [Résolu] Plantage de PRBOOM sous Ubuntu 9.10

J'avais remarqué wink

Et j'ai aussi remarqué qu'en 64 bits Prboom fonctionne à la perfection !
Il suffit de faire les réglages qui vont bien dans le menu, plus besoin de prboom.conf.
Comme quoi on hésite à passer de 32 en 64 bits par crainte de dysfonctionnement et en fait ça marche mieux !

Dernière modification par Lancelin (Le 02/12/2009, à 18:48)

#12 Le 03/12/2009, à 18:31

Gamuti

Re : [Résolu] Plantage de PRBOOM sous Ubuntu 9.10

64 bits ? diable ! moi qui n'en n'ai qu'une. Là, je suis jaloux.

Hors ligne

Haut de page ↑