Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites". Attention, le forum rencontre actuellement quelques difficultés. En cas d'erreur 502, il ne faut pas re-valider l'envoi d'un message ou l'ouverture d'une discussion, au risque de créer un doublon.

La section divers se réorganise ! De nouvelles sous-sections à venir. (plus d'infos + donner son avis)

#1 Le 06/01/2012, à 08:15

bobleiponge

dual boot prioritaire sur vista par défaut

bonjour,
j'avais déjà envisagé le problème lors de l'installation d'ubuntu sur mon DD
j'y reviens maintenant

je ne retrouve plus les messages envoyés et les réponses reçues à cette époque !
je sais que c'est très délicat, j'ai envie de m'y replonger, ne pouvant pas désinstaller ubuntu de mon DD avec os-uninstaller, pour l'instant !!
cordialement

Hors ligne

#2 Le 06/01/2012, à 09:11

malbo

Re : dual boot prioritaire sur vista par défaut

Tu peux utiliser cette technique : http://forum.ubuntu-fr.org/viewtopic.ph … 4#p3287804


MedionPC MT5 MED MT 162 / pentium IV / RAM 1Go / Radeon HD 3450 AGP / XP, HandyLinux et Xubuntu 14.04 32 bits
Acer Aspire M5100-5F7N / Phenom Quad Core 9500 / ATI HD 2600 pro / RAM 4 Go / Win8, XP et Ubuntu 14.04

Hors ligne

#3 Le 08/01/2012, à 21:01

bobleiponge

Re : dual boot prioritaire sur vista par défaut

bonsoir,

voici le choix au démarrage
ubuntu avec linux 3.0.0-12-generic-pae
ubuntu avec linux 3.0.0-12-generic-pae dépannage
previous linux versions
memory test (memtest86+)
memory test (memtest86+,serial console 115200)
windows recovery environnement (loader) (on /dev/sda1)
windows vista (loader) (on /dev/sda2)






je ne comprends pas bien ce tutoriel

OS sélectionné par défaut

    *
      Saisissez cette commande dans un terminal avec un chiffre à la place du x (0 = le premier, 1 = le deuxième etc…)

sudo grub-set-default x

    *
      ou éditez le fichier /etc/default/grub et choisissez parmi les possibilités suivantes pour la variable GRUB_DEFAULT=
          o
            un chiffre (0 = le premier, 1 = le deuxième etc…),
          o
            saved (sans guillemet) pour ce qui a été sélectionné lors du précédent lancement (nécessite de rajouter GRUB_SAVEDEFAULT=true),
          o
            ou le titre exact d'un menu mis entre guillemets (par exemple : "Microsoft Windows 2000 Professionnel (on /dev/sda1)")

Pour obtenir les titres exacts des menus : grep menuentry /boot/grub/grub.cfg





j'ai bien réussi à ouvrir le fichier grub, mais je n'ose pas faire de bêtises car je ne comprends pas comment le modifier


# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0
#GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"

que dois-je mettre à la place du 0


je n'ose pas utiliser cette commande sans savoir comment m'en sortir si cela ne fonctionne plus par la suite
je n'ai pas envie de réinstaller vista

* ou sudo mv /etc/grub.d/30_os-prober /etc/grub.d/06_os-prober (pour mettre windows par défault) ne pas oublier sudo update-grub pour que la modification soit prise en compte.

cordialement

Hors ligne

#4 Le 09/01/2012, à 06:17

malbo

Re : dual boot prioritaire sur vista par défaut

Tu lances l'éditeur de texte gedit avec pouvoir administrateur. Cela se fait en tapant cette commande dans un terminal :

gksudo gedit 

Quand la fenêtre de l'éditeur de texte apparaît, tu ouvres dans cet éditeur le fichier grub qui se trouve dans le chemin suivant /etc/default/
Tu modifies la ligne :

GRUB_DEFAULT=0

pour qu'elle devienne :

GRUB_DEFAULT="windows vista (loader) (on /dev/sda2)"

Pour ce faire, tu auras copié à l'avance "windows vista (loader) (on /dev/sda2)" depuis le fichier /boot/grub/grub.cfg (ou depuis cette discussion) et tu n'auras plus qu'à le coller à la place du 0
Puis tu enregistres dans l'éditeur de texte pour que la modif soit prise en compte.

Après cela, il faut que le fichier de configuration de grub (grub.cfg) soit mis à jour par la commande suivante à passer dans un terminal :

sudo update-grub

Au redémarrage du PC, ça doit démarrer sur Vista

Dernière modification par malbo (Le 09/01/2012, à 06:22)


MedionPC MT5 MED MT 162 / pentium IV / RAM 1Go / Radeon HD 3450 AGP / XP, HandyLinux et Xubuntu 14.04 32 bits
Acer Aspire M5100-5F7N / Phenom Quad Core 9500 / ATI HD 2600 pro / RAM 4 Go / Win8, XP et Ubuntu 14.04

Hors ligne

#5 Le 09/01/2012, à 15:09

bobleiponge

Re : dual boot prioritaire sur vista par défaut

bonjour,
j'ai bien compris maintenant
je le teste dès que je peux
je te remercie infiniment

Hors ligne

#6 Le 09/01/2012, à 23:11

bobleiponge

Re : dual boot prioritaire sur vista par défaut

bonsoir,
nouveau problème avant l'ouverture de grub
voici le message d'erreur

(gksudo:6080): Gtk-WARNING **: Unable to locate theme engine in module_path: "pixmap",
que vais-je devenir ??
cordialement

Hors ligne

#7 Le 10/01/2012, à 00:14

bobleiponge

Re : dual boot prioritaire sur vista par défaut

je pense que j'aurais dû démarrer sur le disque dur pour être administrateur et pas depuis le cd, non ?
je vais refaire un test

Hors ligne

#8 Le 10/01/2012, à 11:07

bobleiponge

Re : dual boot prioritaire sur vista par défaut

bonjour,
démarrage sur le DD
modif de grub ok
update de grub


voici le rapport :

bob@bob-Aspire-7535:~$ sudo update-grub

Generating grub.cfg ...

Found linux image: /boot/vmlinuz-3.0.0-12-generic-pae

Found initrd image: /boot/initrd.img-3.0.0-12-generic-pae

Found linux image: /boot/vmlinuz-3.0.0-12-generic

Found initrd image: /boot/initrd.img-3.0.0-12-generic

Found linux image: /boot/vmlinuz-2.6.27-7-generic

Found initrd image: /boot/initrd.img-2.6.27-7-generic

Found memtest86+ image: /boot/memtest86+.bin

Found Windows Recovery Environment (loader) on /dev/sda1

Found Windows Vista (loader) on /dev/sda2

done

bob@bob-Aspire-7535:~$


extinction / redémarrage
mais le démarrage malheureusement se fait toujours sur ubuntu par défaut
au secours !!!
cordialement

Hors ligne

#9 Le 10/01/2012, à 11:12

bobleiponge

Re : dual boot prioritaire sur vista par défaut

je tente de retourner dans le grub

bob@bob-Aspire-7535:~$ gksudo gedit etc/default/grub




(gksudo:2038): Gtk-WARNING **: Impossible de trouver le moteur de thème dans module_path : « pixmap »

(gksudo:2038): Gtk-WARNING **: Impossible de trouver le moteur de thème dans module_path : « pixmap »

(gksudo:2038): Gtk-WARNING **: Impossible de trouver le moteur de thème dans module_path : « pixmap »

(gksudo:2038): Gtk-WARNING **: Impossible de trouver le moteur de thème dans module_path : « pixmap »


le grub est vide !!!!
ahhhhhhhhhhhhhh, je m'arrache les cheveux

Hors ligne

#10 Le 10/01/2012, à 11:49

malbo

Re : dual boot prioritaire sur vista par défaut

Peux-tu démarrer ton PC sur le Ubuntu installé sur le disque dur et passer cette commande dans un terminal :

cat /etc/default/grub

Elle doit afficher dans le terminal le contenu du ficher en question. J'espère qu'il n'est pas vide...Si c'est le cas (il n'est pas vide), profite pour poster ce qui est affiché, ça permettra de vérifier que c'est correct.

Dernière modification par malbo (Le 10/01/2012, à 11:50)


MedionPC MT5 MED MT 162 / pentium IV / RAM 1Go / Radeon HD 3450 AGP / XP, HandyLinux et Xubuntu 14.04 32 bits
Acer Aspire M5100-5F7N / Phenom Quad Core 9500 / ATI HD 2600 pro / RAM 4 Go / Win8, XP et Ubuntu 14.04

Hors ligne

#11 Le 10/01/2012, à 15:43

bobleiponge

Re : dual boot prioritaire sur vista par défaut

bob@bob-Aspire-7535:~$ cat /etc/default/grub
# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_DEFAULT="windows vista (loader) (on /dev/sda2)"
#GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"



bob@bob-Aspire-7535:~$



il n'est pas vide et ça semble correct, non ?
pourtant le premier choix est toujours ubuntu !

Hors ligne

#12 Le 10/01/2012, à 15:45

atichu

Re : dual boot prioritaire sur vista par défaut

Moi j'utilise grub customizer.. il permet de personnalisé grub2 facilement et il peut se connecté à la derniére insterface rentré. fin bref amort les lignes de commande quand il y a plus simple tongue

http://doc.ubuntu-fr.org/grub-customizer

faire quand même gaffe a pas cliqué sur n'importe quoi tongue

Dernière modification par atichu (Le 10/01/2012, à 15:47)


Je ne suis pas un geek ni un informaticien mais j'aime linux/ubuntu.
acer aspire5741G (unity 12.04))+une vieillebousse(xfce 12.04)
+teste de la version instable

Hors ligne

#13 Le 10/01/2012, à 16:03

malbo

Re : dual boot prioritaire sur vista par défaut

bobleiponge,
Je commence à avoir un doute là. Peux-tu poster ton Boot-info : http://forum.ubuntu-fr.org/viewtopic.php?id=614071
Ce qui est demandé, c'est le lien qui est de la forme : http://paste.ubuntu.com/XXXXXX/
le numéro XXXXX correspondant à TON résultat du Boot Info Script


MedionPC MT5 MED MT 162 / pentium IV / RAM 1Go / Radeon HD 3450 AGP / XP, HandyLinux et Xubuntu 14.04 32 bits
Acer Aspire M5100-5F7N / Phenom Quad Core 9500 / ATI HD 2600 pro / RAM 4 Go / Win8, XP et Ubuntu 14.04

Hors ligne

#14 Le 11/01/2012, à 11:57

bobleiponge

Re : dual boot prioritaire sur vista par défaut

1
bob@bob-Aspire-7535:~$ sudo add-apt-repository ppa:yannubuntu/boot-repair && sudo apt-get update; && sudo apt-get install -y boot-repair && boot-repair
bash: Erreur de syntaxe près du symbole inattendu « && »
bob@bob-Aspire-7535:~$ sudo add-apt-repository ppa:yannubuntu/boot-repair && sudo apt-get update; && sudo apt-get install -y boot-repair && boot-repair
bash: Erreur de syntaxe près du symbole inattendu « && »
bob@bob-Aspire-7535:~$

échec !!!

2
http://paste.ubuntu.com/XXXXXX/
et ce lien ne fonctionne pas

3
bob@bob-Aspire-7535:~$ sudo add-apt-repository ppa:danielrichter2007/grub-customizer && sudo apt-get update && sudo apt-get install -y grub-customizer
[sudo] password for bob:
loSorry, try again.
[sudo] password for bob:

et là, je ne peux même pas donner mon pass !!!
je n'ai plus la main !




cela semble irrémédiable
puis-je envisager de désinstaller ubuntu proprement ?
cordialement

Hors ligne

#15 Le 15/01/2012, à 15:42

bobleiponge

Re : dual boot prioritaire sur vista par défaut

bonjour,
j'ai réinstallé un boot vista unique depuis ce site
http://www.forum-vista.net/reparer-vista-avec-winre-279 (cela fonctionne)
et supprimé les partitions ubuntu

prévenez-moi quand vous aurez une version ubuntu dans laquelle ces problèmes seront corrigés
(boot par défaut sur microsoft après validation une fois pour toutes, désinstallation d'ubuntu plus aisée)
cordialement

Hors ligne

Haut de page ↑