Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites". Attention, le forum rencontre actuellement quelques difficultés. En cas d'erreur 502, il ne faut pas re-valider l'envoi d'un message ou l'ouverture d'une discussion, au risque de créer un doublon.

La section divers se réorganise ! De nouvelles sous-sections à venir. (plus d'infos + donner son avis)

#1 Le 17/10/2005, à 18:06

ThAl

[résolu]Serveur X ne se lance qu'en Root

Alors voilà j'ai chercher par moi même mais je n'ai pas réussir à résoudre ce problème wink

Je ne peux démarrer X qu'en root (sudo startx)
Sinon qu'ne je lance ubuntu normalement, mon serveur x se ferme avant 10 secondes (automatiquement) et ils me mettent une erreur (.Xauthority) et une autre (remove .X0-lock) et bref quand j'ai réglé le pb au niveau de .Xauthority (il s'agit d'un pb de droit), et que j'ai supprimé le .X0-lock, ben j'ai toujours le problème de droit qui se pose alors que quand je fais sudo startx tout démarre bien comme il faut : (

Une suggestion ?

Dernière modification par ThAl (Le 17/10/2005, à 20:05)

Hors ligne

#2 Le 17/10/2005, à 18:10

cep_

Re : [résolu]Serveur X ne se lance qu'en Root

As-tu assez de place sur tes partitions ?
un : df -h dans le termianal te le dira.

S'il n'y a plus de place, faire un sudo apt-get clean et si nécessaire supprimer encore les fichiers bloquant.

#3 Le 17/10/2005, à 18:12

cep_

Re : [résolu]Serveur X ne se lance qu'en Root

En complément, si tu as une partition /home séparée, c'est sur cette partition qu'il faudra faire de la place.
En effet, il est possible que tu ne puisses te connecter en root que grâce aux 5% d'espace alloué à root.

#4 Le 17/10/2005, à 18:50

ThAl

Re : [résolu]Serveur X ne se lance qu'en Root

Alors voilà ce que me donne un df -h :

root@Breezy-01:/root# df -h
Sys. de fich.            Tail. Occ. Disp. %Occ. Monté sur
/dev/hdc1              36G  9,0G   25G  27% /
tmpfs                 507M     0  507M   0% /dev/shm
tmpfs                 507M   13M  494M   3% /lib/modules/2.6.12-9-k7/volatile
/dev/hdb              416M  416M     0 100% /media/cdrom1

Hors ligne

#5 Le 17/10/2005, à 20:06

ThAl

Re : [résolu]Serveur X ne se lance qu'en Root

Alors j'ai  réussi à reavoir x en utilisateur big_smile
Je n'ai qu'une chose à dire : merci Easy Ubuntu big_smile
J'ai reinstallé easyubuntu, redémarré ma machine et paf ça à démarrer big_smile
je sais bien que c'est pas vraiment très propre comme méthode :d
mais ça marche tongue

Hors ligne

#6 Le 17/11/2005, à 00:02

AeroMax

Re : [résolu]Serveur X ne se lance qu'en Root

erf j'ai exactement le même problème, sauf que j'ai bô réinstaller Easyubuntu, ca ne marche toujours pas sad

j'ai le message d'erreur suivant

X user not authorized to run X server, aborting

ceci est dû également à des erreurs sur les droits de .Xauthority or j'ai changé les droits, mais cela ne marche pas grrr au secours plz smile

Haut de page ↑