Contenu | Rechercher | Menus

Annonce

Ubuntu 16.04 LTS
Commandez vos DVD et clés USB Ubuntu-fr !

Pour en savoir un peu plus sur l'équipe du forum.

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

#1 Le 19/08/2012, à 15:30

Vairon

Démarrage systématique sur Windows après installation d'Ubuntu 12.04

Bonjour,

J'ai récemment acheté un ordinateur, un Vaio série E de 2012. J'aimerais y installer Ubuntu 12.04, à côté du Windows 7 préinstallé. Je me suis rendu compte que j'ai un PC EFI ; j'ai donc suivi ce tutoriel pour installer Ubuntu, en utilisant une liveUSB d'Ubuntu créée à partir de l'iso Secure-remix :
http://forum.ubuntu-fr.org/viewtopic.php?id=757311
L'installation semble s'être bien passée : en particulier, j'ai bien vérifié que la clé se lançait en efi. J'ai été surpris par le fait que l'installateur ne détectait pas Windows. Ce ne m'a pas semblé très important, puisque j'ai affecté manuellement les partitions en suivant les instructions du tutoriel. Le problème est qu'au moment du démarrage de l'ordinateur, Windows est lancé directement. Je n'ai pas accès à un écran de sélection d'OS. J'ai donc utilisé boot-repair en passant par une liveUSB d'Ubuntu (secure remix), qui n'a pas signalé d'erreur lors de sa mise en œuvre. Cependant, ça n'a pas résolu mon problème : lorsque je démarre, Windows se lance systématiquement. Voici mon rapport boot-info :
http://paste.ubuntu.com/1155268/
Je ne sais plus trop quoi faire. La partition efi que j'ai créée pour Ubuntu est quasiment à la fin du disque dur. Peut-être est-ce le problème ? En tout cas, je me tourne vers vous, car je ne sais pas interpréter le rapport boot-info.

Je vous remercie de m'avoir lu !

Hors ligne

#2 Le 19/08/2012, à 17:30

Diahovez-Ivan

Re : Démarrage systématique sur Windows après installation d'Ubuntu 12.04

Salut,
Une solution à votre problème,
http://forum.ubuntu-fr.org/viewtopic.php?id=991871


Profil ...
Asus R700VM-TY092V : Linux Mint (15) 13.04  Mate // Tinkpad T61: Linux Mint (14) 12.10 Xfce
Jeux

Hors ligne

#3 Le 19/08/2012, à 18:07

Vairon

Re : Démarrage systématique sur Windows après installation d'Ubuntu 12.04

Merci pour votre réponse ! Mais j'ai du mal à faire le parallèle entre ma situation et celle de le discussion que vous indiquez. Dans mon cas, Windows démarre très bien et Ubuntu n'est pas détecté. Les deux systèmes d'exploitation sont installés en EFI dans mon cas.

Hors ligne

#4 Le 19/08/2012, à 18:31

Diahovez-Ivan

Re : Démarrage systématique sur Windows après installation d'Ubuntu 12.04


Profil ...
Asus R700VM-TY092V : Linux Mint (15) 13.04  Mate // Tinkpad T61: Linux Mint (14) 12.10 Xfce
Jeux

Hors ligne

#5 Le 19/08/2012, à 18:55

Babdu89

Re : Démarrage systématique sur Windows après installation d'Ubuntu 12.04

Bonjour...
La machine devrait démarrer sur la partition efi Ubuntu  Fat /sda6 , si j'ai bien compris ce que rapporte le bootinfo à la fin...

Essaye de mettre le drapeau "boot" sur la partition /dev/sda6 en session live Ubuntu efi , avec Gparted ...

Est -ce que çà démarre Ubuntu?...

@+.   Babdu89   .


J'ai découvert Ubuntu avec la 07.10.... Et alors?!...  Depuis je regarde de temps en temps si Windows marche toujours....

Hors ligne

#6 Le 19/08/2012, à 22:13

YannUbuntu

Re : Démarrage systématique sur Windows après installation d'Ubuntu 12.04

Bonjour

Vairon a écrit :

La partition efi que j'ai créée pour Ubuntu est quasiment à la fin du disque dur. Peut-être est-ce le problème ?

Je pense que oui, et que du coup le BIOS utilise sda3 (ou sda1) comme partition EFI (bien que celles-ci n'aient pas de drapeau de boot).

A votre place je ferais ceci:
1) lancer Boot-Repair
2) cliquer sur "Options avancées"
3) aller dans l'onglet "Emplacement de GRUB"
4) cocher l'option "Partition /boot/efi séparée: sda3"
5) Cliquer sur le bouton "Appliquer"
6) Noter la nouvelle URL qui apparaitra et nous l'indiquer svp
7) redémarrer le PC et nous indiquer ce que vous observez


à consulter/améliorer: Guide du Débutant, Logiciels, Ecole, Travail, Maison

Hors ligne

#7 Le 20/08/2012, à 13:52

Vairon

Re : Démarrage systématique sur Windows après installation d'Ubuntu 12.04

Merci pour le deuxième lien Ivan. Je le garde sous le coude, j'espère ne pas avoir à réinstaller Windows.

Babdu89, j'ai bien vérifié, le drapeau est bien sur la partition sda6. J'aurais bien aimé que le problème soit là, tout simplement smile

J'ai essayé la solution que vous proposez, YannUbuntu, mais je ne peux sélectionner que sda6 dans l'option partition /boot/efi séparé.
Maintenant, je ne suis pas certain que le problème soit ici. Je me suis aperçu que je ne suis pas le seul à avoir des problèmes avec le dual boot sur Vaio. Une solution est proposée ici :
http://bubu-online.blogspot.fr/2012/07/ … -bios.html

Lors de l'installation d'Ubuntu, l'auteur a laissé le drapeau boot sur la partition sda3, l'installateur a donc mis le dossier efi sur cette partition. Pourtant, il semble avoir le même problème : le dual-boot n'est pas activé. A priori, le problème n'est pas (seulement) que ma partition sda6 est trop loin dans le disque. Il y a autre chose. Peut être que sda1 intervient dans le processus de boot ? C'est juste une supposition, je ne comprends pas vraiment comment tout cela fonctionne. (Il faut noter que pour démarrer l'ordinateur, il y a deux possibilités : soit le bouton power, qui démarre l'ordinateur normalement sur Windows, soit un bouton "assist", qui démarre l'ordinateur et lance le système de récupération de Sony. Peut être que sda1 sert au démarrage sur ce bouton assist ?)

J'ai suivi les deux étapes 2 et 3 du tutoriel présenté dans cet article (je peux faire marche arrière pour revenir à la situation précédente en renommant les fichiers). Maintenant, lorsque je démarre, j'arrive bien sur l'écran de sélection de l'OS. Il n'y a pas Windows comme possibilité, mais je suppose que si je suis l'étape 4, ce choix apparaîtra. Au final, le résultat me convient, mais j'ai l'impression que c'est vraiment bidouillé, comme solution (remplacer un fichier par un autre et le renommer pour tromper l'ordinateur, si j'ai bien saisi). Est-ce que ça ne risque pas de poser des problèmes plus tard ? Par exemple lors de mises à jour,... Aussi, je me retrouve avec une installation un peu bancale : puisque j'ai suivi le tutoriel d'installation prudente de malbo, le dossier efi de Ubuntu est sur la partition sda6, mais le fichier grubx64.efi est sur la partition sda3. À nouveau, ça ne pose pas de problèmes ? D'ailleurs, le wifi ne fonctionne pas lorsque je démarre sur la version d'Ubuntu installée sur l'ordinateur, alors que ça fonctionnait en LiveUSB. Je m'égare un peu, mais peut être que ce problème matériel est lié au processus de démarrage !

Hors ligne

#8 Le 20/08/2012, à 15:27

YannUbuntu

Re : Démarrage systématique sur Windows après installation d'Ubuntu 12.04

Vairon a écrit :

J'ai essayé la solution que vous proposez, YannUbuntu, mais je ne peux sélectionner que sda6 dans l'option partition /boot/efi séparé.

Parce-que j'ai oublié de vous dire de commencer par mettre le drapeau de boot sur sda3.

Vairon a écrit :

il semble avoir le même problème : le dual-boot n'est pas activé.

Ce n'est pas le même problème. Ce 2e problème (que vous rencontrez aussi, voir ci-dessous) est que WIndows n'apparait pas dans le menu GRUB.

Vairon a écrit :

Peut être que sda1 sert au démarrage sur ce bouton assist ?

je pense que oui

Vairon a écrit :

Est-ce que ça ne risque pas de poser des problèmes plus tard ?

Ca risque de poser problème lors d'une mise à jour de GRUB.

Vairon a écrit :

le wifi ne fonctionne pas lorsque je démarre sur la version d'Ubuntu installée sur l'ordinateur, alors que ça fonctionnait en LiveUSB.

Ce n'est pas lié au problème de démarrage.

Voici ce que je ferais à votre place:

1) Annuler ce que vous avez fait:
- supprimer sda3/EFI/ubuntu/grubx64.efi et sda3/Microsoft/boot/bootmgfw.efi
- renommer grubx64.efi.old en grubx64.efi ,  et bootmgfw.efi.old en bootmgfw.efi
2) Via gParted, placer le drapeau de boot sur sda3
3) Cliquer sur "Réparation recommandée" de Boot-Repair , et indiquer la nouvelle URL qui apparaitra.

Dernière modification par YannUbuntu (Le 20/08/2012, à 15:29)


à consulter/améliorer: Guide du Débutant, Logiciels, Ecole, Travail, Maison

Hors ligne

#9 Le 20/08/2012, à 16:24

Vairon

Re : Démarrage systématique sur Windows après installation d'Ubuntu 12.04

Merci ! Voici le nouveau rapport boot-info :
http://paste.ubuntu.com/1157256/

EDIT, j'ai oublié de préciser : maintenant, au démarrage, tout se passe comme ce que j'ai décrit dans mon premier message, à savoir aucun menu grub proposé, Windows lancé directement.

Dernière modification par Vairon (Le 20/08/2012, à 17:37)

Hors ligne

#10 Le 20/08/2012, à 18:13

YannUbuntu

Re : Démarrage systématique sur Windows après installation d'Ubuntu 12.04

recommencez en n'oubliant pas de mettre à jour Boot-Repair wink


à consulter/améliorer: Guide du Débutant, Logiciels, Ecole, Travail, Maison

Hors ligne

#11 Le 21/08/2012, à 12:26

Vairon

Re : Démarrage systématique sur Windows après installation d'Ubuntu 12.04

J'ai bien mis à jour Boot-repair cette fois, mais le logiciel est resté à l'étape "scanning systems" pendant plus de quatre heures hier soir. J'ai annulé, parce que je devais éteindre l'ordinateur pour la nuit. Avant la mise à jour, cette étape se faisait rapidement. Est-ce normal ? Si oui, je pourrai relancer le scan ce soir.

Hors ligne

#12 Le 21/08/2012, à 14:38

YannUbuntu

Re : Démarrage systématique sur Windows après installation d'Ubuntu 12.04

Non ce n'est pas normal. Re-essayez ce soir.
Si ça met plus de 30minutes:
- envoyez-moi par email (yannubuntu ATT gmail POINT com) un ZIP du dossier /var/log/boot-sav, puis:
- redémarrez le PC et suivez les étapes 2, 3 4 du tuto du blog, en remplaçant toutes les extensions ".old" par ".bkp" (y compris à l'étape 4),
- puis redémarrez le PC sur l'Ubuntu installé, modifiez le fichier /etc/fstab de l'Ubuntu installé de façon à ce que ce soit sda3 qui soit monté sur /boot/efi (la commande "sudo blkkid" vous indiquera quelle UUID renseigner),
- redémarrez à nouveau le PC sur l'Ubuntu installé, puis ouvrez un terminal et saisissez la commande "sudo update-grub", cela devrait ajouter l'entrée Windows au menu GRUB.


à consulter/améliorer: Guide du Débutant, Logiciels, Ecole, Travail, Maison

Hors ligne

#13 Le 27/08/2012, à 12:03

Mateoz

Re : Démarrage systématique sur Windows après installation d'Ubuntu 12.04

Salut Vairon,

As-tu trouvé une solution satisfaisante à ton problème ?

Parce que je rencontre exactement le même problème en voulant installer ubuntu 12.04 sur mon Vaio SVE14A1V1E acheté avant-hier.

Lors de l'installation, windows n'était visiblement pas reconnu comme système d'exploitation, la commande "installer ubuntu à côté des autres" étant absente. J'ai donc effectué un partitionnement manuel. J'ai tout d'abord créé à l'aide de GParted une partition EFI (type : FAT32 ; taille : 200Mo ; drapeau "boot" coché pour cette partition). Ensuite, avec l'interface d'installation, j'ai créé une partition SWAP et une partition racine (type : EXT4 ; point de montage : / ). Ensuite, j'ai lancé l'installation et tout semble s'être bien déroulé.
Mais quand je lance mon ordinateur, je n'ai pas le choix de mon OS, Windows se lance automatiquement.

Je tiens à préciser que je suis un total néophyte et que je suis par conséquent perdu quand il n'y a pas d'interface graphique, et les rapports boot-info sont du chinois pour moi. Cependant, ça fait trois ans que je suis sur ubuntu et que j'en suis extrêmement satisfait. Du coup, l'idée de ne pas savoir l'installer sur ma nouvelle machine me fend le coeur.

Dernière modification par Mateoz (Le 27/08/2012, à 12:05)

Hors ligne

#14 Le 27/08/2012, à 12:15

YannUbuntu

Re : Démarrage systématique sur Windows après installation d'Ubuntu 12.04

@Mateoz: pouvez-vous indiquer votre URL Boot-Info svp?


à consulter/améliorer: Guide du Débutant, Logiciels, Ecole, Travail, Maison

Hors ligne

#15 Le 27/08/2012, à 17:54

Mateoz

Re : Démarrage systématique sur Windows après installation d'Ubuntu 12.04

La voici : http://paste.ubuntu.com/1170086/

Merci

Dernière modification par Mateoz (Le 27/08/2012, à 17:55)

Hors ligne

#16 Le 27/08/2012, à 23:36

YannUbuntu

Re : Démarrage systématique sur Windows après installation d'Ubuntu 12.04

Le probleme vient probablement du fait que la partition sda6 est trop loin du debut du disque.
A votre place je ferais ceci:
1) via Gparted, remettre le drapeau boot sur sda3
2) lancer Boot-Repair puis cliquer sur Réparation Recommandée. Indiquer l'URL qui apparaitra à la fin.
3) Redémarrer et indiquer ce que vous observez


à consulter/améliorer: Guide du Débutant, Logiciels, Ecole, Travail, Maison

Hors ligne

#17 Le 28/08/2012, à 13:07

Mateoz

Re : Démarrage systématique sur Windows après installation d'Ubuntu 12.04

Génial, Grub se lance au démarrage et je peux donc maintenant lancer mon OS de prédilection. C'est parfait!
Un tout grand merci, YannUbuntu. La plus grande force d'ubuntu reste quand même d'avoir une communauté si serviable smile

Au cas où, je communique toujours l'url boot-repair obtenue : http://paste.ubuntu.com/1171549/

Bonne journée et à bientôt!

Hors ligne

#18 Le 28/08/2012, à 14:35

YannUbuntu

Re : Démarrage systématique sur Windows après installation d'Ubuntu 12.04

@Mateoz: Impeccable smile J'ai la prémonition que ce problème est une régression de GRUB 12.04, et ne serait pas survenu avec 11.10. Si vous avez envie de participer à l'amélioration d'Ubuntu, seriez-vous ok pour "casser" temporairement votre boot afin de vérifier cette théorie? Je vous guiderai pour le test. Cela permettra d'améliorer GRUB.

@Vairon: vous en êtes où?

Dernière modification par YannUbuntu (Le 28/08/2012, à 14:35)


à consulter/améliorer: Guide du Débutant, Logiciels, Ecole, Travail, Maison

Hors ligne

#19 Le 15/09/2012, à 22:02

Mateoz

Re : Démarrage systématique sur Windows après installation d'Ubuntu 12.04

Salut YannUbuntu,

tout d'abord : sincèrement désolé de ne pas avoir répondu à ton précédent message. En réalité, une fois que mon problème a été réglé, je ne suis plus trop repassé sur ce forum.
Du coup, c'est un autre problème qui me ramène ici...

J'ai travaillé avec windows pendant deux semaines, car je rencontrais quelques problèmes avec ubuntu 12.04 (touchpad qui ne fonctionne pas, moins de possibilités qu'avant de changer l'interface, ...) et que j'avais besoin de stabilité pendant un petit temps vu que je viens de partir en erasmus et que j'ai déjà assez de choses dont je dois me soucier que pour passer des heures entières sur mon pc à chercher comment régler ceci ou cela.
Avant-hier, en redémarrant ma machine, plus rien ne fonctionnait. Au démarrage, on me disait qu'il y avait je ne sais pas trop quel problème (un truc avec grub, mais n'y connaissant rien, j'ai pas trop compris). Du coup, je me suis dit que j'allais désinstaller ubuntu pour l'instant (et le réinstaller plus tard), pensant que ça me permettrait de redémarrer au moins sous windows et de récupérer mes données etc. J'ai en même temps voulu toucher au partitionnement de mes disques. Et là j'ai sans doute du faire une erreur de débutant... Bref, Windows n'a plus voulu démarrer du tout.
Exaspéré de toutes ces histoires, j'ai pris la décision de me défaire de tous ces problèmes en arrêtant de vouloir jouer avec deux systèmes d'exploitation sur mon pc : j'ai réinstallé ubuntu en virant tout le reste (plus de windows sur ma machine).

Je me disais que ça règlerait probablement mes problèmes au démarrage, que si j'installais ubuntu à partir du live CD en lui donnant l'entièreté de mon disque dur, tout devrait marcher.. Et bien, j'ai été déçu...

En gros, après une installation réussie d'ubuntu, j'ai allumé mon pc mais ubuntu ne s'est pas lancé. Je suis resté devant un écran mauve :S

Du coup, j'ai relancé avec le live CD, et, fort de mon expérience passée qui m'a fait découvrir la petite merveille qu'est boot-repair, j'ai installé boot-repair et j'ai lui ai gentiment demandé de faire les "réparations recommandées".
Hallelujah, en relançant ma machine, ubuntu s'est lancé!

Mais, comme souvent, je me suis réjoui un peu trop vite... Au redémarrage suivant, ubuntu ne se lançait plus, j'étais à nouveau devant ce magnifique écran mauve qui ne s'en va pas. Du coup, j'ai reproduit exactement la même démarche qu'ante : relance avec le live cd et "réparation recommandée" par boot-repair. Et ça a remarché! Mais une fois que j'ai voulu redémarrer, même problème!

Bref, pour l'instant, la seule solution que j'ai trouvé, c'est de ne pas éteindre mon pc. Mais vous serez d'accord avec moi pour dire que ce n'est pas une solution très viable à long terme.

Voyez-vous d'où le problème pourrait venir ?
Je vous communique l'url de mon rapport boot-info smile

Merci d'avance !

Hors ligne

#20 Le 16/09/2012, à 23:04

YannUbuntu

Re : Démarrage systématique sur Windows après installation d'Ubuntu 12.04

Mateoz a écrit :

Voyez-vous d'où le problème pourrait venir ?

La prochaine fois que cela arrive, peux-tu :
1) d'abord cliquer sur le bouton "Créer un rapport BootInfo", et indiquer cette 1ere URL.
2) Redémarrer et vérifier que le problème persiste
3) puis cliquer sur "Réparation recommandée" et indiquer cette 2eme URL
4) redémarrer et vérifier que Ubuntu démarre correctement

... afin que l'on compare les 2 URLs.


à consulter/améliorer: Guide du Débutant, Logiciels, Ecole, Travail, Maison

Hors ligne

#21 Le 17/09/2012, à 21:08

Mateoz

Re : Démarrage systématique sur Windows après installation d'Ubuntu 12.04

Comme prévu :

1. J'ai relancé mon PC, et, après s'être éteint correctement, il n'a pas voulu relancer ubuntu.
2. J'ai relancé avec le live CD, j'ai lancé un rapport boot-info. En voici l'url : http://paste.ubuntu.com/1211559/
3. J'ai relancé mon pc. A nouveau, je reste devant un magnifique écran mauve, ubuntu ne se lançant pas.
4. J'ai relancé avec le live CD et j'ai demandé à boot-repair d'effectuer les réparations recommandées. Voici l'url que j'ai obtenu : http://paste.ubuntu.com/1211586/
5. J'ai relancé et ubuntu s'est lancé correctement (j'ai l'écran mauve qui reste pendant six ou sept seconde, mais je pense que c'est normal, et ensuite, je peux directement rentrer sur ma session ubuntu)

Si ça peut aider, après avoir effectué les "réparations recommandées", en plus de l'url indiquée ci-dessus, boot-repair me dit également ceci :

You can now reboot your computer.
Please do not forget to make your BIOS boot on sda1/EFI/ubuntu/grubx64.efi file!

The boot files of [Ubuntu 12.04.1 LTS] are far from the start of the disk. Your BIOS may not detect them. You may want to retry after creating a /boot partition (EXT4, >200MB, start of the disk). This can be performed via tools such as gParted. Then select this partition via the [Separate /boot partition:] option of [Boot Repair]. (https://help.ubuntu.com/community/BootPartition)

Merci d'avance pour votre aide ! smile

Hors ligne

#22 Le 17/09/2012, à 23:55

YannUbuntu

Re : Démarrage systématique sur Windows après installation d'Ubuntu 12.04

ok.
On va commencer par éliminer la piste des fichiers trop éloignés (message final de Boot-Repair):

1) démarrer sur un liveCD Ubuntu, choisir "Essayer Ubuntu"
2) lancer Gparted, et réduire la partition Ubuntu (sda2) de 636GB à 99GB (réduire depuis la droite, de façon à ce que la partition se trouve en début de disque)
3) Redémarrer le PC
4) Vérifier si le bug est toujours là ou pas


à consulter/améliorer: Guide du Débutant, Logiciels, Ecole, Travail, Maison

Hors ligne

#23 Le 18/09/2012, à 15:29

Mateoz

Re : Démarrage systématique sur Windows après installation d'Ubuntu 12.04

Je suis obligé de relancer avec le live-cd pour réduire ma partition, ou je peux le faire depuis mon ubuntu ?

Hors ligne

#24 Le 18/09/2012, à 15:33

YannUbuntu

Re : Démarrage systématique sur Windows après installation d'Ubuntu 12.04

Réduire une partition en cours d'utilisation, c'est comme scier la branche sur laquelle on est assis...
donc : le faire depuis le liveCD smile


à consulter/améliorer: Guide du Débutant, Logiciels, Ecole, Travail, Maison

Hors ligne

#25 Le 23/09/2012, à 21:34

Mateoz

Re : Démarrage systématique sur Windows après installation d'Ubuntu 12.04

Voilà. J'ai donc tenté en réduisant ma partition sda2 à 99GB.
Et cela ne fonctionne pas. Quand je relance, je suis toujours face à cet écran mauve qui ne s'en va pas.

J'ai donc ensuite relancé sur live-cd, ré-agrandi ma partition sda2 à 636GB, installé boot-repair et effectué les "réparations recommandées". Et là, comme d'habitude, ubuntu se lance au redémarrage...

Que dois-je faire maintenant ?

Hors ligne