Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites". Attention, le forum rencontre actuellement quelques difficultés. En cas d'erreur 502, il ne faut pas re-valider l'envoi d'un message ou l'ouverture d'une discussion, au risque de créer un doublon.

La section divers se réorganise ! De nouvelles sous-sections à venir. (plus d'infos + donner son avis)

#1 Le 27/10/2012, à 09:42

thierry17700

[RESOLU] Erreur à l'éjection d'appareil photo

Bonjour

J'utilise shotwell pour importer mes photos. Pas de problème, ça fonctionne bien.

A la fin de l'importation, dans la fenêtre thunar, je clique sur la flèche en face de l'APN pour éjecter et je reçois ce message :

Error ejecting /dev/sdg: Command-line `eject "/dev/sdg"'
exited with non-zero exit status 1: eject: unable to eject,
last error: Invalid argument

Quelque chose à faire ?

edit : par contre avec un autre APN (Olympus FE-47) je n'ai pas ce message et l'éjection se passe normalement !

Dernière modification par thierry17700 (Le 27/10/2012, à 12:50)

Hors ligne

#2 Le 27/10/2012, à 11:00

Kooothor

Re : [RESOLU] Erreur à l'éjection d'appareil photo

Salut Thierry,

Ferme toutes les fenêtres Thunar, vérifie que t'as pas de shell dans le dossier de l'apn, et fais `eject /dev/sdg` dans un terminal. Est-ce qu'il y a toujours une erreur ?

@+
~ktr


Utilisateur d'Archlinux | Cruncheur BOINC | Bépoiste
Admin de Flood.fr | Mon ~ | Mes dotfiles
«Your behavior is not funny and is wasting the time of the federal government !»

Hors ligne

#3 Le 27/10/2012, à 12:00

thierry17700

Re : [RESOLU] Erreur à l'éjection d'appareil photo

Salut Kooothor

Dans le dossier de l'APN, 2 dossiers "DCIM" et "MISC".

La commande "eject /dev/sdg" renvoie " eject: impossible d'ouvrir le fichier `/dev/sdg' "

Hors ligne

#4 Le 27/10/2012, à 12:07

The Uploader

Re : [RESOLU] Erreur à l'éjection d'appareil photo

Salut

L'appareil ne correspond pas forcément à /dev/sdg

Pour savoir à quoi correspond chaque point de montage, tu peux faire :

cat /etc/mtab

eject peut utiliser un périphérique (exemple /dev/sdg) ou un point de montage (exemple : /run/media/<user>/<point de montage de l'APN>).

C'est moins risqué de passer par le point de montage, qui est plus parlant (on a vite fait de faire le mauvais périphérique dans /dev et de tenter d'éjecter celui qui fournit le point de montage / hmm Bon pas sûr que ça fonctionne sur le périph' correspondant à / vu qu'il sera en cours d'utilisation, mais bon...)

Dernière modification par The Uploader (Le 27/10/2012, à 12:10)


Passer de Ubuntu 10.04 à Xubuntu 12.04 LTS
ASUS N56VV (UEFI + GPT, Core i5-3230M @ 2.60GHz, Intel HD4000 + GeForce 750M, 12 Go de RAM, SSD 1 To)
Système principal : Archlinux (amd64), avec KDE
Système oublié la plupart du temps : Windows 8.1 Update 1 (x64, OEM)

Hors ligne

#5 Le 27/10/2012, à 12:50

thierry17700

Re : [RESOLU] Erreur à l'éjection d'appareil photo

Finalement j'ai contourné en paramétrant dans la configuration USB de l'APN en "Appareil Photo Numérique".

Dans une précédente version de xubuntu, j'avais du mettre en "Lecteur de disque".

Bref, ça marche smile

Hors ligne

  • Accueil
  • » Forum
  • » XFCE
  • » [RESOLU] Erreur à l'éjection d'appareil photo

Haut de page ↑