Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

#1 Le 03/01/2013, à 21:28

Néwick

Bug démarrage Ubuntu 12.10 sur LVM/dm-crypt

Bonjour à tous !

Je viens d'avoir à faire à un bug similaire, sur deux PC différents, suite à l'installation d'Ubuntu sur un disque dur chiffré via LVM-dm-crypt (comme proposé dans l'installeur).
C'est un problème au démarrage : après l'affichage du Grub 2 : plus d'image, extinction de l'écran (!)... par contre, si on entre la passphrase (à l'aveugle) et qu'on tape entrée, ça valide et ubuntu démarre... -> donc problème d'affichage, je me suis dit. Bein non, j'ai eu beau mettre à jour les drivers et tout, rien n'y fait.
Jusqu'à ce que je décide de changer Grub 2 pour Burg. Depuis, plus de problème.
Le premier PC est une tour avec 2 DD (1 chiffré avec linux dessus, 1 avec windows, dual boot)
Sur le 2e PC (portable, celui-ci), Grub n'était affiché qu'un démarrage sur 2... (mais il n'y a pas d'autre OS). Pareil, à l'aveugle on pouvait y arriver, et ça a été résolu en mettant Burg.

Voilà un bug un peu bizarre, j'ai fait quelques recherches et n'ai rien trouvé, donc je le poste ici.
Si quelqu'un a une solution plus élégante que de changer Grub en Burg, et une idée de ce qui peut causer ce trouble...

Hors ligne

#2 Le 04/01/2013, à 03:46

Maisondouf

Re : Bug démarrage Ubuntu 12.10 sur LVM/dm-crypt

Il faut lui bloquer sa résolution d'écran dans /etc/default/grub et refaire un 'sudo update-grub' ensuite.

GRUB_GFXMODE=640x480

ou

GRUB_GFXMODE=1024x768

Enfin une résolution correcte pour moniteur...

EDIT: ton titre est vraiment trompeur et je pense que beaucoup n'ont même pas ouvert le sujet parce qu'ils n'utilisent pas LVM-machin-truc.

Dernière modification par Maisondouf (Le 04/01/2013, à 03:47)


ASUS M5A88-v EVO avec AMD FX(tm)-8120 Eight-Core Processor,  OS principal Precise 12.04.1 LTS 63bits½
Bricoleur, menteur, inculte, inadapté social et mythomane, enfin d'après certains....
"the secret of my form is summed up in two words, no sport" (Winston Churchill)

Hors ligne

#3 Le 04/01/2013, à 12:17

Néwick

Re : Bug démarrage Ubuntu 12.10 sur LVM/dm-crypt

Merci. Je vais tester de ce pas.
J'avais mis ce titre parce que ça ne m'étais pas arrivé lors de précédentes installations sans dm-crypt, c'était les 2 premières avec...

Hors ligne

Haut de page ↑