Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites". Attention, le forum rencontre actuellement quelques difficultés. En cas d'erreur 502, il ne faut pas re-valider l'envoi d'un message ou l'ouverture d'une discussion, au risque de créer un doublon.

La section divers se réorganise ! De nouvelles sous-sections à venir. (plus d'infos + donner son avis)

#1 Le 23/11/2005, à 09:58

LR

[Résolu] Probleme de clavier

Salut,

Hier j'ai eu un soucis avec ma session (voir ici) et depuis, pas moyen d'avoir des accents.

Mon clavier n'est pas trop mal configur, mais lorsque j'essaie de saisir un caractre accentu, rien ne se passe, la preuve wink

Pourtant, dans Systme/Clavier/Agencement, j'ai bien FR_ch, il me semble que c'est correct.

Je ne peux plus non plus passer en console avec CTRL+ALT+F1, 4a n'a aucun effet. A tien, quand je veux faire un c cedille, 4a me fait un 4 !

EDIT Je ne peux plus non plus faire le symbole AT car ALT Gr ne fonctionne plus !

Voici mon xorg.conf au cas où :

# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the /etc/X11/xorg.conf manual page.
# (Type "man /etc/X11/xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following commands:
#
#   cp /etc/X11/xorg.conf /etc/X11/xorg.conf.custom
#   sudo sh -c 'md5sum /etc/X11/xorg.conf >/var/lib/xfree86/xorg.conf.md5sum'
#   sudo dpkg-reconfigure xserver-xorg

Section "Files"
	FontPath	"unix/:7100"			# local font server
	# if the local font server has problems, we can fall back on these
	FontPath	"/usr/lib/X11/fonts/misc"
	FontPath	"/usr/lib/X11/fonts/cyrillic"
	FontPath	"/usr/lib/X11/fonts/100dpi/:unscaled"
	FontPath	"/usr/lib/X11/fonts/75dpi/:unscaled"
	FontPath	"/usr/lib/X11/fonts/Type1"
	FontPath	"/usr/lib/X11/fonts/CID"
	FontPath	"/usr/lib/X11/fonts/100dpi"
	FontPath	"/usr/lib/X11/fonts/75dpi"
        # paths to defoma fonts
	FontPath	"/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
	FontPath	"/var/lib/defoma/x-ttcidfont-conf.d/dirs/CID"
EndSection

Section "ServerFlags"
    Option "Xinerama"
EndSection

Section "Module"
	Load	"GLcore"
	Load	"bitmap"
	Load	"dbe"
	Load	"ddc"
	Load	"dri"
	Load	"extmod"
	Load	"freetype"
	Load	"glx"
	Load	"int10"
	Load	"record"
	Load	"type1"
	Load	"v4l"
	Load	"vbe"
EndSection

Section "Extensions"

 Option "RENDER" "Enable" 

EndSection

Section "InputDevice"
	Identifier	"Generic Keyboard"
	Driver		"keyboard"
	Option		"CoreKeyboard"
	Option		"XkbRules"	"xorg"
	Option		"XkbModel"	"pc105"
	Option		"XkbLayout"	"FR_ch"
	Option		"XkbOptions"	"fr_CH"
EndSection

Section "InputDevice"
	Identifier	"Configured Mouse"
	Driver		"mouse"
	Option		"CorePointer"
	Option		"Device"		"/dev/input/mice"
	Option		"Protocol"		"ImPS/2"
	Option		"ZAxisMapping"		"4 5"
EndSection

#Section "Device"
#	Identifier	"ATI Technologies, Inc. Radeon 9200 SE (RV280)"
#	Driver		"radeon"
#	BusID		"PCI:1:0:0"
#	Option		"UseFBDev"		"true"
#	Option "UseInternalAGPGART" "no"
#EndSection
Section "Device"

	Identifier	"ATI Technologies, Inc. Radeon 9200 SE (RV280)"

	Driver      	"radeon"

#	Option      	"AGPMode" "4"

#	Option 		"AGPSize" "64" # default: 8

#    	Option 		"RingSize" "8"

#    	Option 		"BufferSize" "2"

#    	Option 		"EnablePageFlip" "true"

#    	Option 		"EnableDepthMoves" "true"

    	Option 		"RenderAccel" "true"
	BusID		"PCI:1:0:0"


    Option "DDCMode" "on"
    Option "DPMS
    Screen 0

EndSection

Section "Device"

	Identifier	"ATI Technologies, Inc. Radeon 9200 SE (RV280)2"

	Driver      	"radeon"

    	Option 		"RenderAccel" "true"
	BusID		"PCI:1:0:0"


    Option "DDCMode" "on"
    Option "DPMS
    Screen 1

EndSection






Section "Device"
	Identifier	"ATI Technologies, Inc, Radeon 9200 SE (RV280)3"
	Driver "fglrx"
	# ### generic DRI settings ###
	# === disable PnP Monitor ===
	#Option "NoDDC"
	# === disable/enable XAA/DRI ===
	Option "no_accel" "no"
	Option "no_dri" "no"
	# === misc DRI settings ===
	Option "mtrr" "off" # disable DRI mtrr mapper, driver has its own code for mtrr
	# ### FireGL DDX driver module specific settings ###
	# === Screen Management ===
	Option "DesktopSetup" "0x00000000"
	Option "MonitorLayout" "AUTO, AUTO"
	Option "IgnoreEDID" "off"
	Option "HSync2" "unspecified"
	Option "VRefresh2" "unspecified"
	Option "ScreenOverlap" "0"
	# === TV-out Management ===
	Option "NoTV" "no"
	Option "TVStandard" "PAL-N"
	Option "TVHSizeAdj" "0"
	Option "TVVSizeAdj" "0"
	Option "TVHPosAdj" "0"
	Option "TVVPosAdj" "0"
	Option "TVHStartAdj" "0"
	Option "TVColorAdj" "0"
	Option "GammaCorrectionI" "0x00000000"
	Option "GammaCorrectionII" "0x00000000"
	# === OpenGL specific profiles/settings ===
	Option "Capabilities" "0x00000000"
	# === Video Overlay for the Xv extension ===
	Option "VideoOverlay" "on"
	# === OpenGL Overlay ===
	# Note: When OpenGL Overlay is enabled, Video Overlay
	# will be disabled automatically
	Option "OpenGLOverlay" "off"
	# === Center Mode (Laptops only) ===
	Option "CenterMode" "off"
	# === Pseudo Color Visuals (8-bit visuals) ===
	Option "PseudoColorVisuals" "off"
	# === QBS Management ===
	Option "Stereo" "off"
	Option "StereoSyncEnable" "1"
	# === FSAA Management ===
	Option "FSAAEnable" "no"
	Option "FSAAScale" "1"
	Option "FSAADisableGamma" "no"
	Option "FSAACustomizeMSPos" "no"
	Option "FSAAMSPosX0" "0.000000"
	Option "FSAAMSPosY0" "0.000000"
	Option "FSAAMSPosX1" "0.000000"
	Option "FSAAMSPosY1" "0.000000"
	Option "FSAAMSPosX2" "0.000000"
	Option "FSAAMSPosY2" "0.000000"
	Option "FSAAMSPosX3" "0.000000"
	Option "FSAAMSPosY3" "0.000000"
	Option "FSAAMSPosX4" "0.000000"
	Option "FSAAMSPosY4" "0.000000"
	Option "FSAAMSPosX5" "0.000000"
	Option "FSAAMSPosY5" "0.000000"
	# === Misc Options ===
	Option "UseFastTLS" "0"
	Option "BlockSignalsOnLock" "on"
	Option "UseInternalAGPGART" "no"
	Option "ForceGenericCPU" "no"
	BusID "PCI:1:0:0" # vendor=1002, device=5964
	Screen 2
EndSection




Section "Monitor"
	Identifier "Tele"
	HorizSync 30-50
	VertRefresh 50-60
	Option "DPMS"
EndSection




Section "Monitor"
	Identifier	"BenQ"
	Option		"DPMS"
	HorizSync	28-64
	VertRefresh	43-60
	Modeline	"1280x800@60" 83.91 1280 1312 1624 1656 800 816 824 841
EndSection

Section "Monitor"
	Identifier	"Sony"
	Option		"DPMS"
	HorizSync	28-64
	VertRefresh	43-60
	#Modeline	"1024x768@75" 83.91 1280 1312 1624 1656 800 816 824 841
	#Modeline 	"1024x768@100" 113.309 1024 1096 1208 1392 768 769 772 814 +hsync +vsync
	#Modeline	"1152x864@75" 108.00   1152 1176 1304 1484 864 873 876 912 +hsync +vsync
	#Modeline	"1280x800@60" 83.91 1280 1312 1624 1656 800 816 824 841
	Modeline 	"1160x864_85.00"  121.50  1160 1240 1368 1576  864 865 868 907  -HSync +Vsync
EndSection

Section "Screen"
	Identifier	"Screen0"
	Device		"ATI Technologies, Inc. Radeon 9200 SE (RV280)"
	Monitor		"BenQ"
	DefaultDepth	24
	SubSection "Display"
		Depth		1
		Modes		"1280x1024" "1280x960" "1280x854" "1280x800" "1280x768" "1152x864" "1152x768" "1024x768" "800x600" "640x480"
	EndSubSection
	SubSection "Display"
		Depth		4
		Modes		"1280x1024" "1280x960" "1280x854" "1280x800" "1280x768" "1152x864" "1152x768" "1024x768" "800x600" "640x480"
	EndSubSection
	SubSection "Display"
		Depth		8
		Modes		"1280x1024" "1280x960" "1280x854" "1280x800" "1280x768" "1152x864" "1152x768" "1024x768" "800x600" "640x480"
	EndSubSection
	SubSection "Display"
		Depth		15
		Modes		"1280x1024" "1280x960" "1280x854" "1280x800" "1280x768" "1152x864" "1152x768" "1024x768" "800x600" "640x480"
	EndSubSection
	SubSection "Display"
		Depth		16
		Modes		"1280x1024" "1280x960" "1280x854" "1280x800" "1280x768" "1152x864" "1152x768" "1024x768" "800x600" "640x480"
	EndSubSection
	SubSection "Display"
		Depth		24
		Modes		"1280x1024" "1280x960" "1280x854" "1280x800" "1280x768" "1152x864" "1152x768" "1024x768" "800x600" "640x480"
	EndSubSection
EndSection



Section "Screen"
    Identifier "Screen1"
    Device "ATI Technologies, Inc. Radeon 9200 SE (RV280)2"
    Monitor "Sony"
    DefaultColorDepth 24
    Subsection "Display"
        Depth 24
#        Virtual 1280 1024
        Modes    "1024x768"#1152x864 
    EndSubsection    
EndSection






Section "Screen"
	Identifier "Screen2"
	Device "ATI Technologies, Inc. Radeon 9200 SE (RV280)2"
	Monitor "Tele"
	DefaultDepth 24
	#Option "backingstore"

	Subsection "Display"
		Depth 24
		Modes "800x600"
		ViewPort 0 0 # initial origin if mode is smaller than desktop
		# Virtual 1280 1024
	EndSubsection
EndSection





#Section "ServerLayout"
#	Identifier	"Default Layout"
#	Screen		"Default Screen"
#	InputDevice	"Generic Keyboard"
#	InputDevice	"Configured Mouse"
#EndSection

Section "ServerLayout"
    Identifier "Multihead layout"
	InputDevice	"Generic Keyboard"
	InputDevice	"Configured Mouse"
    Screen  "Screen0" 0 0
    Screen  "Screen1" RightOf "Screen0" 
EndSection

Section "DRI"
	Mode	0666
EndSection

Dernière modification par LR (Le 26/11/2005, à 21:41)

Hors ligne

#2 Le 24/11/2005, à 11:23

LR

Re : [Résolu] Probleme de clavier

Personne ne peux m'aider pour ça ?

Hors ligne

#3 Le 24/11/2005, à 11:35

cep_

Re : [Résolu] Probleme de clavier

Quelques pistes d'investigation en parcourant ce poste depuis :

http://forum.ubuntu-fr.org/viewtopic.php?pid=93167#p93167

#4 Le 26/11/2005, à 12:24

marc.53

Re : [Résolu] Probleme de clavier

As tu choisi le français suisse dans sytème->administration->langage ?
Moi, j'ai tous les accents que je veux.........éééééééééé  èèèèèèèèè  ààààààààà

Hors ligne

#5 Le 26/11/2005, à 21:41

LR

Re : [Résolu] Probleme de clavier

J'ai trouvé, j'ai du modifier mon xorg.conf comme ça :

Section "InputDevice"
	Identifier	"Generic Keyboard"
	Driver		"kbd"	#"keyboard"
	Option		"CoreKeyboard"
	Option		"XkbRules"	"xorg"
	Option		"XkbModel"	"pc105"
	Option		"XkbLayout"	"ch"	#"FR_ch"
	#Option		"XkbOptions"	"fr_CH"
	Option          "XkbVariant"    "fr"
EndSection

Je pense que j'ai merdé en faisant un reconfigure de xorg...

Merci pour votre aide

Hors ligne

Haut de page ↑