Contenu | Rechercher | Menus

Annonce

DVD, clés USB et t-shirts Ubuntu-fr disponibles sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#26 Le 18/08/2014, à 17:12

ikewdu

Re : [RÉSOLU] Dual-Boot Windows 8.1 EFI * Grub disparu après démarrage Win

Re,

Tu es de toute évidence confronté à un bios /uefi qui bride le démarrage sur W8. Après Toshiba, c'est Dell... il me semble l'avoir vu aussi sur Sony (ça commence à faire du monde).

Edit. La bidouille bootmgfw.efi est d'ailleurs une "fausse bonne solution". Dès la première MAJ des fichiers efi (W8 le fait de temps en temps), retour à la case départ. Il y a intérêt à regarder le bios de très près quand on achète un pc... de toute évidence.

Edit 2. En réactivant l'hibernation, hiberfil sera recréé automatiquement. En ce qui me concerne, je vire systématiquement cette cochonnerie qui n'a d'autre finalité que de tomber en rade... et c'est fréquent.

Hors ligne

#27 Le 18/08/2014, à 17:27

malbo

Re : [RÉSOLU] Dual-Boot Windows 8.1 EFI * Grub disparu après démarrage Win

ikewdu a écrit :

Tu es de toute évidence confronté à un bios /uefi qui bride le démarrage sur W8. Après Toshiba, c'est Dell...

ça reste à démontrer parce que l'ordi de notre ami est peut-être en panne. Moi, je sais que je vois des installation non bridées de Dell :
http://forum.ubuntu-fr.org/viewtopic.ph … #p16995651
http://forum.ubuntu-fr.org/viewtopic.ph … #p16796971
Mais je crois qu'il y en a eu des bridées dans les années passées.

Hors ligne

#28 Le 18/08/2014, à 20:10

kokotx

Re : [RÉSOLU] Dual-Boot Windows 8.1 EFI * Grub disparu après démarrage Win

Re-bonjour,

ikewdu, le fait que Windows 8 puisse annuler la bidouille m'a découragé d'essayer.

J'ai cherché sur le Web et j'ai trouvé des gens chez qui ce dual-boot fonctionne sur un Dell Inspiron 660 ! J'ai donc tenté leur solution et... Ça marche \o/

Voici donc la solution pour ce PC Dell Inspiron 660 avec Windows 8.1 et Ubuntu 14.04 (enfin, plus précisément Linux Mint 17 Cinnamon) :

- Activer Secure Boot dans le bios
- Optionnel ? Vérifier qu'Ubuntu démarre bien
- Optionnel ? Vérifier que le fichier de boot est bien \EFI\ubuntu\shimx64.efi en exécutant la commande

sudo efibootmgr -v

- Si c'est OK, quitter Ubuntu et démarrer Windows
- Ouvrir l'invite de commandes en tant qu'Administrateur
- Saisir la commande :

bcdedit /set {bootmgr} path \EFI\ubuntu\shimx64.efi

- Redémarrer
- Bonjour le menu Grub :-)

J'ai procédé au démarrage d'Ubuntu et de Windows plusieurs fois, c'est bon.
Encore merci pour votre aide.

Dernière modification par kokotx (Le 18/08/2014, à 20:20)

Hors ligne

#29 Le 18/08/2014, à 21:23

ikewdu

Re : [RÉSOLU] Dual-Boot Windows 8.1 EFI * Grub disparu après démarrage Win

Re,

Tellement simple qu'on aurait dû y penser. Bravo à toi.

Hors ligne

#30 Le 18/08/2014, à 21:47

kokotx

Re : [RÉSOLU] Dual-Boot Windows 8.1 EFI * Grub disparu après démarrage Win

Dans le cas de ce PC, c'est Windows qui met des bâtons dans les roues du dual-boot en reconfigurant UEFI au démarrage. À noter, il s'agit d'un Windows « pas pro ». C'est une bonne chose que le Secure Boot soit activé et que Windows laisse la possibilité de choisir le fichier de boot ; pourvu que ça dure ^^. J'espère que les mises à jour Win ne m'obligeront pas à refaire la manip, auquel cas je le signalerai ici.

Hors ligne

#31 Le 19/08/2014, à 00:28

Bougron

Re : [RÉSOLU] Dual-Boot Windows 8.1 EFI * Grub disparu après démarrage Win

kokotx a écrit :

Re-bonjour,

ikewdu, le fait que Windows 8 puisse annuler la bidouille m'a découragé d'essayer.

J'ai cherché sur le Web et j'ai trouvé des gens chez qui ce dual-boot fonctionne sur un Dell Inspiron 660 ! J'ai donc tenté leur solution et... Ça marche \o/

Voici donc la solution pour ce PC Dell Inspiron 660 avec Windows 8.1 et Ubuntu 14.04 (enfin, plus précisément Linux Mint 17 Cinnamon) :

- Activer Secure Boot dans le bios
- Optionnel ? Vérifier qu'Ubuntu démarre bien
- Optionnel ? Vérifier que le fichier de boot est bien \EFI\ubuntu\shimx64.efi en exécutant la commande

sudo efibootmgr -v

- Si c'est OK, quitter Ubuntu et démarrer Windows
- Ouvrir l'invite de commandes en tant qu'Administrateur
- Saisir la commande :

bcdedit /set {bootmgr} path \EFI\ubuntu\shimx64.efi

- Redémarrer
- Bonjour le menu Grub :-)

J'ai procédé au démarrage d'Ubuntu et de Windows plusieurs fois, c'est bon.
Encore merci pour votre aide.

Merci pour ta recherche.
Sur mon micro le secure boot n'est pas activé.
J'ai fais un copier/coller de la commande que tu indiques.
Même constat que toi. Un redémarrage de windows lance le grub qui permet  le  choix.
Cette commande est native en windows, Le logiciel EASYBCD ne sert à rien.

Dernière modification par Bougron (Le 19/08/2014, à 00:29)

Hors ligne

#32 Le 19/08/2014, à 18:46

Bougron

Re : [RÉSOLU] Dual-Boot Windows 8.1 EFI * Grub disparu après démarrage Win

Bonjour.
J'ai deux  questions qui ne sont pas anodines.
                 Tu passes bien par le menu grub ?
                              Qui te proposes Unbuntu ou windows
                Si tu choisis   Windows,
                              As-tu un menu te proposant
                                  La mise en route de windows ou  shimx64 ?
     J'ai l'impression que c'est seulement à l'arrêt de windows avec l'option redémarrage  que la question " windows ou shimx64" est posée.
En tout cas c'est comme cela sur mon micro et je tente d'avoir cette question au démarrage et non à l'arrêt afin d'avoir un vrai dual boot managé par  windows.

Hors ligne

#33 Le 19/08/2014, à 21:46

kokotx

Re : [RÉSOLU] Dual-Boot Windows 8.1 EFI * Grub disparu après démarrage Win

Bonsoir,

Bougron a écrit :

Tu passes bien par le menu grub ?
Qui te proposes Ubuntu ou windows

Oui, le menu Grub me propose Windows ou Ubuntu (Mint...).

Bougron a écrit :

Si tu choisis Windows,
As-tu un menu te proposant La mise en route de windows ou  shimx64 ?

Non, pas de menu, Windows démarre.

Dans tous les cas de figure le comportement du PC est le même : affichage du menu Grub et démarrage direct du système choisi.
Tout roule :-)

Hors ligne

#34 Le 21/08/2014, à 15:28

malbo

Re : [RÉSOLU] Dual-Boot Windows 8.1 EFI * Grub disparu après démarrage Win

kokotx a écrit :

démarrer Windows
- Ouvrir l'invite de commandes en tant qu'Administrateur
- Saisir la commande :

bcdedit /set {bootmgr} path \EFI\ubuntu\shimx64.efi

- Redémarrer
- Bonjour le menu Grub :-)

EDIT1 pour complément d'info :
--------------------------------------------------
après saisie de la commande ci-dessus, on peut contrôler que c'est bien enregistré dans Windows 8.1 en tapant la commande bcdedit qui affiche tout un baratin dans lequel on doit retrouver la ligne "path" modifiée dans la partie "Gestionnaire de démarrage Windows" :
mini_211253Capturedu20140821123902.png
--------------------------------------------------
Si on veut rétablir le démarrage par défaut sur Windows 8 comme au départ, c'est ça :
démarrer Windows
- Ouvrir l'invite de commandes en tant qu'Administrateur
- Saisir la commande :

bcdedit /set {bootmgr} path \EFI\Microsoft\Boot\bootmgfw.efi

- Redémarrer
- Bonjour Windows 8 direct

EDIT2 : voici comment on peut visualiser depuis la session Ubuntu l'effet de la commande "bcdedit /set {bootmgr} path \EFI\ubuntu\shimx64.efi" qui aura été passée depuis Windows : il suffit de passer la commande suivante dans un terminal :

sudo efibootmgr -v

mini_740670Capturedu20140821124654.png
On voit que c'est l'entrée UEFI nommée "Windows Boot Manager" qui est en priorité de démarrage et qu'elle pointe vers le fichier \EFI\ubuntu\shimx64.efi
---------------------------------------------------------------------------------------------------------------------------
EDIT3 (le 24 oct 2014) : si on supprime dans le "Bios" l'entrée "Windows Boot Manager" (c'est possible dans certains ordis mais pas forcément dans ceux qui ont un "Bios" verrouillé), au prochain démarrage sur Windows 8 cette entrée est recrée automatiquement dans le "Bios" et elle pointe sur ce qui a été défini par la commande "bcdedit /set {bootmgr} path...". Si on l'a fait pointer sur \EFI\ubuntu\shimx64.efi, au redémarrage suivant c'est bien le menu Grub qui apparaîtra par défaut.
-----------------------------------------------------------------------------------------------------------------------------
EDIT4 le 25 janv 2015 : mise en œuvre détaillée de ce qui est exposé dans l'EDIT3 en virtualisation (avec VMware Player) :
- État de départ : la modif par bcdedit a déjà été faite depuis Windows 8 pour que "Windows Boot Manager" pointe sur le chargeur d'amorçage de Ubuntu shimx64.efi comme on peut voir en passant la commande "sudo efibootmgr -v" depuis une session de Ubuntu :

malbo@pc-virtuel:~$ sudo efibootmgr -v
[sudo] password for malbo: 
BootCurrent: 0001
Timeout: 2 seconds
BootOrder: 0001,0002,0004,0000,0003,0007
Boot0000* EFI Internal Shell (Unsupported option)	MM(b,3efba000,3f344fff)FvFile(c57ad6b7-0515-40a8-9d21-551652854e37)
Boot0001* ubuntu	HD(2,96800,32000,1ccc0f6b-032a-45c8-b25e-b50e2dc5ee8d)File(\EFI\ubuntu\shimx64.efi)
Boot0002* Windows Boot Manager	HD(2,96800,32000,1ccc0f6b-032a-45c8-b25e-b50e2dc5ee8d)File(\EFI\ubuntu\shimx64.efi)WINDOWS.........x...B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.4.7.9.5.}....................
Boot0003* EFI VMware Virtual SCSI Hard Drive (0.0)	ACPI(a0341d0,0)PCI(10,0)SCSI(0,0)
Boot0004* EFI Network	ACPI(a0341d0,0)PCI(11,0)PCI(1,0)MAC(MAC(000c2932a745,0)
Boot0007* EFI VMware Virtual SATA CDROM Drive (0.0)	ACPI(a0341d0,0)PCI(11,0)PCI(5,0)SATA(0,0,0)

 
- Suppression de l'entrée "Windows Boot Manager"
Je passe la commande de suppression de suppression de l'entrée Boot0002 :

malbo@pc-virtuel:~$ sudo efibootmgr -b 0002 -B
BootCurrent: 0001
Timeout: 2 seconds
BootOrder: 0001,0004,0000,0003,0007
Boot0000* EFI Internal Shell (Unsupported option)
Boot0001* ubuntu
Boot0003* EFI VMware Virtual SCSI Hard Drive (0.0)
Boot0004* EFI Network
Boot0007* EFI VMware Virtual SATA CDROM Drive (0.0)

- Recréation automatique de cette entrée par Windows 8 : 

Je redémarre sur Windows 8 en passant par le menu Grub et je quitte Windows par Redémarrer. ça redémarre sur le menu Grub et je sélectionne ubuntu. Je peux alors vérifier que Windows a recréé de toute pièce une entrée Boot0002 nommée "Windows Boot Manager" qui pointe sur \EFI\ubuntu\shimx64.efi et qui est en priorité de démarrage. La ligne "BootCurrent: 0002" confirme bien que le démarrage s'est fait sur cette entrée Boot0002 :

malbo@pc-virtuel:~$ sudo efibootmgr -v
[sudo] password for malbo: 
BootCurrent: 0002
Timeout: 2 seconds
BootOrder: 0002,0001,0004,0000,0003,0007
Boot0000* EFI Internal Shell (Unsupported option)	MM(b,3efba000,3f344fff)FvFile(c57ad6b7-0515-40a8-9d21-551652854e37)
Boot0001* ubuntu	HD(2,96800,32000,1ccc0f6b-032a-45c8-b25e-b50e2dc5ee8d)File(\EFI\ubuntu\shimx64.efi)
Boot0002* Windows Boot Manager	HD(2,96800,32000,1ccc0f6b-032a-45c8-b25e-b50e2dc5ee8d)File(\EFI\ubuntu\shimx64.efi)WINDOWS.........x...B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.4.7.9.5.}....................
Boot0003* EFI VMware Virtual SCSI Hard Drive (0.0)	ACPI(a0341d0,0)PCI(10,0)SCSI(0,0)
Boot0004* EFI Network	ACPI(a0341d0,0)PCI(11,0)PCI(1,0)MAC(MAC(000c2932a745,0)
Boot0007* EFI VMware Virtual SATA CDROM Drive (0.0)	ACPI(a0341d0,0)PCI(11,0)PCI(5,0)SATA(0,0,0)

Dans ce résultat de la commande sudo efibootmgr -v, l'entrée recréée Boot0002 est identique à ce qu'elle était avant sa suppression.

Dernière modification par malbo (Le 25/01/2015, à 07:44)

Hors ligne

#35 Le 03/09/2014, à 21:39

sirenoyel

Re : [RÉSOLU] Dual-Boot Windows 8.1 EFI * Grub disparu après démarrage Win

Merci Malbo, je viens de retrouver Grub, et ça fonctionne à tout les coups. Voici mon nouveau résultat efiboot :

sirenoyel@sirenoyel-SVE1713L1EW:~$ sudo efibootmgr -v
[sudo] password for sirenoyel:
BootCurrent: 0003
Timeout: 0 seconds
BootOrder: 0003,0002,0004,0001,0000,2001
Boot0000* Windows Boot Manager    HD(1,800,82000,a8e72081-03fa-442d-8a41-202535ab3207)File(\EFI\Microsoft\Boot\bootmgfw.efi)RC
Boot0001* Ubuntu    HD(3,363800,82000,0071e00d-4005-49ac-9fb6-8da0098fcde1)File(\EFI\ubuntu\grubx64.efi)RC
Boot0002* ubuntu    HD(3,363800,82000,0071e00d-4005-49ac-9fb6-8da0098fcde1)File(\EFI\ubuntu\shimx64.efi)
Boot0003* Windows Boot Manager    HD(3,363800,82000,0071e00d-4005-49ac-9fb6-8da0098fcde1)File(\EFI\ubuntu\shimx64.efi)WINDOWS.........x...B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.4.7.9.5.}...u................
Boot0004* Windows Boot Manager    HD(3,363800,82000,0071e00d-4005-49ac-9fb6-8da0098fcde1)File(\EFI\Microsoft\Boot\bootmgfw.efi)RC
Boot2001* EFI USB Device    RC
sirenoyel@sirenoyel-SVE1713L1EW:~$

Hors ligne

#36 Le 03/09/2014, à 22:14

sirenoyel

Re : [RÉSOLU] Dual-Boot Windows 8.1 EFI * Grub disparu après démarrage Win

Je viens d'activer Gparted, il me reste 156Gio non alloué, j'aimerais une partition capable d'être lue par UBUNTU et Windows 8.1 pour échanger des données entre les deux systèmes. Quel format choisir, NTFS?

Hors ligne

#37 Le 04/10/2014, à 15:53

mohican

Re : [RÉSOLU] Dual-Boot Windows 8.1 EFI * Grub disparu après démarrage Win

sirenoyel a écrit :

Je viens d'activer Gparted, il me reste 156Gio non alloué, j'aimerais une partition capable d'être lue par UBUNTU et Windows 8.1 pour échanger des données entre les deux systèmes. Quel format choisir, NTFS?

Oui : NTFS


mohican, plus tout à fait débutant sur Ubuntu.

4x boot : 14.04 Unity 64bits à 95% // Mint 19 Xfce 64b en test // Mint 19 Cinnamon 64b en test // Win7 SP1 64b à 5%

Hors ligne

#38 Le 07/12/2014, à 07:32

Tamarou

Re : [RÉSOLU] Dual-Boot Windows 8.1 EFI * Grub disparu après démarrage Win

Merci à tous pour vos recherches, elles m'ont aidé à régler le même problème de démarrage.

Sur un dual-boot 8.1/xubuntu qui fonctionnait très bien, windows est devenu prioritaire et obligatoire après un démarrage en mode de boot csm (legacy) pour tester une live usb persistante.
Au retour en mode uefi, plus de grub et démarrage en windows direct.


Le commande passée dans windows a rétabli la priorité à grub et donc le choix de l'OS.

Dernière modification par Tamarou (Le 07/12/2014, à 07:34)

Hors ligne

#39 Le 07/12/2014, à 09:56

malbo

Re : [RÉSOLU] Dual-Boot Windows 8.1 EFI * Grub disparu après démarrage Win

@Tamarou : dans de nombreux cas, la solution 7. Dépannage du dual-boot avec Windows 8 est suffisante. Elle est simple à réaliser et très fiable. Je veux simplement te dire que la commande "bcdedit /set {bootmgr} path \EFI\ubuntu\shimx64.efi" depuis Windows n'est pas absolument indispensable. Et je suis quasiment persuadé que tu aurais pu te contenter de la première solution.

Dernière modification par malbo (Le 07/12/2014, à 09:59)

Hors ligne

#40 Le 08/12/2014, à 11:19

Tamarou

Re : [RÉSOLU] Dual-Boot Windows 8.1 EFI * Grub disparu après démarrage Win

Merci pour l'info. Ce sera utile une prochaine fois ...  peut-être. J'ai pensé qu'il serait plus sûr de travailler dans windows que de risquer une installation de Grub tongue

En fait je cherchais à résoudre un problème pour lequel je vais certainement finir par ouvrir un nouveau sujet : j'ai un disque ssd sur lequel les distributions s'installent bien, mais qui ne veut booter sur aucune machine.

Dernière modification par Tamarou (Le 08/12/2014, à 11:30)

Hors ligne

#41 Le 29/08/2015, à 14:12

carbone_vtt

Re : [RÉSOLU] Dual-Boot Windows 8.1 EFI * Grub disparu après démarrage Win

Bonjour à tous,

J'ai testé la méthode du post #28 sur un HP Pavilion 15 : ça a marché impec.

Bravo et merci !

Hors ligne

#42 Le 31/08/2015, à 09:43

Bougron

Re : [RÉSOLU] Dual-Boot Windows 8.1 EFI * Grub disparu après démarrage Win

kokotx a écrit :

Bonjour,

j'ai déjà installé plusieurs fois Ubuntu en dual boot avec Windows 7 sans problème. Sur un nouveau PC, j'ai voulu essayer Linux Mint 17. Je me permets de poster ma question ici car je crois que mon problème (et sa solution) sont identiques pour Mint 17 et Ubuntu 14.04 et que ce forum est bien plus actif ;-)

J'ai donc installé depuis un Live USB (en mode EFI, sur un même disque dur) Linux Mint 17 en dual boot sur un PC Windows 8.1 pré-installé en prenant les précautions que j'ai pu lire (désactiver le quick boot et même le secure boot dans Windows). Linux tourne comme une horloge sur ce PC.

Le problème est que lorsque je choisis depuis le menu Grub de démarrer Windows, Windows fonctionne mais au démarrage qui suit le menu Grub a disparu et je ne peux donc plus démarrer Linux, Windows démarre automatiquement. Pour l'instant, le seul moyen de retrouver le menu Grub consiste à utiliser Boot-Repair depuis un Live USB, ce qui me permet de retrouver Grub et de démarrer Linux. Mais si je choisis de démarrer Windows, le menu Grub disparait à nouveau.

Voici le Boot-Info généré par Boot-Repair : http://paste2.org/mfDyCDjW
Et si cela peut être utile, voici mon grub.cfg : http://paste2.org/0p2Aswsz

J'ai cherché des infos, une solution mais je n'ai pas compris grand chose. Si l'un de vous pouvait m'indiquer une piste ce serait très sympa.

Merci !

Bonjour.
Comme je me souviens que tu as pas mal cherché et trouvé une solution à ce problème (solution que j'ai fait mienne, jusqu'à hier) je me permets de t'informer que maintenant je fais autrement. Si tu es intérressé par la méthode que j'utilise , voici  un lien. http://forum.ubuntu-fr.org/viewtopic.ph … #p20506271

Dernière modification par Bougron (Le 15/10/2015, à 15:59)

Hors ligne

#43 Le 15/10/2015, à 14:39

kokotx

Re : [RÉSOLU] Dual-Boot Windows 8.1 EFI * Grub disparu après démarrage Win

Bonjour,
merci d'avoir posté une autre méthode.

Et sinon, j'ai appliqué la mise à jour Windows 10 sur Windows 8.1 : le menu Grub a disparu. Dans Windows, j'ai à nouveau entré la commande

bcdedit /set {bootmgr} path \EFI\ubuntu\shimx64.efi

et tout est rentré dans l'ordre. Nickel !

Hors ligne

#44 Le 03/11/2015, à 16:41

docteur97

Re : [RÉSOLU] Dual-Boot Windows 8.1 EFI * Grub disparu après démarrage Win

bonjour à tous
perso quand je fait la commande

bcdedit /set {bootmgr} path \EFI\ubuntu\shimx64.efi

et la console m'affiche un message de reussite ("la command à reussi") pourtant lors du rémarrage aucun changement, je démarre sur windows
si vous avez une solution pour moi..

ps : lors du lancement depuis le bios de EFI\ubuntu\shimx64.efi je tombe bien sur mon grub

Dernière modification par docteur97 (Le 03/11/2015, à 16:44)

Hors ligne

#45 Le 03/11/2015, à 17:59

Bougron

Re : [RÉSOLU] Dual-Boot Windows 8.1 EFI * Grub disparu après démarrage Win

Bonjour
Donnes le nom le plus exact possible de ton micro et fais un boot-info.

Hors ligne

#46 Le 24/01/2016, à 16:06

piotw2

Re : [RÉSOLU] Dual-Boot Windows 8.1 EFI * Grub disparu après démarrage Win

docteur97 a écrit :

bonjour à tous
perso quand je fait la commande

bcdedit /set {bootmgr} path \EFI\ubuntu\shimx64.efi

et la console m'affiche un message de reussite ("la command à reussi") pourtant lors du rémarrage aucun changement, je démarre sur windows
si vous avez une solution pour moi..

ps : lors du lancement depuis le bios de EFI\ubuntu\shimx64.efi je tombe bien sur mon grub

idem pour moi sur hp pavilion 15-e043sf (product number : D9V97EA#ABF)
et efibootmgr ne fonctionne pas non plus

win10 + Mint 17.3

j'abandonne car je pense que le bios est en cause et en plus le site de HP indique que le pc n'a pas été testé (certifié?) avec win10


LinuxMint18.1 + Mate / je regrette toujours la 10.04
"La servitude moderne est une servitude volontaire, consentie par la foule des esclaves qui rampent à la surface de la Terre. Ils achètent eux-mêmes toutes les marchandises qui les asservissent..."
Jean-François Brient
the film

Hors ligne

#47 Le 25/01/2016, à 00:30

Bougron

Re : [RÉSOLU] Dual-Boot Windows 8.1 EFI * Grub disparu après démarrage Win

piotw2 a écrit :
docteur97 a écrit :

bonjour à tous
perso quand je fait la commande

bcdedit /set {bootmgr} path \EFI\ubuntu\shimx64.efi

et la console m'affiche un message de reussite ("la command à reussi") pourtant lors du rémarrage aucun changement, je démarre sur windows
si vous avez une solution pour moi..

ps : lors du lancement depuis le bios de EFI\ubuntu\shimx64.efi je tombe bien sur mon grub

idem pour moi sur hp pavilion 15-e043sf (product number : D9V97EA#ABF)
et efibootmgr ne fonctionne pas non plus

win10 + Mint 17.3

j'abandonne car je pense que le bios est en cause et en plus le site de HP indique que le pc n'a pas été testé (certifié?) avec win10

Que se passe-t-il si tu décides d'appuyer sur la touche F9?

Dernière modification par Bougron (Le 25/01/2016, à 00:30)

Hors ligne

#48 Le 11/03/2016, à 16:24

shyalan

Re : [RÉSOLU] Dual-Boot Windows 8.1 EFI * Grub disparu après démarrage Win

kokotx a écrit :

démarrer Windows
- Ouvrir l'invite de commandes en tant qu'Administrateur
- Saisir la commande :

bcdedit /set {bootmgr} path \EFI\ubuntu\shimx64.efi

- Redémarrer
- Bonjour le menu Grub :-)

J'ai procédé au démarrage d'Ubuntu et de Windows plusieurs fois, c'est bon.
Encore merci pour votre aide.

cool
Merci à tous, cette manip m'a également permi de récupérer GRUB après la mise à jour win 8.1.
Heureusement que vous êtes là ! wink

Prenez soin de vous ! smile

big_smile


Asus Gamer G55VW - i7 - 16 Go Ram - Nvidia GTX 660M (2Go dédié) - Ubuntu 20.04 (j'ai viré windows !!! enfin !)

Hors ligne

#49 Le 22/07/2016, à 16:38

michamint

Re : [RÉSOLU] Dual-Boot Windows 8.1 EFI * Grub disparu après démarrage Win

BOnjour a tous

Jai eu  ce probleme de dual boot.

a la place j'ai un windows 10
en effectuant cette commande j'ai tout simplement No Bootable Device, ni windows 10, ni linux mint ne boote,

que faire
merci de votre aide

kokotx a écrit :

Re-bonjour,

ikewdu, le fait que Windows 8 puisse annuler la bidouille m'a découragé d'essayer.

J'ai cherché sur le Web et j'ai trouvé des gens chez qui ce dual-boot fonctionne sur un Dell Inspiron 660 ! J'ai donc tenté leur solution et... Ça marche \o/

Voici donc la solution pour ce PC Dell Inspiron 660 avec Windows 8.1 et Ubuntu 14.04 (enfin, plus précisément Linux Mint 17 Cinnamon) :

- Activer Secure Boot dans le bios
- Optionnel ? Vérifier qu'Ubuntu démarre bien
- Optionnel ? Vérifier que le fichier de boot est bien \EFI\ubuntu\shimx64.efi en exécutant la commande

sudo efibootmgr -v

- Si c'est OK, quitter Ubuntu et démarrer Windows
- Ouvrir l'invite de commandes en tant qu'Administrateur
- Saisir la commande :

bcdedit /set {bootmgr} path \EFI\ubuntu\shimx64.efi

- Redémarrer
- Bonjour le menu Grub :-)

J'ai procédé au démarrage d'Ubuntu et de Windows plusieurs fois, c'est bon.
Encore merci pour votre aide.

Hors ligne

#50 Le 22/07/2016, à 17:14

malbo

Re : [RÉSOLU] Dual-Boot Windows 8.1 EFI * Grub disparu après démarrage Win

michamint,
Je te prie de créer une discussion pour ton cas personnel. Les indications pour le faire sont dans 4.1 Initier une nouvelle discussion

Hors ligne