Contenu | Rechercher | Menus

Annonce

T-shirt Seiche Cosmic, Série limitée

L'équipe des administrateurs et modérateurs du forum vous invite à prendre connaissance des nouvelles règles.
En cas de besoin, vous pouvez intervenir dans cette discussion.

Ubuntu 18.10
T-shirt Ubuntu-FR « Seiche Cosmique » en série limitée ! Prix spécial pré-vente (15€) jusqu'au 4 novembre 2018.

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

Heure d'hiver: N'oubliez pas de décochez l'heure d'été dans votre profil.

#1 Le 16/09/2018, à 23:41

Rouge

[RESOLU] droits admin pour montage auto partage CIFS NAS ?

Bonjour à tous,

J'aimerais avoir votre aide si possible pour monter automatiquement mes dossiers partagés de mon NAS Synology.
Coté NAS, normalement tout est correctement configuré. L'utilisateur a les droits d'accès en lecture/écriture sur le dossier partagé. La partage samba est activé dans DSM. Je teste sous windows, ça fonctionne. je me fais même un script avec net use pour monter les dossiers au démarrage.

Sous Ubuntu 16.04, j'ai des soucis....
J'ai suivi ce tuto https://wiki.ubuntu.com/MountWindowsSharesPermanently , et comme je voulais un truc un peu safe quand même j'ai opté pour la modification du fstab avec mes identifiants stocké dans /root.
J'ai donc ajouté cette ligne dans mo fstab

//servername/sharename /home/windowsshare     cifs     credentials=/root/.smbcredentials,iocharset=utf8,sec=ntlm     0     0

et effectivement avec

sudo mount -a 

ça fonctionne. Mais au reboot ça ne marche pas. L'erreur me renvoie que seul le superutilisateur peut monter le dossier.
Du coup je teste

mount -a 

ça marche pas,

sudo mount -a 

ça marche.
C'est donc cohérent, mais du coup je pige pas...

Je précise que j'accède très bien au NAS via "connection à un serveur" de nautilus.

Qu'est-ce qu'il me manque pour que ce soit l'utilisateur qui monte les dossiers partagés ?
Est-ce une option dans le fstab ?

Merci d'avance !

Dernière modification par Rouge (Le 24/10/2018, à 16:20)


"Tu te réveilles à 35 ans pour te demander ce que ça veut dire «monde de merde» ? C’est pas que tu es indiscret, c’est juste que tu es un con." George ABITBOL
Ubuntu 16.04 64 bits ,Intel Core I5 3570K, Asus P8Z77-V LK, 8Go RAM, Nvidia GT440
Laptop iNote U931-M2 13.3" FHD: Ubuntu16.04 64 bits ,Intel Core 6200U - HD 520, 8Go RAM,

Hors ligne

#2 Le 17/09/2018, à 07:40

michel_04

Re : [RESOLU] droits admin pour montage auto partage CIFS NAS ?

Bonjour,


Dans mon /etc/fstab, ce n'est pas pour un NAS, mais pour monter le HDD de ma Freebox :

## HDD Freebox
//mafreebox.freebox.fr/Disque\040dur     /media/freebox     cifs     _netdev,username=freebox,password=********,cache=none,uid=1000,iocharset=utf8,file_mode=0777,dir_mode=0777,vers=1.0     0    0

A+

Hors ligne

#3 Le 17/09/2018, à 21:15

Rouge

Re : [RESOLU] droits admin pour montage auto partage CIFS NAS ?

Bonjour michel_04,

Tu pourrais m'éclairer sur les options que tu as mis :
cache=none : ?
uid=1000 : cette option veut dire que le montage se fera seulement pour toi c'est ça ?
file_mode=0777 : ?
dir_mode=0777 : ?
vers=1.0 : ?

Merci de ton aide !


"Tu te réveilles à 35 ans pour te demander ce que ça veut dire «monde de merde» ? C’est pas que tu es indiscret, c’est juste que tu es un con." George ABITBOL
Ubuntu 16.04 64 bits ,Intel Core I5 3570K, Asus P8Z77-V LK, 8Go RAM, Nvidia GT440
Laptop iNote U931-M2 13.3" FHD: Ubuntu16.04 64 bits ,Intel Core 6200U - HD 520, 8Go RAM,

Hors ligne

#4 Le 18/09/2018, à 07:23

michel_04

Re : [RESOLU] droits admin pour montage auto partage CIFS NAS ?

Bonjour,


Voir sur la page FreeboxV6 : Installation du disque réseau de la Freebox Server à chaque démarrage.


A+

Hors ligne

#5 Le 20/09/2018, à 22:28

Rouge

Re : [RESOLU] droits admin pour montage auto partage CIFS NAS ?

Bonsoir Michel,

Après avoir parcouru un bon nombre de pages.
Voici ma ligne de mon fstab qui marche à peu près :

//192.168.1.XX/Share /home/XXX/XXX/Share     cifs     _netdev,user,credentials=/home/XXX/.smbcredentials,uid=1000,gid=1000,iocharset=utf8,     0     0

Sans l'option "user" le montage ne voulais se faire qu'en mode root. Mais du coup je suis obligé de mettre mon  fichier .smbcredentials dans /home ce qui n'est pas très safe....
je dis cependant que ça marche à peu près car mon share ne se monte pas automatiquement, il faut que je clique dessus dans nautilus pour qu'il se monte. Ça me va pour l'instant, mais si quelqu'un connaît l'option je suis preneur !

En tout cas, merci !


"Tu te réveilles à 35 ans pour te demander ce que ça veut dire «monde de merde» ? C’est pas que tu es indiscret, c’est juste que tu es un con." George ABITBOL
Ubuntu 16.04 64 bits ,Intel Core I5 3570K, Asus P8Z77-V LK, 8Go RAM, Nvidia GT440
Laptop iNote U931-M2 13.3" FHD: Ubuntu16.04 64 bits ,Intel Core 6200U - HD 520, 8Go RAM,

Hors ligne

#6 Le 21/09/2018, à 06:47

lynn

Re : [RESOLU] droits admin pour montage auto partage CIFS NAS ?

Bonjour,

Chez moi ça fonctionne parfaitement avec ces options

nofail,vers=1.0,x-systemd.automount,x-systemd.idle-timeout=1min,nofail,_netdev,credentials=/root/nas.cred,uid=1000,gid=1000,iocharset=utf8,file_mode=0777,dir_mode=0777 0 0

N.B: Le fichier credentials doit être en mode 600 et appartenir à root. Tu peux le placer dans /root car quoi qu'il en soit, c'est le système et donc l'administrateur (root) qui monte tes partitions via fsatb.


«C'est pas parce qu'ils sont nombreux à avoir tort qu'ils ont raison!»

Coluche

Hors ligne

#7 Le 21/09/2018, à 22:22

Rouge

Re : [RESOLU] droits admin pour montage auto partage CIFS NAS ?

Merci de ton aide lynn,

En utilisant tes options ça a tout de suite marché correctement, à une chose près, impossible de démonter sans le sudo...
J'y ai apporté des modifications :
- Mon NAS est à jour donc aucune raison de rester en version 1, plus de vers=1.0,
- Le NAS tourne H24 donc pas besoin de x-systemd.idle-timeout=1min
- je retire file_mode=0777,dir_mode=0777 car je vois pas trop à quoi ça sert.

Je teste, et ça fonctionne, comme précédemment. cool !!

Après avoir testé un peu, il se trouve que c'est l'option x-systemd.automount qui monte le système de fichier au démarrage.

Reste que sans l'option "user", seul root peut démonter le système de fichier. Mais si je rajoute user, le montage ne se fait pas car il le user ne peux pas lire le fichier /root/.smbcredentials. A creuser...


Aussi, je m'interroge sur l'option uid, car sur man moun.cifs on peut lire que :

uid=arg
              sets  the uid that will own all files or directories on the mounted filesystem when
              the server does not provide ownership information. It may be specified as either  a
              username or a numeric uid. When not specified, the default is uid 0. The mount.cifs
              helper must be at  version  1.10  or  higher  to  support  specifying  the  uid  in
              non-numeric  form.  See the section on FILE AND DIRECTORY OWNERSHIP AND PERMISSIONS
              below for more information.

Qui si je comprend bien,veut dire que l'option uid défini l'uid qui va posséder tout les fichiers ou répertoires sur le system de fichier monté quand le server ne donne pas d'information de propriété.
Sauf que sur le NAS, on défini bien des user avec les permissions !!
Cependant, sur ce forum https://forum.ubuntu-fr.org/viewtopic.php?id=807161 on peut lire :

Le problème ici, c'est la gestion des droits d'accès de type Unix. Tout comme pour les volumes NTFS et FAT32, les droits d'accès dans les volumes CIFS (les dossiers partagés par SMB/CIFS) n'existent pas. Ubuntu doit simuler la gestion des droits d'accès; pour ce faire, au montage du volume, il attribue par défaut la propriété de l'ensemble des fichiers et dossiers du volume CIFS à l'utilisateur qui effectue le montage, c'est-à-dire root -- c'est toujours root qui ultimement effectue le montage des volumes dans Ubuntu.

Si on ne veut pas ce comportement et l'on veut attribuer la propriété des fichiers et dossiers du volume CIFS à un autre utilisateur (par exemple, ton compte d'utilisateur à toi), Il faut donc préciser une option à mount: l'option uid.

Donc je sais pas quoi penser, si quelqu'un veut bien m'éclairer ?...


En tout cas encore merci pour votre aide !

PS : il y a deux fois nofail dans tes options wink

Dernière modification par Rouge (Le 21/09/2018, à 22:23)


"Tu te réveilles à 35 ans pour te demander ce que ça veut dire «monde de merde» ? C’est pas que tu es indiscret, c’est juste que tu es un con." George ABITBOL
Ubuntu 16.04 64 bits ,Intel Core I5 3570K, Asus P8Z77-V LK, 8Go RAM, Nvidia GT440
Laptop iNote U931-M2 13.3" FHD: Ubuntu16.04 64 bits ,Intel Core 6200U - HD 520, 8Go RAM,

Hors ligne

#8 Le 24/10/2018, à 16:17

Rouge

Re : [RESOLU] droits admin pour montage auto partage CIFS NAS ?

Bon finalement je me réponds à moi même, mais j'ai résolu mon problème en changeant un poil mon postulat de départ.
Au lieu de monter automatiquement mon partage CIFS au démarrage, j'ai décider de le monter à la demande (car je suis  en ajoutant cette ligne dans mon fstab :

//192.168.1.XX/Share /home/XXX/XXX/Share     cifs     _netdev,user,,noauto,credentials=/home/XXX/.smbcredentials,iocharset=utf8,     0     0

Résultat, mon partage se monte bien dès que je clique sur dessus dans nautilus.
Il me reste plus qu'à bien protéger le fichier .smbcredentials qui se trouve maintenant dans mon /home

Par contre, j'aimerais bien que l'icône du dossier partagé n'apparaisse pas dans ma barre de lancement rapide (et oui je suis toujours sur la 16.04), quelqu'u sait comment faire ?


"Tu te réveilles à 35 ans pour te demander ce que ça veut dire «monde de merde» ? C’est pas que tu es indiscret, c’est juste que tu es un con." George ABITBOL
Ubuntu 16.04 64 bits ,Intel Core I5 3570K, Asus P8Z77-V LK, 8Go RAM, Nvidia GT440
Laptop iNote U931-M2 13.3" FHD: Ubuntu16.04 64 bits ,Intel Core 6200U - HD 520, 8Go RAM,

Hors ligne