Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails) *** mise à jour 12/10/2014 ***

#1 Le 27/10/2009, à 02:03

Rony4491

Associer des touches aux bureaux virtuels [RESOLU]

Bonsoir.

J'aimerais savoir si il est possible d'associer des touches du clavier (en l'occurence F9 F10 F11 et F12) à mes 4 bureaux virtuels ?



@+

Dernière modification par Rony4491 (Le 27/10/2009, à 19:45)


MacBook Late 2008 - OS X 10.8.3 Mountain Lion & Windows 7 Pro 64 bits
Plus jamais de Linux !

Hors ligne

#2 Le 27/10/2009, à 02:30

BR451

Re : Associer des touches aux bureaux virtuels [RESOLU]

Bonjour

Il y a plusieurs solutions, voilà pour la mienne :



- Ubuntu 9.04 (Gnome), CompizFusion

- Système > Préférences > Gestionnaire de Configuration ConpizConfig
- Changeur de Bureau > Aller sur un bureau spécifique



Note 1 : Il faut passer par "saisir une combinaison de touches", mais les touches "F" marchent très bien

Note 2 : Je te déconseille les touches "F" car elle sont déja très utilisées automatiquement par les logiciels, par exemple F11 pour le plein écran ou autre, je te conseille de laisser l'interface Gnome et les Logiciels les configurer pour toi. Pourquoi pas utiliser une vrai combinaison de touches pas trop dure à retenir, par exemple avec la touche Windows ( fenêtre... bureau différent... pas bête comme moyen mémo-technique) : Win+1 (noté "<Super>ampersand") Win+2 (noté <Super>eacute) ... Win+F1, Win+F2 ...
capturekn.th.png

Note 3 :
Si tu ne fais pas tout au clavier, et que tu as de temps en temps la main sur la souris, tu peux utiliser/ajouter dans ton "tableau de bord" le "sélecteur d'espaces de travail". Si tu ne veux pas l'afficher pour gagner de la place, tu as aussi la solution, toujours dans "CompizConfig", "Exposé", couplé à un clic droit de souris en haut de ton écran et/ou en bas (ou tout autre chose !!!!), bien pratique car tu peux visualiser le contenu de tes bureaux ! et tu peux déplacer les fenêtres d'un bureau à l'autre pour les organiser directement dans ce mode de bureaux en miniature (sans avoir à déplacer ta fenêtre sur un bord de l'écran pour la changer de bureau, avec une transition que je trouve laborieuse en dehors de "Exposé") !
capture1uk.th.png     capture2dp.th.png

Dernière modification par BR451 (Le 27/10/2009, à 03:21)


" 99% des bugs se situent entre le clavier et la chaise "
- Débutant - Ubuntu 9.04 - Gnome forever -
NON au minitel 2.0 -> www.fdn.fr -> www.rhien.org

Hors ligne

#3 Le 27/10/2009, à 02:35

willcoyote

Re : Associer des touches aux bureaux virtuels [RESOLU]

salut
oui c'est possible
ouvre le gestionnaire de configuration compiz
bureau=>rotation du cube=>bindings=>rotate to cube face

rotation vers la face 1=>clic sur desactivé , coche activé
clic sur : saisir une combinaison de touche et appuie sur f9

fait de meme pour les autres

edit BR451 qui m'a grillé a raison : utiliser seulement les touches f est deconseillé

Dernière modification par willcoyote (Le 27/10/2009, à 02:39)


archlinux+kde

Hors ligne

#4 Le 27/10/2009, à 19:44

Rony4491

Re : Associer des touches aux bureaux virtuels [RESOLU]

Bonsoir.

Il y a un souci avec la fonction "Changeur de Bureau"...:|
Je l'ai désactivé car il était pas pratique avec le touchepad, voir ici : http://forum.ubuntu-fr.org/viewtopic.php?id=351914

Sinon la solution à willcoyote fonctionne bien, merci !:P


MacBook Late 2008 - OS X 10.8.3 Mountain Lion & Windows 7 Pro 64 bits
Plus jamais de Linux !

Hors ligne

#5 Le 28/10/2009, à 00:44

BR451

Re : Associer des touches aux bureaux virtuels [RESOLU]

Rony4491 a écrit :

Bonsoir.

Il y a un souci avec la fonction "Changeur de Bureau"...:|
Je l'ai désactivé car il était pas pratique avec le touchepad, voir ici : http://forum.ubuntu-fr.org/viewtopic.php?id=351914

Sinon la solution à willcoyote fonctionne bien, merci !:P

99% des bugs se situent entre le clavier et la chaise

Il n'y a aucun souci ... le seul problème, c'est que cette option soit activée par défaut (je ne parle pas du plugin "Changeur de Bureau", mais bien de la fonction de la molette de la souris .

http://forum.ubuntu-fr.org/viewtopic.php?pid=3014445#p3014445

Note 1 : Pour changer de bureau, il vaut mieux configurer "Changeur de Bureau", il est fait pour ça et ne fait que ça.
Les faces du cube sont des bureaux aussi, et il existe un paramétrage dans ce plugin pour faire des raccourcis vers les bureaux (fonctions doublon avec "Changeur de Bureau" donc), MAIS si tu désactive ton cube (pour une raison "x" ou "y") tu perds cette fonction...

Note 2 : @Rony4491 : Il te faut donc pour la prochaine fois tout simplement, dans le même plugin, pour changer les raccourcis pour les bureaux virtuels :
1 - Activer et désigner les raccourcis clavier
2 - Désactiver les raccourcis souris

Ce principe (duo raccourcis clavier / raccourcis souris) est disponibles dans plusieurs plugins de ConpizFusion, par exemple "Exposé"

Dernière modification par BR451 (Le 28/10/2009, à 02:43)


" 99% des bugs se situent entre le clavier et la chaise "
- Débutant - Ubuntu 9.04 - Gnome forever -
NON au minitel 2.0 -> www.fdn.fr -> www.rhien.org

Hors ligne

Haut de page ↑