Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

Attention, une faille de sécurité dans bash a récemment été rapportée, il est recommandé de mettre à jour son système (plus de détails)

#26 Le 26/06/2006, à 14:35

vincentweb

Re : [Howto] Sagem fast 800 sous dapper

Très bon tutoriel
Merci

Par contre, je pense qu'il faudrait ajouter quelques trucs pour les débutants dans le [urlhttp://doc.ubuntu-fr.org/materiel/ueagle-atm]tutowiki[/url]

- qu'il faut installer gcc (et make ?), sinon on peut pas compiler
- qu'il faut d'abord mettre le CD Ubuntu, puis attendre quand il demande d'ouvrir le gestionnaire de packets graphiques (sinon on ne voit pas les paquets non-installés)

après pour la ligne "gedit /usr/bin/depart_adsl" il ne faut pas rajouter un 'sudo' ?  car je crois que ce sont des dossiers protégés, non ?

#27 Le 26/06/2006, à 22:22

creon

Re : [Howto] Sagem fast 800 sous dapper

Merci beaucoup à toi Cathou!!! J'écris depuis un firefox qui tourne sous ubuntu... j'ai eu une petite frayeur après la mise à jour, mais j'ai tout bien refait et ça marche smile !
Et merci pour ce tuto, à moi Ubuntu.. gnark gnark gnark !!

Hors ligne

#28 Le 28/06/2006, à 12:08

Cathou

Re : [Howto] Sagem fast 800 sous dapper

En cas de nouveau noyau, certains ont des difficultés qui se manifestent ainsi: au moment du sudo modprobe ueagle-atm, la commande répond ceci:

FATAL: Error inserting ueagle_atm : Unknown symbol in module, or unknown parameter (see dmesg)

et dmesg montre:

[17180074.808000] ueagle_atm: disagrees about version of symbol usbatm_usb_probe
[17180074.808000] ueagle_atm: Unknown symbol usbatm_usb_probe


Ce qui suit est une légère modification des étapes du tuto afin que la réinstallation du pilote se fasse à coup sûr.
NB: cela ne concerne QUE la réinstallation du pilote, et pas le paramétrage de la connexion (dhcp, ppp, etc..)

1) Blacklister le module eagle-usb. Pour cela, éditer via sudo le fichier /etc/modprobe.d/blacklist et rajouter les deux lignes suivantes à la fin:

# interdire le chargement du module eagle-usb
blacklist eagle-usb

En effet tous les noyaux dapper, passés ou futurs, ont tendance à vouloir charger ce module.

2) S'assurer d'avoir les fichiers nécessaires dans un répertoire du home:

mkdir ~/ueagle
cd ~/ueagle
wget http://download.gna.org/ueagleatm/ueagle-atm-1.3.tar.gz
tar zxvf ueagle-atm-1.3.tar.gz
rm ueagle-atm-1.3.tar.gz
wget http://eagle-usb.org/ueagle-atm/non-free/ueagle-data-1.1.tar.gz
tar zxvf ueagle-data-1.1.tar.gz
rm ueagle-data-1.1.tar.gz

3) Installer par apt-get (ou Synaptic, Aptitude..) le nouveau noyau, ainsi que ses headers. Selon les méta-paquets installés, cette installation effectue un remplacement du noyau en cours, c'est à dire une mise à jour, ou bien un rajout de noyau.
Ces différences n'ont pas de conséquence dans ce qui suit, mais quoiqu'il en soit vous devez connaître le nom de votre nouveau noyau, et on admettra qu'il se nomme par exemple 2.6.15-25-k7

4) Rebooter et choisir dans le menu grub le NOUVEAU noyau, puis procéder à quelques vérifications:

Dans /usr/src/ les deux répertoires suivants doivent être présents:

linux-headers-2.6.15-25
linux-headers-2.6.15-25-k7

..sinon les headers n'ont pas été installés correctement roll

Dans /lib/modules/ le répertoire correspondant au nouveau noyau doit être présent. Il doit notamment contenir un lien symbolique nommé build qui pointe sur les headers du noyau:

cd /lib/modules/`uname -r`
ls -l build

doit afficher:

build -> /usr/src/linux-headers-2.6.15-25-k7

En principe, dans /lib/firmware/ il doit déja exister un répertoire ueagle-atm contenant tous les firmwares. Si ce n'est pas le cas, faire:

sudo mkdir /lib/firmware/ueagle-atm
sudo cp ~/ueagle/ueagle-data-1.1/* /lib/firmware/ueagle-atm

5) Nettoyage:

sudo rm /lib/modules/`uname -r`/kernel/drivers/usb/atm/usbatm.ko
sudo rm -rf /lib/modules/`uname -r`/kernel/drivers/usb/net/eagle/

En principe, le répertoire /lib/modules/`uname -r`/extra/ n'existe pas. S'il existe, faire:

sudo rm /lib/modules/`uname -r`/extra/usbatm.ko
sudo rm /lib/modules/`uname -r`/extra/ueagle-atm.ko

Important: après ce nettoyage, il faut mettre à jour la base de dépendances de modules:

sudo depmod -ae

6) Rebooter et choisir dans le menu grub le NOUVEAU noyau. Puis vérifier les modules chargés. En faisant:

lsmod | grep usb

en principe on ne doit voir que cette ligne:

usbcore               138948  3 ehci_hcd,ohci_hcd

S'il y a plus d'une ligne, les modules usbatm et ueagle-atm ne doivent pas y figurer.

7) La compilation et l'installation peuvent être effectuées. Pour ce faire, il faut aller dans le répertoire des sources du module ueagle-atm:

cd ~/ueagle/ueagle-atm-1.3
make clean
make
sudo make install

8) Charger le module ueagle-atm:

sudo modprobe ueagle-atm

Surveiller les loupiotes du modem. Quand elles sont toutes les deux allumées, faire:

dmesg | grep ueagle

ce qui affiche plusieurs lignes, dont les deux dernières sont du genre:

[17179614.424000] usb 2-1: [ueagle-atm] modem operational
[17179614.432000] usb 2-1: [ueagle-atm] ATU-R firmware version : 44e2ea17

C'est à dire qu'on se trouve ramené à la fin de la 5ème étape dans le tuto du wiki smile

Remarques:
- ça ne sert à rien de brancher et débrancher le modem.
- il est superflu d'installer les sources du nouveau noyau, les headers suffisent.

Dernière modification par Cathou (Le 14/07/2006, à 06:41)

#29 Le 06/07/2006, à 10:49

lost-in-the-shell_doze

Re : [Howto] Sagem fast 800 sous dapper

Salut tout le monde,
J'ai suivi ce tuto (qui est le même que beaucoup d'autres, que ce soit dans les threads du forum ou dans la documentation d'Ueagle-atm), et j'ai réussi à tout installer. Les diodes sont allumées, et tout devrait marcher pour le mieux si le syslog n'était pas rempli de :

Jul  6 09:16:33 localhost pppd[5255]: Plugin pppoatm.so loaded.
Jul  6 09:16:33 localhost pppd[5261]: pppd 2.4.4b1 started by naji, uid 1000
Jul  6 09:16:33 localhost pppd[5261]: Using interface ppp0
Jul  6 09:16:33 localhost pppd[5261]: Connect: ppp0 <--> 0.35
Jul  6 09:17:01 localhost /USR/SBIN/CRON[5317]: (root) CMD (   run-parts --report /etc/cron.hourly)
Jul  6 09:17:03 localhost pppd[5261]: LCP: timeout sending Config-Requests 
Jul  6 09:17:03 localhost pppd[5261]: Connection terminated.
Jul  6 09:17:03 localhost pppd[5261]: Modem hangup
/* Même chose */
Jul  6 09:17:34 localhost pppd[5261]: Using interface ppp0
Jul  6 09:17:34 localhost pppd[5261]: Connect: ppp0 <--> 0.35
Jul  6 09:18:04 localhost pppd[5261]: LCP: timeout sending Config-Requests 
Jul  6 09:18:04 localhost pppd[5261]: Connection terminated.
Jul  6 09:18:04 localhost pppd[5261]: Modem hangup
/* Machin qui se répète en boucle */

Apparement, la connexion ppp0 avec les VPI et VCI que j'ai renseigné ne s'effectue pas. Ce sont pourtant les bonnes valeurs, vu que j'ai pour FAI Wanadoo Algérie (clé DZ01).
Dois-je tenter de remplacer le VCI par sa valeur hexa (23) ? Dois-je exécuter une danse de la pluie ?

LITS, qui souffre en silence.

#30 Le 06/07/2006, à 12:00

bapoumba

Re : [Howto] Sagem fast 800 sous dapper

@ lost-in-the-shell : j'en suis exactement au même point. ifconfig OK mais pas moyen d'accéder à internet même en renseignant les DNS Wanadoo/Orange dans /etc/resolv.conf.

Le firewall ne voir absolument rien de la connexion (alors que sous breezy et les anciens paquets eagle-usb compilés, tout roulait).

Voilà... Je pense changer de mode d'accès au réseau wink


| Ubuntu Forums |
J'aime les fraises.

Hors ligne

#31 Le 06/07/2006, à 12:06

lost-in-the-shell

Re : [Howto] Sagem fast 800 sous dapper

J'ai dû mal m'exprimer, car ifconfig ne me renvoie en fait que l'interface lo(calhost).

Je viens de contacter la hotline de mon FAI, qui m'a donné les valeurs suivantes :

VPI : 0
VCI : 35 (une fois converti à la main en héxadécimal, ça donne 23)

On m'a aussi conseillé de tenter une connection avec 8 pour VPI, ce qui n'a en rien amélioré mon cas.
En tout et pour tout, j'ai essayé les combinaisons suivantes :
- 0.35 (supposée marcher)
- 8.35
- 35.0
- 0.23
- 8.23
- 23.0
Quelqu'un ayant le même FAI que moi (je rappelle qu'il s'agit de Wanadoo Algérie, aKa Asila EEPAD) aurait-il rencontré des problèmes ?

LITS.

PS : Sous Windows, tout roule. Et avec eagle-usb, tout roulait.

Dernière modification par lost-in-the-shell (Le 07/07/2006, à 02:25)


Linux user #401253 - Ubuntu user #3023 .
Nick sur IRC : naji.
Pensez à adhérer au Comité de lutte contre le SMS.

Hors ligne

#32 Le 07/07/2006, à 02:34

Cathou

Re : [Howto] Sagem fast 800 sous dapper

Je pense que tu te trompes en mettant en cause tes VPI/VCI, la raison de l'échec est ailleurs.

Puisque tu utilises la clé DZ01, tu dois te connecter en PPPoE avec une encapsulation LLC.

OR ce qui est documenté dans les tutos que tu as pu trouver jusqu'à présent, c'est une connexion en PPPoA..
..ce qui est sensiblement différent smile

Si tu veux savoir comment faire pour te connecter en PPPoE, je te suggère de rechercher le paragraphe approprié dans cette page.

Tu auras vraisemblablement besoin d'installer les paquets libatm1 et br2684ctl et d'adapter ce qui est décrit dans le paragraphe à ton cas personnel.

Cela ne me semble pas insurmontable smile
Bonne continuation.

Dernière modification par Cathou (Le 07/07/2006, à 07:25)

#33 Le 07/07/2006, à 02:43

lost-in-the-shell

Re : [Howto] Sagem fast 800 sous dapper

Salut Cathou,
Tu viens de me démontrer que mon problème résidait entre la chaise et le clavier big_smile : j'aurais du vérifier le mode d'encapsulation utilisé dans les tutos que j'ai lu.
J'ai finalement résolu mon problème, et voilà comment je m'y suis pris :
- Installation des paquets manquants ( libatm1 et br2684ctl )
- modprobe br2684ctl
- Ajout de l'interface nas0 avec sudo br2684ctl -c 0 -e 0 -b -a VP.VC
- Up de nas0 ( sudo ifconfig nas0 up )
- Création d'un fichier /etc/ppp/peers/pppoe contenant :

user "mon_nom_dutilisateur"
# Chargement du plugin PPPoE
plugin rp-pppoe.so
# Interface Ethernet à laquelle le modem est raccordé
nas0
# Suppose que le FAI attribuera une adresse IP dynamiquement.
noipdefault
# Tenter de récupérer les adresses de DNS chez le FAI
usepeerdns
# Utiliser cette connexion comme route par défaut
defaultroute
# Forcer pppd à "renuméroter" en cas de déconnexion
persist
# Ne pas demander une authentification distante
noauth

- Connexion avec sudo pppd call pppoe (l'argument de l'option call est le nom d'un fichier se trouvant dans /etc/ppp/peers , comme dit dans les pages de man de pppd )
- Création d'un script Bash pour automatiser le tout (à lancer en root) :

#!/bin/bash
br2684ctl -c 0 -b -a VP.VC
ifup nas0
pppd call pppoe

En vous remerciant de m'avoir aidé à avoir une connexion qui fonctionne sans utiliser eagle-usb,
LITS.

Dernière modification par lost-in-the-shell (Le 07/07/2006, à 08:39)


Linux user #401253 - Ubuntu user #3023 .
Nick sur IRC : naji.
Pensez à adhérer au Comité de lutte contre le SMS.

Hors ligne

#34 Le 07/07/2006, à 15:56

Thierry002

Re : [Howto] Sagem fast 800 sous dapper

Bonjour à tous,
J'ai installé une kubuntu dapper sur un hp pavilion, avec un modem fast800, FAI cegetel. Grâce au tuto, tout fonctionne. C'est dommage qu'un simple apt-get install eagle-usb ne soit plus suffisant, mais il faut reconnaître que la connexion est plus stable et que le modem se synchronise beaucoup plus facilement que sous Windows.
Par contre, je suis peut-être allé trop vite, mais dans le tuto, est-ce qu'il ne manque pas ce fichier à télécharger ?(récupéré en lisant ce topic).
En tout cas, tout fonctionne et merci pour avoir pris la peine de faire quelque chose d'aussi détaillé. Bravo.
Une dernière question : la marche indiquée est-elle valable pour une debian ? les sudo en moins évidemment. J'ai une debian sur un autre pc, avec le même modem (interdiction de se moquer wink), mais il n'est pas configuré : le noyau est un 2.6.15 et les répertoires d'apt ne contiennent que les paquets eagle-usb . Comme ubuntu est basée sur debian, je me disais que...
A bientôt sur ce forum.

Hors ligne

#35 Le 07/07/2006, à 18:42

lost-in-the-shell

Re : [Howto] Sagem fast 800 sous dapper

Vu que tu compiles manuellement et que les répertoires du firmware et des modules sont les mêmes, ça n'a aucune raison de ne pas fonctionner. Quant à la connexion PPPoE, j'ai utilisé les packages Debian (je rappelle qu'ils sont disponibles sur http://packages.debian.org/ ) et je n'ai rencontré aucune erreur à ce niveau là.

LITS.


Linux user #401253 - Ubuntu user #3023 .
Nick sur IRC : naji.
Pensez à adhérer au Comité de lutte contre le SMS.

Hors ligne

#36 Le 13/07/2006, à 17:07

Cathou

Re : [Howto] Sagem fast 800 sous dapper

Euhh.. désolée mais ça ne me paraît pas une bonne idée de suggérer l'usage sous ubuntu de paquets debian pur sucre hmm

Surtout dans un sujet épinglé..

Ok quelquefois ça passe. Mais quand ça passe pas, ça peut faire du dégat. En plus il peut y avoir un effet de bombe à retardement, en particulier au moment d'une mise à jour sad

Du reste, les deux paquets en question existent sous ubuntu. D'ailleurs les liens que je t'avais indiqués dans mon post précédent pointent vers un dépot ubuntu.

Dernière modification par Cathou (Le 14/07/2006, à 06:43)

#37 Le 15/07/2006, à 22:30

laurentgire

Re : [Howto] Sagem fast 800 sous dapper

bonjour,
je suis sur wanadoo , amd64 ; dapper en 64 ;modem sagem usb
je crois avoir fait comme il est ecrit mais je n'arrive pas a me conecter m^me aprés un redemarrage!
voici ce que j'obtiens avec ifconf

laurent@laurent-ubuntu:~$ ifconfig
eth0      Link encap:Ethernet  HWaddr 00:30:1B:B9:47:58
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)
          Interrupt:217 Base address:0xc000

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:101 errors:0 dropped:0 overruns:0 frame:0
          TX packets:101 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:7424 (7.2 KiB)  TX bytes:7424 (7.2 KiB)

pas de pppxxx helas

comment faire, merci pour votre aide


amd64 nvidianforce4 shuttle_snp25 Gutsy32
roule au GPL

Hors ligne

#38 Le 16/07/2006, à 22:08

Arks

Re : [Howto] Sagem fast 800 sous dapper

Oh je crois que je devrai éssayer ça ^^

Hors ligne

#39 Le 24/07/2006, à 09:40

Romain23

Re : [Howto] Sagem fast 800 sous dapper

Bonjour à tous.

J'ai un problème avec ce modem. J'arrive à me connecter seulement 1 fois sur 2 environ. Une fois je peux naviguer sur internet et l'autre firefox m'affiche impossible d'afficher la page.

Hors ligne

#40 Le 24/07/2006, à 16:11

oracle2000

Re : [Howto] Sagem fast 800 sous dapper

bonjour mon voyant ver du pc e passe plus au vert simpliste pou expliquer ma panne mon monitor fontionne mais la carte graphique ne la detecte pas j'ai egalement chnger mes barrettes memoire mais rien une petite idee me depannerai  meci

Hors ligne

#41 Le 31/07/2006, à 08:55

jack77

Re : [Howto] Sagem fast 800 sous dapper

Bonjour,
je viens d'installer la Kubuntu 6 et j'ai suivi ton topic pour installer mon modem sagem 800
Je n'est qu'un mot a dire : BRAVO
mon seul petit soucis est que mon modem ne s'eteind pas lorsque je coupe mon ordi
Cdt
J77

Hors ligne

#42 Le 31/07/2006, à 19:11

laurentgire

Re : [Howto] Sagem fast 800 sous dapper

Bonjour,
j'ai installer le driver ueagle-atm et le Firmwares comme dans la doc du wiki détaillé de ubuntu, tous ce passe tres bien jusqu'a la derniere commande qui est :
ifcofig

ou je n'ai pas de ppp0 mais uniquement eth0 et l0 sans ppp0

en plus comble de tout je perds le clavier et la sourie (qui sont des logitech diNovo sans fil tous 2 raccordés à un unique recepteur usb)
1> comment retrouver l'usage du clavier en mode reparation (je suis debutant)
2 > comment avoir se ppp0 apres ifconfig?
Ca fait 3 fois que je reinstalle tous ubuntu mais je fatigue un connaisseur sous amd64 peut il m'aider ...
Merci!
___________________________________________
voici le detail de l'installation:

laurent@laurent-ubuntu:~$ uname -r
2.6.15-23-amd64-generic
______________________________
laurent@laurent-ubuntu:~$ sudo lsmod | grep eagl
Password:
eagle_usb             133028  0
usbcore               145980  6 eagle_usb,usbhid,usb_storage,ehci_hcd,ohci_hcd
laurent@laurent-ubuntu:~$ sudo modprobe -r eagle-usb
==verif de la suppression ok
laurent@laurent-ubuntu:~$ sudo lsmod | grep eagl
laurent@laurent-ubuntu:~$ bizard que j'ai "eagle_usb" et la commande avec le tiret - "modprobe -r eagle-usb"
________________
laurent@laurent-ubuntu:~$ locate eagle-usb.ko
/lib/modules/2.6.15-23-amd64-generic/kernel/drivers/usb/net/eagle/eagle-usb.ko

laurent@laurent-ubuntu:~$ locate eagle-usb.ko
/lib/modules/2.6.15-23-amd64-generic/kernel/drivers/usb/net/eagle/eagle-usb.ko
laurent@laurent-ubuntu:~$ locate usbatm.ko
/home/laurent/Desktop/drivers/ueagle_install_v2.2/ueagle-atm/usbatm.ko
/home/laurent/Desktop/drivers/ueagle_install_v2.2/ueagle-atm/.usbatm.ko.cmd
/lib/modules/2.6.15-23-amd64-generic/kernel/drivers/usb/atm/usbatm.ko
/lib/modules/2.6.15-23-amd64-generic/kernel/drivers/usb/atm/xusbatm.ko
=== il faut les desinstaller avec :
$ sudo rm /lib/modules/2.6.15-23-amd64-generic/kernel/drivers/usb/atm/usbatm.ko
$ sudo rm /lib/modules/2.6.15-23-amd64-generic/kernel/drivers/usb/atm/xusbatm.ko
$ sudo rm /lib/modules/2.6.15-23-amd64-generic/kernel/drivers/usb/net/eagle/eagle-usb.ko
=====verif qu'il n'y est plus rien
laurent@laurent-ubuntu:~$ locate usbatm.ko /home/laurent/Desktop/drivers/ueagle_install_v2.2/ueagle-atm/usbatm.ko
/home/laurent/Desktop/drivers/ueagle_install_v2.2/ueagle-atm/.usbatm.ko.cmd
laurent@laurent-ubuntu:~$ locate eagle-usb.ko laurent@laurent-ubuntu:~$
=== OK
===prepa de la compil des source pilote
$ uname -r
2.6.15-23-amd64-generic
===On ajoute le CD-ROM d"installation d"Ubuntu comme source de paquets
$sudo apt-cdrom add /media/cdrom

sudo apt-get install gcc make build-essential linux-headers-2.6.15-23-amd64-generic
__4444______________
 DEBRANCHEZ VOTRE MODEM de façon à vider la mémoire.
le pilote

L"installation du pilote se fait en décompressant et compilant l"archive ueagle-atm-1.3.tar.gz de la façon suivante :

$ cp /home/laurent/Desktop/ubuntu/modem/drivers/ueagle-atm-1.3.tar.gz /tmp && cd /tmp
laurent@laurent-ubuntu:~$ cp /home/laurent/Desktop/ubuntu/modem/drivers/ueagle-atm-1.3.tar.gz /tmp && cd /tmp
laurent@laurent-ubuntu:/tmp$ tar -zxvf ueagle-atm-1.3.tar.gz
ueagle-atm-1.3/
ueagle-atm-1.3/COPYING
ueagle-atm-1.3/Makefile
ueagle-atm-1.3/ueagle-atm.c
ueagle-atm-1.3/usbatm.c
ueagle-atm-1.3/usbatm.h
ueagle-atm-1.3/README
laurent@laurent-ubuntu:/tmp$ cd ueagle-atm-1.3
laurent@laurent-ubuntu:/tmp/ueagle-atm-1.3$ sudo make
make -C /lib/modules/2.6.15-23-amd64-generic/build M=/tmp/ueagle-atm-1.3
make[1]: entrant dans le répertoire « /usr/src/linux-headers-2.6.15-23-amd64-generic »
  LD      /tmp/ueagle-atm-1.3/built-in.o
  CC [M]  /tmp/ueagle-atm-1.3/ueagle-atm.o
  CC [M]  /tmp/ueagle-atm-1.3/usbatm.o
  Building modules, stage 2.
  MODPOST
  CC      /tmp/ueagle-atm-1.3/ueagle-atm.mod.o
  LD [M]  /tmp/ueagle-atm-1.3/ueagle-atm.ko
  CC      /tmp/ueagle-atm-1.3/usbatm.mod.o
  LD [M]  /tmp/ueagle-atm-1.3/usbatm.ko
make[1]: quittant le répertoire « /usr/src/linux-headers-2.6.15-23-amd64-generic »
laurent@laurent-ubuntu:/tmp/ueagle-atm-1.3$ sudo make install
make -C /lib/modules/2.6.15-23-amd64-generic/build M=/tmp/ueagle-atm-1.3 modules_install
make[1]: entrant dans le répertoire « /usr/src/linux-headers-2.6.15-23-amd64-generic »
  INSTALL /tmp/ueagle-atm-1.3/ueagle-atm.ko
  INSTALL /tmp/ueagle-atm-1.3/usbatm.ko
make[1]: quittant le répertoire « /usr/src/linux-headers-2.6.15-23-amd64-generic »
/sbin/depmod -ae
laurent@laurent-ubuntu:/tmp/ueagle-atm-1.3$
_____
Si vous listez le dossier /lib/modules/2.6.15-23-amd64-generic/extra ; vous devrez trouver les fichiers usbatm.ko et ueagle-atm.ko :

laurent@laurent-ubuntu:/tmp/ueagle-atm-1.3$ ls  /lib/modules/2.6.15-23-amd64-generic/extra
ueagle-atm.ko  usbatm.ko
__ok
les Firmwares

L"installation des Firmwares se fait de la façon suivante :

Décompression de l"archive ueagle-data-1.1.tar.gz

$ cp /home/laurent/Desktop/ubuntu/modem/drivers/ueagle-data-1.1.tar.gz /tmp && cd /tmp
$ tar -zxvf ueagle-data-1.1.tar.gz
___ok ___

 Création du répertoire /lib/firmware/ueagle-atm et copie des modules

laurent@laurent-ubuntu:/tmp$ sudo mkdir /lib/firmware/ueagle-atm
laurent@laurent-ubuntu:/tmp$ ls
gconfd-laurent            orbit-laurent          ueagle-data-1.1
gedit.laurent.3639573515  ssh-mRgBKv5104         ueagle-data-1.1.tar.gz
keyring-HOFC2X            ueagle-atm-1.3         virtual-laurent.Ln6P5V
mapping-laurent           ueagle-atm-1.3.tar.gz
laurent@laurent-ubuntu:/tmp$ sudo cd ueagle-data-1.1
sudo: cd: command not found
laurent@laurent-ubuntu:/tmp$ cd ueagle-data-1.1/
laurent@laurent-ubuntu:/tmp/ueagle-data-1.1$ sudo cp -a * /lib/firmware/ueagle-atm
=====
REBRANCHEZ VOTRE MODEM
5ème étape : la première synchronisation
Lancez :

$ sudo modprobe ueagle-atm

Ca clignote et les deux diodes s"allument, cool : GAGNÉ. Pour en être sûr, entrez :

$ dmesg | grep ueagle

Vous devriez avoir quelque chose comme :
[ 1192.799656] usb 1-2: [ueagle-atm] modem operational
[ 1192.804656] usb 1-2: [ueagle-atm] ATU-R firmware version : 44e2ea17
laurent@laurent-ubuntu:/tmp/ueagle-data-1.1$  OUI OK CA BAIGNE !!!!!!!!!!!!!!
laurent@laurent-ubuntu:/tmp/ueagle-data-1.1$ sudo modprobe ueagle-atm
laurent@laurent-ubuntu:/tmp/ueagle-data-1.1$ dmesg | grep ueagle
[ 1183.238355] [ueagle-atm] driver ueagle-gna 1.3 loaded
[ 1183.238733] usb 1-2: [ueagle-atm] ADSL device founded vid (0X1110) pid (0X9032) : Eagle III
[ 1183.365130] usb 1-2: [ueagle-atm] pre-firmware device, uploading firmware
[ 1183.365238] usb 1-2: [ueagle-atm] loading firmware ueagle-atm/eagleIII.fw
[ 1183.365344] usbcore: registered new driver ueagle-atm
[ 1184.352891] usb 1-2: [ueagle-atm] firmware uploaded
[ 1185.722915] usb 1-2: [ueagle-atm] ADSL device founded vid (0X1110) pid (0X9031) : Eagle III
[ 1185.882761] usb 1-2: [ueagle-atm] using iso mode
[ 1185.882788] usb 1-2: [ueagle-atm] created proc entry at: /proc/driver/ueagle-atm/001-005[ 1185.882814] usb 1-2: [ueagle-atm] (re)booting started
[ 1192.799656] usb 1-2: [ueagle-atm] modem operational
[ 1192.804656] usb 1-2: [ueagle-atm] ATU-R firmware version : 44e2ea17
laurent@laurent-ubuntu:/tmp/ueagle-data-1.1$ sudo gedit /etc/ppp/peers/ueagle-atm
laurent@laurent-ubuntu:/tmp/ueagle-data-1.1$ sudo gedit /etc/ppp/peers/ueagle-atm
laurent@laurent-ubuntu:/tmp/ueagle-data-1.1$ sudo gedit /etc/ppp/chap-secrets
laurent@laurent-ubuntu:/tmp/ueagle-data-1.1$ sudo modprobe pppoatm
laurent@laurent-ubuntu:/tmp/ueagle-data-1.1$ sudo pppd call ueagle-atm
Plugin pppoatm.so loaded.
laurent@laurent-ubuntu:/tmp/ueagle-data-1.1$ ifconfig
eth0      Lien encap:Ethernet  HWaddr 00:30:1B:B9:47:58
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          Packets reçus:0 erreurs:0 :0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:1000
          Octets reçus:0 (0.0 b) Octets transmis:0 (0.0 b)
          Interruption:233 Adresse de base:0xc000

lo        Lien encap:Boucle locale
          inet adr:127.0.0.1  Masque:255.0.0.0
          adr inet6: ::1/128 Scope:Hôte
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          Packets reçus:235 erreurs:0 :0 overruns:0 frame:0
          TX packets:235 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:0
          Octets reçus:17932 (17.5 KiB) Octets transmis:17932 (17.5 KiB)

laurent@laurent-ubuntu:/tmp/ueagle-data-1.1$

============= et c'est encore foutu toujours pas de
""""""""""""""ppp0


amd64 nvidianforce4 shuttle_snp25 Gutsy32
roule au GPL

Hors ligne

#43 Le 03/08/2006, à 18:33

uperu

Re : [Howto] Sagem fast 800 sous dapper

gene69 a écrit :

HUMMM

Comment on fait pour régler le MTU à 1492 (de tête)?
parce que si c'est XXXX j'ai peur que ce soit 1500 et 1500 c'est pas optimal vu que ça va générer de la framentation lorsque ça va se faire encapsuler par atm(?) !

Jevois que tu es passé à Dapper tout comme  moi avec mises à jour des dépôts depuis Breezy et que tu utilisais
les eagles-usb.
J'ai lu ce tuto mais comme mon installation sur Dapper n'est plus fraîche ,je voulais savoir quelles démarches je devais faire (j'avoue ne pas avoir bien compris); peux-tu m'aider?


ubuntero enthousiaste!
Portable DELL Inspiron 9200 17", Mémoire 2 GO Processeur  Intel® Pentium(R) M processor 1.60GHz, Carte graphique :  gallium 0.4  on Ati RV 350?!,  pavillon externe HP 19" [ 12.04 LTS]
iMac, 2,8 GHz, Intel Core 2 Duo, Memoire 2 Go 667 MHz DDR2 SDRAM, Mac OS X 10.6.8

Hors ligne

#44 Le 09/08/2006, à 00:17

douditch

Re : [Howto] Sagem fast 800 sous dapper

bonjour à tous cool
je suis sous dapper avec un noyau 2.6.15.23 et un modeme sagem fast 800 avec wanadoo compte haut debit 512K et j'ai suivi, aprés d'autres essais avant qui m'ont obligé de reinstaller Dapper, le tuto de cathou dans le cas ou on obtient l'erreur:

Code:

FATAL: Error inserting ueagle_atm : Unknown symbol in module, or unknown parameter (see dmesg)

et dmesg montre:
Code:

[17180074.808000] ueagle_atm: disagrees about version of symbol usbatm_usb_probe
[17180074.808000] ueagle_atm: Unknown symbol usbatm_usb_probe

mais moi c'est un noyau tout neuf (2.6.15.23) installé à partir du cd...
donc aprés avoir suivi le 1er tutodu wiki j'obtiens l'erreur ci dessus et après le tuto de cathou j'obtiens le message:

$dmesg | grep ueagle
[ueagle-atm] driver ueagle-gna 1.3 loaded
[4295191.837000] usbcore: registered new driver ueagle-atm

et surtout mon modem ne bronche pas ...

voila, je suis coincé là et franchement je sais plus quoi faire voyant qu'apparemment ça fonctionne bien pour tout le monde, snif sad
surtout que ça m'empeche de migrer sous ubuntu complètement !!
merci de votre aide
big_smile

Hors ligne

#45 Le 14/08/2006, à 02:20

AlphaLyrae

Re : [Howto] Sagem fast 800 sous dapper

Waou ca marche smile ! Merci beaucoup !
Je m'attendais a bien galérer vu que je n'y connait pas grand chose en linux et que ca avait pas l'air simple mais ca marche nikel.
Mon FAI est neuf télécom, j'utilise Kubuntu et j'ai donc juste eu a remplacer gedit par kate dans les commandes.
Et, en effet, le chemin d'activation automatique au démarrage est dans
/home/nomutilisateur/.kde/Autostart/

#46 Le 14/08/2006, à 12:26

uperu

Re : [Howto] Sagem fast 800 sous dapper

AlphaLyrae a écrit :

Waou ca marche smile ! Merci beaucoup !
Je m'attendais a bien galérer vu que je n'y connait pas grand chose en linux et que ca avait pas l'air simple mais ca marche nikel.
Mon FAI est neuf télécom, j'utilise Kubuntu et j'ai donc juste eu a remplacer gedit par kate dans les commandes.
Et, en effet, le chemin d'activation automatique au démarrage est dans
/home/nomutilisateur/.kde/Autostart/

tu es sous Dapper?
Qu'as-tu chargé?
Peux-tu me donner le chemin de ta démarche?
Merci à toi!


ubuntero enthousiaste!
Portable DELL Inspiron 9200 17", Mémoire 2 GO Processeur  Intel® Pentium(R) M processor 1.60GHz, Carte graphique :  gallium 0.4  on Ati RV 350?!,  pavillon externe HP 19" [ 12.04 LTS]
iMac, 2,8 GHz, Intel Core 2 Duo, Memoire 2 Go 667 MHz DDR2 SDRAM, Mac OS X 10.6.8

Hors ligne

#47 Le 17/08/2006, à 13:30

AlphaLyrae

Re : [Howto] Sagem fast 800 sous dapper

Je suis sous Dapper avec Kubuntu et c'est pratiquement la même méthode que sous Ubuntu.
"uname -r" affiche 2.6.15-23-386

J'ai d'abord fait reconnaitre le CD d'installation de Dapper en tant que dépôt (source de paquets pour installation)
mettre le CD Kubuntu puis taper ça dans Konsole :
sudo apt-cdrom add

Ensuite suivre les instructions de DEoT, en remplaçant gedit par kate.
Pour neuf télécom ADSL, c'est du pppoa et j'ai mis 8.35 pour VPI.VCI

Et à la fin j'ai mis le fichier depart_adsl dans /home/nomutilisateur/.kde/Autostart/

Désolé pour le retard j'avais pas été revoir le forum depuis que j'ai posté.

#48 Le 19/08/2006, à 13:48

douditch

Re : [Howto] Sagem fast 800 sous dapper

j'attends avec impatience un retour sur mon pb ( voir post plus haut) car apparemment y'a que moi qui ai ce soucis.
Je crois avoir essayer toutes les differentes techniques d'installation d'eagle-atm mais malheureusement à chaque fois le modem ne repond pas et la connexion ne peut se faire.
merci d'avance

Hors ligne

#49 Le 20/08/2006, à 17:03

lost-in-the-shell

Re : [Howto] Sagem fast 800 sous dapper

Salut,
J'ai déjà eu ce problème suite à une coupure d'électricité. J'ai juste débranché / rebranché le modem et ça roulait de nouveau smile
LITS


Linux user #401253 - Ubuntu user #3023 .
Nick sur IRC : naji.
Pensez à adhérer au Comité de lutte contre le SMS.

Hors ligne

#50 Le 22/08/2006, à 08:59

M4C C41N

Re : [Howto] Sagem fast 800 sous dapper

Bonjour, je suis sous Kubuntu Dapper et je viens de passer au driver ueagle en suivant le wiki ; tout s'est bien déroulé, la connexion marchait nickel juste apres l'install, mais j'ai redémarré sous windows, et lorsque je suis revenu sous linux plus moyen d'acceder a internet sad

Edit: meme apres reinstallation (sans probleme) ca ne marche pas.Pourtant les deux diodes sont allumées et le plugin semble bien chargé.

Dernière modification par M4C C41N (Le 22/08/2006, à 12:09)

Hors ligne

Haut de page ↑