Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".

#1 Le 17/12/2006, à 19:19

Sorbus

[RESOLU] wvdial ne tient plus compte de wvdial.conf !

Bonsoir les amis,

Je n'y comprends plus rien.
J'étais assez heureux hier d'avoir réussi à faire fonctionner le winmodem Conexant de mon portable... Ce sont les pires...
Bref. Tout marchait bien... Mais j'avais établi la connexion en un lieu nécessitant le préfixe "0" devant le numéro de téléphone.

J'avais donc complété le fichier /etc/wvdial.conf avec le numéro 00860888080 ("0" + "0860888080" numéro de mon FAI).

J'ai ensuite essayé la connexion avec wvdial à plusieurs reprises : impeccable.

Aujourd'hui, je suis en un lieu où il ne faut pas le préfixe "0"... Je pensais : "c'est tout simple... un sudo gedit /etc/wvdial.conf... j'enlève le "0" devant le numéro de téléphone, j'enregistre... et l'affaire est réglée..."

Mais voilà... le fichier wvdial.conf est bien modifié comme il faut... enregistré... mais lorsque je lance wvdial, il n'en tient aucun compte, et il continue à composer le 00860888080... mad

... J'ai du repasser sous Windows pour envoyer ce message.

J'ai cherché à quel autre endroit le numéro avec préfixe "00860888080" a été gardé dans la mémoire du système... mais je ne trouve pas. Une idée ?

J'ai trouvé ce lien : http://www.fr.linuxfromscratch.org/view … vdial.html

Mais j'ai déjà essayé wvdialconf   /etc/wvdial.conf
et je suis déjà aller voir dans les divers fichiers "ppp" indiqués pour la configuration. Aucun autre fichier que wvdial.conf n'enregistre le numéro de téléphone. Mystère...

Dernière modification par Sorbus (Le 20/12/2006, à 08:34)

Hors ligne

#2 Le 18/12/2006, à 07:48

Sorbus

Re : [RESOLU] wvdial ne tient plus compte de wvdial.conf !

hmm Alors là... c'est déroutant.
J'ai fait une désinstallation complète (donc, y compris les fichiers de configuration) de wvdial par le Synaptic...
Puis je l'ai réinstallé par le Synaptic.
Le fichier wvdial.conf n'est évidemment pas renseigné.
Je lance wvdial dans un terminal, et il me numérote 00860888080
Bougrelou de bigrelou... qu'est-ce que c'est qu'ce truc yikes

Là, y'a besoin d'un "pro" !
Où donc le système a-t-il mémorisé ce fichu numéro avec préfixe ?

Je précise une chose  concernant l'interface graphique de "Réglage du réseau" (Système --> Administration --> Réseau) :
- que la connexion par modem soit "non configurée" dans cette interface,
- ou qu'elle soit configurée avec l'indication du numéro 0860888080 sans préfixe (avec case "Préfixe de compostition" vide...)
Wvdial (qui ne tient pas compte non plus de cette interface graphique) numérote quand même 00860888080.

J'ai aussi réinstallé le pilote de mon winmodem via le site de Linuxant (au cas où le numéro à préfixe ait été enregistré quelque part dans la configuration du pilote du modem)... mais ça n'a rien changé.

Je vais essayer avec gnome-ppp et kppp, mais je ne les connais pas du tout... Je les ai installés. kppp apparaît dans "Applications --> Internet"... C'est en anglais... Je ne comprends pas trop (est-ce qu'il y a un paquet pour le franciser... ou bien un tuto quelque part ?)
Gnome-ppp, est aussi dans "Applications --> Internet"... en français... Semble facile à configurer. Je vais essayer.

Enfin, je suis inquiet quand même... Je crains que ce soit pareil avec n'importe quelle application... si le numéro 00860888080 s'est incrusté dans quelque "couche profonde" du système...

Je ne voudrais pas quand même reprendre à zéro toute mon installation d'Ubuntu à cause de ça sad

Dernière modification par Sorbus (Le 19/12/2006, à 15:21)

Hors ligne

#3 Le 18/12/2006, à 09:47

Sorbus

Re : [RESOLU] wvdial ne tient plus compte de wvdial.conf !

Bon... Ouf... tongue
Je suis connecté en 56 K sur ce portable sous Ubuntu grâce à gnome-ppp qui a bien "pris" dans sa configuration le numéro sans préfixe 0860888080.

Le mystère reste entier pour wvdial, que je n'utilise donc plus.
La résolution de cette énigme m'intéresse toujours cependant. J'aimerais bien pouvoir réutiliser wvdial comme solution alternative en cas de besoin.

Mais pour l'instant, je m'en passe.
@+

Dernière modification par Sorbus (Le 18/12/2006, à 09:51)

Hors ligne

#4 Le 20/12/2006, à 08:31

Sorbus

Re : [RESOLU] wvdial ne tient plus compte de wvdial.conf !

Suite du monologue.

Question résolue pour wvdial... Même si je n'ai pas tout compris.
Source de la résolution du problème, ce message : http://forum.ubuntu-fr.org/viewtopic.ph … 35#p560635

J'ai simplement fait :

cp /etc/wvdial.conf ~/.wvdialrc
nano ~/.wvdialrc

Puis changé les lignes "Phone", "Password" et "Username".
Je n'ai pas su enregistrer les modifications dans la fenêtre ouverte par "nano"...

[en fait, c'est Ctrl+x... puis o puis touche "Enter"]

... mais en lançant wvdial, j'ai constaté que le 00860888080 n'était plus mémorisé cette-fois-ci, avec ce résultat tant attendu :

truc@truc:~$ wvdial
--> WvDial: Internet dialer version 1.54.0
--> Warning: section [Dialer Defaults] does not exist in wvdial.conf.
--> Initializing modem.
--> Sending: ATZ
ATZ
OK
--> Modem initialized.
--> Configuration does not specify a valid phone number.
--> Configuration does not specify a valid login name.
--> Configuration does not specify a valid password.

Il m'a suffit alors d'aller modifier le fichier /etc/wvdial.conf par

sudo gedit /etc/wvdial.conf

avec notamment le numéro 0860888080... sans préfixe... et cette fois-ci, wvdial compose le bon numéro.

J'ai donc découvert les fichiers cachés .wvdial.conf, .wvdialrc, .wvdialrc.save qui sont placés dans /home/truc (truc = mon identité).
C'est sans doute là qu'avait été mémorisé le numéro à préfixe que je n'arrivais pas à faire oublier à wvdial...

Dernière modification par Sorbus (Le 04/03/2009, à 00:32)

Hors ligne

Haut de page ↑