Contenu | Rechercher | Menus

Annonce

Si vous rencontrez des soucis à rester connecté sur le forum (ou si vous avez perdu votre mot de passe) déconnectez-vous et reconnectez-vous depuis cette page, en cochant la case "Me connecter automatiquement lors de mes prochaines visites".
Test de l'ISO d'Ubuntu francophone : nous avons besoin de testeurs pour la version francophone d'Ubuntu 14.04. Liens et informations ici.

#1 Le 12/11/2011, à 20:13

seb24

OpenGL 3.0 bientôt supporté par les drivers libres...

Après un gros travail d'intel on devrait enfin voir débarquer le support d'OpenGl 3.0 sur les drivers libres sous Linux. Il reste plus grand chose et c'était sûrement le plus dur à réaliser. les versions suivantes d'OpenGl étant plutôt des évolutions qu'un gros changement comme le fut la v3.

http://www.phoronix.com/scan.php?page=n … px=MTAxNDY

Dernière modification par seb24 (Le 12/11/2011, à 20:13)


Membre attitré de la brigade des S
Ubuntuser.com : Blog sur Ubuntu http://www.ubuntuser.com

Hors ligne

#2 Le 13/11/2011, à 10:56

Vu

Re : OpenGL 3.0 bientôt supporté par les drivers libres...

Génial smile

On a des chances que cela soit intégrer dans Ubuntu 12.04
Ils vont travailler sur la version 4.2 qui est sortit cet été:

After that it's onto playing catch-up with OpenGL 3.1/3.2/3.3, which isn't too bad, but OpenGL 4.0/4.1/4.2 is expected to cause many more headaches.

Je fournis l'aspirine si vous voulez.

Dernière modification par Vu (Le 13/11/2011, à 11:02)


Ubuntu 12.04

Hors ligne

#3 Le 13/11/2011, à 11:43

Julientroploin

Re : OpenGL 3.0 bientôt supporté par les drivers libres...

Bonne nouvelles tout ça !

@Vu : Félicitations pour le concours http://forum.ubuntu-fr.org/viewtopic.ph … 1#p7026691


Fixe : Core i5, 4GoRAM, NVidia 9800GT Silent => Raring64
Portable Compaq Presario2158 : AthlonXP-M2400+, 1GoRAM, ATI Radeon mobility320M => Debian stable+Openbox
https://launchpad.net/~julienmbpe

Hors ligne

#4 Le 13/11/2011, à 17:06

Xime

Re : OpenGL 3.0 bientôt supporté par les drivers libres...

Vous voulez dire que grâce à ça on va pouvoir faire tourner sur Ubuntu une version d'OpenGl qui date d'il y a 4 ans ? Wouhou tongue

Sans vouloir troller, qui développe encore sous OpenGl ? Y a des jeux qui pourraient être facilement portés sur Ubuntu grâce au support de cette version 3.0. ?

Hors ligne

#5 Le 13/11/2011, à 17:22

seb24

Re : OpenGL 3.0 bientôt supporté par les drivers libres...

Tout les jeux qui tournent sous Linux. Et basiquement idem pour tout ce qui est appareils mobiles, qui ne supportent pas DirectX ainsi que les solutions web qui sont centré sur OpenGl. Bref comme Flash DirectX est une techno d'actualité mais le futur appartient aux API ouvertes wink

C'était un gros manque pour les drivers libre. Et surtout d'OpenGl 2 à 3 il y avait visiblement un gros travail à faire. Et les drivers libre eux même étaient dans un triste état il y a 3 ans. Aujourd'hui on commence à avoir des drivers complets dans pas mal de domaine et ce genre d'avancé va permettre de continuer dans ce sens. De ce que j'ai compris le chemin Open Gl 3 vers les versions supérieurs sera plus facile car c'est une simple évolution de l'API.


Membre attitré de la brigade des S
Ubuntuser.com : Blog sur Ubuntu http://www.ubuntuser.com

Hors ligne

#6 Le 13/11/2011, à 17:31

ehmicky

Re : OpenGL 3.0 bientôt supporté par les drivers libres...

Hourra !! smile


Stego++, bibliothèque libre de stéganographie (avec cryptographie), à venir !
Besoin de votre aide :
Stats sur les compilateurs C++ les plus utilisés
Comment utiliser les archetypes C++ ?

Hors ligne

#7 Le 13/11/2011, à 22:55

jajaX

Re : OpenGL 3.0 bientôt supporté par les drivers libres...

salut

bonne nouvelle en effet.

scusez j'ai pas lu l'article mis je veux juste savoir si cela va concerner toutes les cartes Intel ou seulement certaines ?


@+ jajaX [Membre de Breizhtux : LUG de Saint Brieuc]
ACER Aspire 8930G 904G50Bn & HP dv7 2230f sous Kubuntu 14.04 The Trusty Tahr (64 bits) & KDE SC 4.13.2/Amarok 2.8
ACER Aspire 5612 WLMI & HP Compaq NX6310 sous kubuntu 14.04 The Trusty Tahr (32 bits) & KDE SC 4.13.2/Amarok 2.8

Hors ligne

#8 Le 13/11/2011, à 23:48

seb24

Re : OpenGL 3.0 bientôt supporté par les drivers libres...

jajaX a écrit :

salut

bonne nouvelle en effet.

scusez j'ai pas lu l'article mis je veux juste savoir si cela va concerner toutes les cartes Intel ou seulement certaines ?

Ca va concerner toutes les cartes supportant l'Open GL 3.0. Pas seulement les Intel, mais aussi les ATI et Nvidia (enfin,, si j'ai bien compris, le temps qu'ils utilisent le code créé par Intel)


Membre attitré de la brigade des S
Ubuntuser.com : Blog sur Ubuntu http://www.ubuntuser.com

Hors ligne

#9 Le 14/11/2011, à 16:44

jajaX

Re : OpenGL 3.0 bientôt supporté par les drivers libres...

ok cool² alors smile


@+ jajaX [Membre de Breizhtux : LUG de Saint Brieuc]
ACER Aspire 8930G 904G50Bn & HP dv7 2230f sous Kubuntu 14.04 The Trusty Tahr (64 bits) & KDE SC 4.13.2/Amarok 2.8
ACER Aspire 5612 WLMI & HP Compaq NX6310 sous kubuntu 14.04 The Trusty Tahr (32 bits) & KDE SC 4.13.2/Amarok 2.8

Hors ligne

#10 Le 15/11/2011, à 05:12

Gemnoc

Re : OpenGL 3.0 bientôt supporté par les drivers libres...

Salut,

seb24 a écrit :
jajaX a écrit :

salut

bonne nouvelle en effet.

scusez j'ai pas lu l'article mis je veux juste savoir si cela va concerner toutes les cartes Intel ou seulement certaines ?

Ca va concerner toutes les cartes supportant l'Open GL 3.0. Pas seulement les Intel, mais aussi les ATI et Nvidia (enfin,, si j'ai bien compris, le temps qu'ils utilisent le code créé par Intel)

Plus précisément, on parle des pilotes libres pour ATI Nvidia. Ça fait déjà un moment que les pilotes proprios Nvidia supportent OpenGL 3.3.

glxinfo a écrit :

OpenGL vendor string: NVIDIA Corporation
OpenGL renderer string: GeForce 9800 GT/PCI/SSE2
OpenGL version string: 3.3.0 NVIDIA 280.13

Ça ne me déplairait pas d'avoir enfin une accélération graphique potable du pilote libre pour ma carte...


Pensez à consulter la documentation ! :-)

Hors ligne

#11 Le 16/11/2011, à 20:10

Vu

Re : OpenGL 3.0 bientôt supporté par les drivers libres...

Gemnoc a écrit :
glxinfo a écrit :

OpenGL vendor string: NVIDIA Corporation
OpenGL renderer string: GeForce 9800 GT/PCI/SSE2
OpenGL version string: 3.3.0 NVIDIA 280.13

Ça ne me déplairait pas d'avoir enfin une accélération graphique potable du pilote libre pour ma carte...

+1
(sauf que j'ai une Intel® Ironlake Mobile qui j'espère n'est pas trop vielle pour pouvoir bénéficier de ce pilote)
Je rêve de le voir en action dans Firefox histoire de faire jeux égal avec Windows et Mac OS X (avec la 11.10 Firefox peut déjà utiliser WebGL, tapez about:support dans la barre d'url pour le vérifier).


Ubuntu 12.04

Hors ligne

#12 Le 18/11/2011, à 19:19

LaBêteNoire

Re : OpenGL 3.0 bientôt supporté par les drivers libres...

Résultat d"about:support" dans Firefox :
Description de la carte : GLXtest process failed (exited with status 1): X error occurred in GLX probe, error_code=9, request_code=55, minor_code=0
Rendu WebGL : Bloqué pour votre carte graphique à cause de problèmes non résolus du pilote.
Fenêtres avec accélération graphique : 0/1. Bloqué pour votre carte graphique à cause de problèmes non résolus du pilote.

En ce qui concerne mon ATi x1300, j'ai perdu tout espoir... Elle doit avoir 4 ou 5 ans.

Dernière modification par LaBêteNoire (Le 18/11/2011, à 19:33)


- Diaspora : socialement décentralisé
- BeWelcome : association de voyageurs alternative à Couchsurfing
- Démosphère : réseau d'agendas militants et culturels
- OpenStreetMap : cartographie communautaire

Hors ligne

#13 Le 18/11/2011, à 19:23

seb24

Re : OpenGL 3.0 bientôt supporté par les drivers libres...

Quoi ? Avec quelle version du noyau ? des drivers ?


Membre attitré de la brigade des S
Ubuntuser.com : Blog sur Ubuntu http://www.ubuntuser.com

Hors ligne

#14 Le 18/11/2011, à 20:44

LaBêteNoire

Re : OpenGL 3.0 bientôt supporté par les drivers libres...

ubuntu 11.10 (linux 3.0.0.13) avec le driver libre par défaut.


- Diaspora : socialement décentralisé
- BeWelcome : association de voyageurs alternative à Couchsurfing
- Démosphère : réseau d'agendas militants et culturels
- OpenStreetMap : cartographie communautaire

Hors ligne

#15 Le 18/11/2011, à 21:39

seb24

Re : OpenGL 3.0 bientôt supporté par les drivers libres...

A dans Firefox oui en effet les drivers libres sont blacklisté il me semble. Et je sais pas si ils supportent WebGl de toute façon.


Membre attitré de la brigade des S
Ubuntuser.com : Blog sur Ubuntu http://www.ubuntuser.com

Hors ligne

#16 Le 19/11/2011, à 11:54

Vu

Re : OpenGL 3.0 bientôt supporté par les drivers libres...

Non, il faut avoir une version de Mesa  7.11 ou supérieur. Mon pilote est libre et cela fonctionne avec ma carte.
Par contre il y avait un soucis avec Gallium donc les cartes l'utilisant était blacklistés.

La majorité des cartes graphiques qui font tourner Mesa 7.11 peuvent utiliser le WebGL dans FF. Après il est vrai que c'est pilote proprio de Nvidia qui ont été les premiers à faire fonctionner ce mode de Firefox sous Linux.


Ubuntu 12.04

Hors ligne

#17 Le 19/11/2011, à 12:30

src

Re : OpenGL 3.0 bientôt supporté par les drivers libres...

ATI X1400 de mon côté, support abandonné par AMD depuis longtemps (le dernier pilote date de 2009 et n'est pas compatible avec le xorg actuel) et les résultats sont variables avec le pilote libre. Si supertuxkart & stellarium tournent bien (parfois en fenêtré) en revanche on ne peut pas jouer à Minecraft de façon correcte et il y a plein de choses pour lesquelles la carte n'est pas détectée comme compatible : VMware, WebGL.


Actuellement sur Manjaro Xfce (amd64)
Serveur sur FreeBSD 10 (i386) + Debian GNU/kFreeBSD.
http://maniatux.fr

Hors ligne

#18 Le 25/11/2011, à 19:43

Vu

Re : OpenGL 3.0 bientôt supporté par les drivers libres...

À priori certain drivers d'ATI seront supporter par Firefox avec la version 3.0 d'OpenGL

Wiki Mozilla a écrit :

For the FGLRX (proprietary ATI) driver, we whitelist the newer versions that implement OpenGL 3.0 or newer. Indeed, FGLRX does not return any version number of its own, so we had to use the OpenGL version as a differentiator.

Source


Ubuntu 12.04

Hors ligne

#19 Le 30/01/2012, à 19:56

seb24

Re : OpenGL 3.0 bientôt supporté par les drivers libres...

C'est bon Open GL 3.0 est dans les drivers libre Intel et Ati et nvidia ( enfin presque ) wink
http://www.phoronix.com/scan.php?page=n … px=MTA1MDM


Membre attitré de la brigade des S
Ubuntuser.com : Blog sur Ubuntu http://www.ubuntuser.com

Hors ligne

#20 Le 08/03/2012, à 22:25

Linux-one

Re : OpenGL 3.0 bientôt supporté par les drivers libres...


Desktop Intel pentium 4, CG intel 865G, ubuntu 12.04.4 LTS sous Gnome-panel
Laptop HP Pavilion G 15-e073sk i3-3110, CG intel 4000HD, ubuntu 14.04 LTS sous Unity.

Hors ligne

#21 Le 08/10/2012, à 00:30

kikito

Re : OpenGL 3.0 bientôt supporté par les drivers libres...

OpenGL 3.0, oui, mais pas pour Ubuntu mad mad

Ubuntu 12.04.1:			(kernel 3.2.0-32)
OpenGL vendor string: X.Org
OpenGL renderer string: Gallium 0.4 on AMD RV610
OpenGL version string: 2.1 Mesa 8.0.4
OpenGL shading language version string: 1.20

Ubuntu 12.10:			(kernel 3.5.0-17)
OpenGL vendor string: X.Org
OpenGL renderer string: Gallium 0.4 on AMD RV610
OpenGL version string: 2.1 Mesa 9.0-devel
OpenGL shading language version string: 1.30

OpenSuse 12.3 Milestone 0:	(kernel 3.6.0-rc7-1)
OpenGL vndor string: X.Org
OpenGL renderer string: Gallium 0.4 on AMD RV610
OpenGL version string: 3.0 Mesa 9.0-devel
OpenGL shading language version string: 1.30

Mon PC: Precise 14.04. XP: euthanasié / Asus M2N-VM HDMI / AMD Phenom 9550 / RAM: 4Go / video: radeon HD6450 / Disque Dur: Samsung 320Go

Hors ligne

#22 Le 08/10/2012, à 00:43

seb24

Re : OpenGL 3.0 bientôt supporté par les drivers libres...

kikito a écrit :

OpenGL 3.0, oui, mais pas pour Ubuntu mad mad

Ubuntu 12.04.1:			(kernel 3.2.0-32)
OpenGL vendor string: X.Org
OpenGL renderer string: Gallium 0.4 on AMD RV610
OpenGL version string: 2.1 Mesa 8.0.4
OpenGL shading language version string: 1.20

Ubuntu 12.10:			(kernel 3.5.0-17)
OpenGL vendor string: X.Org
OpenGL renderer string: Gallium 0.4 on AMD RV610
OpenGL version string: 2.1 Mesa 9.0-devel
OpenGL shading language version string: 1.30

OpenSuse 12.3 Milestone 0:	(kernel 3.6.0-rc7-1)
OpenGL vndor string: X.Org
OpenGL renderer string: Gallium 0.4 on AMD RV610
OpenGL version string: 3.0 Mesa 9.0-devel
OpenGL shading language version string: 1.30

Oui faut être patient big_smile


Membre attitré de la brigade des S
Ubuntuser.com : Blog sur Ubuntu http://www.ubuntuser.com

Hors ligne

#23 Le 08/10/2012, à 00:45

Gemnoc

Re : OpenGL 3.0 bientôt supporté par les drivers libres...

Sinon la solution rapide c'est peut-être la compilation...


Pensez à consulter la documentation ! :-)

Hors ligne

#24 Le 08/10/2012, à 07:47

kao_chen

Re : OpenGL 3.0 bientôt supporté par les drivers libres...

kikito a écrit :

OpenGL 3.0, oui, mais pas pour Ubuntu mad mad

Ubuntu 12.04.1:			(kernel 3.2.0-32)
OpenGL vendor string: X.Org
OpenGL renderer string: Gallium 0.4 on AMD RV610
OpenGL version string: 2.1 Mesa 8.0.4
OpenGL shading language version string: 1.20

Ubuntu 12.10:			(kernel 3.5.0-17)
OpenGL vendor string: X.Org
OpenGL renderer string: Gallium 0.4 on AMD RV610
OpenGL version string: 2.1 Mesa 9.0-devel
OpenGL shading language version string: 1.30

OpenSuse 12.3 Milestone 0:	(kernel 3.6.0-rc7-1)
OpenGL vndor string: X.Org
OpenGL renderer string: Gallium 0.4 on AMD RV610
OpenGL version string: 3.0 Mesa 9.0-devel
OpenGL shading language version string: 1.30

En fait oui et non.
Oui parce qu'en fait Mesa 9.0 embarque déjà la quasi totalité des extensions nécessaires pour la valider en 3.0.
Non parce qu'il en manque seulement 2 ou 3, du coup on ne pas tamponner OpenGL 3.0
Rien que la version GLSL est en 1.30 ce qui est un gros morceau de OpenGL 3.0

Et en fait, on pourrait passer directement à 3.1 voir 3.3 pour la prochaine stable de Mesa, il manque pas grand chose.
Pour suivre l'avancement, l'équipe mesa tient à jour une todo list assez précise ici:
http://cgit.freedesktop.org/mesa/mesa/tree/docs/GL3.txt

A modérer aussi par le type de driver, tout les cartes ne sont pas logées à la même enseigne, les pilotes i965 d'intel et les r600 de chez AMD, ont pris de l'avance. Pour ce qui des cartes Nvidia, je ne sais pas du tout.

Pour les AMD, il est bon de consulter cette adresse aussi:
http://www.x.org/wiki/RadeonFeature

Perso, j'arrive très bien à jouer à OilRush avec tout les effets d'activés, je mets pas toutes les options en full c'est clair mais je joue et c'est propre. Et ce n'était pas le cas avec la version 7.11 présente dans Oneiric. Ça avance donc.

Pour tester en avance, il faut passer par le ppa https://launchpad.net/~xorg-edgers/+archive/ppa c'est moins casse gueule que par la compilation.

Hors ligne

#25 Le 08/10/2012, à 08:15

billou

Re : OpenGL 3.0 bientôt supporté par les drivers libres...

Xime a écrit :

Sans vouloir troller, qui développe encore sous OpenGl ?

Toutes les plateformes qui ne sont pas de Microsoft tournent sous OpenGL ou un dérivé.

Consoles Sony, Nintendo, smartphones & tablettes sous Androïd, IOS, WebOS, boxs HD des FAI, applications PC sous Linux et MacOS.

Hors ligne

Haut de page ↑