Contenu | Rechercher | Menus

Annonce

Ubuntu-fr vend de superbes t-shirts et de belles clés USB 32Go
Rendez-vous sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 31/10/2016, à 08:48

Isaric

Configurer le démarrage de session, auto-save-session

Bonjour,

Je souhaite configurer le démarrage de LibreOffice pour un fichier.odt.
(Ce projet "Post-it" (points A+B+C) me permet de remplacer l'utilisation xpad ([Abandon]Disparition fenêtres Xpad), d'ailleurs j'ai mis un fond jaune sur les pages du fichier.odt que j'ai nommé "Post-it.odt")

Avoir pour ce fichier.odt spécifique les points :

point B [à résoudre]: (éviter la fenêtre de récupération) --> voir post#2


+ point A [Résolu] (page à 100 % au démarrage) --> voir la remarque en dessous pour le point A
+ point C [Résolu] --> voir ce post Lanceur pour un fichier .odt et dimensionnement de la fenêtre


[*]Remarque :[/*]

Point A [Résolu] : page à 100 % au démarrage
- une page à 100 % au démarrage de LibreOffice et non la dimension de sa dernière utilisation (par exemple 140%)
J'ai posté là avec succès :
ouvrir une page LibreOffice writer à 100%
Résumé :
Macro LibreOffice de C_Lucien

sub zoom100
rem ----------------------------------------------------------------------
rem define variables
dim document   as object
dim dispatcher as object
rem ----------------------------------------------------------------------
rem get access to the document
document   = ThisComponent.CurrentController.Frame
dispatcher = createUnoService("com.sun.star.frame.DispatchHelper")

rem ----------------------------------------------------------------------
dispatcher.executeDispatch(document, ".uno:Zoom100Percent", "", 0,
Array())


end sub 

Cette macro "zoom100" est installée dans le fichier lui même.
La macro que j'ai enregistré se trouve dans fichier.odt (soit 
-->Outils--> Macro --> Gérer les macros-->LibreOffice Basic
-->fichier.odt-->Standard-->Module1-->dans la colonne "Macros
existantes dans : Module1" -->zoom100 )

LibreOffice a écrit :

Petite remarque au passage (non utilisé dans mon cas)
Sinon les macros LibreOffice sont installées sous

/home/moi/.config/libreoffice/4/user/basic/Standard/Module1.xba

Et LibreOffice 5 continue de mettre le dossier /user/ dans un dossier /4/

J'ai ajouté le dossier où se trouve fichier.odt comme fichiers de confiances.
(--->Options-->LibreOffice--> "Sécurité des macros" -> "Sources de confiance"-->Emplacement des fichiers de confiance--> "Ajouter" )
Pour éviter le problème d'ouverture avec la fenêtre de sécurité.

Le problème suivant c'est de lancer la macro à l'ouverture du document. Il faut passer par :

Outils>Personnaliser>Événements 
LibreOffice a écrit :

Car en passant par

 -->Outils--> Macro --> Gérer les macros-->LibreOffice Basic -->fichier.odt-->Standard-->Module1-->dans la colonne "Macros existantes dans : Module1" -->zoom100 

puis

--> assigner je tombe sur la fenêtre "Évènements"

Que je sélectionne pour "Enregistrer dans" LibreOffice ou fichier.odt
que je choisie l'événement "Ouvrir le document" puis clique sur assigner : "Macro"
Je tombe sur la fenêtre "Sélectionneur de macro" et dans "Bibliothèque" j'ai 2 choix "Mes Macros" et "Macro LibreOIffice". je n'ai pas fichier.odt et ne peux donc pas l'affecter de cette manière ?

Dernière modification par Isaric (Le 07/11/2016, à 19:28)


"Être bahá'í signifie simplement aimer la terre toute entière, aimer l'humanité et essayer de la servir, travailler pour la paix universelle et la famille humaine" 'Abdul'l-Bahá
"Vouloir s'ouvrir aux autres n'est pas une preuve de faiblesse, c'est une preuve d'intelligence"  Matthieu Ricard.

Hors ligne

#2 Le 06/11/2016, à 19:57

Isaric

Re : Configurer le démarrage de session, auto-save-session

Point B : Éviter la fenêtre de récupération première partie
- aussi si je ferme l'ordinateur sans fermer avant "fichier.odt", LibreOffice lance sa fenêtre de récupération au redémarrage suivant (...fonctionnement normal). Quelles solutions pour éviter la fenêtre de récupération pour ce fichier uniquement (il se peut qu'il le demande pour d'autres fichiers, mais j'aimerai qu'il ne le fasse pas pour l'ouverture de fichier.odt uniquement) ?
Peut-être faut-il jongler avec un enregistrement à la saisie, est-ce possible ?

Macro LibreOffice de C_Lucien :

sub savethisdoc
rem ----------------------------------------------------------------------
rem define variables
dim document   as object
dim dispatcher as object
rem ----------------------------------------------------------------------
rem get access to the document
document   = ThisComponent.CurrentController.Frame
dispatcher = createUnoService("com.sun.star.frame.DispatchHelper")
rem ----------------------------------------------------------------------
dispatcher.executeDispatch(document, ".uno:Save", "", 0, Array())
end sub 

J'ai associé la macro à l'évènement "/Le document va être fermé/"
J'ai dans -->Options-->Chargement/enregistrement - Général -->la case cochée pour "/Enregistrer les informations de récupération automatiques toutes les 8 minutes/"
Je fais une modification dans le fichier (sans le sauvegarder, je ne quitte pas libre office (je laisse ouvert) et je ferme la session utilisateur.

Elle fonctionne bien effectivement à la fermeture de LibreOffice, mais pas à la fermeture d'une session (la fenêtre de récupération apparaît) au démarrage suivant.
@C_Lucien à partir d'un Mac n'a pas se problème, il pense à une configuration système plutôt que LibreOffice ?



Point B [suite à résoudre] : Éviter la fenêtre de récupération  deuxième partie

Notes du Forum LibreOffice

@Jacques  a écrit :

j'ai fait quelques essais avec libo version ubuntu à jour et ubuntu 16-04

Si je modifie un fichier odt et que je redémarre l'ordinateur sans avoir enregistré les modifs, une fois  redémarré, lorsque j'ouvre Libo, le fichier en question s'ouvre directement sans fenêtre de récupération. Les modifications sont présentes, mais pas sauvegardées dans le fichier d'origine. Si avec Dconf je vais voir org/gnome/gnome-session, je constate que auto-save-session et auto-save-session-one-shot ne sont pas cochées.

Si je coche auto-save-session-one-shot et que je réédite l'opération précédente, j'ai droit à la fenêtre de récupération.

Il y a donc, d'après moi, un réglage à effectuer dans l'OS. Les spécialistes de Ubuntu seraient peut-être à consulter car je n'ai pas vraiment dépassé le stade d'utilisateur...

Pour ma part la configuration Dconf est à "faux"  ??? :
mini_514040ddconf161106.png

Je ne sais pas ce que change auto-save-session et auto-save-session-one-shot sur dconf-editor (Dconf :org/gnome/gnome-session)
Quel choix faire et ce que cela entraîne ?


D'avance merci

Dernière modification par Isaric (Le 07/11/2016, à 15:04)


"Être bahá'í signifie simplement aimer la terre toute entière, aimer l'humanité et essayer de la servir, travailler pour la paix universelle et la famille humaine" 'Abdul'l-Bahá
"Vouloir s'ouvrir aux autres n'est pas une preuve de faiblesse, c'est une preuve d'intelligence"  Matthieu Ricard.

Hors ligne

#3 Le 24/11/2016, à 08:30

Isaric

Re : Configurer le démarrage de session, auto-save-session

up


"Être bahá'í signifie simplement aimer la terre toute entière, aimer l'humanité et essayer de la servir, travailler pour la paix universelle et la famille humaine" 'Abdul'l-Bahá
"Vouloir s'ouvrir aux autres n'est pas une preuve de faiblesse, c'est une preuve d'intelligence"  Matthieu Ricard.

Hors ligne