Contenu | Rechercher | Menus

Annonce

DVD, clés USB et t-shirts Ubuntu-fr disponibles sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 20/11/2021, à 23:47

Nounours18200

[Résolu] Caractère arrobase "@", toujours lui...

Bonjour,

Je viens d'installer Ubuntu 20.2 (mais j'avais également le même problème avec Mint), et le caractère arrobase "@" ne s'affiche jamais (j'écris ici depuis Windows, obligé pour faire quoi que ce soit sur Internet...).

Mon PC est un PC fixe avec un clavier tout ce qu'il a de plus classique, avec son pavé numérique, etc... Le caractère "@" s'obtient par la combinaison de [AltGr + 0], où AltGr se trouve juste à côté du shift droit.

J'ai bien lu ce topic par exemple: https://forum.ubuntu-fr.org/viewtopic.php?id=178871
mais je ne m'en sors pas....

Il doit s'agir à l'évidence d'une mauvaise configuration clavier...
Les claviers que je vois dans les paramètres "Pays et langue" sont :
-Français (variante)
-et Français (variante obsolète)
ce qui ne m'avance pas vraiment...
Dans les 2 cas le caractère "@" se trouve bien au même endroit que sur mon clavier, mais la touche "AltGr" n'est pas indiquée avec "AltGr" mais avec "Level3 S..."
Au cas où ça ait une importance, mon Linux est installé sur une VM (de mon NAS Synology, créée avec Virtual Machine Manager)

Quelqu'un pour aider une buse sous Linux ?

Dernière modification par Nounours18200 (Le 25/11/2021, à 20:39)

Hors ligne

#2 Le 21/11/2021, à 02:08

Coeur Noir

Re : [Résolu] Caractère arrobase "@", toujours lui...

Hello,

les choix d'agencement dans « pays et langues » semblent cohérents avec ton clavier.

Est-ce que la touche [ AltGr ] aurait une fonctionnalité spécifique liée à la VM ?
Dans ce cas elle empêcherait la fonction « habituelle » de [ AltGr ] qui est est l'accès au 3ème niveau du clavier.

Exemple avec l'agencement Français (variante) :
Niveau 1 → [ touche ] seule → taper [ 0 ] affiche à ( le zéro de la 2ème ligne de touches, pas celui de l'éventuel pavé numérique )
Niveau 2 → [ Maj. ] + [ touche ] → 0
Niveau 3 → [ AltGr ] + [ touche ] → @
Niveau 4 → [ Maj. ] + [ AltGr ] + [ touche ] → À

Voir si dans les préférences des VM il y a quelque chose concernant la configuration des raccourcis clavier, qui nécessiterait [ AltGr ] ?


DébuterDocBien rédigerRetour commandeInsérer image | illustrations & captures d'écran <>

Hors ligne

#3 Le 21/11/2021, à 10:36

Nounours18200

Re : [Résolu] Caractère arrobase "@", toujours lui...

Voir si dans les préférences des VM il y a quelque chose concernant la configuration des raccourcis clavier, qui nécessiterait [ AltGr ] ?

Je n'ai rien vu de ce type dans les paramètres de la VM, mais je vais poser la question sur un forum Synology et je reviens vers toi.

Une autre piste est que j'accède à Ubuntu depuis "Virtual Machine Manager" du NAS en faisant "connecter", donc je suis dépendant de VMM. Peut-être qu'en lançant la VM depuis le NAS et en y accédant avec VNC viewer , ce serait différent ?

Au plus tard mardi car je vais être en déplacement (et mon NAS est indisponible actuellement)

Hors ligne

#4 Le 21/11/2021, à 13:44

Coeur Noir

Re : [Résolu] Caractère arrobase "@", toujours lui...

À tester. Puisque la config clavier / agencement semble correcte, ça vient probablement du « contexte » VM ( auquel je ne connais strictement rien ).


DébuterDocBien rédigerRetour commandeInsérer image | illustrations & captures d'écran <>

Hors ligne

#5 Le 24/11/2021, à 20:50

Nounours18200

Re : [Résolu] Caractère arrobase "@", toujours lui...

Je penche également de côté, peut-être que le contexte d'utilisation sur une VM (celle du NAS Synology) est en cause, car j'ai eu le même problème avec Linux Mint, Ubuntu et Ubuntu Budgie (que je vais également supprimer car il est beaucoup plus lent que les autres...).

Décidément je n'ai pas de chance avec Linux: tous les 5 ans je l'installe pour le tester, et à chaque fois il y des défauts rédhibitoires...

Bref, sans caractère "@" je ne peux pas faire grand chose...

Hors ligne

#6 Le 24/11/2021, à 22:12

Coeur Noir

Re : [Résolu] Caractère arrobase "@", toujours lui...

Ben non c'est pas une question de chance, mais de savoir quoi configurer dans ton contexte, pour arriver à tes fins ;-)

Il n'y a pas non plus de raison que Budgie soit plus lent que les autres ( il est moins gourmand en ressources que l'Ubuntu officielle ).

J'aimerais t'aider davantage mais je n'y connais goutte en VM : c'est par là qu'il faut chercher, dans leurs doc's, les raccourcis clavier, leurs diverses configurations…
https://kb.synology.com/fr-fr/search?so … oper_guide ?


DébuterDocBien rédigerRetour commandeInsérer image | illustrations & captures d'écran <>

Hors ligne

#7 Le 24/11/2021, à 22:49

eric63

Re : [Résolu] Caractère arrobase "@", toujours lui...

bonjour
D‘autres pistes bien que je n’y connaisse rien en VM
dans les réglages système il y a un aperçu de la disposition de ton clavier pour voir si la touche correspond bien ce que tu penses être ou bien tu peux choisir ou ajouter une autre disposition
il y a aussi sûrement une rubrique dans ton réglage système qui te liste tes raccourcis clavier voir essayer de changer le raccourci cela devrait montrer une alerte que ce raccourci est déjà employé pour ??


Kubuntu 21.10 - 64 bits + backports beta = plasma 5.23.4 KDE 5.88.0 Qt 5.15.2 et noyau 5.13.0-22  4x intel i5-4570 3.2 Ghz 12 Go nvidia GTX 1060 6GB
Comment installer une brother avec le script de demonipuch

J’utilise le clavier french AFNOR de chez LDLC c‘est fort

Hors ligne

#8 Le 25/11/2021, à 20:38

Nounours18200

Re : [Résolu] Caractère arrobase "@", toujours lui...

Hello,

Bon après avoir essayé plusieurs Linux: Ubuntu, Mint, Bodgie, (et j'ai Kubuntu et eOS en réserve:D) j'ai à chaque fois le même problème: pas de caractère @.

Donc j'ai décidé de m'éviter de passer par VMM de Synology, et j'ai installé "Vino" (un serveur VNC) en suivant ce tutorial super clair pour les buses comme moi:https://www.malekal.com/prendre-la-main … -avec-vnc/
Comme toujours avec Malekal, c'est compréhensible et ça fonctionne.

Ensuite j'ai utilisé "VNC Viewer" sur mon PC Windows, et j'accède à mon Ubuntu !

J'ai ouvert un LibreOffice Writer, et devinez quoi ? le caractère"@" est disponible sans problème ! en-fin...

Il me reste désormais à installer NordVPN sur Ubuntu, mais ça ce sera pour demain.

Merci à tous et à bientôt

Hors ligne

#9 Le 25/11/2021, à 21:53

Coeur Noir

Re : [Résolu] Caractère arrobase "@", toujours lui...

Bon c'est un progrès.

Mais ça conforte l'idée qu'il y a quelque chose à faire côté VMM Synology pour récupérer l'usage de cette touche @…

Ici ce que je ne comprends pas c'est le « pourquoi » de la VM ou du VNC, je n'arrive pas à me figurer ton contexte - ce qui n'est pas important, juste de la curiosité de ma part.

( et un vague pressentiment que tu te compliques peut-être la vie inutilement ).


DébuterDocBien rédigerRetour commandeInsérer image | illustrations & captures d'écran <>

Hors ligne

#10 Le 26/11/2021, à 16:58

Nounours18200

Re : [Résolu] Caractère arrobase "@", toujours lui...

Ici ce que je ne comprends pas c'est le « pourquoi » de la VM ou du VNC, je n'arrive pas à me figurer ton contexte - ce qui n'est pas important, juste de la curiosité de ma part.

Tout simplement parce que je ne veux pas pour l'instant installer un Linux sur mon PC (ma productivité est plus importante avec W et certaines des applis dont j'ai besoin ne sont dispos que sur W), et comme j'ai 2 NAS (deux Syno et un QNAP), je préfère installer Linux là-dessus.

Et accessoirement je voulais pouvoir utiliser un VPN ailleurs que sur mon PC principal, donc là aussi, pourquoi ne pas utiliser le CPU du Syno qui dort la plupart du temps ...

Hors ligne