Contenu | Rechercher | Menus

Annonce

DVD, clés USB et t-shirts Ubuntu-fr disponibles sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 27/11/2021, à 08:00

WiseSherkaan

Réseau inaccessible

Bonjour,

Je réinstalle une Ubuntu 20.04. Au départ, je n'ai pas rencontré de problème d'accès à mon réseau Wifi.
Mais cela n'a pas duré.
Ni en wifi, ni en Ethernet, ni même en partage de connexion de mon téléphone en USB, je n'ai aucun réseau, alors que le réseau est visible et semble fonctionner.

Voici le résultat de quelques commandes :

tom@tom-ThinkCentre-M83:/home$ lspci -k -nn | grep -A 3 -i net
00:19.0 Ethernet controller [0200]: Intel Corporation Ethernet Connection I217-LM [8086:153a] (rev 04)
	DeviceName:  Onboard LAN
	Subsystem: Lenovo ThinkCentre M83 [17aa:309f]
	Kernel driver in use: e1000e
--
02:00.0 Network controller [0280]: Realtek Semiconductor Co., Ltd. RTL8812AE 802.11ac PCIe Wireless Network Adapter [10ec:8812] (rev 01)
	Subsystem: D-Link System Inc RTL8812AE 802.11ac PCIe Wireless Network Adapter [1186:3305]
	Kernel driver in use: rtl8821ae
	Kernel modules: rtl8821ae


tom@tom-ThinkCentre-M83:/home$ ip a
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: eno1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UP group default qlen 1000
    link/ether 00:23:24:91:8d:a9 brd ff:ff:ff:ff:ff:ff
    altname enp0s25
    inet 192.168.1.112/24 brd 192.168.1.255 scope global dynamic noprefixroute eno1
       valid_lft 42526sec preferred_lft 42526sec
    inet6 2a01:e0a:3c7:d3d0:b2af:4a36:6366:aa72/64 scope global temporary dynamic 
       valid_lft 86242sec preferred_lft 85307sec
    inet6 2a01:e0a:3c7:d3d0:c507:e0b1:ab2e:d71e/64 scope global dynamic mngtmpaddr noprefixroute 
       valid_lft 86242sec preferred_lft 86242sec
    inet6 fe80::7b0e:842c:25a7:7676/64 scope link noprefixroute 
       valid_lft forever preferred_lft forever
3: wlp2s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP group default qlen 1000
    link/ether 10:be:f5:05:2f:ee brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.69/24 brd 192.168.1.255 scope global dynamic noprefixroute wlp2s0
       valid_lft 41937sec preferred_lft 41937sec
    inet6 2a01:e0a:3c7:d3d0:6f8b:a9d1:53ce:bf1a/64 scope global temporary dynamic 
       valid_lft 86242sec preferred_lft 84801sec
    inet6 2a01:e0a:3c7:d3d0:7522:5c91:e7a0:edf7/64 scope global dynamic mngtmpaddr noprefixroute 
       valid_lft 86242sec preferred_lft 86242sec
    inet6 fe80::437:1849:5b2a:9557/64 scope link noprefixroute 
       valid_lft forever preferred_lft forever
4: ipv6leakintrf0: <BROADCAST,NOARP,UP,LOWER_UP> mtu 1500 qdisc noqueue state UNKNOWN group default qlen 1000
    link/ether 5a:77:94:3d:6d:e7 brd ff:ff:ff:ff:ff:ff
    inet6 fdeb:446c:912d:8da::/64 scope global noprefixroute 
       valid_lft forever preferred_lft forever
    inet6 fe80::fa02:b28e:9d1d:f50a/64 scope link noprefixroute 
       valid_lft forever preferred_lft forever

tom@tom-ThinkCentre-M83:/home$ dpkg -l | grep -v ^ii
Souhait=inconnU/Installé/suppRimé/Purgé/H=à garder
| État=Non/Installé/fichier-Config/dépaqUeté/échec-conFig/H=semi-installé/W=attend-traitement-déclenchements
|/ Err?=(aucune)/besoin Réinstallation (État,Err: majuscule=mauvais)
||/ Nom                                        Version                               Architecture Description
+++-==========================================-=====================================-============-======================================================================================================


tom@tom-ThinkCentre-M83:/home$ cat /etc/network/interfaces
cat: /etc/network/interfaces: Aucun fichier ou dossier de ce type

tom@tom-ThinkCentre-M83:/home$ iwconfig
lo        no wireless extensions.

eno1      no wireless extensions.

wlp2s0    IEEE 802.11  ESSID:"Sherk"  
          Mode:Managed  Frequency:2.437 GHz  Access Point: 68:A3:78:07:3C:77   
          Bit Rate=144.4 Mb/s   Tx-Power=20 dBm   
          Retry short limit:7   RTS thr=2347 B   Fragment thr:off
          Power Management:on
          Link Quality=70/70  Signal level=-36 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

ipv6leakintrf0  no wireless extensions.

N'ayant pas d'accès au réseau sur la machine en cause, il me faudrait en passer par un téléchargement puis une clé USB si une solution existait.

Merci pour votre aide.
Cordialement,
Thomas

Hors ligne

#2 Le 27/11/2021, à 10:16

iznobe

Re : Réseau inaccessible

Bonjour , d ' apres le retour de : " ip a "
on voit que ta connexion ethernet est active et connectée , pareil pour le wifi d' ailleurs .
par contre ce qui est plus surprenant , c ' est la 3eme connexion , que je ne sais pas interpreter :

4: ipv6leakintrf0: <BROADCAST,NOARP,UP,LOWER_UP> mtu 1500 qdisc noqueue state UNKNOWN group default qlen 1000
    link/ether 5a:77:94:3d:6d:e7 brd ff:ff:ff:ff:ff:ff
    inet6 fdeb:446c:912d:8da::/64 scope global noprefixroute 
       valid_lft forever preferred_lft forever
    inet6 fe80::fa02:b28e:9d1d:f50a/64 scope link noprefixroute 
       valid_lft forever preferred_lft forever

As tu voulu configurer une connexion " speciale " , faudrait nous dire laquelle . ou un truc special ipv6 peut etre ?
c ' est probablement cela qui empeche les autres connescions de fonctionner normalement .

on peut tenter de la desactiver pour voir si tu retrouves un etat standard , que donne :

sudo ip link set dev ipv6leakintrf0 down

Dernière modification par iznobe (Le 27/11/2021, à 10:36)


retour utilisable de commande
MSI Z490A-pro , i7 10700 , 32 GB RAM . avec Ubuntu , LM et W$10

En ligne

#3 Le 27/11/2021, à 10:23

nany

Re : Réseau inaccessible

Bonjour,



iznobe a écrit :

par contre ce qui est plus surprenant , c ' est la 3eme connexion , que je ne sais pas interpreter :

Bah c’est le smartphone, non ?

Ça semble plus être un problème d’internet que de réseau.
Peut-être le DNS ?
Que donne la commande suivante ?

ping -c4 8.8.8.8 && ping -c4 google.fr

Hors ligne

#4 Le 27/11/2021, à 10:43

iznobe

Re : Réseau inaccessible

nany a écrit :

Bah c’est le smartphone, non ?

affectivement pas pensé a ca roll

pour le probleme du serveur DNS , c' etait la 2eme option que j' envisageais , mais tu m' as coupé l' herbe sous le pied wink


retour utilisable de commande
MSI Z490A-pro , i7 10700 , 32 GB RAM . avec Ubuntu , LM et W$10

En ligne

#5 Le 27/11/2021, à 10:43

xubu1957

Re : Réseau inaccessible

Bonjour,

2: eno1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UP group default qlen 1000

    altname enp0s25

Pour la connexion filaire, essaye :

sudo ip link set eno1 down
sudo ip link set eno1 up
sudo dhclient eno1

ou ensuite :

sudo ip link set enp0s25 down
sudo ip link set enp0s25 up
sudo dhclient enp0s25

        _ _ _

(edit=messages regroupés)
        _ _ _


Tu n'avais pas gardé Windows > pour désactiver le WOL ?

Dernière modification par xubu1957 (Le 27/11/2021, à 11:19)


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 20.04 LTS - Lenovo T410 -18.04.1 LTS Toshiba Satellite A300  Membre de Linux-Azur

Hors ligne

#6 Le 27/11/2021, à 10:49

WiseSherkaan

Re : Réseau inaccessible

Hello,
je tente tout ça et vous envoie les retours.

J'en passe par un fichier texte sur une clé USB alors c'est un peu longuet....mais ce sera fait tongue

Hors ligne

#7 Le 27/11/2021, à 11:00

WiseSherkaan

Re : Réseau inaccessible

C'est étrange...

ping -c4 8.8.8.8 && ping -c4 google.fr
tom@tom-ThinkCentre-M83:/home$ ping -c4 8.8.8.8 && ping -c4 google.fr
PING 8.8.8.8 (8.8.8.8) 56(84) bytes of data.
64 octets de 8.8.8.8 : icmp_seq=1 ttl=120 temps=12.0 ms
64 octets de 8.8.8.8 : icmp_seq=2 ttl=120 temps=10.6 ms
64 octets de 8.8.8.8 : icmp_seq=3 ttl=120 temps=11.1 ms
64 octets de 8.8.8.8 : icmp_seq=4 ttl=120 temps=11.4 ms

--- statistiques ping 8.8.8.8 ---
4 paquets transmis, 4 reçus, 0 % paquets perdus, temps 3004 ms
rtt min/avg/max/mdev = 10.607/11.293/11.998/0.502 ms
ping: google.fr: Échec temporaire dans la résolution du nom

C'est comme si quelque chose bloquait la connexion non?

Hors ligne

#8 Le 27/11/2021, à 11:02

WiseSherkaan

Re : Réseau inaccessible

@xubu1957 : la carte Wifi tout comme la carte Ethernet viennent d'un ancien PC probablement sous Windows. Est-ce que cela pourrait avoir une conséquence? SInon il n'y avait pas d'OS sur mes disques.
Je vais ilre attentivement ton lien.

Hors ligne

#9 Le 27/11/2021, à 11:08

WiseSherkaan

Re : Réseau inaccessible

sudo systemctl restart networking
Failed to restart networking.service : Unit networking.service not found
sudo systemctl restart network-manager

==> renvoie au prompt, donc semble opérant

Hors ligne

#10 Le 27/11/2021, à 11:11

xubu1957

Re : Réseau inaccessible

WiseSherkaan a écrit :

N'ayant pas d'accès au réseau sur la machine en cause, il me faudrait en passer par un téléchargement puis une clé USB si une solution existait.

Voir > Connexion de secours - partage de connexion avec un smartphone

Essaye :

sudo apt update

Dernière modification par xubu1957 (Le 27/11/2021, à 11:12)


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 20.04 LTS - Lenovo T410 -18.04.1 LTS Toshiba Satellite A300  Membre de Linux-Azur

Hors ligne

#11 Le 27/11/2021, à 11:17

nany

Hors ligne

#12 Le 27/11/2021, à 11:22

WiseSherkaan

Re : Réseau inaccessible

Hum...de ce que je comprends, la connection est correcte, c'est Firefox qui ne veut rien savoir.
Je vais tenter le sudo apt update pour voir.

tom@tom-ThinkCentre-M83:~$ nmcli -g all
eno1: connecté à Connexion filaire 1
	"Intel I217-LM"
	ethernet (e1000e), 00:23:24:91:8D:A9, hw, mtu 1500
	ip4 par défaut, ip6 par défaut
	inet4 192.168.1.112/24
	route4 0.0.0.0/0
	route4 192.168.1.0/24
	inet6 2a01:e0a:3c7:d3d0:2341:21a6:794e:2af8/64
	inet6 2a01:e0a:3c7:d3d0:c507:e0b1:ab2e:d71e/64
	inet6 fe80::7b0e:842c:25a7:7676/64
	route6 2a01:e0a:3c7:d3d0::/64
	route6 ::/0
	route6 fe80::/64

wlp2s0: connecté à Sherk
	"Realtek RTL8812AE"
	wifi (rtl8821ae), 10:BE:F5:05:2F:EE, hw, mtu 1500
	inet4 192.168.1.69/24
	route4 0.0.0.0/0
	route4 192.168.1.0/24
	route4 169.254.0.0/16
	inet6 2a01:e0a:3c7:d3d0:c002:b33b:ee94:d3ca/64
	inet6 2a01:e0a:3c7:d3d0:7522:5c91:e7a0:edf7/64
	inet6 fe80::437:1849:5b2a:9557/64
	route6 2a01:e0a:3c7:d3d0::/64
	route6 ::/0
	route6 fe80::/64

p2p-dev-wlp2s0: déconnecté
	"p2p-dev-wlp2s0"
	wifi-p2p, hw

lo: non-géré
	"lo"
	loopback (unknown), 00:00:00:00:00:00, sw, mtu 65536

DNS configuration:
	servers: 192.168.1.254
	interface: eno1

	servers: fd0f:ee:b0::1
	interface: eno1

	servers: fd0f:ee:b0::1
	interface: wlp2s0

	servers: 192.168.1.254
	interface: wlp2s0

Utilisez « nmcli device show » pour obtenir des informations complètes sur les périphériques connus et « nmcli connection show » pour obtenir une vue d'ensemble des profils de connexions actifs.

Consultez les pages de manuel nmcli(1) et nmcli-examples(7) pour les détails complets d'utilisation.

Hors ligne

#13 Le 27/11/2021, à 11:32

WiseSherkaan

Re : Réseau inaccessible

Le ping de google.fr répond à présent !
Je n'y comprends plus rien.
Mais FF est toujours HS.

Hors ligne

#14 Le 27/11/2021, à 11:36

nany

Re : Réseau inaccessible

WiseSherkaan a écrit :

Mais FF est toujours HS.

Ferme le puis relance le pour voir.

Hors ligne

#15 Le 27/11/2021, à 12:23

WiseSherkaan

Re : Réseau inaccessible

Impossible de le fermer correctement. Je vais tenter de le désinstaller totalement:|

Hors ligne

#16 Le 27/11/2021, à 12:40

WiseSherkaan

Re : Réseau inaccessible

Et bien voilà, j'ai tout supprimé (autoremove puis purge, sans oublier de vérifier qu'il ne traînait plus aucun fichier), puis réinstallé.
Firefox fonctionne....
Merci à tous pour votre patience.

Bonne journée;)
Thomas

Hors ligne