Contenu | Rechercher | Menus

Annonce

Ubuntu-fr vend de superbes t-shirts et de belles clés USB 32Go
Rendez-vous sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 26/04/2014, à 01:10

baladeur

[RESOLU] Google Earth et ia32-libs

Bonjour,
Sous 14.04 LTS depuis peu je tente d'installer Google Earth sans succès !
La logithèque et tous les installateurs (Tweak) me disent  : dépendance ia32-libs non satisfaite !!! je ne peut pas l'avoir dans Synaptic non plus !
Je ne sais pas comment trouver et installer cette dépendance !
Merci de votre aide !


Packard Bell Easynote ML 65
64 bits  320 G mémoire  4G ram

Dernière modification par baladeur (Le 26/04/2014, à 07:07)


Packard-Bell EasyNote ML65-U-014FR
Intel Pentium Dual Core T4200 (2,0 Ghz) - Ecran 15"4 -Mémoire 3072 Mo - Disque dur 320 Go -
Carte graphique ATI Mobility Radeon HD 3430 (256 Mo dédiés)  avec 18.04 installe récemment
J'ai aussi un petit macboucair mais c'est une autre histoire !

Hors ligne

#2 Le 26/04/2014, à 02:11

louis94

Re : [RESOLU] Google Earth et ia32-libs

Bonjour,

ia32-libs était depuis longtemps un paquet « de transition », ce qui signifiait qu'il ne servait plus à rien et allait être retiré. Apparemment il a finalement disparu (mais a été remplacé depuis plusieurs versions déjà par un autre procédé).

Des solutions en anglais sont données dans la documentation :

La doc a écrit :

Ubuntu Saucy 13.10 64bits :
La dépendance ia32-libs nécessaire pour Google-earth_64_bits n'est plus disponible pour Ubuntu Saucy 13.10. Plusieurs solutions s'offrent à vous :
    Installer le paquet multiarch-support et utiliser Google-earth_i386: (en) Source
    Ou bien suivre (en) cette solution pour recréer un paquet d'installation 64bits
    Ou encore suivre (en) cette autre solution.

À noter, le logiciel Marble, qui est disponible dans les dépôts et offre des fonctionnalités similaires.

Louis

Hors ligne

#3 Le 26/04/2014, à 02:34

bishop

Re : [RESOLU] Google Earth et ia32-libs

Salut !
Pour installer Google Earth sous Trusty 14.04 64 bits tu dois...

1) Donner la possibilité au système d'utiliser des paquets 32 bits sur un architecture 64 bits et mettre à jour les dépôts. Dans un Terminal :

sudo dpkg --add-architecture i386 && sudo apt-get update

Appuyer sur Entrée, entrer votre mot de passe quand il est requis, appuyer de nouveau sur Entrée.


2) Installer les dépendances :

sudo apt-get install libc6-i386 libglib2.0-0:i386 libsm6:i386 libglu1-mesa:i386 libgl1-mesa-glx:i386 libxext6:i386 libxrender1:i386 libx11-6:i386 libfontconfig1:i386 lsb-core

Appuyer sur Entrée, entrer votre mot de passe s'il est requis, appuyer de nouveau sur Entrée.


3) Installer l'Installeur pour les polices de caractères système Microsoft TrueType :

sudo apt-get install ttf-mscorefonts-installer

Appuyer sur Entrée, entrer votre mot de passe s'il est requis, appuyer de nouveau sur Entrée.


4) Télécharger le DEB Google Earth :

cd && wget -O google-earth64.deb http://dl.google.com/dl/earth/client/current/google-earth-stable_current_i386.deb

Appuyer sur Entrée.


5) Installer le DEB :

cd && sudo dpkg -i google-earth64.deb

Appuyer sur Entrée, entrer votre mot de passe s'il est requis, appuyer de nouveau sur Entrée.


6) Vérifier si toutes les dépendances sont bien installées :

sudo apt-get install -f

Appuyer sur Entrée, entrer votre mot de passe s'il est requis, appuyer de nouveau sur Entrée.


Il ne reste plus qu'à taper google earth dans le zone de saisie du Dash (Alt F2) et lancer Google Earth.
Source

J'ai suivi cette procédure sous Trusty 14.04 64 bits et Google Earth fonctionne très bien.

Dernière modification par bishop (Le 03/05/2016, à 08:06)


Moteurs de recherche : PPA Personal Package Archives for Ubuntu, Dépôts Ubuntu Ubuntu Packages Search

Hors ligne

#4 Le 26/04/2014, à 06:52

baladeur

Re : [RESOLU] Google Earth et ia32-libs

Waou,

Suis bluffé là !!

1. pour la solution rapide !!!
2. pour la solution simple !!!

Merci à bishop pour son efficace suite de ligne de commande !
Je ne suis pas un habitué de la ligne de commande mais là, le travail était mâché (j'ai apprécié !)

Merci à louis94 pour sa rapidité et sa solution. Tu comprendra mon choix et de toute façon c'était l'une ou l'autre.

C'est bien d'avoir un forum si réactif
(J'ai eu il y a longtemps ... des soucis avec un certain W.....(???) qui a mis un "certain temps" pour une réponse au débutant que j'étais)

Merci à vous deux, ça marche au poil !


Packard-Bell EasyNote ML65-U-014FR
Intel Pentium Dual Core T4200 (2,0 Ghz) - Ecran 15"4 -Mémoire 3072 Mo - Disque dur 320 Go -
Carte graphique ATI Mobility Radeon HD 3430 (256 Mo dédiés)  avec 18.04 installe récemment
J'ai aussi un petit macboucair mais c'est une autre histoire !

Hors ligne

#5 Le 26/04/2014, à 11:15

bishop

Re : [RESOLU] Google Earth et ia32-libs

Cool ! cool


Moteurs de recherche : PPA Personal Package Archives for Ubuntu, Dépôts Ubuntu Ubuntu Packages Search

Hors ligne

#6 Le 08/05/2014, à 13:33

tioneh

Re : [RESOLU] Google Earth et ia32-libs

Merci bishop - ça marche nickel

Hors ligne

#7 Le 08/05/2014, à 15:29

bishop

Re : [RESOLU] Google Earth et ia32-libs

tioneh !
Cool ! cool Et de rien...

Dernière modification par bishop (Le 09/05/2014, à 06:48)


Moteurs de recherche : PPA Personal Package Archives for Ubuntu, Dépôts Ubuntu Ubuntu Packages Search

Hors ligne

#8 Le 17/05/2014, à 04:38

jvcharles

Re : [RESOLU] Google Earth et ia32-libs

enfin merci bishop


Ubuntu 19.10,18.04, Debian Buster, Bullseye et Manjaro (Windows 10 et Facebook supprimer définitivement 02/02/19)
Cherche à supprimer Android pour un autre OS libre pour mon mobile.
Si vous avez résolu votre problème, ajoutez [Résolu] au titre de la discussion.

Hors ligne

#9 Le 17/05/2014, à 13:12

bishop

Re : [RESOLU] Google Earth et ia32-libs

De rien jvcharles ! cool


Moteurs de recherche : PPA Personal Package Archives for Ubuntu, Dépôts Ubuntu Ubuntu Packages Search

Hors ligne

#10 Le 17/05/2014, à 13:39

Korak

Re : [RESOLU] Google Earth et ia32-libs

Bonjour,

J'ai suivi la procédure de bishop et ça a presque bien fonctionné: l'image de Google Earth apparaît puis disparaît.

Je me suis dit ça y est, il me refait le même coup que sous Ubuntu 12.04 64 bits et je vais devoir installer une ancienne version de Google Earth.

Et bien non, après avoir redémarré le PC, la version 7.1.2.2041 de Google Earth fonctionne sous Ubuntu 14.04 64 bits.

Merci à bishop pour l'aide.


OS: Ubuntu 18.04 64 bits + Windows 10 64 bits en dualboot (BIOS UEFI, Secure Boot activé et table de partitions GPT)
PC portable HP Pavilion 17-f055nb: Processeur: AMD A8-6410 APU   Cartes graphiques: AMD Radeon R5 + R7   Mémoire vive: 12 Go RAM
Je suis Parrain-Linux

Hors ligne

#11 Le 17/05/2014, à 14:06

bishop

Re : [RESOLU] Google Earth et ia32-libs

De rien Korak ! big_smile


Moteurs de recherche : PPA Personal Package Archives for Ubuntu, Dépôts Ubuntu Ubuntu Packages Search

Hors ligne

#12 Le 17/05/2014, à 14:15

Korak

Re : [RESOLU] Google Earth et ia32-libs

Tu as aussi du redémarrer ton PC pour que Google Earth fonctionne?


OS: Ubuntu 18.04 64 bits + Windows 10 64 bits en dualboot (BIOS UEFI, Secure Boot activé et table de partitions GPT)
PC portable HP Pavilion 17-f055nb: Processeur: AMD A8-6410 APU   Cartes graphiques: AMD Radeon R5 + R7   Mémoire vive: 12 Go RAM
Je suis Parrain-Linux

Hors ligne

#13 Le 17/05/2014, à 14:19

bishop

Re : [RESOLU] Google Earth et ia32-libs

Non ! Pas eu besoin...


Moteurs de recherche : PPA Personal Package Archives for Ubuntu, Dépôts Ubuntu Ubuntu Packages Search

Hors ligne

#14 Le 17/05/2014, à 14:29

Korak

Re : [RESOLU] Google Earth et ia32-libs

C'est marrant que deux PC utilisant le même O.S. réagissent différemment.


OS: Ubuntu 18.04 64 bits + Windows 10 64 bits en dualboot (BIOS UEFI, Secure Boot activé et table de partitions GPT)
PC portable HP Pavilion 17-f055nb: Processeur: AMD A8-6410 APU   Cartes graphiques: AMD Radeon R5 + R7   Mémoire vive: 12 Go RAM
Je suis Parrain-Linux

Hors ligne

#15 Le 17/05/2014, à 17:00

bishop

Re : [RESOLU] Google Earth et ia32-libs

C'est très mystique tout cela... lol
Et quand cela arrive je l'attribue "Aux Mystères de Linux".

Plus sérieusement... c'est peut être dû à l'environnement graphique, aux fonctionnalités du processeur ou du GPU, à je ne sais quel artifice d'un composant quelconque, à l'interaction avec des paquets déjà installés... roll

Dernière modification par bishop (Le 17/06/2014, à 13:16)


Moteurs de recherche : PPA Personal Package Archives for Ubuntu, Dépôts Ubuntu Ubuntu Packages Search

Hors ligne

#16 Le 17/05/2014, à 17:06

Korak

Re : [RESOLU] Google Earth et ia32-libs

bishop a écrit :

quand cela arrive j'attribue cela "Aux Mystères de Linux".

Personnellement, je l'attribue aux mystères de l'informatique (j'ai déjà eu la même blague avec deux Windows identiques).

bishop a écrit :

Plus sérieusement... c'est peut être dû à l'environnement graphique, aux fonctionnalités du processeur, à je ne sais quel artifice d'un composant quelconque, à l'interraction avec des paquets déja installés... roll

Possible, a creuser.....


OS: Ubuntu 18.04 64 bits + Windows 10 64 bits en dualboot (BIOS UEFI, Secure Boot activé et table de partitions GPT)
PC portable HP Pavilion 17-f055nb: Processeur: AMD A8-6410 APU   Cartes graphiques: AMD Radeon R5 + R7   Mémoire vive: 12 Go RAM
Je suis Parrain-Linux

Hors ligne

#17 Le 08/06/2014, à 19:19

citrux

Re : [RESOLU] Google Earth et ia32-libs

Bonjour,

est-ce que la méthode décrite par bishop fonctionne aussi sous UBUNTU 12.04 ?


ZBOX Ubuntu 12.04 ; EEEPC 1000H XUBUNTU 14.04

Hors ligne

#18 Le 08/06/2014, à 19:51

bishop

Re : [RESOLU] Google Earth et ia32-libs

citrux a écrit :

Bonjour,

est-ce que la méthode décrite par bishop fonctionne aussi sous UBUNTU 12.04 ?

Salut citrux !
Cette méthode n'est pas adaptée à Ubuntu Precise 12.04 car sur cette distribution  ia32-libs est proposé dans les dépôts officiels.
Il te suffit d'installer ia32-libs (ça va t'installer pas mal de paquets) :

sudo apt-get install ia32-libs

Puis d'installer ttf-mscorefonts-installer et Google Earth. Pour ce faire tu suis les paragraphe 2), 3), 4) et 5) du tutoriel du poste #3.

Et tu dis quoi... roll


Moteurs de recherche : PPA Personal Package Archives for Ubuntu, Dépôts Ubuntu Ubuntu Packages Search

Hors ligne

#19 Le 09/06/2014, à 13:24

citrux

Re : [RESOLU] Google Earth et ia32-libs

ça ne marche pas pour moi. J'ai suivi la démarche indiquée et je pense que les paquets sont bien installés mais lorsque je lance googleearth j'ai un message "carte graphique incompatible". La seule chose visible sont les frontières des pays sur le planisphère. Est-ce qu' une version antérieure fonctionnerait ?


ZBOX Ubuntu 12.04 ; EEEPC 1000H XUBUNTU 14.04

Hors ligne

#20 Le 09/06/2014, à 14:06

le-peyo

Re : [RESOLU] Google Earth et ia32-libs

Holà,

dans Outils=>Options=>Vue 3d tu (dé)coche la case "Compresser" (ça dépend de l'état où tu l'as trouvée en arrivant).

Pour ma part j'utilise une ancienne version comme expliqué .
Les polices ne sont pas très belles mais, honnêtement, quand je vais sur Google Earth ce n'est pas pour lire les textes wink

La version 6.0.3.2197 va bien mais on ne peut pas zoomer en "street view".
La version 6.2.2.6613 marche bien mis à part un léger bug dans le barre de recherche qui ne donne pas accès à l'historique... pas trop gênant. Sur celle-là on peut zoomer avec le clic droit en mode "street view".
La version 7 ne m'affiche pas les panoramios.

Bon courage.

Dernière modification par le-peyo (Le 09/06/2014, à 14:07)


Sous Linux depuis 2009 | Xubuntu 18.04 LTS | Lenovo Thinkpad W540
Windows... ? J'connais pas...
Lire du Flash... sans Flash... C'est par là =>

Hors ligne

#21 Le 09/06/2014, à 17:26

bishop

Re : [RESOLU] Google Earth et ia32-libs

citrux a écrit :

ça ne marche pas pour moi. J'ai suivi la démarche indiquée et je pense que les paquets sont bien installés mais lorsque je lance googleearth j'ai un message "carte graphique incompatible". La seule chose visible sont les frontières des pays sur le planisphère. Est-ce qu' une version antérieure fonctionnerait ?

Tu peux donner quelques détails sur ta machine (tour, portable, carte graphique, proc, etc...) ?


Moteurs de recherche : PPA Personal Package Archives for Ubuntu, Dépôts Ubuntu Ubuntu Packages Search

Hors ligne

#22 Le 13/06/2014, à 22:46

citrux

Re : [RESOLU] Google Earth et ia32-libs

La bécane est une ZBOX de Zotac avec un processeur 4x Intel R Atom CPU D525  1.8 GHZ
1 GB de mémoire
Ecran 800x600 pixels
Carte graphique : Integrated with Intel GMW 3xxx
                             Direct X9 compliant Pixel Shader
                             3D graphic rendering enhancements
                             VGA and HDMI (720p) dual output support

C'est toutes les informations que j'ai trouvées sur la notice de l'appareil.

Merci


ZBOX Ubuntu 12.04 ; EEEPC 1000H XUBUNTU 14.04

Hors ligne

#23 Le 14/06/2014, à 19:45

bishop

Re : [RESOLU] Google Earth et ia32-libs

Salut citrux !
Le problème peut provenir de :
- la version Ubuntu 10.04 que tu utilises sur la ZBOX,
- du fait que le chipset graphique Intel GMW 3xxx ne dispose peut être pas des "ingrédients" nécessaires à l'accélération graphique.

J'ai un portable sous ubuntu 12.04 avec un chipset graphique Intel. Je testerai l'installation de Google Earth pour voir...

Dernière modification par bishop (Le 17/06/2014, à 13:17)


Moteurs de recherche : PPA Personal Package Archives for Ubuntu, Dépôts Ubuntu Ubuntu Packages Search

Hors ligne

#24 Le 15/06/2014, à 20:56

corinactis

Re : [RESOLU] Google Earth et ia32-libs

Bonjour,
Malgré mes recherches et suivis des solutions pour intaller google earth sur Ubuntu version 14.04, ça bloque à la première étape:
impossible d'obtenir le verrou /var/lib/dpkg/lock
Est-ce quelqu'un peu m'aider ?
Merci
Yannick

Hors ligne

#25 Le 15/06/2014, à 22:29

bishop

Re : [RESOLU] Google Earth et ia32-libs

corinactis !
Tu ne dois pas avoir un autre gestionnaire de paquets ouvert (Synaptic, Gestionnaire de mise à jour, etc...).

Sinon, essaie (vu dans la doc ubuntu-fr : Problèmes avec les gestionnaires de paquets (Paragraphe 1 et 2) :

sudo rm -rf /var/lib/apt/lists/lock
sudo dpkg --configure -a

Puis tu reprends le tuto d'installation de Google Earth au début.

Dernière modification par bishop (Le 15/06/2014, à 22:32)


Moteurs de recherche : PPA Personal Package Archives for Ubuntu, Dépôts Ubuntu Ubuntu Packages Search

Hors ligne