Contenu | Rechercher | Menus

Annonce

Ubuntu-fr vend de superbes t-shirts et de belles clés USB 32Go
Rendez-vous sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 06/02/2016, à 18:01

pryzm

Installation Ubuntu 14.04 (Dual Boot Win10) UEFI ?

Bonjour,

Je viens de recevoir mon nouveau PC : un Alienware 15 R2 dernière génération qui tourne sous Windows 10 Famille 64 Bits et qui boot en UEFI.

Voici la configuration :
mini_382233config.png

Je souhaite développer sous Ubuntu mais continuer à conserver Windows pour les jeux et certains programmes (Photoshop, etc.). J'ai tout d'abord tenté d'installer une VM Ubuntu grâce à VirtualBox, mais même avec les 12 Go de RAM et les 4 coeurs, je trouve ça très lent... Le mieux reste quand même d'avoir sa propre installation Ubuntu.

Disposant de 1 disque SSD de 256 Go (où est installé Windows par défaut) et 1 disque dur de 1To, j'hésitais sur la mise en place de l'installation d'Ubuntu (l'installer sur le 1 To ? L'installer sur le SSD ?). J'ai d'abord effectué des sauvegardes des fichiers (CD de réparation Win10 + image système) pour la sécurité.

J'ai tenté d'installer Ubuntu sur le disque 1 To en repartitionnant ce disque (en lui réservant 30 Go). Après avoir créé une clé USB bootable avec la dernière version d'Ubuntu dessus (14.04.03), je l'ai insérée et cela a bien booté dessus en UEFI. Cependant, arrivé sur la page d'installation, le liveUSB ne reconnaissait pas l'installation de Windows. Ne voulant pas perdre l'installation de Windows, j'ai tout stoppé.
J'ai bien vu qu'il fallait désactiver certaines options dans le BOOT menu (notamment le "FastBoot" et/ou "Secure Boot"). Après avoir désactivé le SecureBoot et redémarré le PC, Win10 ne voulait plus se lancer... J'ai du procéder à la démarche inverse pour qu'il veule bien se lancer.
J'ai bien lu que de toute manière, je ne dois pas installer Ubuntu en mode "Legacy" mais bien en mode "UEFI" puisque Windows l'a été installé ainsi.

Voici les options proposées dans mon BOOT menu :
mini_216451IMG20160206144746.jpgmini_119550IMG20160206144755.jpgmini_948088IMG20160206144803.jpgmini_749031IMG20160206144816.jpg

Après être tombé sur ce post [SSD + HDD, dual boot ou 2 SSD ?], cela m'a engagé dans la voie citée, c'est-à-dire installer Ubuntu à côté de Windows sur le SSD (prévoir 30-40 Go sur le SSD pour Ubuntu ? Incluant le /home) et conserver le 1To pour les DATA. En revanche, je ne sais pas si je dois faire quelque chose spécifique pour le swap ou non...
Cependant, en vérifiant la table de partition sous Windows, je vois que le SSD contient déjà 4 partitions, et il me semble que c'est le nombre maximum de partition primaire :
mini_887839harddrive.png

Je ne sais donc pas comment installer Ubuntu à côté de mon Windows... Que me conseillez-vous pour procéder à cette installation de manière simple mais performante ? Et comment faire pour l'installer en liveUSB si Ubuntu ne reconnait pas mon installation Windows ?
J'espère vous avoir donné assez d'informations sur mon matériel et ma configuration, mais n'hésitez pas à me demander s'il manquerait une info.

Merci d'avance de votre réponse,

Pryzm.

Hors ligne

#2 Le 06/02/2016, à 19:20

lucmars

Re : Installation Ubuntu 14.04 (Dual Boot Win10) UEFI ?

pryzm a écrit :

Cependant, en vérifiant la table de partition sous Windows, je vois que le SSD contient déjà 4 partitions, et il me semble que c'est le nombre maximum de partition primaire :

Pour une installe en mode legacy, oui mais pas en mode UEFI. D'ailleurs sur ton SSD tu as une partition de 500 Mo pour les fichiers efi.

Pour s'en assurer, tu boot en mode-live et tu fais un boot-info (voir la doc).

Si il vaut mieux installer ubuntu sur le ssd, il te reste 170 Go de libre, t'as de quoi tailler dedans mais c'est selon ton usage.

Quand à la swap, avec 12Go de ram tu n'en n'aurais pas besoin.

Commence par le boot-info.


Gaulois Matter !

Hors ligne

#3 Le 06/02/2016, à 22:13

pryzm

Re : Installation Ubuntu 14.04 (Dual Boot Win10) UEFI ?

Merci lucmars de ta réponse.

J'ai tenté d'effectuer un boot-info avec le LiveUSB Ubuntu avec ce tutoriel : https://doc.ubuntu-fr.org/tutoriel/boot-info. Cependant, même en étant connecté en Ethernet, le LiveUSB n'est pas connecté à Internet... Impossible donc de faire la première méthode du tuto.
Le lancement du LiveUSB n'est donc apparemment que la première partie de la complexité de l'installation d'Ubuntu sur mon ordinateur... :-/

J'ai donc tenté la seconde méthode en créant un LiveUSB avec l'iso 64 bits Boot-Repair-Disk. J'ai bien réussi à faire le boot-info. Cependant, l'ordinateur ne reconnaissant pas internet non plus et étant sur un LiveUSB, il est impossible de sauvegarder ce log (même sur une autre clé USB, j'ai l'impression qu'il ne reconnait pas les autres périphérique USB type clé ou souris...). Aurais-tu une idée de comment procéder ?

Merci

Hors ligne

#4 Le 07/02/2016, à 08:06

pryzm

Re : Installation Ubuntu 14.04 (Dual Boot Win10) UEFI ?

Après de nouveaux essais, je suis quand même parvenu à créer une liveUSB Ubuntu réellement persistante avec le logiciel Universal USB Installer de Pendrivelinux sous Windows (la liveUSB creée précédemment avec usb-creator sous Ubuntu n'était pas persistante même si l'option avait été choisie...).

J'ai donc pu, à l'aide d'un second PC sur lequel ethernet est reconnu, installer boot-info sur le liveUSB, redémarrer dessus avec l'Alienware et et le lancer dessus (puisque persistent). Voici le log (le disk de 16 Go étant la clé liveUSB) :

 Boot Info Script e7fc706 + Boot-Repair extra info      [Boot-Info 9Feb2015]


============================= Boot Info Summary: ===============================

 => No boot loader is installed in the MBR of /dev/sda.
 => Syslinux MBR (4.04 and higher) is installed in the MBR of /dev/sdb.

sda1: __________________________________________________________________________

    File system:       
    Boot sector type:  -
    Boot sector info: 
    Mounting failed:   mount: unknown filesystem type ''

sda2: __________________________________________________________________________

    File system:       ntfs
    Boot sector type:  Windows 8/2012: NTFS
    Boot sector info:  No errors found in the Boot Parameter Block.
    Operating System:  
    Boot files:        

sdb1: __________________________________________________________________________

    File system:       vfat
    Boot sector type:  SYSLINUX 4.07 2013-07-25
    Boot sector info:  Syslinux looks at sector 59002 of /dev/sdb1 for its 
                       second stage. SYSLINUX is installed in the /uui 
                       directory. No errors found in the Boot Parameter Block.
    Operating System:  
    Boot files:        /boot/grub/grub.cfg /casper/vmlinuz.efi 
                       /EFI/BOOT/grubx64.efi

============================ Drive/Partition Info: =============================

Drive: sda _____________________________________________________________________

Disk /dev/sda: 1000.2 GB, 1000204886016 bytes
256 heads, 63 sectors/track, 121126 cylinders, total 1953525168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes

Partition  Boot  Start Sector    End Sector  # of Sectors  Id System

/dev/sda1                   1 4,294,967,295 4,294,967,295  ee GPT

/dev/sda1 ends after the last sector of /dev/sda

GUID Partition Table detected.

Partition    Start Sector    End Sector  # of Sectors System
/dev/sda1           2,048       264,191       262,144 Microsoft Reserved Partition (Windows)
/dev/sda2         264,192 1,892,083,711 1,891,819,520 Data partition (Windows/Linux)

Drive: sdb _____________________________________________________________________

Disk /dev/sdb: 15.5 GB, 15482298368 bytes
64 heads, 32 sectors/track, 14765 cylinders, total 30238864 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes

Partition  Boot  Start Sector    End Sector  # of Sectors  Id System

/dev/sdb1    *             32    30,238,719    30,238,688   c W95 FAT32 (LBA)


"blkid" output: ________________________________________________________________

Device           UUID                                   TYPE       LABEL

/dev/loop0       5dae763a-2a5a-de46-a700-5479bd62c804   ext2       casper-rw
/dev/loop1                                              squashfs   
/dev/sda2        7630F46230F42AAF                       ntfs       DATA
/dev/sdb1        0CFF-342E                              vfat       UUI

========================= "ls -l /dev/disk/by-id" output: ======================

total 0
lrwxrwxrwx 1 root root  9 Feb  7 06:25 ata-HGST_HTS721010A9E630_JR10004M0RX2HF -> ../../sda
lrwxrwxrwx 1 root root 10 Feb  7 06:24 ata-HGST_HTS721010A9E630_JR10004M0RX2HF-part1 -> ../../sda1
lrwxrwxrwx 1 root root 10 Feb  7 06:27 ata-HGST_HTS721010A9E630_JR10004M0RX2HF-part2 -> ../../sda2
lrwxrwxrwx 1 root root  9 Feb  7 06:25 usb-UDISK_PDU09_16G_A6I2.0_785745438aa018-0:0 -> ../../sdb
lrwxrwxrwx 1 root root 10 Feb  7 06:24 usb-UDISK_PDU09_16G_A6I2.0_785745438aa018-0:0-part1 -> ../../sdb1
lrwxrwxrwx 1 root root  9 Feb  7 06:25 wwn-0x5000cca8a8ca6993 -> ../../sda
lrwxrwxrwx 1 root root 10 Feb  7 06:24 wwn-0x5000cca8a8ca6993-part1 -> ../../sda1
lrwxrwxrwx 1 root root 10 Feb  7 06:27 wwn-0x5000cca8a8ca6993-part2 -> ../../sda2

================================ Mount points: =================================

Device           Mount_Point              Type       Options

/dev/loop1       /rofs                    squashfs   (ro,noatime)
/dev/sdb1        /cdrom                   vfat       (rw,noatime,fmask=0022,dmask=0022,codepage=437,iocharset=iso8859-1,shortname=mixed,errors=remount-ro)


=========================== sdb1/boot/grub/grub.cfg: ===========================

--------------------------------------------------------------------------------

if loadfont /boot/grub/font.pf2 ; then
	set gfxmode=auto
	insmod efi_gop
	insmod efi_uga
	insmod gfxterm
	terminal_output gfxterm
fi

set menu_color_normal=white/black
set menu_color_highlight=black/light-gray

menuentry "Try Ubuntu without installing" {
	set gfxpayload=keep
	linux	/casper/vmlinuz.efi  file=/cdrom/preseed/ubuntu.seed cdrom-detect/try-usb=true persistent noprompt floppy.allowed_drive_mask=0 ignore_uuid boot=casper quiet splash --
	initrd	/casper/initrd.lz
}
menuentry "Install Ubuntu" {
	set gfxpayload=keep
	linux	/casper/vmlinuz.efi  file=/cdrom/preseed/ubuntu.seed cdrom-detect/try-usb=true persistent noprompt floppy.allowed_drive_mask=0 ignore_uuid boot=casper only-ubiquity quiet splash --
	initrd	/casper/initrd.lz
}
menuentry "OEM install (for manufacturers)" {
	set gfxpayload=keep
	linux	/casper/vmlinuz.efi  file=/cdrom/preseed/ubuntu.seed cdrom-detect/try-usb=true persistent noprompt floppy.allowed_drive_mask=0 ignore_uuid boot=casper only-ubiquity quiet splash oem-config/enable=true --
	initrd	/casper/initrd.lz
}
menuentry "Check disc for defects" {
	set gfxpayload=keep
	linux	/casper/vmlinuz.efi  cdrom-detect/try-usb=true persistent noprompt floppy.allowed_drive_mask=0 ignore_uuid boot=casper integrity-check quiet splash --
	initrd	/casper/initrd.lz
}
--------------------------------------------------------------------------------

=============================== StdErr Messages: ===============================

File descriptor 9 (/proc/4072/mounts) leaked on lvs invocation. Parent PID 9088: bash
File descriptor 63 (pipe:[28412]) leaked on lvs invocation. Parent PID 9088: bash
  No volume groups found

ADDITIONAL INFORMATION :
=================== log of boot-info 2016-02-07__06h25 ===================
boot-info version : 4ppa35
boot-sav version : 4ppa35
glade2script version : 3.2.2~ppa47~saucy
boot-sav-extra version : 4ppa35
boot-info is executed in live-session (Ubuntu 14.04.3 LTS, trusty, Ubuntu, x86_64)
CPU op-mode(s):        32-bit, 64-bit
BOOT_IMAGE=/casper/vmlinuz.efi file=/cdrom/preseed/ubuntu.seed cdrom-detect/try-usb=true persistent noprompt floppy.allowed_drive_mask=0 ignore_uuid boot=casper quiet splash --
ls: cannot access /home/usr/.config: No such file or directory

WARNING: GPT (GUID Partition Table) detected on '/dev/sda'! The util fdisk doesn't support GPT. Use GNU Parted.


=================== os-prober:


=================== blkid:
/dev/loop0: LABEL="casper-rw" UUID="5dae763a-2a5a-de46-a700-5479bd62c804" TYPE="ext2"
/dev/loop1: TYPE="squashfs"
/dev/sda2: LABEL="DATA" UUID="7630F46230F42AAF" TYPE="ntfs"
/dev/sdb1: LABEL="UUI" UUID="0CFF-342E" TYPE="vfat"


WARNING: GPT (GUID Partition Table) detected on '/dev/sda'! The util sfdisk doesn't support GPT. Use GNU Parted.


WARNING: GPT (GUID Partition Table) detected on '/dev/sda'! The util fdisk doesn't support GPT. Use GNU Parted.


=================== efibootmgr -v
BootCurrent: 1005
Timeout: 0 seconds
BootOrder: 0000,0003,0004,1005
Boot0000* Windows Boot Manager	HD(1,800,fa000,39e3883c-0eda-4308-988c-3e5ceda6f3e6)File(EFIMicrosoftBootbootmgfw.efi)WINDOWS.........x...B.C.D.O.B.J.E.C.T.=.{.9.d.e.a.8.6.2.c.-.5.c.d.d.-.4.e.7.0.-.a.c.c.1.-.f.3.2.b.3.4.4.d.4.7.9.5.}....................
Boot0003* Onboard NIC (IPV4)	ACPI(a0341d0,0)PCI(1c,4)PCI(0,0)MAC(f8cab8531c89,0)IPv4(0.0.0.0:0<->0.0.0.0:0,0, 0..BO
Boot0004* Onboard NIC (IPV6)	ACPI(a0341d0,0)PCI(1c,4)PCI(0,0)MAC(f8cab8531c89,0)030d3c000000000000000000000000000000000000000000000000000000000000000000000000000000004000000000000000000000000000000000..BO

=================== UEFI/Legacy mode:
BIOS is EFI-compatible, and is setup in EFI-mode for this live-session.
SecureBoot enabled.


=================== PARTITIONS & DISKS:
sda2	: sda,	not-sepboot,	no-grubenv	nogrub,	no-docgrub,	no-update-grub,	32,	no-boot,	no-os,	not--efi--part,	part-has-no-fstab,	part-has-no-fstab,	no-nt,	no-winload,	no-recov-nor-hid,	no-bmgr,	notwinboot,	nopakmgr,	nogrubinstall,	no---usr,	part-has-no-fstab,	not-sep-usr,	standard,	farbios,	/mnt/boot-sav/sda2.

sda	: GPT,	no-BIOS_boot,	has-no-EFIpart, 	not-usb,	no-os,	2048 sectors * 512 bytes


=================== parted -l:

Model: ATA HGST HTS721010A9 (scsi)
Disk /dev/sda: 1000GB
Sector size (logical/physical): 512B/4096B
Partition Table: gpt

Number  Start   End    Size   File system  Name                          Flags
1      1049kB  135MB  134MB               Microsoft reserved partition  msftres
2      135MB   969GB  969GB  ntfs         Basic data partition          msftdata


Model: UDISK PDU09_16G A6I2.0 (scsi)
Disk /dev/sdb: 15.5GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos

Number  Start   End     Size    Type     File system  Flags
1      16.4kB  15.5GB  15.5GB  primary  fat32        boot, lba

=================== parted -lm:

BYT;
/dev/sda:1000GB:scsi:512:4096:gpt:ATA HGST HTS721010A9;
1:1049kB:135MB:134MB::Microsoft reserved partition:msftres;
2:135MB:969GB:969GB:ntfs:Basic data partition:msftdata;

BYT;
/dev/sdb:15.5GB:scsi:512:512:msdos:UDISK PDU09_16G A6I2.0;
1:16.4kB:15.5GB:15.5GB:fat32::boot, lba;

=================== lsblk:
KNAME TYPE FSTYPE     SIZE LABEL
sda   disk          931.5G
sda1  part            128M
sda2  part ntfs     902.1G DATA
sdb   disk           14.4G
sdb1  part vfat      14.4G UUI
loop0 loop ext2         2G casper-rw
loop1 loop squashfs 962.1M

KNAME ROTA RO RM STATE   MOUNTPOINT
sda      1  0  0 running
sda1     1  0  0
sda2     1  0  0         /mnt/boot-sav/sda2
sdb      1  0  1 running
sdb1     1  0  1         /cdrom
loop0    1  0  0
loop1    1  0  0         /rofs


=================== mount:
/cow on / type overlay (rw)
proc on /proc type proc (rw,noexec,nosuid,nodev)
sysfs on /sys type sysfs (rw,noexec,nosuid,nodev)
udev on /dev type devtmpfs (rw,mode=0755)
devpts on /dev/pts type devpts (rw,noexec,nosuid,gid=5,mode=0620)
tmpfs on /run type tmpfs (rw,noexec,nosuid,size=10%,mode=0755)
/dev/sdb1 on /cdrom type vfat (rw,noatime,fmask=0022,dmask=0022,codepage=437,iocharset=iso8859-1,shortname=mixed,errors=remount-ro)
/dev/loop1 on /rofs type squashfs (ro,noatime)
none on /sys/fs/cgroup type tmpfs (rw)
none on /sys/fs/fuse/connections type fusectl (rw)
none on /sys/kernel/debug type debugfs (rw)
none on /sys/kernel/security type securityfs (rw)
none on /sys/firmware/efi/efivars type efivarfs (rw)
tmpfs on /tmp type tmpfs (rw,nosuid,nodev)
none on /run/lock type tmpfs (rw,noexec,nosuid,nodev,size=5242880)
none on /run/shm type tmpfs (rw,nosuid,nodev)
none on /run/user type tmpfs (rw,noexec,nosuid,nodev,size=104857600,mode=0755)
none on /sys/fs/pstore type pstore (rw)
systemd on /sys/fs/cgroup/systemd type cgroup (rw,noexec,nosuid,nodev,none,name=systemd)
gvfsd-fuse on /run/user/999/gvfs type fuse.gvfsd-fuse (rw,nosuid,nodev,user=ubuntu)
/dev/sda2 on /mnt/boot-sav/sda2 type fuseblk (rw,nosuid,nodev,allow_other,blksize=4096)


=================== ls:
/sys/block/sda (filtered):  alignment_offset bdi capability dev device discard_alignment events events_async events_poll_msecs ext_range holders inflight power queue range removable ro sda1 sda2 size slaves stat subsystem trace uevent
/sys/block/sdb (filtered):  alignment_offset bdi capability dev device discard_alignment events events_async events_poll_msecs ext_range holders inflight power queue range removable ro sdb1 size slaves stat subsystem trace uevent
/dev (filtered):  autofs block bsg btrfs-control bus char console core cpu cpu_dma_latency cuse disk dri ecryptfs fb0 fd full fuse hidraw0 hpet i2c-0 i2c-1 i2c-2 i2c-3 i2c-4 i2c-5 i2c-6 i2c-7 input kmsg kvm log mapper mcelog media0 mem memory_bandwidth net network_latency network_throughput null port ppp psaux ptmx pts random rfkill rtc rtc0 sda sda1 sda2 sdb sdb1 sg0 sg1 shm snapshot snd stderr stdin stdout uhid uinput urandom usb v4l vfio vga_arbiter vhci vhost-net video0 zero
ls /dev/mapper:  control

=================== hexdump -n512 -C /dev/sda2
00000000  eb 52 90 4e 54 46 53 20  20 20 20 00 02 08 00 00  |.R.NTFS    .....|
00000010  00 00 00 00 00 f8 00 00  3f 00 ff 00 00 08 04 00  |........?.......|
00000020  00 00 00 00 80 00 80 00  ff df c2 70 00 00 00 00  |...........p....|
00000030  00 00 0c 00 00 00 00 00  02 00 00 00 00 00 00 00  |................|
00000040  f6 00 00 00 01 00 00 00  af 2a f4 30 62 f4 30 76  |.........*.0b.0v|
00000050  00 00 00 00 fa 33 c0 8e  d0 bc 00 7c fb 68 c0 07  |.....3.....|.h..|
00000060  1f 1e 68 66 00 cb 88 16  0e 00 66 81 3e 03 00 4e  |..hf......f.>..N|
00000070  54 46 53 75 15 b4 41 bb  aa 55 cd 13 72 0c 81 fb  |TFSu..A..U..r...|
00000080  55 aa 75 06 f7 c1 01 00  75 03 e9 dd 00 1e 83 ec  |U.u.....u.......|
00000090  18 68 1a 00 b4 48 8a 16  0e 00 8b f4 16 1f cd 13  |.h...H..........|
000000a0  9f 83 c4 18 9e 58 1f 72  e1 3b 06 0b 00 75 db a3  |.....X.r.;...u..|
000000b0  0f 00 c1 2e 0f 00 04 1e  5a 33 db b9 00 20 2b c8  |........Z3... +.|
000000c0  66 ff 06 11 00 03 16 0f  00 8e c2 ff 06 16 00 e8  |f...............|
000000d0  4b 00 2b c8 77 ef b8 00  bb cd 1a 66 23 c0 75 2d  |K.+.w......f#.u-|
000000e0  66 81 fb 54 43 50 41 75  24 81 f9 02 01 72 1e 16  |f..TCPAu$....r..|
000000f0  68 07 bb 16 68 52 11 16  68 09 00 66 53 66 53 66  |h...hR..h..fSfSf|
00000100  55 16 16 16 68 b8 01 66  61 0e 07 cd 1a 33 c0 bf  |U...h..fa....3..|
00000110  0a 13 b9 f6 0c fc f3 aa  e9 fe 01 90 90 66 60 1e  |.............f`.|
00000120  06 66 a1 11 00 66 03 06  1c 00 1e 66 68 00 00 00  |.f...f.....fh...|
00000130  00 66 50 06 53 68 01 00  68 10 00 b4 42 8a 16 0e  |.fP.Sh..h...B...|
00000140  00 16 1f 8b f4 cd 13 66  59 5b 5a 66 59 66 59 1f  |.......fY[ZfYfY.|
00000150  0f 82 16 00 66 ff 06 11  00 03 16 0f 00 8e c2 ff  |....f...........|
00000160  0e 16 00 75 bc 07 1f 66  61 c3 a1 f6 01 e8 09 00  |...u...fa.......|
00000170  a1 fa 01 e8 03 00 f4 eb  fd 8b f0 ac 3c 00 74 09  |............<.t.|
00000180  b4 0e bb 07 00 cd 10 eb  f2 c3 0d 0a 41 20 64 69  |............A di|
00000190  73 6b 20 72 65 61 64 20  65 72 72 6f 72 20 6f 63  |sk read error oc|
000001a0  63 75 72 72 65 64 00 0d  0a 42 4f 4f 54 4d 47 52  |curred...BOOTMGR|
000001b0  20 69 73 20 63 6f 6d 70  72 65 73 73 65 64 00 0d  | is compressed..|
000001c0  0a 50 72 65 73 73 20 43  74 72 6c 2b 41 6c 74 2b  |.Press Ctrl+Alt+|
000001d0  44 65 6c 20 74 6f 20 72  65 73 74 61 72 74 0d 0a  |Del to restart..|
000001e0  00 00 00 00 00 00 00 00  00 00 00 00 00 00 00 00  |................|
000001f0  00 00 00 00 00 00 8a 01  a7 01 bf 01 00 00 55 aa  |..............U.|
00000200

WARNING: GPT (GUID Partition Table) detected on '/dev/sda'! The util fdisk doesn't support GPT. Use GNU Parted.


=================== df -Th:

Filesystem     Type      Size  Used Avail Use% Mounted on
/cow           overlay   2.0G  338M  1.6G  18% /
udev           devtmpfs  5.9G   12K  5.9G   1% /dev
tmpfs          tmpfs     1.2G  1.6M  1.2G   1% /run
/dev/sdb1      vfat       15G  3.0G   12G  21% /cdrom
/dev/loop1     squashfs  963M  963M     0 100% /rofs
none           tmpfs     4.0K     0  4.0K   0% /sys/fs/cgroup
tmpfs          tmpfs     5.9G   32K  5.9G   1% /tmp
none           tmpfs     5.0M     0  5.0M   0% /run/lock
none           tmpfs     5.9G   76K  5.9G   1% /run/shm
none           tmpfs     100M   32K  100M   1% /run/user
/dev/sda2      fuseblk   903G   86G  818G  10% /mnt/boot-sav/sda2

=================== fdisk -l:

Disk /dev/sda: 1000.2 GB, 1000204886016 bytes
256 heads, 63 sectors/track, 121126 cylinders, total 1953525168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disk identifier: 0xa2f4f0e7

Device Boot      Start         End      Blocks   Id  System
/dev/sda1               1  4294967295  2147483647+  ee  GPT
Partition 1 does not start on physical sector boundary.

Disk /dev/sdb: 15.5 GB, 15482298368 bytes
64 heads, 32 sectors/track, 14765 cylinders, total 30238864 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disk identifier: 0x0002492b

Device Boot      Start         End      Blocks   Id  System
/dev/sdb1   *          32    30238719    15119344    c  W95 FAT32 (LBA)


No OS or WinEFI system
gui-tab-other.sh: line 94: _checkbutton_repairfilesystems: command not found


=================== Suggested repair
The default repair of the Boot-Repair utility would not act on the MBR.
Additional repair would be performed:  repair-filesystems


=================== User settings
The settings chosen by the user will not act on the boot.

Quelles sont les lignes intéressantes dans ce log et comment puis-je donc installer Ubuntu sur ma machine ?

--

J'ai également tenté d'activer le wifi en liveUSB avec ce tuto. Malgré la bonne installation du package et après reboot, le wifi ne fonctionne toujours pas.
Voici ce que donne la commande

sudo lshw -class network

:

ubuntu@ubuntu:~$ sudo lshw -class network
  *-network UNCLAIMED     
       description: Ethernet controller
       product: Qualcomm Atheros
       vendor: Qualcomm Atheros
       physical id: 0
       bus info: pci@0000:3b:00.0
       version: 10
       width: 64 bits
       clock: 33MHz
       capabilities: pm pciexpress msi msix bus_master cap_list
       configuration: latency=0
       resources: memory:dd300000-dd33ffff ioport:d000(size=128)
  *-network UNCLAIMED
       description: Network controller
       product: Wireless 8260
       vendor: Intel Corporation
       physical id: 0
       bus info: pci@0000:3c:00.0
       version: 3a
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress cap_list
       configuration: latency=0
       resources: memory:dd200000-dd201fff

Mais peut-être que ce problème vient du fait que l'installation se fasse sur une liveUSB ?

Merci d'avance de ta réponse,

Pryzm.

Hors ligne

#5 Le 07/02/2016, à 14:57

lucmars

Re : Installation Ubuntu 14.04 (Dual Boot Win10) UEFI ?

Bon, il y a deux problèmes.

D'abord il semble que ta carte ethernet et ton wifi ne soient pas reconnu par ubuntu, on ne voit aucun nom de pilote dans le résultat de ta commande lshw.

Dis-toi que si cela ne marche pas en live, cela ne marchera pas plus après l'installation.

Tu as donc bien fait de faire une clef persistante, pour y installer les pilotes qui vont bien (si ils existent). Autrement, il n'y aurait aucun interet à faire un dual-boot.

Second problème, mineur: ton boot-info ne voit que le HD, pas ton SSD. Tu trouveras des cas similaire dans cette section, avec des solutions.

Cela peut venir de verrouillage à désactiver dans le bios, comme tu le sais ; mais aussi du fait que Windows n'est pas totalement à l'arrêt.

Maintenant des choses à lire du boot-info :

=================== UEFI/Legacy mode:
BIOS is EFI-compatible, and is setup in EFI-mode for this live-session.
SecureBoot enabled.

Tu peux voir que Secureboot est activé. Il te faudra peut-être désactivé aussi le Fastboot. De là peut-être ton SSD sera visible.

Autre chose encore

=================== parted -l:

Model: ATA HGST HTS721010A9 (scsi)
Disk /dev/sda: 1000GB
Sector size (logical/physical): 512B/4096B
Partition Table: gpt

Number  Start   End    Size   File system  Name                          Flags
1      1049kB  135MB  134MB               Microsoft reserved partition  msftres
2      135MB   969GB  969GB  ntfs         Basic data partition          msftdata

Ton HD a une table de partition dite gpt c'est-à-dire compatible UEFI.


Gaulois Matter !

Hors ligne

#6 Le 07/02/2016, à 15:47

malbo

Re : Installation Ubuntu 14.04 (Dual Boot Win10) UEFI ?

Sur cette page qui concerne ton modèle Alienware 15 R2, je lis cette info sur ton SSD :

Storage : Samsung PM951 NVMe MZ-VLV256D, 256 GB 

Il se trouve qu'il y a quelques cas d'utilisation de SSD Samsung de cette référence "MZ-VLV..." sur le forum et il en ressort que Ubuntu ne sait pas détecter les SSD de cette référence. Exemple ici et . Je ne sais pas s'il existe une solution pour l'instant .

Dernière modification par malbo (Le 07/02/2016, à 15:48)

Hors ligne

#7 Le 07/02/2016, à 16:29

pryzm

Re : Installation Ubuntu 14.04 (Dual Boot Win10) UEFI ?

Merci de vos réponses.

Effectivement, même après avoir désactivé le "Secure Boot" (là où Windows ne veut plus démarrer) et en bootant sur le liveUSB pour faire un boot-info, le disque SSD n'est toujours pas visible (ce qui confirme ce que dit malbo).

De ce que je comprend, il est donc très difficile (voir quasi impossible xD) de faire un DualBoot Win10/Ubuntu sur le SSD de ma machine :-(.

Je vois donc plusieurs solutions possibles, vous allez me dire si c'est possible ou non :
- Supprimer Windows 10 installé en UEFI (oui c'est radical ^^) et réinstaller un Windows 7 (ou 10 si j'arrive à récupérer la clé OEM) en mode BIOS sur le SSD. Ubuntu sera également installé en mode BIOS, ainsi, peut-être que ça sera possible ? Dans le cas où c'est vraiment le type SSD du disque qui n'est pas reconnu, cela ne fonctionnera pas...
- Ma deuxième option est donc : est-il possible de conserver Win10 UEFI sur le SSD et installer Ubuntu sur le HD (puisqu'il ne reconnait que ce disque) et de faire un dualboot ? Dans ce cas, je ne sais pas du tout s'il faut conserver le boot Windows ou installer GRUB (et si oui, où l'installer ?)

Ces deux solutions ne fonctionnent uniquement si j'arrive à trouver un moyen d'installer des pilotes Wifi/Ethernet sous Ubuntu (et c'est pas gagné...)

Qu'en pensez-vous ?

Je trouverai ça vraiment dommage d'avoir un PC puissant pour jouer et d'être obligé d'utiliser un autre PC pour coder... x)

Hors ligne

#8 Le 07/02/2016, à 16:53

lucmars

Re : Installation Ubuntu 14.04 (Dual Boot Win10) UEFI ?

Pour un dual-boot, il ne reste que ton HD.

Mais l'inconvenient de ce genre de dual-boot est qu'il te faudra passer par le bios pour choisir l'os à lancer. (si ton bios le veut bien par ailleurs)

Une autre solution serait d'attendre la 1604: avec un peu de chance tu auras un support wifi/ethernet ainsi que de ton ssd.


Gaulois Matter !

Hors ligne

#9 Le 07/02/2016, à 16:56

pryzm

Re : Installation Ubuntu 14.04 (Dual Boot Win10) UEFI ?

Merci du conseil, je vais attendre la v16.04 en espérant que cela fonctionne ! smile

Hors ligne