Contenu | Rechercher | Menus

Annonce

T-shirt Disco Dingo : Série limitée

Ubuntu 19.04
T-shirt Ubuntu-FR « Disco Dingo » en série limitée !
Prix spécial pré-vente (15€) jusqu'au 21 avril 2019.

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 14/05/2016, à 15:55

laurent76

[résolu] Bluetooth up mais ne détecte aucun périphérique (et pas vu)

Bonjour à tous


Je lis souvent les infos du forum pour résoudre les petits (et gros) tracas avec succès, sauf que là je sèche vraiment depuis un moment
Le problème : le Bluetooth est up mais ne détecte aucun périphérique (et n'est pas vu)

Contexte : Ubuntu 16.04 64bits sur PC portable HP Envy 13 (13-d003nf)
Pilote alternatif activé (mais même problème quand l'alternatif est désactivé).
L'installation 16.04 est toute neuve (réinstall from scratch) mais j'avais le même soucis avec Ubuntu 15.10 64bits
Les périphériques bluetooth "testés" : téléphone android 5, récepteur audio belkin, souris microsoft, enceinte bose

J'ai donc épuisé de nombreux fils dont sur le forum :
-> RESOLU PC Acer ne détecte pas les périphériques bluetooth (https://forum.ubuntu-fr.org/viewtopic.php?id=1989633) ... en fait c'est un contournement puisque la solution c'est d'utiliser un cordon audio
-> Bluetooth ne détecte aucun appareil (https://forum.ubuntu-fr.org/viewtopic.php?id=1926291)
donc j'ai l'impression que sans être un problème généralisée, je ne suis pas le seul à rencontrer ce dysfonctionnement.


Quelques infos :

laurent@ENVY:~$ lspci
00:00.0 Host bridge: Intel Corporation Sky Lake Host Bridge/DRAM Registers (rev 08)
00:02.0 VGA compatible controller: Intel Corporation Sky Lake Integrated Graphics (rev 07)
00:04.0 Signal processing controller: Intel Corporation Skylake Processor Thermal Subsystem (rev 08)
00:14.0 USB controller: Intel Corporation Sunrise Point-LP USB 3.0 xHCI Controller (rev 21)
00:14.2 Signal processing controller: Intel Corporation Sunrise Point-LP Thermal subsystem (rev 21)
00:15.0 Signal processing controller: Intel Corporation Sunrise Point-LP Serial IO I2C Controller (rev 21)
00:15.1 Signal processing controller: Intel Corporation Sunrise Point-LP Serial IO I2C Controller (rev 21)
00:16.0 Communication controller: Intel Corporation Sunrise Point-LP CSME HECI (rev 21)
00:17.0 SATA controller: Intel Corporation Sunrise Point-LP SATA Controller [AHCI mode] (rev 21)
00:1c.0 PCI bridge: Intel Corporation Sunrise Point-LP PCI Express Root Port (rev f1)
00:1d.0 PCI bridge: Intel Corporation Device 9d18 (rev f1)
00:1f.0 ISA bridge: Intel Corporation Sunrise Point-LP LPC Controller (rev 21)
00:1f.2 Memory controller: Intel Corporation Sunrise Point-LP PMC (rev 21)
00:1f.3 Audio device: Intel Corporation Sunrise Point-LP HD Audio (rev 21)
00:1f.4 SMBus: Intel Corporation Sunrise Point-LP SMBus (rev 21)
01:00.0 Network controller: Broadcom Corporation BCM43142 802.11b/g/n (rev 01)
02:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. RTS522A PCI Express Card Reader (rev 01)
laurent@ENVY:~$ hciconfig
hci0:	Type: BR/EDR  Bus: USB
	BD Address: 60:6D:C7:D4:CA:F6  ACL MTU: 1021:8  SCO MTU: 64:1
	UP RUNNING PSCAN ISCAN 
	RX bytes:9124 acl:0 sco:0 events:1187 errors:0
	TX bytes:13137 acl:0 sco:0 commands:1024 errors:0

laurent@ENVY:~$ hciconfig -a
hci0:	Type: BR/EDR  Bus: USB
	BD Address: 60:6D:C7:D4:CA:F6  ACL MTU: 1021:8  SCO MTU: 64:1
	UP RUNNING PSCAN ISCAN 
	RX bytes:9124 acl:0 sco:0 events:1187 errors:0
	TX bytes:13137 acl:0 sco:0 commands:1024 errors:0
	Features: 0xff 0xfe 0xcf 0xfe 0xdb 0xff 0x7b 0x87
	Packet type: DM1 DM3 DM5 DH1 DH3 DH5 HV1 HV2 HV3 
	Link policy: RSWITCH HOLD SNIFF 
	Link mode: SLAVE ACCEPT 
	Name: 'ENVY'
	Class: 0x2c010c
	Service Classes: Rendering, Capturing, Audio
	Device Class: Computer, Laptop
	HCI Version: 4.0 (0x6)  Revision: 0x0
	LMP Version: 4.0 (0x6)  Subversion: 0x210b
	Manufacturer: Broadcom Corporation (15)

laurent@ENVY:~$ rfkill unblock bluetooth && rfkill list bluetooth
0: hci0: Bluetooth
	Soft blocked: no
	Hard blocked: no

laurent@ENVY:~$ uname -r -m
4.4.0-22-generic x86_64

laurent@ENVY:~$ dpkg -l | grep -Ei "linux-(g|h|i|lo|si|t)"
ii  linux-generic                                               4.4.0.22.23                                         amd64        Complete Generic Linux kernel and headers
ii  linux-headers-4.4.0-21                                      4.4.0-21.37                                         all          Header files related to Linux kernel version 4.4.0
ii  linux-headers-4.4.0-21-generic                              4.4.0-21.37                                         amd64        Linux kernel headers for version 4.4.0 on 64 bit x86 SMP
ii  linux-headers-4.4.0-22                                      4.4.0-22.39                                         all          Header files related to Linux kernel version 4.4.0
ii  linux-headers-4.4.0-22-generic                              4.4.0-22.39                                         amd64        Linux kernel headers for version 4.4.0 on 64 bit x86 SMP
ii  linux-headers-generic                                       4.4.0.22.23                                         amd64        Generic Linux kernel headers
ii  linux-image-4.4.0-21-generic                                4.4.0-21.37                                         amd64        Linux kernel image for version 4.4.0 on 64 bit x86 SMP
ii  linux-image-4.4.0-22-generic                                4.4.0-22.39                                         amd64        Linux kernel image for version 4.4.0 on 64 bit x86 SMP
ii  linux-image-extra-4.4.0-21-generic                          4.4.0-21.37                                         amd64        Linux kernel extra modules for version 4.4.0 on 64 bit x86 SMP
ii  linux-image-extra-4.4.0-22-generic                          4.4.0-22.39                                         amd64        Linux kernel extra modules for version 4.4.0 on 64 bit x86 SMP
ii  linux-image-generic                                         4.4.0.22.23                                         amd64        Generic Linux kernel image
ii  linux-signed-generic                                        4.4.0.22.23                                         amd64        Complete Signed Generic Linux kernel and headers
ii  linux-signed-image-4.4.0-21-generic                         4.4.0-21.37                                         amd64        Signed kernel image generic
ii  linux-signed-image-4.4.0-22-generic                         4.4.0-22.39                                         amd64        Signed kernel image generic
ii  linux-signed-image-generic                                  4.4.0.22.23                                         amd64        Signed Generic Linux kernel image

Le symptome est bien que ubuntu ne "voit" rien : ni via l'interface graphique ni en CLI.
Exemple ci-dessous avec hcitool, ça mouline 5s et puis rend la main sans rien indiquer.

laurent@ENVY:~$ hcitool inq
Inquiring ...

laurent@ENVY:~$ hcitool scan
Scanning ...

évidement, j'ai fait le reset de l'adaptateur bluetooth à plusieurs reprises

sudo hciconfig hci0 reset

et j'ai redémarré le deamon bluetooth ... sans succès
Je passe sur les tentatives avec blueman, connman, ...
Côté WIFI : pas de soucis cela fonctionne bien


Une idée / des conseils ?!


A noter : je pense essayer à l'occasion une autre distribution (Debian, Mint ...) pour voir si cela fonctionne en dehors d'Ubuntu

Merci

Dernière modification par laurent76 (Le 28/05/2016, à 17:25)

Hors ligne

#2 Le 14/05/2016, à 17:56

xubu1957

Re : [résolu] Bluetooth up mais ne détecte aucun périphérique (et pas vu)

Bonjour,

Et cette discussion : forum.ubuntu-fr.org/viewtopic.php?id=1988558 avec au # 6 la solution de jajax validée au # 7 par Doug2109 .


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 18.04.1 LTS - Lenovo T410 -Toshiba Satellite A300  Membre de Linux-Azur

En ligne

#3 Le 14/05/2016, à 19:16

laurent76

Re : [résolu] Bluetooth up mais ne détecte aucun périphérique (et pas vu)

Merci pour le retour
effectivement je l'avais vu et cela ne correspond par à ma situation puisque pour doug2109 le device bluetooth est vu mais n'était pas "utilisable".
dans mon "cas", aucun device bluetooth n'est vu par le système.

Hors ligne

#4 Le 14/05/2016, à 19:24

xubu1957

Re : [résolu] Bluetooth up mais ne détecte aucun périphérique (et pas vu)

Bug actuel sur la carte BCM43142 en version 16.04 : https://bugs.launchpad.net/ubuntu/+sour … ug/1572659


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 18.04.1 LTS - Lenovo T410 -Toshiba Satellite A300  Membre de Linux-Azur

En ligne

#5 Le 14/05/2016, à 20:38

laurent76

Re : [résolu] Bluetooth up mais ne détecte aucun périphérique (et pas vu)

Merci également toutefois je n'ai aucun pbm de WIFI et la commande modprobe fonctionne correctement

laurent@ENVY:~$ sudo modprobe wl
[sudo] Mot de passe de laurent : 
laurent@ENVY:~$

J'ai actuellement le noyau 4.4.0-22.39 (suite MAJ "standard" d'Ubuntu) et le bcmwl 6.30.223.248+bdcom-0ubuntu8
et surtout j'ai désactivé Secure Boot dans le "bios" à l'installation car c'est "conseillé" par Ubuntu lors de l'install

laurent@ENVY:~$ dpkg -l | grep bcmwl
ii  bcmwl-kernel-source                                         6.30.223.248+bdcom-0ubuntu8                         amd64        Broadcom 802.11 Linux STA wireless driver source

Hors ligne

#6 Le 14/05/2016, à 20:42

laurent76

Re : [résolu] Bluetooth up mais ne détecte aucun périphérique (et pas vu)

ou alors... la désactivation du secure boot enlève l'erreur, mais masque le problème... ?!

Hors ligne

#7 Le 14/05/2016, à 20:49

xubu1957

Re : [résolu] Bluetooth up mais ne détecte aucun périphérique (et pas vu)


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 18.04.1 LTS - Lenovo T410 -Toshiba Satellite A300  Membre de Linux-Azur

En ligne

#8 Le 14/05/2016, à 20:59

laurent76

Re : [résolu] Bluetooth up mais ne détecte aucun périphérique (et pas vu)

Pour le coup je n'étais pas tombé sur celui là.
Merci smile

Je regarde dans le détails, mais déjà un truc bizarre car quand je passe la commande de status j'ai un paquet d'erreur malgré un restart (et même + d'erreur après le restart) :

laurent@ENVY:~$ sudo service bluetooth status
● bluetooth.service - Bluetooth service
   Loaded: loaded (/lib/systemd/system/bluetooth.service; enabled; vendor preset: enabled)
   Active: active (running) since sam. 2016-05-14 20:18:32 CEST; 1h 37min ago
     Docs: man:bluetoothd(8)
 Main PID: 1077 (bluetoothd)
   Status: "Running"
    Tasks: 1 (limit: 512)
   CGroup: /system.slice/bluetooth.service
           └─1077 /usr/lib/bluetooth/bluetoothd
mai 14 20:18:32 ENVY bluetoothd[1077]: Not enough free handles to register service
mai 14 20:18:32 ENVY bluetoothd[1077]: Sap driver initialization failed.
mai 14 20:18:32 ENVY bluetoothd[1077]: sap-server: Operation not permitted (1)
mai 14 20:18:33 ENVY bluetoothd[1077]: Endpoint registered: sender=:1.48 path=/MediaEndpoint/A2DPSource
mai 14 20:18:33 ENVY bluetoothd[1077]: Endpoint registered: sender=:1.48 path=/MediaEndpoint/A2DPSink
mai 14 20:19:25 ENVY bluetoothd[1077]: Endpoint registered: sender=:1.78 path=/MediaEndpoint/A2DPSource
mai 14 20:19:25 ENVY bluetoothd[1077]: Endpoint registered: sender=:1.78 path=/MediaEndpoint/A2DPSink
mai 14 20:19:25 ENVY bluetoothd[1077]: RFCOMM server failed for Headset Voice gateway: rfcomm_bind: Address already in use (98)
mai 14 20:19:43 ENVY bluetoothd[1077]: Endpoint unregistered: sender=:1.48 path=/MediaEndpoint/A2DPSource
mai 14 20:19:43 ENVY bluetoothd[1077]: Endpoint unregistered: sender=:1.48 path=/MediaEndpoint/A2DPSink
laurent@ENVY:~$ 

laurent@ENVY:~$ sudo service bluetooth restart
laurent@ENVY:~$ 

laurent@ENVY:~$ sudo service bluetooth status
● bluetooth.service - Bluetooth service
   Loaded: loaded (/lib/systemd/system/bluetooth.service; enabled; vendor preset: enabled)
   Active: active (running) since sam. 2016-05-14 21:56:05 CEST; 1s ago
     Docs: man:bluetoothd(8)
 Main PID: 10977 (bluetoothd)
   Status: "Running"
    Tasks: 1 (limit: 512)
   CGroup: /system.slice/bluetooth.service
           └─10977 /usr/lib/bluetooth/bluetoothd

mai 14 21:56:05 ENVY bluetoothd[10977]: Not enough free handles to register service
mai 14 21:56:05 ENVY bluetoothd[10977]: Not enough free handles to register service
mai 14 21:56:05 ENVY bluetoothd[10977]: Current Time Service could not be registered
mai 14 21:56:05 ENVY bluetoothd[10977]: gatt-time-server: Input/output error (5)
mai 14 21:56:05 ENVY bluetoothd[10977]: Not enough free handles to register service
mai 14 21:56:05 ENVY bluetoothd[10977]: Not enough free handles to register service
mai 14 21:56:05 ENVY bluetoothd[10977]: Sap driver initialization failed.
mai 14 21:56:05 ENVY bluetoothd[10977]: sap-server: Operation not permitted (1)
mai 14 21:56:05 ENVY bluetoothd[10977]: Endpoint registered: sender=:1.78 path=/MediaEndpoint/A2DPSource
mai 14 21:56:05 ENVY bluetoothd[10977]: Endpoint registered: sender=:1.78 path=/MediaEndpoint/A2DPSink
laurent@ENVY:~$ 

Hors ligne

#9 Le 14/05/2016, à 21:23

xubu1957

Re : [résolu] Bluetooth up mais ne détecte aucun périphérique (et pas vu)

A la fin de la discussion:

I have had the same issue on a HP Stream 11 laptop. A temporary solution for my laptop is to turn aeroplane mode on and off.

A hard solution for resetting your wirless chip on start up would be to add these lines to the end of your .bashrc:

nmcli networking off 
nmcli networking on

Par désactivation du mode avion ?


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 18.04.1 LTS - Lenovo T410 -Toshiba Satellite A300  Membre de Linux-Azur

En ligne

#10 Le 15/05/2016, à 07:46

laurent76

Re : [résolu] Bluetooth up mais ne détecte aucun périphérique (et pas vu)

Par désactivation du mode avion ?

Merci pour la recherche / l'idée.
je viens de le tenter : ca interrompt bien l'autoethernet & Wifi mais ca n'a aucune conséquence sur le bluetooth... cela ne semble pas normal non-plus

Etat d'avant :

laurent@ENVY:~$ ifconfig 
enx3c18a0066917 Link encap:Ethernet  HWaddr 3c:18:a0:06:69:17  
          inet adr:192.168.1.100  Bcast:192.168.1.255  Masque:255.255.255.0
          adr inet6: fe80::b7af:1122:4484:f39d/64 Scope:Lien
          [b]UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1[/b]
          Packets reçus:8377 erreurs:0 :0 overruns:0 frame:0
          TX packets:6578 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:1000 
          Octets reçus:8556183 (8.5 MB) Octets transmis:825638 (825.6 KB)

lo        Link encap:Boucle locale  
          inet adr:127.0.0.1  Masque:255.0.0.0
          adr inet6: ::1/128 Scope:Hôte
          [b]UP LOOPBACK RUNNING  MTU:65536  Metric:1[/b]
          Packets reçus:1135 erreurs:0 :0 overruns:0 frame:0
          TX packets:1135 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:1 
          Octets reçus:95229 (95.2 KB) Octets transmis:95229 (95.2 KB)

wlp1s0    Link encap:Ethernet  HWaddr 60:6d:c7:d4:ca:f5  
          inet adr:192.168.1.101  Bcast:192.168.1.255  Masque:255.255.255.0
          adr inet6: fe80::aa2f:8165:6129:ce02/64 Scope:Lien
          [b]UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1[/b]
          Packets reçus:285 erreurs:0 :0 overruns:0 frame:2934
          TX packets:187 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:1000 
          Octets reçus:36391 (36.3 KB) Octets transmis:22647 (22.6 KB)
          Interruption:17 

laurent@ENVY:~$ hciconfig
hci0:	Type: BR/EDR  Bus: USB
	BD Address: 60:6D:C7:D4:CA:F6  ACL MTU: 1021:8  SCO MTU: 64:1
	[b]UP RUNNING PSCAN ISCAN[/b] 
	RX bytes:1302 acl:0 sco:0 events:66 errors:0
	TX bytes:3048 acl:0 sco:0 commands:63 errors:0

laurent@ENVY:~$ 

Après coupure / passage en mode avion :

laurent@ENVY:~$ nmcli networking off

laurent@ENVY:~$ ifconfig 
lo        Link encap:Boucle locale  
          inet adr:127.0.0.1  Masque:255.0.0.0
          adr inet6: ::1/128 Scope:Hôte
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          Packets reçus:1175 erreurs:0 :0 overruns:0 frame:0
          TX packets:1175 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 lg file transmission:1 
          Octets reçus:97901 (97.9 KB) Octets transmis:97901 (97.9 KB)

laurent@ENVY:~$ hciconfig
hci0:	Type: BR/EDR  Bus: USB
	BD Address: 60:6D:C7:D4:CA:F6  ACL MTU: 1021:8  SCO MTU: 64:1
	[b]UP RUNNING PSCAN ISCAN [/b]
	RX bytes:1302 acl:0 sco:0 events:66 errors:0
	TX bytes:3048 acl:0 sco:0 commands:63 errors:0

Après passage en mode "pas avion", le LAN & WIFI redeviennent UP. pas d'impact sur le Bluetooth
... et les scan/inquire ne ramènent toujours rien.

laurent@ENVY:~$ hcitool scan
Scanning ...
laurent@ENVY:~$ hcitool inq
Inquiring ...
laurent@ENVY:~$ 

Hors ligne

#11 Le 15/05/2016, à 07:52

xubu1957

Re : [résolu] Bluetooth up mais ne détecte aucun périphérique (et pas vu)

Tiens , regardes aussi ta version du flash

Hier, suite à cette discussion: forum.ubuntu-fr.org/viewtopic.php?pid=21518241#p21518241 au # 9.


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 18.04.1 LTS - Lenovo T410 -Toshiba Satellite A300  Membre de Linux-Azur

En ligne

#12 Le 15/05/2016, à 07:53

laurent76

Re : [résolu] Bluetooth up mais ne détecte aucun périphérique (et pas vu)

J'ai fait une tentative avec Linux Mint 17.3 Rosa hier soir --> exactement le même comportement. En même temps, c'est pas vraiment une surprise.
==> Je ferai un test dans la journée avec Debian 8.4.0


en parallèle, je vais installer HCIdump et voir ce que ça indique.
car je suis toujours à creuser l'info

Tu avais vu ce fil : askubuntu.com/questions/770188/ubuntu-16-04-bluetooth-adapter-doesnt-search

et il y a presque toujours des erreurs de ce type :

laurent@ENVY:~$ sudo service bluetooth status
[sudo] Mot de passe de laurent : 
● bluetooth.service - Bluetooth service
   Loaded: loaded (/lib/systemd/system/bluetooth.service; enabled; vendor preset: enabled)
   Active: active (running) since dim. 2016-05-15 08:28:00 CEST; 22min ago
     Docs: man:bluetoothd(8)
 Main PID: 1066 (bluetoothd)
   Status: "Running"
    Tasks: 1 (limit: 512)
   CGroup: /system.slice/bluetooth.service
           └─1066 /usr/lib/bluetooth/bluetoothd

mai 15 08:28:00 ENVY bluetoothd[1066]: Not enough free handles to register service
mai 15 08:28:00 ENVY bluetoothd[1066]: Sap driver initialization failed.
mai 15 08:28:00 ENVY bluetoothd[1066]: sap-server: Operation not permitted (1)
mai 15 08:28:00 ENVY bluetoothd[1066]: Endpoint registered: sender=:1.45 path=/MediaEndpoint/A2DPSource
mai 15 08:28:00 ENVY bluetoothd[1066]: Endpoint registered: sender=:1.45 path=/MediaEndpoint/A2DPSink
mai 15 08:28:12 ENVY bluetoothd[1066]: Endpoint registered: sender=:1.81 path=/MediaEndpoint/A2DPSource
mai 15 08:28:12 ENVY bluetoothd[1066]: Endpoint registered: sender=:1.81 path=/MediaEndpoint/A2DPSink
mai 15 08:28:12 ENVY bluetoothd[1066]: RFCOMM server failed for Headset Voice gateway: rfcomm_bind: Address alr
mai 15 08:28:32 ENVY bluetoothd[1066]: Endpoint unregistered: sender=:1.45 path=/MediaEndpoint/A2DPSource
mai 15 08:28:32 ENVY bluetoothd[1066]: Endpoint unregistered: sender=:1.45 path=/MediaEndpoint/A2DPSink

Hors ligne

#13 Le 15/05/2016, à 08:16

laurent76

Re : [résolu] Bluetooth up mais ne détecte aucun périphérique (et pas vu)

Côté HCIdump cela ne remonte aucune info utilisable :
il ne voit rien non-plus quand je fais des inq/scan

laurent@ENVY:~$ hcidump
HCI sniffer - Bluetooth packet analyzer ver 5.37
device: hci0 snap_len: 1500 filter: 0xffffffffffffffff
> HCI Event: Command Status (0x0f) plen 4
    Inquiry (0x01|0x0001) status 0x00 ncmd 1
> HCI Event: Inquiry Complete (0x01) plen 1
    status 0x00
> HCI Event: Command Status (0x0f) plen 4
    Inquiry (0x01|0x0001) status 0x00 ncmd 1
> HCI Event: Inquiry Complete (0x01) plen 1
    status 0x00

A la limite, le seul point étrange est que le dump indique que les mêmes ordres/commandes sont réalisés lors d'un "HCITOOL INQ" et d'un "HCITOOL SCAN"

au passage j'avais fait un reset juste avant :

laurent@ENVY:~$ hcidump
HCI sniffer - Bluetooth packet analyzer ver 5.37
device: hci0 snap_len: 1500 filter: 0xffffffffffffffff
> HCI Event: Command Complete (0x0e) plen 4
    Reset (0x03|0x0003) ncmd 1
    status 0x00
> HCI Event: Command Complete (0x0e) plen 12
    Read Local Supported Features (0x04|0x0003) ncmd 1
    status 0x00
    Features: 0xff 0xfe 0xcf 0xfe 0xdb 0xff 0x7b 0x87
> HCI Event: Command Complete (0x0e) plen 12
    Read Local Version Information (0x04|0x0001) ncmd 1
    status 0x00
    HCI Version: 4.0 (0x6) HCI Revision: 0x0
    LMP Version: 4.0 (0x6) LMP Subversion: 0x210b
    Manufacturer: Broadcom Corporation (15)
> HCI Event: Command Complete (0x0e) plen 10
    Read BD ADDR (0x04|0x0009) ncmd 1
    status 0x00 bdaddr 60:6D:C7:D4:CA:F6
> HCI Event: Command Complete (0x0e) plen 11
    Read Buffer Size (0x04|0x0005) ncmd 1
    status 0x00
    ACL MTU 1021:8 SCO MTU 64:1
> HCI Event: Command Complete (0x0e) plen 7
    Read Class of Device (0x03|0x0023) ncmd 1
    status 0x00 class 0x000000
> HCI Event: Command Complete (0x0e) plen 252
    Read Local Name (0x03|0x0014) ncmd 1
    status 0x00 name 'ENVY'
> HCI Event: Command Complete (0x0e) plen 6
    Read Voice Setting (0x03|0x0025) ncmd 1
    status 0x00 voice setting 0x0060
> HCI Event: Command Complete (0x0e) plen 5
    Read Number of Supported IAC (0x03|0x0038) ncmd 1
> HCI Event: Command Complete (0x0e) plen 8
    Read Current IAC LAP (0x03|0x0039) ncmd 1
    IAC 0x9e8b33 (General Inquiry Access Code)
> HCI Event: Command Complete (0x0e) plen 4
    Set Event Filter (0x03|0x0005) ncmd 1
    status 0x00
> HCI Event: Command Complete (0x0e) plen 4
    Write Connection Accept Timeout (0x03|0x0016) ncmd 1
    status 0x00
> HCI Event: Command Complete (0x0e) plen 7
    LE Read Buffer Size (0x08|0x0002) ncmd 1
    status 0x00 pktlen 0x001b maxpkt 0x0f
> HCI Event: Command Complete (0x0e) plen 12
    LE Read Local Supported Features (0x08|0x0003) ncmd 1
    status 0x00 features 0x0100000000000000 (Link Layer supports LE Encryption)
> HCI Event: Command Complete (0x0e) plen 12
    LE Read Supported States (0x08|0x001c) ncmd 1
> HCI Event: Command Complete (0x0e) plen 68
    Read Local Supported Commands (0x04|0x0002) ncmd 1
    status 0x00
    Commands: ffffff03ceffefffffffef1ff20fe8fe3ff78fff1c00000061f7ffff7f
> HCI Event: Command Complete (0x0e) plen 4
    Write Simple Pairing Mode (0x03|0x0056) ncmd 1
    status 0x00
> HCI Event: Command Complete (0x0e) plen 4
    Write Inquiry Mode (0x03|0x0045) ncmd 1
    status 0x00
> HCI Event: Command Complete (0x0e) plen 5
    Read Inquiry Response Transmit Power Level (0x03|0x0058) ncmd 1
    status 0x00 level 0
> HCI Event: Command Complete (0x0e) plen 14
    Read Local Extended Features (0x04|0x0004) ncmd 1
    status 0x00 page 1 max 1
    Features: 0x01 0x00 0x00 0x00 0x00 0x00 0x00 0x00
> HCI Event: Command Complete (0x0e) plen 4
    Set Event Mask (0x03|0x0001) ncmd 1
    status 0x00
> HCI Event: Command Complete (0x0e) plen 8
    Read Stored Link Key (0x03|0x000d) ncmd 1
    status 0x00 max 1 num 0
> HCI Event: Command Complete (0x0e) plen 4
    Write Default Link Policy Settings (0x02|0x000f) ncmd 1
    status 0x00
> HCI Event: Command Complete (0x0e) plen 8
    Read Page Scan Activity (0x03|0x001b) ncmd 1
    status 0x00 interval 2048 window 18
> HCI Event: Command Complete (0x0e) plen 5
    Read Page Scan Type (0x03|0x0046) ncmd 1
> HCI Event: Command Complete (0x0e) plen 4
    LE Set Event Mask (0x08|0x0001) ncmd 1
    status 0x00
> HCI Event: Command Complete (0x0e) plen 5
    LE Read Advertising Channel Tx Power (0x08|0x0007) ncmd 1
    status 0x00 level 0x4 (dBm)
> HCI Event: Command Complete (0x0e) plen 5
    LE Read White List Size (0x08|0x000f) ncmd 1
> HCI Event: Command Complete (0x0e) plen 4
    LE Clear White List (0x08|0x0010) ncmd 1
    status 0x00
> HCI Event: Command Complete (0x0e) plen 4
    Write LE Host Supported (0x03|0x006d) ncmd 1
> HCI Event: Command Complete (0x0e) plen 6
    Delete Stored Link Key (0x03|0x0012) ncmd 1
    status 0x00 deleted 0
> HCI Event: Command Complete (0x0e) plen 4
    LE Set Advertising Data (0x08|0x0008) ncmd 1
    status 0x00
> HCI Event: Command Complete (0x0e) plen 4
    LE Set Scan Response Data (0x08|0x0009) ncmd 1
    status 0x00
> HCI Event: Command Complete (0x0e) plen 4
    Write Scan Enable (0x03|0x001a) ncmd 1
    status 0x00
> HCI Event: Command Complete (0x0e) plen 4
    Write Class of Device (0x03|0x0024) ncmd 1
    status 0x00
> HCI Event: Command Complete (0x0e) plen 4
    Write Local Name (0x03|0x0013) ncmd 1
    status 0x00
> HCI Event: Command Complete (0x0e) plen 4
    Write Extended Inquiry Response (0x03|0x0052) ncmd 1
    status 0x00

Hors ligne

#14 Le 15/05/2016, à 08:18

xubu1957

Re : [résolu] Bluetooth up mais ne détecte aucun périphérique (et pas vu)

Tu avais vu le # 11 ?


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 18.04.1 LTS - Lenovo T410 -Toshiba Satellite A300  Membre de Linux-Azur

En ligne

#15 Le 15/05/2016, à 08:18

laurent76

Re : [résolu] Bluetooth up mais ne détecte aucun périphérique (et pas vu)

et... à bien y réfléchir... HCIDUMP ne réagit pas lorsque je fais une recherche bluetooth depuis mon téléphone android.
J'aurai pensé qu'il remonterait des paquests d'informations sur l'inquire/scan fait par le téléphone

Hors ligne

#16 Le 15/05/2016, à 08:19

laurent76

Re : [résolu] Bluetooth up mais ne détecte aucun périphérique (et pas vu)

Tu avais vu le # 11 ?

non, je viens de rafraichir en postant le précédent message -> j'y regarde immédiatement
Merci

Hors ligne

#17 Le 15/05/2016, à 08:30

laurent76

Re : [résolu] Bluetooth up mais ne détecte aucun périphérique (et pas vu)

Tu avais vu le # 11 ?

non, je viens de rafraichir en postant le précédent message -> j'y regarde immédiatement
Merci

J'ai bien le paquet flash installé (flashplugin-installer 11.2.202.621ubuntu0.16.04.1) mais pas de paquet relatif à shockwave

Toutefois le fil forum.ubuntu-fr.org/viewtopic.php?pid=21518241#p21518241 au # 9 ma ramène à ma condition : je n'arrive même pas à voir mes périphériques bluetooth
alors que dans ce fil les périphériques (casque...) sont bien vu mais leur utilisation provoquait des pbm.

Hors ligne

#18 Le 15/05/2016, à 08:41

xubu1957

Re : [résolu] Bluetooth up mais ne détecte aucun périphérique (et pas vu)

A priori, felixlechat a désinstallé la version 11 pour garder la dernière version 21 de flash pour faire fonctionner le bluetooth !

Quels navigateurs utilises tu ?


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 18.04.1 LTS - Lenovo T410 -Toshiba Satellite A300  Membre de Linux-Azur

En ligne

#19 Le 15/05/2016, à 08:54

laurent76

Re : [résolu] Bluetooth up mais ne détecte aucun périphérique (et pas vu)

Quels navigateurs utilises tu ?

- FireFox 46 (celui installé de base, et éventuellement mis à jour automatiquement)
- Chromium Version 49.0.2623.108 Ubuntu 16.04 (64-bit) installé via l'Ubuntu Software

Hors ligne

#20 Le 15/05/2016, à 09:10

laurent76

Re : [résolu] Bluetooth up mais ne détecte aucun périphérique (et pas vu)

J'ai creusé plusieurs posts, debian et raspberry entre-autres.

https://bugs.debian.org/cgi-bin/bugrepo … bug=803265  --> apparemment les messages d'erreurs ne seraient que des warnings "sans conséquences" ?! (#10)

https://www.raspberrypi.org/forums/view … 8&t=131999 --> j'ai appliqué la méthode indiquée "adding this flag to the ExecStart= line in bluetooth.service: '--noplugin=sap" et du coup je n'ai plus le message d'erreur "Sap driver initialization failed." ... mais il me reste tout les autres.

laurent@ENVY:~$ sudo service bluetooth status
● bluetooth.service - Bluetooth service
   Loaded: loaded (/lib/systemd/system/bluetooth.service; enabled; vendor preset: enabled)
   Active: active (running) since dim. 2016-05-15 09:55:27 CEST; 12min ago
     Docs: man:bluetoothd(8)
 Main PID: 1075 (bluetoothd)
   Status: "Running"
    Tasks: 1 (limit: 512)
   CGroup: /system.slice/bluetooth.service
           └─1075 /usr/lib/bluetooth/bluetoothd --noplugin=sap

mai 15 09:55:27 ENVY bluetoothd[1075]: gatt-time-server: Input/output error (5)
mai 15 09:55:27 ENVY bluetoothd[1075]: Not enough free handles to register service
mai 15 09:55:27 ENVY bluetoothd[1075]: Not enough free handles to register service
mai 15 09:55:28 ENVY bluetoothd[1075]: Endpoint registered: sender=:1.53 path=/MediaEndpoint/A2DPSource
mai 15 09:55:28 ENVY bluetoothd[1075]: Endpoint registered: sender=:1.53 path=/MediaEndpoint/A2DPSink
mai 15 10:06:34 ENVY bluetoothd[1075]: Endpoint registered: sender=:1.93 path=/MediaEndpoint/A2DPSource
mai 15 10:06:34 ENVY bluetoothd[1075]: Endpoint registered: sender=:1.93 path=/MediaEndpoint/A2DPSink
mai 15 10:06:34 ENVY bluetoothd[1075]: RFCOMM server failed for Headset Voice gateway: rfcomm_bind: Addre
mai 15 10:06:52 ENVY bluetoothd[1075]: Endpoint unregistered: sender=:1.53 path=/MediaEndpoint/A2DPSource
mai 15 10:06:52 ENVY bluetoothd[1075]: Endpoint unregistered: sender=:1.53 path=/MediaEndpoint/A2DPSink

Hors ligne

#21 Le 15/05/2016, à 09:13

xubu1957

Re : [résolu] Bluetooth up mais ne détecte aucun périphérique (et pas vu)

Tu peux utiliser la dernière version de flashplayer

§ 2.1 a écrit :

Depuis les dépôts officiels
Méthode recommandée depuis mai 2015 :
- activer les dépôts partenaires de Canonical
- puis installer le paquet adobe-flashplugin
Cette méthode est vivement conseillée car elle permet de gérer les 2 versions différentes de Flash disponibles actuellement sous Firefox et Chromium


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 18.04.1 LTS - Lenovo T410 -Toshiba Satellite A300  Membre de Linux-Azur

En ligne

#22 Le 15/05/2016, à 09:46

laurent76

Re : [résolu] Bluetooth up mais ne détecte aucun périphérique (et pas vu)

FlashPlayer : ca y est j'ai le dernier plugin sous Firefox et Chromium --> " You have version 21,0,0,242 installed "
note : j'ai supprimé (et purgé) l'ancien paquet "flashplugin-installer"

laurent@ENVY:~$ dpkg -l |grep flash
ii  adobe-flash-properties-gtk                                  1:20160512.1-0ubuntu0.16.04.1                       amd64        GTK+ control panel for Adobe Flash Player plugin
ii  adobe-flashplugin                                           1:20160512.1-0ubuntu0.16.04.1                       amd64        Adobe Flash Player plugin
ii  browser-plugin-freshplayer-pepperflash                      0.3.5-1~webupd8~xenial~3                            amd64        PPAPI-host NPAPI-plugin adapter for pepperflash

Toutefois aucun effet sur le Bluetooth

Hors ligne

#23 Le 15/05/2016, à 09:50

laurent76

Re : [résolu] Bluetooth up mais ne détecte aucun périphérique (et pas vu)

Je dois faire la "pause" dominicale.

Je continue ce soir avec :
- recherche / résolution des erreurs de "service bluetooth status"
- test avec Debian 8.4.0

Merci, et bon dimanche !

Hors ligne

#24 Le 15/05/2016, à 09:50

xubu1957

Re : [résolu] Bluetooth up mais ne détecte aucun périphérique (et pas vu)

Bon dimanche !


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 18.04.1 LTS - Lenovo T410 -Toshiba Satellite A300  Membre de Linux-Azur

En ligne

#25 Le 15/05/2016, à 13:36

laurent76

Re : [résolu] Bluetooth up mais ne détecte aucun périphérique (et pas vu)

Bon, alors entre le dessert et le café j'ai creusé un peu et j'ai trouvé ceci :
https://howto.biapy.com/fr/ubuntu-gnu-l … sur-ubuntu

et l'ai appliqué (avec quelques légers ajustements) mais la méthode est globalement suivi et fonctionne
--> Ubuntu voit les périphériques bluetooth et peut s'y connecter (rapide test avec le belkin, un récepteur audio bluetooth et le son sort bien sur l'enceinte bluetooth)
--> le téléphone android voit Ubuntu

Il faut que je fasse plus de tests dans la soirée, et regarde notamment 1 truc / effet de bord possible --> la carte autoEthernet n'est plus reconnue (mais le WIFI est toujours OK).


Bref... ca avance !

Hors ligne