Contenu | Rechercher | Menus

Annonce

Ubuntu-fr vend de superbes t-shirts et de belles clés USB 32Go
Rendez-vous sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 02/10/2016, à 20:03

tkpx

Perte de wifi carte RTL8723BE

Bonjour,

J'ai installé ubuntu sur mon HP et je constatais une vitesse de wifi très lente.
J'ai donc chercher sur le net et suivi les instructions que j'ai trouvé sauf que depuis, je n'ai plus de wifi du tout.

Il s'agit d'une carte RTL8723BE
J'ai déjà parcouru le topic suivant, mais ça ne fonctionne pas.

Je débute sous ubuntu et j'ai besoin d'aide smile

Hors ligne

#2 Le 02/10/2016, à 20:19

tkpx

Re : Perte de wifi carte RTL8723BE

Si je fais lspci

02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8101/2/6E PCI Express Fast/Gigabit Ethernet controller (rev 07)
03:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8723BE PCIe Wireless Network Adapter

Hors ligne

#3 Le 02/10/2016, à 20:25

grandtoubab

Re : Perte de wifi carte RTL8723BE


Linux tout seul sur HP Pavilion DV7 et Acer Aspire T650, Canon MG3650 en wifi
Debian 10 Buster Gnome/Xorg, Gnome/Wayland, Weston/Wayland
https://bidouilledebian.wordpress.com/
ON M'A VU DANS LE VERCORS, SAUTER A L'ELASTIQUE..... J'AI DANS LES BOTTES DES MONTAGNES DE QUESTIONS....

Hors ligne

#4 Le 02/10/2016, à 21:11

tkpx

Re : Perte de wifi carte RTL8723BE

merci pour ta réponse mais :
- l'installation du packet debian ne fonctionne pas
"dpkg: erreur de traitement de l'archive firmware-realtek_0.43_all.deb (--install) :
tentative de remplacement de « /lib/firmware/RTL8192E/main.img », qui appartient aussi au paquet linux-firmware 1.157.3
dpkg-deb : erreur : le sous-processus coller a été tué par le signal (Relais brisé (pipe))
Des erreurs ont été rencontrées pendant l'exécution :
firmware-realtek_0.43_all.deb"

- la partie qui parle de compiler le module, c'est du chinois pour moi... je débute sad

Hors ligne

#5 Le 02/10/2016, à 21:25

tkpx

Re : Perte de wifi carte RTL8723BE

j'ai réussis certaines étapes mais à la ligne "sudo modprobe rtl8723be" ça ne veut pas.

modprobe: ERROR: could not insert 'rtl8723be': Required key not available

Hors ligne

#6 Le 02/10/2016, à 23:45

alex2423

Re : Perte de wifi carte RTL8723BE

Excellent ton site. Sinon au lieu de compiler, un gars sur le 2ème commentaire propose un ppa

Bonjour,
Comme beaucoup j’arrive ici parce que je galère avec ma rtl8821ae (un des chipsets wifi maudits) sous Linux Mint.
J’ai trouvé cette solution : http://askubuntu.com/questions/730430/w … 432#730432
Il s’agit d’ajouter le ppa de l’auteur des drivers Realtek, qui ainsi se mettent à jour via aptitude.
Cordialement

Hors ligne

#7 Le 02/10/2016, à 23:47

tkpx

Re : Perte de wifi carte RTL8723BE

j'ai finalement reussi.
J'ai tout formaté et reinstallé dans l'ordre les différentes techniques. Et ça fonctionne.

Hors ligne

#8 Le 02/10/2016, à 23:54

alex2423

Re : Perte de wifi carte RTL8723BE

Tu as réinstallé ton ubuntu carrement ?
Et après qu'as tu fais ? Tu as installé le ppa ?

Jaybi a du avoir le meme problème que toi https://forum.ubuntu-fr.org/viewtopic.php?id=1997368 et a résolu avec le ppa comme il a été suggéré dans le lien de son post

rm-rf/ a écrit :

Et toi ?
Cela peut être utile pour les autres (dont moi quand j'aurais accès à l'ordi smile )

Hors ligne

#9 Le 02/10/2016, à 23:58

tkpx

Re : Perte de wifi carte RTL8723BE

j'ai tout formaté et réinstallé.
Comme je suis sur HP, j'ai du desactivé mon security boot aussi.
J'ai suivi les étapes du premier lien qu'on ma donné
+ j'ai installé le ppa (le wifi est revenu mais très faible)
+  fais la dernière étape "echo "options rtl8723be ant_sel=2"  | sudo tee /etc/modprobe.d/rtl8723be.conf" (maintenant je capte bien, et je vois les wifi des voisins)

Hors ligne

#10 Le 03/10/2016, à 00:34

alex2423

Re : Perte de wifi carte RTL8723BE

cool merci pour avoir pris le temps de donner ce qui a marché pour toi smile

Hors ligne

#11 Le 21/10/2016, à 20:14

tkpx

Re : Perte de wifi carte RTL8723BE

pour infos, le soucis revient en général après les mises à jour qui touchent au kernel, donc j'ai deja du refaire la manip. relou

Hors ligne

#12 Le 24/10/2016, à 08:09

metalux

Re : Perte de wifi carte RTL8723BE

Bonjour,
Es-tu sûr d'utiliser le P.P.A. hanipouspilot/rtlwifi qui installe la version DKMS?
Celui-ci justement met à jour le pilote au changement de version pour éviter de refaire la manip au changement de noyau suite à une mise à jour contrairement à la compilation. Méthode testée et approuvée sur un HP avec cette carte.

Hors ligne

#13 Le 28/10/2016, à 21:22

tkpx

Re : Perte de wifi carte RTL8723BE

Oui j'ai bien le P.P.A
ça fonctionne avec mais j'ai un signal faible. Je dois ensuite toujours faire une modif. Mais je pense acheter une autre carte wifi pour régler le soucis;

Hors ligne

#14 Le 28/10/2016, à 22:46

metalux

Re : Perte de wifi carte RTL8723BE

Pour le signal faible, ça vient généralement de l'antenne sélectionnée. il faut trouver les bons réglages avec cette carte qui diffèrent d'un Pc à l'autre.
Peux-tu me donner les résultats de:

cat /etc/modprobe.d/rtl8723be.conf

et celui de:

systool -v -m rtl8723be

Il n' y a pas de raison d'être obligé de toujours faire une modif. Qu'elle est cette modif?
Pour info, je m'occupe de 2 Pcs avec cette carte et aucun des 2 wifis n'étaient fonctionnel. Maintenant les 2 fonctionnent sans problème mais ils n'utilisent pas les mêmes options. Tout dépend des symptômes.

Hors ligne

#15 Le 28/10/2016, à 22:49

tkpx

Re : Perte de wifi carte RTL8723BE

options rtl8723be fwlps=0

Module = "rtl8723be"

  Attributes:
    coresize            = "143360"
    initsize            = "0"
    initstate           = "live"
    refcnt              = "0"
    srcversion          = "2DA37D00E0E770F2130B511"
    taint               = "OE"
    uevent              = <store method only>

  Parameters:
    ant_sel             = "2"
    debug               = "1"
    disable_watchdog    = "N"
    fwlps               = "N"
    ips                 = "Y"
    msi                 = "N"
    swenc               = "N"
    swlps               = "N"

  Sections:
    .bss                = "0x0000000000000000"
    .data.unlikely      = "0x0000000000000000"
    .data               = "0x0000000000000000"
    .exit.text          = "0x0000000000000000"
    .gnu.linkonce.this_module= "0x0000000000000000"
    .init.text          = "0x0000000000000000"
    .note.gnu.build-id  = "0x0000000000000000"
    .parainstructions   = "0x0000000000000000"
    .rodata.str1.1      = "0x0000000000000000"
    .rodata.str1.8      = "0x0000000000000000"
    .rodata             = "0x0000000000000000"
    .strtab             = "0x0000000000000000"
    .symtab             = "0x0000000000000000"
    .text               = "0x0000000000000000"
    __jump_table        = "0x0000000000000000"
    __mcount_loc        = "0x0000000000000000"
    __param             = "0x0000000000000000"
    __verbose           = "0x0000000000000000"

Mais là j'ai un bon wifi.


Modération : merci à l'avenir d'utiliser les balises code (explications ici).

Dernière modification par cqfd93 (Le 28/10/2016, à 22:52)

Hors ligne

#16 Le 28/10/2016, à 23:23

metalux

Re : Perte de wifi carte RTL8723BE

fwlps=0 est utilisé lorsque tu as des déconnexions régulières, ça empêche la carte de se mettre en veille. Je ne suis pas sûr que tu sois confronté à ce cas là si j'ai bien lu le sujet, cette option ne devrait pas être nécessaire ici. Par contre le résultat de la 1ère commande n'est pas cohérent avec le résultat de la seconde. Tu ne m'as pas répondu concernant la modification que tu apportes à chaque fois. Vu ce que je vois, ça doit être en rapport avec debug et ant_sel. Pour rendre cela permanent, passe la commande:

echo "options rtl8723be ant_sel=2" | sudo tee /etc/modprobe.d/rtl8723be.conf

Si tu as des déconnexions, alors fwlps=0 est nécessaire. passe alors à ce moment là la commande:

echo "options rtl8723be fwlps=0 ant_sel=2" | sudo tee /etc/modprobe.d/rtl8723be.conf

Comme ça, pas besoin de faire des modifications à chaque fois.
N'oublie pas de décharger puis rechager le module à chaque modification pour sa prise en compte.

sudo modprobe -r rtl8723be
sudo modprobe rtl8723be

Hors ligne

#17 Le 28/10/2016, à 23:30

tkpx

Re : Perte de wifi carte RTL8723BE

Merci metalux pour les lignes de code.
je te confirme que j'ai des déconnexions régulières en sortant de veille, encore maintenant (enfin, je verrais bien avec tes lignes de codes) smile

La modif que je faisais à chaque fois c'était ""echo "options rtl8723be ant_sel=2"  | sudo tee /etc/modprobe.d/rtl8723be.conf""

Hors ligne

#18 Le 28/10/2016, à 23:46

metalux

Re : Perte de wifi carte RTL8723BE

Alors pourquoi tu as options rtl8723be fwlps=0 dans le fichier /etc/modprobe.d/rtl8723be.conf? Ce fichier sert justement à ne pas avoir à repasser les options à chaque fois.
Vu ta modif, tu aurais dû avoir options rtl8723be ant_sel=2 comme réponse. Donc soit tu écrases tes modifications à chaque fois, soit tu les charges autrement.

j'ai des déconnexions régulières en sortant de veille

Si le wifi n'accroche pas en sortie de veille, ce n'est pas la même chose, il faut regarder du côté de systemd ou de NetworkManager.
https://doc.ubuntu-fr.org/network-manag … _de_veille
fwlps=0 élimine les déconnexions qui se font au bout de 5 à 10 mns et qui reviennent régulièrement. Rien à voir avec une déconnexion en sortie de veille.

Hors ligne

#19 Le 04/11/2016, à 08:58

metalux

Re : Perte de wifi carte RTL8723BE

Pour les déconnexions en sortie de veille, je te propose de relancer NetworkMager avec ce service systemd:

sudo nano /etc/systemd/system/wifi-resume.service

coller le contenu suivant:

[Unit]
Description=Restart networkmanager at resume
After=suspend.target
After=hibernate.target
After=hybrid-sleep.target

[Service]
Type=oneshot
ExecStart=/bin/systemctl restart network-manager.service

[Install]
WantedBy=suspend.target
WantedBy=hibernate.target
WantedBy=hybrid-sleep.target

Ctrl+X pour sauvegarder et répondre "O" pour enregistrer le nom de fichier.
puis activer le service et autoriser son lancement automatique au démarrage:

systemctl enable wifi-resume.service
systemctl start wifi-resume.service

Maintenant la connexion devrait se faire en sortie de veille.

Hors ligne