Contenu | Rechercher | Menus

Annonce

Ubuntu 16.04 LTS
Commandez vos DVD et clés USB Ubuntu-fr !

Pour en savoir un peu plus sur l'équipe du forum.

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

#1 Le 17/12/2016, à 23:01

sylpaf

[Résolu ] Activation impossible carte wifi realtek RTL8723BE

Bonjour, nouvelle unstall Ubuntu 16.04 sur un HP 17yo28nf en dual boot avec windows 10, j'ai un gros souci de wifi:

impossible d'activer cette fichue carte wifi realtek RTL8723BE, le bouton "activer" dans les paramètres réseaux se désactive tout seul au bout d'une demi-seconde !
La carte est pourtant bien reconnue avec lspci:

03:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8723BE PCIe Wireless Network Adapter

Sous windows aucun problème.

La commande rfkill list suggère que la carte serait bloquée niveau logiciel :

rfkill list
0: hci0: Bluetooth
	Soft blocked: yes
	Hard blocked: no
1: phy0: Wireless LAN
	Soft blocked: no
	Hard blocked: no
2: acer-wireless: Wireless LAN
	Soft blocked: yes
	Hard blocked: no

Mais rfkill unblock all ne débloque rien du tout.

J'ai tenté les solutions proposées ici: https://angristan.fr/resoudre-les-probl … ous-linux/
...sans aucun changement.

Help! Je ne sais plus quoi faire...... merci d'avance

Dernière modification par Ayral (Le 21/04/2017, à 09:47)

Hors ligne

#2 Le 17/12/2016, à 23:19

metalux

Re : [Résolu ] Activation impossible carte wifi realtek RTL8723BE

Bonsoir,
As-tu essayé le P.P.A. hanipouspilot/rtlwifi? Il m'a permis de résoudre les problèmes rencontrés avec cette carte.
Regarde les réponses que j'ai données ici ou

Hors ligne

#3 Le 18/12/2016, à 09:55

sylpaf

Re : [Résolu ] Activation impossible carte wifi realtek RTL8723BE

Bonjour et merci de ton aide,
J'ai donc essayé le PPC dont tu parles, sans succès.
J'ai lu les posts et essayé de modifier les options genre fwlps=0, sans vraiment comprendre à quoi elles correspondent, mais encore sans aucun changement.

J'ai donc toujours l'impossibilité d'activer le wifi: le bouton se désactive immédiatement après que je clique dessus.

POur info voici mes résultats actuels pour

cat /etc/modprobe.d/rtl8723be.conf

et

systool -v -m rtl8723be 

:

francoise@francoise-HP-Notebook:~$ cat /etc/modprobe.d/rtl8723be.conf
options rtl8723be fwlps=0 ant_sel=2
francoise@francoise-HP-Notebook:~$ systool -v -m rtl8723be
Module = "rtl8723be"

  Attributes:
    coresize            = "135168"
    initsize            = "0"
    initstate           = "live"
    refcnt              = "0"
    srcversion          = "00619764255210776FAB54D"
    taint               = "OE"
    uevent              = <store method only>

  Parameters:
    ant_sel             = "2"
    debug               = "1"
    disable_watchdog    = "N"
    fwlps               = "N"
    ips                 = "Y"
    msi                 = "N"
    swenc               = "N"
    swlps               = "N"

  Sections:
    .bss                = "0x0000000000000000"
    .data               = "0x0000000000000000"
    .data.unlikely      = "0x0000000000000000"
    .exit.text          = "0x0000000000000000"
    .gnu.linkonce.this_module= "0x0000000000000000"
    .init.text          = "0x0000000000000000"
    .note.gnu.build-id  = "0x0000000000000000"
    .parainstructions   = "0x0000000000000000"
    .rodata             = "0x0000000000000000"
    .rodata.str1.1      = "0x0000000000000000"
    .rodata.str1.8      = "0x0000000000000000"
    .strtab             = "0x0000000000000000"
    .symtab             = "0x0000000000000000"
    .text               = "0x0000000000000000"
    __mcount_loc        = "0x0000000000000000"
    __param             = "0x0000000000000000"
    __verbose           = "0x0000000000000000"

francoise@francoise-HP-Notebook:~$ 

Bon et puis maintenant j'ai fait 50 manips différentes, je ne sais plus trop où j'en suis et ce que je peux essayer.....

Hors ligne

#4 Le 18/12/2016, à 10:53

xubu1957

Re : [Résolu ] Activation impossible carte wifi realtek RTL8723BE

Bonjour,

Pour la même carte wifi , au message 47 de cette discussion : [RESOLU]RTL8723BE mon Wifi ne s'active pas (soft blocked: yes)

Le 09/12/2016, sTraTe a écrit :

Trouvé !

J'avais la solution sous les yeux depuis le départ. J'avais deux modules wifi pour gérer la même carte et qui générait un conflit.

rfkill list
0: phy0: Wireless LAN
    Soft blocked: no
    Hard blocked: no
1: hci0: Bluetooth
    Soft blocked: no
    Hard blocked: no
2: acer-wireless: Wireless LAN
    Soft blocked: yes
    Hard blocked: no

Pour simplifier j'ai blacklisté le module réseau acer (sur un ordi HP...). J'imagine qu'il doit y avoir un moyen de désinstaller le bouzin. Mais en tout cas ça a marché, pour le moment je laisse comme ça.

echo "blacklist acer-wmi" | sudo tee -a /etc/modprobe.d/blacklist.conf

J'ajouterai que les autres manipulations et en particulier celle sur ant_sel=2 sont utiles et en particulier pour la force du signal sur ce type de carte/


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 16.04.1 LTS : Lenovo T410 - Toshiba Satellite A300 - HP 7100 DC - Asus 1015BX -Fujitsu Siemens Scaleo J3000  Membre de Linux-Azur

Hors ligne

#5 Le 18/12/2016, à 10:57

metalux

Re : [Résolu ] Activation impossible carte wifi realtek RTL8723BE

Je n'avais pas bien regardé hier soir le résultat de rfkill list.
ta carte est concernée par ça en principe:

1: phy0: Wireless LAN
	Soft blocked: no
	Hard blocked: no

Donc elle n'est pas bloquée. Par contre, tu as également ce qui suit:

2: acer-wireless: Wireless LAN
	Soft blocked: yes
	Hard blocked: no

je ne suis pas expert en wifi mais ça me semble bizarre. Y aurait-il 2 cartes wifi sur ce Pc?
Regarde dans le bios si il y a quelque chose en rapport avec le wifi. Donne également le retour de:

lsmod

Si il y a un module en rapport avec acer_wmi, essaye de le désactiver:

sudo modprobe -r acer_wmi

essaye avec et sans l'option  ant_sel=2. Pour fwlps=0, tu peux laisser en principe, ça empêche la carte de se mettre en veille et évite les déconnexions.
Si ça ne fonctionne pas, essaye ensuite de réactiver le module et retente un essai.
Dans l'idéal, il faudrait faire chaque test avec et sans le P.P.A. mais chaque chose en son temps, commence déjà comme ça pour éviter d'empirer la situation.
Edit:xubu1957 a posté pendant que je rédigeais le message et ça confirme mon analyse. Donc avant de blacklister, teste avec la désactivation du module. Si ça fonctionne, tu peux le blacklister.

Dernière modification par metalux (Le 18/12/2016, à 11:00)

Hors ligne

#6 Le 18/12/2016, à 10:58

sylpaf

Re : [Résolu ] Activation impossible carte wifi realtek RTL8723BE

J'ai du nouveau !
En essayant différentes solutions j'ai fini par réussir à activer et connecter mon wifi grâce à:

sudo modprobe -r rtl8723be
sudo modprobe rtl8723be fwlps=0 ips=0 ant_sel=1

Mon problème maintenant: au redémarrage de l'ordi, ça ne s'active pas tout automatiquement. Je peux faire "Activer le réseau wifi" avec l'icône wifi en haut à gauche, ça fonctionne. Mais c'est l'ordi de ma maman, j'aimerais que l'activation soit automatique...
Autre bizarerie : dans "Paramètres système/Réseaux", le bouton "Reéseaux sans fil" reste sur "off" avec indication "hors de portée" pour ma box..... alors que je suis connecté dessus !

Le problème est donc partiellement résolu mais ça me semble encore très bancal.....

La config actuelle:

francoise@francoise-HP-Notebook:~$ systool -v -m rtl8723be
Module = "rtl8723be"

  Attributes:
    coresize            = "135168"
    initsize            = "0"
    initstate           = "live"
    refcnt              = "0"
    srcversion          = "00619764255210776FAB54D"
    taint               = "OE"
    uevent              = <store method only>

  Parameters:
    ant_sel             = "0"
    debug               = "1"
    disable_watchdog    = "N"
    fwlps               = "N"
    ips                 = "N"
    msi                 = "N"
    swenc               = "N"
    swlps               = "N"

  Sections:
    .bss                = "0x0000000000000000"
    .data               = "0x0000000000000000"
    .data.unlikely      = "0x0000000000000000"
    .exit.text          = "0x0000000000000000"
    .gnu.linkonce.this_module= "0x0000000000000000"
    .init.text          = "0x0000000000000000"
    .note.gnu.build-id  = "0x0000000000000000"
    .parainstructions   = "0x0000000000000000"
    .rodata             = "0x0000000000000000"
    .rodata.str1.1      = "0x0000000000000000"
    .rodata.str1.8      = "0x0000000000000000"
    .strtab             = "0x0000000000000000"
    .symtab             = "0x0000000000000000"
    .text               = "0x0000000000000000"
    __mcount_loc        = "0x0000000000000000"
    __param             = "0x0000000000000000"
    __verbose           = "0x0000000000000000"

Dernière modification par sylpaf (Le 18/12/2016, à 11:05)

Hors ligne

#7 Le 18/12/2016, à 11:12

sylpaf

Re : [Résolu ] Activation impossible carte wifi realtek RTL8723BE

Bon, je suis allé un peu vite dans mon enthousiasme..... après un nouveau redémarrage, retour à la case départ, wifi non activé et non activable.
Je constate que ma nouvelle configuration n'a pas "tenu":

ant_sel est revenu à = "0"

francoise@francoise-HP-Notebook:~$ systool -v -m rtl8723be
Module = "rtl8723be"

  Attributes:
    coresize            = "135168"
    initsize            = "0"
    initstate           = "live"
    refcnt              = "0"
    srcversion          = "00619764255210776FAB54D"
    taint               = "OE"
    uevent              = <store method only>

  Parameters:
    ant_sel             = "0"
    debug               = "1"
    disable_watchdog    = "N"
    fwlps               = "N"
    ips                 = "N"
    msi                 = "N"
    swenc               = "N"
    swlps               = "N"

  Sections:
    .bss                = "0x0000000000000000"
    .data               = "0x0000000000000000"
    .data.unlikely      = "0x0000000000000000"
    .exit.text          = "0x0000000000000000"
    .gnu.linkonce.this_module= "0x0000000000000000"
    .init.text          = "0x0000000000000000"
    .note.gnu.build-id  = "0x0000000000000000"
    .parainstructions   = "0x0000000000000000"
    .rodata             = "0x0000000000000000"
    .rodata.str1.1      = "0x0000000000000000"
    .rodata.str1.8      = "0x0000000000000000"
    .strtab             = "0x0000000000000000"
    .symtab             = "0x0000000000000000"
    .text               = "0x0000000000000000"
    __mcount_loc        = "0x0000000000000000"
    __param             = "0x0000000000000000"
    __verbose           = "0x0000000000000000"

francoise@francoise-HP-Notebook:~$

Quand je relance

sudo modprobe -r rtl8723be
sudo modprobe rtl8723be fwlps=0 ips=0 ant_sel=1

, ça repart !

Une solution pour que cela se stabilise et que cela reste après démarrage?
Une idée pour que le bouton d'activation dans les paramètres système ne reste pas sur "off" alors que la connexion est ok?

Merci d'avance !

Hors ligne

#8 Le 18/12/2016, à 11:16

metalux

Re : [Résolu ] Activation impossible carte wifi realtek RTL8723BE

echo "options rtl8723be fwlps=0 ips=0 ant_sel=1" | sudo tee /etc/modprobe.d/rtl8723be.conf

Lis les messages précédents concernant le blacklistage de acer_wmi.
Essaye également avec ant_sel=2, en général cela donne de meilleurs résultats, à confirmer sur ta configuration.

Hors ligne

#9 Le 18/12/2016, à 11:38

sylpaf

Re : [Résolu ] Activation impossible carte wifi realtek RTL8723BE

BINGO ! Vous êtes des chefs !

Il y avait donc bien un module acer_wmi que j'ai désactivé puis blacklisté, et tout est rentré dans l'ordre: activation, connexion automatique et "bouton" des paramètres systèmes sur "ON". Impec !
Une idée de ce qu'est ce module acer_wmi et à quoi il sert? Est-ce que sa désactivation ne risque pas de poser d'autres problèmes?

En revanche, ant_sel est revenu encore une fois à = "0" et ça n'a pas l'air de poser problème, mais la modif n'est pas conservée après redémarrage....

En tout cas merci encore.

Hors ligne

#10 Le 18/12/2016, à 11:44

xubu1957

Re : [Résolu ] Activation impossible carte wifi realtek RTL8723BE

Dans la Doc : acer_wmi


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 16.04.1 LTS : Lenovo T410 - Toshiba Satellite A300 - HP 7100 DC - Asus 1015BX -Fujitsu Siemens Scaleo J3000  Membre de Linux-Azur

Hors ligne

#11 Le 18/12/2016, à 11:49

metalux

Re : [Résolu ] Activation impossible carte wifi realtek RTL8723BE

cat /etc/modprobe.d/rtl8723be.conf

Tu dois avoir:

options rtl8723be fwlps=0 ips=0 ant_sel=1

ou bien ant_sel=2 selon la configuration que tu as choisis.
Si ça ne reste pas au redémarrage, c'est que tu n'as pas entré la dernière commande que je t'ai proposé.
acer_wmi est pour parler en terme plus courant un pilote wifi. Et ici, il y avait 2 pilotes pour une seule carte. Imagine bien que cela pose problème si ils sont 2 à vouloir séduire ta belle carte wink

Hors ligne

#12 Le 18/12/2016, à 14:13

sylpaf

Re : [Résolu ] Activation impossible carte wifi realtek RTL8723BE

C'est parfait: j'ai effectivement stabilisé tout ça grâce à

echo "options rtl8723be fwlps=0 ips=0 ant_sel=1" | sudo tee /etc/modprobe.d/rtl8723be.conf

, au passage j'ai mis ant_sel=2 au lieu de =1 , ce qui a considérablement amélioré la réception wifi ( je n'en avais plus à l'étage).

Merci à tous !

Hors ligne