Contenu | Rechercher | Menus

Annonce

La nouvelle clé USB Ubuntu-fr est en prévente
Rendez-vous sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#26 Le 30/12/2016, à 21:29

mabel

Re : [Résolu]Wifi rtl8723be ne fonctionne pas

Ah merci beaucoup, justement j'allais vous demander comment faire pour garder le réglage sur l'antenne 2 car il "retombe" en sortie de veille ou redémarrage. J'ai essayé tes scripts, @Metalux, je reviendrai te dire si ça fonctionne.

Hors ligne

#27 Le 31/12/2016, à 10:45

mabel

Re : [Résolu]Wifi rtl8723be ne fonctionne pas

Le script fonctionne super bien. En tout jusque là le wifi fonctionne très bien après mise en veille ou redémarrage.
:-D
Merci pour votre aide précieuse.

Hors ligne

#28 Le 31/12/2016, à 13:33

metalux

Re : [Résolu]Wifi rtl8723be ne fonctionne pas

mabel, n'oublie pas de mettre ton sujet en résolu en éditant ton 1er message. Profites en pour lui donner un titre plus explicite genre:

[Résolu]Wifi rtl8723be ne fonctionne pas

Hors ligne

#29 Le 31/12/2016, à 13:53

mabel

Re : [Résolu]Wifi rtl8723be ne fonctionne pas

C'est bien noté merci.

Hors ligne

#30 Le 15/01/2017, à 18:27

mabel

Re : [Résolu]Wifi rtl8723be ne fonctionne pas

Bonsoir,
Je reviens sur ce post car malgré le script proposé par Metalux (post #25) un souci de connexion persiste. En effet,  si j'ai bien compris le script permet de redémarrer la carte wifi à chaque sortie de veille, en choisissant également la bonne antenne. Cela fonctionne très bien dans la plupart des cas, mais il arrive (je ne comprends pas pourquoi à ces moments et pas à d'autres) que Firefox tourne dans le vide après une sortie de veille. Le wifi semble bien connecté, j'ai un signal excellent, mais dès que j'ouvre Firefox il cherche cherche cherche et n'affiche rien. La seule solution est alors de redémarrer l'ordinateur pour retrouver la connexion. Je n'arrive pas à comprendre d'où vient le problème... J'ai quand même l'impression que c'est lorsque l'ordinateur a été en veille assez longtemps (je n'ai pas calculé)...
Merci pour vos lumières si vous avez des idées...

Hors ligne

#31 Le 15/01/2017, à 20:10

metalux

Re : [Résolu]Wifi rtl8723be ne fonctionne pas

Bonsoir,
hmm Je n'ai pas trop d'idée de quoi ça peut venir. Le caractère aléatoire est d'autant plus surprenant.
Lorsque cela se représentera, essaye de passer les commandes suivantes, une seule à chaque fois, et dis moi lesquelles fonctionnent sans redémarrer:

systemctl restart NetworkManager.service

puis essaye une autre fois:

sudo modprobe -r rtl8723be
sudo modprobe rtl8723be

et si ça ne fonctionne toujours pas essaye:

sudo modprobe -r rtl8723be
sudo modprobe rtl8723be fwlps=0 ant_sel=2 

Hors ligne

#32 Le 17/01/2017, à 22:45

mabel

Re : [Résolu]Wifi rtl8723be ne fonctionne pas

Bonsoir Metalux.

La deuxième commande a fonctionné !

sudo modprobe -r rtl8723be
sudo modprobe rtl8723be

Je crois avoir remarqué que le problème se produit après une mise en veille "véritable". En fait, lorsqu'on ferme le capot de l'ordinateur, celui-ci ne se met pas toujours en veille (lorsqu'on rouvre, le mot de passe n'est pas demandé, on revient directement sur le bureau). L'ordi se met en veille lorsqu'il est fermé au bout d'un temps très long ou bien si on clique sur "mettre en veille" évidemment.
Pourtant les paramètres sont bien : mettre en veille si inactif au bout de 5 minutes (sur secteur et sur batterie) et "mettre en veille lorsque le capot est fermé (sur secteur et batterie)...

Hors ligne

#33 Le 17/01/2017, à 23:27

metalux

Re : [Résolu]Wifi rtl8723be ne fonctionne pas

Pour ton histoire de mise en veille, non, je penses que le PC se met bien en veille mais que c'est lié à l'économiseur d'écran lorsqu'il te demande un mot de passe. Sur Ubuntu je ne sais pas où ça se trouve (perso j'ai mate et lxde en ce moment) mais recherche dans le dash avec le mot économiseur. Perso, je supprime la demande de mot de passe, c'est quelque chose qui m'agace, et c'est peut-être pour ça que ça fonctionne chez moi.
Mais pour une question de confidentialité tu souhaites peut-être le garder. Dans ce cas lis la suite.
C'est le module wifi qui ne se relance pas et non network-manager.
Ou bien les 2? On verra si ça persiste, on avisera à ce moment là.

Bon, pour que ça fonctionne à tout les coups, on va contourner en modifiant le script. Dans un premier temps tu vas arrêter les services:

sudo systemctl stop wifi-resume.service
sudo systemctl disable wifi-resume.service

Ensuite tu vas modifier en reprenant la réponse #25 et là, tu vas changer:

ExecStart=/bin/systemctl restart network-manager.service

par:

ExecStart=/sbin/rmmod rtl8723be ; /sbin/modprobe rtl8723be

et tu réactives le service:

sudo systemctl start wifi-resume.service
sudo systemctl enable wifi-resume.service

Hors ligne

#34 Le 24/01/2017, à 21:56

mabel

Re : [Résolu]Wifi rtl8723be ne fonctionne pas

@Metalux, ça a l'air de fonctionner désormais !
Mille merci :-)

Hors ligne

#35 Le 24/01/2017, à 22:05

metalux

Re : [Résolu]Wifi rtl8723be ne fonctionne pas

Qu'as-tu fais au final?
Désactiver le mot de passe en sortie de veille dans l'économiseur ou Modifier le script systemd? Autant que ça serve pour d'autres.

Hors ligne

#36 Le 31/01/2017, à 21:36

mabel

Re : [Résolu]Wifi rtl8723be ne fonctionne pas

Bonsoir,
Je n'ai rien touché au niveau de la sortie de veille, pour l'instant ça ne me dérange pas. J'ai modifié le script pour que ce soit le module wifi qui redémarre et non le network manager.
Merci encore.

Hors ligne