Contenu | Rechercher | Menus

Annonce

DVD, clés USB et t-shirts Ubuntu-fr disponibles sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 27/02/2019, à 01:52

Coeur Noir

Tearing sous 18.04 mais pas sous 16.04, pourquoi ? [ résolu ]

Hello,

Un pc en multiboot : 16.04.5 unity / 18.04.2 budgie / 18.04.2 « défaut ».
Systèmes avec HWE activés, à jour ; wayland nulle part.

Sous les 18.04 j'ai du tearing en vidéo, streaming ou localement. Sous 16.04, impeccable.

Pas de souci avec un jeu tel que supertuxkart, que ce soit sous 16.04 ou 18.04.

Matos : Intel® Core™ i7-4770K CPU @ 3.50GHz × 8  / Intel® Haswell Desktop / ram 15,5 Gio

Comment comparer les installations graphiques entre 16.04 / 18.04 ( est-ce comparable d'ailleurs ) ? Je suppose que j'ai oublié d'installer ou activer quelque chose en 18.04 ( driver, firmware… )
Ou s'agit-il d'une différence entre Unity/Compiz d'un côté et Mutter de l'autre ?

Dernière modification par Coeur Noir (Le 28/02/2019, à 17:29)


DébuterDocBien rédigerRetour commandeInsérer image | illustrations & captures d'écran <>

Hors ligne

#2 Le 27/02/2019, à 08:06

xubu1957

Re : Tearing sous 18.04 mais pas sous 16.04, pourquoi ? [ résolu ]

Bonjour,

Tu n'as rien de proposé dans le gestionnaire_de_pilotes_proprietaires ?


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 20.04 LTS - Lenovo T410 -18.04.1 LTS Toshiba Satellite A300  Membre de Linux-Azur

En ligne

#3 Le 28/02/2019, à 17:04

Coeur Noir

Re : Tearing sous 18.04 mais pas sous 16.04, pourquoi ? [ résolu ]

Alors sous 16.04 comme 18.04, pilote proprio me répond « aucun ».

Sous 18.04 j'ai

coeur-noir@asgard:~$ lspci -nnk | egrep -iA3 "VGA"
00:02.0 VGA compatible controller [0300]: Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics Controller [8086:0412] (rev 06)
	Subsystem: ASUSTeK Computer Inc. Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics Controller [1043:8534]
	Kernel driver in use: i915
	Kernel modules: i915
coeur-noir@asgard:~$ sudo lshw -c video
[sudo] Mot de passe de coeur-noir : 
  *-display                 
       description: VGA compatible controller
       produit: Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics Controller
       fabriquant: Intel Corporation
       identifiant matériel: 2
       information bus: pci@0000:00:02.0
       version: 06
       bits: 64 bits
       horloge: 33MHz
       fonctionnalités: msi pm vga_controller bus_master cap_list rom
       configuration: driver=i915 latency=0
       ressources: irq:26 mémoire:f7800000-f7bfffff mémoire:e0000000-efffffff portE/S:f000(taille=64) mémoire:c0000-dffff
coeur-noir@asgard:~$ 

et sous 16.04 :

coeurnoir@Asgard:~$ lspci -nnk | egrep -iA3 "VGA"
00:02.0 VGA compatible controller [0300]: Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics Controller [8086:0412] (rev 06)
	DeviceName:  Onboard IGD
	Subsystem: ASUSTeK Computer Inc. Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics Controller [1043:8534]
	Kernel driver in use: i915
coeurnoir@Asgard:~$ sudo lshw -c video
[sudo] Mot de passe de coeurnoir : 
  *-display               
       description: VGA compatible controller
       produit: Xeon E3-1200 v3/4th Gen Core Processor Integrated Graphics Controller
       fabriquant: Intel Corporation
       identifiant matériel: 2
       information bus: pci@0000:00:02.0
       version: 06
       bits: 64 bits
       horloge: 33MHz
       fonctionnalités: msi pm vga_controller bus_master cap_list rom
       configuration: driver=i915 latency=0
       ressources: irq:26 mémoire:f7800000-f7bfffff mémoire:e0000000-efffffff portE/S:f000(taille=64) mémoire:c0000-dffff
coeurnoir@Asgard:~$ 

…autrement dit c'est idem…

Dernière modification par Coeur Noir (Le 28/02/2019, à 17:08)


DébuterDocBien rédigerRetour commandeInsérer image | illustrations & captures d'écran <>

Hors ligne

#4 Le 28/02/2019, à 17:18

Coeur Noir

Re : Tearing sous 18.04 mais pas sous 16.04, pourquoi ? [ résolu ]

Ooops j'avais pas vu le §4.3 de https://doc.ubuntu-fr.org/intel_graphics je teste…


DébuterDocBien rédigerRetour commandeInsérer image | illustrations & captures d'écran <>

Hors ligne

#5 Le 28/02/2019, à 17:22

xubu1957

Re : Tearing sous 18.04 mais pas sous 16.04, pourquoi ? [ résolu ]


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 20.04 LTS - Lenovo T410 -18.04.1 LTS Toshiba Satellite A300  Membre de Linux-Azur

En ligne

#6 Le 28/02/2019, à 17:29

Coeur Noir

Re : Tearing sous 18.04 mais pas sous 16.04, pourquoi ? [ résolu ]

…je ne suis pas assez « joueur » pour me sentir concerné par ce bug ( en plus la personne signalant utilise des versions de libgl1-mesa-dri provenant du ppa padoka0 ) je n'ai pas vu de tearing avec supertuxkart, ça me suffit ;-)
Par contre en vidéo toute simple oui il y a du tearing et ça, c'est plus frustrant pour moi.

Donc j'ai testé sous 18.04 ce que propose la doc :

Problème de saccade/déchirure "Tearing"avec Intel HD graphics lors des lectures VLC ou navigation sous Firefox.

Suite à une mise à niveau sous la version 18.04, mes lectures VLC sont déchirées, présence de "Tearing".

Il faut créer le fichier suivant /usr/share/X11/xorg.conf.d/20-intel_flicker_fix.conf avec les droits d'administration et y coller ces lignes :

Section "Device"
  Identifier  "Intel Graphics"
  Driver      "intel"
  Option      "TripleBuffer" "true"
  Option      "TearFree"     "true"
EndSection

Sauvegarder et redémarrer.

et ma foi ça semble résoudre mon problème !

Par contre je veux bien une explication : c'est spécifique à une mise à niveau ? Ou c'est un genre de régression ?

Dernière modification par Coeur Noir (Le 28/02/2019, à 17:31)


DébuterDocBien rédigerRetour commandeInsérer image | illustrations & captures d'écran <>

Hors ligne

#7 Le 28/02/2019, à 18:17

GammaDraconis

Re : Tearing sous 18.04 mais pas sous 16.04, pourquoi ? [ résolu ]

Tu n'aurais pas un 2ème écran branché à ton PC ?

Normalement avec Mutter sous Gnome, quand 1 seul écran est branché, il n'y a pas de tearing en vidéo car justement il synchronise avec la fréquence d'affichage.
La manip que tu décris est normalement valable plutôt des environnements comme Xfce, Mate ou Lxde qui eux ont du tearing par défaut.

En revanche si tu as un 2ème écran c'est normale.

Dernière modification par GammaDraconis (Le 28/02/2019, à 18:28)


Discussion sur mon script de post-install pour Ubuntu 20.04LTS : https://forum.ubuntu-fr.org/viewtopic.php?id=2026344
Lien direct script : https://github.com/simbd/Ubuntu_20.04LTS_PostInstall
Démo vidéo (peertube) : https://video.ploud.fr/videos/watch/fb7 … 0d252ed2db

Hors ligne

#8 Le 28/02/2019, à 18:42

Coeur Noir

Re : Tearing sous 18.04 mais pas sous 16.04, pourquoi ? [ résolu ]

Non un seul écran.

Et à bien y réfléchir, je ne suis pas sûr d'avoir toujours eu ce problème de tearing sous 18.04 ( budgie et defaut gnomeuse ). Je dirais que ça date de quelques semaines et depuis avant l'officialisation de 18.04.2

Sans certitude absolue.

En tout cas la manip' au #6 est efficace.


DébuterDocBien rédigerRetour commandeInsérer image | illustrations & captures d'écran <>

Hors ligne

#9 Le 28/02/2019, à 19:21

Coeur Noir

Re : Tearing sous 18.04 mais pas sous 16.04, pourquoi ? [ résolu ]

Oh bah tiens, j'ai retrouvé une « vieille » install' de 18.04 version « defaut » pas à jour → pas de tearing.

Après mise à jour ( environ 170 paquets, il y a du mesa dans le lot ) → tearing…

Dernière modification par Coeur Noir (Le 01/03/2019, à 13:53)


DébuterDocBien rédigerRetour commandeInsérer image | illustrations & captures d'écran <>

Hors ligne

#10 Le 01/03/2019, à 13:52

Coeur Noir

Re : Tearing sous 18.04 mais pas sous 16.04, pourquoi ? [ résolu ]

…et donc à nouveau, application du « réglage » proposé par la doc' et zou, bye bye le tearing.

Pourquoi est-ce que ça n'est pas le réglage par défaut, du coup ???


DébuterDocBien rédigerRetour commandeInsérer image | illustrations & captures d'écran <>

Hors ligne

#11 Le 01/03/2019, à 15:37

GammaDraconis

Re : Tearing sous 18.04 mais pas sous 16.04, pourquoi ? [ résolu ]

Sur mon ultrabook en 18.04/Gnome à jour, je n'ai pas de tearing et pourtant je n'ai pas ajouté le fichier de config (je le fais que pour les environnements Xfce ou Mate comme sous ma Archlinux qui est avec Xfce par exemple).

Ton problème doit avoir un lien avec ton matériel et une maj.

Normalement sous Gnome tu ne dois pas avoir ce genre de soucis.

(et n'oublie pas que cette manip ne concerne que ceux qui utilisent un chipset graphique Intel)

Dernière modification par GammaDraconis (Le 01/03/2019, à 16:11)


Discussion sur mon script de post-install pour Ubuntu 20.04LTS : https://forum.ubuntu-fr.org/viewtopic.php?id=2026344
Lien direct script : https://github.com/simbd/Ubuntu_20.04LTS_PostInstall
Démo vidéo (peertube) : https://video.ploud.fr/videos/watch/fb7 … 0d252ed2db

Hors ligne

#12 Le 01/03/2019, à 16:18

Coeur Noir

Re : Tearing sous 18.04 mais pas sous 16.04, pourquoi ? [ résolu ]

Je confirme que j'ai constaté le souci :
- sous gnome 18.04
- budgie 18.04
et pas du tout constaté le souci sous :
- unity 16.04
…ces systèmes étant installés sur une seule et même machine ( multi boot, chacun leurs partitions donc racines distinctes ).

Matériel : core i7 haswell, pas d'autre CG, driver libre nouveau.

Oui c'est probablement lié à la mise à jour de certains paquets ( mesa et compagnie ? ) puisque sur une ancienne install' 18.04 pas mise à jour, pas de tearing.

Ça n'est pas spécifique au noyau : démarrer sur d'anciens ne supprime pas le tearing une fois qu'il est apparu. Passer en hwe ( 4.18 ) ne supprime pas non plus le tearing.
C'est davantage une question de paramétrage logiciel, visiblement.


DébuterDocBien rédigerRetour commandeInsérer image | illustrations & captures d'écran <>

Hors ligne

#13 Le 21/03/2019, à 03:14

Coeur Noir

Re : Tearing sous 18.04 mais pas sous 16.04, pourquoi ? [ résolu ]

Et dans la série des différences entre 16.04 et 18.04, si mon pépin de tearing semble résolu en vidéo, il en reste un présent dans Firefox ( sous 18.04 donc, mais pas sous 16.04 ) avec un look un peu différent :
là le déchirement est visible quand je « scrolle » des pages web, dans la diagonale… mais c'est pas systématique.


DébuterDocBien rédigerRetour commandeInsérer image | illustrations & captures d'écran <>

Hors ligne

#14 Le 21/03/2019, à 12:33

metalux

Re : Tearing sous 18.04 mais pas sous 16.04, pourquoi ? [ résolu ]

Bonjour,
Tu peux tenter ceci: https://forum.ubuntu-fr.org/viewtopic.p … #p21606839
Ce qui m'étonne également, c'est que ce problème a lieu sur Gnome, ça concerne normalement les environnements comme Xfce ou Lxde par exemple.
Tu peux aussi essayer en supprimant xserver-xorg-video-intel comme je l'indique dans le 1er message si ce paquet est toujours présent en 18.04 (je suis resté en 16.04).

Hors ligne

#15 Le 30/03/2019, à 02:15

Coeur Noir

Re : Tearing sous 18.04 mais pas sous 16.04, pourquoi ? [ résolu ]

Oooh bah merci metalux, c'est passer layers.acceleration.force-enabled à True dans le about:config de Firefox qui m'aura rendu la fluidité.

Sous Gnome et Budgie 18.04. Et après une certaine mise à jour, avant je n'avais pas remarqué ces tearings.

Et toujours pas ce souci sous 16.04 Unity… où layers.acceleration.force-enabled est à False, dans la même version de Firefox.

Dernière modification par Coeur Noir (Le 08/04/2019, à 22:50)


DébuterDocBien rédigerRetour commandeInsérer image | illustrations & captures d'écran <>

Hors ligne

#16 Le 10/03/2020, à 19:37

AldoLaClasse

Re : Tearing sous 18.04 mais pas sous 16.04, pourquoi ? [ résolu ]

Coeur Noir a écrit :

Oooh bah merci metalux, c'est passer layers.acceleration.force-enabled à True dans le about:config de Firefox qui m'aura rendu la fluidité.

bonjour
même problème de tearing dans Firefox et même solution sous 18.04 et chipset intel
merci

Hors ligne