Contenu | Rechercher | Menus

Annonce

DVD, clés USB et t-shirts Ubuntu-fr disponibles sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 29/09/2019, à 16:32

savaparigole

Ubuntu ne demare pas sur un acer aspire ES1-732 tout neuf

Bonjour à tous.

J'ai un acer aspire ES1-732 tout neuf et comme à chaque acquisition de matériel j'ai tenté d’installer la dernière version de Ubuntu (pour moi Kubuntu).
Mais quelque soit la version (dernière ou plus ancienne) l'ordi plante, ou plutôt se fige à 66% de exécution de "grub-install /dev/sda".
Pour être sur que d'ordi ne travaille pas en interne, je l'ai laissé allumer le temps d'un film, mais pas de miracle.
J'ai préparé la clé bootable sur Ubuntu et sur Windows et avec des outils différents, mais cela plante toujours au même moment.
De le même façon boot-repair se fige aussi, et l'onglet de boot-repair concernant l'EFI reste grisé et je ne peux pas l'ouvrir.
J'ai pu relever avant que la clé ne boote - problem looging boot db EFI X509 certificat -65.
D'après la documentation il faut configurer - select an uefi as trusted for executing - dans l'onglet sécurité du le BIOS, mais cette fonction n'existe pas dans mon BIOS.
C'est cela qui me fais penser que le BIOS déconne, j'ai tenté de le mettre à jour mais pour le moment Acer cache bien ses micros programmes.
Quand je vérifie mes partissions toutes les partissions linux sont en place.
En recherchant dans la documentation des problèmes similaires, j'ai tenté de configurer le BIOS en lignes de commande pour qu'il reconnaisse Ubuntu via le live DC, , rien ne marche.
Bon voila le topo de mon désespoir, pas de Kubuntu dans le BIOS.....
Merci pour vos réponses et bonne soirée.
Savaparigolé.

Hors ligne

#2 Le 29/09/2019, à 16:54

xubu1957

Re : Ubuntu ne demare pas sur un acer aspire ES1-732 tout neuf


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 20.04 LTS - Lenovo T410 -18.04.1 LTS Toshiba Satellite A300  Membre de Linux-Azur

En ligne

#3 Le 29/09/2019, à 17:19

lucmars

Re : Ubuntu ne demare pas sur un acer aspire ES1-732 tout neuf

savapa a écrit :

select an uefi as trusted for executing - dans l'onglet sécurité du le BIOS, mais cette fonction n'existe pas dans mon BIOS.

Pas cool, sinon qu'en créeant un compte admin dans le bios cela te donnerait accès à cette fonction, mais pas garantit.


Gaulois Matter !

Hors ligne

#4 Le 30/09/2019, à 17:20

savaparigole

Re : Ubuntu ne demare pas sur un acer aspire ES1-732 tout neuf

Merci pour les conseilles.
Je tente de les appliquer ce soir, mon prochain message raconteras ma fortune....
En attentant j'ai une question concernant la prise en charge de l'ordi.
- - Est-il normal que le bios soit incomplet, peut-on y écrire se que l'on veux ?
- - Si se n'est pas normal est-ce que je peux faire jouer la garantie pour changer d'appareil ?
A bientôt et très bonne soirée.

Hors ligne

#5 Le 30/09/2019, à 17:48

lucmars

Re : Ubuntu ne demare pas sur un acer aspire ES1-732 tout neuf

C'est normal, le bios est te qu'il est avec ses qualités et défauts. Tu peux tenter sa mise à jour (c'est risqué) sans garantie de quelque amélioration.

En général les constructeurs ne garantissent pas le niveau logiciel.


Gaulois Matter !

Hors ligne

#6 Le 06/10/2019, à 10:25

savaparigole

Re : Ubuntu ne demare pas sur un acer aspire ES1-732 tout neuf

Bonjour la communauté.....

Voila le bilan de mes essais = TRÈS TRÈS NUL. comme "select an uefi as trusted for executing" n'existe pas, il est impossible de booter sur Ubuntu.

Je ne peux pas mettre le bois en " legancy ", la fonction " efi " reste grise.

Même en installant Ubuntu seul sur tout le disque le bios ne le trouve pas. Et quand je coche la fonction " configure sécure boot " ( page 3 de l'installation ), l'ordi plante instantanément.
De même quand je paramétré dans un terminal et en ligne de commande via une clé usb, l'ordi plante pendant la configuration de grub.

Il ne me reste plus que windows pour faire tourner l'ordi, c'est bien dommage car je déteste les images qui gigotent dans tous les sens et ne pas pouvoir supprimer des programme qui s'installent automatiquement.

Merci pour les conseils et à bientôt sur le forum.

Hors ligne

#7 Le 06/10/2019, à 15:59

geole

Re : Ubuntu ne demare pas sur un acer aspire ES1-732 tout neuf

Bonjour
Je n'ai pas très  bien compris si tu "jettes l'éponge" ou si tu demandes de l'aide pour installer ubuntu..

Tu es dans un contexte assez bien connu maintenant.
    Un ordinateur uniquement EFI qui n'a pas implémenté le SECURE BOOT aux normes de UBUNTU.
   Un UBUNTU qui refuse de s'installer sur un ordinateur EFI  NON sécurisé.
  Un ordinateur ne bootant qu'avec  une structure standard de boot /EFI/BOOT/BOOTX64.EFI

Mais il existe deux palliatifs
   1)   Booter   en technique bind   et virer tous les modules EFI SECURE  inutiles.
   2)   Installer    UBUNTU sans le secure mode.

Si tu souhaites de l'aide, publies un boot-info et dis ce que tu as déjà essayé afin de gagner un peu  de temps.
J'ai  l'habitude  de proposer  le pré-requis suivant
a)     Faire en sorte de déactiver dans le bios le SECURE-BOOT
b)     Utiliser REFIND pour booter au lieu du grub https://doc.ubuntu-fr.org/refind
     L'installation de refind est décrite au paragraphe  2.1.2
   Cependant, tu éviteras de faire cette  dernière commande puisque ton bios EFI n'accepte pas d'être modifié.

sudo efibootmgr -c -d /dev/NomDuDisque -p N°DeLaPartition -L "Refind" -l "\EFI\refind\refind_x64.efi"
sudo efibootmgr -v 

Dernière modification par geole (Le 06/10/2019, à 16:00)

En ligne

#8 Le 08/10/2019, à 21:58

savaparigole

Re : Ubuntu ne demare pas sur un acer aspire ES1-732 tout neuf

Bonjour à tous.

Si j’ai froissé quelqu’un dans mon dernier message, c’est à cause de toutes ces tentatives qui ont échouées et je vous prie de m’excuser.
Mais j’en suis toujours au même point, tout plante.
J’ai plus ou moins classer ce que j’ai fait, c’est un roman.

J'ai mis à jour le bios via acer mais il est toujours identique.

Pour le boot-info voici l’URL : http://paste.ubuntu.com/p/HDgW977gn8/

Voici ce que j’ai essayé : avec https://askubuntu.com/questions/254491/ … ath-of-cow
grub-install /dev/sda
Installing for i386-pc platform.
grub-install: error: failed to get canonical path of `/cow'.
update-grub
/usr/sbin/grub-probe: error: failed to get canonical path of `/cow'.

Avec ce tuto : https://doc.ubuntu-fr.org/refind
kubuntu@kubuntu:~$ sudo apt-get install refind
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Les paquets supplémentaires suivants seront installés : efibootmgr
Les NOUVEAUX paquets suivants seront installés :  efibootmgr refind
0 mis à jour, 2 nouvellement installés, 0 à enlever et 272 non mis à jour.
Il est nécessaire de prendre 2755 ko/2783 ko dans les archives.
Après cette opération, 4738 ko d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer ? [O/n] o
Réception de :1 http://archive.ubuntu.com/ubuntu disco/universe amd64 refind amd64 0.11.3-1 [2755 kB]
+
+
Réception de :2 cdrom://Kubuntu 19.04 _Disco Dingo_ - Release amd64 (20190416) disco/main amd64 efibootmgr amd64 15-1 [28,2 kB]
2755 ko réceptionnés en 0s (8712 ko/s)                   
Préconfiguration des paquets...
Sélection du paquet efibootmgr précédemment désélectionné.
(Lecture de la base de données... 179565 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../efibootmgr_15-1_amd64.deb ...
Installing rEFInd to the ESP...
dpkg: erreur de traitement du paquet refind (--configure) :
installed refind package post-installation script subprocess returned error exit status 1
Traitement des actions différées (« triggers ») pour man-db (2.8.5-2) ...
Des erreurs ont été rencontrées pendant l'exécution :  refind
E: Sub-process /usr/bin/dpkg returned an error code (1)

Avec ce tuto - https://community.acer.com/en/discussio … ent_480966 :
kubuntu@kubuntu:~$ sudo mount /dev/sda4 /mnt #sda4
kubuntu@kubuntu:~$ sudo mkdir /mnt/boot/efi
mkdir: cannot create directory ‘/mnt/boot/efi’: File exists
kubuntu@kubuntu:~$ sudo mount /dev/sda1 /mnt/boot/efi #sda1
kubuntu@kubuntu:~$  /dev /dev/pts /proc /sys
bash: /dev: Is a directory
kubuntu@kubuntu:~$ sudo mount -B $i /mnt$i
mount: /mnt: mount(2) system call failed: No such file or directory.

J’ai fais aussi
kubuntu@kubuntu:~$ sudo dpkg -P --force-all grub-efi-amd64-signed
dpkg: avertissement: requête ignorée : suppression de grub-efi-amd64-signed, qui n'est pas installé

kubuntu@kubuntu:~$ dpkg-query --list grub* efi* secure*
Souhait=inconnU/Installé/suppRimé/Purgé/H=à garder
| État=Non/Installé/fichier-Config/dépaqUeté/échec-conFig/H=semi-installé/W=attend-trait
|/ Err?=(aucune)/besoin Réinstallation (État,Err: majuscule=mauvais)
||/ Nom                   Version              Architecture Description
+++-=====================-====================-============-============================
un  efibootmgr            <aucune>             <aucune>     (aucune description n'est di
un  grub                  <aucune>             <aucune>     (aucune description n'est di
ii  grub-common           2.02+dfsg1-12ubuntu2 amd64        GRand Unified Bootloader (co
un  grub-coreboot         <aucune>             <aucune>     (aucune description n'est di
un  grub-doc              <aucune>             <aucune>     (aucune description n'est di
un  grub-efi              <aucune>             <aucune>     (aucune description n'est di
un  grub-efi-amd64        <aucune>             <aucune>     (aucune description n'est di
un  grub-efi-arm          <aucune>             <aucune>     (aucune description n'est di
un  grub-efi-arm64        <aucune>             <aucune>     (aucune description n'est di
un  grub-efi-ia32         <aucune>             <aucune>     (aucune description n'est di
un  grub-efi-ia64         <aucune>             <aucune>     (aucune description n'est di
un  grub-emu              <aucune>             <aucune>     (aucune description n'est di
ii  grub-gfxpayload-lists 0.7                  amd64        GRUB gfxpayload blacklist
un  grub-ieee1275         <aucune>             <aucune>     (aucune description n'est di
un  grub-legacy           <aucune>             <aucune>     (aucune description n'est di
un  grub-legacy-doc       <aucune>             <aucune>     (aucune description n'est di
un  grub-linuxbios        <aucune>             <aucune>     (aucune description n'est di
ii  grub-pc               2.02+dfsg1-12ubuntu2 amd64        GRand Unified Bootloader, ve
ii  grub-pc-bin           2.02+dfsg1-12ubuntu2 amd64        GRand Unified Bootloader, ve
un  grub-uboot            <aucune>             <aucune>     (aucune description n'est di
un  grub-xen              <aucune>             <aucune>     (aucune description n'est di
un  grub-yeeloong         <aucune>             <aucune>     (aucune description n'est di
un  grub2                 <aucune>             <aucune>     (aucune description n'est di
lines 1-28

Il y a : kubuntu@kubuntu:~$  sudo blkid | grep -Ei "ext4|vfat" 
/dev/sda1: UUID="14DE-1D8D" TYPE="vfat" PARTLABEL="EFI System Partition" PARTUUID="90ea34d4-5759-47ff-ace5-80ff50a56698"
/dev/sda2: UUID="37c262a1-fa11-446f-8261-48c6cec51736" TYPE="ext4" PARTUUID="32f3f255-d0cc-4360-9f98-c34b2e6c2dc9"
/dev/sda4: UUID="cc013145-582c-4dbd-a70d-c1050081f217" TYPE="ext4" PARTUUID="e3779029-10d1-4492-bb47-9e3543503531"
/dev/sda5: UUID="9bc63d0d-9719-4240-8762-336f51c604db" TYPE="ext4" PARTUUID="e87774d3-c890-4888-ab0b-8f02f1ca2792"
/dev/sdb1: LABEL_FATBOOT="Windows USB" LABEL="Windows USB" UUID="E5A4-CF67" TYPE="vfat" PARTUUID="8f11075a-01"
/dev/sdc1: UUID="141D-556B" TYPE="vfat" PARTUUID="000742e8-01"
kubuntu@kubuntu:~$
et
kubuntu@kubuntu:~$  sudo parted -l | grep -Ei "ext4|fat32"
1      1049kB  538MB   537MB   fat32           EFI System Partition          boot, esp
2      538MB   1538MB  1000MB  ext4                                          bios_grub
4      2539MB  403GB   400GB   ext4
5      403GB   1193GB  790GB   ext4
1      4194kB  7795MB  7790MB  primary  fat32        lba
1      32,3kB  16,0GB  16,0GB  primary  fat32        boot, lba

j’ai essayé : https://doc.ubuntu-fr.org/boot-repair
kubuntu@kubuntu:~$ sudo mount     -v /dev/sda4  /mnt     
mount: /dev/sda4 mounted on /mnt.
kubuntu@kubuntu:~$ sudo mount    --bind /dev  /mnt/dev
kubuntu@kubuntu:~$ sudo mount    -t proc /proc /mnt/proc
kubuntu@kubuntu:~$ sudo mount    --bind /run  /mnt/run
kubuntu@kubuntu:~$ sudo mount   --bind /sys  /mnt/sys
kubuntu@kubuntu:~$ modprobe efivars
kubuntu@kubuntu:~$ sudo mount   --bind /run/resolvconf  /mnt/run/resolvconf
kubuntu@kubuntu:~$ sudo chroot    /mnt
root@kubuntu:/# mount  -t devpts devpts /dev/pts
root@kubuntu:/# mkdir   -p /boot/efi
root@kubuntu:/# mount  -v /dev/sda1 /boot/efi
mount: /dev/sda1 mounted on /boot/efi.
root@kubuntu:/# grub-install
Installing for i386-pc platform.
grub-install: error: install device isn't specified.
root@kubuntu:/# apt  update
Réception de :1 http://fr.archive.ubuntu.com/ubuntu disco InRelease [257 kB]
Réception de :104 http://fr.archive.ubuntu.com/ubuntu disco-backports/multiverse amd64 c-n-f Metadata [116 B]   
66,9 Mo réceptionnés en 12s (5431 ko/s)
Error: Timeout was reached
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
264 paquets peuvent être mis à jour. Exécutez « apt list --upgradable » pour les voir.
root@kubuntu:/# apt  install grub-efi-ia32    grub-efi-ia32-bin
et la sa se fige,

kubuntu@kubuntu:~$ sudo blkid | grep vfat
/dev/sda1: UUID="14DE-1D8D" TYPE="vfat" PARTLABEL="EFI System Partition" PARTUUID="90ea34d4-5759-47ff-ace5-80ff50a56698"
/dev/sdb1: LABEL_FATBOOT="Windows USB" LABEL="Windows USB" UUID="E5A4-CF67" TYPE="vfat" PARTUUID="8f11075a-01"
/dev/sdc1: UUID="141D-556B" TYPE="vfat" PARTUUID="000742e8-01"
kubuntu@kubuntu:~$ sudo mount -v /dev/sda1 /mnt 
mount: /dev/sda1 mounted on /mnt.
kubuntu@kubuntu:~$ sudo mv -v /mnt/efi/Boot/bootx64.efi /mnt/efi/Boot/Bootx64$(07/01/2019"-%Y-%m-%d-%H-%M-%S").efi
bash: 07/01/2019-%Y-%m-%d-%H-%M-%S: No such file or directory
mv: '/mnt/efi/Boot/bootx64.efi' and '/mnt/efi/Boot/Bootx64.efi' are the same file
kubuntu@kubuntu:~$ sudo cp -Rv /mnt/efi/refind/* /mnt/efi/Boot
'/mnt/efi/refind/BOOT.CSV' -> '/mnt/efi/Boot/BOOT.CSV'
kubuntu@kubuntu:~$ sudo cp -v /mnt/efi/Boot/refind_x64.efi /mnt/efi/Boot/bootx64.efi
'/mnt/efi/Boot/refind_x64.efi' -> '/mnt/efi/Boot/bootx64.efi'
L’ordi plante à la commande suivante.

Et refind avec windows :
PS S:\EFI\refind> copy refind.conf-sample refind.conf
PS S:\EFI\refind> bcdedit /copy '{current}' /d 'Refind'
Une erreur s’est produite lors de la tentative d’opération de copie spécifiée.
Ressources système insuffisantes pour terminer le service demandé.
L’installation s’arrête la.

Merci pour le temps passé à décrypter tout ça, j’espère que les connaisseurs apprécieront.

Hors ligne

#9 Le 08/10/2019, à 22:02

cqfd93

Re : Ubuntu ne demare pas sur un acer aspire ES1-732 tout neuf

Modération

Bonjour,

Pour ajouter toi-même les balises code à ton message #8 :

  • Cliquer sur le lien « Modifier » en bas à droite du message

  • Sélectionner le texte

  • Cliquer sur le <> de l'éditeur de message
    1471986854.png


cqfd93

Hors ligne

#10 Le 09/10/2019, à 00:29

geole

Re : Ubuntu ne demare pas sur un acer aspire ES1-732 tout neuf

Bonsoir.
J'al lu de tes explications.
As-tu essayé de booter aprés l'installation de refind?
Si c'est encore windows qui a mis en route, cela signifie que le bios est bridé sur windows
Ce qui génère probablement l'incident que tu décris

PS S:\EFI\refind> bcdedit /copy '{current}' /d 'Refind'
Une erreur s’est produite lors de la tentative d’opération de copie spécifiée

Donc, tu fais  ce qui est indiqué au paragraphe 6.9 de refind. Refind sera alors substitué à windows mais saura le détecter pour le proposer au boot.

Le boot-info indique que la structure /boot n'a même pas été créée pour la version 19.04.
Le plus simple est de recommencer l'installation en appliquant la consigne du paragraphe 7.1 de refind


ATTENTION
J'ai vu ce message
root@kubuntu:/# apt  install grub-efi-ia32    grub-efi-ia32-bin
et la sa se fige,

Si tu n'as rien modifé pour booter avec ton support d'installation, ce n'est pas la version 32 bits mais bien la version 64 bits qu'il faut utiliser.
Je te signale que la version 19.10 est disponible http://cdimage.ubuntu.com/kubuntu/releases/19.10/beta/

Dernière modification par geole (Le 09/10/2019, à 00:40)

En ligne

#11 Le 09/10/2019, à 05:55

ikewdu

Re : Ubuntu ne demare pas sur un acer aspire ES1-732 tout neuf

Salut,

Et visiblement, Ubuntu est installé en Legacy et non en uefi :

kubuntu@kubuntu:~$ sudo dpkg -P --force-all grub-efi-amd64-signed
dpkg: avertissement: requête ignorée : suppression de grub-efi-amd64-signed, qui n'est pas installé

ii  grub-pc               2.02+dfsg1-12ubuntu2 amd64        GRand Unified Bootloader, ve
ii  grub-pc-bin           2.02+dfsg1-12ubuntu2 amd64        GRand Unified Bootloader, ve

2      538MB   1538MB  1000MB  ext4                                          bios_grub

Dernière modification par ikewdu (Le 09/10/2019, à 05:57)

Hors ligne

#12 Le 14/10/2019, à 10:10

savaparigole

Re : Ubuntu ne demare pas sur un acer aspire ES1-732 tout neuf

Bonjour.

Après quelques hésitations et erreurs de manipulations, j'ai tout désinstaller, réinstaller avec "ubiquity -b puis Refind ..... et .... ça fonctionne, même si la prise en main de Rufind n'est pas immédiate ( petit détail).


Grand merci à tous pour l'attention l'aide efficace que vous m'avez apportée.

Hors ligne