Contenu | Rechercher | Menus

Annonce

DVD, clés USB et t-shirts Ubuntu-fr disponibles sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 08/05/2021, à 11:46

Neelix

[Résolu] Surround 5.1 - Pas de sont sur la sortie front-center

Bonjour,

Une fois de plus, je sollicite l'aide de la communauté Ubuntu.

Après un:

speaker-test 1.1.3

Le périphérique de lecture est plug:surround51
Les paramètres du flux sont 48000Hz, S16_LE, 6 canaux
fichier(s) WAV
La fréquence est 48000Hz (demandée 48000Hz)
L'intervalle de la taille du tampon est de 64 à 5440
L'intervalle de la taille de la période est de 32 à 2720
Taille max. de tampon 5440 utilisée
Périodes = 4
La durée de la période à été définie= 1088
La taille du tampon à été définie = 5440
 0 - Front Left
 4 - Front Center
 1 - Front Right
 3 - Rear Right
 2 - Rear Left
 5 - LFE
Temps par période = 8,534825

Je m'aperçois qu'aucun son ne sort sur front-center.

Tous les canaux sont bien présentes et actifs (pas en "Mute") dans alsamixer et pavucontrol.

Voici mes paramètres.

Pour /etc/pulse/daemon.conf:

resample-method = src-sinc-best-quality
; avoid-resampling = false
enable-remixing = yes
remixing-use-all-sink-channels = yes
enable-lfe-remixing = yes
; lfe-crossover-freq = 0

Pour ~/.asoundrc:

pcm.a52 {
    @args [ CARD ]
    @args.CARD {
               type string
               default 0
    }
    type plug
    slave {
           pcm {
               type a52
               channels 6
               bitrate 640
               rate 48000
               card $CARD
           }
    }
hint.show on
hint.description "encodage Dolby Surround avec a52"
}

Pour /etc/pulse/default.pa:
:

.fail

### Automatically restore the volume of streams and devices
load-module module-device-restore
load-module module-stream-restore
load-module module-card-restore

### Automatically augment property information from .desktop files
### stored in /usr/share/application
load-module module-augment-properties

### Should be after module-*-restore but before module-*-detect
load-module module-switch-on-port-available

### Use hot-plugged devices like Bluetooth or USB automatically (LP: #1702794)
.ifexists module-switch-on-connect.so
load-module module-switch-on-connect
.endif

### Load audio drivers statically
### (it's probably better to not load these drivers manually, but instead
### use module-udev-detect -- see below -- for doing this automatically)
#load-module module-alsa-sink device=hw:0,0 tsched=0
#load-module module-alsa-source device=hw:0,0
#load-module module-oss device="/dev/dsp" sink_name=output source_name=input
#load-module module-oss-mmap device="/dev/dsp" sink_name=output source_name=input
#load-module module-null-sink
#load-module module-pipe-sink

### Automatically load driver modules depending on the hardware available
.ifexists module-udev-detect.so
load-module module-udev-detect tsched=0
.else
### Use the static hardware detection module (for systems that lack udev support)
load-module module-detect
.endif

### Automatically connect sink and source if JACK server is present
.ifexists module-jackdbus-detect.so
.nofail
load-module module-jackdbus-detect channels=2
.fail
.endif

### Automatically load driver modules for Bluetooth hardware
.ifexists module-bluetooth-policy.so
load-module module-bluetooth-policy
.endif

.ifexists module-bluetooth-discover.so
load-module module-bluetooth-discover
.endif

### Load several protocols
.ifexists module-esound-protocol-unix.so
load-module module-esound-protocol-unix
.endif
load-module module-native-protocol-unix

### Network access (may be configured with paprefs, so leave this commented
### here if you plan to use paprefs)
#load-module module-esound-protocol-tcp
#load-module module-native-protocol-tcp
#load-module module-zeroconf-publish

### Load the RTP receiver module (also configured via paprefs, see above)
#load-module module-rtp-recv

### Load the RTP sender module (also configured via paprefs, see above)
#load-module module-null-sink sink_name=rtp format=s16be channels=2 rate=44100 sink_properties="device.description='RTP Multicast Sink'"
#load-module module-rtp-send source=rtp.monitor

### Load additional modules from GConf settings. This can be configured with the paprefs tool.
### Please keep in mind that the modules configured by paprefs might conflict with manually
### loaded modules.
.ifexists module-gconf.so
.nofail
load-module module-gconf
.fail
.endif

### Automatically restore the default sink/source when changed by the user
### during runtime
### NOTE: This should be loaded as early as possible so that subsequent modules
### that look up the default sink/source get the right value
load-module module-default-device-restore

### Automatically move streams to the default sink if the sink they are
### connected to dies, similar for sources
load-module module-rescue-streams

### Make sure we always have a sink around, even if it is a null sink.
load-module module-always-sink

### Honour intended role device property
load-module module-intended-roles

### Automatically suspend sinks/sources that become idle for too long
load-module module-suspend-on-idle

### If autoexit on idle is enabled we want to make sure we only quit
### when no local session needs us anymore.
.ifexists module-console-kit.so
load-module module-console-kit
.endif
.ifexists module-systemd-login.so
load-module module-systemd-login
.endif

### Enable positioned event sounds
load-module module-position-event-sounds

### Cork music/video streams when a phone stream is active
load-module module-role-cork

### Block audio recording for snap confined packages unless they have
### the "pulseaudio" or "audio-record" interfaces plugged.
.ifexists module-snap-policy.so
load-module module-snap-policy
.endif

### Modules to allow autoloading of filters (such as echo cancellation)
### on demand. module-filter-heuristics tries to determine what filters
### make sense, and module-filter-apply does the heavy-lifting of
### loading modules and rerouting streams.
load-module module-filter-heuristics
load-module module-filter-apply

### Make some devices default
#set-default-sink output
#set-default-source input

load-module module-equalizer-sink
load-module module-dbus-protocol

Dernière modification par Neelix (Le 10/05/2021, à 13:06)


Xubuntu 18.04 Bionic x64
AMD Phenom II X4 955: 3,2GHz - RAM: 8Go
Gfx: NVidia Geforce GTX 550 Ti - 1Go
Audio: High Definition Audio Realtek ALC892 8 canaux

Hors ligne

#2 Le 08/05/2021, à 11:53

xubu1957

Re : [Résolu] Surround 5.1 - Pas de sont sur la sortie front-center

Bonjour,

Fournis les cartes sons :

lspci | grep [Aa]udio && lsusb | grep [Aa]udio

et :

cat /proc/asound/pcm
sudo fuser -v /dev/snd/*

Depuis un terminal, dont au préalable la fenêtre est élargie, afin de ne pas tronquer l'image, montre :

alsamixer

Voir les exemples > du message #6


Conseils pour les nouveaux demandeurs et pas qu'eux
Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.                   Membre de Linux-Azur

Hors ligne

#3 Le 08/05/2021, à 12:24

Neelix

Re : [Résolu] Surround 5.1 - Pas de sont sur la sortie front-center

Bonjour xubu1957 et merci de venir à mon secours. Voilà les sorties que tu m'as demandé:

neelix@cochrane:~$ lspci | grep [Aa]udio && lsusb | grep [Aa]udio
00:14.2 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] SBx00 Azalia (Intel HDA) (rev 40)
01:00.1 Audio device: NVIDIA Corporation GF116 High Definition Audio Controller (rev a1)
neelix@cochrane:~$ cat /proc/asound/pcm
00-00: ALC892 Analog : ALC892 Analog : playback 1 : capture 1
00-01: ALC892 Digital : ALC892 Digital : playback 1
00-02: ALC892 Alt Analog : ALC892 Alt Analog : capture 1
01-03: HDMI 0 : HDMI 0 : playback 1
01-07: HDMI 0 : HDMI 0 : playback 1
01-08: HDMI 0 : HDMI 0 : playback 1
01-09: HDMI 0 : HDMI 0 : playback 1
02-00: USB Audio : USB Audio : capture 1
sudo fuser -v /dev/snd/*
[sudo] Mot de passe de neelix : 
                     UTIL.       PID ACCÈS  COMMANDE
/dev/snd/controlC0:  neelix     2554 F.... pulseaudio
/dev/snd/controlC1:  neelix     2554 F.... pulseaudio

Et enfin alsamixer:
alsamixer.png


Xubuntu 18.04 Bionic x64
AMD Phenom II X4 955: 3,2GHz - RAM: 8Go
Gfx: NVidia Geforce GTX 550 Ti - 1Go
Audio: High Definition Audio Realtek ALC892 8 canaux

Hors ligne

#4 Le 08/05/2021, à 12:28

xubu1957

Re : [Résolu] Surround 5.1 - Pas de sont sur la sortie front-center

Sur ton image, je vois des flèches sur la droite, tu aurais d'autres colonnes ?

_ _ _

Pour les colonnes marquées MM, tente :

Au § 1.1 a écrit :

Utilisez les flèches gauche et droite pour naviguer, haut et bas pour augmenter/baisser le son et M pour activer/désactiver le mode silencieux (marqué "MM").

Doc > son_problemes#aucun_son_audible

Dernière modification par xubu1957 (Le 08/05/2021, à 12:32)


Conseils pour les nouveaux demandeurs et pas qu'eux
Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.                   Membre de Linux-Azur

Hors ligne

#5 Le 08/05/2021, à 14:40

Neelix

Re : [Résolu] Surround 5.1 - Pas de sont sur la sortie front-center

Sur ton image, je vois des flèches sur la droite, tu aurais d'autres colonnes ?

Effectivement, il y a une seconde colonne "Rear Mic", sans l'affichage du niveau de volume.

Pour les colonnes marquées MM

J'ai augmenté le volume et désactivé le mode silencieux pour toutes les colonnes, mais ça ne change rien.


Xubuntu 18.04 Bionic x64
AMD Phenom II X4 955: 3,2GHz - RAM: 8Go
Gfx: NVidia Geforce GTX 550 Ti - 1Go
Audio: High Definition Audio Realtek ALC892 8 canaux

Hors ligne

#6 Le 08/05/2021, à 14:53

xubu1957

Re : [Résolu] Surround 5.1 - Pas de sont sur la sortie front-center

Pour :

speaker-test -Dplug:surround51 -c6 -l1 -twav

un retour ?

> § 3 son surround 4.1- 5.1-7.1

_ _ _

Montre aussi d'éventuels paquets cassés :

dpkg -l | grep -v ^ii

Tente cette commande, pour les permissions :

moko138 a écrit :

Merci de montrer :

echo -e "\n\tNombre d'éléments de /home/moi ne m'appartenant pas :"; find ~ \( ! -user $USER -o ! -group $USER \) | wc -l

Dernière modification par xubu1957 (Le 08/05/2021, à 15:05)


Conseils pour les nouveaux demandeurs et pas qu'eux
Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.                   Membre de Linux-Azur

Hors ligne

#7 Le 08/05/2021, à 16:32

Neelix

Re : [Résolu] Surround 5.1 - Pas de sont sur la sortie front-center

Pour:

neelix@cochrane:~$ speaker-test -Dplug:surround51 -c6 -l1 -twav

speaker-test 1.1.3

Le périphérique de lecture est plug:surround51
Les paramètres du flux sont 48000Hz, S16_LE, 6 canaux
fichier(s) WAV
La fréquence est 48000Hz (demandée 48000Hz)
L'intervalle de la taille du tampon est de 64 à 5440
L'intervalle de la taille de la période est de 32 à 2720
Taille max. de tampon 5440 utilisée
Périodes = 4
La durée de la période à été définie= 1088
La taille du tampon à été définie = 5440
 0 - Front Left
 4 - Front Center
 1 - Front Right
 3 - Rear Right
 2 - Rear Left
 5 - LFE
Temps par période = 8,531733

J'ai le même retour que précédemment et toujours le central qui ne marche pas.

neelix@cochrane:~$ dpkg -l | grep -v ^ii
Souhait=inconnU/Installé/suppRimé/Purgé/H=à garder
| État=Non/Installé/fichier-Config/dépaqUeté/échec-conFig/H=semi-installé/W=attend-traitement-déclenchements
|/ Err?=(aucune)/besoin Réinstallation (État,Err: majuscule=mauvais)
||/ Nom                                                              Version                                                            Architecture Description
+++-================================================================-==================================================================-============-===============================================================================================================================================================================
ic  edrawmax                                                         10.0.4                                                             amd64        All-in-one diagramming software.
rc  libsasl2-modules:i386                                            2.1.27~101-g0780600+dfsg-3ubuntu2.3                                i386         Cyrus SASL - pluggable authentication modules
rc  libsnmp-dev                                                      5.7.3+dfsg-1.8ubuntu3.6                                            amd64        SNMP (Simple Network Management Protocol) development files
rc  libssl1.1:i386                                                   1.1.1i-1+ubuntu18.04.1+deb.sury.org+4                              i386         Secure Sockets Layer toolkit - shared libraries
rc  linux-image-4.15.0-109-generic                                   4.15.0-109.110                                                     amd64        Signed kernel image generic
rc  linux-modules-4.15.0-109-generic                                 4.15.0-109.110                                                     amd64        Linux kernel extra modules for version 4.15.0 on 64 bit x86 SMP
rc  linux-modules-extra-4.15.0-109-generic                           4.15.0-109.110                                                     amd64        Linux kernel extra modules for version 4.15.0 on 64 bit x86 SMP
echo -e "\n\tNombre d'éléments de /home/neelix ne m'appartenant pas :"; find ~ \( ! -user $USER -o ! -group $USER \) | wc -l

	Nombre d'éléments de /home/neelix ne m'appartenant pas :
find: ‘/home/neelix/.nv/ComputeCache/5/f’: Permission non accordée
find: ‘/home/neelix/.cache/doc’: Permission non accordée
find: ‘/home/neelix/.cache/dconf’: Permission non accordée
find: ‘/home/neelix/.gvfs’: Permission non accordée
find: ‘/home/neelix/.cpan/build/SGML-Parser-OpenSP-0.994-1/samples’: Permission non accordée
find: ‘/home/neelix/.cpan/build/SGML-Parser-OpenSP-0.994-1/t’: Permission non accordée
find: ‘/home/neelix/.cpan/build/SGML-Parser-OpenSP-0.994-1/lib’: Permission non accordée
find: ‘/home/neelix/.cpan/build/SGML-Parser-OpenSP-0.994-1/eg’: Permission non accordée
find: ‘/home/neelix/.cpan/build/HTML-Encoding-0.61-1/t’: Permission non accordée
find: ‘/home/neelix/.cpan/build/HTML-Encoding-0.61-1/tinput’: Permission non accordée
find: ‘/home/neelix/.cpan/build/HTML-Encoding-0.61-1/lib’: Permission non accordée
find: ‘/home/neelix/.cpan/build/HTML-Encoding-0.61-1/eg’: Permission non accordée
find: ‘/home/neelix/.dbus’: Permission non accordée
7484

Xubuntu 18.04 Bionic x64
AMD Phenom II X4 955: 3,2GHz - RAM: 8Go
Gfx: NVidia Geforce GTX 550 Ti - 1Go
Audio: High Definition Audio Realtek ALC892 8 canaux

Hors ligne

#8 Le 08/05/2021, à 16:56

xubu1957

Re : [Résolu] Surround 5.1 - Pas de sont sur la sortie front-center

Permission non accordée
7484

Pour les permissions, tu as dans ce message > les explications de moko138


Conseils pour les nouveaux demandeurs et pas qu'eux
Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.                   Membre de Linux-Azur

Hors ligne

#9 Le 09/05/2021, à 10:29

Neelix

Re : [Résolu] Surround 5.1 - Pas de sont sur la sortie front-center

J'ai modifié les permissions, voilà la sortie:

echo -e "\n\tNombre d'éléments de /home/neelix ne m'appartenant pas :"; find ~ \( ! -user $USER -o ! -group $USER \) | wc -l

	Nombre d'éléments de /home/neelix ne m'appartenant pas :
0

Mais le problème persiste.


Xubuntu 18.04 Bionic x64
AMD Phenom II X4 955: 3,2GHz - RAM: 8Go
Gfx: NVidia Geforce GTX 550 Ti - 1Go
Audio: High Definition Audio Realtek ALC892 8 canaux

Hors ligne

#10 Le 09/05/2021, à 10:32

xubu1957

Re : [Résolu] Surround 5.1 - Pas de sont sur la sortie front-center

Bonjour,

Tu devrais demander sur le forum spécialisé linuxmao.org

                                                                            ↓↓↓↓↓↓

    La discussion > Son 5.1 - Pas de sortie sur front-center

Dernière modification par xubu1957 (Le 09/05/2021, à 12:16)


Conseils pour les nouveaux demandeurs et pas qu'eux
Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.                   Membre de Linux-Azur

Hors ligne

#11 Le 09/05/2021, à 11:00

Neelix

Re : [Résolu] Surround 5.1 - Pas de sont sur la sortie front-center

Je vais aller y faire un tour. Merci du conseil.


Xubuntu 18.04 Bionic x64
AMD Phenom II X4 955: 3,2GHz - RAM: 8Go
Gfx: NVidia Geforce GTX 550 Ti - 1Go
Audio: High Definition Audio Realtek ALC892 8 canaux

Hors ligne

#12 Le 10/05/2021, à 09:13

bonuscad

Re : [Résolu] Surround 5.1 - Pas de sont sur la sortie front-center

Dans alsamixer, tu ne serais pas sur la mauvaise puce  pour ouvrir les canaux?
Dans celui-ci faire F6 pour changer de carte son et voir les réglages actif sur l'autre carte vu que tu en as deux:

neelix@cochrane:~$ lspci | grep [Aa]udio && lsusb | grep [Aa]udio
00:14.2 Audio device: Advanced Micro Devices, Inc. [AMD/ATI] SBx00 Azalia (Intel HDA) (rev 40)
01:00.1 Audio device: NVIDIA Corporation GF116 High Definition Audio Controller (rev a1)

Hors ligne

#13 Le 10/05/2021, à 13:05

Neelix

Re : [Résolu] Surround 5.1 - Pas de sont sur la sortie front-center

J'ai enfin réglé mon problème. Il se situait au niveau matériel. C'était le câble qui reliait la sortie central/subwoofer à mon home cinema qui était défectueux. Du coup, des recherches dans le vide pour rien. roll


Xubuntu 18.04 Bionic x64
AMD Phenom II X4 955: 3,2GHz - RAM: 8Go
Gfx: NVidia Geforce GTX 550 Ti - 1Go
Audio: High Definition Audio Realtek ALC892 8 canaux

Hors ligne