Contenu | Rechercher | Menus

Annonce

DVD, clés USB et t-shirts Ubuntu-fr disponibles sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#26 Le 11/10/2021, à 19:44

grigouille

Re : Imprimante HP pro m479fdw - 16.4 LTS vers 20.4 LTS

arvernes a écrit :
HP Linux Imaging and Printing System (ver. 0.0.0)

Aucune chance avec cette version.

Tu n'as donné aucun retour de commande de la désinstallation d'hplip. Dommage.
La doc hplip te dit comment il faut faire.


Xubuntu 20.04
HP LaserJet M1132 MFP

Hors ligne

#27 Le 11/10/2021, à 19:50

arvernes

Re : Imprimante HP pro m479fdw - 16.4 LTS vers 20.4 LTS

Ah excuse moi. Je l'ai désinstallé en me mettant dans le répertoire hplip-3.21.8 et j'ai lancé sudo ./uninstall.py , ensuite ça à tourné et il m'a dit que tout était désinstallé.

Là j'ai même désinstallé via synaptic hplip hplip data et gui, et j'ai réinstallé ces trois fichiers. et bien que dalle. Il ne me propose plus d'installer via net

Un autre truc, si ça peut servir, j'ai essayé de lancer hp-toolbox et bien j'ai droit à ce message :

Traceback (most recent call last):
  File "/usr/bin/hp-toolbox", line 269, in <module>
    QApplication, ui_package = utils.import_dialog(ui_toolkit)
TypeError: cannot unpack non-iterable NoneType object

Dernière modification par arvernes (Le 11/10/2021, à 20:09)

Hors ligne

#28 Le 11/10/2021, à 21:12

ylag

Re : Imprimante HP pro m479fdw - 16.4 LTS vers 20.4 LTS

Bonsoir,

arvernes a écrit :

Je l'ai désinstallé en me mettant dans le répertoire hplip-3.21.8 et j'ai lancé sudo ./uninstall.py , ensuite ça à tourné et il m'a dit que tout était désinstallé.

Tu n'as pas suivi la procédure de la doc, au §8 : 8. Désinstaller la dernière version de HPLIP
Une fois le sudo make uninstall exécuté, il semble qu'il faille ensuite supprimer manuellement quelques répertoires pour compléter la désinstallation ?

Sauf erreur de ma part, le script python uninstall.py serait utilisé par l'installeur du .run pour supprimer une éventuelle version de hplip déjà présente, installée à partir des dépôts ?

Ajout :
Concernant le fichier models.dat, c'est installé via le paquet libsane-hpaio à l'emplacement /usr/share/hplip/data/models/models.dat lorsque tu installes la version des dépôts de hplip.
Le hplip-8.run en fournit un de son cru, je crois que l'installeur du .run supprime le paquet libsane-hpaio durant la procédure ; le fichier installé par le .run pourrait ne pas se retrouver au même endroit...

A+

Dernière modification par ylag (Le 11/10/2021, à 21:28)

Hors ligne

#29 Le 12/10/2021, à 05:40

arvernes

Re : Imprimante HP pro m479fdw - 16.4 LTS vers 20.4 LTS

Effectivement je n'ai pas suivi la procédure du wiki, mais je m'étais dit, vu que pour l'installation je n'avais pas suivi non plus (je n'avais pas vu que cette doc existait), j'ai préféré la procédure donnée pour la désinstallation qui suive celle de l'installation.
Suite à tout ça, j'ai fait une désinstallation totale de tous les paquets .deb relatifs à hplip et je les ai réinstallés dans l'espoir que cela supprime tous les fichiers de config, et bien sûr, ça ne fonctionne pas du tout. Dans la nuit, j'ai réinstallé le .run, et là par ex. le hp-setup ne me donne plus une version 0.0.0 mais une version 3.21.8 ce qui me semble un peu mieux. Bon ça ne marche pas mieux. Je veux bien désinstallé par le uninstall et enlever manuellement les quatre répertoires qui sont donnés, mais après faut-il que je réinstalle tous les paquets .deb hplib, ou faut-il que je désinstalle d'abord les paquets hplip et uniquement après le .run et les répertoires qui vont bien ? Je ne voudrais pas supprimer des répertoires qui m'empêcheraient par la suite de désinstaller les .deb.?

Je me demande aussi si il n'y a pas un truc qui déconne dans la config, vu qu'en Wifi direct, je peux imprimer. Je ne sais plus où aller chercher. Dès que j'aurais la possibilité de le faire, je ferai des essais en session live, mais il faut quand même que je cherche en attendant.

Comme je l'ai dit hier, j'ai suivi des tutos et notamment celui-ci, est-ce que cela a pu me mettre du bazard ? maintenant pour revenir en arrière ..?

Dernière modification par arvernes (Le 12/10/2021, à 05:51)

Hors ligne

#30 Le 12/10/2021, à 10:55

ylag

Re : Imprimante HP pro m479fdw - 16.4 LTS vers 20.4 LTS

Bonjour,

arvernes a écrit :

Bon ça ne marche pas mieux. Je veux bien désinstallé par le uninstall et enlever manuellement les quatre répertoires qui sont donnés, mais après faut-il que je réinstalle tous les paquets .deb hplib ...

La procédure d'installation du .run devrait se charger de supprimer automatiquement les paquets .deb relatifs à hplip.
Une fois le .run installé, je crois qu'une commande du genre de :

apt list --installed | grep hplip

...ne devrait donner aucun résultat.

Donc, si tu as installé puis désinstallé le .run en suivant bien la procédure de la doc, tu devrais pouvoir réinstaller le hplip des dépôts avec la commande :

sudo apt install hplip

Sinon, je ne sais pas concernant la config, désolé...

Ajout : Sur la 20.04, installer le paquet python-is-python3 semble faciliter les choses pour l'installation de hplip...

A+

Dernière modification par ylag (Le 12/10/2021, à 11:00)

Hors ligne

#31 Le 12/10/2021, à 14:42

arvernes

Re : Imprimante HP pro m479fdw - 16.4 LTS vers 20.4 LTS

Il m'en restait un finalement :

apt list --installed | grep hplip
WARNING: apt does not have a stable CLI interface. Use with caution in scripts.
hplip-data/focal,focal,now 3.20.3+dfsg0-2 all [installé, pouvant être supprimé automatiquement]

Au niveau de la désinstallation, il est mis de faire

sudo make uninstall

et bien ça ne marche pas, il faut simplement faire

sudo ./uninstall

Pour ce qui est de python-is-python3, oui, je l'avais déjà installé. D'ailleurs dommage que je n'avais pas vu ça avant, car ça m'aurait évité de faire tous les essais avec des tutos que j'ai vus sur youtube.
Dans la doc, il est dit de faire

sudo rm -rf /usr/share/hplip

, ça ne sert à rien car le sous-répertoire hplip n'existe plus.
Par contre j'ai bien supprimé comme il est dit répertoire /etc/hp, mais lors de l'install des paquets .deb de hplip, j'ai eu droit à

Creating/updating hplip user account...
Can't open /etc/hp/hplip.conf: Aucun fichier ou dossier de ce type.
Can't open /etc/hp/hplip.conf: Aucun fichier ou dossier de ce type.

donc j'aurais peut-être mieux fait de ne pas supprimer ce répertoire ;-(

Hors ligne

#32 Le 12/10/2021, à 15:01

ylag

Re : Imprimante HP pro m479fdw - 16.4 LTS vers 20.4 LTS

Bonjour,

Pour le répertoire /etc/hp el le fichier hplip.conf, il faut installer le paquet libsane-hpaio, qui est normalement installé comme une dépendance lorsque l'on installe le paquet hplip... hmm

Concernant les commandes de désinstallation, il aurait fallu voir le résultat des deux, sinon on tâtonne...

Se pourrait-il que sudo ./uninstall n'ait simplement relancé le scrip uninstall.py ?

Pour se faire une idée d'où tu en est, donne peut-être le résultat de :

dpkg -l | grep -E "hplip|sane"

A+

Dernière modification par ylag (Le 12/10/2021, à 15:20)

Hors ligne

#33 Le 12/10/2021, à 15:05

grigouille

Re : Imprimante HP pro m479fdw - 16.4 LTS vers 20.4 LTS

arvernes a écrit :
Creating/updating hplip user account...
Can't open /etc/hp/hplip.conf: Aucun fichier ou dossier de ce type.
Can't open /etc/hp/hplip.conf: Aucun fichier ou dossier de ce type.

Où est la commande ?


Xubuntu 20.04
HP LaserJet M1132 MFP

Hors ligne

#34 Le 12/10/2021, à 15:12

ylag

Re : Imprimante HP pro m479fdw - 16.4 LTS vers 20.4 LTS

Re,

grigouille a écrit :

Où est la commande ?

Bien d'accord avec @grigouille : Difficile de se faire une idée si tu ne donnes pas les commandes passées avec leur résultat.
Surtout que tu aurais fait une mise à niveau de la 16.04 vers la 20.04 - (As-tu passé par la 18.04 pour le faire ?) - un saut périlleux, pour le moins ! wink

A+

Dernière modification par ylag (Le 12/10/2021, à 15:15)

Hors ligne

#35 Le 12/10/2021, à 15:16

xubu1957

Re : Imprimante HP pro m479fdw - 16.4 LTS vers 20.4 LTS

+1

Le 29/03/2018, moko138 a écrit :

Un retour complet doit contenir toutes les lignes,
depuis celle, entière, de la commande
jusqu'à la ligne attendant la commande suivante
, exemple :

moi@mon-pc~$: ma-commande
son retour
moi@mon-pc~$:

Faute de quoi, il manque souvent à ceux qui tentent de t'aider des éléments essentiels.

(Plus de détails dans ce message-ci Retour utilisable de commande.)

Et si tu ne veux pas divulguer ton nom d'user, tu le remplaces par "toto" ou ce que tu veux.

_ _ _

@ylag

Le rallye > [Résolu] passage 16.4 LTS vers 20.4 LTS puis de 18.04 vers 20.04

Dernière modification par xubu1957 (Le 12/10/2021, à 15:18)


Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.

Xubuntu 20.04 LTS - Lenovo T410 -18.04.1 LTS Toshiba Satellite A300  Membre de Linux-Azur

En ligne

#36 Le 12/10/2021, à 15:24

arvernes

Re : Imprimante HP pro m479fdw - 16.4 LTS vers 20.4 LTS

J'ai fait ça

apt list --installed | grep hplip

. J'ai vu qu'il me restait un paquet data que j'ai supprimé à partir de synaptic. Ensuite j'ai fait

sudo apt install hplip

et dans la console j'ai vu ces deux messages d'erreur. J'avais vu lorsque j'ai désinstallé le .run qu'il me fallait sucrer ce répertoire /etc/hp, j'ai donc suivi la doc qu'on m'avait conseillée.
J'ai vraiment des trucs bizarres. L'ordi est un portable, et il y a plusieurs années j'avais installé une 1ère imprimante Brother (en suivant d'ailleurs ce qui est dit sur ce forum et ça avait super bien marché), ensuite, j'ai déménagé, et une nouvelle imprimante est arrivée, je l'ai installée aussi, sans pb (c'était une HP). Depuis, rechangement, et j'ai cette nouvelle imprimante. Je n'ai pas sucré les anciennes, car parfois je retourne dans ces endroits, et j'ai besoin des imprimantes que j'avais installées.
J'ai toujours dans les paramètres - imprimantes, trois imprimantes (enfin deux plus fax), et parfois je vois une 4ème qui s'affiche, et qui disparait, c'est l'imprimante que j'essaie d'installer. Si sur cette 4ème imprimante qui s'affiche je veux en faire mon imprimante par défaut, ça freeze. il ne se passe rien et je suis obligé de "killer". Si je clique sur "paramètres d'imprimante supplémentaire", soit, ça freeze, donc je suis obligé de "killer", soit au bout d'un temps certain ça s'affiche, et je n'ai que 3 imprimantes (2 + fax). Si je veux en rajouter une, ça freeze. Parfois dans "Paramètres - Imprimantes", au lieu d'avoir mes 3 ou parfois 4 imprimantes, je n'en ai plus, et il me met un message du genre "service d'impression indisponible etc...." . Là je viens de réinstaller tous les paquets que j'avais déja installés contenant "cups", ça n'a rien changé. C'est la panade la plus complète.

Hors ligne

#37 Le 12/10/2021, à 15:26

arvernes

Re : Imprimante HP pro m479fdw - 16.4 LTS vers 20.4 LTS

Le 29/03/2018, moko138 a écrit :

Un retour complet doit contenir toutes les lignes,
depuis celle, entière, de la commande
jusqu'à la ligne attendant la commande suivante
,

Je n'avais pas fait ça, pour ne pas encombrer mais bon à l'avenir, copy/paste de la totalité. Ok pas de pb

Hors ligne

#38 Le 12/10/2021, à 15:28

ylag

Re : Imprimante HP pro m479fdw - 16.4 LTS vers 20.4 LTS

Re,

Que se passe-il si tu tentes :

sudo apt install libsane-hpaio hplip

Donne le résultat complet de la commande.

Je continue à croire que la désinstallation du hplip en .run aurait echoué.

A+

Dernière modification par ylag (Le 12/10/2021, à 15:31)

Hors ligne

#39 Le 12/10/2021, à 15:30

arvernes

Re : Imprimante HP pro m479fdw - 16.4 LTS vers 20.4 LTS

sudo apt install libsane-hpaio hplip
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
hplip est déjà la version la plus récente (3.20.3+dfsg0-2).
libsane-hpaio est déjà la version la plus récente (3.20.3+dfsg0-2).
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  libllvm11 libpython2-dev libpython2.7-dev python2-dev python2.7-dev
  qml-module-qtquick-controls qml-module-qtquick-dialogs
  qml-module-qtquick-privatewidgets
Veuillez utiliser « sudo apt autoremove » pour les supprimer.
0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
dpkg -l | grep -E "hplip|sane"
ii  hplip                                         3.20.3+dfsg0-2                              amd64        HP Linux Printing and Imaging System (HPLIP)
ii  hplip-data                                    3.20.3+dfsg0-2                              all          HP Linux Printing and Imaging - data files
rc  hplip-gui                                     3.20.3+dfsg0-2                              all          HP Linux Printing and Imaging - GUI utilities (Qt-based)
ii  libsane:amd64                                 1.0.29-0ubuntu5.2                           amd64        API library for scanners
ii  libsane-common                                1.0.29-0ubuntu5.2                           all          API library for scanners -- documentation and support files
ii  libsane-dev:amd64                             1.0.29-0ubuntu5.2                           amd64        API development library for scanners [development files]
ii  libsane-hpaio:amd64                           3.20.3+dfsg0-2                              amd64        HP SANE backend for multi-function peripherals
ii  sane-utils                                    1.0.29-0ubuntu5.2                           amd64        API library for scanners -- utilities
ii  xsane                                         0.999-8ubuntu2.1                            amd64        featureful graphical frontend for SANE (Scanner Access Now Easy)
ii  xsane-common                                  0.999-8ubuntu2.1                            all          xsane architecture independent files

Dernière modification par arvernes (Le 12/10/2021, à 15:41)

Hors ligne

#40 Le 12/10/2021, à 15:41

ylag

Re : Imprimante HP pro m479fdw - 16.4 LTS vers 20.4 LTS

Re,

Ah! Ça semble correct au niveau de l'installation de ces deux paquets.

À ce stade, si tu n'as pas /etc/hp/hplip.conf, tente peut-être :

sudo apt install --reinstall libsane-hpaio

...si ça ne fonctionne pas pour rétablir ce fichier, il te faudra purger l'installation actuelle du paquet et le réinstaller, ce qui implique de prendre en note toutes les dépendances qui seront emportées dans la manip pour pouvoir les réinstaller manuellement si requis :

sudo apt purge libsane-hpaio

...s'assurer de noter les dépendances emportées avec libsane-hpaio, puis réinstaller :

sudo apt install libsane-hpaio

...vérifier que les autres paquets désinstallés soient bien réinstallés avec libsane-hpaio, sinon les réinstaller manuellement.

A+

Dernière modification par ylag (Le 12/10/2021, à 15:47)

Hors ligne

#41 Le 12/10/2021, à 15:49

arvernes

Re : Imprimante HP pro m479fdw - 16.4 LTS vers 20.4 LTS

J'ai fait la réinstallation, et ça n'a pas mis le fichier hplip.conf.

résultat de la commande suivante :

sudo apt purge libsane-hpaio
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  hplip-data libhpmud0 libllvm11 libpython2-dev libpython2.7-dev printer-driver-hpcups printer-driver-postscript-hp python2-dev python2.7-dev qml-module-qtquick-controls
  qml-module-qtquick-dialogs qml-module-qtquick-privatewidgets
Veuillez utiliser « sudo apt autoremove » pour les supprimer.
Les paquets suivants seront ENLEVÉS :
  hplip* libsane-hpaio*
0 mis à jour, 0 nouvellement installés, 2 à enlever et 0 non mis à jour.
Après cette opération, 2086 ko d'espace disque seront libérés.
Souhaitez-vous continuer ? [O/n] 
(Lecture de la base de données... 258338 fichiers et répertoires déjà installés.)
Suppression de hplip (3.20.3+dfsg0-2) ...
Suppression de libsane-hpaio:amd64 (3.20.3+dfsg0-2) ...
Traitement des actions différées (« triggers ») pour dbus (1.12.16-2ubuntu2.1) ...
Traitement des actions différées (« triggers ») pour man-db (2.9.1-1) ...
(Lecture de la base de données... 258267 fichiers et répertoires déjà installés.)
Purge des fichiers de configuration de hplip (3.20.3+dfsg0-2) ...
Purge des fichiers de configuration de libsane-hpaio:amd64 (3.20.3+dfsg0-2) ...
Traitement des actions différées (« triggers ») pour dbus (1.12.16-2ubuntu2.1) ...
sh: 0: getcwd() failed: No such file or directory

Je ne sais pas ce que veut dire cette dernière ligne...

je retrouve cette même ligne dans la commande de réinstallation. Là il me remet bien les deux fichiers qu'il avait supprimés

sudo apt install libsane-hpaio
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances       
Lecture des informations d'état... Fait
Les paquets suivants ont été installés automatiquement et ne sont plus nécessaires :
  libllvm11 libpython2-dev libpython2.7-dev python2-dev python2.7-dev qml-module-qtquick-controls qml-module-qtquick-dialogs qml-module-qtquick-privatewidgets
Veuillez utiliser « sudo apt autoremove » pour les supprimer.
Les paquets supplémentaires suivants seront installés : 
  hplip
Paquets suggérés :
  hplip-doc hplip-gui
sh: 0: getcwd() failed: No such file or directory
Les NOUVEAUX paquets suivants seront installés :
  hplip libsane-hpaio
sh: 0: getcwd() failed: No such file or directory
0 mis à jour, 2 nouvellement installés, 0 à enlever et 0 non mis à jour.
sh: 0: getcwd() failed: No such file or directory
Il est nécessaire de prendre 0 o/330 ko dans les archives.
Après cette opération, 2086 ko d'espace disque supplémentaires seront utilisés.
Souhaitez-vous continuer ? [O/n] 
sh: 0: getcwd() failed: No such file or directory
sh: 0: getcwd() failed: No such file or directory
sh: 0: getcwd() failed: No such file or directory
Sélection du paquet libsane-hpaio:amd64 précédemment désélectionné.
(Lecture de la base de données... 258263 fichiers et répertoires déjà installés.)
Préparation du dépaquetage de .../libsane-hpaio_3.20.3+dfsg0-2_amd64.deb ...
Dépaquetage de libsane-hpaio:amd64 (3.20.3+dfsg0-2) ...
Sélection du paquet hplip précédemment désélectionné.
Préparation du dépaquetage de .../hplip_3.20.3+dfsg0-2_amd64.deb ...
Dépaquetage de hplip (3.20.3+dfsg0-2) ...
Paramétrage de libsane-hpaio:amd64 (3.20.3+dfsg0-2) ...
Paramétrage de hplip (3.20.3+dfsg0-2) ...
Creating/updating hplip user account...
Traitement des actions différées (« triggers ») pour dbus (1.12.16-2ubuntu2.1) ...
Traitement des actions différées (« triggers ») pour man-db (2.9.1-1) ...
sh: 0: getcwd() failed: No such file or directory

Mais au moins, j'ai retrouvé un fichier hplip.conf dans /etc/hp

Hors ligne

#42 Le 12/10/2021, à 15:58

ylag

Re : Imprimante HP pro m479fdw - 16.4 LTS vers 20.4 LTS

Bonjour,

Pour ces erreurs :

sh: 0: getcwd() failed: No such file or directory

Une recherche rapide sur le net semble pointer vers le fait que tu aurais lancé les commandes à partir d'un répertoire supprimé ?
Tu n'as pas inclus l'invite de commande dans tes résultats, on ne peut voir à partir de quel répertoire elles ont été lancées...

Une ancienne discussion à ce sujet (j'y comprends que dalle, mais bon...) :
[résolu]Message d'erreur à l'utilisation de la commande 'service'

Sinon, ça ne semblerait pas bloquant ?

A+

Dernière modification par ylag (Le 12/10/2021, à 16:01)

Hors ligne

#43 Le 12/10/2021, à 17:15

arvernes

Re : Imprimante HP pro m479fdw - 16.4 LTS vers 20.4 LTS

Oups effectivement, c'était à partir d'un répertoire supprimé.

Hors ligne

#44 Le 12/10/2021, à 17:50

ylag

Re : Imprimante HP pro m479fdw - 16.4 LTS vers 20.4 LTS

Bonsoir,

Arrives-tu maintenant à réinstaller ton imprimante ?

Si non, j'arrive à la limite de mes connaisances et il te faudra probablement relancer @abelthorne dans ton autre discussion, ou peut-être attendre et voir si @grigouille aura d'autres propositions à faire ?

A+

Dernière modification par ylag (Le 12/10/2021, à 17:53)

Hors ligne

#45 Le 12/10/2021, à 18:10

arvernes

Re : Imprimante HP pro m479fdw - 16.4 LTS vers 20.4 LTS

Merci beaucoup ylag, non, j'ai toujours droit à la même chose. Tout ce que j'ai écrit comme comportement bizarre, est toujours là :-( J'espère que quelqu'un arrivera à me trouver une solution. Encore une fois, merci à vous tous, qui donnez de votre temps pour aider.

Hors ligne

#46 Le 12/10/2021, à 18:15

arvernes

Re : Imprimante HP pro m479fdw - 16.4 LTS vers 20.4 LTS

xubu1957 m'avait conseillé de faire un hp-check. Si ça peut aider, voilà le résultat :

hp-check 
Saving output in log file: /home/fm/hp-check.log

HP Linux Imaging and Printing System (ver. 3.20.3)
Dependency/Version Check Utility ver. 15.1

Copyright (c) 2001-18 HP Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

Note: hp-check can be run in three modes:
1. Compile-time check mode (-c or --compile): Use this mode before compiling the
HPLIP supplied tarball (.tar.gz or .run) to determine if the proper dependencies
are installed to successfully compile HPLIP.                                    
2. Run-time check mode (-r or --run): Use this mode to determine if a distro    
supplied package (.deb, .rpm, etc) or an already built HPLIP supplied tarball   
has the proper dependencies installed to successfully run.                      
3. Both compile- and run-time check mode (-b or --both) (Default): This mode    
will check both of the above cases (both compile- and run-time dependencies).   

Check types:                                                                    
a. EXTERNALDEP - External Dependencies                                          
b. GENERALDEP - General Dependencies (required both at compile and run time)    
c. COMPILEDEP - Compile time Dependencies                                       
d. [All are run-time checks]                                                    
PYEXT SCANCONF QUEUES PERMISSION                                                

Status Types:
    OK
    MISSING       - Missing Dependency or Permission or Plug-in
    INCOMPAT      - Incompatible dependency-version or Plugin-version

warning: ubuntu-20.04 version is not supported. Using ubuntu-19.10 versions dependencies to verify and install...

---------------
| SYSTEM INFO |
---------------

 Kernel: 5.4.0-88-generic #99-Ubuntu SMP Thu Sep 23 17:29:00 UTC 2021 GNU/Linux
 Host: celtes15
 Proc: 5.4.0-88-generic #99-Ubuntu SMP Thu Sep 23 17:29:00 UTC 2021 GNU/Linux
 Distribution: ubuntu 20.04
 Bitness: 64 bit


-----------------------
| HPLIP CONFIGURATION |
-----------------------

HPLIP-Version: HPLIP 3.20.3
HPLIP-Home: /usr/share/hplip
warning: HPLIP-Installation: Auto installation is not supported for ubuntu distro  20.04 version 

Current contents of '/etc/hp/hplip.conf' file:
# hplip.conf.  Generated from hplip.conf.in by configure.

[hplip]
version=3.20.3

[dirs]
home=/usr/share/hplip
run=/var/run
ppd=/usr/share/ppd/hplip/HP
ppdbase=/usr/share/ppd/hplip
doc=/usr/share/doc/hplip
html=/usr/share/doc/hplip-doc
icon=no
cupsbackend=/usr/lib/cups/backend
cupsfilter=/usr/lib/cups/filter
drv=/usr/share/cups/drv
bin=/usr/bin
apparmor=/etc/apparmor.d
# Following values are determined at configure time and cannot be changed.
[configure]
network-build=yes
libusb01-build=no
pp-build=no
gui-build=yes
scanner-build=yes
fax-build=yes
dbus-build=yes
cups11-build=no
doc-build=yes
shadow-build=no
hpijs-install=yes
foomatic-drv-install=yes
foomatic-ppd-install=no
foomatic-rip-hplip-install=no
hpcups-install=yes
cups-drv-install=yes
cups-ppd-install=no
internal-tag=3.20.3
restricted-build=no
ui-toolkit=qt5
qt3=no
qt4=no
qt5=yes
policy-kit=yes
lite-build=no
udev_sysfs_rules=no
hpcups-only-build=no
hpijs-only-build=no
apparmor_build=no
class-driver=no


Current contents of '/var/lib/hp/hplip.state' file:
Plugins are not installed. Could not access file: No such file or directory

Current contents of '~/.hplip/hplip.conf' file:
[installation]
date_time = 10/12/21 19:12:34
version = 3.20.3


 <Package-name>        <Package-Desc>      <Required/Optional> <Min-Version> <Installed-Version> <Status>   <Comment>

-------------------------
| External Dependencies |
-------------------------

 error: cups          CUPS - Common Unix Printing System                           REQUIRED        1.1             -               INCOMPAT   'CUPS may not be installed or not running'
 gs                   GhostScript - PostScript and PDF language interpreter and previewer REQUIRED        7.05            9.50            OK         -
 xsane                xsane - Graphical scanner frontend for SANE                  OPTIONAL        0.9             0.999           OK         -
 scanimage            scanimage - Shell scanning program                           OPTIONAL        1.0             1.0.29          OK         -
 dbus                 DBus - Message bus system                                    REQUIRED        -               1.12.16         OK         -
 policykit            PolicyKit - Administrative policy framework                  OPTIONAL        -               0.105           OK         -
 network              network -wget                                                OPTIONAL        -               1.20.3          OK         -
 avahi-utils          avahi-utils                                                  OPTIONAL        -               0.7             OK         -

------------------------
| General Dependencies |
------------------------

 libjpeg              libjpeg - JPEG library                                       REQUIRED        -               -               OK         -
 cups-devel           CUPS devel- Common Unix Printing System development files    REQUIRED        -               -               OK         -
 cups-image           CUPS image - CUPS image development files                    REQUIRED        -               -               OK         -
 libpthread           libpthread - POSIX threads library                           REQUIRED        -               b'2.31'         OK         -
 libusb               libusb - USB library                                         REQUIRED        -               1.0             OK         -
 sane                 SANE - Scanning library                                      REQUIRED        -               -               OK         -
 sane-devel           SANE - Scanning library development files                    REQUIRED        -               -               OK         -
 libnetsnmp-devel     libnetsnmp-devel - SNMP networking library development files REQUIRED        5.0.9           5.8             OK         -
 libcrypto            libcrypto - OpenSSL cryptographic library                    REQUIRED        -               1.1.1           OK         -
 python3X             Python 2.2 or greater - Python programming language          REQUIRED        2.2             3.8.10          OK         -
 python3-notify2      Python libnotify - Python bindings for the libnotify Desktop notifications OPTIONAL        -               -               OK         -
 error: python3-pyqt4-dbus PyQt 4 DBus - DBus Support for PyQt4                         OPTIONAL        4.0             -               MISSING    'python3-pyqt4-dbus needs to be installed'
 error: python3-pyqt4 PyQt 4- Qt interface for Python (for Qt version 4.x)         REQUIRED        4.0             -               MISSING    'python3-pyqt4 needs to be installed'
 python3-dbus         Python DBus - Python bindings for DBus                       REQUIRED        0.80.0          1.2.16          OK         -
 python3-xml          Python XML libraries                                         REQUIRED        -               2.2.9           OK         -
 python3-devel        Python devel - Python development files                      REQUIRED        2.2             3.8.10          OK         -
 python3-pil          PIL - Python Imaging Library (required for commandline scanning with hp-scan) OPTIONAL        -               8.3.2           OK         -
 python3-reportlab    Reportlab - PDF library for Python                           OPTIONAL        2.0             3.6.1           OK         -

--------------
| COMPILEDEP |
--------------

 libtool              libtool - Library building support services                  REQUIRED        -               2.4.6           OK         -
 gcc                  gcc - GNU Project C and C++ Compiler                         REQUIRED        -               9.3.0           OK         -
 make                 make - GNU make utility to maintain groups of programs       REQUIRED        3.0             4.2.1           OK         -

---------------------
| Python Extentions |
---------------------

 cupsext              CUPS-Extension                                               REQUIRED        -               3.20.3          OK         -
 hpmudext             IO-Extension                                                 REQUIRED        -               3.20.3          OK         -

----------------------
| Scan Configuration |
----------------------

 hpaio                HPLIP-SANE-Backend                                           REQUIRED        -               3.20.3          OK         'hpaio found in /etc/sane.d/dll.conf'
 scanext              Scan-SANE-Extension                                          REQUIRED        -               3.20.3          OK         -

------------------------------
| DISCOVERED SCANNER DEVICES |
------------------------------

device `hpaio:/net/HP_LaserJet_300_colorMFP_M375nw?ip=192.168.0.22' is a Hewlett-Packard HP_LaserJet_300_colorMFP_M375nw all-in-one
device `escl:http://192.168.1.22:8080' is a ESCL HP Color LaserJet Pro M478f-9f [D68EE1] flatbed scanner
device `escl:https://192.168.1.22:443' is a ESCL HP Color LaserJet Pro M478f-9f [D68EE1] SSL flatbed scanner
device `hpaio:/net/HP_LaserJet_300_colorMFP_M375nw?ip=192.168.0.22' is a Hewlett-Packard HP_LaserJet_300_colorMFP_M375nw all-in-one
device `escl:http://192.168.1.22:8080' is a ESCL HP Color LaserJet Pro M478f-9f [D68EE1] flatbed scanner
device `escl:https://192.168.1.22:443' is a ESCL HP Color LaserJet Pro M478f-9f [D68EE1] SSL flatbed scanner


--------------------------
| DISCOVERED USB DEVICES |
--------------------------

No devices found.

---------------------------------
| INSTALLED CUPS PRINTER QUEUES |
---------------------------------

 


Type: Unknown
Device URI: lpd://BRW001FE1CA01C1/BINARY_P1



Type: Printer
Device URI: hp:/net/HP_LaserJet_300_colorMFP_M375nw?ip=192.168.0.22
error: Required plug-in status: Not installed
error: Unable to communicate with device (code=12): hp:/net/HP_LaserJet_300_colorMFP_M375nw?ip=192.168.0.22
error: unable to open channel
error: Communication status: Failed



Type: Fax
Device URI: hpfax:/net/HP_LaserJet_300_colorMFP_M375nw?ip=192.168.0.22
error: Required plug-in status: Not installed
error: Unable to communicate with device (code=12): hpfax:/net/HP_LaserJet_300_colorMFP_M375nw?ip=192.168.0.22
error: unable to open channel
error: Communication status: Failed


--------------
| PERMISSION |
--------------

 
-----------
| SUMMARY |
-----------

Missing Required Dependencies
-----------------------------
error: 'libcups2' package is missing/incompatible 
error: 'python3-pyqt4' package is missing/incompatible 
error: 'gtk2-engines-pixbuf' package is missing/incompatible 

Missing Optional Dependencies
-----------------------------
error: 'python3-dbus.mainloop.qt' package is missing/incompatible 

Plug-in Status
--------------
error: Plug-ins need to be installed

Total Errors: 7
Total Warnings: 0


Done.

Hors ligne

#47 Le 12/10/2021, à 18:17

ylag

Re : Imprimante HP pro m479fdw - 16.4 LTS vers 20.4 LTS

Regarde le résultat de la commande :

apt list ?obsolete

...si ça retourne une liste conséquente de paquets, dits «orphelins», serait alors bon de le signaler dans l'autre discussion pour voir ce qu'en penserait @abelthorne.

Hors ligne

#48 Le 12/10/2021, à 18:21

ylag

Re : Imprimante HP pro m479fdw - 16.4 LTS vers 20.4 LTS

Bonsoir,

Au message #46, il semble que le greffon propriétaire (requis dans ton cas...) ne soit pas installé ?

Plugins are not installed. Could not access file: No such file or directory

Est-ce que l'imprimante était en ligne, à l'adresse IP 192.168.0.22 lorsque tu as passé le hp-check ?

Type: Printer
Device URI: hp:/net/HP_LaserJet_300_colorMFP_M375nw?ip=192.168.0.22
error: Required plug-in status: Not installed
error: Unable to communicate with device (code=12): hp:/net/HP_LaserJet_300_colorMFP_M375nw?ip=192.168.0.22
error: unable to open channel
error: Communication status: Failed

J'y crois moyennement, mais si possible avec l'appareil branché au réseau, IP 192.168.0.22, essayer :

hp-plugin -ig

...l'option « g » est pour activer le mode «debug», pour peut-être tirer des infos pertinentes de la tentative d'installation du greffon ?

A+

Dernière modification par ylag (Le 12/10/2021, à 18:28)

Hors ligne

#49 Le 12/10/2021, à 19:01

arvernes

Re : Imprimante HP pro m479fdw - 16.4 LTS vers 20.4 LTS

Comme je le disais, les imprimantes qui apparaissent dans le message précédent sont les imprimantes que j'avais installées il y a plusieurs années. Ces imprimantes ont été configurées sur d'autres réseaux. Là où je suis en ce moment, c'est un autre réseau et mon imprimante HP est bien branchée, elle a comme adresse IP 192.168.1.22. J'ai essayé de l'installer, mais je n'y arrive pas, donc c'est sans doute normal qu'on ne la voit pas dans la commande. Là encore, comme je le disais, je vois dans "Parametres - Imprimantes" mes 3 imprimantes (Une brother, une HP et aussi le support Fax pour la HP), et parfois, j'ai une 4 ème qui apparaît, c'est celle que j'essaie d'installer. Elle apparaît et disparaît, comme une imprimante fantôme (??). Quand je la vois, j'essaie de la supprimer pour pouvoir la réinstaller, mais elle réapparait avant même que j'ai quitté cet écran Imprimante. Pendant que j'écris ce message, je la vois HP_Color_LaserJet_Pro_M478f_9f_D68EE1_ prête, et pourtant la commande hp-check ne la voit pas.

la commande

apt list ?obsolete

ne me renvoie que 6 ou 7 paquets dont j'ai besoin, notamment des fichiers qui avaient été installés par le script pour ma Brother.

J'ai essayé d'installer cette imprimante, et voilà les commandes et le résultat :-(

$ hp-setup -i 192.168.1.22

HP Linux Imaging and Printing System (ver. 3.20.3)
Printer/Fax Setup Utility ver. 9.0

Copyright (c) 2001-18 HP Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

(Note: Defaults for each question are maked with a '*'. Press <enter> to accept the default.)

 
--------------------------------
| SELECT CONNECTION (I/O) TYPE |
--------------------------------

  Num       Connection  Description                                               
            Type                                                                  
  --------  ----------  ----------------------------------------------------------
  0*        usb         Universal Serial Bus (USB)                                
  1         net         Network/Ethernet/Wireless (direct connection or JetDirect)

Enter number 0...1 for connection type (q=quit, enter=usb*) ? 1

Using connection type: net

error: No device selected/specified or that supports this functionality.
francois@monpc:~$ ping 192.168.1.22
PING 192.168.1.22 (192.168.1.22) 56(84) bytes of data.
64 octets de 192.168.1.22 : icmp_seq=1 ttl=64 temps=0.061 ms
64 octets de 192.168.1.22 : icmp_seq=2 ttl=64 temps=0.072 ms
64 octets de 192.168.1.22 : icmp_seq=3 ttl=64 temps=0.059 ms
^C
--- statistiques ping 192.168.1.22 ---
3 paquets transmis, 3 reçus, 0 % paquets perdus, temps 2050 ms
rtt min/avg/max/mdev = 0.059/0.064/0.072/0.005 ms

Hors ligne

#50 Le 12/10/2021, à 19:14

arvernes

Re : Imprimante HP pro m479fdw - 16.4 LTS vers 20.4 LTS

je ne sais pas pourquoi lorsque j'ai lancé la comme "hp-check " comme je le disais au dessus, j'ai eu ce message à propos de CUPS

-------------------------
| External Dependencies |
-------------------------

 error: cups          CUPS - Common Unix Printing System                           REQUIRED        1.1             -               INCOMPAT   'CUPS may not be installed or not running'
 

Ensuite j'ai ça toujours avec la même commande :

Missing Required Dependencies
-----------------------------
error: 'libcups2' package is missing/incompatible 
error: 'python3-pyqt4' package is missing/incompatible 
error: 'gtk2-engines-pixbuf' package is missing/incompatible 

lorsque je regarde libcups2 ce fichier est bien installé, d'après synaptic. J'ia même libcups2-dev qui est installé.
python3-pyqt4, je ne le trouve pas dans synaptic
gtk2-engines-pixbuf est pourtant installé là encore d'après synaptic.

Hors ligne