Contenu | Rechercher | Menus

Annonce

DVD, clés USB et t-shirts Ubuntu-fr disponibles sur la boutique En Vente Libre

Si vous avez des soucis pour rester connecté, déconnectez-vous puis reconnectez-vous depuis ce lien en cochant la case
Me connecter automatiquement lors de mes prochaines visites.

À propos de l'équipe du forum.

#1 Le 09/08/2022, à 15:18

jokoko

Pas de démarrage de l'interface

Bonjour,

Je suis sous Ubuntu Studio 22.04 avec KDE/Plasma et (a priori) SDDM comme 'display-manager'
Depuis aujourd'hui je n'arrive plus à démarrer ma session.
J'ai d'abord eu un premier démarrage qui est resté bloqué sur une suite d'erreurs : "ACPI error" & "mtd device must be supplied"
J'ai d'abord pensé à un problème d'espace disque (j'ai assez peu d'espace et j'ai souvent rencontré ce problème au démarrage par le passé), j'ai donc décidé de faire un peu de place, en mode recovery avec l'outil "clean" puis en ligne de commande en me promenant dans mon dossier utilisateur... Mais ça n'a pas suffit.
J'ai tout de même ensuite eu accès à l'étape de démarrage suivante à savoir le login en ligne de commande (sur tty1) -> je me dis que ça n'est probablement pas du tout la conséquence de la manipulation de nettoyage précédente?
Une rapide recherche de "ACPI error" m'a orienté vers un problème de drivers graphiques (qui avaient pourtant bien marché jusque là et pour lesquels je ne me souviens pas d'avoir fait de mises à jours...). J'ai donc rajouté "modprobe.blacklist=nouveau" dans les paramètres du grub. Mais ça n'a rien changé.

J'ai ensuite cherché à lancer mon display manager manuellement, via la commande :

systemctl start sddm.service

J'ai alors eu un retour m'indiquant qu'il était "masked"
J'ai trouvé sur un forum une commande qui proposait de le démasquer via

systemctl unmask sddm.service

ça m'a renvoyé un retour pas très rassurant du type "sddm.service deleted"

Bref, quelque chose cloche dans le démarrage de ma session mais je suis un peu perdu et je ne sais pas trop ou donner de la tête pour réussir à rétablir les choses...

Merci pour votre aide.

PS: Je ne suis pas sûr de poster dans le bonne catégorie car je ne comprends pas du tout l'origine du problème, mais vu que ce que je constate c'est que mon interface graphique KDE ne démarre pas, je tente dans cette section ;-)

Dernière modification par jokoko (Le 10/08/2022, à 12:36)

Hors ligne

#2 Le 09/08/2022, à 15:42

xubu1957

Re : Pas de démarrage de l'interface

Bonjour,

Tu avais trouvé une solution pour problème avec Wayland ?


Conseils pour les nouveaux demandeurs et pas qu'eux
Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.                   Membre de Linux-Azur

En ligne

#3 Le 09/08/2022, à 15:57

jokoko

Re : Pas de démarrage de l'interface

xubu1957 a écrit :

Bonjour,

Tu avais trouvé une solution pour problème avec Wayland ?

Non pas du tout.
C'était avec Ubuntu Studio 20.04
En faite, le problème est que je n'arrivais plus à faire fonctionner mon accélération graphique sur cette installation, donc j'ai profité de l'arrivé de Ubuntu Studio 22.04 pour faire une 2e installation à côté (et ainsi être sûr de garder mon travail, -notamment sous Ardour- encore accessible).
Et jusque là, l'accélération graphique avec la 22.04 tournait sans problème, je pouvais donc faire tourner Da Vinci Resolve pour le montage vidéo et Ardour pour les nouveaux projets tout en gardant encore sous la main les ancien travaux de l'installation 20.04
Mais là avec le problème que je décris je n'y ai plus accès, mais j'ai toujours accès à mon installation 20.04, d'où je vous écris d'ailleurs, mais qui est en train de devenir obsolète (et dont le problème n'a jamais été résolu...).

Hors ligne

#4 Le 09/08/2022, à 16:02

xubu1957

Re : Pas de démarrage de l'interface

Montre :

df -Th

Conseils pour les nouveaux demandeurs et pas qu'eux
Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.                   Membre de Linux-Azur

En ligne

#5 Le 09/08/2022, à 16:26

jokoko

Re : Pas de démarrage de l'interface

xubu1957 a écrit :

Montre :

df -Th

Donne :

Sys. de fichiers Type     Taille Utilisé Dispo Uti% Monté sur
tmpfs            tmpfs      1,6G    1,7M  1,6G   1% /run
/dev/nvme0n1p3   ext4       169G    125G   35G  79% /
tmpfs            tmpfs      7,8G       0  7,8G   0% /dev/shm
tmpfs            tmpfs      5,0M    4,0K  5,0M   1% /run/lock
/dev/nvme0n1p1   vfat       511M    5,3M  506M   2% /boot/efi
tmpfs            tmpfs      1,6G     40K  1,6G   1% /run/user/1000

Hors ligne

#6 Le 09/08/2022, à 16:33

xubu1957

Re : Pas de démarrage de l'interface

Montre aussi d'éventuels paquets cassés :

dpkg -l | grep -v ^ii

et :

snap list --all

Conseils pour les nouveaux demandeurs et pas qu'eux
Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.                   Membre de Linux-Azur

En ligne

#7 Le 09/08/2022, à 20:07

jokoko

Re : Pas de démarrage de l'interface

xubu1957 a écrit :

Montre aussi d'éventuels paquets cassés :

dpkg -l | grep -v ^ii

et :

snap list --all

OK, alors le problème que j'ai c'est pour récupérer le log, car je n'ai pas accès a la partition 22.04 depuis 20.04
Mais le retour de dkpg -l me donne une longe liste d'applications et services installés toujours commençant par "rc" puis' lenomdel'app' 'sa version' 'la mention "all" ou "amd64"' et enfin une description
Je vois rien qui semble indiquer des paquets cassés ici.
Pareil pour snap list, là j'ai une liste d'une 10aine d'applications, avec nom, version, un numéro " rev" un tracking (tous latest/stable), le publisher (canonical ou mozilla) et des notes: base, disabled, snapd ou -

Je suis désolé pour cette réponse peu claire mais là j'vais avoir du mal a faire mieux pour l'instant, si tu penses que ça serait bien de regarder de plus prêt tout ça je peux voir pour uploader des photos (mais tu t'en doutes, c'est un peu galère...)

Hors ligne

#8 Le 09/08/2022, à 20:10

xubu1957

Re : Pas de démarrage de l'interface

C'était pour gagner de la place !

1) Pour nettoyer les fichiers de configuration devenus sans objets et marqués "rc", et uniquement ces fichiers, exécute :

Le 22/07/2020, nany a écrit :
dpkg -l | awk '/^rc/ && !/sql/{print $2}' | xargs -r sudo dpkg -P

Pour info, les précisions de nany, pour la commande de nettoyage

2) Nettoyage des snaps désactivés :

snap list --all | awk '/désactivé|disabled/{print $1, $3}' | while read snapname revision; do sudo snap remove "$snapname" --revision="$revision"; done

stockée dans > |RESOLU] snap nettoyage des versions désactivées.


Conseils pour les nouveaux demandeurs et pas qu'eux
Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.                   Membre de Linux-Azur

En ligne

#9 Le 09/08/2022, à 21:27

jokoko

Re : Pas de démarrage de l'interface

OK, alors les commande de purge des fichier de conf marqués rc et des snap désactivé ont marché (j'ai testé avec les commandes précédantes).
Mais au démarrage j'ai toujours le login en ligne de commande.
J'ai essayé de lancer manuellement une interface (en testant : sddm.vervice, gdm.service, lightdm.service) avec :

systemctl start sddm.service

Mais à chaque fois j'ai :

Unit sddm.service not found.

Hors ligne

#10 Le 09/08/2022, à 21:35

xubu1957

Re : Pas de démarrage de l'interface

Pour sddm, je laisse répondre des utilisateurs.


Conseils pour les nouveaux demandeurs et pas qu'eux
Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.                   Membre de Linux-Azur

En ligne

#11 Le 10/08/2022, à 10:35

jokoko

Re : Pas de démarrage de l'interface

Ok, sinon pour ma part j'ai continué à essayer de démarrer le serveur graphique.
J'ai donc essayé les commandes :

X

-> ça me donne un écran noir......... ctrl + alt + f4 pour revenir à la console.

sudo init 5
[   43.451890]mtd device must be supplied (device name is empty)

("init 5" sans "sudo" me renvoi un "permission denied")


Et

xinit

->il me propose de l'installer via "apt install"


Si jamais ça peut aider...
Voilà, si vous avez d'autres idées de commandes pour essayer de lancer une session graphique, je suis preneur, d'autant que même si je résous pas tout de suite le démarrage automatique sur la session, je vais commencer à avoir besoin d'y accéder...

EDIT :
Et pour info, mon système est installé sur un SSD NVMe.

EDIT2: j'ai changé le titre du topic parce que je me rend compte que je suis vraiment pas sûr de l'origine du problème.
Tout ce que je constate c'est que je suis bloqué au login en shell...
Et SDDM était 'masked' quand j'ai essayé de le lancer les 1eres fois, et après avoir essayer de le 'unmask' ça m'a dit 'sddm deleted', et depuis il a pas l'air de le reconnaitre plus que ça, donc je préfère être plus large dans la description

Dernière modification par jokoko (Le 10/08/2022, à 12:35)

Hors ligne

#12 Le 10/08/2022, à 14:00

xubu1957

Re : Pas de démarrage de l'interface

Bonjour,

Quelle carte graphique :

lspci -vnn | grep -A 12 '\''[030[02]\]' | grep -Ei "vga|3d|display|kernel"

?


Conseils pour les nouveaux demandeurs et pas qu'eux
Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.                   Membre de Linux-Azur

En ligne

#13 Le 10/08/2022, à 14:55

jokoko

Re : Pas de démarrage de l'interface

xubu1957 a écrit :

Bonjour,

Quelle carte graphique :

lspci -vnn | grep -A 12 '\''[030[02]\]' | grep -Ei "vga|3d|display|kernel"

?

01:00.0 VGA compatible controller [0300] : NVIDIA Corporation GP108 [GeForce GT 1030] [10de:1d01] (rev a1) (prog-if 00 [VGA controller])
Kernel modules: nvidiafb, nouveau

Hors ligne

#14 Le 11/08/2022, à 11:44

xubu1957

Re : Pas de démarrage de l'interface

Bonjour,

Montre :

ubuntu-drivers devices

Conseils pour les nouveaux demandeurs et pas qu'eux
Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.                   Membre de Linux-Azur

En ligne

#15 Le 11/08/2022, à 13:34

jokoko

Re : Pas de démarrage de l'interface

xubu1957 a écrit :

Bonjour,

Montre :

ubuntu-drivers devices

Bonjour,

Alors il me propose d'installer le paquet ubuntu-drivers-common, mais ma connection wifi n'est pas fonctionnelle. j'ai essayé quelques manip' avec iwconfig pour corriger ça mais, je n'y arrive pas...

Hors ligne

#16 Le 11/08/2022, à 13:37

xubu1957

Re : Pas de démarrage de l'interface

Pas de smartphone ?

Voir > Connexion de secours - partage de connexion avec un smartphone, si tu ne peux pas brancher l'ordi en filaire.

Et pas de pilote pour ta carte nvidia ?

Dernière modification par xubu1957 (Le 11/08/2022, à 13:40)


Conseils pour les nouveaux demandeurs et pas qu'eux
Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.                   Membre de Linux-Azur

En ligne

#17 Le 11/08/2022, à 16:27

jokoko

Re : Pas de démarrage de l'interface

Habile!

Donc, une fois ubuntu-drivers-common installé, voici ce que j'obtiens

ubuntu-drivers devices
modalias : pci:v000010DEd00001D01sv00001043sd000085F5bc03sc00i00
vendor : NVIDIA Corporation
model : GP108 [GeForce GT 1030}
driver : nvidia-driver-418-server - distro non-free
driver : nvidia-driver-450-server - distro non-free
driver : nvidia-driver-390 - distro non-free
driver : nvidia-driver-510 - distro non-free
driver : nvidia-driver-515 - distro non-free
driver : nvidia-driver-470 - distro non-free
driver : nvidia-driver-470-server - distro non-free
driver : nvidia-driver-510-server - distro non-free
driver : nvidia-driver-515-server - distro non-free
driver : xserver-xorg-video-nouveau - distro free builtin

Mais il me semble que j'ai les drivers 510 d'installés, qui jusqu'ici ne m'avaient posés aucun soucis. J'espère que c'est pas encore un problème avec les drivers, comme lors de mon précédent topic non résolu sur wayland...

Hors ligne

#18 Le 11/08/2022, à 16:33

xubu1957

Re : Pas de démarrage de l'interface

Montre :

dpkg -l | grep nvidia

Dernière modification par xubu1957 (Le 11/08/2022, à 16:33)


Conseils pour les nouveaux demandeurs et pas qu'eux
Important : Pensez à passer vos sujets en [Résolu] lorsque ceux-ci le sont, au début du titre en cliquant sur Modifier sous le premier message, et un bref récapitulatif de la solution à la fin de celui-ci. Merci.                   Membre de Linux-Azur

En ligne

#19 Le 11/08/2022, à 17:33

jokoko

Re : Pas de démarrage de l'interface

xubu1957 a écrit :

Montre :

dpkg -l | grep nvidia
ii  libnvidia-cfg1-510:amd64                      510.73.05-0ubuntu0.22.04.1              amd64        NVIDIA binary OpenGL/GLX configuration library
ii  libnvidia-common-510                          510.85.02-0ubuntu0.22.04.1              all          Shared files used by the NVIDIA libraries
ii  libnvidia-compute-510:amd64                   510.73.05-0ubuntu0.22.04.1              amd64        NVIDIA libcompute package
ii  libnvidia-compute-510:i386                    510.73.05-0ubuntu0.22.04.1              i386         NVIDIA libcompute package
ii  libnvidia-decode-510:amd64                    510.73.05-0ubuntu0.22.04.1              amd64        NVIDIA Video Decoding runtime libraries
ii  libnvidia-decode-510:i386                     510.73.05-0ubuntu0.22.04.1              i386         NVIDIA Video Decoding runtime libraries
ii  libnvidia-egl-wayland1:amd64                  1:1.1.9-1.1                             amd64        Wayland EGL External Platform library -- shared library
ii  libnvidia-encode-510:amd64                    510.73.05-0ubuntu0.22.04.1              amd64        NVENC Video Encoding runtime library
ii  libnvidia-encode-510:i386                     510.73.05-0ubuntu0.22.04.1              i386         NVENC Video Encoding runtime library
ii  libnvidia-extra-510:amd64                     510.73.05-0ubuntu0.22.04.1              amd64        Extra libraries for the NVIDIA driver
ii  libnvidia-fbc1-510:amd64                      510.73.05-0ubuntu0.22.04.1              amd64        NVIDIA OpenGL-based Framebuffer Capture runtime library
ii  libnvidia-fbc1-510:i386                       510.73.05-0ubuntu0.22.04.1              i386         NVIDIA OpenGL-based Framebuffer Capture runtime library
ii  libnvidia-gl-510:amd64                        510.73.05-0ubuntu0.22.04.1              amd64        NVIDIA OpenGL/GLX/EGL/GLES GLVND libraries and Vulkan ICD
ii  libnvidia-gl-510:i386                         510.73.05-0ubuntu0.22.04.1              i386         NVIDIA OpenGL/GLX/EGL/GLES GLVND libraries and Vulkan ICD
ii  linux-modules-nvidia-510-5.15.0-41-lowlatency 5.15.0-41.44                            amd64        Linux kernel nvidia modules for version 5.15.0-41
ii  linux-modules-nvidia-510-lowlatency           5.15.0-41.44                            amd64        Extra drivers for nvidia-510 for the lowlatency flavour
ii  linux-objects-nvidia-510-5.15.0-41-lowlatency 5.15.0-41.44                            amd64        Linux kernel nvidia modules for version 5.15.0-41 (objects)
ii  linux-signatures-nvidia-5.15.0-41-lowlatency  5.15.0-41.44                            amd64        Linux kernel signatures for nvidia modules for version 5.15.0-41-lowlatency
ii  nvidia-compute-utils-510                      510.73.05-0ubuntu0.22.04.1              amd64        NVIDIA compute utilities
ii  nvidia-driver-510                             510.73.05-0ubuntu0.22.04.1              amd64        NVIDIA driver metapackage
ii  nvidia-kernel-common-510                      510.73.05-0ubuntu0.22.04.1              amd64        Shared files used with the kernel module
ii  nvidia-kernel-source-510                      510.73.05-0ubuntu0.22.04.1              amd64        NVIDIA kernel source package
ii  nvidia-prime                                  0.8.17.1                                all          Tools to enable NVIDIA's Prime
ii  nvidia-settings                               510.47.03-0ubuntu1                      amd64        Tool for configuring the NVIDIA graphics driver
ii  nvidia-utils-510                              510.73.05-0ubuntu0.22.04.1              amd64        NVIDIA driver support binaries
ii  screen-resolution-extra                       0.18.2                                  all          Extension for the nvidia-settings control panel
ii  xserver-xorg-video-nvidia-510                 510.73.05-0ubuntu0.22.04.1              amd64        NVIDIA binary Xorg driver

Et finalement j'arrive à récupérer les sorties commandes dans des fichiers textes, donc bcp plus pratique ;-)

Hors ligne